NC Error Messages
NC Error Messages

NC Error Messages

TNC7
TNC7 basic
TNC 640
TNC 620
TNC 320
TNC 128
CNC PILOT 640
MANUALplus 620
NC Software
xxxxxx-18
10/2023
NC Error Messages
Version English (en)


NC Error Messages
NC Error Messages

NC Error Messages

Valid for:

81762x-18, 34059x-18, 81760x-18, 77185x-18, 77184x-18, 68894x-18, 54843x-18

Release:

10/2023

Copyright © 2023 DR. JOHANNES HEIDENHAIN GmbH. All rights reserved.


Error description 120-0006

Error message

Configuration of soft key not readable

Cause of error

The specified soft key is not contained in the configuration data.

Error correction

Check the configuration data.


Error description 120-0007

Error message

Configuration of layer not readable

Cause of error

The configured soft-key row (layer) canot be read.

Error correction

Check the configuration data.


Error description 120-0008

Error message

Cycle or query %1 unknown

Cause of error

The specified cycle or cycle dialog was not found in the configuration data.

Error correction

Check the configuration data.


Error description 120-000A

Error message

Cannot generate menu

Cause of error

Software problem in the user interface

Error correction

Inform your service agency.


Error description 120-000B

Error message

Q Parameter %1: Cannot read or write value

Cause of error

Software problem in the user interface

Error correction

Inform your service agency.


Error description 120-000C

Error message

Soft-key group without first element

Cause of error

In the configuration data a soft-key group is specified, but no soft key is marked as "first."

Error correction

Edit the configuration data.


Error description 120-000D

Error message

Soft-key type is not supported

Cause of error

An illegal soft-key type was used within a cycle dialog.

Error correction

Edit the configuraiton data.


Error description 120-000E

Error message

Invalid resource ID

Cause of error

Software problem in the user interface

Error correction

Inform your service agency.


Error description 120-000F

Error message

Invalid configuration data for cycle

Cause of error

Too many soft keys defined in a cycle dialog

Error correction

Inform your service agency.


Error description 120-0013

Error message

Error in the user interface

Cause of error

Software problem in the user interface.

Error correction

Inform your service agency.


Error description 120-0016

Error message

Cause of error

Internal software error with front end/dialogs.

Error correction

Inform your service agency.


Error description 120-001E

Error message

Can't connect to network: %1 %2 %3

Cause of error

Unable to connect with a network drive defined in the network management.

Error correction

- Use the program manager to open the network management (NETWORK soft key)
- Press the MOD key and enter the network code number NET123.
- Enter all required data for the network connection (DEFINE NETWORK CONNECTN. soft key).
- Check the correctness and spelling of the input data for the network connection


Error description 120-001F

Error message

File '%1' not found

Cause of error

A required file could not be found at the specified location.

Error correction

Check the spelling of the path and file name, for example. If possible, copy the file to the required directory.


Error description 120-0027

Error message

Unable to open configuration server queue

Cause of error

Error in the system-inherent communication.

Error correction

Inform your service agency.


Error description 120-0028

Error message

Unable to read configuration data '%1'

Cause of error

Error in the system-inherent communication.

Error correction

Inform your service agency.


Error description 120-002E

Error message

Path '%1' not found

Cause of error

A required drive or directory was not found.

Error correction

Check the spelling of the path.


Error description 120-0041

Error message

No files available for online help (*.CHM)

Cause of error

No context-sensitive help can be displayed because no files are available for the *.CHM online help.
You have to download the *.CHM files from the HEIDENHAIN Homepage and save them on the control in the subfolder for your language. Note the information in the User's Manual.

Error correction

- Download the help files from the HEIDENHAIN homepage (www.heidenhain.de):
> www.heidenhain.de > Documentation and information > User's documentation
- Unpack the ZIP file and transfer the *.CHM files to the control


Error description 125-0067

Error message

Error when saving the screen content in the file %1

Cause of error

There was an error when saving the screen content in the file.

Error correction

Delete all unneeded files to increase memory capacity, or inform the service agency for your control.


Error description 125-0068

Error message

Source file %1 not found

Cause of error

A file in the list of example files cannot be addressed as source

Error correction

Inform your service agency


Error description 125-0069

Error message

Example file %1 could not be copied. Error code %2

Cause of error

A file in the list of example files could not be copied

Error correction

Inform your service agency


Error description 125-006A

Error message

List for copying the example files not available %1

Cause of error

The file containing the list of example files is not available

Error correction

Inform your service agency


Error description 125-006C

Error message

Error during software update: %1

Cause of error

Error correction


Error description 125-006D

Error message

The update rules are not fulfilled

Cause of error

One or more update rules were not complied with.

Error correction

Inform your machine tool builder


Error description 125-006E

Error message

Update file invalid or does not exist

Cause of error

The update file was not found or it does not contain a valid update.

Error correction

Inform your machine tool builder


Error description 125-006F

Error message

Checksum error during update

Cause of error

The checksums do not match the update files.

Error correction

Inform your machine tool builder


Error description 125-0070

Error message

Invalid signature entry during update

Cause of error

An invalid signature entry was found in the update file.

Error correction

Inform your machine tool builder


Error description 125-0071

Error message

Not enough memory. Update not possible.

Cause of error

There is not enough free memory on the data medium to save the update there.

Error correction

Vacate some memory space


Error description 125-0072

Error message

Backup file not found

Cause of error

During the software update, the control automatically makes a backup file for restoring the previous software level. The backup file was not found on the data medium.

Error correction

Change to the directory in which the backup file was saved.


Error description 125-0075

Error message

ZIP file contains no control setup

Cause of error

A .zip file was selected for the software update that does not contain any setup files for the control.

Error correction

- Check the .zip file


Error description 125-00D2

Error message

Unable to write configuration data '%1'

Cause of error

Error in the system-inherent communication.

Error correction

Inform your service agency.


Error description 125-00D4

Error message

In the configuration data, no operating times are
released for editing.

Cause of error

Although the code number was entered correctly, the operating times cannot be edited because all fields of the operating times locked against editing in the configuration data.

Error correction

Release the required fields in the configuration data.


Error description 125-0117

Error message

The connection list is full

Cause of error

The maximum number of configurable connections has been reached.

Error correction

Please delete a connection before you add another one.


Error description 125-011F

Error message

Connection setup to DNC not possible

Cause of error

Cannot connect with the DNC.


Error description 125-0120

Error message

TeleService request is in error

Cause of error

Unable to send TeleService request.

Error correction

Check the network connections and retry.


Error description 125-0121

Error message

TeleService request is in error

Cause of error

The machine parameter for TeleService is improperly configured.

Error correction

The machine parameter for TeleService, "CfgServiceRequest," must be correctly configured.


Error description 125-0149

Error message

Traverse limits were not adopted.

Cause of error

The input for one or more traverse ranges could not be loaded.
Possible cause:
Value range for modulo axis was entered to be greater than 360°
- An NC program is being run

Error correction

- Adapt the input values and load them again
- Load the traverse limits again after program run


Error description 125-014A

Error message

Input not in effect

Cause of error

The input was not accepted. Possible causes:
- You have entered an illegal character. The following characters are allowed: 1234567890.-
- You have entered too many characters before or after the decimal separator.

Error correction

Check and correct the entered values.


Error description 125-014B

Error message

Kinematic model was not switched over

Cause of error

The kinematic model was not selected. Possible causes:
- An NC program is being run
- Tilting of the working plane is active (3D ROT soft key, PLANE function, Cycle 19)
- The kinematic model is faulty

Error correction

- Switch the kinematics again after program run
- Deactivate the "Tilt Working Plane" function:
- Use the 3D ROT soft key to set manual tilting to inactive, or
- Use the PLANE function or Cycle 19 to deactivate tilting under program control
- Inform your service agency


Error description 125-0163

Error message

Unit of measure was not switched

Cause of error

The unit of measure for the position display could not be changed.
Possible cause:
- An NC program is being processed

Error correction

- Switch the unit of measure again after program run


Error description 126-0072

Error message

Error during self-test

Cause of error

An invalid message was received during the self test.

Error correction

Inform your service agency


Error description 126-0075

Error message

Error during self-test

Cause of error

An error occurred during the self test.

Error correction

- Check the emergency-stop circuits -ES.A and -ES.B for correct wiring and proper function
- Inform your service agency.


Error description 126-0076

Error message

Error during self test

Cause of error

An error occurred during the self test.

Error correction

- Check the emergency-stop circuits -ES.A and -ES.B for correct wiring and proper function
- Inform your service agency


Error description 126-007F

Error message

Self-test cannot be started

Cause of error

Before the self-test (emergency stop test), an error occurred that prevents the test from starting:
- Emergency stop error has occurred
- Emergency stop button was pressed
- Emergency-stop circuit is defective
- Internal temperature of an HSCI component is too high
- Internal temperature of an HSCI component is too low
- The fan of an HSCI component is defective
- The power supply to the component is missing, too low or too high
- HSCI cabling is missing or defective

Error correction

- Note further messages.
- Use the HSCI bus diagnostics to find out which components are reporting an error
- Check the emergency-stop circuit
- Check the power supply to the affected HSCI components
- Check the HSCI cabling
- If necessary, exchange the HSCI component
- Generate the service files and inform your service agency


Error description 126-010F

Error message

The CC only runs with 500 MHz

Cause of error

IThere is at least one CC controller unit in the system that is clocked only with 500 MHz. This results in performance problems in combination with the use of adaptive control functions.

Error correction

- Check the CCs and exchange them if required.
- Contact your machine tool builder


Error description 126-0110

Error message

NC software not released for FS applications

Cause of error

- The control system (hardware) was detected as a system with functional safety (FS) from HEIDENHAIN. However, the installed NC software has not been approved for applications that use integrated functional safety (FS) from HEIDENHAIN.
- The installed software is a test software or an NC software that has not been released for the application of integrated functional safety (FS)

Error correction

- Install an NC software version of your control that has been approved for applications with integrated functional safety (FS) from HEIDENHAIN.
- Inform your service agency.


Error description 126-0111

Error message

Too many switch-off ports defined

Cause of error

In the IOC file, more than one output was defined for switching the machine off after shutdown. This is not allowed. No more that one output can be defined.

Error correction

- Check the IO configuration and correct it if required


Error description 126-0112

Error message

Switch-off port on incorrect bus system

Cause of error

The output for switching off the machine after the control shutdown was defined for the wrong bus system. The permitted bus systems are external PL assemblies with HSCI interface or internal PL assemblies.

Error correction

- Check the IO configuration and correct it if required


Error description 126-0113

Error message

PLC output for shutdown has multiple definitions

Cause of error

A PLC output for shutting down the control (switch-off port) is defined both in the IOC file as well as in the configuration data (machine parameters).
Note that the entry in the configuration data has priority.

Error correction

- Check the IO configuration.
- Check the configuration datum DisplaySettings->CfgShutdown (Maschinen-Parameternummer 101600)
- Inform your service agency


Error description 126-0114

Error message

Automatic switch-off not possible

Cause of error

Machine switch-off after control shutdown cannot be activated because the IO configuration does not match the actual hardware configuration.
- The control will be operated in simulation mode
- The IOC file does not match the hardware configuration
- The options in the configuration are incorrectly set.

Error correction

- Check the hardware configuration
- Check the IO configuration
- Check the options
- Inform your service agency


Error description 126-0115

Error message

PLC output for switch-off is improperly defined

Cause of error

The output for switching off the machine after the control has been shutdown was incorrectly configured.
- An output on the internal PL was addressed (e.g. with UEC, UMC), although no internal PL exists.
- The address of the output is outside of the permissible range O0 to O30.

Error correction

Check the configuration data (machine parameter number 101600).


Error description 126-0116

Error message

PLC output for switch-off is improperly configured

Cause of error

The PLC output for switching off the machine after the control has been shutdown was incorrectly configured.
- An output on an HSCI device was address, although not device is connected to the control over HSCI.
- The addressed HSCI device is not a PL.
- The addressed output does not exist on the PL.

Error correction

- Check the configuration data (machine parameter number 101600)
- Inform your service agency


Error description 126-0117

Error message

PLC output for switch-off is improperly configured

Cause of error

The PLC output for switching off the machine after the control has been shutdown was incorrectly configured.
The settings in the configuration datum CfgShutdown are not applicable for an integrated PL (e.g. with UEC, UMC) nor for a PL connected over HSCI (e.g. PLB 62xx).
Settings for output on internal PL:
- powerOffDevice: Unassigned
- powerOffSlot: Unassigned
- powerOffPort: Number of the output on internal PL (value range: 0 to 30)
Settings for output on a PL connected over HSCI:
- powerOffDevice: Bus address of the PL
- powerOffSlot: Slot number of the module (0 for system module and UEC11x)
- powerOffPort: Number of the output to be switched

Error correction

- Check the configuration data (machine parameter number 101600)
- Inform your service agency


Error description 126-0118

Error message

PLC output for switch-off is improperly configured

Cause of error

Automatic machine switch-off after control shutdown has been selected. However, no PlC output was defined for it in the configuration file nor in the IOC file.

Error correction

- Define a PLC output for switch-off in the IOC file or in the configuration file
- Inform your service agency


Error description 126-0119

Error message

Key name %1 for OEM script is too long

Cause of error

- The key name used for Python script to be started during start-up is too long. Maximum of 10 characters allowed.

Error correction

- Change the configuration datum


Error description 126-011A

Error message

Hardware combination not permitted

Cause of error

The detected hardware configuration includes an impermissible combination of CC or PL components.
Examples:
- CC 6106 and CC 306
- CC 306 and UEC 112
- CC 306 and older PLB, MB, or TE (not "Gen 3 ready" or not "Gen 3 exclusive")

Error correction

- Reconfigure the hardware
- Inform your machine tool builder


Error description 126-011B

Error message

Self-test error was not detected on %2 with HSCI address %3

Cause of error

During the device self-test, an expected message was not received.

Error correction

- Check all cable connections from and to this device
- Check the device and, if necessary, exchange it
- Inform your service agency


Error description 126-011C

Error message

No reaction during self-test on %2 with HSCI address %3

Cause of error

During the device self-test, an expected message was not received.

Error correction

- Check all cable connections from and to this device
- Check the device and, if necessary, exchange it
- Inform your service agency


Error description 126-011D

Error message

Self-test was not executed on %2 with HSCI address %3

Cause of error

During the device self-test, an expected message was not received.

Error correction

- Check all cable connections from and to this device
- Check the device and, if necessary, exchange it
- Inform your service agency


Error description 126-011E

Error message

Missing authorization

Cause of error

You do not have the right to execute the Commissioning mode (current controller adjustment / capturing the field angle).

Error correction

- Acquire the NC.SetupDrive right, for example by entering the password of an authorized user
- Then start the function again


Error description 126-011F

Error message

Safety not ensured

Cause of error

Configuration data relevant to safety functions of the system were changed and have not been accepted yet.

Error correction

Please pay attention to the following information about parameter sets in which configuration data was changed.
Perform an acceptance test of the functional safety for this system according to the guidelines of the OEM when the respective parameter sets are active.
Shut the system down; while doing so, confirm that the functional safety was successfully tested and accepted.


Error description 126-0120

Error message

Safe configuration data %1 changed

Cause of error

Configuration data relevant to safety functions of the system were changed in the indicated parameter set and have not been accepted yet.

Error correction

Perform an acceptance test of the functional safety for this system according to the guidelines of the OEM while the indicated parameter set is active.
Shut the system down; while doing so, confirm that the functional safety was successfully tested and accepted.


Error description 126-0129

Error message

Automatic switchover in simulation mode DriveSimul

Cause of error

The control was automatically switched to the "DriveSimul" simulation mode.
Possible causes:
- There is no controller unit (CC) in the system.
- Components of drive generation 3 with external safety are being used but without a PAE module.

Error correction

- Check the hardware components installed.
- Restart the control.
- Set the CfgMachineSimul/MP_simMode setting to "DriveSimul".
- Inform your service agency.


Error description 126-012A

Error message

Automatic switchover in simulation mode DriveAndEmStopSimul

Cause of error

The control was automatically switched to the "DriveAndEmStopSimul" simulation mode.
Possible cause:
- No system PL was detected

Error correction

- Check the hardware components installed
- Restart the control.
- Set the CfgMachineSimul/MP_simMode setting to "DriveAndEmStopSimul".
- Inform your service agency.


Error description 126-012B

Error message

Automatic switchover in simulation mode FullSimul

Cause of error

The control was automatically switched to the "FullSimul" simulation mode.
Possible causes:
- Neither a PL nor a machine operating panel was detected in the system.
- No devices were detected at the HSCI bus.
- The CfgMachineSimul/MP_simMode setting does not match the real hardware components installed.

Error correction

- Check the hardware components
- Check the HSCI cable connections
- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Restart the control.
- Set the CfgMachineSimul/simMode setting to "FullSimul"
- Inform your service agency


Error description 126-012E

Error message

Too many UM units connected to one CC: CC index %1

Cause of error

- Too many UM inverters are connected to the stated CC controller unit.
- For each CC, the maximum number of UM inverters (or motor connections) is limited to the number of axes possible on the CC.

Error correction

- Distribute the UM inverters over other CC controller units or adapt the configuration
- Remove UM inverters that aren't being used (or use one-axis modules instead of two-axis modules)
- Inform your service agency


Error description 126-012F

Error message

Component: %1 with serial number: %2 not planned in project

Cause of error

In a system with the Gen 3 generation of drives, all components connected to the HSCI bus and all power modules must be included in the IOconfig project.

Error correction

Add the missing component to your IOconfig project.


Error description 126-0130

Error message

Project planning with IOconfig incomplete

Cause of error

In a system with the Gen 3 drives, all components connected to the HSCI bus and all power modules must be included in the IOconfig project.

Error correction

Add the missing components in your IOconfig project, and restart the control.


Error description 126-0131

Error message

TNCdiag cannot be started

Cause of error

Internal error

Error correction

Inform your service agency


Error description 126-0132

Error message

Too many HSCI devices connected. Current: %1; permitted: %2

Cause of error

Too many devices are connected to the HSCI bus.

Error correction

- Modify the machine configuration in order to avoid exceeding the maximum number of HSCI participants
- Inform your machine manufacturer


Error description 126-0133

Error message

Too many CC/UxC devices connected. Current: %1; permitted: %2

Cause of error

Too many CC, UEC, or UMC units are connected to the HSCI bus.

Error correction

- Modify the machine configuration in order to avoid exceeding the maximum number of HSCI participants
- Inform your machine manufacturer


Error description 126-0134

Error message

Too many PLB/MB/TE/UxC devices connected. Current: %1; perm.: %2

Cause of error

Too many PLB, MB, TE, UEC, or UMC units are connected to the HSCI bus.

Error correction

- Modify the machine configuration in order to avoid exceeding the maximum number of HSCI participants
- Inform your machine manufacturer


Error description 126-0135

Error message

Too many MB/TE devices connected. Current: %1; permitted: %2

Cause of error

Too many MB or TE operating panels are connected to the HSCI bus.

Error correction

- Modify the machine configuration in order to avoid exceeding the maximum number of HSCI participants
- Inform your machine manufacturer


Error description 126-0136

Error message

Too many UVR devices connected. Current: %1; permitted: %2

Cause of error

Too many UVR devices are connected to the HSCI bus.

Error correction

- Modify the machine configuration in order to avoid exceeding the maximum number of HSCI participants
- Inform your machine manufacturer


Error description 126-0137

Error message

Too many I/O terminals present. Current: %1; permitted: %2

Cause of error

There are too many I/O terminals present on the PLB, MB, TE, UEC, or UMC units.
Functionally safe terminals count as one terminal.
Perhaps more terminals were detected than are actually present on the units. Some units contain internal terminals that are included in this count for technical reasons.

Error correction

- Modify the machine configuration in order to avoid exceeding the maximum number of terminals
- Inform your machine manufacturer


Error description 126-0138

Error message

The IOCP file for projecting the hardware was not loaded

Cause of error

The system could not load the IOCP file for projecting because
- the path name is not entered in the configuration data
- no file was found at the configured path
- the syntax in the file is bad

Error correction

- Check the configuration and the directory tree
- Install the correct file


Error description 126-0139

Error message

Projected HSCI device could not be assigned

Cause of error

The device projected in the IOCP file cannot be assigned to the device found under this HSCI address.
Possible causes:
- Error while loading the IOCP file
- Option for configuring the hardware expansion was set incorrectly
- Other device is connected
- Device not connected at that address, or is additionally connected
- Devices connected in different sequence

Error correction

- Check projection and the options in effect
- Check cabling of the HSCI chain
You can use the diagnostics functions of the control for this.


Error description 126-013A

Error message

Projected module of HSCI device could not be assigned

Cause of error

The module %1 projected for the HSCI device %2 does not match the module found at this slot.
Possible causes:
- Incorrect IOCP file loaded
- The option relevant for evaluating the projection was set incorrectly in the configuration
- Module not connected, or is additionally connected
- Other module is connected
- Modules connected in wrong sequence

Error correction

Check the projection and configuration of the associated options and connected modules.
You can use the diagnostics functions of the control for this.


Error description 130-0001

Error message

Processor check error

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-0002

Error message

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-0066

Error message

Cause of error

Arithmetical error. Value too small.

Error correction

Inform your service agency.


Error description 130-0067

Error message

Cause of error

Arithmetical error. Value too large.

Error correction

Inform your service agency.


Error description 130-0068

Error message

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-0069

Error message

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-006A

Error message

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-006B

Error message

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-006C

Error message

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-006D

Error message

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-006F

Error message

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-0070

Error message

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-0096

Error message

Cause of error

System error with cancellation of machining

Error correction

Inform your service agency.


Error description 130-0097

Error message

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-0098

Error message

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-0099

Error message

File access was successful

Cause of error

Information for the user that file access was successful.


Error description 130-009A

Error message

File system error

Cause of error

1.) The path name contains more than six subdirectories.
2.) The path name contains a directory or file name with more than 16 characters.
3.) The path name contains two or more file name extensions or a file extension with more that 3 characters.
4.) A system error occurred during file access.

Error correction

1.) and 2.) Save the file in another directory or under another, shorter name.
3.) Save the file with only one file name extension with no more than 3 characters.
4.) Inform your service agency.


Error description 130-009B

Error message

File not found

Cause of error

The named path has no file.

Error correction

Correct the given path name.


Error description 130-009C

Error message

Illegal file name

Cause of error

An invalid path name was given (e.g. a path name containing illegal characters).

Error correction

Correct the given path name.


Error description 130-009D

Error message

Too many files open

Cause of error

The file couldn't be opened because too many files are already opened. There is a limit to the number of simultaneously open files.

Error correction

Close the files that you no longer need.


Error description 130-009E

Error message

File access not possible

Cause of error

1.) Access to the file was denied.
2.) The file is already being written to by another application.

Error correction

1.) Check the access rights to the file and remove any existing write protection.
2.) Close the file in the application that has blocked access to the file.


Error description 130-009F

Error message

File access not possible

Cause of error

The file was opened only for reading and cannot be written to.

Error correction

Save the files under another name.


Error description 130-00A0

Error message

Directory could not be erased

Cause of error

The current directory cannot be deleted.

Error correction

Please select another directory first.


Error description 130-00A1

Error message

Further file entry impossible

Cause of error

The TNC cannot save any more files.

Error correction

Delete any files that you no longer need.


Error description 130-00A2

Error message

File access not possible

Cause of error

The drive doesn't allow positioning in the file, or the positioning is not at the begining of a line.

Error correction

Inform your service agency.


Error description 130-00A3

Error message

Drive not ready

Cause of error

Hardware error during file access.

Error correction

Check whether the device, e.g. a network adapter, is connected correctly.


Error description 130-00A4

Error message

File access not possible

Cause of error

The file is already in use by another application.

Error correction

Close the file in the application that has access to the file.


Error description 130-00A5

Error message

File access not possible

Cause of error

Access to a certain area of the file was blocked by another application.

Error correction

Close the file in the application that has blocked access to the file.


Error description 130-00A6

Error message

Further file entry impossible

Cause of error

The file could not be saved because the data medium is full.

Error correction

Delete unneeded files on the data medium.


Error description 130-00A7

Error message

Program incomplete

Cause of error

Unexpected end of file found.

Error correction

Ensure that the file is complete.


Error description 130-00A8

Error message

Directory access not possible

Cause of error

Access to the directory was denied.

Error correction

Check the access privileges to the file and, if required, cancel an existing write protection.


Error description 130-012C

Error message

Cause of error

The system is no longer consistent.

Error correction

Inform your service agency.


Error description 130-012D

Error message

Cause of error

The system cannot be started, since not all objects are available.

Error correction

Inform your service agency.


Error description 130-012E

Error message

Cause of error

The system cannot be started, since not all objects are available.

Error correction

Inform your service agency.


Error description 130-012F

Error message

Cause of error

The system cannot be started, since not all objects are available.

Error correction

Inform your service agency.


Error description 130-0130

Error message

Cause of error

Error in communication within the system

Error correction

Inform your service agency.


Error description 130-0131

Error message

Cause of error

The system cannot be started, since not all objects are available.

Error correction

Inform your service agency.


Error description 130-0132

Error message

Cause of error

The system cannot be started, since not all objects are available.

Error correction

Inform your service agency.


Error description 130-0133

Error message

Cause of error

The system cannot be started, since not all objects are available.

Error correction

Inform your service agency.


Error description 130-0134

Error message

Cause of error

The system cannot be started, since not all objects are available.

Error correction

Inform your service agency.


Error description 130-0135

Error message

Cause of error

The system cannot be started because not all objects are available.

Error correction

Inform your service agency.


Error description 130-0136

Error message

Cause of error

The system cannot be started because not all objects are available.

Error correction

Inform your service agency.


Error description 130-0137

Error message

Error: Unexpected end of process %1

Cause of error

A started process ended irregularly. Possible causes:
- Faulty script or error in implementation
- Memory assigned for script is exhausted
- Other system resources are exhausted

Error correction

- Check the log files of the script for clues. If required, edit the script.
- You might find further information in the log files of the control and the operating system.
- Increase the memory assigned for the script.


Error description 130-0190

Error message

ClientQueue (%1) could not be opened

Cause of error


Error description 130-0191

Error message

Log file could not be saved.

Cause of error

The log file could not be saved under the specified path/file name.

Error correction

Enter another path/file name for saving.


Error description 130-0192

Error message

ASSERTION: Consistency condition not fulfilled

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-0193

Error message

INFO: %1

Cause of error


Error description 130-0194

Error message

Cause of error

Error in communication within the system

Error correction

Inform your service agency.


Error description 130-0195

Error message

Cause of error

No further time job could be started.

Error correction

Inform your service agency.


Error description 130-0196

Error message

Cause of error

Not enough memory available.

Error correction

Inform your service agency.


Error description 130-0197

Error message

Invalid event class in the following error!

Cause of error

System error

Error correction

Inform your service agency.


Error description 130-0199

Error message

OEM error without additional information

Cause of error

Error text was not found.

Error correction

Enter the error text in the error-text file and/or save the error text file in the corresponding directory.


Error description 130-019A

Error message

Cycle error without additional information

Cause of error

Error text was not found.

Error correction

Enter the error text in the error-text file and/or save the error-text file in the corresponding directory.


Error description 130-019B

Error message

%1

Cause of error


Error description 130-019C

Error message

Saving service files...

Cause of error

Service files are being saved for diagnostic purposes.

Error correction

Inform your service agency.


Error description 130-019D

Error message

The error log could not be opened. NOTE: No error messages or info messages will be logged.

Cause of error

The log is write-protected.

Error correction

Remove the write protection, or rename or delete the log.


Error description 130-01A1

Error message

Error while saving the service file

Cause of error

An error occurred while saving the service files.

Error correction

Generate the service files again. If required, use the SAVE SERVICE FILES soft key.


Error description 130-01FA

Error message

Incorrect condition in switch statement

Cause of error


Error description 130-01FB

Error message

No acknowledgment from application %1

Cause of error

The application does not confirm closing the trace files for diagnostic purposes.

Error correction

No error correction possible.


Error description 130-01FC

Error message

System error

Cause of error

An as yet unimplemented function of a server was called.

Error correction

Inform your service agency


Error description 130-01FD

Error message

System error

Cause of error

A server cannot find the sender of a message.

Error correction

Inform your service agency


Error description 130-01FE

Error message

System error

Cause of error

A server cannot reach the sender of a message.

Error correction

Inform your service agency


Error description 130-01FF

Error message

System error

Cause of error

A software error has occurred.

Error correction

Inform your service agency


Error description 130-0200

Error message

Configuration datum %1 - %2
contains errors

Cause of error

The given configuration datum contains errors and was not accepted for control operation.

Error correction

Correct the given configuration data or inform your machine tool builder.


Error description 130-0201

Error message

Configuration datum %1 - %2
contains errors

Cause of error

The given configuration datum has errors. The erroneous values were replaced by default values.

Error correction

Correct the given configuration datum or inform your machine manufacturer.


Error description 130-0202

Error message

NC program cancelled

Cause of error

The NC program was cancelled because of an error.

Error correction

Note further error messages.
If no further error messages appear, inform your service agency.


Error description 130-03EE

Error message

File exists already

Cause of error

The file cannot be generated because a file with the same name already exists.

Error correction

Save the file under another name.


Error description 130-03EF

Error message

File access not possible

Cause of error

The file contains data in an illegible format.

Error correction

Select another file or inform your service agency.


Error description 130-03F0

Error message

Directory not found

Cause of error

The specified directory does not exist or was deleted.

Error correction

Select another directory.


Error description 130-03F1

Error message

Drive not found

Cause of error

The specified drive is not connected.

Error correction

Select another drive.


Error description 130-0414

Error message

Service files could not be saved

Cause of error

An error occurred while saving the service files.

Error correction

Try to save again. If required, restart the control beforehand.
Notify your service agency if the problem recurs.


Error description 130-0415

Error message

There is no online help for the error!

Cause of error


Error description 130-07D0

Error message

File not found: %1

Cause of error

The named path has no file.

Error correction

Correct the given path name.


Error description 130-07D1

Error message

Error when opening/closing a zip file (%1)

Cause of error

The TNC was not able to create or close the zip file.
The file might be corrupt.

Error correction

Try again to create the zip file.


Error description 130-07D2

Error message

There was an error when saving a (zip) file

Cause of error

When creating the service files, the TNC was unable to save at least one file.

Error correction

No remedy possible.


Error description 130-07D4

Error message

Key might be jammed

Cause of error

On or more keys were pressed for more than 5 seconds.

Error correction

If the problem continues, inform your service agency.
Press the keys SHIFT, CTRL and ALT.


Error description 130-07D5

Error message

Parameter transfer not possible

Cause of error

Could not write machine parameters because the background activity blocked access to the machine configuration.

Error correction

- Conclude the background activities.
- Ensure during offset adjustment that the axis is in servo control and that the control window is reached.


Error description 130-07D6

Error message

No response from drive “%1”!

Cause of error

The network drive is no longer ready or no longer reacts.

Error correction

- Check the network
- Check whether the connected computer is active
- Check the network cables and connectors
- Check the activity of the Ethernet data interface. LEDs should light up or blink.
- Have a network specialist check the network settings.


Error description 130-07D7

Error message

Program start or program selection has failed

Cause of error

The action was prevented by a simultaneous reconfiguration or a configuration error.

Error correction

- End the current simulation in the Test Run operating mode
- Correct the configuration error


Error description 130-07D8

Error message

The application cannot be started

Cause of error

The authorization necessary in order to run the application is missing.


Error description 130-07E2

Error message

Non-secure DNC connection %1 detected from %2

Cause of error

An application has established a non-secure DNC connection to the control, or tried to do so.
Note:
In order to significantly increase IT security, DNC connections are by default permitted only through an SSH tunnel now. This non-secure connection could only be established because it was explicitly permitted in the machine parameter allowUnsecureRPC. In the future it will not be possible to permit non-secure connections in the machine configuration.

Error correction

- Migrate the affected application to a secure DNC connection. HEIDENHAIN offers a configuration for secure communication.
- Use the newest versions of HEIDENHAIN programs (such as TNCremo) and configure a secure connection.
- If the application does not come from HEIDENHAIN: Notify the manufacturer of the affected application.


Error description 130-07E3

Error message

Non-secure connection %1 detected from %2

Cause of error

An application has established a non-secure LSV2 connection to the control, or tried to do so.
Note:
In order to significantly increase IT security, LSV2 connections are by default permitted only through an SSH tunnel now. This non-secure connection could only be established because it was explicitly permitted in the machine parameter allowUnsecureLsv2. In the future it will not be possible to permit non-secure connections in the machine configuration.
Starting with a future version of the NC software, LSV2 will no longer be supported.

Error correction

- Migrate the affected application to a secure connection. HEIDENHAIN offers a configuration for secure communication.
- Use the newest versions of HEIDENHAIN programs (such as TNCremo) and configure a secure connection.
- If the application does not come from HEIDENHAIN: Notify the manufacturer of the affected application.


Error description 140-0001

Error message

Backup copy of the configuration data cannot be created.

Cause of error

When configuration data are written, a backup copy of the parameter file is created.
This file could not be created.
– File is write-protected
- Drive is full
- Problem with the hard disk

Error correction

- Remove the write protection
- Delete unneeded files on the hard disk or memory card to make space.


Error description 140-0002

Error message

Configuration file '%1' cannot be written.

Cause of error

The file cannot be opened for writing.
- File is write-protected
- Drive is full
- Problem with the hard disk

Error correction

- Remove the write protection.
- Delete unneeded files on the hard disk to make space.


Error description 140-0004

Error message

Configuration file '%1' not found.

Cause of error

A parameter file specified in the "configfiles.cfg" file was not found.
- Incorrect parameter file entered
- Incorrect directory for the parameter file entered
- Parameter file deleted

Error correction

- Correct the "configfiles.cfg" or "configfile.cfg" file.
- Specify the correct file in the update rule.
- Create a parameter file or copy it into the desired directory.


Error description 140-0005

Error message

Data object '%1' '%2' not complete

Cause of error

A configuration object in a configuration file is incomplete.
One or more configuration parameters are missing. The incomplete configuration object is designated by object name and object key.
Possible causes:
- The existing configuration data belong to an older software version
- The data file was edited manually

Error correction

- Define the update rule or inform your service agency
- Use the configuration editor to completely fill out the parameter object


Error description 140-0006

Error message

Key of the data object '%1' not initialized.

Cause of error

The key of a parameter object is missing.

Error correction

Enter the key for all parameter objects.


Error description 140-000A

Error message

Cycle ini file '%1' not found.

Cause of error

The cycle file specified in the parameter object "CfgJhPath" or "CfgOemPath" was not found. The name of the unfound file is given.
- Incorrect file entered
- Incorrect object entered
- File deleted If the file is present, the problem could be caused by incorrect entries.
- Incorrect or incomplete entries
- Incorrect cycle, parameter, or text definitions

Error correction

- Correct the file information.
- Create a file or copy one into the corresponding directory.
- Use CycleDesign to correct the cycle definitions.


Error description 140-000B

Error message

Unknown code word '%1' in cycle ini file.

Cause of error

An unknown keyword was found in a cycle file.
- Incorrect cycle file
- Incorrect version of CycleDesign
- Incomplete or incorrect cycle definition

Error correction

- Use the correct cycle file.
- Use the correct version of CycleDesign.
- Use CycleDesign to correct the cycle definition.


Error description 140-000D

Error message

No text found for text name '%1'

Cause of error

In a parameter file, the text name entered for a language-dependent text was not found.
- Text is not yet defined
- Text file is not compiled
- Text file was not copied onto the target system
- Incorrect name entered

Error correction

If no text has been entered:
- Define the text in a resource file
- Compile the text file
- Copy the text file onto the target system
Otherwise, enter an existing text name or correct the text name in question.


Error description 140-000F

Error message

Module '%1' not open.

Cause of error

A module is not logged on with the configuration server.
- This task requires that you be logged on.
- You attempted to log off.

Error correction

Inform your service agency.


Error description 140-0010

Error message

Module '%1' has no general write access.

Cause of error

An attempt was made to set the general write protection on the configuration server. However, the write protection is already active and cannot be set again.

Error correction

Inform your service agency.


Error description 140-0011

Error message

'%1' has no general write access.

Cause of error

A module is trying to cancel the general write protection, which however was not reserved by this module.

Error correction

Inform your service agency.


Error description 140-0012

Error message

Unknown message '%1' for configuration server.

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 140-0013

Error message

Write access for '%1' '%2' not reserved.

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 140-0014

Error message

Incorrect file type '%1' with '%2'.

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 140-0015

Error message

Character string '%1' not found in '%2'.

Cause of error

An incorrect character string was found in a cycle file.
- The file is defective
- Incorrect version of CycleDesign in use

Error correction

- Use CycleDesign to create a new cycle file.
- Use the correct version of CycleDesign.


Error description 140-0016

Error message

ZERO message '%1'

Cause of error

- Insufficient main memory
- Internal control error

Error correction

Inform your service agency.


Error description 140-0017

Error message

Machine parameters were changed.
Shut down the control and restart.

Cause of error

Configuration files have been changed that require a control reset for the changed data to take effect.

Error correction

- Stop NC programs and all traverse.
- Press the emergency stop button.
- Restart the control.


Error description 140-0018

Error message

Data object '%1' '%2' already exists in file

Cause of error

A configuration data object with the specified key already exists.

Error correction

- Check whether the correct configuration data files are being used, e.g. whether one of the files is being used twice.
- Check whether a data object is already available in another file.
- Change the key of one of the redundant configuration data objects.
- Delete one of the redundant objects.


Error description 140-0019

Error message

Internal software error

Cause of error

Internal software error.

Error correction

Inform your service agency.


Error description 140-001A

Error message

Configuration object '%1' / '%2' not found

Cause of error

A configuration data object that is necessary for the control start does not exist.

Error correction

– Check the configuration in use
– Check the configuration data


Error description 140-001B

Error message

No change acknowledgment obtained from '%1'

Cause of error

Internal control error.
Configuration data were changed. After notification of the change not all returned an acknowledgment within the required time.
The module that did not acknowledge will be listed in the additional text.

Error correction

Inform your service agency.


Error description 140-001D

Error message

Parameter change during program run or macro run

Cause of error

You attempted to change configuration data during a program run. These data cannot be changed during a program run (applies to reset, run or ref. errors).
The additional information shows the name of the data object that cannot be changed during program run.

Error correction

Select NC stop for the running programs in Program Run Single Block, Test Run and programming graphics, and then an internal stop. Then save the data again.


Error description 140-001E

Error message

Parameter locked from editing

Cause of error

There are two possible causes:
1. An attempt was made to change configuration data while a notification of change is still pending. The last change and notification is still in progress.
2. An attempt was made to start a program while a notification of configuration change is still in progress.

Error correction

1. Try again to save.
2. Restart the program.


Error description 140-001F

Error message

Program start: Data objects with write protection not allowed

Cause of error

An attempt was made to start a program although data objectsare still write-protected or writing access was reserved for data objects. At program start, writing access must be allowed for all objects.

Error correction

Restart the program.


Error description 140-0020

Error message

Module name missing or unknown '%1'

Cause of error

Internal software error.
During a request a module did not enter its identification or entered it incorrectly.

Error correction

Inform your service agency.


Error description 140-0021

Error message

Data object '%1' renamed to '%2'
key '%3'

Cause of error

The read configuration data belong to an older level of the control. The specified data object was renamed by the control due to a rule.

Error correction

Check the values of the specified data object. If the data object is incorrect, correct it. Then save the data.


Error description 140-0022

Error message

Data object '%1' '%2' removed

Cause of error

The read configuration data belong to an older level of the control. The data object is no longer supported and was removed by the control due to a rule.

Error correction

Save the changed data.


Error description 140-0023

Error message

Data type changed with data object '%1' '%2'
Attribute '%3'

Cause of error

The read configuration data belong to an older version of control. The data type of a data object attribute was changed by the control due to a rule.

Error correction

Check the value of the specified attribute in the data object. If the value is incorrect, correct it. Then save the data.


Error description 140-0024

Error message

Attribute renamed in data object '%1' '%2'
Attribute '%3'

Cause of error

The read configuration data belong to an older level of the control.
In the specified data object, the control renamed an attribute due to a rule.

Error correction

Check the value of the specified attribute in the data object.
If the value is not correct, correct it. Then save the data.


Error description 140-0025

Error message

Attribute in data object '%1' '%2' removed
Attribute '%3'

Cause of error

The read configuration data belong to an older level of the control.
In the specified data object, the control removed an attribute due to a rule.

Error correction

Check the values of the specified data object. If the data object is incorrect, correct it.
Then save the data.


Error description 140-0026

Error message

Attribute inserted in data object '%1' '%2'
Attribute '%3'

Cause of error

The read configuration data belong to an older level of the control. The specified data object is incomplete. Due to a rule, the control control inserted the missing attribute(s).

Error correction

Check the values of the specified data object. If the data object is incorrect, correct it. Then save the data.


Error description 140-0027

Error message

Data object '%1' '%2' removed

Cause of error

The read configuration data belong to an older level of the control. The data object is still supported by the control, but was removed due to a rule.

Error correction

Save the changed data.


Error description 140-0028

Error message

Data object '%1' '%2' inserted

Cause of error

The read configuration data belong to an older level of the control. The data object is missing in the given configuration data and was inserted due to a rule.

Error correction

Check the values of the specified data object. If the data object is incorrect, correct it. Then save the data.


Error description 140-0029

Error message

Incorrect insertion value in data object '%1' '%2'
Attribute '%3'

Cause of error

The read configuration data belong to an older level of the control. The specified data object is incomplete. Due to a rule, the control inserted the missing attribute.
The value to be inserted as specified in the rule is incorrect.

Error correction

- The attribute is initialized with a default value. Check the value and correct it if necessary.
- Correct the rule.


Error description 140-002B

Error message

Data file not saved

Cause of error

This warning is issued for information and appears if:
- the configuration data have uncorrected syntax errors
- or the configuration data were updated but the update was not yet saved
- or default data were copied or a data backup was restored but the control was not yet restarted.
In this condition, no configuration data are written to the data files.

Error correction

- Manually correct the fatal errors in the configuration editor by selecting the FIX SYNTAX ERROR soft key.
- Fix the errors that are corrected by an update rule by selecting the CONFIG DATA soft key in the configuration editor and then saving.
- Restart the control.


Error description 140-002C

Error message

Unknown object name '%1'

Cause of error

An object name is unkown. The name might be incorrectly written, or it might not be supported by the version.

Error correction

- If the name comes from a configuration file, correct it there.
- Otherwise, inform your service agency.


Error description 140-002D

Error message

Maximum list size exceeded

Cause of error

The maximum list size has been reached. Too many configuration data objects have been added.

Error correction

- Delete configuration data objects
- If this is not possible, inform your service agency


Error description 140-002E

Error message

SIK control identification faulty: %1

Cause of error

The SIK (System Identification Key) is not suitable for this software. With this software, the control can be operated only as a programming station. Possible causes:
- Control is an export version
- Wrong SIK
- Incorrect or unconfigured control type
- Error while accessing the SIK.

Error correction

- Inform your service agency


Error description 140-002F

Error message

General key expired

Cause of error

The machine tool builder can use a master keyword (general key) for putting the control into service that will unlock all options for a duration of 90 days.
The general key has expired and is therefore no longer valid.
Now the options will be active only with the fiting keywords.

Error correction

Order the required software option(s) from your service agency.


Error description 140-0030

Error message

General key is active

Cause of error

The machine tool builder can use a master keyword (general key) for putting the control into service that will unlock all options for a duration of 90 days.
This message is displayed after every start-up if the general key is active.
After the time period is over, the options can be used only with the fitting keywords. If an NC program is running when the general key expires, an NC stop is issued!

Error correction

Contact the machine manufacturer. He can check in the SIK menu how long the general key will be valid, or deactivate the general key.


Error description 140-0031

Error message

'%1' entered as password

Cause of error


Error description 140-0032

Error message

Incorrect software version

Cause of error

The export code does not match this software version.

Error correction

You have to switch from the standard version to the export version or vice versa.


Error description 140-0033

Error message

Job cannot run

Cause of error

The configuration server cannot run a job. For more information about the job, refer to the additional information.

Error correction

- Check other entries in the log: there might be additional entries that provide more information for troubleshooting.
- Check the machine parameter System > PLC > CfgPlcOptions > noConfigDataLock: if the parameter is not set or is FALSE, then parameter changes are not permissible while executing a program.
Set noConfigDataLock to TRUE in order to permit changes to parameters while executing a program. Refer to the Technical Manual for more information about noConfigDataLock.
- Inform your service agency


Error description 140-0034

Error message

Data object '%1' '%2' moved to file '%3'

Cause of error

The downloaded configuration data belong to an older NC software level. The data object was saved in an incorrect file and was moved to another file according to a rule.

Error correction

Save the modified data.


Error description 140-0035

Error message

Data object '%1' '%2' divided into '%3'

Cause of error

The downloaded configuration data belong to an old NC software level. The data object was divided into one or more data objects.

Error correction

Save the modified data.


Error description 140-0036

Error message

Value of data object '%1' '%2' was changed.
Attribute '%3'.

Cause of error

The downloaded configuration data belong to an old NC software level. The control modified one or more values of a data object on the basis of a rule.

Error correction

Check the values of the given attributes in the data object. If the value is incorrect, correct it. Then save the data.


Error description 140-0037

Error message

Attribute of data object '%1' '%2' was moved.
Attribute '%3'.

Cause of error

The downloaded configuration data belong to an older NC software level. The control moved an attribute of the given data object on the basis of a rule.

Error correction

Check the values of the given data object. If the data object is incorrect, correct it. Then save the data.


Error description 140-0038

Error message

Data object '%1': Key was changed from '%2' to '%3'

Cause of error

The downloaded configuration data belong to an older version of the control.
The objekt key of a data object was changed on the basis of a rule.

Error correction

Check the values of the given data object. If the data object is incorrect, correct the object. Then save the data.


Error description 140-0042

Error message

Faulty cycle data

Cause of error

- Too many soft keys in one level
- Error in menu tree
- Other error

Error correction

- Distribute the soft keys over multiple levels
- Configure the menu tree correctly
- Note the additional information


Error description 140-0043

Error message

Too much data

Cause of error

You changed too many data objects or loaded an MP subfile that is too large. Not all changed data objects will become effective immediately.

Error correction

- Shut down and restart the control.
- Divide the MP subfile


Error description 140-0044

Error message

Shut down and restart the control

Cause of error

The trial license was deactivated. However, the temporarily enabled options remain active until the control is shut down.

Error correction

The control must be shut down and restarted.


Error description 140-0045

Error message

Error while opening file '%1'

Cause of error

- File does not exist
- Access to file failed
- File is not a valid backup file

Error correction

- Select an existing file
- The file must not be opened by another file
- The selected file must first be created by the control as a backup file


Error description 140-0046

Error message

Data change without effect

Cause of error

More than one MP subfile is loaded, or parameters were changed by a PLC module.
An attempt was made to edit data, but the changes have no effect during control operation because they are covered over by MP subfiles or PLC changes.

Error correction

Check the active data in the 'effective data' data record. If they do not have the desired values:
- Reload the MP subfile in which the changes were made
- Unload other MP subfiles
- Edit the data in the 'temporary files' data record


Error description 140-0047

Error message

Error while loading the backup

Cause of error

- Program Run is active
- The files belong to an older software version
- A file has a syntax error
- The files from the backup were restored but could not be activated because they contain reset parameters with other values.

Error correction

- Stop the program
- The data must be updated. Refer to the instructions for updating configuration data.
- Use the "REMOVE SYNTAX ERROR"REMOVE SYNTAX ERROR" soft key to make a manual correction
- The control must be shut down and restarted.
If you have to restore the old data, activate the file %OEM%:\config\_LastKnownGoodConfig_.zip


Error description 140-0048

Error message

Error while creating the backup

Cause of error

- Not allowed in this data record
- File cannot be created

Error correction

- Select the basis data record
- Select another file


Error description 140-0049

Error message

The software option for OEM cycles has not yet been enabled

Cause of error

An OEM cycle tree was configured, but the software option has not been enabled.

Error correction

Order the required software option from your service agency.


Error description 140-004A

Error message

The software option for '%1' has not been enabled

Cause of error

The language selected for the required software option is not enabled.

Error correction

Order the required software option from your service agency.


Error description 140-004B

Error message

Error in finding the current control parameters

Cause of error

There was an error in the automatic calculation of the current controller parameters.

Error correction

The current controller parameters must be acquired manually.


Error description 140-004C

Error message

System settings deleted

Cause of error

The system settings in non-volatile memory, e.g. which programs were last opened, were deleted.
When the control is started it reinitializes these system settings.

Error correction

Shut the control down and restart it.


Error description 140-004D

Error message

Password %1 defined twice

Cause of error

The entered coder number or password already exist. The double definition is not allowed.

Error correction

- Replace the entered password in the configuration (CfgOemPassword or CfgChangePassword). Use a password that has not yet been used.


Error description 140-004E

Error message

Password %1 replaced by machine manufacturer

Cause of error

The machine manufacturer replaced the entered password with another one.

Error correction

Use the password defined by the machine manufacturer.
Refer to the machine manual or contact your machine manufacturer to receive the password.


Error description 140-004F

Error message

Update of the configuration data

Cause of error

The active machine configuration is not compatible with the current version of the NC software. The configuration files belong to an older software version.

Error correction

- After a configuration backup is loaded you have to close the control down and restart it.
- The code number prompt is shown during start-up. Enter the code number for the Machine Parameter Editing operating mode.
- The control implements the configuration data according to the update rules. Check the changes in the machine configuration and save the edited configuration data.
- Also also read the instructions for updating configuration data in the Technical Manual.


Error description 140-0050

Error message

Impermissible data object for file

Cause of error

The data object was saved in a impermissible location. The data object either cannot be saved in a parameter file or it has to be located in a file of the PLC: or SYS: drive.

Error correction

Remove the data object completely from the file or move it into a file on another drive. Note also which access is defined for the data object.


Error description 140-0051

Error message

Data object "%1" is faulty

Cause of error

A configuration object in a configuration file is faulty or incomplete.
Possible causes:
- The existing configuration data belong to an older software version.
- The data file was edited manually.

Error correction

- Reset the config version and run the update again.
- Use the configuration editor to correct or completely fill out the parameter object


Error description 140-0052

Error message

Installation of setup in PLCE drive failed

Cause of error

The installation of setup files into the encrypted PLCE drive has failed.

Error correction

Possible causes:
- An incorrect password was entered for encrypting the setup file in PLCdesign. Make a new setup.zip file in PLCdesign with the correct password.
- A target file name or target directory was entered in PLCdesign that contains illegal characters. Use only ASCII characters for target paths in "PLCE:". Make a new setup.zip file with PLCdesign.
- The image file for "PLCE:" is too small for the update. Save the contents of "PLCE:", generate a larger image file, restore the backup and try the update again.
- There is no encrypted "PLCE:" partition on the control. Make an encrypted partition and retry the update.
- No password was found for the encrypted partition or the incorrect password was entered. Enter a correct password in the settings for the "PLCE:" partition (PLC Programming mode).


Error description 140-0053

Error message

Configuration data object not found

Cause of error

A configuration data object that is necessary for a software update does not exist The update of the configuration data might therefore be incomplete.

Error correction

Check the machine configuration and correct it if required.


Error description 140-0054

Error message

Error while loading the default data

Cause of error

An error occurred while loading the default data:
- One or more files are still being accessed by the control
- The default data incomplete or incorrect.

Error correction

- Check whether there are any more messages in the log file that indicate the possible cause of the error.
- Restart the control and stop the start-up by immediately pressing the MOD key. Then load the default data
- If this does not help, inform your service agency


Error description 140-0055

Error message

Faulty update rule

Cause of error

The update rule given in the additional data is faulty. The machine configuration cannot be updated with this rule.

Error correction

- Check all settings in the update rule.
- If a file is named in the rule: Check whether this file is part of the present configuration.
- Correct the update rule so that the machine configuration can be updated successfully.


Error description 140-0056

Error message

Error while saving configuration data

Cause of error

An error occurred while saving the configuration data.

Error correction

- Please note the additional section shown in the internal information.
- Inform your service agency.


Error description 140-0057

Error message

Illegal value

Cause of error

- The test of the entered value found that it is incorrect or invalid.
- Whether the value is valid can also depend on other machine parameters (plausibility).

Error correction

- Check the entered value and change it if necessary. If the parameter depends on other parameters, you must consider them as well.
- Inform your service agency


Error description 140-0058

Error message

Data object '%1' does not exist

Cause of error

- Error when writing data.
- Given key name does not exist.

Error correction

- Check the key name and correct if necessary, or enter an existing key name.
- First create a data object with this key name.
- Inform your service agency.


Error description 140-0059

Error message

Too many MP partial files

Cause of error

The maximum number of subfiles was exceeded while MP subfiles were loading.

Error correction

- Unload all MP subfiles using the config editor
- Restart the control
- Inform your service agency


Error description 140-005A

Error message

Faulty data in update rule

Cause of error

The data object given in the update rule is faulty.

Error correction

Check the spelling of the data object shown under “object” and correct it if necessary:
- Check the spelling of all names.
- Check the syntax of parentheses for completeness. Opening parentheses must be closed again.
- Check the syntax of all machine parameters or attributes. Attributes must be separated by commas. Important: A comma must not precede a parenthesis!
- Check the syntax of character strings. Character strings must be enclosed by quotation marks.
- If quotation marks are used, they must be preceded by a backslash. Example: \”A name\”
- If there is a backslash, it must be preceded by another. Example: \\
- Inform your service agency.


Error description 140-005B

Error message

Updating of system data not permitted

Cause of error

- You tried to use the update rules to change or overwrite write-protected data/files or configuration data.
- Update rules must not edit write-protected data or system data.

Error correction

- Remove the faulty update rule. You will find the faulty update rule in the error message’s additional information by pressing the INTERNE INFO soft key.
- Inform your service agency.


Error description 140-005C

Error message

Faulty value for machine parameter

Cause of error

- Syntax error in the value for a machine parameter in the update rule.
- Entered value has a spelling error or in not allowed for the parameter that is to be changed by the update rule.

Error correction

- Check the spelling of the value.
- Check the type of value. A numerical value can contain only one number. An enumerated list must be given an existing enumeration name.
- Inform your service agency.


Error description 140-005D

Error message

Unknown name in update rule

Cause of error

- Unknown attribute name or machine parameter entered in the update rule.

Error correction

- Check the name for spelling errors.
- Check the data object for whether the attribute or machine parameter really exists.
- Inform your service agency.


Error description 140-005E

Error message

Incorrect list index

Cause of error

- No index or excessively large index entered for the list in the update rule.

Error correction

- If no index was entered, enter one.
- Check whether the entered index is larger than the maximum index of the associated list. Change the index if necessary.
- Inform your service agency.


Error description 140-005F

Error message

Unknown file '%1' in update rule '%2'

Cause of error

- In the update rule, a file is given that is either nonexistent or is not listed in the list of configuration files.
- You can find more information on the error message by pressing the INTERNAL INFO soft key.

Error correction

- The file does not exist or is not in the list of configuration files:
- The control will automatically create a file and save the new data in the file.
- If you do not want to use the new file, move the data to another one and delete the existing file from the list of configuration files.
- Incorrect path or file name in the update rule:
- Press the UPDATE RULES soft key, then check the update rule and correct it if necessary.
- Configuration file exists, but is not in the list of configuration files:
- Press the CONFIG FILE LIST soft key and add the file to the list.
- Inform your service agency.


Error description 140-0060

Error message

Unit of measure “%1” not defined

Cause of error

- Unknown unit of measure given in the attribute information.

Error correction

- Check the unit for mass and change it if necessary. Use only the default units of math. Only the measuring unit’s name can be entered, not the measuring unit itself.
- Note that, depending on the unit of measure, the displayed value is converted to the unit of measure used by the control.
- With machine parameters CfgOemInt and CfgOemPosition, no units of measure can be used that require conversion.


Error description 140-0062

Error message

Configuration error while logging the user on or off

Cause of error

A configuration error occurred in the operating system when logging the user on or off.

Error correction

- Ensure that all required configuration data is available to the user, particularly the data on HOME:
- Stop all NC programs
- Log the user off and then on again. If errors are still being reported, please contact your service agency.


Error description 140-0063

Error message

Function with encrypted data not allowed

Cause of error

If encrypted configuration files are used, no configuration backup or restore can be executed.

Error correction

Start the backup or restore with PC tools, such as TNCremo.


Error description 140-0064

Error message

Software option '%1' is disabled by the configuration

Cause of error

- The software option is locked by configuration. The software option is therefore not available, although it has been enabled in the SIK.
- Observe any changed machine behavior (for example, when DCM collision monitoring is locked)!

Error correction

- Re-enable the software option in the SIK dialog to restore the original behavior.
- Inform your service agency.


Error description 140-0065

Error message

Load subfile through NC program

Cause of error

The selected MP subfile was loaded by an NC program from one of the simulation operating modes (e.g. Test Run). Such an MP subfile is indicated with a prefixed pound sign (#).
This MP subfile can only be unloaded from the same simulation operating mode.

Error correction

- Switch to the simulation operating mode from which the MP subfile was loaded.
- Start an NC program there that unloads the MP subfile.
- Inform your service agency.


Error description 140-0066

Error message

Configuration files adapted as the result of an update

Cause of error

For informational purposes:
At least one of the files indicated under CfgConfigUpdate/baseFiles or CfgConfigUpdate/portionFiles was automatically adapted due to a software update.

Error correction

HEIDENHAIN recommends checking the changes that were performed automatically.


Error description 140-0067

Error message

Error while re-reading the configuration data

Cause of error

Errors occurred while reloading the configuration data. Refer to the additional information in the error window opened by the INTERNAL INFO soft key:
HAS_FATAL: The data that was read includes syntax errors
HAS_UPD: The data must be updated
Please note: the previous configuration data of the control is still active. It is no longer possible to change the configuration data.

Error correction

Restart the control


Error description 140-0068

Error message

File '%1' listed more than once

Cause of error

A file is listed more than once in CfgConfigDataFiles.
Please note:
The file can also be listed under SYS: in CfgJhConfigDataFiles.

Error correction

- Change the file name and entry in CfgConfigDataFiles


Error description 140-006C

Error message

Evaluation of SIK2 failed

Cause of error

An error occurred while evaluating the SIK2 component.

Error correction

Inform your service agency


Error description 140-006D

Error message

Text name '%1' defined in multiple *.po files

Cause of error

The same text name is used in multiple *.po files. This is not allowed.
Please note the file names indicated in the message details.

Error correction

- Change the text name: the name must be unique
You could add a unique identifier as a prefix to your text names.


Error description 141-0003

Error message

Key already exists

Cause of error

A data object with the entered key already exists.
Therefore no new data object can be created with this key.

Error correction

- Delete old data object
- or enter another key


Error description 141-0005

Error message

Data was not fully saved

Cause of error

Some of the changed data could not be saved because it is locked from write access or an NC program is still running.

Error correction

- Stop NC program run
- Try again to save, because the lock on write access might have been removed in the meantime.


Error description 141-0006

Error message

Value out of range %1 to %2

Cause of error

The entered value is invalid or lies outside the permitted limit values.

Error correction

Enter another value.


Error description 141-0007

Error message

Key non-functional

Cause of error

In this context the key has no function.


Error description 141-0025

Error message

Insufficient access rights for data change
'%1' '%2'

Cause of error

You do not have the access rights to change data.
Perhaps you are running a cycle or NC program from a drive for which you do not have access rights.
The message shows the data object for which more access rights are required.

Error correction

- The data cannot be saved.
- Another code number must be entered.
Run the cycle or NC program from a drive for which you do have the necessary access rights.
- For a software update the system code number is required.


Error description 141-0030

Error message

No further password entries possible

Cause of error

An incorrect password was entered repeatedly to enable an option. After 10 incorrect entries no further entry is accepted.

Error correction

Inform your service agency.


Error description 141-0048

Error message

Selection is not an MP subfile

Cause of error

You selected a directory instead of a file. This function supports the selection of only one file.

Error correction

- Either select an MP subfile (no directory)
- Or use the soft key FILE / UPDATE DIRECTORY to update all the files in the directory


Error description 141-004B

Error message

Required value missing

Cause of error

A required value was not entered.

Error correction

- Enter a value at the indicated position


Error description 141-004C

Error message

Invalid input range or incorrect format

Cause of error

The entered value does not fit the parameter format.

Error correction

- Enter a value from the valid value range for input in the associated parameter


Error description 141-004D

Error message

Value must not be changed

Cause of error

You have entered attribute information that cannot be changed by the machine manufacturer.
This input might have happened directly in a parameter file.

Error correction

Enter only the data that are offered in the dialog window for editing attribute information.


Error description 141-004E

Error message

No line has been selected

Cause of error

Under "Selection," you have not chosen a field from the table.

Error correction

- Use the cursor to select a line in the table under "Selection."
Note: It depends on the type of parameter whether a selection can be entered!


Error description 141-004F

Error message

Function possible only with basic data

Cause of error

TEST EN

Error correction

TEST EN


Error description 141-0050

Error message

Software option [%1] cannot be disabled

Cause of error

You tried to lock a software option listed in the SIK dialog using the LOCK OPTION soft key. The selected option belongs to the control's factory default setting.
Options that are available as standard cannot be locked.

Error correction

Select a software option available for this control for the LOCK OPTION function.
You can find the list of available software options in the Technical Manual.


Error description 141-0051

Error message

MP subfile already loaded

Cause of error

An already loaded subfile cannot be opened again for writing.

Error correction

Select a different file for editing from the data record list.


Error description 141-0052

Error message

Selected file already active as base file

Cause of error

The file selected for editing is contained in the basic data.

Error correction

Select the basic data and edit the file data with the configuration editor.


Error description 141-0141

Error message

Copy default configuration to \\CONFIG ?

Cause of error


Error description 141-0142

Error message

Previous data are saved in \\CONFIG.BAK

Cause of error


Error description 145-0001

Error message

Circular arc not fully defined

Cause of error

The start angle of the circular arc is not defined.


Error description 145-0002

Error message

Circular arc not fully defined

Cause of error

The stopping angle of the circular arc is not defined.


Error description 145-0003

Error message

Circular arc not fully defined

Cause of error

Starting and stopping angles of the circular arc are not defined.


Error description 145-0004

Error message

System error in the geometry

Cause of error

The position of a circular spatial arc is not explicitly defined.

Error correction

Inform your service agency


Error description 145-0005

Error message

System error in the geometry

Cause of error

Message must not contain a transformation matrix

Error correction

Inform your service agency


Error description 145-0006

Error message

Invalid scaling factor

Cause of error

You defined different axis-specific scaling factors for the same circle. For circles, use identical axis-specific scaling factors.


Error description 145-0008

Error message

Incorrect tangent

Cause of error

The specified tangent end point lies too closely to the arc.

Error correction

Correct the end point of the tangent.


Error description 145-0009

Error message

Incorrect tangent

Cause of error

The specified tangent point lies on the circular arc.

Error correction

Correct the end point of the tangent.


Error description 145-000A

Error message

Incorrect tangent

Cause of error

The specified tangent point lies inside the circular arc.

Error correction

Correct the end point of the tangent.


Error description 145-000C

Error message

Incorrect point

Cause of error

The given point does not line on the circular arc.

Error correction

Correct the coordinates of the point.


Error description 145-000D

Error message

Function not yet implemented

Cause of error

Function not yet implemented.


Error description 145-000E

Error message

Incorrect circular arc

Cause of error

Start point and end point of the circular arc are at different distances from the center.

Error correction

Correct the coordinates of the end point and center.


Error description 145-000F

Error message

Incorrect circular arc

Cause of error

The distance between the start point and end point of the circular arc is too small.

Error correction

Correct the point.


Error description 145-0010

Error message

Incorrect circular arc

Cause of error

The specified radius is too small to connect the start point and end point.

Error correction

Correct the coordinates.


Error description 145-0011

Error message

Incorrect circular arc

Cause of error

The tangents at the start poine and end point of the circular arc are parallel.

Error correction

Correct the coordinates.


Error description 145-0012

Error message

No intersection

Cause of error

The specified curves have not intersection.

Error correction

Correct the coordinates.


Error description 145-0013

Error message

Incorrect chamfer

Cause of error

Length of chamfer is undefined

Error correction

Enter the chamfer length


Error description 145-0014

Error message

Incorrect chamfer

Cause of error

Chamfer too long

Error correction

Correct the chamfer length.


Error description 145-0015

Error message

Incorrect chamfer

Cause of error

Chamfer is possible only between straight lines

Error correction

Delete the chamfer block


Error description 145-0016

Error message

Error in rounding arc (RND)

Cause of error

Radius of rounding arc is undefined

Error correction

Correct the rounding arc


Error description 145-0017

Error message

Error in rounding arc (RND)

Cause of error

Rounding arc radius too large

Error correction

Correct the rounding arc radius


Error description 145-0018

Error message

Incorrect approach movement (APPR)

Cause of error

Undefined length of approach movement


Error description 145-0019

Error message

Incorrect approach movement (APPR)

Cause of error

Undefined side of approach


Error description 145-001A

Error message

Incorrect approach movement (APPR)

Cause of error

Undefined radius of approach


Error description 145-001B

Error message

Incorrect approach movement (APPR)

Cause of error

Undefined traverse angle of approach


Error description 145-001C

Error message

Incorrect approach movement (APPR)

Cause of error

Radius of the transition arc in approach too large


Error description 145-001D

Error message

Incorrect departure movement (DEPT)

Cause of error

Length of departure movement is undefined


Error description 145-001E

Error message

Incorrect departure movement (DEPT)

Cause of error

Departure side undefined


Error description 145-001F

Error message

Incorrect departure movement (DEPT)

Cause of error

Radius of departure is undefined


Error description 145-0020

Error message

Incorrect departure movement (DEPT)

Cause of error

Traverse angle of departure movement is undefined


Error description 145-0021

Error message

Incorrect departure movement (DEPT)

Cause of error

Radius of the transitional arc in the departure movement is too large


Error description 145-0022

Error message

Incorrect departure movement (DEPT)

Cause of error

End point of departure movement is undefined


Error description 145-0023

Error message

System error in the geometry

Cause of error

Access to a vector component with invalid index

Error correction

Inform your service agency.


Error description 145-0024

Error message

System error in the geometry

Cause of error

An attempt was made to normalize a null vector.

Error correction

Inform your service agency.


Error description 145-0025

Error message

System error in the geometry

Cause of error

Access to a matrix element with invalid index.

Error correction

Inform your service agency.


Error description 145-0026

Error message

System error in the geometry

Cause of error

Access to the column of a matrix with invalid index.

Error correction

Inform your service agency.


Error description 145-0027

Error message

System error in the geometry

Cause of error

You attempted to invert a singular matrix.

Error correction

Inform your service agency.


Error description 145-0028

Error message

System error in the geometry

Cause of error

No conversion possible

Error correction

Inform your service agency.


Error description 145-002F

Error message

Translation error

Cause of error

The definition of the orientation in a coordinaten transformation is incorrect.

Error correction

Correct the definition.


Error description 145-0030

Error message

Translation error

Cause of error

In a cordinaten transformation the Y direction cannot be calculated.

Error correction

Correct the definition.


Error description 145-0031

Error message

Geometry error

Cause of error

The distance between two points is too small for one calculation.


Error description 145-0032

Error message

System error in the geometry

Cause of error

Division by zero during an internal calculation

Error correction

Inform your service agency.


Error description 145-0033

Error message

System error in the geometry

Cause of error

An internal calculation resulted in a circle with negative radius.

Error correction

Inform your service agency.


Error description 145-0034

Error message

System error in the geometry

Cause of error

For an ellipse or an elliptical arc, a function was called that is permitted only for circles or circular arcs.

Error correction

Inform your service agency.


Error description 145-0035

Error message

System error in the geometry

Cause of error

Internal software error.

Error correction

Inform your service agency.


Error description 145-0036

Error message

System error in the geometry

Cause of error

Two points are so close together in a geometric figure that the polar vector is too inexact.

Error correction

Inform your service agency.


Error description 145-0037

Error message

Circle incorrectly programmed

Cause of error

No circle is defined through the given point.

Error correction

Correct the coordinates of the points.


Error description 145-0038

Error message

System error in the geometry

Cause of error

In an internal calculation, an ellipse has degenerated into a line segment. Some operations cannot be performed for such degenerated ellipses.

Error correction

Inform your service agency.


Error description 145-0039

Error message

Error in rounding arc (RND)

Cause of error

An attempt was made to place a rounding radius between two directionally opposed parallel lines.

Error correction

Correct the coordinates of the lines.


Error description 145-003A

Error message

Undefined rotational direction of contour

Cause of error

You tried to learn the rotational direction of a contour that has none defined.

Error correction

Ensure that the contour is closed and free of gaps.


Error description 160-0001

Error message

System error in interpreter

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 160-0003

Error message

Block format incorrect

Cause of error

Keyword or G function not programmed.

Error correction

Edit the NC program.


Error description 160-0004

Error message

System error in interpreter

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 160-0007

Error message

System error in interpreter

Cause of error

Error in internal cycle

Error correction

Inform your service agency.


Error description 160-000B

Error message

CYCL DEF not defined

Cause of error

You have programmed a cycle call without first defining the cycle, or you tried to call a DEF-active cycle.

Error correction

Define the cycle before calling it.


Error description 160-000D

Error message

Error when opening the file '%1'

Cause of error

An error occurred while a file was being opened.

Error correction

Ensure that the file exists, that the given path is correct, and that the file has a readable format.


Error description 160-0018

Error message

Jump to label 0 not permitted

Cause of error

In a LBL CALL (ISO: L 0,0) block of a part program or in a jump instruction (parametric calculation) you attempted to program a jump to the label 0.

Error correction

Edit the part program.


Error description 160-001A

Error message

Block format incorrect

Cause of error

The program section repeat was incorrectly programmed.

Error correction

Edit the NC program.


Error description 160-001B

Error message

Label number not found

Cause of error

With LBL CALL (ISO: L x,x), you tried to call a label that does not exist.

Error correction

Change the number in the LBL CALL block or insert the missing label (LBL SET).


Error description 160-001C

Error message

Label number already assigned

Cause of error

You attempted to program the same label number in several LBL SET (ISO: G98 Lxx) blocks in a part program.

Error correction

Edit the part program.


Error description 160-001D

Error message

Block format incorrect

Cause of error

A positioning movement was programmed without type of interpolation.

Error correction

Edit the NC program.


Error description 160-001F

Error message

Wrong axis programmed

Cause of error

An axis programmed in the NC block is not configured.

Error correction

Edit the NC program.


Error description 160-0020

Error message

Wrong axis programmed

Cause of error

No nominal/actual position could be found for the axis specified in the FN18 block (ISO: D18).

Error correction

Check the index of the system data.


Error description 160-0021

Error message

Pole incorrectly defined

Cause of error

In the NC program both coordinates of a pole must be programmed in the plain. Either you forgot one coordinate, entered more than two coordinates, or programmed one coordinate twice.

Error correction

Check the pole programming in the NC program.


Error description 160-0022

Error message

Block format incorrect

Cause of error

In a linear block, you programmed the polar radius twice

Error correction

Edit the NC program


Error description 160-0023

Error message

Block format incorrect

Cause of error

A radius was programmed in a polar circular interpolation CP (ISO:G12/G13/G15), but the radius is defined by the distance of the starting point to the pole.

Error correction

Edit the NC program.


Error description 160-0024

Error message

Block format incorrect

Cause of error

The radius is missing for a Circle with Radius block (CR, ISO: G02, G03).

Error correction

Edit the part program.


Error description 160-0025

Error message

Block format incorrect

Cause of error

The arc direction of rotation was incorrectly programmed.

Error correction

Edit the NC program.


Error description 160-0026

Error message

Direction of rotation missing

Cause of error

A circle was programmed without direction of rotation.

Error correction

Always program a direction of rotation (DR).


Error description 160-0028

Error message

Invalid Q parameter

Cause of error

The given index for a Q parameter is out of range.

Error correction

Edit the NC program.


Error description 160-0029

Error message

Block format incorrect

Cause of error

The programmed NC syntax is not supported.

Error correction

Edit the NC program.


Error description 160-002A

Error message

Block format incorrect

Cause of error

The programmed NC syntax is not supported.

Error correction

Edit the NC program.


Error description 160-002B

Error message

Block format incorrect

Cause of error

The programmed NC syntax is not supported.

Error correction

Edit the NC program.


Error description 160-002C

Error message

Block format incorrect

Cause of error

A syntactically incorrect NC block was programmed.

Error correction

Edit the NC program.


Error description 160-0032

Error message

Arithmetical error

Cause of error

Incorrect Q parameter calculation: Division by 0, square root of a negative number, or similar error

Error correction

Check the input values.


Error description 160-0036

Error message

NC block not found

Cause of error

The block specified for mid-program startup was not found.

Error correction

Enter another target for the mid-program startup.


Error description 160-003C

Error message

CYCL DEF incomplete

Cause of error

You programmed an incomplete cycle definition or inserted other NC blocks between cycle blocks.

Error correction

Edit the NC program.


Error description 160-003D

Error message

Block format incorrect

Cause of error

The programmed syntax element is not allowed in this NC block.

Error correction

Edit the NC program.


Error description 160-003E

Error message

Block format incorrect

Cause of error

The programmed syntax element is not allowed in this NC block.

Error correction

Edit the NC program.


Error description 160-0048

Error message

Block format incorrect

Cause of error

The programmed NC syntax is not supported by this control.

Error correction

Edit the NC program.


Error description 160-0049

Error message

Touch point inaccessible

Cause of error

No signal came from the touch probe within the measuring distance.

Error correction

Pre-position as appropriate and repeat the probing process.


Error description 160-0054

Error message

Block format incorrect

Cause of error

An incorrect system data number was entered in the function FN18 ID2000.

Error correction

Edit the NC program.


Error description 160-0055

Error message

Tool change faulty

Cause of error

An incorrect tool was enabled.

Error correction

Inform your machine tool builder.


Error description 160-0056

Error message

Tool axis is missing

Cause of error

You programmed a positioning block with tool radius compensation without first calling a tool.

Error correction

Edit the NC program.


Error description 160-0058

Error message

Cycle for TOOL CALL not defined

Cause of error

The tool definition cycle was not defined.

Error correction

Inform your machine tool builder.


Error description 160-0059

Error message

Cycle for TOOL DEF not defined

Cause of error

The tool definition cycle was not defined.

Error correction

Inform your machine tool builder.


Error description 160-005A

Error message

Unknown tool type '%1'

Cause of error

An undefined tool type was found in function FN17 ID950.

Error correction

Inform your machine tool builder.


Error description 160-005D

Error message

Block format incorrect

Cause of error

The data type of the column given in an SQL BIND command does not agree with that of the given parameter.

Error correction

Check the table definition and edit the NC program.


Error description 160-0060

Error message

Parameter not connected with a column

Cause of error

An attempt was made to use SQL BIND to dissolve a link that does not exist.

Error correction

Edit the NC program.


Error description 160-0061

Error message

System error in interpreter

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 160-0063

Error message

Block format incorrect

Cause of error

The programmed syntax element is not allowed in this NC block.

Error correction

Edit the NC program.


Error description 160-0064

Error message

Table access failed

Cause of error

- The syntax of the programmed SQL statement is incorrect
- The given table could not be opened
- The given table is incorrectly defined
- The symbolic name of the table is not defined
- The table does not contain the given columns
- A data record could not be read because it is locked

Error correction

Check the table definition and edit the NC program


Error description 160-0065

Error message

Block format incorrect

Cause of error

An unfulfillable condition was given in the FN20 function.

Error correction

Edit the NC program.


Error description 160-0067

Error message

Faulty access to table

Cause of error

An internal control error has occurred.

Error correction

Inform your service agency.


Error description 160-0068

Error message

Block format incorrect

Cause of error

A syntactically incorrect SQL statement was programmed.

Error correction

Edit the NC program.


Error description 160-0069

Error message

Feed rate is missing

Cause of error

No feed rate was programmed, or the feed rate 0 was programmed.

Error correction

Edit the NC program.


Error description 160-006B

Error message

Feed rate for tool is missing

Cause of error

In an NC block you programmed F AUTO, but you did not program a feed rate in the TOOL CALL block.

Error correction

- Enter the feed rate directly in the NC block
- Program a TOOL CALL block with feed rate


Error description 160-0073

Error message

SQL handles at program end not yet released

Cause of error

A program was ended although table access was still active.

Error correction

Before closing the program, end all SQL table access with SQL COMMIT or SQL ROLLBACK.


Error description 160-0082

Error message

Axis double programmed

Cause of error

You programmed an axis twice in a single positioning block.

Error correction

Edit the part program.


Error description 160-0083

Error message

Axis double programmed

Cause of error

You programmed an axis twice in the Mirror Image cycle.

Error correction

Edit the part program.


Error description 160-0084

Error message

Axis double programmed

Cause of error

While defining Cycle 26 (axis-specific scaling factor) you programmed the scaling factor or the scaling datum twice in one axis.

Error correction

Edit the part program.


Error description 160-0085

Error message

Axis double programmed

Cause of error

A axis was double-programmed in an approach or departure block.

Error correction

Edit the NC program.


Error description 160-0086

Error message

Axis double programmed

Cause of error

An axis was double-programmed in a coordinate transformation cycle.

Error correction

Edit the NC program.


Error description 160-0087

Error message

Axis double programmed

Cause of error

In a "TCH PROBE" probing cycle an axis was double programmed.

Error correction

Edit the NC program.


Error description 160-0089

Error message

Incorrect number for FN17/FN18

Cause of error

The number combination for the system data (FN17/FN18) is not allowed.

Error correction

Check the number and index of the system data.


Error description 160-008A

Error message

Incorrect axis index for FN17/FN18

Cause of error

An incorrect axis index was specified while reading from/writing to system data (FN17/FN18).

Error correction

Check the index of the system date.


Error description 160-008B

Error message

Block format incorrect

Cause of error

A radius was programmed at an illegal location.

Error correction

Edit the NC program.


Error description 160-008C

Error message

Block format incorrect

Cause of error

A direction of rotation was programmed at an illegal location.

Error correction

Edit the NC program.


Error description 160-008F

Error message

Block format incorrect

Cause of error

Too many axis positions programmed in the NC block.

Error correction

Edit the NC program.


Error description 160-0091

Error message

Block format incorrect

Cause of error

In the NC block APPR/DEP more than 3 axis positions were programmed.

Error correction

Edit the NC program.


Error description 160-0092

Error message

Block format incorrect

Cause of error

In the FN29 block more than 8 values programmed.

Error correction

Edit the NC program.


Error description 160-0093

Error message

Block format incorrect

Cause of error

In a datum shift cycle you programmed too many positions.

Error correction

Edit the NC program


Error description 160-0094

Error message

Block format incorrect

Cause of error

Too many positions programmed in the axis-specific scaling cycle.

Error correction

Edit the NC program.


Error description 160-0095

Error message

Block format incorrect

Cause of error

In the axis-specific scaling factor cycle you programmed too many center coordinates.

Error correction

Edit the NC program


Error description 160-0096

Error message

Block format incorrect

Cause of error

Too many axes programmed in the mirroring cycle.

Error correction

Edit the NC program.


Error description 160-0099

Error message

Column already assigned to a parameter

Cause of error

In the NC program, the SQL BIND command was used to assign a column name more than once to a parameter.

Error correction

Edit the NC program.


Error description 160-009A

Error message

Table column is not connected with a parameter

Cause of error

Before a table column can accept SQL UPDATE commands (SQL
"SELECT...", SQL UPDATE, SQL FETCH), it must be connected
with a value by SQL BIND, SQL SYSBIND or by corresponding
configuration data.

Error correction

Edit the NC program.


Error description 160-009B

Error message

Column not defined

Cause of error

Description missing for a table column.

Error correction

Check the definition of the table.


Error description 160-009C

Error message

Block format incorrect

Cause of error

The FN function programmed in the NC program is not supported.

Error correction

Edit the NC program.


Error description 160-009E

Error message

Wrong axis programmed

Cause of error

Incorrect value for FN17:SYSWRITE ID 212

Error correction

Edit the NC program.


Error description 160-009F

Error message

Block format incorrect

Cause of error

Too many axes were programmed for setting a preset value.

Error correction

Edit the NC program.


Error description 160-00A0

Error message

Spindle is not rotating

Cause of error

A machining cycle was called although the spindle is stopped.

Error correction

Edit the NC program.


Error description 160-00A1

Error message

Incorrect tool index programmed

Cause of error

Invalid tool index programmed.

Error correction

Edit the NC program.


Error description 160-00A2

Error message

Block format incorrect

Cause of error

Faulty workpiece blank definition

Error correction

Edit the NC program.


Error description 160-00A3

Error message

Axis double programmed

Cause of error

One axis was programmed twice in the workpiece blank definition.

Error correction

Edit the NC program.


Error description 160-00A4

Error message

Wrong axis programmed

Cause of error

Invalid axis in the workpiece blank definition.

Error correction

Edit the NC program.


Error description 160-00A5

Error message

Block format incorrect

Cause of error

The specified sytax element is not allowed in the NC block.

Error correction

Edit the NC program.


Error description 160-00A6

Error message

Cycle is not installed

Cause of error

The programmed cycle is not installed.

Error correction

Check the installed cycles and edit the NC program.


Error description 160-00A7

Error message

System error in interpreter

Cause of error

Internal software error.

Error correction

Inform your service agency.


Error description 160-00A8

Error message

Recursive label call

Cause of error

Within a subprogram, you tried to call the label with which the subprogram begins.

Error correction

Correct the NC program. A subprogram cannot call itself.


Error description 160-00A9

Error message

Unsuitable touch probe

Cause of error

The desired measuring cycle cannot be performed with the currently selected probe.

Error correction

Edit the NC program.


Error description 160-00AA

Error message

Excessive program nesting

Cause of error

Program nesting through CALL LBL or CALL PGM is too deep, presumably because of a recursive call.

Error correction

Edit the NC program.


Error description 160-00AB

Error message

Recursive program call

Cause of error

Within an NC program, you tried to call the NC program itself as a subprogram. Maybe you tried to call one of the NC programs that called the current NC program.

Error correction

Correct the NC program. An NC program cannot call itself.


Error description 160-00AC

Error message

Not possible on this machine

Cause of error

The desired command cannot be performed on this machine, or the configuration is faulty.

Error correction

Inform the machine tool builder or (if the error occured in an NC program), edit the NC program.


Error description 160-00AD

Error message

Block format incorrect

Cause of error

You programmed an invalid syntax element within a contour definition. Only traversing commands are allowed with the exception of APPR/DEPT and Q parameter calculation.

Error correction

Edit the part program.


Error description 160-00AE

Error message

Invalid value

Cause of error

You attempted to assign an illegal value to a variable.

Error correction

Edit the NC program.


Error description 160-00AF

Error message

Undeclared string variable

Cause of error

You used a string variable without first declaring it.

Error correction

Edit the NC program.
Before it's first use, every string variable must be declared with DECLARE STRING.


Error description 160-00B0

Error message

Block format incorrect

Cause of error

You concluded a contour definition improperly.

Error correction

Edit the NC program. Contours defined by label must end with label 0.


Error description 160-00B1

Error message

Cannot write

Cause of error

You attempted to use FN17:SYSREAD or SQL SYSBIND and SQL FETCH to write to a read-only system parameter.

Error correction

Edit the NC program.


Error description 160-00B2

Error message

String too long

Cause of error

In a table you attempted to write a string that is too long for the corresponding column.

Error correction

Edit the NC program.


Error description 160-00B3

Error message

Block format incorrect

Cause of error

A mandatory syntax element is missing in the NC block.

Error correction

Edit the NC program.


Error description 160-00B4

Error message

Format file defective

Cause of error

The format file for FN16: F-PRINT (DIN/ISO: D16) has the wrong format.

Error correction

Correct the format file.


Error description 160-00B5

Error message

Format file defective

Cause of error

The format file for FN16: F-PRINT (DIN/ISO: D16) has the wrong format:
The Q parameters and other keywords in the specified lined do not fit to the replacement characters in the format string. Remember:
- If an %% character in the format string is not to be understood as format information, you must write \%%.
- Each line must begin with all keywords that generate an output (such as HOUR, Q14, ...), only then followed by those that do not generate an output (such as M_CLOSE).

Error correction

Correct the format file.


Error description 160-00B6

Error message

Format file defective

Cause of error

The format file for FN16: F-PRINT (DIN/ISO: D16) has the wrong format: The specified line contains the keywords for several different languages.

Error correction

Correct the format file. Each line can contain no more than one keyword for a language.


Error description 160-00B7

Error message

Format file defective

Cause of error

The format file for FN16: F-PRINT (DIN/ISO: D16) has the wrong format:
The specified line contains an unknown code word.

Error correction

Correct the format file.


Error description 160-00B8

Error message

Format file defective

Cause of error

The text generated by FN16: F-PRINT (ISO: D16) is too long. Maximum permissible length: 1024 characters.

Error correction

Change the format file. If necessary, divide the output over several FN16 commands.


Error description 160-00B9

Error message

%1

Cause of error


Error description 160-00BA

Error message

File access not possible

Cause of error

You tried to access a file that is reserved for the control manufacture or machine tool builder.

Error correction

Edit the NC program.


Error description 160-00BB

Error message

Faulty CFGREAD

Cause of error

Failed attempt to read a configuration datum via CFGREAD. The desired configuration datum may not exist or it has another type.

Error correction

Check that the name (TAG), key (KEY) and desired attribute (ATTR) is written correctly and that the desired datum has the correct type:
In numerical formulas, enter only datum that can be converted to a numerical value (numbers and Boolean variables). In string formulas, enter only data that can be converted to a string (string, Boolean and enumeration).


Error description 160-00BC

Error message

Tool definition is missing

Cause of error

In a TOOL CALL (ISO: T..) you entered a tool number for which there is no definition in the program.

Error correction

Edit the part program.


Error description 160-00BD

Error message

Block format incorrect

Cause of error

A coordinate is required in the specified NC block, but you did not enter one.

Error correction

Edit the NC program.


Error description 160-00BE

Error message

Illegal probe type

Cause of error

An invalid number was entered for the touch probe model. The probe data or a cycle are probably in error.

Error correction

Correct the type of the touch probe (if necessary through your customer service).


Error description 160-00BF

Error message

CYCL DEF faulty

Cause of error

The Q parameters entered in a cycle as calling parameters are contradictory. The cycle is probably incorrectly defined, or maybe you simply programmed it incorrectly.

Error correction

Correct the NC program with the NC editor. If this does not remedy the error, contact your machine tool builder.


Error description 160-00C0

Error message

%1

Cause of error

An error was provoked by the function FN14 (ISO: D14) in an NC program or cycle.

Error correction

Look for a description of the error in the machine manual. Then fix the error and restart the program.


Error description 160-00C1

Error message

FN14 error without text

Cause of error

With the FN14 (ISO: D14) function you provoked an error in the NC program or cycle.
The string variable to be shown as an error text does not exist.

Error correction

Correct the FN14 function in the NC program. Inform the machine manufacturer if an error message is generated from a cycle.


Error description 160-00C2

Error message

FN14 error without text

Cause of error

With the FN14 (ISO: D14) function you provoked an error in the NC program or cycle.
The additional information is missing for the given error number.

Error correction

Correct the FN14 function in the NC program. Inform the machine manufacturer if an error message is generated from a cycle.


Error description 160-00C3

Error message

M function not permitted

Cause of error

An M function was programmed with a number that is not permitted on this control.

Error correction

Correct the number of the M function.


Error description 160-00C4

Error message

No program selected

Cause of error

An attempt was made to call an NC program with CALL SELECTED, although no program was selected.

Error correction

Correct the NC program.


Error description 160-00C5

Error message

Tool not defined

Cause of error

You have called a tool that is not defined in the tool table.

Error correction

- Add the missing tool to the tool table.
- Use another tool.


Error description 160-00C6

Error message

Incorrect tool data

Cause of error

Incorrect tool data

Error correction

Correct the tool table.


Error description 160-00C7

Error message

Invalid value

Cause of error

An invalid value was entered for a parameter in a function.

Error correction

Correct the NC program.


Error description 160-00C8

Error message

Cycle defective

Cause of error

An incorrect system jump address was entered in a cycle.

Error correction

Inform your machine tool builder.


Error description 160-00C9

Error message

Invalid value for table

Cause of error

You tried to write an invalid value in an SQL table.

Error correction

Correct the NC program.


Error description 160-00CA

Error message

Invalid SQL handle

Cause of error

An invalid SQL handle was entered for the transaction. Maybe the transaction was never successfully opened, or it was already ended through COMMIT or ROLLBACK.

Error correction

Correct the NC program.


Error description 160-00CB

Error message

Error when opening a selected file

Cause of error

Error while opening a file.

Error correction

Ensure that the file exists, that the given path is correct, and that the file has a readable format.


Error description 160-00CC

Error message

Error when opening a system file

Cause of error

Error while opening a system file.

Error correction

Inform your service agency.


Error description 160-00CD

Error message

Block format incorrect

Cause of error

In a NC program you used a syntax element that is allowed only within a contour-definition program.

Error correction

Create a contour definition program and select with SEL CONTOUR.


Error description 160-00CE

Error message

ID for FN17/FN18 not available

Cause of error

The given ID in the system datum (FN17/FN18) is not available for this channel because the corresponding configuration data are missing.

Error correction

Check the ID of the system datum or run the NC program in another channel. If you really do need a system datum with this ID in this channel, ask your service agency.


Error description 160-00CF

Error message

NC command not available

Cause of error

The given command is not available because the corresponding configuration data are missing. It is probably not supported on this machine.

Error correction

Change the NC program or inform your machine tool builder.


Error description 160-00D0

Error message

M128 / M129 not allowed here

Cause of error

No switch-over of the TCPM is possible while the radius compensation is active (RR/RL, or G41/G42).

Error correction

Activate or deactivate TCPM before beginning or after end of radius compensation.


Error description 160-00D1

Error message

3-D tool compensation incorrect

Cause of error

LN blocks (face milling) are not possible together with simple radius compensation.

Error correction

If you want face milling, switch off the radius compensation.
If you want peripheral milling, switch on TCPM (M128).


Error description 160-00D2

Error message

Only allowed in subprogram

Cause of error

The syntax used is allowed only in subprograms that are called with CALL PGM and in cycles, not in the main program.

Error correction

Correct the NC program.


Error description 160-00D3

Error message

Variable in calling program not defined

Cause of error

In a subprogram, you tried to change a variable that is not declared in the calling program.

Error correction

Correct the NC program.


Error description 160-00D4

Error message

Tool axis of touch probe not defined

Cause of error

You called a probing cycle without first defining the tool axis of the touch probe.

Error correction

Run the TOOL CALL with the corrent tool axis.


Error description 160-00D5

Error message

OEM system cycle '%3' not defined

Cause of error

You tried to call a non-configured OEM system cycle.

Error correction

Complete the missing OEM system cycle configuration, or correct the NC program containing the call.


Error description 160-00D6

Error message

No technological data available for contour pocket machining

Cause of error

A Cycle 20 must be programmed before every fixed cycle 21, 22, 23, or 24.

Error correction

Program a Cycle 20


Error description 160-00D7

Error message

Inconsistent status of the SQL server

Cause of error

Open transactions to the SQL server exist in the interpreter, even though they have already been closed.

Error correction

Check if the data in the SQL tables matches your expectations.


Error description 160-00D8

Error message

Option not enabled

Cause of error

The function programmed is not allowed on this control or is available only as an option.

Error correction

- Enable the option
- Correct the NC program


Error description 160-00D9

Error message

Only allowed in cycle

Cause of error

The syntax used is allowed only in cycles, not in main programs or subprograms.

Error correction

Correct the NC program.


Error description 160-00DA

Error message

Access to PLC variable has failed

Cause of error

The attempt to access a PLC variable has failed. It may be that the desired variable does not exist.

Error correction

Check that the symbolic name of the variable is spelled correctly and that the variable is defined in the PLC.


Error description 160-00DB

Error message

Access to PLC variable has failed

Cause of error

The attempt to access a PLC variable has failed because it is not of the expected type.

Error correction

Edit the NC program.


Error description 160-00DC

Error message

Wrong rpm

Cause of error

The programmed spindle speed does not lie in the existing pattern of spindle speed stages.

Error correction

Enter the correct rotational speed.


Error description 160-00DD

Error message

Check the depth sign

Cause of error

The cycle can only be performed in the negative direction (Cycle 204: positive direction) because the configuration parameter displayDepthErr is set to "on".

Error correction

- Enter a negative depth (Cycle 204: positive depth) in order to perform the cycle
- Set the configuration parameter displayDepthErr to "off" in order to perform the cycle in positive direction (Cycle 204: negative direction)
- Enter the diameter in Cycle 240 as a negative value in order to perform the operation in the negative direction of the tool axis.


Error description 160-00DE

Error message

Program was edited

Cause of error

The current NC program was changed, or one of the NC programs that have called the current NC program. It is therefore not possible to go back into the program.

Error correction

Use the GOTO function or the mid-program startup function to select the desired location to return to in the program.


Error description 160-00DF

Error message

R+ (G43) or R- (G44) not allowed here

Cause of error

The radius compensation R+ or R- cannot be used during active RR or RL.

Error correction

Edit the NC program.


Error description 160-00E0

Error message

FZ was programmed in conjunction with the number of teeth 0

Cause of error

You used FZ to define a feed per tooth, although no tooth number is defined in the tool table.

Error correction

Add to the CUT column in the tool table for the active tool.


Error description 160-00E1

Error message

Combination of FU/FZ with M136 not allowed in inch programs

Cause of error

You tried to use FU or FZ (feed rate in inch/rev or inch/tooth) in conjunction with M136 (feed rate in 0.1 inch/rev).

Error correction

Edit the NC program.


Error description 160-00E2

Error message

PGM CALL not allowed

Cause of error

Calling subprograms over CALL PGM is not allowed in the Positioning with MDI mode of operation.

Error correction

Edit the NC program.


Error description 160-00E3

Error message

Spindle speed S is greater than NMAX from the tool table

Cause of error

You entered a spindle speed S greater than the maximum speed defined for this tool in the tool table.

Error correction

- Enter a lower spindle speed S.
- Change the maximum spindle speed in the NMAX column of the tool table.


Error description 160-00E4

Error message

Probe cycle started with stylus already deflected

Cause of error

You tried to start a probing cycle although the stylus is still deflected.

Error correction

Increase the retraction path


Error description 160-00E5

Error message

Axis positions could not be determined

Cause of error

The position of the touch point could not be read.

Error correction

Inform your service agency


Error description 160-00E6

Error message

Missing tool data!

Cause of error

The data for the current tool are not available; the tool is not in the table. Do not run any programs with this condition!

Error correction

- Ensure that the desired tool is entered in the tool table. If required, correct the tool table.
- Acknowledge the error message
- Conduct a TOOL CALL with an existing tool


Error description 160-00E7

Error message

Incremental input not allowed

Cause of error

In the PATTERN DEF block, you used incremental coordinates to define the first position or a position after a pattern definition.

Error correction

In PATTERN DEF, always use absolute coordinates to program
- the first position,
- the next position after a pattern


Error description 160-00E8

Error message

Point table has been changed

Cause of error

A pocket table defined with SEL PATTERN has changed during the program run. This is not allowed because the geometry is calculated ahead of time and the changes can then sometimes no longer be considered.

Error correction

Restart the program


Error description 160-00E9

Error message

M function not allowed in a CYCL CALL PAT block

Cause of error

In CYCL CALL PAT block an M function was programmed that is not allowed there.

Error correction

Edit the NC program


Error description 160-00EA

Error message

CYCL CALL PAT not possible with selected cycle

Cause of error

The selected cycle is not allowed for execution with CYCL CALL PAT.

Error correction

Edit the NC program


Error description 160-00EB

Error message

Recursive call of CYCL CALL PAT

Cause of error

Another CYCL CALL PAT block was found within a point pattern operation.

Error correction

Correct the NC program


Error description 160-00EC

Error message

Radius compensation not allowed before CYCL CALL PAT

Cause of error

The control cannot approach the points of a pattern and compensate the tool radius. Radius compensation must not be switched on before a CYCL CALL PAT block or at the end of the cycle called by this block.

Error correction

Edit the NC program


Error description 160-00ED

Error message

Point pattern call or definition faulty

Cause of error

A CYCL CALL PAT or PATTERN DEF block could not be executed because:
- The machining plane programmed with TOOL CALL is not supported or
- The point table or a pattern definition with PATTERN DEF is faulty.

Error correction

Check the NC program or point table and correct if necessary


Error description 160-00EE

Error message

No point pattern defined

Cause of error

CYCL CALL PAT can only work if beforehand a point pattern was selected with SEL PATTERN or PATTERN DEF.

Error correction

Edit the NC program


Error description 160-00EF

Error message

M136 not allowed

Cause of error

M136 is not allowed in combination with the selected cycle.

Error correction

Correct the NC program


Error description 160-00F0

Error message

Faulty call of READ KINEMATICS or WRITE KINEMATICS

Cause of error

You programmed the READ KINEMATICS or WRITE KINEMATICS command incorrectly.
Possible causes:
- The character string entered under KEY contains an unknown element or an incorrect number of elements
- Writing the programmed data to the machine kinematics is not allowed or is not supported

Error correction

Edit the NC program


Error description 160-00F1

Error message

FUNCTION PARAXCOMP or PARAXMODE is faulty

Cause of error

You programmed FUNCTION PARAXCOMP DISPLAY or FUNCTION PARAXCOMP MOVE without indicating an axis, or in FUNCTION PARAXMODE you entered fewer than three axes.

Error correction

- Enter at least one axis in FUNCTION PARAXCOMP DISPLAY or FUNCTION PARAXCOMP MOVE
- Enter exactly three axes in FUNCTION PARAXMODE
- Correct the NC program


Error description 160-00F2

Error message

M118/M128 at the same time is not allowed

Cause of error

You tried to use M118 to activate a handwheel superimposition during active TCPM.

Error correction

M118 and M128 must not be active at the same time. Edit the NC program.


Error description 160-00F3

Error message

M118/M128 at the same time is not allowed

Cause of error

You tried to use M118 to activate a handwheel superimposition during active TCPM. The TNC has deactivated the handwheel superimpositioning.

Error correction

M118 and M128 must not be active at the same time. Edit the NC program.


Error description 160-00F4

Error message

Active program was changed

Cause of error

You have changed the active NC program and not yet saved it.

Error correction

Save the unsaved NC program and restart.


Error description 160-00F5

Error message

Called program was changed

Cause of error

You have edited and not yet saved an NC program that was called by another program during program run.

Error correction

Save the called NC program and restart the main program.


Error description 160-00F6

Error message

NC block not allowed in milling mode

Cause of error

You programmed an NC block that is not permitted in milling mode.

Error correction

Correct the NC program.


Error description 160-00F7

Error message

NC block not allowed in turning mode

Cause of error

You tried to execute a function that is not allowed in turning mode.
- Fixed cycles for cylindrical surface
- Fixed cycles that are locked for turning mode
- These manual operation functions are not allowed for turning

Error correction

If necessary, correct the NC program.


Error description 160-00F8

Error message

Switching to milling or turning operation not allowed

Cause of error

You tried to switch between milling and turning mode while tool radius compensation was active.

Error correction

Cancel the tool radius compensation before switching to milling or turning mode.


Error description 160-00F9

Error message

FUNCTION TURNDATA not allowed on active tool

Cause of error

You tried to use FUNCTION TURNDATA to activate a turning-tool compensation for a milling cutter.

Error correction

Call a turning tool before programming a FUNCTION TURNDATA.


Error description 160-00FA

Error message

M136 not allowed

Cause of error

You attempted with active M136 to make an automatic swing-in movement in connection with Cycle 19 or the PLANE function.

Error correction

Deactivate M136 before swing-in.


Error description 160-00FB

Error message

Spindle speed programmed without configured spindle

Cause of error

You tried to program a spindle speed, although no spindle is configured for the active kinematic configuration.

Error correction

Select a kinematic configuration with spindle, or edit the NC program.


Error description 160-00FC

Error message

0 rpm not permitted

Cause of error

You called a Rigid Tapping or Tapping cycle with a programmed spindle speed of 0.

Error correction

Program a spindle speed greater than 0.


Error description 160-00FD

Error message

Feed rate FT or FMAXT not allowed

Cause of error

You defined a feed rate with FT or FTMAX although that is not allowed in connection with APPR LN, LT, CT, PLN, PLT, PCT.

Error correction

Use other feed rate definitions than FT or FTMAX


Error description 160-00FE

Error message

Global Q parameter not defined

Cause of error

A program run (test run) showed that a globally effective Q parameter is not defined.

Error correction

Check whether all required global parameters are in the program head and add more if required.


Error description 160-00FF

Error message

M function not allowed in a CYCL CALL POS block

Cause of error

In the CYCL CALL POS block you programmed an M function that is not allowed there.

Error correction

Edit the NC program


Error description 160-0100

Error message

CYCL CALL POS not allowed with active cycle

Cause of error

The active machining cycle is not allowed in combination with CYCL CALL POS.

Error correction

Call the cycle with M99 or CYCL CALL


Error description 160-0101

Error message

CYCL CALL POS with radius compensation not allowed

Cause of error

You defined a CYCL CALL POS block even though tool-radius compensation is active.

Error correction

Cancel the tool-radius compensation before the CYCL CALL POS block


Error description 160-0102

Error message

CYCL CALL PAT or CYCL CALL POS: No working direction defined

Cause of error

You did not define a unique working direction in a cycle definition.

Error correction

Check the recent cycle definitions (parameters Q201, Q249, Q356 or Q358).


Error description 160-0103

Error message

Axis angle not equal to tilt angle

Cause of error

- Datum setting inactive with tilted working plane: the position of the tilting axes is not 0°.
- Datum setting active with tilted working plane: the position of the tilting axes does not agree with the active angle values.

Error correction

- Move the tilted axes into the default position.
- Move the tilting axes to the correct position or adapt the angular values of the tilted axes' position.


Error description 160-0104

Error message

Configuration data cannot be loaded or unloaded

Cause of error

This function is not supported in the Test Run operating mode or by the editor graphics.


Error description 160-0105

Error message

Preset not possible with current machine state

Cause of error

The active preset contains at least one value unequal to zero,
which is not allowed because of the present machine condition.
The control did not activate this preset.

Error correction

Check the current preset and change if required.


Error description 160-0106

Error message

NC function not permitted

Cause of error

The block scan evaluated an NC function that cannot be used with mid-program startup (e.g. M142, M143).

Error correction

- If possible, remove the NC function from the program and then restart the block scan.
- If this is a control program for calling various part programs, start the desired part program individually in the block scan.


Error description 160-0107

Error message

Impermissible compensation for turning tools

Cause of error

You programmed M128 (TCPM) together with an RL (G41)/
RR (G42) radius compensation or an LN block.
This function is not supported in connection
with turning tools.

Error correction

Edit the NC program.


Error description 160-0108

Error message

0 rpm not allowed

Cause of error

You programmed a spindle speed of 0.

Error correction

Always define S to be greater than 0.


Error description 160-0109

Error message

0 rpm not allowed

Cause of error

Turning mode is active:
- You programmed a spindle speed of 0 with FUNCTION TURNDATA SPIN.
- You programmed a constant surface speed VC with FUNCTION TURNDATA SPIN,
but did not define the cutting speed VC.
- You programmed a constant rotational speed (VCONST:OFF) with FUNCTION TURNDATA,
but did not define the rotational speed S.

Error correction

- Always program S to be greater than 0.
- For constant surface speed (VCONST:ON), always define a surface speed VC.
- For constant rotational speed (VCONST:OFF), always define a rotational speed S.


Error description 160-010A

Error message

Number of program part repeats is defined as 0

Cause of error

In a CALL LBL statement (DIN/ISO: L x,y), you defined the
number of program part repeats with 0.

Error correction

- Define a number of repeats between 1 and 9999.
- Define a subprogram call without entering repetitions.


Error description 160-010B

Error message

No turning tool is active

Cause of error

The TNC cannot execute the function with the data of the active tool.

Error correction

- Insert a turning tool.
- Check the TYPE column of the lathe tool table.


Error description 160-010C

Error message

Contradictory tool data

Cause of error

You tried to call a lathe tool with data that are allowed only for milling tools, e.g.
- Spindle speed S
- Oversizes DL, DR, DR2

Error correction

Correct the NC program.


Error description 160-010D

Error message

Tool data are contradictory during active turning operation

Cause of error

The following functions are not allowed during active turning operation (FUNCTION MODE TURN):
- Definition of the spindle speed for the tool spindle (TOOL CALL S, DIN/ISO: S)
- Definition of the tool axis direction (e.g. TOOL CALL Z, DIN/ISO: G17/G18/G19)

Error correction

Correct the NC program.


Error description 160-010E

Error message

Incorrect file type

Cause of error

The type of entered data is not permissible in this application.

Error correction

Please check whether the file has the correct extension.


Error description 160-010F

Error message

Spline interpolation is not supported

Cause of error

You tried to run an NC block that was described as a spline. This block format is not supported by the control.

Error correction

Select an NC program without spline interpolation or edit the NC program.


Error description 160-0110

Error message

FN27/FN28: No table selected

Cause of error

You attempted to use FN27 to write to a table, or FN28 to read from a table, although no table was open.

Error correction

Use FN26 to open the desired table.


Error description 160-0111

Error message

FN27/FNF28: Field is not numerical

Cause of error

You attempted to use an FN27 or FN28 function to write to or read from a non-numerical field.

Error correction

Writing and reading operations are possible only with numerical fields.


Error description 160-0112

Error message

MDI: Radius compensation not possible

Cause of error

No tool radius compensation is allowed in MDI mode.

Error correction

Correct the NC block


Error description 160-0113

Error message

Label is missing

Cause of error

You used Cycle 14 to call a nonexistent label.

Error correction

Change the number or name in Cycle 14 or insert the missing label


Error description 160-0114

Error message

Label is missing

Cause of error

You used FUNCTION TURNDATA BLANK LBL to call a nonexistent label.

Error correction

Change the number or name in FUNCTION TURNDATA BLANK LBL or insert the missing label


Error description 160-0115

Error message

Too many vertical profiles programmed

Cause of error

The selected surface profile contains too many vertical profiles.

Error correction

Edit the NC program


Error description 160-0116

Error message

Type of interpolation invalid

Cause of error

No interpolation type or an unsupported interpolation type was programmed.

Error correction

Edit the NC program


Error description 160-0117

Error message

Too many axes programmed

Cause of error

You programmed too many axes for paraxial interpolation.

Error correction

Edit the NC program


Error description 160-0118

Error message

Plane profile incorrectly defined

Cause of error

The selected contour cannot be used as the plane profile of a profile surface. The plane profile must consist only of a subcontour.

Error correction

Edit the NC program


Error description 160-0119

Error message

Circle calculation failed

Cause of error

It was not possible to calculate a circle from the given coordinates.

Error correction

Edit the NC program


Error description 160-011A

Error message

No tool touch probe active

Cause of error

You tried to switch a tool touch probe without first activating it.

Error correction

Activating the tool touch probe.


Error description 160-011B

Error message

At least one parameter within the contour is not initialized

Cause of error

The QL parameters of this program cannot be accessed in the contour defined in the current program.

Error correction

Define the QL parameters used within the contour definition or use globally effective Q parameters.


Error description 160-011C

Error message

Touch probe not defined

Cause of error

- You called a touch probe that is not defined in the touch probe table.
- The touch probe table is write-protected or it does not exist.

Error correction

- Add the missing touch probe to the touch probe table.
- Create a touch probe table or cancel the write protection.


Error description 160-011D

Error message

Tool not defined

Cause of error

You have called a tool that is not defined in the tool table.

Error correction

- Add the missing tool to the tool table.
- Use another tool.


Error description 160-011E

Error message

Turning tool incompletely defined

Cause of error

- You called a turning tool that is not defined in the turning tool table.
- The turning tool table is faulty or missing.

Error correction

- Add the missing tool to the turning tool table.
- Create or correct the turning tool table.


Error description 160-011F

Error message

Range of traverse not defined

Cause of error

You tried to switch to a traverse range that was not defined in the configuration through CfgWorkingRange.

Error correction

Inform your machine tool builder


Error description 160-0120

Error message

DATA ACCESS has failed

Cause of error

An incorrect path was used for DATA ACCESS or there are no access rights.

Error correction

- Correct the programmed path for DATA ACCESS
- Move the NC program to the PLC partition


Error description 160-0121

Error message

Label is missing

Cause of error

A workpiece blank definition (NC block: BLK FORM ROTATION) refers to a nonexistent label.

Error correction

- Correct the NC program: Change the reference to the label or insert the missing label.


Error description 160-0122

Error message

Contradictory M functions

Cause of error

In the same block, you tried to output multiple effective M functions that cancel each other.
For example, you cannot program M3 and M4 in the same NC block because both go into effect at beginning of the block.
On the other hand, M3 and M5 are allowed in the same block because M3 goes into effect at the block beginning and M5 at block end.
The machine tool builder specifies which M functions cancel each other.

Error correction

Correct the NC program.


Error description 160-0123

Error message

Alias strobe of type %1 not configured

Cause of error

The entered command is not available because the corresponding configuration data are missing.
Presumably it is not supported on this machine.
The config object CfgPlcStrobeAlias is missing or has not been entered in the CfgPlcStrobes/aliasStrobes list.

Error correction

Edit the NC program or contact your machine tool builder.


Error description 160-0124

Error message

CFGWRITE incorrect

Cause of error

The attempt to use CFGWRITE to write a configuration datum has failed. It might have another type, or the the write axis is not allowed.

Error correction

Check the spelling of TAG, KEY, attribute (ATR) and the type of value to be written (DAT). If required, move the program from the TNC to the PLC partition.


Error description 160-0125

Error message

Demo version

Cause of error

This software is a demo version.
With the demo version you can edit and run NC programs with a maximum length of 100 lines.
With the demo version you are not entitled to service support from HEIDENHAIN.

Error correction

- If you would like to purchase the licensed version of the product, please contact the service agency for the control.
- Check whether the keyboard of the programming station (or the dongle) is connected.


Error description 160-0126

Error message

M90 is not supported by this NC software

Cause of error

The M90 function is no longer available with this NC software.

Error correction

Use Cycle 32 TOLERANCE in order to influence accuracy, surface quality and machining speed.


Error description 160-0127

Error message

M105 and M106 are not supported with this NC software

Cause of error

The M105 and M106 function is not available with this NC software.


Error description 160-0128

Error message

M104 is not supported with this software

Cause of error

M104 is not supported by this NC software. The datum set manually most recently is saved in row 0 of the preset table.

Error correction

- Use Cycle 247 SET DATUM to activate a preset from the preset table.


Error description 160-0129

Error message

M112 and M113 are not supported with this NC software

Cause of error

The M115 and M113 functions are not available with this NC software.

Error correction

Use Cycle 32 TOLERANCE in order to influence accuracy, surface quality and machining speed.


Error description 160-012A

Error message

M114 and M115 are not supported with this NC software

Cause of error

M114 und M115 are not supported by this NC software.

Error correction

- Use M144/145 or M128/129 in order to take the positions of rotary and tilting axes into consideration.


Error description 160-012B

Error message

M124 is not supported with this NC software

Cause of error

M124 is not supported by this NC software. The contour filter cannot be programmed in the NC program.

Error correction

- Use CfgStretchFilter to configure the contour filter in the machine configuration.


Error description 160-012C

Error message

M132 is not supported with this NC software

Cause of error

M132 is not supported by this NC software.

Error correction

- Use Cycle 32 TOLERANCE in order to influence accuracy, surface quality and machining speed.


Error description 160-012D

Error message

M134 and M135 are not supported with this NC software

Cause of error

This NC software does not support M134 and M135 for a precision stop at non-tangential transitions for positioning moves with rotary axes.

Error correction

- Use machine-specific funtions to activate or deactivate automatic clamping.
- If required, contact your machine tool builder


Error description 160-012E

Error message

M142 is not supported with this NC software

Cause of error

The deletion of modal program functions through M124 is not supported by this NC software.


Error description 160-012F

Error message

M150 is not supported with this NC software

Cause of error

This NC software does not support the suppression of limit-switch messages through M150.


Error description 160-0130

Error message

M200 to M204 are not supported with this NC software

Cause of error

This NC software does not support M200-M204 for laser cutting.


Error description 160-0131

Error message

FT and FMAXT are not supported with this NC software


Error description 160-0132

Error message

FN15: PRINT is not supported with this NC software


Error description 160-0133

Error message

FN25: PRESET is not supported with this NC software


Error description 160-0134

Error message

FN31: RANGE SELECT is not supported with this NC software


Error description 160-0135

Error message

FN32: PLC PRESET is not supported with this NC software


Error description 160-0136

Error message

SL1 cycles are not supported with this NC software

Cause of error

The SL1 cycles 6, 15 and 16 are not supported by this NC software.

Error correction

- Adapt the NC program: Replace SL1 cycles by the new, improved SL2 cycles 20, 21, 22, 23 and 24.


Error description 160-0137

Error message

The touch probe cycle is not supported with this NC software

Cause of error

The programmed touch probe cycle is not supported by this NC software.

Error correction

- Adapt the NC program: Replace the touch probe cycle 2 or 9 by the newer cycles 461, 462 or 463.


Error description 160-0138

Error message

Cycle 30 is not supported with this NC software

Cause of error

Cycle 30 is not supported by this NC software.


Error description 160-0139

Error message

Tool must not be changed

Cause of error

A change of tool number or tool index is not allowed at present. This test was activated by the machine tool builder within the TOOL CALL macro.

Error correction

Inform your machine tool builder


Error description 160-013A

Error message

Mid-program startup to area with active RTC function not possible

Cause of error

You tried to run a mid-program startup on an area in the NC program in which the RTC function (Real-Time Coupling) is active. This is not possible.

Error correction

- Adapt the target position for the block search
- Choose a target position so that the mid-program startup ends before activation of the RTC function.


Error description 160-013B

Error message

Function locked

Cause of error

You have programmed a function that has not been enabled by the machine manufacturer.

Error correction

- Edit the NC program or contact your machine tool builder


Error description 160-013C

Error message

Function not possible with current tool

Cause of error

A function is incompatible with the properties of the current tools.

Error correction

- Edit the NC program
- Check the tool data


Error description 160-013D

Error message

File %1 for tool carrier kinematics could not be opened

Cause of error

The given file for a tool carrier kinematic model could be found neither under TNC:\system\Toolkinematics nor under OEM:\config\Toolkinematics.

Error correction

- Add the file in one of the appropriate directories or delete the corresponding entry under “KINEMATIC” in the tool table if no tool-carrier kinematic model is to be used for the tool.
- Inform your service agency.


Error description 160-013E

Error message

Data of the tool carrier kinematics is faulty

Cause of error

The tool-carrier kinematic data for the current tool are faulty.
Note: Do not run any NC programs in this condition and be careful if you move the axes manually!

Error correction

- Ensure under “KINEMATICS” that a valid file for the tool-carrier kinematics is entered for the desired tool in the tool table.
- Acknowledge the error message
- Run a TOOL CALL for a tool that has no tool-carrier kinematics assigned or one that has a valid tool-carrier kinematic model.
- Inform your service agency.


Error description 160-0142

Error message

Axis positioning not possible

Cause of error

- An auxiliary axis movement was moved before the last movement of this axis was completed

Error correction

Check the PLC program.
- Wait explicitly for the end of the previous positioning movement or cancel it
- Inform your service agency.


Error description 160-0143

Error message

Axis movement canceled

Cause of error

The positioning movement of an auxiliary axis was canceled.

Error correction

- If necessary, check other pending error messages
- Check the PLC program and status marker of the axis
- Inform your service agency


Error description 160-0144

Error message

The configuration datum %2 is missing for the tool touch probe %1

Cause of error

The appropriate configuration datum is missing for the TT tool touch probe activated with the CfgProbes/activeTT parameter.

Error correction

Add the missing configuration datum or activate another TT tool touch probe.


Error description 160-0145

Error message

No active touch probe

Cause of error

You started a probing cycle without first activating the touch probe.

Error correction

- Insert the TS touch probe, or
- switch to the TT tool touch probe.


Error description 160-0146

Error message

Alias strobe of type %1 is incorrectly configured

Cause of error

The entered command is not available because the corresponding configuration data are faulty.
Presumably it is not supported on this machine.
The M function referenced in CfgPlcStrobeAlias is not configured.

Error correction

- Inform your machine tool builder


Error description 160-0155

Error message

Ambiguity: DR2 and DR2TABLE defined in the tool table

Cause of error

Ambiguous DR2 data are entered in the tool table. Only DR2 or DR2TABLE can set for a tool at any given time.

Error correction

In order to use 3-D radius compensation, enter the desired DR2 value and leave the DR2TABLE entry empty
In order to use the 3D-ToolComp option, enter in DR2TABLE the file name (without extension) of the compensation value table and set DR2 to zero (0)


Error description 160-0156

Error message

Radius compens. impossible with milling cutter (TCPM TIP-CENTER)

Cause of error

An attempt has been made to program a radius compensation using a milling tool and active TCPM REFPNT TIP CENTER. Radius compensation with this preset is possible only for turning tools.

Error correction

Insert a turning tool.


Error description 160-0157

Error message

Activation of TCPM REFPNT TIP-CENTER is not allowed

Cause of error

An attempt was made to activate TCPM REFPNT TIP-CENTER. This is not allowed in the current program context.
TCPM REFPNT TIP-CENTER cannot be used in the following program states:
- Active tool radius compensation
- Active 3-D tool compensation

Error correction

If necessary, deactivate the active tool radius compensation or 3-D tool compensation


Error description 160-0158

Error message

TCPM TIP-CENTER active

Cause of error

TCPM REFPNT TIP-CENTER is active. The following functions cannot be used with this TCPM reference point:
- 3-D tool compensation
- Radius compensation R+ and R-

Error correction

Deactivate TCPM TIP-CENTER (using FUNCTION TCPM RESET or M129) or select TIP-TIP or CENTER-CENTER for the TCPM preset before activating the tool compensation.


Error description 160-015A

Error message

TCPM TIP-CENTER is active with tool radius compensation

Cause of error

TCPM REFPNT TIP-CENTER with tool radius compensation is active. The following functions are not possible in this state:
- M128
- M129 / FUNCTION TCPM RESET
- FUNCTION TCPM REFPNT: Change of TCPM preset

Error correction

Deactivate tool radius compensation first with R0


Error description 160-0160

Error message

M2/M30 in subprogram

Cause of error

The NC program was ended by a call from M2 or M30 in a subprogram called with CALL PGM.

Error correction

- If this behavior is desired, no further measures are required.
- If you want to return from the subprogram, edit the NC program and jump to the last line of the subprogram.


Error description 160-0162

Error message

File with 3D-ToolComp compensation values not available

Cause of error

The file with the name provided in the tool-table column DR2TABLE could not be opened.

Error correction

- Check the spelling of the file name in the tool table.
- Check whether the file is located in the intended folder on the control.
- Inform your service agency.


Error description 160-0163

Error message

NC command not allowed during tool-oriented machining

Cause of error

- NC command was executed that is not supported with tool-oriented machining.
In this mode, for example, no change is allowed of the preset table through traverse-range switchover.

Error correction

- Correct the NC program, or
- use workpiece-oriented machining


Error description 160-0164

Error message

Parameter not permissible in macro

Cause of error

In an OEM macro, TOOL CALL was programmed with invalid parameters.
- With TOOL CALL, no parameters are allowed in the macro for tool-oriented pallet machining.
- In the TOOL CALL, only number, step index and spindle speed are allowed in the tool change macros.


Error description 160-0165

Error message

Facing slide: M148 not allowed

Cause of error

Automatic tool lift-off not allowed with an active facing slide.

Error correction

- Check the NC program and adapt it if necessary.


Error description 160-0166

Error message

Function locked

Cause of error

The machine tool builder disabled this function with a configuration setting.

Error correction

Edit the NC program or contact your machine tool builder.


Error description 160-0167

Error message

Cannot continue program

Cause of error

In rare cases, a program resumption with GOTO is no longer possible.

Error correction

- Restart the NC program
- If required, try a mid-program startup


Error description 160-0168

Error message

Preset not allowed

Cause of error

The activated preset contains at least one value not equal to zero. This is not allowed due to a limitation defined by the machine tool builder.
The limitation could have been activated by the following causes:
- Globally by configuration
- Dependency on a machine condition, through an NC syntax.
The control did not activate the impermissible value of this preset.

Error correction

- Check the current preset and change it if required
- In the Test Run operating mode, machining preset loading can be aided using the blank-in-workspace function
- Inform your service agency


Error description 160-0169

Error message

OEM offset for X, Y, or Z axis not permissible

Cause of error

You tried to define an OEM offset for one of the principal axes X, Y or Z. That is not allowed.


Error description 160-016A

Error message

Automatic tool change not possible

Cause of error

An automatic tool change is supported at preset only for milling operations.

Error correction

- In the AFC settings, specify a strategy that does not have the overload response OVLD = M (macro).
- Contact your service agency if this message did not occur due to an AFC overload reaction.


Error description 160-016B

Error message

Switching the machining mode is not allowed

Cause of error

You tried to switch the operating mode while tool radius compensation was active.

Error correction

Cancel the tool radius compensation before switching the operating mode.


Error description 160-016C

Error message

NC block in grinding mode is not allowed

Cause of error

You tried to execute a function that is not allowed in grinding mode.
- Machining cycles for cylindrical surface
- Machining cycles that are disabled for grinding mode
- Functions of manual operation that are not permitted for grinding

Error correction

- Correct the NC program


Error description 160-016D

Error message

NC block in dressing mode is not allowed

Cause of error

You tried to execute a function that is not permitted in dressing mode.
- Machining cycles for cylindrical surface
- Machining cycles that are disabled for dressing mode
- Functions of manual operation that are not permitted for dressing

Error correction

- Correct the NC program


Error description 160-016E

Error message

M function not permitted

Cause of error

In the M function dialog you indicated an M function that is only permitted in the NC program.

Error correction

- Correct the number of the M function
- Output the function via an MDI block.


Error description 160-016F

Error message

Execution right for NC syntax missing

Cause of error

You do not have the rights to perform this specific function (e.g. FN22).

Error correction

Edit the NC program.


Error description 160-0170

Error message

M89 not supported in combination with FK

Cause of error

It was attempted to execute an FK block while M89 was active. This is not supported.

Error correction

- Edit the NC program.
- In order to execute the selected cycle, program M99 for the respective FK blocks instead of M89.


Error description 160-0171

Error message

FN27/FN28 type of field not supported

Cause of error

You tried to use an FN27 or FN28 function to access a field that does not match the type of parameter.

Error correction

- For numerical fields you must use a Q, QL, or QR parameter as the source or target.
- A QS parameter must be used for text fields.


Error description 160-0177

Error message

Grinding tool not defined completely

Cause of error

- You have called a griding tool that is not defined in the griding tool table, or at least not completely.
- The griding tool table does not exist or is faulty.

Error correction

- Add the missing tool to the griding tool table.
- Create or correct the griding tool table.


Error description 160-0179

Error message

Traverse range not defined

Cause of error

You tried to deactivate a traverse range that is not defined in the configuration through CfgWorkingRange.

Error correction

Inform your machine tool builder.


Error description 160-017A

Error message

Maximum number of configuration changes was exceeded

Cause of error

Too many configuration changes were buffered with WRITE CFG PREPARE.

Error correction

Write the already prepared changes with WRITE CFG COMMIT before any further PREPARE instructions.


Error description 160-017B

Error message

NC program faulty: WRITE CFG COMMIT without PREPARE

Cause of error

You programmed WRITE CFG COMMIT without a preceding WRITE CFG PREPARE, or the most recently programmed WRITE CFG PREPARE is no longer valid.

Error correction

Edit the NC program


Error description 160-017C

Error message

Parameter type is incorrect

Cause of error

The result type in a Q parameter formula does not match the parameter on the left side:
- On the left is a Q, QR, or QL parameter but the result of the formula is a string
- On the left is a QS parameter but the result of the formula is a number

Error correction

Correct the formula


Error description 160-017D

Error message

Probing movement was prevented by DCM

Cause of error

The collision monitoring function shortened the length of the probing movement to 0.

Error correction

- Check the configuration of the touch probe being used
- Check whether a collision object must be deactivated for the probing operation


Error description 160-017E

Error message

Block scan not permitted

Cause of error

You began a mid-program startup while dressing mode was active or the target of a mid-program startup is at a position in the dressing mode. This is not allowed.

Error correction

Adapt the target position for the block search


Error description 160-017F

Error message

Handwheel superimpositioning not allowed in dressing mode

Cause of error

You attempted to switch to dressing mode even though handwheel superimpositioning is still active.

Error correction

Switch off handwheel superimpositioning before switching to dressing mode.


Error description 160-030A

Error message

No technology data record available for contour machining

Cause of error

A Cycle 271 must be programmed before every fixed cycle 272, 273, or 274.

Error correction

- Adapt the NC program
- Program Cycle 271


Error description 160-030B

Error message

Block scan not permitted

Cause of error

The target position of the mid-program startup is within an active reciprocating movement. This is not allowed.

Error correction

Adapt the target position for the block search


Error description 160-030E

Error message

Preset not defined

Cause of error

An attempt was made to select a preset that is not defined.

Error correction

Correct the name or the preset or expand the preset table.


Error description 160-030F

Error message

File type not permissible for the tool-model file

Cause of error

A file with a non-permitted file type was specified for the tool to be inserted. *.stl files are permitted.

Error correction

Replace the file with a permitted file.


Error description 160-0310

Error message

File with tool model is missing

Cause of error

The name of the file with a description of the tool model was entered in the tool table: this file does not exist.

Error correction

- Check the spelling of the file name in the tool table
- Copy the file to the intended folder on the control (refer to the information in the User's Manual)


Error description 160-0312

Error message

No position stored for returning

Cause of error

You attempted to return to a stored liftoff point even though no such point was stored.
- Function was called outside of a macro in which liftoff points are stored
- No M140 is programmed in the macro

Error correction

Correct the macro


Error description 160-0313

Error message

Invalid value for table

Cause of error

You tried to use TABDATA ADD to add a value to an empty table entry.

Error correction

- Check whether the data in the tables meet your expectations
- Correct the NC program


Error description 160-0314

Error message

Data for tool shape are faulty or function is disabled

Cause of error

The tool shape data for the current tool are faulty.
Note: Do not run any NC programs in this condition and be careful if you move the axes manually!

Error correction

- Ensure under "TSHAPE" that a valid file for the 3D tool shape is entered for the desired tool in the tool table.
- Acknowledge the error message.
- Run a TOOL CALL for a tool that has no tool shape assigned or one that has a valid 3D tool shape file.
- Inform your service agency.


Error description 160-0315

Error message

"IF" instruction missing before "ELSE (IF)" or "END IF"

Cause of error

A sequence with the instructions "IF", "ELSE IF", "ELSE" and/or "END IF" was programmed incorrectly.

Error correction

Edit the NC program.


Error description 160-0316

Error message

"ELSE" is not permitted after "ELSE"

Cause of error

A sequence with the instructions "IF", "ELSE IF", "ELSE" and/or "END IF" was programmed incorrectly.

Error correction

Edit the NC program.


Error description 160-0317

Error message

Couldn't find concluding "END IF" of an "IF" instruction

Cause of error

A sequence with the instructions "IF", "ELSE IF", "ELSE" and/or "END IF" was programmed incorrectly.

Error correction

Edit the NC program.


Error description 160-0318

Error message

"END IF" without preceding "IF"

Cause of error

A sequence with the instructions "IF", "ELSE IF", "ELSE" and/or "END IF" was programmed incorrectly.

Error correction

Edit the NC program.


Error description 160-0319

Error message

Instruction not permitted between "IF" and "END IF"

Cause of error

Within a block initiated with IF, FOR or WHILE, a jump instruction was programmed that is not permitted there.

Error correction

Edit the NC program.


Error description 160-031A

Error message

Instruction not permitted within a FOR or WHILE loop

Cause of error

Within a block initiated with IF, FOR or WHILE, a jump instruction was programmed that is not permitted there.

Error correction

Edit the NC program.


Error description 160-031B

Error message

End of a loop (FOR or WHILE) faulty: the beginning is missing

Cause of error

A loop was programmed incorrectly. A loop begins with "FOR" or "WHILE" and ends with "END FOR" or "END WHILE". "CONTINUE" or "BREAK" may be used only within a loop.

Error correction

Edit the NC program.


Error description 160-031C

Error message

"END FOR" not found

Cause of error

A loop was programmed incorrectly. A loop begins with "FOR" or "WHILE" and ends with "END FOR" or "END WHILE". "CONTINUE" or "BREAK" may be used only within a loop.

Error correction

Edit the NC program.


Error description 160-031D

Error message

"END WHILE" not found

Cause of error

A loop was programmed incorrectly. A loop begins with "FOR" or "WHILE" and ends with "END FOR" or "END WHILE". "CONTINUE" or "BREAK" may be used only within a loop.

Error correction

Edit the NC program.


Error description 160-031E

Error message

"CONTINUE" outside of a loop

Cause of error

A loop was programmed incorrectly. A loop begins with "FOR" or "WHILE" and ends with "END FOR" or "END WHILE". "CONTINUE" or "BREAK" may be used only within a loop.

Error correction

Edit the NC program.


Error description 160-031F

Error message

"BREAK" outside of a loop

Cause of error

A loop was programmed incorrectly. A loop begins with "FOR" or "WHILE" and ends with "END FOR" or "END WHILE". "CONTINUE" or "BREAK" may be used only within a loop.

Error correction

Edit the NC program.


Error description 160-0320

Error message

Impermissible tool type for tool shape

Cause of error

3D tool shapes can be used for milling cutters and touch probes.
Note: The parameterized description of the tool takes effect.
Indexed tools can also be shown only in a parameterized manner.

Error correction

- Remove the entry from the TSHAPE column
- Enter a correct parametric description of the tool


Error description 160-0321

Error message

Importing data from the digital project folder failed

Cause of error

Tools, presets and datums could not, or could not fully, be converted to the internal format necessary for machining.

Error correction

Pay attention to the additional text, and correct or regenerate the data in the digital project folder.


Error description 160-0322

Error message

Software option for DCM v2 is missing

Cause of error

Die Software-Option für DCM v2 ist nicht freigeschaltet.

Error correction

Kundendienst benachrichtigen
NC-Programm ändern
Einträge in der TSHAPE-Spalte der Werkzeugtabelle entfernen


Error description 1A0-0001

Error message

System error in internal path calculation
Invalid message %1

Cause of error

System error

Error correction

Inform your service agency.


Error description 1A0-0002

Error message

System error in the geometry chain:
%1

Cause of error

System error

Error correction

Inform your service agency.


Error description 1A0-0003

Error message

Function not possible:
%1

Cause of error

You tried to use a function that is not available in this version of the NC software.

Error correction

Edit the NC program.


Error description 1A0-0004

Error message

System error in the geometry chain:
%1

Cause of error

System error in the geometry chain

Error correction

Inform your service agency.


Error description 1A0-0005

Error message

System error in the geometry chain:
%1

Cause of error

System error in internal path calculation

Error correction

Inform your service agency


Error description 1A0-0006

Error message

System error in the geometry chain:
%1

Cause of error

System error in internal path calculation

Error correction

Inform your service agency


Error description 1A0-0007

Error message

System error in the geometry chain:
%1

Cause of error

System error in the geometry chain

Error correction

Inform your service agency.


Error description 1A0-0008

Error message

Axis double programmed

Cause of error

In a circle-center block or a pole block (CC, ISO: I,J,K) you programmed the same axis twice.

Error correction

Edit the NC program


Error description 1A0-0009

Error message

Axis in CC block (ISO: I,J,K) double programmed

Cause of error

In a circle-center block or a pole block (CC, ISO: I,J,K) you programmed the same axis twice.

Error correction

Edit the NC program


Error description 1A0-000A

Error message

No tool axis defined

Cause of error

No plane selection or tool axis direction programmed, or no default plane specified.

Error correction

Edit the NC program or specify the default working plane in the configuration.


Error description 1A0-000B

Error message

No arc end point programmed

Cause of error

Arc end point data missing

Error correction

Program at least one coordinate of the arc end point.


Error description 1A0-000C

Error message

Arc block: No direction of rotation programmed

Cause of error

You programmed a circle without a direction of rotation.

Error correction

Always program the direction of rotation (DR).


Error description 1A0-000D

Error message

No arc radius programmed in CR block

Cause of error

Missing arc radius in CR block

Error correction

Program a radius in the CR block.


Error description 1A0-000E

Error message

System error in the geometry chain:
%1

Cause of error

System error in the geometry chain

Error correction

Inform your service agency.


Error description 1A0-000F

Error message

Pole is missing

Cause of error

You tried to move with polar coordinates (LP/CP/CTP, DIN/ISO: G10/G11/G12/G13/G15/G16), without first programming a pole (CC) (ISO: I/J/K); or you did not first enter a circle center when programming a circle.

Error correction

Program the pole (CC) before the first block with polar coordinates (ISO: I, J; K), or first program a circle center (CC) when programming a circle.


Error description 1A0-0010

Error message

System error in the geometry chain:
%1

Cause of error

System error in the geometry chain

Error correction

Inform your service agency.


Error description 1A0-0011

Error message

Programmed axis not assigned to a physical axis

Cause of error

Axis value programming with programmable axis without assigned physical axis

Error correction

- Correct the NC program.
- Inform your service agency.


Error description 1A0-0012

Error message

System error in the geometry chain: Gap in the programmed path

Cause of error

System error in the geometry chain

Error correction

Inform your service agency.


Error description 1A0-0013

Error message

Tool radius too large

Cause of error

- Inside contour radius smaller than tool radius
- Tool compensation results in contour damage (loop in the path of the tool center)
- Contour offset too large

Error correction

- Edit the NC program.
- Select a smaller tool.
- Program a smaller contour offset.


Error description 1A0-0016

Error message

Error in module configuration:
%1

Cause of error

Error in the module configuration (uninitialized list in configuration object)

Error correction

- Edit the configuration data.
- Inform your service agency.


Error description 1A0-0017

Error message

Error in module configuration:
%1

Cause of error

Error in module configuration (list size of an attribute in configuration object is too small)

Error correction

- Edit the configuration data.
- Inform your service agency.


Error description 1A0-0019

Error message

Switch the diameter programming off before eccentric grinding

Cause of error

Diameter programming not switched off before eccentric grinding

Error correction

Edit the cycle.


Error description 1A0-001B

Error message

Automatic pole capture not permitted

Cause of error

You programmed (automatic pole capture) a CC block (DIN/ISO: I,J,K) without coordinates. This is not possible in the current context, since the TNC cannot clearly identify the plane for the pole.

Error correction

- In the block directly before the pole-capture block, program two linear axes of the working plane.
- Specify the working plane via TOOL CALL


Error description 1A0-001C

Error message

Angle reference missing

Cause of error

In an LP/CP block (ISO: G10, G11, G12, G13) no polar angle or incremental polar angle is defined, i.e.:
- The distance between the last programmed position and the pole is less than or equal to 0.1 µm.
- No rotation is programmed between pole assumption and an LP/CP block.

Error correction

- Program the absolute polar angle.
- Check the position of the pole.
- If necessary, reset the rotation.


Error description 1A0-001D

Error message

Incorrect pole axis for selected working plane

Cause of error

- Z component with XY plane
- X component with YZ plane
- Y component with ZX plane

Error correction

Edit the NC program.


Error description 1A0-001E

Error message

Chamfer/rounding arc: Subsequent line lies in the wrong plane

Cause of error

After programming a transition element (RND/CHF), you programmed a linear element that does not lie in the plane of the transition element.

Error correction

Edit the NC program.


Error description 1A0-0021

Error message

System error in the geometry chain:
%1

Cause of error

System error in the geometry chain

Error correction

Inform your service agency.


Error description 1A0-0022

Error message

System error in the geometry chain:
%1

Cause of error

System error in the geometry chain

Error correction

Inform your service agency.


Error description 1A0-0024

Error message

An axis must not be locked after a contour transition element

Cause of error

Rounding or chamfer programmed immediately before axis locking

Error correction

- Correct the NC program.
- Eliminate contour transition element from program, or
- Program target position after contour transition element.


Error description 1A0-0025

Error message

Presetting not permitted after a contour transition element

Cause of error

Setting the base transformation immediately after contour transition element

Error correction

- Correct the NC program.
- Eliminate contour transition element from program, or
- Program target position after contour transition element.


Error description 1A0-0026

Error message

Setting of axis values not permitted immediately after contour
transition element.

Cause of error

Setting of axis values immediately after contour transition element

Error correction

- Edit the NC program.
- Eliminate contour transition element from program or
- Program target position after contour transition element.


Error description 1A0-0027

Error message

Tool change not permitted right after contour transition element

Cause of error

Tool change immediately after contour transition element

Error correction

- Correct NC program.
- Eliminate contour transition element from program, or
- Program target position after contour transition element.


Error description 1A0-0028

Error message

Probe block not permitted right after contour transition element

Cause of error

Probing block immediately after contour transition element

Error correction

- Correct the NC program.
- Eliminate contour transition element from program, or
- Program target position after contour transition element.


Error description 1A0-002B

Error message

Touch point inaccessible

Cause of error

In the TCH-PROBE 0 cycle (ISO: G55) or during use of the manual probing cycles, no touch point was reached within the traverse path defined in the touch probe table.

Error correction

- Preposition the touch probe closer to the workpiece.
- Increase the value in the touch probe table.


Error description 1A0-002C

Error message

Two successive APPR/DEP movements programmed

Cause of error

- Two approach/depart movements programmed in succession.
- Elements with zero length were programmed between two approach/departure movements.

Error correction

Edit the NC program.


Error description 1A0-002D

Error message

Compensation switching not permitted

Cause of error

Change of compensation without previous end of compensation

Error correction

- Edit the NC program.
- Close the previous contour.


Error description 1A0-002F

Error message

Tool definition is missing

Cause of error

The geometry chain has received no tool data before switching on the tool compensation.

Error correction

- Edit the NC program.
- Inform your service agency.


Error description 1A0-0030

Error message

Path comp wrongly started

Cause of error

You tried to activate the tool radius compensation with RL or RR (ISO: G41 or G42) in an arc block.

Error correction

Activate the tool radius compensation only with a linear block (L, ISO: G0, G1, G10, G11).


Error description 1A0-0031

Error message

Path comp wrongly ended

Cause of error

You tried to cancel the tool radius compensation with R0 (ISO: G40) in an arc block.

Error correction

Cancel the tool radius compensation only with a linear block (L, ISO: G0, G1, G10, G11).


Error description 1A0-0032

Error message

Switching the working plane not permitted

Cause of error

- Change of working plane after RND, CHF, APPR

Error correction

- Edit the NC program.


Error description 1A0-0033

Error message

Rounding cannot be calculated

Cause of error

- The rounding was programmed in the first positioning block of the NC program.
- Before the rounding, a contour element was programmed that does not lie exclusively in the working plane.
- Before the rounding, a contour element was programmed that has no geometric length.
- An RND block (DIN/ISO: G25) was selected with GOTO after a program interruption.

Error correction

- At least two contour elements must be programmed before the rounding.
- The contour element immediately before the rounding must be programmed exclusively in the working plane.
- After a program interruption, restart at least two positioning blocks before the RND block.


Error description 1A0-0034

Error message

Chamfer cannot be calculated

Cause of error

- The chamfer was programmed in the first positioning block of the NC program.
- Before the chamfer, a contour element was programmed that does not lie exclusively in the working plane.
- Before the chamfer, a contour element was programmed that has no geometric length.
- An CHF block (DIN/ISO: G24) was selected with GOTO after a program interruption.

Error correction

- At least two contour elements must be programmed before the chamfer.
- The contour element immediately before the chamfer must be programmed exclusively in the working plane.
- After a program interruption, restart at least two positioning blocks before the CHF block.


Error description 1A0-0035

Error message

Two successive transitional elements not permitted

Cause of error

- Two transition elements were programmed in succesion
- CHF after transition element
- RND after transition element
- APPRLT after transition element
- APPRLN after transition element
- APPRCT after transition element
- APPRLCT after transition element
- DEPLT after transition element
- DEPLN after transition element
- DEPCT after transition element
- DEPLCT after transition element

Error correction

- Edit the NC program.


Error description 1A0-0036

Error message

Contour transition not concluded

Cause of error

- Missing curve element after CHF/RND
- E.g. program end after CHF/RND

Error correction

- Edit the NC program.


Error description 1A0-0037

Error message

General system error in the geometry chain

Cause of error

- Contradictory data.

Error correction

- Inform your service agency.


Error description 1A0-0038

Error message

Incorrect application of Cycle 19

Cause of error

- Before Cycle 19 was called, tilted working plane was switched off (FN17 ID210 NR6).

Error correction

Edit the NC program.


Error description 1A0-0039

Error message

Incorrect application of Cycle 19

Cause of error

- Before Cycle 19 was called, Cycle 8 or Cycle 10 was called.

Error correction

Edit the NC program.


Error description 1A0-003A

Error message

Incorrect axis index for FN18

Cause of error

- In the Read System Data function (FN18, ISO: D18), you entered an incorrect axis index.

Error correction

- Check the index of the system datum.


Error description 1A0-003B

Error message

System error in the geometry chain:
Message in wrong state
%1 %2 %3

Cause of error

- System error in the geometry chain

Error correction

- Inform your service agency.


Error description 1A0-003C

Error message

Calculation of tool center path or contour-linking operations
for present contour lists failed!

Cause of error

- Internal software error

Error correction

- Change the contour definitions
- Inform your service agency


Error description 1A0-003D

Error message

System error in the geometry chain:
%1

Cause of error

- System error in the geometry chain

Error correction

- Inform your service agency.


Error description 1A0-003E

Error message

Tool compensation must not be switched on after G27

Cause of error

An attempt was made to switch on the radius compensation after G27.

Error correction

Remove the radius compensation.


Error description 1A0-003F

Error message

Linear movement not allowed

Cause of error

You tried to program a linear movement after G27 before deactivating the radius compensation.

Error correction

- First switch off the radius compensation


Error description 1A0-0040

Error message

Approach movement by means of RND not allowed right after
a contour transition element

Cause of error

An approach was programmed with RND after RND or CHF.

Error correction

- Edit the NC program.


Error description 1A0-0041

Error message

G26 programmed in wrong context

Cause of error

- Radius compensation was not switched on immediately after G26.

Error correction

- Switch on the radius compensation immediately before G26.


Error description 1A0-0042

Error message

G26 not allowed after corner rounding or chamfer

Cause of error

You programmed a G26 after RND (ISO: G25) or CHF (ISO: G24).

Error correction

- Edit the NC program


Error description 1A0-0043

Error message

G27 not allowed when tool compensation is off

Cause of error

A G27 was programmed, although tool compensation was switched off.

Error correction

- Edit the NC program.


Error description 1A0-0044

Error message

Radius compensation must not be switched on in a block
preceding the approach block

Cause of error

You tried to switch on the tool radius compensation before an approach block.

Error correction

- Switch on the tool radius compensation only in the approach block


Error description 1A0-0045

Error message

System error in the geometry chain:
%1 %2

Cause of error

System error: Data in a message are contradictory.

Error correction

- Inform your service agency.


Error description 1A0-0046

Error message

Pole programming with only one coordinate not allowed

Cause of error

You defined a pole in only one axis.

Error correction

- Program two axes or no axes (automatic pole transfer)


Error description 1A0-0047

Error message

Circular arc after G27 not allowed

Cause of error

A circular arc was programmed after G27.

Error correction

- Edit the NC program.


Error description 1A0-0048

Error message

Helix after corner rounding or chamfer not allowed

Cause of error

A helix was programmed after a contour transition element.

Error correction

- Edit the NC program.


Error description 1A0-0049

Error message

Height of helix must not lie a circle plane

Cause of error

You programmed an incorrect axis in the direction perpendicular to the circle plane.

Error correction

- Edit the NC program


Error description 1A0-004A

Error message

Angle of a helical path must be programmed incrementally

Cause of error

You programmed a helix without incremental data on the angle.

Error correction

- Edit the NC program


Error description 1A0-004B

Error message

The sign and direction of a circle's angle are
contradictory

Cause of error

In a circular movement, you programmed a negative angle increment to a positive direction of rotation (counterclockwise) or a positive angle increment to a negative direction of rotation (clockwise).

Error correction

- Correct the direction of the movement or the algebraic sign of the angle


Error description 1A0-004C

Error message

Tangent at start point of element not defined

Cause of error

A geometrical element with tangential transition (e.g. CT) was programmed. However, the tangent at the start point is undefined, e.g. because of an immediately preceding verticaldeparture. or because it is the 1st block of the NC program.

Error correction

- Edit the NC program.


Error description 1A0-004D

Error message

First geometric element after scaling is not a straight line

Cause of error

A scaling was programmed immediately before a geometric element that is not a linear element.

Error correction

- Edit the NC program.


Error description 1A0-004E

Error message

Linear movement after tangential departure is not in circle plane

Cause of error

Immediately after a tangential departure, a linear element was programmed that contains a component perpendicular to the arc plane.

Error correction

Edit the NC program.


Error description 1A0-004F

Error message

Tool compensation not switched off for 5-axis movement

Cause of error

You programmed a linear 5-axis movement although the tool radius compensation was active.

Error correction

- Switch off the tool radius compensation beforehand


Error description 1A0-0050

Error message

Linear 5-axis movement not allowed after transition element

Cause of error

A linear 5-axis movement was programmed after a contour transition element.

Error correction

- Edit the NC program.


Error description 1A0-0051

Error message

Illegal axis programmed

Cause of error

You programmed an illegal axis.

Error correction

Edit the NC program:
- Program another axis
- Change the machining mode via FUNCTION MODE MILL/TURN
- Switch to another tool (with the appropriate tool type and tool orientation)
- In the Programming mode, switch the AUTO DRAW soft key to ON and edit/check the (sub-) contour in a separate NC program
- Edit/check the (sub-) contour in a separate NC program if the error with the AUTO DRAW soft key appears on ON


Error description 1A0-0052

Error message

System error in the geometry chain:
%1

Cause of error

System error: Not all axis values were included in the message GmAxesValueSet.

Error correction

- Inform your service agency.


Error description 1A0-0053

Error message

Programmed NC block not permitted right after a contour
transition element

Cause of error

- Immediately after a transition element an attempt was made to program an NC block that is not allowed at that

Error correction

- Edit the NC program.
- Inform your service agency.


Error description 1A0-0054

Error message

System error in the geometry chain:
%1

Cause of error

System error: The axis programmed in Cycle 19 is not a physical axis.

Error correction

- Inform your service agency.


Error description 1A0-0055

Error message

System error in the geometry chain:
%1

Cause of error

System error: The axis programmed in Cycle 19 is a rotary axis.

Error correction

- Inform your service agency.


Error description 1A0-0056

Error message

System error in the geometry chain:
%1

Cause of error

System error: The value in the message GmGeoRotWorkPlane is not absolute.

Error correction

- Inform your service agency.


Error description 1A0-0057

Error message

Probe monitoring must not be switched on right after
a contour transition element

Cause of error

The probe monitoring was switched on immediately after a contour element was programmed.

Error correction

- Complete the contour before switching on the touch probe.


Error description 1A0-0058

Error message

TCPM must not be switched on or off right after
a contour transition element

Cause of error

An attempt was made to switch the TCPM mode on or off immediately after a contour transition element.

Error correction

- Edit the NC program.


Error description 1A0-0059

Error message

%1 not allowed

Cause of error

A function was programmed that is not allowed in the current context.

Error correction

- Edit the NC program.


Error description 1A0-005A

Error message

System error in the geometry chain:
%1

Cause of error

System error in the geometry chain.

Error correction

- Inform your service agency.


Error description 1A0-005B

Error message

System error in the geometry chain:
%1

Cause of error

System error in the geometry chain.

Error correction

- Inform your service agency.


Error description 1A0-005C

Error message

System error in the geometry chain:
%1 %2

Cause of error

System error in internal path calculation

Error correction

- Inform your service agency


Error description 1A0-005D

Error message

Thread cycle not allowed right after a contour transition element

Cause of error

A thread cycle was programmed immediately after a contour transition element.

Error correction

- Edit the NC program.


Error description 1A0-005E

Error message

Tool not perpendicular to working plane

Cause of error

You tried to use a function that requires the tool to be perpendicular to the working plane (e.g. tapping) when it was not.

Error correction

- Edit the NC program
- Rotate the tool to make it perpendicular to the working plane
- If need be, tilt back the working plane


Error description 1A0-005F

Error message

Thread cutting not allowed with tool compensation active

Cause of error

A tapping cycle was programmed with the tool compensation switched on.

Error correction

- First switch off the tool compensation.


Error description 1A0-0060

Error message

Plunging depth in tapping cycle too small

Cause of error

Excessively small plunging depth was programmed in a tapping cycle.

Error correction

- Select a larger value for plunging depth.


Error description 1A0-0061

Error message

Plunging depth in tapping cycle has wrong sign

Cause of error

In a tapping cyle the plunging depth was programmed with negative sign.

Error correction

- Edit the NC program.


Error description 1A0-0062

Error message

Value for retraction has wrong sign

Cause of error

You programmed the retraction value with the incorrect algebraic sign.

Error correction

- Enter the algebraic sign


Error description 1A0-0063

Error message

System error in the geometry chain:
%1

Cause of error

- System error in the geometry chain.

Error correction

- Inform your service agency.


Error description 1A0-0064

Error message

Tool change not allowed with tool compensation active

Cause of error

You programmed a tool change while the tool radius compensation was active.

Error correction

- Switch off the tool radius compensation before a tool change


Error description 1A0-0065

Error message

Tool compensation must not be switched on before
the approach block

Cause of error

You activated the tool radius compensation before the approach block.

Error correction

Switch on the tool radius compensation in the approach block


Error description 1A0-0066

Error message

System error in the geometry chain:
%1

Cause of error

- System error in the geometry chain

Error correction

- Inform your service agency.


Error description 1A0-0067

Error message

Departure movement not permitted immediately
after activation of tool radius compensation

Cause of error

A departure was programmed immediately after switch-on of the tool compensation.

Error correction

Program a geometric element before departure.


Error description 1A0-0068

Error message

System error in the geometry chain:
%1

Cause of error

- System error in the geometry chain.

Error correction

- Inform your service agency.


Error description 1A0-006A

Error message

System error in the geometry chain:
%1

Cause of error

- Sytem error in the geometry chain.

Error correction

- Inform your service agency.


Error description 1A0-006B

Error message

System error in the geometry chain:
%1 %2

Cause of error

- System error in the geometry chain.

Error correction

- Inform your service agency.


Error description 1A0-006C

Error message

System error in the geometry chain:
%1

Cause of error

- System error in the geometry chain.

Error correction

- Inform your service agency.


Error description 1A0-006D

Error message

Approach movement not allowed before touch probe cycle

Cause of error

An approach was programmed before a probing cycle.

Error correction

- Edit the NC program.


Error description 1A0-006E

Error message

System error in the geometry chain:
%1

Cause of error

System error in the geometry chain.

Error correction

- Inform your service agency.


Error description 1A0-006F

Error message

DEP movement not allowed right after a nonplanar movement

Cause of error

Illegal movement before a departure (DEP).

Error correction

Edit the NC program


Error description 1A0-0070

Error message

Mid-program startup not possible

Cause of error

The target position of the mid-program startup is within a thread or measuring cycle.

Error correction

- Choose a different target position for mid-program startup


Error description 1A0-0071

Error message

APPR/DEP CT or APPR/DEP LN not allowed
with inactive tool radius compensation

Cause of error

You programmed APPR/DEP CT or APPR/DEP LN with inactive tool radius compensation.

Error correction

Edit the NC program


Error description 1A0-0072

Error message

Approach movement cannot be calculated

Cause of error

The given geometric data do not result in a defined approach.

Error correction

Program another approach.


Error description 1A0-0073

Error message

Departure movement cannot be calculated

Cause of error

The given geometric data do not result in a defined departure.

Error correction

Program another departure


Error description 1A0-0074

Error message

Circle tangent cannot be calculated

Cause of error

A circle was programmed with radius 0.

Error correction

Edit the NC program


Error description 1A0-0075

Error message

After tangential departure only a line block is permitted

Cause of error

An illegal movement was programmed after a tangential departure.

Error correction

Program an L block after a tangential departure.


Error description 1A0-0076

Error message

Rounding or chamfer cannot be calculated

Cause of error

Connecting geometrical element is too small or has the same tangent.

Error correction

Edit the NC program.


Error description 1A0-0077

Error message

System error in the geometry chain:
%1

Cause of error

Cause is stated in the error text.

Error correction

Inform your service agency.


Error description 1A0-0078

Error message

Illegal probe function

Cause of error

You tried to conduct a probe function during active mirroring or scaling.

Error correction

Edit the NC program


Error description 1A0-0079

Error message

No contour pockets present for fixed cycle

Cause of error

- No contour pocket geometery, or only islands defined

Error correction

- Program the missing Cycle 14
- If required, check the rotational direction and compensation direction of the individual contours


Error description 1A0-007A

Error message

Invalid contour expression

Cause of error

Syntax error in contour expression: Missing parentheses, incorrect operands or operators, etc.

Error correction

- Check the contour expression


Error description 1A0-007B

Error message

No technological data available for contour pocket machining

Cause of error

A Cycle 20 must be programmed before every fixed cycle 21, 22, 23, or 24.

Error correction

Program a Cycle 20


Error description 1A0-007C

Error message

Compensation spacing of tool paths too small

Cause of error

The compensation distance of the tool center path during contour cycle machining is less than 0.1 mm.

Error correction

– Use a larger tool radius, or
- Increase the path overlap (Q2) (if relevant for the called cycle).


Error description 1A0-007E

Error message

Polar programming not possible if M91/M92 is active

Cause of error

You tried to program polar coordinates during an active M91/M92.

Error correction

Program the positions with Cartesian coordinates


Error description 1A0-007F

Error message

Pole invalid

Cause of error

The pole was not programmed in the currently valid coordinate system. The error occurs when M91/M92 is used to define or apply the pole.

Error correction

Program a new pole


Error description 1A0-0080

Error message

Arc definition in parallel coordinate axes

Cause of error

You programmed the arc end point in parallel coordinate axes (e.g. X and U coordinate).

Error correction

Program the arc end point in two coordinate axes that define a plane (e.g. X and V coordinate).


Error description 1A0-0081

Error message

Invalid helix definition

Cause of error

You programmed a helical path with more than one coordinate outside the plane of the arc.

Error correction

Program a helix with one coordinate perpendicular to the plane of the arc.


Error description 1A0-0082

Error message

Circle incorrectly programmed

Cause of error

Start point and end point are the same in a programmed arc.

Error correction

Program the start point and end point with different coordinates.


Error description 1A0-0083

Error message

Circle incorrectly programmed

Cause of error

Radius for circular arc programming too small (radius of 0 or insufficient distance between start point and end point).

Error correction

- Increase the radius
- Program the start point and end point with different coordinates.


Error description 1A0-0084

Error message

Circle incorrectly programmed

Cause of error

Center or end point of CC data is incorrect.
The distances from the start point to the midpoint and from the end point to the midpoint differ by more than the tolerance value.

Error correction

The starting point, end point, and midpoint do not belong to a circular segment.
- Recalculate the midpoint and/or end point.
- If necessary, use another type of circular arc programming.


Error description 1A0-0085

Error message

Circle incorrectly programmed

Cause of error

The end point of a CT block lies in the extension of the tangent of the previously programmed contour element.

Error correction

Edit the coordinates of the end point


Error description 1A0-0086

Error message

Scaling factor invalid

Cause of error

- The programmed scaling factor is outside of the permitted range.

Error correction

- Enter a scaling factor in the range of
0.000 001 to 99.999 999.


Error description 1A0-0087

Error message

Mid-program startup not allowed

Cause of error

Mid-program startup not allowed after an approach block that was programmed immediately before the program end.

Error correction

Set the mid-program startup to the block in which the approach movement is programmed.


Error description 1A0-0088

Error message

Working plane cannot be changed

Cause of error

You called Cycle 10 (ISO: G73) before selecting the plane.

Error correction

Edit the NC program


Error description 1A0-0089

Error message

Illegal base transformation

Cause of error

The base information applies to a nonexistent axis.

Error correction

Change the datum.


Error description 1A0-008A

Error message

Illegal coordinate transformation

Cause of error

The coordinate transformation applies to a nonexistent axis.

Error correction

Edit the NC program.


Error description 1A0-008B

Error message

Incorrect axis index for FN18

Cause of error

Coordinate transformations can be used only for the principal axes X,Y,Z.

Error correction

Edit the NC program.


Error description 1A0-008C

Error message

Illegal coordinate transformation

Cause of error

Coordinate transformations can be used only for the principal axes X,Y,Z.

Error correction

Edit the NC program.


Error description 1A0-008D

Error message

Not enough block memory

Cause of error

The system cannot resolve the NC program due to lack of block memory. Between two tool movements only a limited number of blocks can be processed that cause no movement (e.g.comments or variable assignments).

Error correction

Edit the NC program


Error description 1A0-008E

Error message

Safety clearance for synchronization of spindles is missing

Cause of error

No safety clearance was entered for synchronizing the spindle.

Error correction

Edit the NC program.


Error description 1A0-008F

Error message

Tool radius too large

Cause of error

The radius of the cutter is too large to machine the programmed contour pockets or contour trains.

Error correction

Use a smaller tool radius or change the geometry of the contour pockets or contour trains.


Error description 1A0-0090

Error message

Drill radius too large

Cause of error

- The pilot drill being used causes a collision with an edge contour.

Error correction

- Use a smaller drill or larger cutter. If the drill radius is equal to or less than the cutter radius, there can be no collisions.


Error description 1A0-0091

Error message

R0 not allowed in contour subprogram.

Cause of error

Within a contour subprogram, RL/RR controls the type of contour (pocket/island). R0 is undefined and illegal.

Error correction

Remove R0 from the contour subprogram.


Error description 1A0-0092

Error message

Rounding radius for inside corners too large

Cause of error

The circular arcs with the inside corner rounding radius programmed in Cycle 20 are too large to be inserted between two neighboring contour elements.

Error correction

Select a smaller rounding radius in Cycle 20.


Error description 1A0-0093

Error message

No space for approach movement

Cause of error

No suitable position was found for a collision-free approach in a contour pocket cycle (stroke of reciprocation during clearance, approach arc during finishing).

Error correction

Use a smaller tool diameter, change the pocket geometry, try drilling instead of a reciprocating plunge.


Error description 1A0-0094

Error message

Cannot calculate tool radius compensation

Cause of error

Cannot calculate a tool radius compensation for the programmed contour in the working plane.

Error correction

Circles can be corrected only in the working plane.


Error description 1A0-0095

Error message

Cannot calculate tool radius compensation

Cause of error

Cannot make a tool radius compensation for the programmed contour.

Error correction

Edit the contour or use another tool.


Error description 1A0-0096

Error message

Contour subprogram: Illegal axis programmed

Cause of error

You programmed an illegal axis (e.g. a rotary axis) within a contour subprogram.

Error correction

Define in the contour subprogram only coordinates of the active working plane. Edit the NC program.


Error description 1A0-0097

Error message

Clearance height lies on machining side

Cause of error

The clearance height (Q7) programmed for the called cycle lies on the machining side of the workpiece surface (Q5) specified by the algebraic sign of the milling depth (Q1). That is not allowed.
Also, the (absolute) clearance height (Q7) should not be equal to the (absolute) coordinate of the workpiece surface (Q5).

Error correction

- Change the cycle parameters clearance height (Q7), milling depth (Q1) and/or the coordinate of the workpiece surface (Q5).


Error description 1A0-0098

Error message

Limit plane: Jump/jump not allowed

Cause of error

The "jump" method of machining cannot be set for both sides of a limit plane.

Error correction

Select another machining method for the limit plane.


Error description 1A0-0099

Error message

Limit plane: jump move in wrong direction

Cause of error

A jump auxiliary movement must go toward the jump side of the limit plane.

Error correction

Change the direction of the jump auxiliary movement or adjust the clearance height


Error description 1A0-009A

Error message

Limit plane: Incomplete definition of limit plane

Cause of error

Cannot acivate the plane because it has not been defined completely. A point or normal vector of the plane is missing, or maybe the direction for projection or for the jump auxiliary movements.

Error correction

Program the missing information before the plane is activated.


Error description 1A0-009B

Error message

An active limit plane cannot be redefined or deleted

Cause of error

The definition of the limit plane cannot be changed or deleted as long as the limit plane is active.

Error correction

First deactivate the limit plane.


Error description 1A0-009C

Error message

Cannot activate/deactivate limit plane now

Cause of error

The limit plane can be switched on or off only if the programmed position is on a curve side or a jump side beyond the 2nd safety clearance.

Error correction

Move to a safe position before switching the limit plane on or off.


Error description 1A0-009D

Error message

Limit plane: Space between 2 limit planes must be set to "curve"

Cause of error

Between two limit planes (for non-parallel planes: in the work space) the curve machining method must be set.

Error correction

Adjust the machining method for one or both limit planes.


Error description 1A0-009E

Error message

SL cycle call with active tool radius compensation

Cause of error

Before an SL cycle is called the tool radius compensation must be switched off.

Error correction

Program an R0 before the SL cycle or move the cycle call to another place.


Error description 1A0-009F

Error message

An active zoning filter cannot be redefined or deleted

Cause of error

The definition of the zoning filter cannot be deleted or edited as long as the zoning filter is still active.

Error correction

First define the zoning filter.


Error description 1A0-00A0

Error message

Definition of the zoning filter incomplete

Cause of error

The zoning filter could not be activated because it was not fully defined. It still needs: at least one polygon (curve), a projection direction (of the length >0, if explicitly programmed), a setup clearance and a clearance height.

Error correction

Program the missing data before the zoning filter is activated.


Error description 1A0-00A1

Error message

Definition of the zoning polygons (polygon curves) inconsistent

Cause of error

A closed zoning polygon must be defined by at least three points, an open polygon curve by at least two points. Each side of a polygon (curve) must have a component perpendicular to the direction of zoning projection. The individual polygon curves must
not intersect with themselves or with the other polygon curves. An "illegal" zone must not enclose a "legal" zone.

Error correction

Check the definition of the zoning polygons (curves) and correct them.


Error description 1A0-00A2

Error message

Incorrect sequence of vertices of a zoning polygon (polyg. curve)

Cause of error

The corner points of a polygon curve must be produced in the sequence: FirstPoint ->IntermediatePoint -> ... -> IntermediatePoint -> LastPoint(ForClose). The corresponding attributes must have the correct syntax.

Error correction

Note the correct sequence in the definition of zoning polygons.


Error description 1A0-00A3

Error message

Invalid tool technology data

Cause of error

Technology data of the tool used, such as ANGLE or LCUTS, are not registered in the tool database or have invalid values.

Error correction

Make or correct the corresponding entries:
ANGLE : Max. plunge angle in degrees, 1.0 <= ANGLE <= 90.0
LCUTS : Tooth length in mm, 0.1 <= LCUTS <= tool length


Error description 1A0-00A4

Error message

Tooth length of the tool used is too small

Cause of error

The tooth length of the tool used is smaller than the plunging depth programmed in the cycle.

Error correction

Program a smaller plunging depth or use a tool with a longer tooth.


Error description 1A0-00A5

Error message

No contours are available under this label

Cause of error

Possible causes:
- Contour labels that are be used as operands in expressions must have been assigned contours by means of DECLARE CONTOUR or by using previous expressions.
- The contour can be empty, e.g. because antiparallel contour elements cancel each other.

Error correction

Check the contour declarations and expressions.


Error description 1A0-00A6

Error message

Tool form compensation not allowed with active tool radius comp.

Cause of error

Tool form compensation (LN blocks with programmed workpiece normal) is not allowed during active tool radius compensation (RR/RL).

Error correction

Edit the NC program (e.g. R0 before first LN block).


Error description 1A0-00A7

Error message

No machining side defined for peripheral milling

Cause of error

Before activation of the 3-D tool radius compensation (peripheral milling) no machining side was programmed with RR/RL.

Error correction

Change the NC program (e.g. RL or RR before the first LN or L block).


Error description 1A0-00A8

Error message

Axis-specific scaling factor not allowed

Cause of error

During active tool radius compensation, axis-specific scaling factors are not allowed for circular and helical movements.

Error correction

Edit the NC program.


Error description 1A0-00A9

Error message

Operation not allowed with active radius compensation

Cause of error

A function was programmed (e.g. cycle, tool change) that is not allowed during active tool radius compensation.

Error correction

First switch off the tool radius compensation.


Error description 1A0-00AA

Error message

Incorrect tool at start of block scan
(current T%1, programmed T%2)

Cause of error

Mid-program startup with incorrect tool.

Error correction

Change to the correct tool and start again.


Error description 1A0-00AB

Error message

Block scan cannot jump over probing functions

Cause of error

A probing function was found before the block being searched for with the block scan.

Error correction

Attempt the block scan on a different block


Error description 1A0-00AC

Error message

Gap in non-cylindrical contour

Cause of error

The starting and end point of a non-cylindrical contour do not coincide.

Error correction

Edit the part program


Error description 1A0-00AD

Error message

Contour intersects itself

Cause of error

The edge contour of a pocket cannot be programmed to intersect itself.

Error correction

Change the contour definition in the NC program.


Error description 1A0-00AE

Error message

Active tool larger than reference tool

Cause of error

To fully prevent collisions with the workpiece, the tool selected for machining with 3-D tool compensation must in every direction have a surface curvature that is not smaller than that of the reference tool.

Error correction

- Use a smaller tool.
- Ensure that there are no collisions with the currently used tool, and use M107 to suppress this error.


Error description 1A0-00AF

Error message

Axis-specific scaling not allowed

Cause of error

An axis-specific scaling factor is not allowed during the definition of a limit plane filter or zoning filter, or during active 3-D tool radius compensation or tool form compensation.

Error correction

Edit the NC program.


Error description 1A0-00B0

Error message

Axis-value programming not allowed

Cause of error

Axis value programming in a linear block with 3-D tool radius compensation or tool form compensation is allowed only for rotary axes, not for translation axes.

Error correction

Use coordinate programming (remove M91)


Error description 1A0-00B1

Error message

Rotary axes mixed with tool polar vectors

Cause of error

Rotary axis values and tool direction vectors must never be in the same NC block, and during active 3-D tool radius compensation they also must not appear alternately in successive blocks.

Error correction

- Program either only rotary axes or only one direction vector (TX, TY, TZ) to specify the tool axis direction per NC block.
- During active 3-D tool radius compensation, program either only direction vectors or only rotary axes. If necessary, switch the tool radius compensation off and then on again within the program.


Error description 1A0-00B2

Error message

Programmed direction vector is zero vector

Cause of error

A programmed direction vector in an LN block must have at least one component not equal to zero.

Error correction

- Program NX, NY, NZ, TX, TY or TZ to be unequal to zero.
- Remove NX, NY and NZ from the LN block (in which case there will be no tool form compensation!) or remove TX, TY and TZ (in which case the tool axis direction will not be changed).


Error description 1A0-00B3

Error message

No spindle available for tapping

Cause of error

No spindle available for tapping

Error correction

Use a configuration with a spindle


Error description 1A0-00B4

Error message

Missing start angle for incremental programming

Cause of error

If the end point of the last block lies on the pole, incremental angle programming is not allowed.

Error correction

Program the angle here with absolute values.


Error description 1A0-00B5

Error message

Position logic not allowed in App/Dep movement

Cause of error

It is not allowed to switch on the "Positioning logic" during APPR/DEP movements.

Error correction

Switch off the "Positioning logic" before the APPR/DEP movement.


Error description 1A0-00B6

Error message

Position logic not allowed in rounding/chamfer

Cause of error

It is not allowed to switch on the "Positioning logic" during rounding/chamfer movements

Error correction

Switch off the "Positioning logic" before the rounding/chamfer movement


Error description 1A0-00B7

Error message

Specified axis does not lie on "ToolSide"!

Cause of error

The specified axis does not lie on the "tool side" of the kinematic elements.

Error correction

The specified axis lies on the "tool side" of the kinematic elements.


Error description 1A0-00B8

Error message

Specified axis does not lie on "WpSide"!

Cause of error

The specified axis does not lie on the "workpiece side" of the kinematic elements.

Error correction

Set the specified axis on the "workpiece side" of the kinematic elements.


Error description 1A0-00B9

Error message

Specified axes inconsistent!

Cause of error

The specified axes are faulty

Error correction

Inform your service agency


Error description 1A0-00BA

Error message

Programming of axes in the REF system is not allowed
after RND/CHF or APPR/DEP

Cause of error

Programming of axes in the REF system is not allowed after RND/CHF or APPR/DEP movements

Error correction

Use RND/CHF or APPR/DEP movements without M91


Error description 1A0-00BB

Error message

Programming together with M130 not allowed!

Cause of error

Programming together with M130 not allowed!

Error correction

This command cannot be used together with M130


Error description 1A0-00BC

Error message

Programming of axes in the REF system is not allowed

Cause of error

Polar programming is not allowed in the REF system!

Error correction

This command cannot be used together with M91


Error description 1A0-00BD

Error message

Polar kinematics not possible!

Cause of error

Polar kinematics are not possible with the specified axes!

Error correction

The given axes cannot be used for polar kinematics


Error description 1A0-00BE

Error message

General error in the calculation of a circle

Cause of error

No circle can be calculated from the given input data


Error description 1A0-00BF

Error message

It is not possible to program a tangential connecting arc
with axis-value programming.

Cause of error

- It is not possible to program a tangentially connecting arc during axis value programming

Error correction

- Program the arc with center and end point


Error description 1A0-00C0

Error message

Pole and arc in various planes

Cause of error

The pole and end point of the arc are not programmed in the same plane

Error correction

Check the definitions of the pole and the arc


Error description 1A0-00C1

Error message

Define the arc end point with two coordinates

Cause of error

Define the arc end point with two coordinates.

Error correction

Define the arc end point with both coordinates of the working plane.


Error description 1A0-00C2

Error message

Probe movement with length 0

Cause of error

A probing movement must have a length not equal to zero


Error description 1A0-00C3

Error message

Programming of rotary axes with circular movement is not allowed!

Cause of error

Programming of rotary axes with circular movement is not allowed!


Error description 1A0-00C4

Error message

Departing movement not allowed!

Cause of error

Preceding movement is too complex

Error correction

Omit the departing movement or program the preceding movement differently


Error description 1A0-00C5

Error message

System error in geometry chain:
%1

Cause of error

System error

Error correction

Inform your service agency


Error description 1A0-00C6

Error message

Error in the geometry configuration.
%1

Cause of error

Indicated in English in the additional text

Error correction

Corresponding to the given cause


Error description 1A0-00C7

Error message

Not allowed after approaching movement

Cause of error

Indicated in English in the additional text

Error correction

Corresponding to the given cause


Error description 1A0-00C8

Error message

Probing length must not be zero!

Cause of error

The probing length is zero.

Error correction

Correct the probing length (must be greater than 0)


Error description 1A0-00C9

Error message

Nesting of pocket definitions is not allowed!

Cause of error

Nested pockets programmed

Error correction

Edit the program


Error description 1A0-00CA

Error message

Deletion of the configuration object is not allowed!
%1

Cause of error

The type of deleted object is indicated in English in the additional text

Error correction

Use the configuration editor to reinsert the deleted object


Error description 1A0-00CB

Error message

Contour train cannot be machined.

Cause of error

The contour description is ambiguous:
The selected contour contains too many subcontours.

Error correction

Edit the NC program.


Error description 1A0-00CC

Error message

Error in tool radius compensation

Cause of error

The tool radius compensation is missing or the entered tool radius compensation cannot be machined.

Error correction

Edit the NC program.


Error description 1A0-00CD

Error message

Empty contour

Cause of error

An operand or intermediate result in the contour calculation is an empty contour.

Error correction

Edit the NC program.


Error description 1A0-00CE

Error message

A contour element of the slot in the cylinder surface too small

Cause of error

Possible causes:
One distance is too short, or an angular length is too small.

Error correction

Edit the NC program.


Error description 1A0-00CF

Error message

The data of the slot in the cylinder surface are faulty

Cause of error

Possible causes:
A contour element of the slot is too small, the cylinder radius is too small, the slot too deep, or something similar.

Error correction

Edit the NC program.


Error description 1A0-00D0

Error message

The position entered for the cylinder in the working plane is incorrect

Cause of error

Possible causes:
Either the vectors do not have the length 1, they are not perpendicular, or there is some similar problem.

Error correction

Edit the NC program.


Error description 1A0-00D1

Error message

Tool not perpendicular to the cylinder surface

Cause of error

The cylinder must be aligned parallel to the machine axes and be clamped at the center of the rotary table. The tool must be perpendicular to the cylinder surface.

Error correction

If needed, tilt the working plane in order to position the tool perpendicular to the cylinder surface, unless this has already been configured in the kinematics.
- Program the position of the cylinder coordinate system correctly.
- If required, configure the machining table system at the center over the rotary axis. The Z axis of the machine table system must point in the direction of rotary axis rotation.


Error description 1A0-00D2

Error message

No translation axis is parallel to the cylinder reference axis

Cause of error

Possible causes:
The cylinder or the working plane is not in the right position.

Error correction

Edit the NC program.


Error description 1A0-00D3

Error message

Approach not allowed

Cause of error

Possible causes:
- APPR command in MDI mode
- APPR command at the end of an NC program
- APPR command before a coordinate transformation
- Similar sequence of NC commands

Error correction

Edit the NC program.


Error description 1A0-00D4

Error message

Reading the axis values is not allowed during block scan

Cause of error

During a block search you attempted to read the current axis values before finding the desired block.

Error correction

- Try a block scan to another block
- Edit the program


Error description 1A0-00D5

Error message

Contour subprogram for cylinder surface machining is faulty

Cause of error

Possible causes:
- Programmed contour is not defined in X/Y cylinder surface coordinates.
- Programmed contour contains incremental coordinates.
- Programmed contour contains diameter coordinates.

Error correction

Edit the NC program.


Error description 1A0-00D6

Error message

Contour subprogram for cylinder surface machining is faulty

Cause of error

Programmed contour is not defined in X/Y cylinder surface coordinates.

Error correction

Always program contours on a cylinder surface (regardless of the machine geometry) in X/Y cylinder surface coordinates.


Error description 1A0-00D7

Error message

No rotary axis found.

Cause of error

Possible causes: The first axis beneath the machine table must be a rollover rotary axis.

Error correction

- Change the kinematics configuration- Inform your service agency


Error description 1A0-00D8

Error message

Cylinder axis is not parallel to rotary axis.

Cause of error

Possible causes:
- The cylinder axis does not run parallel to the first axis under the machine table. The first axis under the machine table must be a rotary axis.
- The cylinder is not clamped in the center.
- One of the coordinate directions X, Y, or Z of the machine table system must point in the direction of the rotary axis.

Error correction

Change the kinematic configuration.


Error description 1A0-00D9

Error message

Basic rotation not allowed

Cause of error

The rotary axis of the basic rotation during cylinder surface machining does not lie parallel to the cylinder axis.
One of the coordinate directions X, Y, or Z of the machine table system must point in the direction of the rotary axis.

Error correction

- Change the basic rotation.
- Change the kinematic configuration.


Error description 1A0-00DA

Error message

Cylinder radius too small.

Cause of error

Cylinder radius too small.

Error correction

Edit the NC program.


Error description 1A0-00DB

Error message

Cylinder slot too deep or excessive plunging depth.

Cause of error

Cylinder slot too deep or excessive plunging depth.

Error correction

Edit the NC program.


Error description 1A0-00DC

Error message

Cylinder slot too shallow or insufficient plunging depth.

Cause of error

Cylinder slot too shallow or insufficient plunging depth.

Error correction

Edit the NC program.


Error description 1A0-00DD

Error message

Cylinder slot too narrow.

Cause of error

Cylinder slot too narrow.

Error correction

Edit the NC program.


Error description 1A0-00DE

Error message

The programmed safety clearance is too small.

Cause of error

The clearance height must be be at least as large as the cutter radius.

Error correction

Edit the NC program.


Error description 1A0-00DF

Error message

The precision for the slot walls is too small or too large.

Cause of error

The precision for the slot walls is too small or too large.

Error correction

Edit the NC program.


Error description 1A0-00E0

Error message

Diameter of selected milling cutter is too small.

Cause of error

Diameter of selected milling cutter is too small.

Error correction

Insert a different tool.


Error description 1A0-00E1

Error message

Transformation not allowed

Cause of error

Possible causes:
- Define datum shifts only in X/Y cylinder surface coordinates.
- Contour definition with angle data: program a datum shift only within the contour definition.
- Rotations and scaling are allowed only with length dimensions and only cylinder surface coordinates.
- Define mirroring only in cylinder surface coordinates.
- You must not change presets, basic rotations or the tilt condition during cylinder surface machining.

Error correction

Edit the NC program.


Error description 1A0-00E2

Error message

This action is not allowed

Cause of error

Possible causes:
This action is not yet implemented for cylinder surface machining.
There may be a positioning block that is not programmed in the cylinder surface.
Polar or axis-value programming, APPR or DEP blocks, probing blocks, thread cutting, tool change, certain cycles, 3-D tool compensation or similar things are also possible.

Error correction

Edit the NC program.


Error description 1A0-00E3

Error message

The tool is in the wrong position

Cause of error

The tool is in an incorrect or unexpected position, e.g. too deep in the workpiece.
This error also occurs during cylinder surface machining if the tool point is located too close to the cylinder axis.

Error correction

Edit the NC program, reposition the tool, or inform your service agency.


Error description 1A0-00E4

Error message

Contour too complex

Cause of error

A pocket contour consists of more than 10000 blocks.

Error correction

Adapt the NC program: Program a simpler contour.


Error description 1A0-00E5

Error message

M103 not allowed

Cause of error

A reduction of the infeed velocity in the negative tool axis direction is not possible. Possible causes are programmed, e.g. rotary axes, 3-D radius compensation or kinematic compensation movements.

Error correction

Edit the NC program.


Error description 1A0-00E6

Error message

Orientation not possible

Cause of error

You tried to orient the spindle through the NC, but no spindle is configured.

Error correction

Use a configuration with a spindle


Error description 1A0-00E7

Error message

Closed contour train not allowed

Cause of error

The contour train is closed or nearly closed.

Error correction

Use pocket machining cycles for closed contour trains.


Error description 1A0-00E8

Error message

Diameter of selected cutter is too large

Cause of error

The selected cutter does not fit in the cylinder slot.

Error correction

Insert a different tool.


Error description 1A0-00E9

Error message

Program resumption not possible

Cause of error

The program cannot be continued from the point of interruption.

Error correction

Use GoTo to position to the start of program, or select the program again.
If you are machining a pallet, then update the pallet table (perhaps set W-STATUS to BLANK).
Then the program can be started.


Error description 1A0-00EA

Error message

Rounding arc and chamfer not possible with active stretch filter

Cause of error

Transition elements (rounding arcs and chamfers) are not possible when the stretch filter is active.

Error correction

Switch off the stretch filter in the configuration (CfgStretchFilter).


Error description 1A0-00EB

Error message

Programmed parallel axis not available

Cause of error

In the FUNCTION PARAXCOMP or FUNCTION PARAXMODE functions, you programmed parallel axes that are not available in this kinematic model.

Error correction

- Use other machine kinematics
- Edit the NC program


Error description 1A0-00EC

Error message

Position of a linear axis is overdetermined

Cause of error

You programmed two end values for the same machine axis in one NC program block.
Possible causes:
- You programmed the axis as coordinate and, over the syntax element POS, also as axis value
- You did not switch with FUNCTION PARAXMODE to machining in minor axes or did not list the doubly defined axis in that function
- With an active polar kinematic configuration you additionally assigned a target value to an axis in the three-axis kinematic configuration

Error correction

Edit the NC program.


Error description 1A0-00ED

Error message

Syntax element POS not allowed in this block

Cause of error

You programmed the syntax element POS at an illegal place.

Error correction

Edit the NC program.


Error description 1A0-00EE

Error message

Parallel axes not allowed in this block

Cause of error

You tried to program parallel axes
- in approach or departure movements
- in circle center or pole definitions
- in circular or helical movements
- in LN blocks.

Error correction

Edit the NC program.


Error description 1A0-00EF

Error message

Polar kinematics not allowed with parallel axis machining

Cause of error

You tried to use FUNCTION PARAXMODE although a polar kinematic configuration is active.

Error correction

Switch off the machining method before you switch another on.


Error description 1A0-00F0

Error message

Kinematic switch-over is not allowed

Cause of error

You tried to use FUNCTION PARAXCOMP to program axis compensation values for parallel axes, although the default setting is not active.

Error correction

- Edit the NC program
- Switch the kinematics only in the default condition. The default condition is configured in the config object CfgAxesPropKin in the parameter parAxComp


Error description 1A0-00F1

Error message

Kinematic switch-over is not allowed

Cause of error

You have tried to perform a kinematics switch-over although FUNCTION PARAXMODE is active.

Error correction

Deactivate FUNCTION PARAXMODE before kinematic switch-over.


Error description 1A0-00F2

Error message

Kinematic switch-over is not allowed

Cause of error

You tried to switch the kinematics although the tilted plane function or kinematic compensation movements (e.g. M128, M144) are active.

Error correction

Before switching the kinematics, deactivate all functions that depend on them.


Error description 1A0-00F3

Error message

Kinematic switch-over is not allowed

Cause of error

You tried to switch the kinematics although a kinematic compensation in a calling program (e.g. M128, M144, FUNCTION PARAXCOMP, FUNCTION PARAXMODE) is active.

Error correction

Before switching the kinematics, return to the default condition in all programs.


Error description 1A0-00F4

Error message

No further axes allowed in pole plane

Cause of error

In a line block with polar coordinates you programmed further axes that lie in the working plane defined by the pole. The end position is therefore overdetermined.

Error correction

Delete additionally defined axes from the line block with polar coordinates.


Error description 1A0-00F5

Error message

Tilting the working plane is not allowed

Cause of error

You tried to tilt the working plane although this function is not allowed with the active kinematic configuration.

Error correction

- Use another machine kinematic configuration
- If required, edit the NC program
- If necessary, inform your service agency


Error description 1A0-00F7

Error message

Entered angle not permitted

Cause of error

- The solid angles programmed in Cycle 19 Tilt Working Plane (DIN/ISO: G80) cannot be realized with the current attachment (e.g. universal head where only one hemisphere is accessible).
- Run probing cycle only with paraxial angular position.
- The point angle (T-ANGLE) defined for the active tool is 180°.

Error correction

- Edit the solid angle entered.
- Run probing cycle only with paraxial angular position.
- Use angular values greater than 0 and less than 180°.


Error description 1A0-00F8

Error message

Angle cannot be calculated

Cause of error

In the tilted-working-plane function you have the spatial-angle input mode active although this mode is not supported for your machine configuration.

Error correction

Select axis-angle input in the active kinematic table.
If necessary, refer to your machine tool builder.


Error description 1A0-00F9

Error message

Coordinate transformation not allowed in the contour subprogram

Cause of error

You programmed an illegal coordinate transformation in a contour program, e.g. tilting the working plane, preset change, basic rotation or an axis offset.

Error correction

In the contour subprogram, use only the coordinate transformations rotation, datum shift, mirroring and scaling. Edit the NC program.


Error description 1A0-00FA

Error message

Incremental tilting angle not allowed

Cause of error

You tried to tilt the working plane farther incrementally with axis angles, although you did not define the function with axis angles.

Error correction

Always define incremental tilting of the working plane with the same method as in the previous tilting. Change the type of incremental tilting or the previous absolute tilting.


Error description 1A0-00FB

Error message

Incremental tilting angle not allowed

Cause of error

You tried to tilt the working plane farther incrementally with spatial angles, although you did not define the function with spatial angles.

Error correction

Always define incremental tilting of the working plane with the same method as in the previous tilting. Change the type of incremental tilting or the previous absolute tilting.


Error description 1A0-00FC

Error message

No solution in limited range

Cause of error

You tried to limit the range for the master axis with SEQ+ or SEQ-. In this range the control cannot tilt the working plane.

Error correction

Cancel the limitation by SEQ+ / SEQ-.


Error description 1A0-00FD

Error message

Vectors are not perpendicular

Cause of error

You tried to define a working plane with PLANE VECTOR, entering vectors that are not perpendicular or do not intersect.

Error correction

Ensure that the vectors are perpendicular and intersect.
Permit vectors that are not perpendicular to each other by changing the configuration: CfgRotWorkPlane-->autoCorrectVector to TRUE.


Error description 1A0-00FE

Error message

Points on a plane too close to each other

Cause of error

You tried to define a working plane with PLANE POINTS, entering plane points that lie too close together.

Error correction

Define plane points that are farther apart from each other.


Error description 1A0-00FF

Error message

Points on a plane lie on a line

Cause of error

You tried to define a working plane with PLANE POINTS, entering plane points that lie one a straight line. Therefore the control cannot calculate an unambiguous plane.

Error correction

Define plane points that form a triangle.


Error description 1A0-0100

Error message

No rotary axes available

Cause of error

You attempted to tilt the working plane in a kinematic configuration without rotary axes.

Error correction

- Correct the NC program: Delete the functions for tilting the working plane.
- Activate the kinematic configuration with rotary rotary axes.


Error description 1A0-0101

Error message

Vectors are too short

Cause of error

You tried to define a working plane with PLANE VECTOR, when at least one of the vectors is too short.

Error correction

- Enter longer vectors
- Adapt machine parameters (must be done by machine manufacturer):
Set machine parameter CfgRotWorkPlane/autoCorrectVector to the value TRUE in order to permit basic vectors with zero length.


Error description 1A0-0102

Error message

Infeed depth too small

Cause of error

In one of the Cycles 21, 22, 24 or 25 (DIN/ISO: G121, G122, G124, G125) you defined the plunging depth Q10 smaller than 0.1 mm.

Error correction

Define the plunging depth Q10 with a value larger than 0.1 mm.


Error description 1A0-0103

Error message

Too many rotary axes available

Cause of error

You attempted to tilt the working plane in a kinematic configuration with more than two rotary axes. This is only possible when programming with axis values.

Error correction

- Correct the NC program: use PLANE AXIAL
- Activate the kinematic configuration with two rotary rotary axes
- Use M138 to select the rotational axes


Error description 1A0-0104

Error message

Combination of functions not permitted

Cause of error

You tried to tilt the working plane while a datum shift in rotational axes was active. This is only possible when programming with axis values.

Error correction

- Correct the NC program: use PLANE AXIAL
- Use a reference point for this shift.


Error description 1A0-0105

Error message

Position after G43/G44 not perpendicular to the G41/G42 contour!

Cause of error

The G43/G44 approach is not perpendicular to the next G41/G42 movement. This causes a contour error that can damage the workpiece. The contour error depends on the distance between the end position and the perpendicular distance R
of the G41/G42 starting position. The distance is greater than 0.1 * tool radius R.

Error correction

- Edit the NC program: the approach from G43/G44 must be perpendicular to the contour.


Error description 1A0-0106

Error message

& operator not applicable to active 3-axis kinematics

Cause of error

You tried to use the X, Y or Z axis with the & operator, although this axis in included in the active 3-axis kinematic configuration. The & operator is permissible only if you have used the PARAXMODE FUNCTION to take the corresponding axis
out of the active 3-axis kinematic configuration.

Error correction

Use the corresponding axis without the & operator.


Error description 1A0-0107

Error message

M128 and M144 with CYCL CALL POS not allowed

Cause of error

During an active M128 or M144 you tried to use CYCL CALL POS to call a cycle.

Error correction

Deactivate M128 and M144 before the cycle call with CYCL CALL POS.


Error description 1A0-0108

Error message

CYCL CALL POS: Incremental values without reference

Cause of error

You tried to call CYCL CALL POS with incremental coordinates, of which some are not based on coordinates that you had previously programmed with CYCL CALL POS.

Error correction

Ensure that every incrementally programmed coordinate in a cycle call with CYCL CALL POS is given with respect to coordinates in previously programmed CYCL CALL POS commands.


Error description 1A0-0109

Error message

Resumption with M120 not allowed

Cause of error

Re-entry with GOTO during active M120 not permitted.

Error correction

Re-entry possible only via mid-program startup.


Error description 1A0-010A

Error message

TCPM: PATHCTRL VECTOR not possible

Cause of error

You tried to move the rotary axes with PATHCTRL VECTOR so that the direction of the tool axis is always in the same plane. PATHCTRL VECTOR is not possible with the programmed direction vectors.

Error correction

- Use the TCPM function with PATHCTRL AXIS.
- If required, correct the directional vector.


Error description 1A0-010B

Error message

Spatial circular arc not allowed

Cause of error

You tried to move on a spatial circular arc, but this function is not possible. A spatial circular arc results, for example, if you have programmed a circle in the X/Z plane, and then, for example, turn with Cycle 10 in the X/Y plane.

Error correction

Edit the NC program.


Error description 1A0-010C

Error message

Movement is nonlinear

Cause of error

You programmed an NC block that causes a counter axis to make a nonlinear movement.

Error correction

- Edit the NC program


Error description 1A0-010D

Error message

This contour is not possible in turning cycles.

Cause of error

You programmed an illegal NC block within a contour
for a turning cycle.

Error correction

Edit the contour definition in the NC program.


Error description 1A0-010E

Error message

Run-in length incorrectly programmed

Cause of error

You programmed the overrun length for tapping to be zero
or a negative number.

Error correction

Enter only positive numbers for the run-in length.
Recommended run-in length: at least half the pitch.


Error description 1A0-010F

Error message

Overrun length incorrectly programmed

Cause of error

You programmed the overrun length for tapping to be zero or a negative number.

Error correction

Enter only positive numbers for the overrun length.
Recommended overrun length: at least half the pitch.


Error description 1A0-0110

Error message

Error in turning cycle

Cause of error

Possible causes:
- You tried to run a turning cycle, although the
active tool is not a turning tool.
- You tried to run a turning cycle, although the
milling mode is active.

Error correction

- Insert a turning tool.
- Use FUNCTION MODE TURN to switch to the turning mode.


Error description 1A0-0111

Error message

Error in rounding arc

Cause of error

You tried to program a rounding arc in a contour with less than two elements.

Error correction

Edit the NC program.


Error description 1A0-0112

Error message

Error in rounding arc

Cause of error

You tried to end a contour with a rounding arc.
However, the contour not closed.

Error correction

Edit the NC program.


Error description 1A0-0113

Error message

Error in contour element of a turning cycle

Cause of error

You programmed an undercut or recess at the beginning of a turning contour.

Error correction

Edit the NC program.


Error description 1A0-0114

Error message

Error in recess

Cause of error

Possible causes:
- You have programmed neither the center point of the recess (CENTER) nor the recess position (PLACE).
- You have programmed both the center point of the recess (CENTER) and the recess position (PLACE).

Error correction

Edit the NC program.


Error description 1A0-0115

Error message

Turning operation: tool position is incorrect

Cause of error

The cutting insert of the turning tool is not
in the permitted working plane.

Error correction

Rotary axes and cutting inserts must lie in a working plane.
- Correct the position of the tool.
- If desired, adopt the rotary axis coordinates with M128 or M144.


Error description 1A0-0116

Error message

Recessing cycle: tool position is incorrect

Cause of error

You tried to use a recessing tool,
although the machine is not in the default setting.

Error correction

Cancel the tool orientation:
- Move the rotary axis to the home position.
- If necessary, use M128 or M144 to load the rotary axis values.


Error description 1A0-0117

Error message

Turning cycle with button tool dimensioned at center

Cause of error

You tried to run a turning cycle with a button tool dimensioned at its center.

Error correction

Button tools that are dimensioned at the center must be measured in a corner, so they have to have tool orientation 1 to 8.


Error description 1A0-0118

Error message

Program resumption not possible

Cause of error

It is not possible to resume the program at the point of interruption.

Error correction

- Jump to the program start using the GOTO key or reselect the program over PGM MGT.
- The StretchFilter must be deactivated in order to be able to continue the program at the point of interruption.


Error description 1A0-0119

Error message

Thread not possible with inclined tool

Cause of error

You tried to cut a thread with an inclined tool and at a feed rate of 0.

Error correction

- Cancel the tool position. To do so, return the rotary axes to their home position and, if required, take over the rotary axis values with M128 or M144.
- Change the type of feed rate.


Error description 1A0-011A

Error message

Coordinate transformation in turning operation

Cause of error

You tried to change to turning mode although a coordinate transformation (rotation, mirroring and/or scaling) is active.

Error correction

Deactivate coordinate transformations (rotation, mirroring and or scaling) before you switch to turning mode.


Error description 1A0-011B

Error message

Noncylindrical contour must not begin at an inside corner

Cause of error

You tried to begin a noncylindrical contour with radius compensation at an inside corner (concave position).
These are some of the possible causes of this error message:
- The starting point lies on a real inside corner
- The starting point lies on the transition between two arcs that are tangential, but were
programmed or generated with poor accuracy
- A "round" inside noncylindrical contour was resolved into nothing but straight-line segments. The starting point
then lies on a tangential transition between two arcs. However, the resolution
into straight line segments again results in an inside corner.

Error correction

- Correct the starting point by choosing a correct point that does not lie on an inside corner
- Create/generate the noncylindrical program (especially circular movements) with higher accuracy
- Avoid resolving the noncylindrical contour into straight-line segments, or manually place the starting point in the middle of a
generated line segment
- Have the tool-compensated path of the noncylindrical contour calculated/generated externally instead of by the control.


Error description 1A0-011C

Error message

Tool radius too large

Cause of error

With the defined contour data, the tool radius is too large for side finishing or fine roughing.

Error correction

For side finishing, the sum of the side-finishing allowance (side-finishing cycle) and the finishing-tool radius must be smaller than
the sum of the side-finishing allowance (contour data cycle) and the roughing-tool radius.
The above calculation also applies if you run the side-finishing cycle without first having cleared the area out with the roughing tool;
the radius of the roughing tool then has the value “0.”
During fine roughing, the radius of the fine roughing tool must be smaller than the radius of the coarse roughing tool.


Error description 1A0-011D

Error message

Normal vector too short

Cause of error

You tried to define a working plane with PLANE VECTOR, but the normal vector is too short.

Error correction

The TNC cannot correct the normal vector automatically, enter a longer normal vector.


Error description 1A0-011E

Error message

Workpiece blank definition: contour is not closed

Cause of error

The start point and end point do not agree in the definition for the workpiece blank contour.

Error correction

Edit the NC program.
The start position must be complete, which means that it has to contain values for both coordinates.


Error description 1A0-011F

Error message

Invalid tooth length in recessing cycle

Cause of error

You tried to run a recess turning cycle with a tool whose tooth length was zero or is not defined.

Error correction

Check the cutting length for the recess turning tool in the tool table.


Error description 1A0-0120

Error message

No recessing tool is active

Cause of error

You tried to run a recess turning cycle although the active tool is not a recess turning tool.

Error correction

Insert a recess turning tool.


Error description 1A0-0121

Error message

Illegal syntax element in contour subprogram for turning cycles

Cause of error

In a contour subprogram that is called by a turning cycle you used one of the following impermissible syntax elements:
- Radius compensation is not defined in the first row of the contour description.
- A DEP block is programmed within the contour description.

Error correction

Correct the contour subprogram.


Error description 1A0-0123

Error message

Radius comp. undefined

Cause of error

You programmed a radius-compensated single-axis positioning block that, without the radius compensation, does not result in tool movement (e.g. IX+0 R+, ISO: G7).

Error correction

Edit the NC program.


Error description 1A0-0124

Error message

Cannot calculate any intersection

Cause of error

The control cannot calculate an intersection: two straight lines are parallel.

Error correction

Check the contour description.


Error description 1A0-0125

Error message

Cannot calculate any intersection

Cause of error

The control cannot calculate an intersection: two outside circles do not intersect.

Error correction

Check the contour description.


Error description 1A0-0126

Error message

Cannot calculate any intersection

Cause of error

The control cannot calculate an intersection: two inside circles do not intersect.

Error correction

Check the contour description.


Error description 1A0-0127

Error message

Cannot calculate any intersection

Cause of error

The control cannot calculate an intersection: two inside circles do not intersect.

Error correction

Check the contour description.


Error description 1A0-0128

Error message

Cannot calculate any intersection

Cause of error

The control cannot calculate an intersection: a straight line and a circle do not intersect.

Error correction

Check the contour description.


Error description 1A0-0129

Error message

Contiguous circles with opposite direction of rotation

Cause of error

Two contiguous circles illegally have opposite directions of rotation.

Error correction

Check the contour description.


Error description 1A0-012A

Error message

Contour element with length=0 programmed

Cause of error

The starting the ending points of a profile contour are identical.

Error correction

Check the contour description.


Error description 1A0-012B

Error message

Cannot calculate any intersection

Cause of error

The control cannot calculate an intersection: a circle has a zero radius.

Error correction

Check the contour description.


Error description 1A0-012E

Error message

Cannot calculate any intersection

Cause of error

The control cannot calculate an intersection: two straight lines are parallel and are not superimposed.

Error correction

Check the contour description.


Error description 1A0-012F

Error message

Faulty subdivision of the vertical profiles

Cause of error

The control cannot machine the defined profile.

Error correction

Check the profile description (SEL CONTOUR PROFILE), machining parameters and data of the tool used.


Error description 1A0-0130

Error message

The plane profile is not closed or begins at a corner

Cause of error

The start point and end point of the plane profile either do not match or they are on a corner.

Error correction

Check the programmed plane profile.


Error description 1A0-0131

Error message

Control cannot conclude machining operation

Cause of error

Error in internal calculations.

Error correction

Check the contour description (SEL CONTOUR SURFACE and SEL CONTOUR PROFILE), machining parameters and data of the tool used.


Error description 1A0-0132

Error message

Machining operation requires too many cycles

Cause of error

The maximum permissible number of machining runs was exceeded.

Error correction

Check the machining parameters and data of the tool used.


Error description 1A0-0133

Error message

Error management tables are inconsistent

Cause of error

SEL CONTOUR SURFACE uses a table index that lies outside of the permissible value range.

Error correction

Inform your service agency.


Error description 1A0-0134

Error message

Cycle not suited for contour definition with APPR/DEP block.

Cause of error

The cycle you selected cannot use any contour definition that contains APPR or DEP blocks.

Error correction

Remove APPR and DEP blocks from the contour definition.
For Cycle 1025, use Cycle 270 to program APPR/DEP.


Error description 1A0-0135

Error message

APPR block in contour definition not in first line

Cause of error

In a contour description you have programmed an APPR block that is not in the first line.

Error correction

Correct the contour description.


Error description 1A0-0136

Error message

Too many APPR/DEP blocks in contour description

Cause of error

You programmed multiple APPR or DEP blocks in a contour description.

Error correction

Contour descriptions must contain only one APPR/DEP block.
Correct the contour description.


Error description 1A0-0137

Error message

Radius compensation in contour subprogram inconsistently defined

Cause of error

In a contour subprogram, you have defined multiple radius compensation values that contradict each other.

Error correction

Edit the contour subprogram.


Error description 1A0-0138

Error message

DEP block in contour definition not programmed in the last line

Cause of error

In a contour subprogram you have programmed an DEP block that is not in the last line of the contour description.

Error correction

Correct the contour description.


Error description 1A0-0139

Error message

CMO is not in the current kinematic description

Cause of error

You tried to activate or deactivate a collision monitored object (CMO) for monitoring.
The control cannot fine the CMO in the currently selected kinematics.

Error correction

Correct the name of the CMO to be activated or deactivated.


Error description 1A0-013A

Error message

Erroneous plane profile programmed

Cause of error

The plane profile was programmed incorrectly.

Error correction

- Ensure that for each geometric element that describes the geometry of the plain profile (which therefore excludes blocks that describe an approaching or departing motion) an appropriate vertical profile is defined.
- Ensure that in each case no more than one approaching or departing motion is programmed at the beginning or end of the plane profile definition.
- Ensure that at first, after each reference to a vertical profile, at least one geometric element is programmed.


Error description 1A0-013B

Error message

Illegal transformation during execution of a profile surface

Cause of error

Programming a profile surface (Cycles 281-283) is impermissible if a mirror image along a tool axis (Cycle 8) is active at the same time.

Error correction

Rewrite the program so that the mirroring is not active during the call of the profile surface cycles (281-283).


Error description 1A0-013C

Error message

Cycles 281 and 283 only applicable to pockets

Cause of error

Cycles 281 for roughing and 283 for floor finishing must be used only for profile surfaces that form a pocket.

Error correction

Ensure that the programmed plane profile is closed.
If the plane profile is defined with Cycle 14, ensure that the combination of machining direction, radius compensation and monotonicity of the vertical profile results in a pocket.


Error description 1A0-013D

Error message

Missing radius compensation in the plane profile definition

Cause of error

If the plane profile of a profile surface (Cycles 280 to 283) is programmed using Cycle 14, a radius compensation (RL or RR) must be entered within the definition of the plane profile.

Error correction

Enter the radius compensation within the definition of the plane profile.


Error description 1A0-013E

Error message

Invalid vertical profile defined

Cause of error

The programmed vertical profile of a profile surface(Cycles 280 – 283) is invalid.

Error correction

Ensure that the definition of the vertical profile contains at least two geometric blocks.
Ensure that no radius compensation is programmed within the definition of the vertical profile.
Ensure that the vertical profile increases with respect to the abscissa (usually the x coordinate) (i.e. increases monotonically).
Ensure that the vertical profile either increases or decreases with respect to the ordinate (usually the y coordinate) (i.e. monotonically increases or monotonically decreases).


Error description 1A0-013F

Error message

Radius compensation defined within plane profile

Cause of error

If the plane profile of a profile surface (Cycles 280 to 283) is specified using the syntax element CONTOUR DEF, there must be no radius compensation entered within the definition of the plane profile.

Error correction

Remove the radius compensation from the definition of the plane profile.


Error description 1A0-0140

Error message

Profile surface cycle with active tool radius compensation

Cause of error

You tried to call a profile surface cycle (Cycles 281 – 283) with active tool radius compensation.

Error correction

Before the profile surface cycle, use R0 to cancel the tool radius compensation or program the cycle call at another location.


Error description 1A0-0141

Error message

Programmed plane profile is not closed.

Cause of error

You tried to use CONTOUR DEF to program a plane profile as a pocket. However, the plane profile does not result in a closed contour.

Error correction

Program a closed plane profile.
Use Cycle 14 to define an open plane profile.


Error description 1A0-0142

Error message

Programmable axis %1 missing in "CfgChannelAxes/progAxis"

Cause of error

The machine configuration is faulty. The affected axis is not configured as a programmable axis.

Error correction

- Inform your machine tool builder
- Correct the machine configuration: Enter the axis as a programmable axis in 'CfgChannelAxes/progAxis'


Error description 1A0-0143

Error message

Roughing cycle: Start position too close to rotary axis

Cause of error

The starting position of a roughing cycle is located too close to the rotary axis.

Error correction

Edit the NC program.


Error description 1A0-0144

Error message

Workpiece blank definition: Contour intersects itself

Cause of error

A contour that describes the surface line of a workpiece blank (NC block BLK FORM ROTATION) intersects itself.

Error correction

Correct the NC program: Adapt the workpiece blank contour so that it no longer intersects itself.


Error description 1A0-0145

Error message

Workpiece blank definition: Illegal axis in subprogram

Cause of error

You programmed an illegal axis in a subprogram that defines the surface line of a workpiece blank (NC block: BLK FORM ROTATION).

Error correction

- Correct the NC program: Program the coordinates in the subprogram that result from the selection of the rotation axis for the workpiece blank.


Error description 1A0-0146

Error message

Turning tool with contradictory data

Cause of error

A turning tool was inserted whose data are contradictory for the following reasons:
The tool orientation does not fit the tool angle and point angle.

Error correction

Correct the data in the turning tool table


Error description 1A0-0147

Error message

Workpiece blank definition for active coordinate transformation

Cause of error

During an active coordinate transformation (datum shift, tilting), you tried to define a workpiece blank using a surface line (NC block: BLK FORM ROTATION).

Error correction

Reset all active coordinate transformations before you define the workpiece blank.


Error description 1A0-0148

Error message

Function not permitted

Cause of error

You tried to calculate a spindle rotation between input coordinate system and tool coordinate system (e.g. with ID210 NR8), at the same time as a transformation for scaling or mirroring was active.

Error correction

Edit the NC program


Error description 1A0-014B

Error message

Illegal movement if FUNCTION TCPM and mirroring are active.

Cause of error

You tried to program a rotary axis motion defined with spatial angles during a circular movement (CP..., CPT...) with active TCPM FUNCTION (with AXIS SPAT) and active mirroring.

Error correction

Deactivate mirroring before the motion is processed while TCPM FUNCTION is active.


Error description 1A0-014C

Error message

Erroneous tool-carrier kinematics in the file %1

Cause of error

- Tool-carrier kinematic model in the given file is faulty

Error correction

- For more detailed information on this error message, press the INTERNAL INFO soft key
- Check the tool kinematic model in the given file and correct it if necessary
- Inform your service agency


Error description 1A0-014D

Error message

Data of the tool carrier kinematics is faulty

Cause of error

The tool-carrier kinematic data for the current tool are faulty.
Note: Do not run any NC programs in this condition and be careful if you move the axes manually!

Error correction

- Ensure under “KINEMATICS” that a valid file for the tool-carrier kinematics is entered for the desired tool in the tool table.
- Acknowledge the error message
- Run a TOOL CALL for a tool that has no tool-carrier kinematics assigned or one that has a valid tool-carrier kinematic model.
- Inform your service agency.


Error description 1A0-0151

Error message

Illegal number of lines (%1) in the compensation value table

Cause of error

Too few (or too many) measured values were entered in the compensation value table for 3D-ToolComp. At least two values must be entered.

Error correction

- Check the compensation value table and correct it if necessary
- Perform the calibration cycle again


Error description 1A0-0152

Error message

Inconsistent (multiple) angular values in the compensation table.

Cause of error

The compensation value table contains ambiguous (multiple) angular values (ANGLE).

Error correction

Check the table and perform the calibration cycle again if necessary.


Error description 1A0-0153

Error message

Angle value (%1) is outside of the valid range.

Cause of error

An evaluation was attempted outside the boundaries of the angular range that was measured.

Error correction

Expand the compensation table in order to include the necessary angles.


Error description 1A0-0154

Error message

Tool carrier kinematics is ignored in "%1"

Cause of error

The given kinematic model has no insertion point for tool-carrier kinematics.

Error correction

- Adjust the machine configuration for tool-carrier kinematics. To do so, please contact your machine tool builder.
Please note: If you use the entered kinematic model, the machining operation will be executed without the desired tool carrier.


Error description 1A0-0155

Error message

Starting position of noncircular contour not in workpiece system

Cause of error

- Axis-value programming is active

Error correction

- Edit the program


Error description 1A0-0156

Error message

Starting position is programmed incrementally

Cause of error

Polar programmed starting position is programmed incrementally

Error correction

Edit the program or the cycle


Error description 1A0-0157

Error message

Relative programming of the reciprocation starting position is
not allowed

Cause of error

Starting position of the reciprocation is programmed in relative values

Error correction

Program the starting position with absolute values


Error description 1A0-0158

Error message

Absolute programming of the relief vector is not allowed.

Cause of error

- Relief vector was programmed absolutely instead of incrementally

Error correction

- Program the relief vector incrementally


Error description 1A0-0159

Error message

Relative programming of the infeed starting position is
not allowed!

Cause of error

Starting position of the infeed is programmed in relative values

Error correction

Program the starting position with absolute values


Error description 1A0-015A

Error message

Programmed axis is not a grinding axis

Cause of error

Wrong axis selected for grinding

Error correction

Program a grinding axis


Error description 1A0-015B

Error message

Programmed value is not interpreted as a coordinate

Cause of error

Presumably a system error

Error correction

Inform your service agency


Error description 1A0-015C

Error message

Incremental programming of the starting position is not allowed

Cause of error

Starting position is programmed incrementally

Error correction

Program the starting position with absolute values


Error description 1A0-015D

Error message

Polar starting position is programmed incrementally

Cause of error

The radius or angle of the polar-programmed starting position is programmed incrementally

Error correction

Edit the program or the cycle


Error description 1A0-015E

Error message

Reciprocation over zero length is not allowed

Cause of error

Error correction

- Edit the program


Error description 1A0-0161

Error message

Programmed rotary axis on circle not allowed (TCPM TIP-CENTER)

Cause of error

An attempt was made to program a circle with a rotary axis setting without tool radius compensation with an active TCPM REFPNT TIP CENTER. Simultaneous rotary axis adjustment on circles is permissible only with tool radius compensation.

Error correction

Activate tool radius compensation


Error description 1A0-0162

Error message

Tool radius compensation incorrectly ended (TCPM TIP-CENTER)

Cause of error

An attempt was made to stop tool radius compensation with TCPM REFPNT TIP-CENTER in an impermissible manner.
With this TCPM preset, tool radius compensation can be stopped only by means of a linear block with R0 in which both working plane coordinates are programmed.

Error correction

Stop tool radius compensation with a linear block containing both working plane coordinates.


Error description 1A0-0164

Error message

Cannot find direction of rotation for the defined contour

Cause of error

The programmed workpiece blank contour is not closed or is without curves. It is therefore impossible to find the rotational direction or display in 3-D.

Error correction

- Change the NC program
- Program a workpiece blank contour consisting of more than one point. The contour must be closed and must not lie on a single straight line.


Error description 1A0-0165

Error message

Recesses in the BLK FORM are not supported

Cause of error

A recess was programmed in the contour for the BLK FORM.

Error correction

- Edit the NC program. Remove the recess from the contour for the BLK FORM.


Error description 1A0-0166

Error message

Undercuts in the BLK FORM are not supported

Cause of error

An undercut was programmed in the contour for the BLK FORM.

Error correction

Remove the undercut from the contour


Error description 1A0-0167

Error message

SL cycle not allowed (TCPM REFPNT CENTER)

Cause of error

An attempt has been made to program an SL cycle while TCPM REFPNT TIP-CENTER or REFPNT CENTER-CENTER is active. No SL cycles are possible with these TCPM settings.

Error correction

Edit the NC program


Error description 1A0-0169

Error message

M130 not allowed

Cause of error

No M130 can be programmed during active turning-tool compensation in the tilted plane’s system (FUNCTION TURNDATA CORR-WPL, or columns WPL-DZL and WPL-DX-DIAM from the turning-tool table).

Error correction

- Check the NC program and adapt it if necessary.


Error description 1A0-016C

Error message

Facing slide: Only ZK contour allowed

Cause of error

A contour was programmed that is not in the ZX plane.

Error correction

Check the NC program and adapt it if necessary.


Error description 1A0-016D

Error message

Facing slide: Transformation not allowed

Cause of error

Certain transformations are not allowed with an active facing slide:
- Tilting the working plane
- Scaling
- Datum shift

Error correction

Check the NC program and adapt it if necessary.


Error description 1A0-016E

Error message

Tilted working plane no allowed

Cause of error

With FUNCTION MODE TURN, tilting the working plane is allowed only with facing slide kinematics.

Error correction

Check the NC program and adapt it if necessary.


Error description 1A0-016F

Error message

Helix with active facing slide not allowed

Cause of error

No helix is allowed with an active facing slide.

Error correction

Check the NC program and adapt it if necessary.


Error description 1A0-0170

Error message

Facing slide: Combination with M91 not allowed

Cause of error

The combination of active facing slide and M91 are not allowed.

Error correction

Check the NC program and adapt it if necessary.


Error description 1A0-0171

Error message

Facing slide: TCPM not allowed

Cause of error

No TCPM (M128) is allowed with an active facing slide.

Error correction

Check the NC program and adapt it if necessary.


Error description 1A0-0172

Error message

Facing slide: 3-D radius compensation not allowed

Cause of error

3-D radius compensation is not allowed with an active facing slide.

Error correction

Check the NC program and adapt it if necessary.


Error description 1A0-0173

Error message

Special kinematics are not allowed for facing slide machining

Cause of error

You tried to combine FUNCTION PARAXMODE with a special kinematic model:
- Polar kinematics
- Facing slide kinematics

Error correction

Deactivate the machining method before another is to be activated.


Error description 1A0-0174

Error message

Facing slide: Only in turning mode

Cause of error

A facing slide can be activated only in turning mode.

Error correction

Use FUNCTION MODE TURN to switch to the turning mode.


Error description 1A0-0175

Error message

Facing slide: Impermissible circle programmed

Cause of error

The programmed circle has a radius or arc that is too small for the facing slide

Error correction

Check the NC program and adapt it if necessary


Error description 1A0-0176

Error message

Facing slide: Probing block not allowed

Cause of error

Probing block not allowed with an active facing slide

Error correction

Run the probing block before the facing slide is activated


Error description 1A0-0177

Error message

Facing slide: Spindle is not aligned

Cause of error

The Z axis of the input system and the spindle direction are not parallel

Error correction

Align the spindle direction before the facing slide is activated


Error description 1A0-0178

Error message

Facing slide not possible when stretch filter is active

Cause of error

Facing slide cannot be activated when the “stretch filter” is active

Error correction

- Check the entry under CfgStrechFilter and change it if required
- Inform your service agency


Error description 1A0-0179

Error message

Facing slide: M140 not allowed

Cause of error

Tool retraction (M140) not allowed with an active facing slide

Error correction

Edit the NC program


Error description 1A0-017A

Error message

Facing slide: PARAXCOMP not allowed

Cause of error

FUNCTION PARAXCOMP not allowed with an active facing slide

Error correction

Check the NC program and adapt it if necessary


Error description 1A0-017B

Error message

Turning cycle is allowed only with an active facing slide

Cause of error

With facing slide kinematics, you tried to execute a turning cycle without activating the facing slide

Error correction

- Program FACING HEAD POS


Error description 1A0-017C

Error message

Tool contour missing for simultaneous turning cycle

Cause of error

The tool contour for simultaneous turning could not be read.

Error correction

The 2-D tool contour for the cycle is calculated from the corresponding 3-D tool carrier kinematics:
- Ensure that a valid tool carrier kinematic model is entered in the "KINEMATIC" tool table column.
- For the simultaneous rotation cycle, make particularly sure that the geometry defined in it matches the data of the tool in the tool table.


Error description 1A0-017D

Error message

Faulty tool data for simultaneous turning cycle

Cause of error

The tool data of the tool table is not compatible with the simultaneous turning cycle.
The tool data (ZL, XL, RS, TO, P-ANGLE, T-ANGLE, CUTWIDTH, CUTLENGTH and KINEMATIC) must describe a realistic tool. In particular, the following conditions must be met:
- Neither the radius (RS) nor the cutting edge length (CUTLENGTH and CUTWIDTH) are zero.
- Only button tools, roughing tools, and finishing tools are allowed.
- TO, ZL, and XL must agree with the tool holder geometry in KINEMATIC.

Error correction

Check and correct the entries in the tool table


Error description 1A0-017E

Error message

GS rotation with working plane not in XY

Cause of error

An attempt has been made to combine a rotation from the global program settings with a working plane in ZX or YZ. This is not allowed.
Such a working plane is available in the turning mode as well as when using TOOL CALL X or TOOL CALL Y.

Error correction

Edit the NC program or, in the corresponding program section, activate no rotation via global program settings.


Error description 1A0-017F

Error message

Negative cutting edge radius

Cause of error

An attempt was made to start a turning cycle with a turning tool with negative cutting edge radius. That is not allowed.
The effective cutting edge radius is the sum of the following three elements:
- Value in the RS column from the turning-tool table
- Value in the DRS column from the turning-tool table
- through FUNCTION TURNDATA CORR-TCS: Z/X DRS programmed oversize

Error correction

The sum of the three values must be positive: adjust the NC program or tool table


Error description 1A0-0180

Error message

Simultaneous turning: No fitting tilting axis found.

Cause of error

No appropriate tilting axis was found for the simultaneous turning cycle.

Error correction

- If the machine physically has a suitable axis:
- Adapt the precession angle via Cycle 800
- Check the kinematics configuration and change it if necessary
- Inform your service agency


Error description 1A0-0182

Error message

Tilting working plane does not fit to rotary transformations

Cause of error

- An attempt has been made to activate the tilting of the machining plane while one of the rotational transformations mentioned below is active.
- An attempt has been made to activate one of the rotational transformations named below while the machining plane is tilted.

Error correction

- Deactivate tilting of the machining plane or Cycle 800.
If the transformation named in item 2 is active outside the turning operation, please contact the machine manufacturer.
The following are affected:
1. Transformation activated by Cycle 800
2. Special transformation in turning operation, which the input system usually adapts to kinematics with the A or B table. The POS tab of the status display shows whether the transformer is active.


Error description 1A0-0183

Error message

Data for turning tool invalid

Cause of error

The data of the active turning tool are invalid.
Invalid value combination: TYPE and TO do not match.
The value 9 can be defined in TO only for button tools.

Error correction

Edit the tool data.


Error description 1A0-0184

Error message

Simultaneous turning: Programmed tool compensations not allowed

Cause of error

Programmed tool compensations (FUNCTION TURNDATA CORR-TCS ...) are not permitted for the simultaneous turning cycle.
Such compensations change the position of the indexable insert relative to the tool carrier, which can lead to collisions.

Error correction

Remove all tool compensations programmed before the cycle.


Error description 1A0-0185

Error message

Selected TCPM mode cannot be combined with simultaneous turning

Cause of error

The simultaneous turning cycle does not support the programmed TCPM mode

Error correction

The following TCPM parameters must be set:
- AXIS POS (coordinates = nominal position),
- PATHCTRL AXIS (interpolation = nominal position)
- REFPNT CENTER-CENTER or REFPNT TIP-CENTER (tool preset)


Error description 1A0-0188

Error message

Function not permitted

Cause of error

- FUNCTION FACINGHEAD is programmed with active tool compensation regarding the workpiece coordinate system.
- FUNCTION FACINGHEAD is not allowed in combination with FUNCTION TURNDATA CORR-WCS.

Error correction

Deactivate tool compensation with regard to the workpiece coordinate system.


Error description 1A0-0189

Error message

Impermissible interpolation of rotary axes

Cause of error

- A rotary axis was programmed that was deselected with M138 or in the machine parameter CfgAxisPropKin/MP_rotAxisForKinCalc = FALSE but, according to the machine parameter CfgAxisPropKin/MP_paraxComp = Display, must be considered.
- This movement cannot be interpreted with TCPM movements.

Error correction

- Check the NC program and edit it if necessary
- Inform your service agency


Error description 1A0-018A

Error message

No physical axis available for handwheel superimpositioning

Cause of error

Handwheel superimpositioning in an axis that is not in the current kinematics

Error correction

- Deactivate the handwheel superimpositioning
- Check the machine configuration
- Inform your service agency


Error description 1A0-018B

Error message

Contour preparation not possible

Cause of error

An internal error occurred while preparing the contour for the loaded noncircular program, which can therefore not be executed.

Error correction

Inform your service agency


Error description 1A0-018C

Error message

Contour preparation cannot process a noncircular program

Cause of error

The noncircular program cannot be processed by the contour preparation. Possible causes:
- The program contains contour elements whose length is extremely short (length < 1pm)
- The parameter "F effective as C feed rate" is set in the program and the C axis reverses direction during the program or its speed (briefly) drops to zero

Error correction

- Edit the NC program
- Inform your service agency


Error description 1A0-018E

Error message

Simultaneous turning: Pre-positioning

Cause of error

The current inclination of the tool is outside the programmed angle range.

Error correction

Adjust the inclination angle of the tool accordingly before calling the cycle.


Error description 1A0-018F

Error message

Inclination angles could not be reached

Cause of error

The desired inclination angles are outside the valid inclination range.

Error correction

Adjust the inclination angle range or the desired inclination angle at the beginning or end of the contour.


Error description 1A0-0190

Error message

Axis of a branched kinematics path used

Cause of error

An axis was used that is in a kinematics path that is currently branched.
The following uses are not possible for such an axis:
- Positioning with the PLANE function
- Selecting the axis with M138
- Positioning within an LN block
- Positioning within a CP block

Error correction

Edit the NC program


Error description 1A0-0191

Error message

Impermissible axis was programmed

Cause of error

You have programmed an axis that is configured as a spindle in the selected kinematics model.

Error correction

Edit the NC program


Error description 1A0-0192

Error message

Faulty turning tool data

Cause of error

The lathe tool is incorrectly defined. It does not have a permissible type.

Error correction

Correct the type of the turning tool


Error description 1A0-0194

Error message

The limit switches of a modulo axis are invalid

Cause of error

Please note that the following conditions apply for the limit switches/protection zones of modulo axes:
- The lower limit must be greater than -360° and less than +360°
- The upper limit must not be negative and must be less than +360°
- The lower limit must not be greater than the upper limit
- The lower limit and upper limit must be less than 360° apart
Please also ensure that the set limit switches and protection zone result in a clearly defined traverse range.
A missing or doubled overlap of the two ranges is not permitted.

Error correction

Correct an incorrectly set protection zone or incorrectly configured limit switches.


Error description 1A0-0195

Error message

Faulty tool data for simultaneous turning cycle

Cause of error

The tool contour consisting of cutter and holder could not be determined.

Error correction

- TO, ZL, XL and ORI must agree with the tool holder geometry in KINEMATIC.
- The faulty contours were stored in TNC:\system\Toolkinematics\


Error description 1A0-0196

Error message

TCPM: PATHCTRL VECTOR not possible

Cause of error

You programmed TCPM with PATHCTRL VECTOR so that the tool orientation lies in the same plane during the complete movement from the start point to the end point.
The current rotary axes in conjunction with the programmed start orientation and end orientation do not permit smooth motion.

Error correction

- Prefer PATHCHTRL AXIS. PATHCHTRL VECTOR is only useful during peripheral milling or if large changes of angle are programmed.
- Program an additional NC data point in the symmetry position (pole)
- Edit the NC program


Error description 1A0-0198

Error message

TCPM: PATHCTRL VECTOR not possible

Cause of error

You programmed TCPM with PATHCTRL VECTOR so that the tool orientation lies in the same plane during the complete movement from the start point to the end point.
This is not possible because positions that cannot be approached are located along the path between the start orientation and the end orientation (e.g., limit switches or kinematic limitations).

Error correction

- If the fault is not due to a limit switch, prefer PATHCHTRL AXIS. PATHCHTRL VECTOR is only useful during peripheral milling or if large changes of angle are programmed.
- Edit the NC program


Error description 1A0-0199

Error message

TCPM: PATHCTRL VECTOR not possible

Cause of error

You programmed TCPM with PATHCTRL VECTOR so that the tool orientation lies in the same plane during the complete movement from the start point to the end point.
This is not possible because a rotary axis that was not selected with M138 or a linear secondary axis was programmed.

Error correction

Edit the NC program.


Error description 1A0-019A

Error message

Coordinate transformation not allowed in dressing mode

Cause of error

You attempted to switch to dressing mode even though a coordinate transformation (datum shift, rotation, mirroring, and/or scaling) is active.

Error correction

Deactivate the coordinate transformation (datum shift, rotation, mirroring, and/or scaling) before switching to dressing mode.


Error description 1A0-019B

Error message

Tool-carrier kinematics not allowed

Cause of error

Grinding wheels with tool-carrier kinematics cannot be dressed.

Error correction

- For the grinding wheel to be dressed, delete the entry under "KINEMATIC" in the tool table
- Inform your service agency


Error description 1A0-019C

Error message

Plunging not possible at position (%1, %2)

Cause of error

A pocket cannot be machined since plunging is not possible with this tool radius.

Error correction

- Use a smaller tool
- Rework with a smaller tool


Error description 1A0-019D

Error message

Limitation cannot be defined with Cycle 14

Cause of error

The first defined contour cannot be interpreted as a border if Cycle 14 was used to define it.

Error correction

- Define contours with CONTOUR DEF or
- Use the first contour as a pocket and set parameter Q569 to 0 in Cycle 271


Error description 1A0-019E

Error message

Internal error in OCM contour milling cycle

Cause of error

- Contradictory data.

Error correction

- Inform your service agency.


Error description 1A0-019F

Error message

Pocket not supported after an "open frame"

Cause of error

In the definition of the contours, a pocket (P2) is defined after a "bounding box".
A "bounding box" must be followed by an island (I2).

Error correction

- Do not define a "bounding box" in Cycle 271 if a closed pocket is to be machined.
- Use CONTOUR DEF to define an island after the "bounding box" if an open pocket is to be machined.
- Refer to the User's Manual for more documentation.


Error description 1A0-01A0

Error message

Plunging depth too small

Cause of error

You programmed too low a depth in Cycle 271.

Error correction

Edit the NC program


Error description 1A0-01A1

Error message

No technology data record available for contour machining

Cause of error

A Cycle 271 must be programmed before every fixed cycle 272, 273, or 274.

Error correction

- Adapt the NC program
- Program Cycle 271


Error description 1A0-01A3

Error message

Plunging depth too small

Cause of error

You defined the plunging depth Q238 to be less than 0.1 mm in Cycle 274.

Error correction

- Adapt the NC program
- Define the plunging depth Q238 to be greater than 0.1 mm


Error description 1A0-01A4

Error message

Tool radius too small

Cause of error

The tool radius of the current tool is too small.

Error correction

Select a larger tool


Error description 1A0-01A5

Error message

Roughing tool not defined

Cause of error

A roughing tool must be defined for each fixed cycle 273 and 274.

Error correction

- Adapt the NC program
- Call Cycle 272
- Reference a roughing tool in parameter Q438


Error description 1A0-01A6

Error message

Parameter 'Feed per revolution Q436' incorrectly defined

Cause of error

You entered the value 0 for the infeed per revolution parameter Q436.

Error correction

Check and correct the value in Q436


Error description 1A0-01A7

Error message

Impermissible NC block in contour

Cause of error

This NC block is not permitted in a contour (e.g. APPR or DEP blocks, LN blocks,...)

Error correction

Edit the contour


Error description 1A0-01A8

Error message

Erroneous description of fixture in file %1

Cause of error

The description of the fixture in the given file is faulty or the file does not exist.

Error correction

- Check the description of the fixture in the given file and correct it if necessary
- Reset the fixture with FIXTURE RESET ALL
- Load a valid fixture with FIXTURE SELECT
- Inform your service agency


Error description 1A0-01A9

Error message

SW limit switch for modulo axes faulty

Cause of error

Movements of modulo axes with software limit switches are not permitted in this version of the control software.

Error correction

- Edit the NC program
- Do not configure limit switches for a modulo axis
- Do not configure the axis as a modulo axis
- Install a newer version of the NC software


Error description 1A0-01AA

Error message

Traverse limits for modulo axes faulty

Cause of error

Movements of modulo axes with traverse limits are not permitted in this version of the control software.

Error correction

- Edit the NC program
- Do not configure traverse limits for a modulo axis
- Do not configure the axis as a modulo axis
- Install a newer version of the NC software


Error description 1A0-01AB

Error message

Fixture not permitted

Cause of error

Fixtures are not permitted in dressing mode.

Error correction

- Remove the entry CfgKinFixSocket from the active kinematics configuration
- Inform your service agency


Error description 1A0-01AC

Error message

Configuration not suited for cylinder surface machining

Cause of error

The first machine axis under the table must be a modulo rotary axis.

Error correction

- Check the axis configuration
- Inform your machine tool builder


Error description 1A0-01AD

Error message

Fixtures ignored in "%1"

Cause of error

The indicated kinematic model has no insertion point for fixtures.

Error correction

- Adjust the machine configuration to include fixtures. To do so, please contact your machine tool builder.
Please note: If you use the indicated kinematic model, the machining operation will be executed without the desired fixture.


Error description 1A0-01AE

Error message

Island not permitted directly after a bounding block

Cause of error

In the definition of the contours, an island (I2) is defined after a "bounding block".
A "bounding block" must be followed by a pocket (P2).

Error correction

- Do not define a "bounding block" in Cycle 271 if a closed pocket or stud is to be machined
- Use CONTOUR DEF to define a pocket after the "bounding block" if an open pocket is to be machined.
- Refer to the User's Manual for more documentation


Error description 1A0-01AF

Error message

Invalid tool technology data

Cause of error

The tool radius is the sum of the values R and DR from the tool table; in some cases a programmed oversize has been added. If the width of the indexable insert (RCUTS) equals this tool radius, then the plunge angle (ANGLE) must be 90.

Error correction

Check the tool data and correct them if required.


Error description 1A0-01B1

Error message

Width of the indexable insert is too large

Cause of error

The tool radius results from the sum of the values R and DR from the tool table; in some cases a programmed oversize has been added. The width of the indexable insert (RCUTS) must not exceed 95% of the tool radius.

Error correction

Check the tool data and correct them if required.


Error description 1A0-01B2

Error message

Usable length of the tool used is too small

Cause of error

The useful length of the tool being used (column LU in the tool table) is less than the machining depth programmed in the cycle.

Error correction

- Use a tool with a greater useful length


Error description 1A0-01B3

Error message

Polar kinematics cannot be activated

Cause of error

The polar kinematics could not be activated with the programmed axes and selected solution.

Error correction

Check the selected axes and the solution:
- The axes must span the three-dimensional space
- The rotary axis must be built onto the table side and configured as a modulo axis (CfgAxis/isModulo = TRUE)
- Exactly one rotary axis must be selected
- It must be possible to reach the selected solution from the current position (MODE_POS: machine is at a positive value of the radial axis, MODE_NEG: machine is at a negative value of the radial axis)


Error description 1A0-01B4

Error message

Polar kinematics: TCPM not allowed

Cause of error

TCPM (M128) is not allowed with active polar kinematics.

Error correction

Check the NC program and adapt it if necessary


Error description 1A0-01B5

Error message

Polar kinematics: transformation not allowed

Cause of error

Certain transformations are not permitted with active polar kinematics:
- Tilt the working plane

Error correction

Check the NC program and adapt it if necessary


Error description 1A0-01B6

Error message

Polar kinematics not possible when stretch filter is active

Cause of error

Polar kinematics cannot be activated if a "Stretch Filter" is active.

Error correction

- Check the entry under CfgStrechFilter and change it if required
- Inform your service agency


Error description 1A0-01B7

Error message

Five-axis machining is not allowed with active polar kinematics

Cause of error

Programming of linear- and rotary-axis movements in one NC block is not not permitted with active polar kinematics.

Error correction

Edit the NC program.


Error description 1A0-01B8

Error message

Handwheel superimp. not allowed with active polar kinematics

Cause of error

Handwheel superimpositioning is not permitted with active polar kinematics

Error correction

- Deactivate handwheel superimpositioning
- Deactivate polar kinematics


Error description 1A0-01B9

Error message

Polar kinematics: combination with M91 not allowed

Cause of error

The combination of active polar kinematics and M91 is not permitted.

Error correction

Check the NC program and adapt it if necessary


Error description 1A0-01BA

Error message

Alternating machining not permitted for a closed contour

Cause of error

A value of 0 for Q15 (alternating machining direction) is not supported for a closed contour.

Error correction

Change the value for Q15 to +1 (climb) or -1 (up-cut).


Error description 1A0-F302

Error message

APPRLT not permitted for a closed contour

Cause of error

Approaching with APPRLT is not supported for a closed contour.

Error correction

In Cycle 270 set the input parameter Q390 to 1 (APPRCT) or 3 (APPRLN).


Error description 1A0-F303

Error message

No contours to be machined

Cause of error

After internal resolution of the contours, no (sub)contours that can be machined with OCM remain.
Please note:
- Pockets that are narrower than 2*R*(1+Q578) cannot be machined, due to the rounding arcs of inside corners.
- Depending on R and RCUTS, no plunging is possible in narrow pockets.

Error correction

Ensure that the programmed contours are sufficiently wide, particularly concerning the dimensions stated above.


Error description 1A0-F304

Error message

The depth will not be finished without an allowance

Cause of error

The depth will not be finished as long as no allowance is programmed for the depth (Q369).

Error correction

When defining the contour data, program an allowance for the depth in Q369.


Error description 1A0-F305

Error message

Programmed value for rotary axis too high

Cause of error

You programmed an excessive value for a rotary axis (greater than 1,000,000°).

Error correction

Check the NC program and correct it


Error description 1A0-F308

Error message

Workpiece blank contour too complex

Cause of error

The current workpiece blank contour exceeds the maximum limit of 200 blocks.

Error correction

Adapt the workpiece blank, or export it as an STL file and include it with BLK FORM FILE.


Error description 1A0-F309

Error message

Axis-value programming during active basic rotation

Cause of error

You programmed M128, TCPM with AXIS POS, or PLANE AXIAL.
A basic rotation for the workpiece was active at the same time.
This can lead to incorrect positioning on the workpiece.

Error correction

Edit the NC program


Error description 1A1-000C

Error message

Selected kinematics not defined

Cause of error

- Attempt to use nonexisting kinematics

Error correction

- Expand the kinematics configuration.
- Change the cycle.
- Inform your service agency.


Error description 1A1-000D

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-000E

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-000F

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-0010

Error message

Limit switch %1%2

Cause of error

The calculated tool path exceeds the machine's positive traverse limits. The current machine setting was presumably not used and the workpiece is therefore in the wrong position in the working space.
The positive software limit switch is defined with the configuration datum CfgPositionLimits->swLimitSwitchPos.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.


Error description 1A1-0011

Error message

Limit switch %1%2

Cause of error

The calculated tool path exceeds the machine's negative traverse limits. The current machine setting was presumably not used and the workpiece is therefore in the wrong position in the working space.
The negative software limit switch is defined with the configuration datum CfgPositionLimits->swLimitSwitchNeg.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.


Error description 1A1-0012

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-0013

Error message

Kinematics configuration faulty
%1

Cause of error

Fewer than 3 translation axes are configured in the machine kinematics.

Error correction

- Edit the configuration of the machine kinematics
- Check the number of axes in the kinematic model that is defined in the config object CfgProgAxis as MainLinCoord type
- When using the FUNCTION PARAXMODE: Check the number and type of axes that you have programmed in this function
- Inform your service agency


Error description 1A1-0014

Error message

Kinematics configuration faulty
%1

Cause of error

More than 3 translation axes are configured in the machine kinematics.

Error correction

- Edit the configuration of the machine kinematics
- Check the number of axes in the kinematic model that is defined in the config object CfgProgAxis as MainLinCoord type
- When using the FUNCTION PARAXMODE: Check the number and type of axes that you have programmed in this function
- Inform your service agency


Error description 1A1-0015

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-0016

Error message

Program position not accessible

Cause of error

The machine cannot reach all points in the space. The three linear axes with which the control moves to programmed positions all lie in one plane. Possible causes:
- With FUNCTION PARAXMODE you selected three axes that lie in one plane
- A linear axis is mounted on a rotary axes; the rotary axis has tilted the linear axis into the plane of the two other linear axes

Error correction

Edit the NC program


Error description 1A1-0017

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.
- Edit the cycles.


Error description 1A1-0018

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-0019

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-001A

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-001B

Error message

No accuracy specified for calculating the kinematic compensating
movement.

Cause of error

- Accuracy data missing for calculation of the kinematic compensation movement

Error correction

- Edit the cycle.


Error description 1A1-001C

Error message

Rotary axis undefined

Cause of error

- Machine kinematics incorrectly configured
- Wrong kinematics selected

Error correction

- Edit the configuration of the machine kinematics.
- Edit the cycle.
- Inform you service agency.


Error description 1A1-001D

Error message

Kinematics configuration faulty
%1

Cause of error

- Machine kinematics incorrectly configured

Error correction

- Edit the configuration of the machine kinematics.
- Inform your service agency.


Error description 1A1-001E

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-0022

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Choose a kinematic configuration with orthagonally arranged axes
- Inform your service agency


Error description 1A1-0023

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-0024

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-0025

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-0026

Error message

Function not yet implemented: %1

Cause of error

- You tried to use a non-implemented function.

Error correction

- Edit the NC program


Error description 1A1-0027

Error message

Type of grinding wheel compensation not defined

Cause of error

You have not specified the grinding wheel edge to be compensated.

Error correction

- Edit the cycle


Error description 1A1-0028

Error message

Axis cannot be moved!
%1

Cause of error

You tried to move an axis that cannot be moved by the NC, such as a display axis, which is only displayed.

Error correction

- Check the NC program
- Select suitable machine kinematics (polar)


Error description 1A1-0029

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-002A

Error message

Kinematics configuration faulty
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-002B

Error message

Kinematics configuration faulty
%1

Cause of error

- System error
- Incorrect kinematics

Error correction

- Edit the configuration of the machine kinematics.
- Inform your service agency.


Error description 1A1-003B

Error message

Grinding wheel geometry incorrect
Negative value %1 in the grinding wheel parameters

Cause of error

- Incorrect parameter settings of grinding wheel geometry

Error correction

- Correct the parameters of the grinding wheel geometry.


Error description 1A1-003C

Error message

Grinding wheel geometry incorrect
Negative value for %1 in the grinding wheel parameters

Cause of error

- Incorrect parameter settings of grinding wheel geometry

Error correction

- Correct the parameters of the grinding wheel geometry.


Error description 1A1-003D

Error message

Grinding wheel geometry incorrect
Angle %1 in the grinding wheel parameters too small

Cause of error

- Incorrect parameter settings of grinding wheel geometry

Error correction

- Correct the parameters of the grinding wheel geometry.


Error description 1A1-003E

Error message

Grinding wheel geometry incorrect
Negative edge length in the grinding wheel geometry

Cause of error

- Incorrect parameter settings of grinding wheel geometry

Error correction

- Correct the parameters of the grinding wheel geometry.


Error description 1A1-003F

Error message

Grinding wheel geometry incorrect
Missing parameter %1 in grinding wheel parameters

Cause of error

- Incorrect parameter settings of grinding wheel geometry

Error correction

- Correct the parameters of the grinding wheel geometry.


Error description 1A1-0040

Error message

System error in the geometry chain:
%1

Cause of error

- System error

Error correction

- Inform your service agency.


Error description 1A1-0042

Error message

Kinematics configuration faulty
%1

Cause of error

Invalid attribute or list element in a view message, caused by incorrect key entries in configuration messages. Because of this, the configuration server overlooks entities, which is why elements of the output lists in the view message are set to
invalid.

Error correction

- Correct the kinematic configuration.
- Inform your service agency.


Error description 1A1-0043

Error message

Kinematics configuration faulty
%1

Cause of error

Cause of error is explicitly described in the error text.

Error correction

Inform your service agency.


Error description 1A1-0044

Error message

Setting of software limits for roll-over axis not permitted

Cause of error

You tried to set values for software limit switches on a roll-over axis.

Error correction

- Change the configuration
- Edit the cycle


Error description 1A1-0045

Error message

Vertical axis direction not possible

Cause of error

It is not possible to orient the tool axis orthogonally to the working plane that you defined.

Error correction

- Edit the NC program
- If possible, clamp the tool differently
- Where applicable, change the limit switch setting of the rotary axes


Error description 1A1-0046

Error message

Control cannot calculate the circle tangent

Cause of error

You defined a cirle with the radius 0.

Error correction

Edit the NC program


Error description 1A1-0047

Error message

The control cannot change the tool orientation because no rotary
axes are defined

Cause of error

Rotary axes are not defined to allow changing the tool orientation.

Error correction

- Edit the NC program
- Rebuild the machine
- Configure the kinematics with rotary axes


Error description 1A1-0048

Error message

Error in the kinematic configuration:
%1

Cause of error

Indicated in English in the additional text

Error correction

- Edit the kinematic configuration
- Inform your service agency


Error description 1A1-0049

Error message

No axis found for tool length compensation.

Cause of error

Possible causes:
there is no axis or no clearly definable axis that can compensate the tool length.

Error correction

- Change the contour configuration
- Inform your service agency


Error description 1A1-004A

Error message

Too many axes to be interpolated

Cause of error

The maximum allowed number of simultaneously moving axes was exceeded.
(In the export version the maximum is 4 axes.)

Error correction

Check the NC program


Error description 1A1-004B

Error message

Kinematics configuration faulty

Cause of error

More than 3 translation axes are configured in the machine kinematics.

Error correction

- Edit the configuration of the machine kinematics
- Check the number of axes in the kinematic model that are defined in the config object CfgAxis in the Parameter specCoordSys as additional linear axes. Together with the axes in the kinematic model, which are defined in the config object CfgProgAxis as
the MainLinCoord type, exactly 3 axes must be available for the machine kinematics.
- When using the FUNCTION PARAXMODE: Check the number and type of axes that you have programmed in this function
- Inform your service agency


Error description 1A1-004C

Error message

Thread cutting: Direction reversal not allowed!

Cause of error

A direction reversal of the thread reference axis is not allowed.

Error correction

- You must not change the direction of the thread reference axis.
- Edit the NC program.


Error description 1A1-004D

Error message

Non-interpolating axis is exceeding the traverse range!

Cause of error

A non-interpolating axis is exceeding the traverse range limits.

Error correction

Reduce the programmed path of the non-interpolating axis.


Error description 1A1-004E

Error message

Distance is too short to accelerate non-interpolating axis!

Cause of error

A non-interpolating axis is exceeding the maximum acceleration!

Error correction

Extend the programmed path of the non-interpolating axis.


Error description 1A1-004F

Error message

This area cannot be machined!

Cause of error

No traverse permitted with polar kinematics in the programmed range.

Error correction

Check the height difference of the point or the position of the fixed axis.
Check whether the machining operation is permitted at the pole.


Error description 1A1-0050

Error message

Limit switch with handwheel superimpositioning %1%2

Cause of error

The calculated tool path exceeds the machine's positive traverse limits. The current machine setting was presumably not adopted and the workpiece is therefore in the wrong position in the working space.
M118 limit switch

Error correction

Reduce the handwheel traverse range (M118)


Error description 1A1-0051

Error message

Wrong kinematic model for FACING HEAD POS

Cause of error

The active kinematic model had not facing slide. FACING HEAD POS is allowed only with facing-slide kinematics.

Error correction

Insert the facing slide and switch the kinematics


Error description 1A1-0052

Error message

Tool inclination cannot be calculated

Cause of error

There are too many or too few rotary axes present in order to calculate the tool angle of inclination

Error correction

- Use M138 to select or deselect the rotary axes
- Check the configuration of the tool spindle, particularly CfgAxisPropKin/rotAxisForKinCalc
- Contact your machine tool builder


Error description 1A1-0053

Error message

Tool inclination cannot be calculated

Cause of error

The orientation of the indexable insert of the turning tool is not permissible.

Error correction

The plane of the indexable insert must be parallel or perpendicular to the tool spindle:
- Check the tool data
- Check the kinematics configuration, particularly the transformations (CfgKinSimpleTrans) between the tool spindle and tool
- Contact your machine tool builder


Error description 1A1-0054

Error message

Tool inclination cannot be calculated

Cause of error

Incorrect orientation of the selected rotary axes. Possible causes:
- The turning spindle is parallel to the selected tilting axis
- The tool direction is parallel to the selected tilting axis
- The programmed inclination is not possible with the present device

Error correction

- Check the programmed inclination
- Use M138 to select a different tilting axis
- Check the kinematics configuration
- Check the configuration of the tool spindle, particularly CfgAxisPropKin/rotAxisForKinCalc
- Contact your machine tool builder


Error description 1A2-000A

Error message

System error in the calculation of transformation:
%1

Cause of error

Ist im Fehlertext direkt angegeben

Error correction

- Kundendienst benachrichtigen


Error description 1A2-000B

Error message

Axis programmed more than once in PRESET command

Cause of error

Sie haben im PRESET-Befehl mehrfach dieselbe Achse programmiert.

Error correction

- NC-Programm bzw. Zyklus ändern


Error description 1C7-01F6

Error message

Data record for the FS configuration of the SPLC program

Cause of error

Data record for the configuration of functional safety for the SPLC program


Error description 1C7-0205

Error message

Max. time until the test of the motor holding-brakes

Cause of error

Axis-specific time monitoring for the execution of the brake test.
- 0: No time monitoring through the SKERN


Error description 1C7-0206

Error message

Maximum path with SS2 reaction

Cause of error

Maximum permissible path or spindle revolutions for SS2 reaction in SOM2 operating mode


Error description 1C7-0207

Error message

Maximum path with SS2 reaction

Cause of error

Maximum permissible path or revolutions of the spindle with SS2 reaction in SOM3 operating mode


Error description 1C7-0208

Error message

Maximum path with SS2 reaction

Cause of error

Maximum permissible path or spindle revolutions for SS2 reaction in SOM4 operating mode


Error description 1C7-021B

Error message

MC drives cannot be switched on: NN_GenSafe = 0

Cause of error

- SPLC interface signal NN_GenSafe = 0. It is therefore impossible to switch on the drives.
- SPLC program does not set the interface signal.
- The machine parameter MP_skipEmStopTest has been set.

Error correction

- Check the SPLC program.
- Check the entry in MP_skipEmStopTest.
- Inform your service agency.


Error description 1C7-0255

Error message

Following error monitoring for RTC coupled axes

Cause of error

Position monitoring for coupled axes.
If the axis cannot follow the RTC specification and the position difference exceeds this value, an EMERGENCY STOP reaction is triggered. You can find information on braking the drives during an EMERGENCY STOP in the Technical Manual for your control.
The settings in posTolerance apply only during active RTC and are independent of the settings in CfgPosControl.


Error description 1C7-025F

Error message

Default HSCI data rate

Cause of error

Enter the desired HSCI data rate.
With the “automatic” option, the control automatically selects the highest possible data rate.
If there are devices or cables in the HSCI system that are suited for only limited data rates, a manual preselection might be necessary.


Error description 1C7-0268

Error message

Permit handwh. superimposition of rotary axes only with TCPM

Cause of error


Error description 1C7-0350

Error message

Mode of nominal/actual value monitoring (optional)

Cause of error

The parameter specifies the type of nominal-actual-value monitoring:
- speedAndPosCompDefault:
With FS spindles, the nominal-actual-value comparison is always performed for rotational speeds; with position-controlled feed axes when the guard doors are open for positions, and when the guard doors are closed for speeds.
- speedAndPosCompReduced:
With FS spindles, the nominal-actual-value comparison is always performed for rotational speeds; with position-controlled axes when the guard doors are open for positions and otherwise for speeds
- noComp:
The nominal-actual-value comparison is inactive, so neither speeds nor positions are checked
- speedComp:
With FS spindles, the nominal-actual-value comparison is performed for rotational speeds, and with feed axes for positions.


Error description 1C9-006B

Error message

Description of a tool carrier

Cause of error

Describe here a tool carrier.


Error description 200-0001

Error message

Calculator

Cause of error


Error description 200-0017

Error message

Configuration of '%1' incorrect

Cause of error

The configuration data are incomplete or contain invalid values.

Error correction

Check the configuration data.


Error description 200-0018

Error message

Configuration for axis %1 invalid

Cause of error

The configuration data for the specified axis are incomplete or contain invalid values.

Error correction

Check the configuration datum "CfgProgAxis" for this axis.


Error description 200-0019

Error message

Configured name for axis %1 invalid

Cause of error

The configured name for an axis with the configured properties is not permissible or is already assigned to another axis.

Error correction

Change the configuration datum "CfgProgAxis/axName"


Error description 200-001A

Error message

Configured index for axis %1 invalid

Cause of error

The configured index for an axis with the configured properties is not permissible or is already assigned to another axis.

Error correction

Change the configuration datum "CfgProgAxis/index"


Error description 200-001B

Error message

Configured direction for axis %1 invalid

Cause of error

None of the directions XAxis, YAxis or ZAxis is configured for the axis.

Error correction

Change the configuration datum "CfgProgAxis/dir"


Error description 200-001C

Error message

Cycle %1 already defined

Cause of error

In CycleDesign, the same number or G number was assigned more than once for a cycle or query cycle.

Error correction

In CycleDesign, change the number of one of the cycles or its G number.


Error description 200-001D

Error message

Unable to open configuration server queue

Cause of error

Error in system-inherent communication

Error correction

Inform your service agency


Error description 200-001E

Error message

Unable to read configuration data '%1'

Cause of error

Error in system-inherent communication

Error correction

Inform your service agency.


Error description 200-001F

Error message

No programmable axes defined for the editor

Cause of error

The configuration is faulty:
CfgEditorSettings/useProgAxes is set so that the programmable axes defined through CfgChannelAxes/progAxis are to be used for the editor. CfgChannelAxes/progAxis is empty, however.

Error correction

Correct the configuration: CfgEditorSettings/useProgAxes


Error description 200-0020

Error message

NC program is incomplete

Cause of error

No valid program end found:
- File was not transmitted to the control completely
- File corrupted during editing with a text editor
- Error in the file system

Error correction

- Retransmit the file or restore it from an archive
- Manually correct the file in the NC editor
Note: The NC editor automatically appends a program end for visual purposes.
Use 'Save as' to write this program end into the file.


Error description 201-0800

Error message

Key non-functional

Cause of error

In this context the key has no function.


Error description 201-0801

Error message

Program memory exceeded

Cause of error

The NC program memory no longer suffices for part programs.

Error correction

Delete the programs that you no longer need.


Error description 201-0802

Error message

Search address missing

Cause of error

In the NC program the original search address no longer exists.

Error correction

Abort search.


Error description 201-0803

Error message

Entry value incorrect

Cause of error

- The value you entered is out-of-range.
- Cycle 209 (ISO: 209): You entered the value 0 as infeed depth for chip breaking (Q257).

Error correction

- Enter the correct value.
- Enter a value other than 0 in Q257.


Error description 201-0804

Error message

Program not found

Cause of error

You attempted to call a program that is not stored in TNC memory.

Error correction

Edit the part program.


Error description 201-0805

Error message

Protected File!

Cause of error

You cannot edit or erase this program until the protection has been removed.

Error correction

Cancel the program protection.


Error description 201-0806

Error message

Block format incorrect

Cause of error

Incorrect block format in the highlighted block.

Error correction

Edit the part program.


Error description 201-0807

Error message

Address letter already assigned

Cause of error

You used an address letter incorrectly in an ISO block.

Error correction

Edit the highlighted block.


Error description 201-0808

Error message

Block too long

DATUM SHIFT

Cause of error


Error description 201-092E

Error message

Traverse direction not defined

Cause of error

In a probing cycle you entered 0 for the traverse direction Q267.

Error correction

For Q267, enter either +1 (for positive traverse direction) or -1 (for negative traverse direction).


Error description 201-092F

Error message

No datum table active

Cause of error

Probing cycle for datum setting: You want the TNC to write the measured point into a datum table, but you have not activated a datum table in a program run mode (status M).

Error correction

In the single block or full sequence program run mode, activate the datum table into which you want the measured point to be entered.


Error description 201-0930

Error message

Position error: center in axis 1

Cause of error

Probing cycle for workpiece measurement: Center of 1st axis outside of position tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-0931

Error message

Position error: center in axis 2

Cause of error

Probing cycle for workpiece measurement: Center of 2st axis outside of position tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-0932

Error message

Hole diameter too small

Cause of error

Probing cycle for workpiece measurement: Hole diameter too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-0933

Error message

Hole diameter too large

Cause of error

- Probing cycle for workpiece measurement: Hole diameter tolerance exceeded.
- Cycle 208: The programmed hole diameter (Q335) cannot be machined with the active tool.

Error correction

- Check the workpiece and, if necessary, the measuring log.
- Cycle 208: Use a larger tool. Hole diameter must not be larger than twice the tool diameter.


Error description 201-0934

Error message

Stud diameter too small

Cause of error

Probing cycle for workpiece measurement: Stud diameter too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-0935

Error message

Stud diameter too large

Cause of error

Probing cycle for workpiece measurement: Stud diameter too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-0936

Error message

Pocket too small: rework axis 1

Cause of error

Probing cycle for workpiece measurement: Pocket length in 1st axis too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-0937

Error message

Pocket too small: rework axis 2

Cause of error

Probing cycle for workpiece measurement: Pocket width in 2nd axis too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-0938

Error message

Pocket too large: scrap axis 1

Cause of error

Probing cycle for workpiece measurement: Pocket length in 1st axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-0939

Error message

Pocket too large: scrap axis 2

Cause of error

Probing cycle for workpiece measurement: Pocket width in 2nd axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-093A

Error message

Stud too small: scrap axis 1

Cause of error

Probing cycle for workpiece measurement: Stud length in 1st axis too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-093B

Error message

Stud too small: scrap axis 2

Cause of error

Probing cycle for workpiece measurement: Stud width in 2nd too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-093C

Error message

Stud too large: rework axis 1

Cause of error

Probing cycle for workpiece measurement: Stud length in 1st axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-093D

Error message

Stud too large: rework axis 2

Cause of error

Probing cycle for workpiece measurement: Stud width in 2nd axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 201-093E

Error message

Meas. cycle: length exceeds max

Cause of error

Probing cycle 425 or 427: The measured length exceeds the maximum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 201-093F

Error message

Meas. cycle: length below min

Cause of error

Probing cycle 425 or 427: The measured length is below the minimum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 201-0940

Error message

TCHPROBE 426: length exceeds max

Cause of error

Probing cycle 426: The measured length exceeds the maximum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 201-0941

Error message

TCHPROBE 426: length below min

Cause of error

Probing cycle 426: The measured length is below the minimum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 201-0942

Error message

TCHPROBE 430: diameter too large

Cause of error

Probing cycle 430: The measured bolt-hole-circle diameter exceeds the maximum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 201-0943

Error message

TCHPROBE 430: diameter too small

Cause of error

Probing cycle 430: The measured bolt-hole-circle diameter is below the minimum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 201-094F

Error message

Incomplete cycle was deleted

Cause of error

Informational message that the TNC has erased an incomplete cycle.


Error description 201-0950

Error message

Intermediate memory empty

Cause of error

You attempted to insert a block from an empty intermediate memory.

Error correction

before trying to insert a block from intermediate memory, put the block into memory by:
- using the DEL key to delete the block to be copied, or
- placing the editing cursor into the block to be copied


Error description 201-0951

Error message

No permission to write

Cause of error

You have selected a write-protected file for editing.

Error correction

Before editing, enter the code number 86357 to cancel the write protection.


Error description 201-0952

Error message

To delete entire context: NO ENT

Cause of error

During editing you attempted to delete a word that is a required element of a function.

Error correction

Press NO ENT to delete the entire function, or press END to cancel.


Error description 201-0953

Error message

Impermissible change of context

Cause of error

You attempted to open another context within a context dialog sequence.

Error correction

Continue the dialog, or completely erase the block and enter a new context.


Error description 201-0954

Error message

No polar coordinates possible

Cause of error

You pressed the P key to enter polar coordinates. Polar coordinates are not programmable for the active function.

Error correction

Enter Cartesian coordinates to program the active function, or use a function that permits polar coordinate input.


Error description 201-0955

Error message

To change context: press ENT

Cause of error

You attempted to change a context initiator to which other elements in the current block belong.

Error correction

First delete the elements, then change the context initiator.


Error description 201-0956

Error message

Input as context not permitted

Cause of error

You entered a function that cannot initiate a context.

Error correction

Enter only permissible functions.


Error description 201-0957

Error message

Check parentheses for pairs

Cause of error

You attempted to end a Q-parameter block containing an odd number of parentheses. Parentheses can be programmed only in pairs.

Error correction

Enter the missing parentheses.


Error description 201-099D

Error message

Too many decimal places

Cause of error


Error description 201-099E

Error message

File name not equal program name

Cause of error


Error description 201-099F

Error message

Context code name unknown

Cause of error


Error description 201-09A0

Error message

Numerical value out of range

Cause of error


Error description 201-09A1

Error message

Syntax error

Cause of error

Syntax error


Error description 201-09A2

Error message

NC language unknown

Cause of error


Error description 201-09A3

Error message

File access not possible

Cause of error


Error description 201-09A5

Error message

Required value missing

Cause of error

You attempted to save an NC block although you have not entered all values required for the elements programmed in the block.

Error correction

Enter the NC block with all required data. Refer to the User's Manual if required.


Error description 201-09A8

Error message

Table data unknown

Cause of error

Table data unknown


Error description 201-09A9

Error message

Syntax error in binary record

Cause of error

Syntax error in binary record


Error description 201-0A1F

Error message

Entry character not allowed

Cause of error

You attempted to enter a character that is not allowed in the entry box.

Error correction

Edit the NC program.


Error description 201-0A20

Error message

Lowercase letter not allowed

Cause of error

You attempted to enter a lowercase letter.

Error correction

Edit the NC program. Use only uppercase letters in the entry box.


Error description 201-0A21

Error message

Letter not allowed

Cause of error

You attempted to enter a letter.

Error correction

Edit the NC program. Use only numerals in the entry box.


Error description 201-0A22

Error message

Numeral not allowed

Cause of error

You attempted to enter a numeral.

Error correction

Edit the NC program. Use only letters in the entry box.


Error description 201-0A51

Error message

Reference to block %.6s:no DEL

Cause of error

FK programming: You have attempted to delete a part program block to which another block refers.

Error correction

First edit the referring block, then delete the reference


Error description 201-0A52

Error message

FK reference to current block

Cause of error

You attempted in an FK program to delete a block to which another part of the program makes a reference.

Error correction

Change the FK reference.


Error description 201-0A55

Error message

No axes selected

Cause of error

In the MOD settings of the machining modes, no axes were selected for L-block generation.

Error correction

In the MOD settings, enter the axes whose positions are to be put into an L block when the "actual-position-capture key" is pressed.


Error description 201-0A6F

Error message

Too many characters

Cause of error

You exceeded the maximum permissible number of characters for the active input box.

Error correction

Enter fewer characters.


Error description 201-0A70

Error message

Value out of input range

Cause of error

You attempted to enter a numerical value that lies outside the permissible range.

Error correction

Comply with the permissible input range.


Error description 201-0A71

Error message

Too many decimal places

Cause of error

You attempted to enter a value that exceeds the permissible number of decimal places.

Error correction

Comply with the permissible input range.


Error description 201-0A72

Error message

Algebraic sign not allowed

Cause of error

You tried to enter an algebraic sign using the -/+ key.

Error correction

- The -/+ key is non-functional.
- It is not necessary/possible to enter the algebraic sign.


Error description 201-0A73

Error message

Only integers permitted

Cause of error

You tried to enter a number with decimal places.

Error correction

- The , key is non-functional.
- It is not necessary/possible to enter a decimal place.


Error description 201-0A74

Error message

Q not allowed: enter a number

Cause of error

You attempted to use a Q parameter in the active input box.

Error correction

Enter a numerical value.


Error description 201-0A75

Error message

Incremental input not allowed

Cause of error

You attempted to enter an incremental value by pressing the I key.

Error correction

Enter an absolute value.


Error description 201-0A76

Error message

Too many M functions

Cause of error

Too many M functions for one NC block.

Error correction

Use no more than two M functions per NC block.


Error description 201-0A77

Error message

Too many axes programmed

Cause of error

- An NC block has more than the allowed number of simultaneously movable axes.
- You tried to use an NC program to make a reverse program in which more than 5 axes are programmed.

Error correction

- Standard version: Program no more than 5 axes per NC block.
- Export version: Program no more than 4 axes per NC block.
- The source program must not include more than a total of 5 different axes.


Error description 201-0A78

Error message

Axis double programmed

Cause of error

You programmed the same axis more than once within one NC block.

Error correction

Program only different axes within one block.


Error description 201-0A79

Error message

Element double / not allowed

Cause of error

- You used the same syntax element more than once within one NC block.- The current sequence of syntax elements in an NC block do not comply with requirements.

Error correction

- Do not program syntax elements more than once within one NC block.- Put the syntax elements into the required sequence.


Error description 201-0A7A

Error message

Incomplete data input

Cause of error

Not all required data have been entered in an NC block.

Error correction

Add the missing information.


Error description 201-0A7B

Error message

ISO: Block number N missing

Cause of error

An NC block in an ISO program begins without a block number N.

Error correction

Insert the block number.


Error description 201-0A7C

Error message

Required element missing

Cause of error

Not all required data have been entered in an NC block.

Error correction

Add the missing information.


Error description 201-0A7D

Error message

Syntax incorrect

Cause of error

An NC block contains a syntax element that requires other syntax elements.

Error correction

Correct the NC block.


Error description 201-0A9F

Error message

Keyword unknown

Cause of error

In an NC block, you attempted to enter a word that the TNC cannot interpret.

Error correction

Enter only valid words.


Error description 201-0AA0

Error message

Syntax element not editable

Cause of error

You attempted to edit a syntax element in an NC block.

Error correction

Enter a new NC block with a different syntax element.


Error description 201-0AA1

Error message

PGM header not editable

Cause of error

In a program, you attempted to edit one of the blocks BEGIN PGM (ISO: %... G71), or END PGM (ISO: N99999999%...).

Error correction

The program beginning and program end must not be edited. To change the program name, use the RENAME function in the file management.


Error description 201-0AA2

Error message

No reference system change!

Cause of error

You attempted to change the coordinate data in the present block from Cartesian to polar or vice versa.

Error correction

Move the cursor to the block initation element and press the P key to change to polar or Cartesian coordinate input.


Error description 201-0AA3

Error message

Rotary axis not permitted here

Cause of error

You programmed a rotary axis as tool axis.

Error correction

Program only linear axes in the TOOL CALL block (ISO: T..).


Error description 201-0AA4

Error message

Incorrect block syntax

Cause of error

A part program block contains a syntax error.

Error correction

Edit the part program.


Error description 201-0AA5

Error message

Really delete NC block? DEL!

Cause of error

Warning before deleting an NC block.

Error correction

For complete deletion of the NC block, press DEL. To abort the delete sequence, press any other key.


Error description 201-0AA6

Error message

Axis letter not permitted

Cause of error

An attempt was made to program an axis that is not allowed for the currently active function.

Error correction

Only program permitted axes.


Error description 201-0AA7

Error message

Cannot cancel Block Skip

Cause of error

You attempted to cancel the Block Skip funktion with the Backspace key.

Error correction

Function is only permitted if the NC block begins with / .


Error description 201-0AA8

Error message

String incomplete

Cause of error

You attempted to enter an NC block in which a syntax element was not concluded with the required apostrophe.

Error correction

Ensure that apostrophes are entered in the correct locations. Refer to the User's Manual if required.


Error description 201-0AB4

Error message

Cannot go past edge of screen

Cause of error

You moved the display position of the current block to the edge of the screen.

Error correction

Select the display position of the current block so that it lies within the screen limits.


Error description 201-0ADF

Error message

Actual pos. capture not possible

Cause of error

You attempted to load the actual position into the program while the tilted working plane function was active.

Error correction

The actual position can be loaded only if the tilted working plane function is not active.


Error description 201-0AFE

Error message

Context change only on initiat.!

Cause of error

You tried to make a major change to the format of an NC block.

Error correction

Changing the NC block format is possible only if you place the cursor on the block initiator.


Error description 201-0B31

Error message

CANCELLATION in block %u (%u %%)

Cause of error

You have aborted the search process.

Error correction

If required, restart the search function and let it terminate the search process.


Error description 201-0B67

Error message

Line %u label name already assigned

Cause of error

You tried to assign the same label name in more than one NC block containing LBL SET.

Error correction

Use different label names.


Error description 201-0B88

Error message

No editing while PGM is running

Cause of error

- You tried to edit a program that is now being run.
- You tried to edit a table that is accessed from within the program that is now being run.

Error correction

- Make changes only in the stopped condition.
- Stop the program (internal stop) and reselect it with the PGM MGT key. Then edit the AFC settings.


Error description 201-0C02

Error message

File system I/O error

Cause of error

Error during access to a file system device.

Error correction

- For TNC drives, switch the control off and on to test the drives. Contact HEIDENHAIN if the problem recurs.
- For network drives, check the network connection and the computer providing the directory.
- To download a table, ensure correct table contents (for redundant lines, for example).


Error description 201-F388

Error message

Line N%u label name already assigned

Cause of error

You tried to assign the same label name in more than one NC block containing LBL SET.

Error correction

Use different label names.


Error description 210-0001

Error message

End of a system file, no identifier found

Cause of error

An identifier was expected in a message file, but the file end was reached.

Error correction

Inform your service agency.


Error description 210-0002

Error message

Identifier in system file expected

Cause of error

An identifier was expected in a message file, but a nonalphanumeric character was read.

Error correction

Inform your service agency.


Error description 210-0003

Error message

End of a system file, no string found

Cause of error

A string was expected in a message file, but the file end was reached.

Error correction

Inform your service agency.


Error description 210-0004

Error message

String in system file expected

Cause of error

A string beginning with " was expected in a message file, but another character was read.

Error correction

Inform your service agency.


Error description 210-0005

Error message

Incompatible data types in system file

Cause of error

In a message file data were read that do not fit the data object to be read.

Error correction

Inform your service agency.


Error description 210-0006

Error message

Unknown entity name in system file
Message library incompatible or
no entity instance implemented

Cause of error

An undefined message was read in a message file.

Error correction

Inform your service agency.


Error description 210-0007

Error message

Identifier already assigned in system file

Cause of error


Error description 210-0008

Error message

Integral value expected in system file

Cause of error

An integer was expected in a message file.

Error correction

Inform your service agency.


Error description 210-0009

Error message

Floating point number expected in system file

Cause of error

A floating-point number was expected in a message file.

Error correction

Inform your service agency.


Error description 210-000A

Error message

Invalid logical value in system file

Cause of error

A message file should contain a logical value (TRUE or FALSE, or a Q parameter with numerical value 0 or 1).

Error correction

Inform your service agency


Error description 210-000B

Error message

Invalid list number in system file

Cause of error

A whole number was expected in a message file, but an undefined string or a Q parameter with invalid numerical value was read.

Error correction

Inform your service agency.


Error description 210-000C

Error message

"(" expected in system file

Cause of error

A opening parenthesis "(" was expected in a message file.

Error correction

Inform your service agency.


Error description 210-000D

Error message

Unexpected end of system file

Cause of error

More characters were expected in a message file, but the file end was reached.

Error correction

Inform your service agency.


Error description 210-000E

Error message

Unknown attribute name in system file

Cause of error

In a message file an unknown message attribute was read.

Error correction

Inform your service agency.


Error description 210-000F

Error message

Attribute already assigned in system file

Cause of error

In a message file a message attribute was read more than once.

Error correction

Inform your service agency.


Error description 210-0010

Error message

":=" expected in system file

Cause of error

A colon and equal sign ":=" were expected in a message file.

Error correction

Inform your service agency.


Error description 210-0011

Error message

")" or "," expected in system file

Cause of error

A closing parenthesis ")" or a comma "," was expected in a message file.

Error correction

Inform your service agency.


Error description 210-0012

Error message

"[" expected in system file

Cause of error

An opening square bracket "[" was expected in a message file.

Error correction

Inform your service agency.


Error description 210-0013

Error message

End of a system file while reading a list

Cause of error


Error description 210-0014

Error message

End of a system file while reading an array

Cause of error

In a message file the file end was reached while an array was being read.

Error correction

Inform your service agency.


Error description 210-0015

Error message

"]" or "," expected in system file

Cause of error

A closing square bracket "]" or comma "," was expected in a message file.

Error correction

Inform your service agency.


Error description 210-0016

Error message

List in system file too long

Cause of error

A message contains a list with more elements than allowed.

Error correction

Inform your service agency.


Error description 210-0017

Error message

List in system file too short

Cause of error

A message contains a list with fewer elements than allowed.

Error correction

Inform your service agency.


Error description 210-0018

Error message

Incorrect binary data in system file (string)

Cause of error

Error during binary transmission of a string in a message

Error correction

Inform your service agency.


Error description 210-0019

Error message

Incorrect binary data in system file

Cause of error

An error occurred during the binary transfer of a binary number in a message.

Error correction

Inform your service agency


Error description 210-001A

Error message

Incorrect binary data in system file (list)

Cause of error

Error during binary transmission of a list in a message.

Error correction

Inform your service agency.


Error description 210-001B

Error message

Incorrect binary data in system file (array)

Cause of error

Error during binary transmission of an array in a message.

Error correction

Inform your service agency.


Error description 210-001C

Error message

Incorrect binary data in system file (entity)

Cause of error

Error during binary transmission of a message.

Error correction

Inform your service agency.


Error description 210-001D

Error message

Error in system file

Cause of error

An error occurred during access to an internal list element.

Error correction

Inform your service agency


Error description 210-001E

Error message

Invalid array index in system file

Cause of error

Access with an illegal index to an array.

Error correction

Inform your service agency.


Error description 210-001F

Error message

Invalid Q parameter index in system file

Cause of error

An excessively large Q-parameter index is being used in a message file.

Error correction

Inform your service agency.


Error description 210-0020

Error message

Invalid binary data in system file

Cause of error

In a message, a binary number was supposed to be read (% followed by a combination of 0 and 1).

Error correction

Inform your service agency


Error description 210-0021

Error message

Invalid attribute name in system file

Cause of error

An undefined attribute name was sought in a message.

Error correction

Inform your service agency.


Error description 210-0022

Error message

No base type defined in system file

Cause of error

Nonavailable information about base types was requested in a message.

Error correction

Inform your service agency.


Error description 210-0023

Error message

Error during access to system file

Cause of error

Basic reading error while reading a message file.

Error correction

Inform your service agency.


Error description 210-0024

Error message

Insufficient memory

Cause of error

The message memory manager has no more memory.

Error correction

Inform your service agency.


Error description 210-0025

Error message

System error: Insufficient memory

Cause of error

The message memory management is not receiving required resources from the system.

Error correction

Inform your service agency.


Error description 210-0026

Error message

System error: File mapping

Cause of error

The message memory management could not create global buffers.

Error correction

Inform your service agency.


Error description 210-0027

Error message

Requested memory block too large

Cause of error

An excessively large globel message buffer was requested.

Error correction

Inform your service agency.


Error description 210-0028

Error message

Invalid memory block returned

Cause of error

An invalid buffer was returned to the message memory management.

Error correction

Inform your service agency.


Error description 210-0029

Error message

Memory block already returned

Cause of error

A buffer was returned repeatedly to the message memory management.

Error correction

Inform your service agency.


Error description 210-002A

Error message

Missing type information in system file

Cause of error

The given message type is unknown.

Error correction

Inform your service agency.


Error description 210-002B

Error message

Invalid attribute index in system file

Cause of error

Information was requested on a nonexistent message attribute.

Error correction

Inform your service agency.


Error description 210-002C

Error message

Invalid supertype index in system file

Cause of error

Information was requested on a nonexistent message supertype.

Error correction

Inform your service agency.


Error description 210-002D

Error message

Invalid function call in system file

Cause of error

A function was called that is not allowed for Q messages.

Error correction

Inform your service agency.


Error description 210-002E

Error message

Invalid Q message data in system file

Cause of error

Error in a message file while reading a Q message.

Error correction

Inform your service agency.


Error description 210-002F

Error message

Invalid Q string

Cause of error

An excessively long string was assigned to a Q-String.

Error correction

Inform your service agency.


Error description 220-0001

Error message

Undefined error

Cause of error

Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 220-0002

Error message

Internal software error

Cause of error

System error. The given message contains an attribute with illegal value.

Error correction

Inform your service agency.


Error description 220-0003

Error message

Internal software error

Cause of error

Attempt to read the same measuring position more than once with the same identifier.

Error correction

Inform your service agency.


Error description 220-0004

Error message

Internal software error

Cause of error

System error

Error correction

Inform your service agency.


Error description 220-0005

Error message

Internal software error

Cause of error

System error

Error correction

Inform your service agency.


Error description 220-0008

Error message

Internal software error

Cause of error

System error

Error correction

Inform your service agency.


Error description 220-000A

Error message

Start was not executed

Cause of error

Start of an application that cannot be run together with another.
There are unacknowledged errors in the error window.

Error correction

First end the application.
Delete the error message.


Error description 220-000B

Error message

Internal software error

Cause of error

System error

Error correction

Inform your service agency.


Error description 220-000C

Error message

Message will not be handled in its present state

Cause of error

Message will not be handled in its present state.

Error correction

None


Error description 220-000E

Error message

Error in module configuration

Cause of error

The object requested by the configuration server could not be found.

Error correction

Edit the configuration data.
Inform your service agency.


Error description 220-000F

Error message

Error in TOOL DEF or TOOL CALL cycle

Cause of error

The TOOL DEF message was followed by an incorrect TOOL CALL message.

Error correction

Inform your service agency.


Error description 220-0010

Error message

Internal software error

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 220-0011

Error message

Error occured in startup cycle

Cause of error

Startup cycle interrupted with error.

Error correction

Remove the cause of error and delete the error message. The cycle is restarted.


Error description 220-0013

Error message

Configuration error occured

Cause of error

Channel name must be unambiguous

Error correction

Edit the configuration data.


Error description 220-0014

Error message

Invalid message %1

Cause of error

The entered message contains an attribute with invalid value.

Error correction

No further action required


Error description 220-0015

Error message

File access not possible

Cause of error

1.) Access to the file was denied.
2.) Another application is already writing to the file.
3.) Error in path name.
4.) Data medium full.

Error correction

1.) Check the access rights to the file and remove any existing write protection.
2.) Close the file in the application that has locked access to the file.
3.) Correct the entered path name.
4.) Delete any unneeded files on the data medium.


Error description 220-0016

Error message

Disk full

Cause of error

Data medium full.

Error correction

Delete any unneeded files on the data medium.


Error description 220-0017

Error message

File close failed

Cause of error

Error while closing the file.

Error correction

Ensure that the file is not being used by another application.


Error description 220-0018

Error message

General internal communication error

Cause of error

An error has occurred in the system-inherent communication.

Error correction

Inform your service agency.


Error description 220-0019

Error message

ClientQueue (%1) could not be opened

Cause of error

Error in system-inherent communication.
No access possible to the specified queue.

Error correction

Inform your service agency.


Error description 220-001A

Error message

Cannot write to queue '%1'

Cause of error

Error in the system-inherent communication.
An error occurred while writing data to the specified queue.

Error correction

Inform your service agency.


Error description 220-001B

Error message

Cannot close queue '%1'

Cause of error

Error in the system-inherent communication.
The specified queue cannot be closed.

Error correction

Inform your service agency.


Error description 220-001C

Error message

Unknown error

Cause of error

An unknown error occurred during the execution of a program.

Error correction

- Inform your service agency.


Error description 220-001D

Error message

Value too small in %1-%2

Cause of error

- The entered value is below the minimum limit value.

Error correction

- Change the value.
- Check the minimum limit value.


Error description 220-001E

Error message

Value too large in %1-%2

Cause of error

- The entered value is above the maximum limit value.

Error correction

- Change the value.
- Check the maximum limit value.


Error description 220-001F

Error message

Value in %1 out of range

Cause of error

- The entered value is outside of the permitted value range.

Error correction

- Change the value.
- Check the limit values.


Error description 220-0020

Error message

System error in the channel object

Cause of error

System error in the channel object

Error correction

- Inform your service agency.


Error description 220-0021

Error message

Invalid FN14 function

Cause of error

- Stop error not allowed within an internal cycle
- Stop error not alllowed after start via soft key

Error correction

Edit the cycle or inform your service agency or machine tool builder.


Error description 220-0022

Error message

System error in program run:
Control might be inconsistent

Cause of error

An error occurred in an internal cycle. The internal data of the control might therefore be inconsistent.

Error correction

- Shut down the control as soon as possible and restart it. Until then procede with increased caution.
- Inform your service agency.


Error description 220-0023

Error message

Format file defective

Cause of error

The outputs with FN16: F-PRINT (ISO: D16) have reached the maximum size.

Error correction

Change the format file. If necessary, output each text individually, concluding with M_CLOSE.


Error description 220-0024

Error message

Function not available

Cause of error

During a block scan on a control without a history, an attempt was made to implement a PLC strobe with a macro.
The function cannot be run on this control.

Error correction

- Change the machine configuration
- Inform your service agency


Error description 220-0025

Error message

Contradictory data during PLC strobe implementation

Cause of error

The data in a message are contradictory (implementation of a PLC strobe with a macro).

Error correction

- Inform your service agency


Error description 220-0026

Error message

Mid-program startup: Simulated TOOL CALL missing

Cause of error

- You executed a block scan that makes a TOOL CALL. However, in the config object CfgSimPosition, the required axis positions after the tool change were not specified.

Error correction

- Adapt the machine configuration. Assign appropriate values to the config object CfgSimPosition.
- Inform your machine tool builder.


Error description 220-0027

Error message

Contradictory data in calculation of the position to be attained

Cause of error

When returning to the contour (mid-program startup), the control found contradictory data when calculating the position to be moved to.

Error correction

- Inform your service agency.


Error description 220-0028

Error message

OK

Cause of error


Error description 220-0029

Error message

NC program

Cause of error


Error description 220-002A

Error message

NC program changed!

Cause of error


Error description 220-002B

Error message

External tool

Cause of error


Error description 220-002C

Error message

Remaining tool life too short

Cause of error


Error description 220-002D

Error message

Tool life exceeded

Cause of error


Error description 220-002E

Error message

Radius difference exists

Cause of error


Error description 220-002F

Error message

Radius R2 greater than radius R

Cause of error


Error description 220-0030

Error message

Tool not defined

Cause of error


Error description 220-0031

Error message

No fitting tool available

Cause of error


Error description 220-0032

Error message

Tool locked

Cause of error


Error description 220-0033

Error message

Warning: Tool usage file was not generated with %s!

Cause of error


Error description 220-0034

Error message

The current kinematic configuration uses a deactivated axis!

Cause of error

In the current kinematic configuration, an axis is used that is deactivated at present.
When an NC program is started or after a PLC strobe is executed, the control checks whether all axes of the active kinematic configuration are also active. Axis movements are no longer allowed.

Error correction

- Activate the deactivated axis, check the machine configuration and correct it if required.
- Activate another machine kinematic configuration through the NC program.
- Edit the machine configuration or activate another machine kinematic configuration.


Error description 220-0035

Error message

Not all axes in necessary nominal position

Cause of error

You tried to resume the program after returning to the contour, after an NC stop, or after a mid-program startup although not all axes are on the nominal position.
The nominal position after an NC stop is the stop position.
The nominal position after a mid-program startup is the calculated restore position.

Error correction

- Check the configuration, CfgChannelAxes/restoreAxis
- Inform your machine tool builder.


Error description 220-0036

Error message

Incorrect operating mode for internal cycle

Cause of error

An internal cycle is running in another operating mode than intended. Therefore the internal data of the control are possibly inconsistent.

Error correction

- Shut down the control and restart.
- Inform your service agency.


Error description 220-0037

Error message

Cancel during switch between turning op. and milling operation

Cause of error

A cancelation occurred during switchover between turning and milling operation.

Error correction

Run FUNCTION MODE MILL or FUNCTION MODE TURN again for consistency.


Error description 220-0038

Error message

Machine not initialized

Cause of error

- After the machine traversed the reference points, you
tried to select a program run mode although the machine was not yet completely initialized.
- You canceled the initialization process.

Error correction

- Close all open protective doors.
- Unlock all emergency stop buttons.
Then press the INIT MACHINE soft key (2nd soft-key row).


Error description 220-0039

Error message

Data reset due to reconfiguration of the kinematics

Cause of error

Data were set during a reconfiguration of the kinematics that are independent from the kinematics.
Press the "INTERNAL INFO" soft key for more information.

Error correction

- Delete the error and do an NC start if the reset is OK.
- Cancel if difficulties are expected in program continuation due to the reset.


Error description 220-003A

Error message

Data record already locked

Cause of error

An attempt was made to update the tool life in an locked tool data record.

Error correction

Cancel the lock on the data record (e.g. exit the input with the "EDIT OFF/ON" soft key),
otherwise it can result in data loss at program end when the tool life updated.


Error description 220-003B

Error message

Cannot end the cancel system cycle %1

Cause of error

Could not complete the cancel system cycle, perhaps because a PLC strobe was not acknowledged.

Error correction

- Shut down and restart the control (shutdown via error window,
MORE FUNCTIONS soft key)
- Inform your machine tool builder. He should take the following measures:
- Correct the error in the cancel cycle or in the OEM cancel macro
- Correct the error in the PLC program


Error description 220-003C

Error message

Faulty configuration

Cause of error

Entry appears twice in the list

Error correction

Check the configuration data and edit them if necessary


Error description 220-003D

Error message

Tool usage time could not be calculated

Cause of error

- An error occurred in finding the application times of the tools.
- Tool usage file is not available or not up to date.

Error correction

- Ensure that the tool usage test has been activated by the configuration.
- Usage file for NC program: simulate the program in the Test Run operating mode. The TNC then automatically creates the tool usage file.
- Usage file for pallet file: simulate the marked program in the Test Run operating mode. The TNC then automatically creates the tool usage file for each simulated program.


Error description 220-003F

Error message

Program cannot be continued. Selection with GOTO necessary.

Cause of error

You have called for the program simulation to continue within an NC block. Changed conditions must be applied in order to continue.
These can be, for example, a new position for a stop, a changed Q parameter, or a changed condition for the activation of skipped blocks.

Error correction

Starting with RESET+START is possible, as is START after GOTO.
As an alternative, perform the stated changes only at a stop at the beginning of an NC block.


Error description 220-0040

Error message

File path %1 missing
in CfgConfigDataFiles or in CfgJhConfigDataFiles
%2 has no effect

Cause of error

A file path is missing in the configuration data. See the error text for more information.

Error correction

Enter the missing path in CfgConfigDataFiles or in CfgJhConfigDataFiles


Error description 220-0041

Error message

Programmed variable cannot be applied

Cause of error

You tried to edit a variable (e.g. a Q parameter) even though this is not possible in the current state.
For example, variables of an NC program cannot be edited while the program is running (not stopped).

Error correction

Try again under appropriate conditions.


Error description 220-0042

Error message

Warnings are being suppressed

Cause of error

The current program run is generating many warnings.
The number of warnings of the same type is limited.
Further warnings of this type will be suppressed.

Error correction

Correct the NC program


Error description 221-0004

Error message

Error in the kinematic configuration:
%1

Cause of error

List attribute not initialized

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0005

Error message

Error in module configuration

Cause of error

The object requested by the configuration server could not be found.

Error correction

- Edit the configuration data
- Inform your service agency


Error description 221-0007

Error message

Configuration error occured

Cause of error

General error message that shows that at least one configuration error has occurred.

Error correction

- Correct the displayed configuration error
- If no more configuration errors occur, the message is automatically deleted.


Error description 221-0008

Error message

Error in module configuration:
%1

Cause of error

- The individual object received by the configuration server is incorrect.

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0009

Error message

Error in module configuration:
%1

Cause of error

- The view object received by the configuration server is incorrect.

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-000A

Error message

Error in module configuration:
%1

Cause of error

Inconsistent configuration data

Error correction

- Edit the configuration data.
- Inform your service agency.


Error description 221-000B

Error message

General system error in the geometry chain

Cause of error

Contradictory data

Error correction

Inform your service agency.


Error description 221-000C

Error message

Incorrect condition in switch statement

Cause of error

System error during reconfiguration

Error correction

- Edit the kinematic configuration.
- Inform your service agency.


Error description 221-000D

Error message

Error in module configuration:
%1

Cause of error

Uninitialized list in configuration object

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-000E

Error message

Error in module configuration:
%1

Cause of error

List size of an attributre in configuration object is too small.

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-000F

Error message

Kinematics configuration faulty
%1

Cause of error

Incorrect axis key in key list

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0010

Error message

Kinematics configuration faulty

Cause of error

Error in the kinematic configuration

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0011

Error message

Kinematics configuration faulty

Cause of error

Error in the kinematic configuration

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0012

Error message

Kinematics configuration faulty

Cause of error

Error in the kinematic configuration

Error correction

- Edit the kinematic configuration.
- Inform your service agency.


Error description 221-0013

Error message

Kinematics configuration faulty

Cause of error

Error in the kinematic configuration

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0014

Error message

Kinematics configuration faulty
%1

Cause of error

Missing attribute

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0015

Error message

Kinematics configuration faulty
%1

Cause of error

Attribute with incorrect value

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0016

Error message

Kinematics configuration faulty
%1

Cause of error

Inconsistency in number of axes

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0017

Error message

Kinematics configuration faulty
%1

Cause of error

Inconsistent key lists in the kinematic model

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0018

Error message

Kinematics configuration faulty
%1

Cause of error

Keys in key list already defined

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0019

Error message

Kinematics configuration faulty
%1

Cause of error

Same key in the key lists for coordinate transformation through directions and coordinate transformation through angle.

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-001A

Error message

Kinematics configuration faulty
%1

Cause of error

Incorrect index for key list

Error correction

- Change the kinematic configuration.
- Inform you service agency.


Error description 221-001B

Error message

Kinematics configuration faulty
%1

Cause of error

Incorrect number of coordinate transformations

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-001C

Error message

Kinematics configuration faulty
%1

Cause of error

Missing coordinate transformation matrix

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-001D

Error message

Kinematics configuration faulty
%1

Cause of error

Key missing in two key lists, although it should be in one of them

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-001E

Error message

Error in the kinematic configuration
Function not yet implemented: %1

Cause of error

Attempt to use a nonimplemented function

Error correction

- Edit the NC program.


Error description 221-001F

Error message

Kinematics configuration faulty
%1

Cause of error

Coordinate system defined in two different ways

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0020

Error message

Kinematics configuration faulty
%1

Cause of error

- Missing coordinate system definition by angle
- Usually caused by an incorrect key in a coordinate transformation defined by directions

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0021

Error message

Kinematics configuration faulty
%1

Cause of error

Incorrect key in key list

Error correction

- Change the kinematic configuration.
- Inform your service agency.


Error description 221-0022

Error message

System error during reconfiguration of geometry chain:
%1

Cause of error

System error during reconfiguration

Error correction

- Inform your service agency.


Error description 221-0023

Error message

Incorrect path parameters for look-ahead:
%1

Cause of error

Incorrect path parameter for look-ahead

Error correction

- Edit the configuration.


Error description 221-0024

Error message

No acceleration was defined

Cause of error

No axis acceleration set

Error correction

Edit the configuration.


Error description 221-0025

Error message

Invalid max. feed override

Cause of error

Invalid maximum feed rate override

Error correction

Edit the configuration


Error description 221-0026

Error message

Error in the general parameter configuration:
%1

Cause of error

Error in the general parameter configuration.

Error correction

- Edit/complete the parameter configuration.
- Inform your service agency.


Error description 221-0027

Error message

Kinematics configuration faulty
%1

Cause of error

A programmable axis with special properties was configured. This programmable axis was not assigned to any physical.

Error correction

– Check the axis configuration and edit/add to it if required.
- Inform your service agency


Error description 221-0028

Error message

Bad attribute info of %1

Cause of error

Attribute information invalid or illegible

Error correction

Inform your service agency.


Error description 221-0029

Error message

Value too small in %1-%2

Cause of error

Programmed or configured value too small.

Error correction

- Edit the configuration.
- Edit the program.


Error description 221-002A

Error message

Value too large in %1-%2

Cause of error

Programmed or configured value too large.

Error correction

- Edit the configuration.
- Edit the program.


Error description 221-002B

Error message

No SQL column description for column %1 in table %2

Cause of error

The SQL server does not provide a column description for the given SQL table column.
It could be that the corresponding table does not exist, is incorrect in syntax, or for some other reason cannot be opened from the SQL server. Or the table has no column with the given name.

Error correction

Ensure that the corresponding table exists and that it has the matching column. Then restart the control.
The interpreter needs column descriptions
- For all table columns for which you have configured bonds (over CfgSqlProperties, CfgTableBinding and CfgColumnBinding).
- For all columns of some fundamental SQL tables, that are indispensable for the correct function of the system (e.g. tool table).


Error description 221-002C

Error message

SQL column description for column %1
in table %2 inconsistent with bond

Cause of error

The column description for the specified SQL table column provided by the SQL server does not have the correct format for the bond that you have configured for this column, or the table column has a format the interpreter does not recognize.

Error correction

Ensure that the column description is correct.


Error description 221-002D

Error message

CfgTableBinding with key %1 inconsistent

Cause of error

In a CfgTableBinding you listed a key for a CfgColumnBinding that does not exist.

Error correction

Add the missing CfgColumnBinding or delete the entry from CfgTableBinding.


Error description 221-002E

Error message

Faulty SQL column bond for column %1

Cause of error

A faulty bond is configured for the specified column (CfgColumnBinding).

Error correction

Correct CfgColumnBinding: You can configure bonds on Q parameters (ID=0, NR0 bis 999) and bonds on the system data managed in the interpreter.


Error description 221-002F

Error message

Inconsistent configuration for implicit SQL access
in the interpreter

Cause of error

The configuration data that determine how the interpreter implicitly accesses SQL tables are inconsistent.
(These configuration data are accessible only to the control manufacturer)

Error correction

Correct the configuration data:
- The tables (id50Table etc.) given in CfgChannelSysData for the corresponding channel must exist.
- An entity CfgSysDataTable with the corresponding key must exist for the columns (id50Columns etc.).
- For every entry in the Attribute column of the entity CfgSysDataTable, an entity CfgSysDataColumn with the corresponding key must exist.


Error description 221-0030

Error message

Unknown error

Cause of error

An unknown error occurred during the execution of a program.

Error correction

- Inform your service agency.


Error description 221-0031

Error message

Machine base not specified

Cause of error

The kinematics contain a plane (CfgCMOPlane) and rotary axes.
The position of the machine base must be entered in this kinematic configuration.

Error correction

Specify the position of the machine base (in CfgKinAnchor).
Use only planes between the machine base and the first rotary axis at the tool.
Use only planes between the machine base and the first rotary axis at the machine table.


Error description 221-0032

Error message

Kinematics configuration faulty

Cause of error

Physical axis cannot be assigned to any programmable axis

Error correction

- Change the configuration (CfgProgAxis, CfgAxis)
- Inform your service agency


Error description 221-0033

Error message

Model not loaded "%1": CMOMesh3D "%2"

Cause of error

The M3D file could not be opened.

Error correction

Check the path to the file in the machine configuration and correct it if necessary.


Error description 221-0034

Error message

Model not loaded "%1": CMOMesh3D "%2"

Cause of error

Error while loading the M3D file. The file is corrupt or is not a valid M3D file.

Error correction

- Check the path and correct it if necessary
- Reload the M3D file


Error description 221-0035

Error message

STL model does not fulfill the quality requirements

Cause of error

STL model %1 does not fulfill the quality requirements.

Error correction

Use an STL model that fulfills the quality requirements.
The following requirements are placed on STL models:
- All size values in mm
- No gaps between triangles ("waterproof")
- No overlapping
- No degenerated triangles
Refer to the additional information in the Technical Manual.


Error description 221-0036

Error message

Kinematic temperature compensation incorrectly configured

Cause of error

Parameters in the machine configuration were entered incorrectly:
Within the config object CfgKinSimpleTrans, both machine parameters realtimeComp and temperatureComp are set. This is not allowed. Only one of the two parameters can be set.

Error correction

Correct the machine configuration:
Delete either the parameter realtimeComp or temperatureComp.


Error description 221-0037

Error message

Model not loaded "%1": CMOMesh3D "%2"

Cause of error

Error while loading the M3D file. The file contains too many triangles.

Error correction

Model the collision objects with fewer triangles. Refer to the additional information in the Technical Manual.


Error description 221-006F

Error message

Faulty kinematics configuration
Active kinematics %1 contains an invalid insertion point.

Cause of error

The given kinematic model contains at least one invalid insertion point for a tool-carrier kinematic model (entry under CfgKinToolSocket)

Error correction

Ensure that the kinematic model contains no more than one object of the CfgKinToolSocket type.
Ensure that no objects of the CfgKinSimpleAxis or CfgKinAnchor types are located between the tool (i.e. the upper end of the kinematic chain) and the insertion point for the tool carrier.


Error description 221-0071

Error message

No facing slide axis available in the kinematic model

Cause of error

The kinematics do not include a facing slide axis.

Error correction

- Change the kinematic configuration
- Inform your service agency


Error description 221-0072

Error message

Spindle or facing slide in faulty in the kinematic model

Cause of error

The spindle is not correctly configured in the kinematics:
- In the kinematics configuration, the spindle is not located directly next to the facing slide
- The kinematics do not include spindle

Error correction

- Inform your service agency
- Adapt the kinematic configuration


Error description 221-0073

Error message

Datum of facing slide axis is incorrect

Cause of error

The datum of the facing slide is not on the spindle axis.

Error correction

- Check the kinematic configuration and adapt it if necessary.
- Inform your service agency.


Error description 221-0074

Error message

Faulty kinematics configuration

Cause of error

Active kinematics contains an invalid insertion point for a fixture (entry under CfgKinFixSocket).
The invalid entry is shown in the additional information of the error message.

Error correction

Ensure that the kinematic model contains no more than one object of the CfgKinFixSocket type.
Ensure that no objects of the type CfgKinSimpleAxis or CfgKinAnchor are located between the machine table (i.e. the bottom end of the kinematics chain) and the insertion point for the fixture.


Error description 221-0075

Error message

Faulty kinematics configuration

Cause of error

Active kinematics contains an invalid insertion point for a tool-carrier kinematic model (entry under CfgKinToolSocket).
The invalid entry is shown in the additional information of the error message.

Error correction

Ensure that the kinematic model contains no more than one object of the CfgKinToolSocket type.
Ensure that no objects of the type CfgKinSimpleAxis or CfgKinAnchor are located between the tool (i.e. the top end of the kinematics chain) and the insertion point for the tool carrier.


Error description 230-0001

Error message

Parameter set %2 of axis %3 does not exist

Cause of error

An undefined axis parameter block was selected.

Error correction

In the configuration data, create an additional parameter block for this axis, or select another parameter block for this axis.


Error description 230-0002

Error message

Logical axis number %2 too large

Cause of error

The control supports a certain maximum number of axes. Here more axes were configured that permitted.

Error correction

Configure fewer axes.


Error description 230-0003

Error message

Too many analog axes configured (more than 2)

Cause of error

The control supports a certain maximum number of analog axes.
Here more axes were configured than allowed.

Error correction

Configure fewer analog axes.


Error description 230-0004

Error message

More axes are activated than are enabled in the SIK

Cause of error

The axis options in the SIK specify how many axes can be active at the same time. You have activated more axes over the machine configuration or the PLC program than are allowed as axis options in the SIK.
You can delete this error message. If the configured axis number is still too large after the drives are switched on again, the error message will reappear.

Error correction

- Check the machine configuration and PLC program.
- If you need more axes, you can get a code number from HEIDENHAIN to enable them.


Error description 230-0005

Error message

External EMERGENCY STOP

Cause of error

- The PLC input for the control-is-ready signal is inactive
- The EMERGENCY STOP circuit was interrupted manually or by the control.

Error correction

- Enable the EMERGENCY STOP button, switch on the control voltage, and acknowledge the error message.
- Check the EMERGENCY-STOP circuit. (EMERGENCY STOP button, axis limit switches, wiring, etc.)


Error description 230-0006

Error message

Check the parameter for the direction of spindle rotation (2)!

Cause of error

A change in the evaluation of the parameter signCorrNominalVal automatically changed the value of the parameter signCorrActualVal.

Error correction

Please check whether the spindle turns with M3 and M19 in the correct direction.
If required, use parameter CfgAxisHardware > signCorrNominalVal or CfgAxisHardware > signCorrActualVal  to define the direction of rotation correctly according to the data in the Technical Manual.


Error description 230-0007

Error message

Channel number %2 too large

Cause of error

The control supports a certain maximum number of channels. Here more channels were configured than allowed.

Error correction

Configure fewer channels.


Error description 230-0008

Error message

No reaction from CC

Cause of error

The speed and current controller was switched off due to an error.

Error correction

Check the axis cabling.


Error description 230-0009

Error message

IPO exceeds cycle time

Cause of error

The control loop exceeds the maximum permissible cycle time.

Error correction

Increase the maximum permissible cycle time in the System->MachineHardware->ipoCycle parameter.


Error description 230-000A

Error message

Axis %2 is switched inactive

Cause of error

Command to an axis configured as inactive.

Error correction

In the parameter "Axes->PhysicalAxes->????->axisMode," switch the axis to "active."
"????" designates the current axis name.


Error description 230-000B

Error message

This is not the export version of the software

Cause of error

This is not the export version of the software.

Error correction

Inform your service agency.


Error description 230-000C

Error message

Parameter %2 is not loaded until the control has been restarted

Cause of error

A parameter cannot be loaded for this axis without a RESET of the control.

Error correction

Restart the control.


Error description 230-000D

Error message

Ipo-Trace started

Cause of error

IPO trace started (info)


Error description 230-000E

Error message

Ipo-Trace stopped

Cause of error

IPO trace stopped (info)


Error description 230-000F

Error message

Drive switched off illegally %2

Cause of error

The drive was switched off without a command from the PLC.


Error description 230-0010

Error message

IPO is running in simulation mode

Cause of error

IPO is running in simulation mode (info)


Error description 230-0011

Error message

This software version has not been enabled

Cause of error

Wrong software installed

Error correction

Inform your service agency


Error description 230-0012

Error message

Only %1 KB of free memory remaining in SYS partition

Cause of error

The memory capacity of the SYS partition is almost depleted.

Error correction

Inform your service agency


Error description 230-0013

Error message

Only %1 KB of free memory remaining in SYS partition

Cause of error

The memory capacity of the SYS partition is almost depleted.
Service information recording was stopped.

Error correction

Inform your service agency


Error description 230-0014

Error message

Parameter selection for axis %2 not allowed in this state

Cause of error

A parameter block switchover was requested in an illegal condition of the NC.

Error correction

Check the PLC program


Error description 230-0015

Error message

Initialization of counter components (G50) failed

Cause of error

The required configuration data for the counter component (G50) could not be read from the file %SYS%\config\CfgG50Init.cfg.

Error correction

Inform your service agency


Error description 230-0016

Error message

Wrong hardware configuration

Cause of error

There are two SPI modules with various versions.

Error correction

Inform your service agency


Error description 230-0017

Error message

Access to internal periphery failed

Cause of error

A timeout was caused during access to the internal periphery

Error correction

Inform your service agency


Error description 230-0018

Error message

Position or speed control of axis %2 still active

Cause of error

The position, speed and current controllers of axes must be switched off before they can be activated or deactivated.

Error correction

- Check the PLC program


Error description 230-0019

Error message

Changing a parameter requires an NC STOP

Cause of error

During reconfiguration or a parameter set switchover a parameter was changed that requires a previous NC STOP.

Error correction

- Check the PLC program


Error description 230-001A

Error message

A parameter change requires the drive to be switched off (axis %2)

Cause of error

During reconfiguration or a parameter set switchover a parameter was changed that requires that the drive be switched off beforehand.

Error correction

- Check the PLC program


Error description 230-001B

Error message

For a parameter change the drive has to be deactivated (axis %2)

Cause of error

During reconfiguration or a parameter set switchover a parameter was changed that requires that the drive be deactivated beforehand.
Note: The changed parameter or parameter set was not accepted.

Error correction

- Check the PLC program


Error description 230-001C

Error message

Interrupt cycle greater than 3 ms

Cause of error

The cycle time of the controller interrupt exceeds the maximum permissible tolerance of 3 ms. The cause could be a hardware defect of the computer unit MC.

Error correction

- Inform your service agency


Error description 230-001D

Error message

Control loop of axis %2 was opened

Cause of error

The position control loop was opened in order to optimize the axis (e.g. with TNCopt).


Error description 230-001E

Error message

Timeout in the initial servicing of axis %2

Cause of error

Possible cause: There is no connection to the PC initial-servicing software TNCopt.

Error correction

- Check the connection to TNCopt. (Is the network cable plugged in? Are the interface settings correct?)
- Restart TNCopt


Error description 230-001F

Error message

Max. traverse range limits of axis %2 exceeded

Cause of error

When the control loop was open the traverse range limits given by TNCopt were exceeded.

Error correction

Inform your service agency


Error description 230-0020

Error message

Failed to send internal message

Cause of error

Error in the internal system communication

Error correction

Inform your service agency


Error description 230-0021

Error message

Axis %2 cannot be activated

Cause of error

The value configured under CfgAxis-axisHw prohibits this activation command.

Error correction

Check the configuration


Error description 230-0022

Error message

One or more axes of the channel (%2) are deactivated

Cause of error

You have selected a machine kinematic configuration that contains deactivated axes. During NC start the control checks whether all axes of the selected kinematic configuration are also active.

Error correction

- Check the machine configuration and PLC program.
- Activate deactivated axes.
- Select a machine kinematic configuration that has no deactivated axes.


Error description 230-0023

Error message

Change of the activation status of axis %2 not allowed

Cause of error

A change was requested of the activation status of an axis (activate/deactivate) in an illegal status of the NC.

Error correction

- Check the PLC program and correct if necessary.


Error description 230-0024

Error message

SPI analog module on CC%2 not recognized

Cause of error

An analog axis was configured on a CC, but no SPI analog module was detected there.

Error correction

Check the configuration. If necessary, inform your service agency.


Error description 230-0025

Error message

Position of axis %2 stored

Cause of error

The position of this axis is to be saved (frozen) while the control loop is closed
or the control loop of this axis was to be closed while the position was saved.

Error correction

Check the PLC program. If necessary, inform your service agency.


Error description 230-0026

Error message

An HSCI participant has triggered the SS2/STOP2 stop reaction

Cause of error

- The self-test of the control could not be completed
- A device reports a temperature problem
- The fan of a device is defective

Error correction

- Note further messages
- Use the bus diagnostics (or TNCdiag, if available) to find out which device reports the error (bit REQ.SS2 in the local S status)


Error description 230-0027

Error message

More spindles than permitted are configured

Cause of error

You configured more spindles than allowed for the control.

Error correction

- Check the machine configuration and correct it if required
Parameter: System / CfgAxes / spindleIndices


Error description 230-0028

Error message

Internal software error

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 230-0029

Error message

IPO cycle time exceeded permissible threshold (%2 us)

Cause of error

The cycle time of the controller interrupt exceeds the default threshold in the internal parameter maxIpoTime.

Error correction

Inform your service agency.


Error description 230-002A

Error message

Difference between ACTL and NOML spindle speed (%2) too high

Cause of error

The difference between the actual and nominal speed exceeds the tolerance.

Error correction

- Check the parameters CfgSpindle/absSpeedTolerance and CfgSpindle/relSpeedTolerance
- Check whether the actual and nominal speeds have the same algebraic sign


Error description 230-002B

Error message

Formula entered in distPerMotorTurnF is invalid

Cause of error

In the machine parameter "distPerMotorTurnF" you entered a formula that contains invalid characters.

Error correction

- Check the input value in machine parameter "distPerMotorTurnF " and correct it


Error description 230-002C

Error message

PLC:/ccfiles file must be deleted

Cause of error

The file PLC:/ccfiles is available, but it is needed as a directory by the NC software for CC files.

Error correction

Delete the PLC:/ccfiles file and then restart the control


Error description 230-002D

Error message

Deactivation of an active touch probe (TS or TT) not allowed

Cause of error

The PLC program tried to deactivate a touch probe activated by the NC, or the NC tried to deactivate a touch probe activated by the PLC.

Error correction

Check the NC program and/or the PLC program


Error description 230-002E

Error message

Initialization of counter components (G127) failed

Cause of error

Hardware is defective

Error correction

Inform your service agency.


Error description 230-002F

Error message

The control is still in its factory default setting

Cause of error

The parameter CfgMachineSimul/simMode is still set to the value "Delivery". The drives cannot be switched on in this mode.

Error correction

- Set parameter CfgMachineSimul/simMode to the value "FullOperation". First the parameters of the axes must be assigned with realistic values.


Error description 230-0030

Error message

Encoder error in axis %2

Cause of error

The encoder for this axis reports an error.
Possible errors (encoder status):
Bit 2 = 1: Position could not be ascertained
Bit 3 = 1: CRC error during EnDat 2.2 transmission
Bit 4 = 1: No position measurement with EnDat 2.2
Bit 5 = 1: Alarm 1 with EnDat 2.2
Bit 6 = 1: Alarm 2 with EnDat 2.2
Bit 7 = 1: Timeout during EnDat 2.2 transmission

Error correction

Check the connected encoder


Error description 230-0031

Error message

RTC: Axis %2 exceeds the max. permissible velocity

Cause of error

The maximum permissible value was exceeded during the real-time coupling (RTC).

Error correction

Allow a greater share of CfgFeedLimits/maxFeed in CfgRtCoupling/maxFeed, or change the function in CfgRtCoupling/function


Error description 230-0032

Error message

RTC: Axis %2 exceeds the max. permissible acceleration

Cause of error

The real-time coupling function (RTC) causes a violation of the maximum permissible acceleration.

Error correction

Allow a greater share of CfgFeedLimits/maxAcceleration in CfgRtCoupling/maxAcc, or change the function in CfgRtCoupling/function


Error description 230-0033

Error message

RTC: Axis %2 exceeds the max. permissible end positions

Cause of error

The real-time coupling function (RTC) causes a violation of the maximum permissible working space.

Error correction

Adjust the setting in CfgRtCoupling/function


Error description 230-0034

Error message

RTC: Axis %2 causes a run-time error

Cause of error

The configured function for Real-Time Coupling (RTC) causes a run-time error (e.g. root(-1)).

Error correction

- Check the function in the machine parameter CfgRTCoupling/function and adapt it if required
- Inform your service agency


Error description 230-0034

Error message

The formula in limitAccSpeedCtrlF is faulty

Cause of error

In the machine parameter "distPerMotorTurnF", you entered a formula that contains invalid characters.

Error correction

Check the input value in the parameter "distPerMotorTurnF" and correct it


Error description 230-0035

Error message

The formula in limitDecSpeedCtrlF is faulty

Cause of error

In the machine parameter "limitDecSpeedCtrlF", you entered a formula that contains invalid characters.

Error correction

Check the input value in the parameter "limitDecSpeedCtrlF" and correct it


Error description 230-0036

Error message

Voltage drop on controller unit

Cause of error

The power supplies on a device in the HSCI line are outside of the specified range.
The HSCI bus diagnosis indicates which HSCI component triggered the error. Possible devices:
- MC main computer
- PL inputs/outputs
- MB machine operating panel
- Other CC in the HSCI line
Possible causes:
- Insufficient power supply to the devices
- Short circuit in the power supply
- Short circuit in PL inputs and outputs

Error correction

- Check the supply voltage in the connected devices
Check the wiring for possible short circuits (e.g. PLC inputs or outputs).
- If required, exchange the defective hardware
- Inform your service agency


Error description 230-0037

Error message

Impermissibly large position nominal value in axis %2

Cause of error

- Internal software error
- Faulty nominal value jump detected

Error correction

- Save the service files
- Inform your service agency


Error description 230-003A

Error message

Measuring cycle started without a touch probe

Cause of error

- Touch probe cycle started for measurement without inserted touch probe

Error correction

- Check the NC program
- Insert the touch probe
- Inform your service agency


Error description 230-003B

Error message

Parameter checking: %2 warnings issued

Cause of error

- Current configuration of the machine has discrepancies

Error correction

- Check the inspection results in PLC:\service\ParamCheck.txt
- Correct any discrepancies
- Inform your service agency


Error description 230-003D

Error message

Two-fold positioning was requested for axis %2

Cause of error

- Double positioning started for an axis
- The axis is to be moved both by the PLC as well as the NC

Error correction

- Check the PLC program and correct it if necessary
- Inform your service agency


Error description 230-003E

Error message

Disturbance of handwheel for %2 (handwheel on encoder connection)

Cause of error

The amplitude of the encoder signal is too small or the signal for contamination is active.
- Encoder contaminated
- Encoder defective
- Penetration of humidity
- Scanning head misaligned (distance, parallelism, etc.)
- Encoder cabling defective
- Encoder input defective on the control
- Vibration
- Interfering signals

Error correction

- Inform your service agency


Error description 230-003F

Error message

Position encoder input reserved by FS (axis %2)

Cause of error

In systems with functional safety, the speed and position encoder inputs are always permanently assigned to a single axis.
This means in a single-encoder system (speed encoder only) it is not possible for example to use the vacant position encoder input for another drive or a display axis.

Error correction

- Check the configuration and change it if necessary
- Inform your service agency.


Error description 230-0040

Error message

Position encoder input reserved

Cause of error

In systems with functional safety, the speed and position encoder inputs are always permanently assigned to a single axis.
This means in a single-encoder system it is not possible for example to use the vacant position encoder input for another drive or a handwheel.

Error correction

- Check the configuration and change it if necessary
- Inform your service agency.


Error description 230-0041

Error message

IPO cycle time has exceeded the permissible threshold (%2 µs)

Cause of error

- Internal error: Cycle time of the controller interrupt is too large.

Error correction

- Make a service file
- Inform your service agency


Error description 230-0042

Error message

The touch probe monitor is deactivated for %2 seconds

Cause of error

The probe monitoring has been deactivated by the operator for a certain time

Error correction

Retract the touch probe and/or remove it from the working space


Error description 230-0043

Error message

Error in reference point acquisition in axis %2

Cause of error

An error occurred during determination of the EnDat switch-on position

Error correction

Inform your service agency


Error description 230-0044

Error message

Error in axis simulation

Cause of error

Incorrect call of the controller unit during the simulation.

Error correction

Inform your service agency.


Error description 230-0045

Error message

Error in CfgAnalogSync (key = %2)

Cause of error

No function was configured in an element.

Error correction

- Check the configuration and correct it if necessary
- Inform your service agency.


Error description 230-0046

Error message

Error in CfgAnalogSync

Cause of error

No free list element was found.

Error correction

- Check the configuration and correct it if necessary
- Inform your service agency.


Error description 230-0048

Error message

The axis (%2) cannot be traversed additionally

Cause of error

Due to the active kinematics model, this axis cannot be traversed additionally.
Possible causes:
- Basic rotation activated
- TCPM activated
- Machine with oblique axis

Error correction

Deactivate basic rotation
Deactivate TCPM


Error description 230-0049

Error message

Timeout during job acknowledgment

Cause of error

The module that assigned commands to the CC (UVR commands) can't be reached.

Error correction

Inform your service agency


Error description 230-004A

Error message

Could not send message to PLC

Cause of error

An acknowledgment message could not be sent to the PLC.
The incoming queue of the PLC is full.

Error correction

Inform your service agency


Error description 230-004D

Error message

Encoder increments faulty, %2 measured, %3 set

Cause of error

A check revealed a deviation between the set and measured increments per revolution of the position encoder.

Error correction

- Check the configuration data of the position encoder, and correct them if required
- Check the position encoder being used


Error description 230-0064

Error message

Axis %2 in channel %3 not yet configured

Cause of error

An axis unknown to the system is to be moved

Error correction

Check the NC program, and if required, configure the axes.


Error description 230-0065

Error message

Grinding function not available

Cause of error

Grinding function was not enabled.

Error correction

Check the NC program. If necesary, configure the grinding axes.


Error description 230-0066

Error message

Internal error in grinding functions

Cause of error

Internal error in the grinding generators for swinging and infeed

Error correction

Inform your service agency


Error description 230-0067

Error message

Grinding command not allowed in this state

Cause of error

Command not permitted in current state of the grinding generators

Error correction

- Check sequence of grinding commands.
- Inform your service agency if necessary.


Error description 230-006C

Error message

Stylus deflected in %2 outside of the probing process

Cause of error

The touch probe was triggered although the measuring procedure had not yet begun.

Error correction

Check the NC program or working space.


Error description 230-006D

Error message

In %2 no axis polynomial available during movement

Cause of error

Timing problem in the coordination of interpolator and LookAhead.

Error correction

Inform your service agency.


Error description 230-006E

Error message

%2 Parameter CfgLiftOff off

Cause of error

In the parameter NcChannel->????->CfgLiftOff->on, the lift-off is switched off with NC stop although it should be activated in the NC program. "????" stands for the current channel name.

Error correction

Check the NC program or activate CfgLiftOff


Error description 230-006F

Error message

%2 Distance CfgLiftOff != Parameter

Cause of error

The lift-off height in the NC program is greater than that entered in the parameter NcChannel->????->CfgLiftOff->distance. "????" stands for the current channel name.

Error correction

Change the lift-off distance in the NC program.


Error description 230-0070

Error message

Too many axes to be interpolated

Cause of error

The maximum allowed number of simultaneously moving axes was exceeded.
(In the export version the maximum is 4 axes.)

Error correction

Check the NC program


Error description 230-0071

Error message

Spindle is not yet referenced

Cause of error

An spindle without reference is supposed to be positioned.

Error correction

- Check the NC program
- Home the spindle


Error description 230-0072

Error message

Too many labels in channel %2 during channel synchronization

Cause of error

Too many labels assigned during channel synchronization.

Error correction

- Check the NC program


Error description 230-0073

Error message

Error in synchronization on coordinates in channel %2

Cause of error

A channel that is supposed to be waited for before starting channel synchronization has already traversed the next synchronization mark; i.e. the synchronization is faulty.

Error correction

- Check the NC program


Error description 230-0074

Error message

Thread with incorrect spindle

Cause of error

You tried to drill/cut threads with a spindle that does not at present belong to this channel.

Error correction

- Check the NC program


Error description 230-0075

Error message

This function is permitted only for modulo axes (axis %2)

Cause of error

An axis was being placed in modulo limits although it was not defined as a modulo axis in the machine configuration. Only a modulo axis can be placed in modulo limits.

Error correction

- Check the NC program
- Check the machine parameter CfgAxis->isModulo and correct it if required.


Error description 230-0076

Error message

No axes-movement allowed in channel %2

Cause of error

The NC program was not started with the the NC Start key, so no axis movements are allowed.
Or, one or more unreferenced axes are to be moved in one cycle.

Error correction

- Check the NC program
- Move the axes over the reference marks


Error description 230-0077

Error message

Illegal jump in the path profiles of an axis

Cause of error

The actual position of an axis does not agree with the nominal value calculated from the geometry.

Error correction

- Inform your service agency


Error description 230-0078

Error message

Spindle synchronization is not possible!

Cause of error

The programmed starting length for synchronizing the spindle is insufficient.

Error correction

- Increase the starting length or reduce the spindle speed.


Error description 230-0079

Error message

Spindle not synchronized at beginning/end of the thread!

Cause of error

The programmed starting length/overtravel length for synchronizing and desynchronizing the spindle is insufficient.
As a result, the thread at the start/end does not have the programmed pitch!

Error correction

- Increase the starting length/overtravel length, or reduce the spindle speed.


Error description 230-007A

Error message

One or more axes do not reach the control window in channel %2

Cause of error

At program start and during an exact stop, all axes must be in the control window.One or more axes of this channel has not fulfilled this condition.

Error correction

Check the configuration data CfgControllerTol->posTolerance and CfgControllerTol->timePosOK. Adapt the configuration data to the conditions of the machine.


Error description 230-007B

Error message

One or more axes in channel %2 will be assigned by the PLC

Cause of error

For NC stop, the PLC must cancel all PLC positioning of this channel's axes. It has up to 10 seconds for this task. This time was exceeded.

Error correction

Check the PLC program


Error description 230-007C

Error message

IPO internal Breakpoint reached

Cause of error


Error description 230-007D

Error message

Thread cutting canceled with NC stop

Cause of error

The NC stop button was pressed in channel %2 during thread cutting

Error correction

Restart NC program


Error description 230-007E

Error message

Axis %2 in channel %3 has no reference

Cause of error

One axis of the active kinematic configuration has no reference.

Error correction

Reference the axis and restart the NC program.


Error description 230-007F

Error message

Retraction from thread completed

Cause of error

The retraction from the thread has been concluded.

Error correction

NC program cannot be continued. If required, restart the program.


Error description 230-0080

Error message

Auxiliary axes are not permitted in an NC channel

Cause of error

Free auxiliary axes (e.g. from a UMC 11x), are supposed be adopted in the kinematics of an NC channel. This is not allowed.

Error correction

Check the machine configuration and correct it if required.


Error description 230-0081

Error message

Finding the field angle

Cause of error


Error description 230-0082

Error message

Touch probe cannot be switched off

Cause of error

The control tried to switch off the touch probe but it did not react within a specified time.

Error correction

- Check the signal.
– Check the transmitter/receiver and cleaned it if necessary.


Error description 230-0083

Error message

“MoveAfterRef” is not possible with active protection zone

Cause of error

- A protection zone was defined for a modulo axis.
- A configured movement is not possible after the reference run.

Error correction

- Check the axis position
- After the reference run, delete the movement in the configuration
- Inform your service agency


Error description 230-0084

Error message

Dual-head evaluation not permitted in the export software (%2)

Cause of error

- The dual-head evaluation function requires an export license.
- The parameter MP_posEncoderTwoHead may not be set in the export software.

Error correction

- Check and correct the configuration.
- Inform your service agency.


Error description 230-00C7

Error message

Coupling for inactive axes not possible (axis %2)

Cause of error

A coupling for a deactivated axis was supposed to be closed. This is not possible.

Error correction

Check the PLC program or configuration.
Inform your service agency.


Error description 230-00C8

Error message

No configuration available for axis %2

Cause of error

There is no configuration available for the desired axis coupling.

Error correction

A desired coupling (position coupling or torque coupling) for the respective slave axis must be entered under CfgAxisCoupling.


Error description 230-00C9

Error message

Axis %2 is already a master axis

Cause of error

For the desired axis coupling, the slave axis is already a master axis.

Error correction

Couplings can be commanded only for axes that are not the master or slave axis of an already existing coupling.


Error description 230-00CA

Error message

Axis %2 is already a slave axis

Cause of error

For the desired axis coupling, the slave axis is already a slave axis.

Error correction

Couplings can be commanded only for axes that are not the master or slave axis of an already existing coupling.


Error description 230-00CB

Error message

No coupling active (axis %2)

Cause of error

An attempt was made to open an axis coupling that is already active.

Error correction

Only active couplings can be opened.


Error description 230-00CC

Error message

Coupling is modulo / non-modulo axes not allowed (axis %2)

Cause of error

Differently configured axes were supposed to be coupled.

Error correction

For axis coupling, either both or neither of the axes (master and slave) have to be modulo axes.


Error description 230-00CD

Error message

Opening an axis coupling only allowed for slave axis (axis %2)

Cause of error

An axis coupling was supposed to be opened. The command for opening must be sent to the slave axis.

Error correction

Check the PLC or NC program


Error description 230-00CE

Error message

Maximum position difference exceeded (axis %2)

Cause of error

The position difference configured in parameter CfgAxisCoupling->maxPosDiff was exceeded.

Error correction

Check the machine or parameters.


Error description 230-00CF

Error message

Maximum position difference exceeded (axis %2)

Cause of error

The position difference configured in parameter CfgAxisCoupling->ultimatePosDiff was exceeded.
This error is not deletable because it is a mechanical defect.

Error correction

Check the mechanical configuration or parameters.


Error description 230-00D0

Error message

Slave does not reach coupling position. (axis %2)

Cause of error

During coupling the slave axis crossed over its own software limit switch.

Error correction

Check the position of the axes (master and slave) and the parameters.


Error description 230-00D1

Error message

Option for gantry axes not enabled

Cause of error

A gantry axis (synchronized axes with position coupling) was configured and activated, but the required software option was not yet enabled.

Error correction

- Check the parameter object CfgAxisCoupling
- Enable the software option


Error description 230-00D2

Error message

Coupling factor not equal to +1 or -1 is not allowed

Cause of error

For modulo axes, only coupling factors of +1 or -1 are allowed for a gantry coupling.

Error correction

Check the parameter object CfgAxisCoupling or the PLC program


Error description 230-00D3

Error message

Option for spindle synchronism not enabled

Cause of error

A spindle synchronization was commanded, but the required software option was not enabled.

Error correction

Enable the software option


Error description 230-00D4

Error message

During active synchronism, a spindle cannot be used as an axis

Cause of error

During active synchronism, a spindle is to be used as an interpolating axis

Error correction

- Check the NC or PLC program and adapt it if necessary
- Inform your service agency


Error description 230-00D5

Error message

Kinematics axis not possible as slave axis. (axis %2)

Cause of error

An axis that is in the kinematics cannot be used as a slave axis of a gantry system.

Error correction

- Check the axis configuration.
- Check the kinematics configuration.
- Inform your service agency.


Error description 230-00FA

Error message

Limit switch %2 +

Cause of error

The calculated tool path exceeds the machine's positive traverse limits.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.


Error description 230-00FB

Error message

Limit switch %2 -

Cause of error

The calculated tool path exceeds the machine's traverse limits.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.


Error description 230-00FC

Error message

Limit switch %1 -

Cause of error

The calculated tool path exceeds the machine's traverse limits.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.


Error description 230-00FD

Error message

Limit switch %1 +

Cause of error

The calculated tool path exceeds the machine's positive traverse limits.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.


Error description 230-00FE

Error message

Pos. SW limit switch is smaller than neg. SW limit switch (%1)

Cause of error

The value of the positive SW limit switch is smaller than the value of the negative SW limit switch

Error correction

Check the parameter Axes->ParameterSets->????->CfgPositionLimits->...
”????” stands for the current parameter block name


Error description 230-00FF

Error message

The PLC variable %1 has reached the maximum value of %2 mm

Cause of error

The variable concerned goes into the calculation of the kinematic compensation and has exceeded the maximum permissible value.
The variable will be set to the maximum value. The warning will be deleted as soon as the variable has fallen below the maximum value by 0.1 mm.

Error correction

- Check the calculation for the variable's value
- Inform your machine tool builder


Error description 230-0100

Error message

%1 axis has reached the max. axis-error compensation of %2 mm

Cause of error

The calculated axis-error compensation has exceeded the max. permissible value for the axis.
The compensation is set to the maximum value. The warning is deleted as soon as the axis compensation has fallen below the maximum value by 0.1 mm.

Error correction

- Check the parameters for axis error compensation.
- Check the values in the axis-error compensation table.


Error description 230-0104

Error message

In %2, the load limit 1 of %3 was exceeded

Cause of error

During load monitoring the warning threshold for power was exceeded.

Error correction

- Reduce feed rate of machining
- If necessary, run a reference search to reestablish the power limits


Error description 230-0105

Error message

In %2, the load limit 2 was exceeded by %3

Cause of error

During load monitoring (power) the threshold for program cancelation was exceeded.

Error correction

- Reduce feed rate of machining
- If necessary, run a reference search to reestablish the power limits


Error description 230-0106

Error message

In %2 the total load limit of %3 was exceeded

Cause of error

During load monitoring the warning threshold for the total load was exceeded.

Error correction

- Reduce feed rate of machining
- If necessary, run a reference search to reestablish the power limits


Error description 230-0109

Error message

Error in the real-time coupling function (RTC) of axis %2

Cause of error

Real-time coupling function (RTC) is supposed to be opened, but no coupling function is active.

Error correction

- Check the NC program and correct if necessary
- Inform your machine tool builder


Error description 230-010A

Error message

Error in the real-time coupling function (RTC) of axis %2

Cause of error

Real-time coupling (RTC) is supposed to be closed, but coupling function is already active.

Error correction

- Check the NC program and correct if necessary
- Inform your machine tool builder


Error description 230-010B

Error message

Error in the real-time coupling function (RTC) of axis %2

Cause of error

No valid command for closing or opening the coupling was given for the real-time coupling function.

Error correction

- Check the NC program and correct if necessary
- Inform your machine tool builder


Error description 230-010C

Error message

Error in the real-time coupling function (RTC) of axis %2

Cause of error

The PLC program tried to open a coupling function activated by the NC, or die NC tried to open a coupling function activated by the PLC.

Error correction

- Check the NC program and correct if necessary
- Inform your machine tool builder


Error description 230-010D

Error message

Error in the real-time coupling function (RTC) of axis %2

Cause of error

An error occurred during compilation of the function (see INTERNAL INFO soft key).

Error correction

- Check the real-time coupling function (RTC) to be activated
- Inform your service agency


Error description 230-010E

Error message

Error in the real-time coupling function (RTC) of axis %2

Cause of error

No function was entered in the configuration for closing a real-time coupling function (RTC).

Error correction

- Check the function under CfgRtCoupling/function and adjust if necessary
- Inform your machine tool builder


Error description 230-010F

Error message

Error in the real-time coupling function (RTC) of axis %2

Cause of error

The active real-time coupling function (RTC) has caused a run-time error. (E.g. sqrt(-1) )

Error correction

- Check the active function in the machine configuration (CfgRtCoupling/function)
- Inform your machine tool builder


Error description 230-0110

Error message

Option for coupling functions not enabled

Cause of error

A coupling was commanded, but the required software option was not enabled.

Error correction

- Enable option #135 (synchronizing functions)


Error description 230-0111

Error message

Error in the real-time coupling function (RTC) of axis %2

Cause of error

The function entered for closing a real-time coupling function (RTC) was too long.

Error correction

- Check the function under CfgRtCoupling/function and adjust if necessary
- If the formula was presented by the PLC, check the PLC program
- Inform your machine tool builder


Error description 230-0112

Error message

RTC coupling programmed with active DCM. Deactivate DCM?

Cause of error

During active DCM collision monitoring you started a real-time coupling function (RTC).
Caution: DCM must be deactivated!

Error correction

Press NC start to confirm deactivation of DCM and continue editing the program


Error description 230-0113

Error message

RTC coupling programmed with active DCM

Cause of error

During active DCM collision monitoring you started a real-time coupling function (RTC).
The NC program run was aborted.

Error correction

Adapt the NC program:
Deactivate DCM if the real-time coupling function (RTC) is switched on by a cycle.


Error description 230-0115

Error message

Formula is erroneous

Cause of error

Faulty formula in the entity RTCanalog.

Error correction

- Check the configuration and change it if necessary
- Inform your service agency


Error description 230-0116

Error message

Extended limit switch monitoring %2 +

Cause of error

A compensation movement traverses the extended positive limit switch

Error correction

- Check compensations
- Inform your service agency


Error description 230-0117

Error message

Extended limit switch monitoring %2 -

Cause of error

A compensation movement traverses the extended negative limit switch

Error correction

- Check compensations
- Inform your service agency


Error description 230-011A

Error message

Run-time error in the formula calculation of offsetForM19

Cause of error

The active formula for offsetForM19 caused a run-time error, such as sqrt(-1).

Error correction

Check the active function in the machine configuration (CfgSpindle/offsetForM19)


Error description 230-011B

Error message

Formula in offsetForM19 invalid

Cause of error

In the machine parameter "offsetForM19", you entered a formula that contains invalid characters.

Error correction

Check the input value in the parameter "offsetForM19" and correct it


Error description 230-015E

Error message

Error in initialization of touch probe

Cause of error

3-D touch probe: Actual position capture was refused by the CC with an error message.

Error correction

- Inform your service agency


Error description 230-0190

Error message

Excessive servo lag in %2

Cause of error

The following error of a moving axis is greater than the value specified in the configuration datum Axes > ParameterSets > ???? > CfgPosControl > servoLagMin1 / servoLagMax1.
"????" designates the name of the affected parameter set.

Error correction

- Reduce the contouring feed rate, increase the rotational speed.
- Remove any possible sources of vibration.
- Inform your service agency if the error occurs frequently.


Error description 230-0192

Error message

Excessive servo lag in %2

Cause of error

The following error of a moving axis is greater than the value specified in the configuration datum Axes > ParameterSets > ???? > CfgPosControl > servoLagMin2 / servoLagMax2.
"????" designates the name of the affected parameter set.

Error correction

- Reduce the contouring feed rate, increase the rotational speed.
- Remove any possible sources of vibration.
- Inform your service agency if the error occurs frequently.


Error description 230-0193

Error message

Position encoder %2: Amplitude too small

Cause of error

The amplitude of the position encoder signal is too low or the signal for contamination is active.

Error correction

Check the amplitude of the position encoder signal.


Error description 230-0194

Error message

Position encoder %2: Frequency too high

Cause of error

The maximum input frequency was exceeded at a position encoder input.

Error correction

Check the input frequency of the position encoder signal.


Error description 230-0195

Error message

Error in zero pulse distance of encoder %2

Cause of error

Encoder defective

Error correction

Exchange the encoder.


Error description 230-0196

Error message

Position encoder %2 defective

Cause of error

Contradiction apparent from comparison of the absolute and incremental positions.

Error correction

Inform your service agency.


Error description 230-0197

Error message

Error in zero pulse distance of encoder %2

Cause of error

Contradiction in comparison of the absolute and incremental position.

Error correction

Inform your service agency.


Error description 230-0198

Error message

Nominal speed value too high %2

Cause of error

An excessively high nominal speed value was calculated.
Analog axes: Maximum nominal value +-10 V
Analog spindle: Maximum nominal value +-10 V
Digital axes and spindle: Maximum nominal value = maximum motor speed
- The machine does not reach the set acceleration and braking ramps
- Hardware error in the control loop

Error correction

- Analog axes: Check the servo
- Inform your service agency


Error description 230-0199

Error message

Movement monitoring error in %2

Cause of error

Movement monitoring: Nominal rpm=0, actual rpm=0, feed value>0 ==> Axis physically blocked or position comparison of motor encoder does not equal external position encoder.

Error correction

Check the parameter Axes->ParameterSets->????->CfgEncoderMonitor->movementThreshold.
"????" designates the present parameter set name.
- Inform your service agency


Error description 230-019A

Error message

Standstill monitoring err. in %2

Cause of error

The position error at standstill is greater than the parameter Axes->ParameterSets->????->CfgControllerAuxil->checkPosStandstill defined in the configuration datum.
"????" designates the present configuration set name.

Error correction

Inform your service agency.


Error description 230-019B

Error message

%2 does not attain the control window

Cause of error

The configuration datum Axes->ParameterSets->????->CfgControllerTol->posTolerance is defined too low.
"????" designates the current parameter set name

Error correction

Increase the value


Error description 230-019C

Error message

Following error in switched-off axis (%2) is too large

Cause of error

Disconnected axis was moved.

Error correction

When an axis is switched off, it must be locked.
Or
Switch off the parameter Axes->ParameterSets->????->CfgControllerAuxil->driveOffLagMonitor.
"????" stands for the current parameter block name.


Error description 230-019D

Error message

Probe system not ready

Cause of error

- Touch probe is not connected.
- Battery in touch probe is dead.
- No connection between infrared probe system and receiver unit.

Error correction

- Connect the touch probe.
- Exchange the battery.
- Clean the receiver unit.
To be able to exchange the defective touch probe:
1. In the Manual operating mode, press the "touch probe
monitoring" soft key.
2. Delete the error message.
3. Call another tool.
Note: The touch probe monitoring is inactive until the next
tool call or measuring operation. This means that the NC
will not detect a collision with the touch probe!


Error description 230-019E

Error message

Exchange touch probe battery

Cause of error

The battery in the touch probe is dead.

Error correction

Use a fresh battery.


Error description 230-019F

Error message

CC index for %1 too large

Cause of error

In the hardware equipment of this control, there are fewer speed controller processors than were configured for this axis.

Error correction

Check the parameters in the Axes->ParameterSets->????->CfgAxisHardware entity.
"????" stands for the current parameter block name.


Error description 230-01A0

Error message

Axis index on CC too large

Cause of error

The axis index on the CC is specified by the parameter selEncoderIn, but the CC has fewer axes than were configured.

Error correction

Distribute the axes into two or more CCs (if available).


Error description 230-01A1

Error message

Input for position encoder (%1) not found

Cause of error

The input of the position encoder in the indicated axis is configured incorrectly.

Error correction

Check the configuration of the axis:
- CfgAxisHardware/posEncoderInput


Error description 230-01A2

Error message

EnDat encoder (%2) reports error

Cause of error

Connected EnDat encoder or encoder cable is defective

Error correction

Check the EnDat encoder or encoder cable


Error description 230-01A3

Error message

Absolute actual position of the axis (%2) not confirmed

Cause of error

Current EnDat position will not be transferred (user input)

Error correction

Check the EnDat encoder or encoder cable, exchange encoder if necessary


Error description 230-01A4

Error message

EnDat encoder (%2) reports different resolution

Cause of error

The resolution reported by the connected EnDat encoder does not match the resolution defined in the configuration data

Error correction

Check the configuration data of the encoder


Error description 230-01A5

Error message

EnDat encoder (%2) reports wrong position

Cause of error

Connected EnDat encoder or encoder cable is defective

Error correction

Check the EnDat encoder or the encoder cable


Error description 230-01A6

Error message

%2 does not attain the programmed speed

Cause of error

The configuration datum Axes->ParameterSets->????->CfgControllerTol->speedTolerance is defined too low.
"????" designates the current name of the configuration set.

Error correction

Increase the value


Error description 230-01AB

Error message

Drive to be moved (%2) is not switched on.

Cause of error

A drive that is supposed to be moved from an NC program or by PLC positioning is not switched on.

Error correction

Check the PLC program


Error description 230-01AC

Error message

Drive to be moved (%2) is not in the position loop

Cause of error

Nominal position values are being generated from an NC program or by a PLC positioning command for a drive that is not in the position loop.

Error correction

Check the PLC program.


Error description 230-01AD

Error message

Deviation in the switch-on position of axis %2 too large

Cause of error

The switch-on position of this axis deviates more than allowed from the position last saved (CfgReferencing->endatDiff).

Error correction

Check the current position. If required, increase the parameter values.


Error description 230-01AE

Error message

Hardware description for axis %2 has changed
Position might not be valid

Cause of error

Hardware description parameters of this axis have been changed. Saved positions are invalid.

Error correction

Check the current position.


Error description 230-01AF

Error message

Error in encoder configuration of axis %1

Cause of error

Incorrect encoder configuration of the axis.

Error correction

The encoder configuration does not fit the hardware.
Refer to the Technical Manual.


Error description 230-01B0

Error message

Error in spindle positioning (%2)

Cause of error

A spindle positioning movement could not be ended properly.

Error correction

The configuration datum Axes/ParameterSets/[key of the axis]/CfgFeedLimits/m19MaxSpeed is defined too low.


Error description 230-01B1

Error message

MC software does not match CC software

Cause of error

Incorrect combination of CC and MC software.

Error correction

Inform your service agency


Error description 230-01B2

Error message

Configuration of digital axes not possible without CC

Cause of error

Without CC only analog axes can be configured.

Error correction

Inform your service agency or change the configuration.


Error description 230-01B3

Error message

S-RAM contents of axis %2 are invalid.

Cause of error

The axis position values saved in S-RAM are invalid.

Error correction

Check the current position


Error description 230-01B4

Error message

Maximum traverse range of EnDat axis was exceeded.

Cause of error

The axis must be readjusted.

Error correction

Redetermine the parameter CfgReferencing->refPosition


Error description 230-01B5

Error message

The maximum traverse range of the EnDat axis was exceeded while it was switched off

Cause of error

Check the position of the axis.

Error correction

If necessary, reenter the parameter CfgReferencing->refPosition


Error description 230-01B6

Error message

%2 synchronous window not reached

Cause of error

The configuration datum Axes->ParameterSets->????->CfgControllerTol->syncTolerance is defined too low.
"????" designates the current name of the configuration set.

Error correction

Increase the value


Error description 230-01B7

Error message

The encoder of an axis in the position control loop must not be switched (%2).

Cause of error

Before a position encoder can be switched, the drive concerned must be switched off by the PLC.

Error correction

Check the NC program, check the PLC program.


Error description 230-01B8

Error message

Two encoders with EnDat interface cannot be used for one axis (%2).

Cause of error

If an EnDat encoder is configured for an axis, the encoder must be entered in parameter block index 0.
No more than one EnDat encoder is allowed per axis.

Error correction

- Change the configuration (sequence of parameter blocks).
- Change the hardware configuration (encoders).


Error description 230-01B9

Error message

Input X%2 for axis %3 is already assigned to another axis.

Cause of error

The CfgAxes->ParamSet->..->posEncoderInput parameter refers to an input that is already occupied by another axis.

Error correction

- Check the encoder inputs.
- If an axis does not have a position encoder, enter the value "none."


Error description 230-01BA

Error message

Input X%2 for axis %3 is already assigned to another axis.

Cause of error

The CfgAxes->ParamSet->..->speedEncoderInput parameter refers to an input that is already occupied by another axis.

Error correction

- Check the encoder inputs.
- If an axis does not have a speed encoder, enter the value "none."


Error description 230-01BB

Error message

Input X%2 for axis %3 is already assigned to another axis.

Cause of error

The CfgAxes->ParamSet->..->pwmSignalOutput parameter refers to an output that is already occupied by another axis.

Error correction

- Check the wiring.
- If an axis does not have a PWM output, enter the value "none."


Error description 230-01BC

Error message

Error during control of an SPI module

Cause of error

An error occurred during transfer of rotary encoder data to or from an SPI module (module %2)

Error correction

- Check the wiring
- Inform your service agency


Error description 230-01BD

Error message

Spindle (%2) has no position encoder

Cause of error

A selected function (spindle positioning, synchronism, thread, etc.) requires a position encoder of the spindle concerned, but no such encoder has been configured.

Error correction

Check the NC program


Error description 230-01BE

Error message

AxisMode and AxisHw for axis (%2) do not match

Cause of error

An illegal combination of
Axes->PhysicalAxes->CfgAxis->axisMode and
Axes->PhysicalAxes->CfgAxis->axisHw has been configured.
Permissible combinations include:
- AxisMode = NotActive =>
axisHw = everything allowed
- AxisMode = Active =>
axisHw = InOutCC
axisHw = AnalogMC
axisHw = AnalogCC
axisHw = DisplayMC
axisHw = DisplayCC
axisHw = ManualMC
axisHw = ManualCC
- AxisMode = Virtual =>
axisHw = None

Error correction

Check the configuration.


Error description 230-01BF

Error message

Encoder type not permitted for axis (%2)

Cause of error

An impermissible combination of
Axes->PhysicalAxes->CfgAxis->axisHw and
Axes->ParameterSets->CfgAxisHardware->posEncoderType is configured.
Permissible combinations are:
axisHw = InOutCC
CC422 - Motor encoder and all position encoders connected to MC
CC424 - Motor encoder and all position encoders connected to CC
CC520 - Motor encoder and all position encoders connected to CC
axisHw = AnalogMC
All position encoders connected to MC
axisHw = AnalogCC
All position encoders connected to CC
axisHw = DisplayMC
All position encoders connected to MC
axisHw = DisplayCC
All position encoders connected to CC
axisHw = ManualMC
All position encoders connected to MC
axisHw = ManualCC
All position encoders connected to CC
axisHw = ProfiNet
Motor encoder and all position encoders connected to ProfiNet

Error correction

Check the configuration


Error description 230-01C0

Error message

Analog output of axis %2 was assigned twice

Cause of error

More than one axis is trying to write to an analog output at one time.

Error correction

Check the PLC program.
If more than one axis uses the same analog output, only one at a time can be switched on.


Error description 230-01C1

Error message

Unknown touch probe model designation

Cause of error

An unknown touch probe model designation was selected in the touch probe table.

Error correction

Check the touch probe table.


Error description 230-01C2

Error message

Spindle (%2) has not yet been homed

Cause of error

A command has been given for a synchronous spindle run. However, not all spindles have been homed. The synchronous spindle run can be switched off only if all involved spindles have been referenced.

Error correction

— Home the spindle
- Check the NC or PLC program


Error description 230-01C3

Error message

EMERGENCY STOP defective (%2)

Cause of error

The internal or external EMERGENCY STOP circuit is defective.
- Excessively long switching times of the involved relays in the chain between the control-is-ready output signal (MC.RDY, STO.A.G) and the control-is-ready acknowledgment (I3, ES.A, ES.B) during the EMERGENCY STOP or switch-on routine
- Control-is-ready acknowledgement (I3, ES.A, ES.B) has a short circuit to +24 V

Error correction

Check the emergency-stop circuit:
- Check / replace the applicable relays in the electrical cabinet
- Check / restore the contacts / wiring
- Inform your service agency


Error description 230-01C4

Error message

Relay ext. dc voltage missing

Cause of error

Error message after power interruption.

Error correction

- Switch on the control voltage separately
- Check the wiring in the electrical cabinet
- Check the 'Machine control voltage ON' button


Error description 230-01C5

Error message

After SW download, CC no longer responds

Cause of error

After a download of the controller software, an existing CC no longer answers.

Error correction

CC defective. Exchange the hardware.


Error description 230-01C6

Error message

The option for double-speed control loops has not been enabled

Cause of error

A double-speed control loop was configured, but the option was not enabled.
Single-speed controller performance was activated for the control loop.

Error correction

Check the parameter CfgAxisHardware->ctrlPerformance.


Error description 230-01C7

Error message

Communication between MC and CC is faulty

Cause of error

An error occurred in the HSCI communication between the MC computer unit and the CC controller unit.

Error correction

Inform your service agency


Error description 230-01C8

Error message

Timeout during command processing by the CC

Cause of error

A CC was given commands and has not acknowledged them.

Error correction

- Note further messages
- Correct the configuration error
- If this error occurs without configuration errors:
The CC controller unit might be defective. Replace the hardware.


Error description 230-01C9

Error message

Option for master-slave torque control not enabled

Cause of error

You have configured a master-slave torque control, but you have not enabled the required software option.

Error correction

- Check the parameter CfgAxisCoupling
- Enable the software option


Error description 230-01CA

Error message

Switch off after NC stop due to error %2

Cause of error

The machine was switched off after NC stop.
Reason: CC error

Error correction

Note the information on remedies while the CC error is displayed.


Error description 230-01CB

Error message

Output of axis %2 was assigned twice

Cause of error

More than one axis is trying to write to an output at one time.

Error correction

- Check the PLC program
If more than one axis uses the same output, only one at a time can be switched on.


Error description 230-01CC

Error message

Input of axis %2 was assigned twice

Cause of error

Two or more axes are trying to read one input at the same time.

Error correction

- Check the PLC program
If more than one axis uses the same input, only one at a time can be switched on.


Error description 230-01CD

Error message

Incorrect connector assignment of the axis %2

Cause of error

On the CC 424 or CC 61xx there is a fixed assignment of speed encoder input to PWM output. The parameters speedEncoderInput and pwmSignalOutput have an illegal connector assignment. Permissible connector assignments:
X15 - X51
X16 - X52
X17 - X53
X18 - X54
X19 - X55
X20 - X56
X80 - X57
X81 - X58
X82 - X59
X83 - X60

Error correction

Check the axis configuration and edit it if required.


Error description 230-01CE

Error message

Machine parameters were changed through TNCOPT

Cause of error


Error description 230-01CF

Error message

Switch off after NC stop due to error %2

Cause of error

The machine was switched off after an NC stop.
Reason: PLC error

Error correction

Note the further information on remedies available when the PLC error is displayed.


Error description 230-01F4

Error message

PLC: timeout

Cause of error

PLC runtime error:
- The processing of the cyclically executed program section takes too long. Check the subprogram structure for very calculation-intensive sections that you can start as SUBMIT jobs.
- The displayed processing time will be increased during data transfer and in handwheel mode. In case of doubt, select handwheel mode and simultaneously start the data transfer at max. baud rate. At the same time, check "MAXIMUM PROCESSING TIME" in the
PLC programming. Values should not exceed 150% (safety reserve in the event of unfavorable operating conditions!).

Error correction

Edit the PLC program.


Error description 230-01F5

Error message

Probe cycle started with stylus already deflected

Cause of error

You tried to start a probing cycle although the stylus is still deflected.

Error correction

Increase the retraction path


Error description 230-01F6

Error message

LookAhead: Time out

Cause of error

Run-time error in LookAhead.

Error correction

Inform your service agency


Error description 230-01F7

Error message

High-speed inputs were incorrectly configured

Cause of error

Only inputs I0 to I31 and I128 to I152 can be used.

Error correction

Check the configuration


Error description 230-0226

Error message

Client with this thread ID is already logged on with CfgServer.

Cause of error

Error correction

Inform your service agency.


Error description 230-0227

Error message

Configuration server not ready

Cause of error

Error correction

Inform your service agency.


Error description 230-0228

Error message

Missing entity (%2) in configuration data

Cause of error

A required parameter is missing in the configuration.

Error correction

Check the configuration.


Error description 230-0229

Error message

Missing entity (%2) in configuration data for axis %3

Cause of error

A required parameter is missing in the configuration.

Error correction

Check the configuration.
If more than one parameter block is assigned to this axis, no other block than block 0 must be complete. However, the extended parameter block key must be entered in configuration date CfgKeySynonym->key and the corresponding basis block key in
configuration date CfgKeySynonym->relatedTo.


Error description 230-022A

Error message

Power module %2 not found in table

Cause of error

The specified power module is not listed in the power module table.

Error correction

- Inform your service agency
- Check the name of the motor and the power module in the table


Error description 230-022B

Error message

Power module table cannot be read

Cause of error

Cannot read or find the power module table.

Error correction

- The SQL server was given a table file with a syntactically incorrect file name.
The file name of the table must begin with a letter, as in M123.D.
Change the table's file name.
- Check the directory of the power module table
- Check the power module table.


Error description 230-022C

Error message

Motor (%2) not found in motor table

Cause of error

The entered motor is not in the motor table.

Error correction

- Check the motor assignment of the axes
- Check the entries in the motor table, especially whether the MODE column has the right value
- Inform your service agency


Error description 230-022D

Error message

Motor table (%2) cannot be read

Cause of error

The specified motor table could not be found or read.
The file name specified for the motor table is syntactically incorrect. For the control's SQL server to read the file, the file name of the table must contain at least one letter at the beginning. Example: MOTOR123.MOT
Observe other displayed messages on the cause of the error.

Error correction

- Correct the file name of the motor table
- Check the directory of the motor table
- Check the motor table
- Check whether the motor table has all required columns
- Inform your service agency


Error description 230-022E

Error message

No connection to the SQL server

Cause of error

No connection to the SQL server

Error correction

Inform your service agency.


Error description 230-022F

Error message

Axis (%2) not found in compensation table

Cause of error

Data of the specified axis could not be found in the compensation table.

Error correction

- Check the compensation table. The specified axis must be available as a column in the compensation table.
- Inform your service agency.


Error description 230-0230

Error message

Syntax error in compensation table (%2)

Cause of error

The data in the specified compensation table could not be read.

Error correction

- Check the configuration table (*.cma)
- Check the compensation table (*.com)
The table can contain up to 1024 compensation points (lines).
The AXISPOS column of the first and last line must show the beginning and end of the compensation range with respect to the machine datum.
The compensation points between them are calculated internally by the control and do not need to be specified.
If you enter optional position values in the AXISPOS column they must have equal spacing.
If required, in the BACKLASH column enter compensation values that are measured in negative traverse direction.
In the column of the associated axis, enter the values belonging to the compensation points.
- Inform your service agency


Error description 230-0231

Error message

Compensation table (%2) cannot be read

Cause of error

Could not find or read the given compensation table.

Error correction

- Check the name and directory of the configuration table saved in the configuration editor through the keyword "TABCMA".
- Check the directory of the compensation table saved in the configuration editor through the keyword "oemTable".
- The tables assigned to the axes in the configuration table must be in the directory of the compensation tables.
- The SQL server was given a table file with a syntactically incorrect file name.
The file name of the table must begin with a letter, as in M123.D.
Change the table's file name.
- Check the configuration table (*.cma)
- Check the compensation table (*.com)
- Inform your service agency


Error description 230-0232

Error message

Parameter block name (%2) for axis (%3) is already assigned

Cause of error

Two or more axes are defined with reference to the same parameter block.

Error correction

Each axis needs its own parameter block name.


Error description 230-0233

Error message

Too many parameter blocks for axis %2

Cause of error

More parameter blocks were requested for an axis than allowed.

Error correction

Make fewer parameter blocks for this axis.


Error description 230-0234

Error message

Shut down the control and restart after you delete an entity

Cause of error

An axis parameter entity was deleted.

Error correction

Restart the control.


Error description 230-0235

Error message

Positioning of axis %2 was stopped due to reconfiguration.

Cause of error

An attempt was made to change a parameter for a moving axis.

Error correction

Axis was stopped.


Error description 230-0236

Error message

Timeout while stopping axis %2

Cause of error

An attempt was made to change a parameter for a moving axis.

Error correction

Axis was stopped.


Error description 230-0237

Error message

A spindle must be configured as a modulo axis (axis %2)

Cause of error

An axis was defined as spindle that was not configured as a modulo axis.
A spindle must always be configured as a modulo axis.

Error correction

Check and, if necessary, correct the parameter CfgAxis->isModulo


Error description 230-0238

Error message

Fatal configuration error: Cycle machining has been stopped

Cause of error

A fatal error in the configuration has prevented normal operation of the control.

Error correction

Check the configuration


Error description 230-0239

Error message

Name (%2) for axis (%3) is invalid

Cause of error

Two or more axes refer to the same axis key, or an invalid key was installed in System->CfgAxes->axisList.

Error correction

The names must be unambiguous and valid for each axis.


Error description 230-023A

Error message

Invalid configuration for axis %2

Cause of error

This error can have several causes:
1. In CfgAxis->axisMode, NotAllowed is configured
2. In CfgAxis->axisMode, Active is configured, but this axis has no parameter block
3. In CfgAxis->axisMode, Virtual is configured, but something other than None is in CfgAxis->axisHw

Error correction

Check the combination of parameters


Error description 230-023B

Error message

Fatal error in interpolator: Cyclic machining has been stopped

Cause of error

A fatal error in the interpolator has prevented normal operation of the control.

Error correction

Inform your service agency.


Error description 230-023C

Error message

Supply module %2 not found in table

Cause of error

The specified supply module is not listed in the supply module table.

Error correction

- Inform your service agency.
- Check the name of the supply module in the table


Error description 230-023D

Error message

Supply-module table cannot be read

Cause of error

Cannot read or find the supply module table.
The control cannot read or find the supply module table.
The file name must begin with a letter.

Error correction

- Check the path of the supply module table under CfgTablePath (SUPPLY or SUPPLY_OEM keys)
- Check the directory of the supply module table
- Check the supply module table and correct the file name if required.


Error description 230-02BC

Error message

No oriented spindle stop of homed spindle

Cause of error

Oriented spindle stop should be performed with a spindle that has not yet been homed.

Error correction

- Check the NC program
- Home the spindle
- The parameter Axis->ParamSets->(Spindle)->CfgReferencing->refType must be set to "without Switch and on the fly" so that the spindle automatically homes.


Error description 230-02BD

Error message

Stylus already in contact

Cause of error

The stylus is already deflected at the start of a probing movement.

Error correction

- Get the touch probe clear and repeat the probe.
- If the error frequently recurs, inspect the probe for damage.
- If necessary, contact your service agency.


Error description 230-02BF

Error message

Handwheel?

Cause of error

- The electronic handwheel is not connected.
- An incorrect handwheel is configured in machine parameter System/CfgHandwheel/type.
- The transmission line is defective was incorrectly chosen.

Error correction

- Connect the handwheel via cable adapter.
- Check the machine parameter System/CfgHandwheel/type.
- Inspect the transmission line for damage


Error description 230-02C0

Error message

Velocity programmed for axis %2 too low

Cause of error

The velocity programmed for this axis for PLC positioning is too slow.

Error correction

Program a faster velocity or check the configuration datum Axes->ParameterSets->????->CfgFeedLimits->minFeed.
"????" designates the current name of the configuration set.


Error description 230-02C1

Error message

Rotational speed programmed for spindle ("%2") too low

Cause of error

The shaft speed programmed for this axis for PLC positioning is too slow.

Error correction

Program a faster shaft speed or check the configuration datum Axes->ParameterSets->????->CfgFeedLimits->minFeed.
"????" designates the current name of the configuration set.


Error description 230-02C2

Error message

Return to contour in thread cycle not allowed.

Cause of error

In a thread cycle, you tried to return in the tilted working plane.

Error correction

In thread cycles, always return only in the tool axis direction.


Error description 230-02EE

Error message

The option for HSC filter has not been enabled

Cause of error

An HSC filter was configured, but the option was not enabled.
Now the triangle filter was activated for this axis.

Error correction

Configure another file type


Error description 230-02EF

Error message

Software option 151 Load Monitoring not enabled

Cause of error

A load monitor (G995, G996) was programmed in the NC program, but the required software option 151 Load Monitoring is not enabled.

Error correction

- Check the NC program and adapt it if necessary
- If required, enable the software option 151 Load Monitoring
- Contact the machine tool builder
- Inform your service agency


Error description 230-02F0

Error message

Option for digital control loops not enabled

Cause of error

A digital control loop was configured without enabling the necessary option in the control’s SIK.

Error correction

- Check the configuration and correct if necessary
- Enable the option
- Inform your machine tool builder


Error description 230-0327

Error message

Plug & Play (%2) Motor detected: %3

Cause of error

The "Plug & Play" function for automatic recognition of drive components through the electronic ID label is active for this axis.
A motor was recognized that differs from the current configuration.

Error correction

- Confirm the "Plug & Play" dialog, if the detected motor belongs to this combination of axis and parameter set
- Deactivate "Plug & Play", if the motor was not correctly recognized
- Contact your machine tool builder


Error description 230-0328

Error message

Plug & Play (%2) Inverter detected: %3

Cause of error

The "Plug & Play" function for automatic recognition of drive components through the electronic ID label is active for this axis.
An inverter was recognized that differs from the current configuration.

Error correction

- Confirm the "Plug & Play" dialog, if the detected inverter belongs to this combination of axis and parameter set
- Deactivate "Plug & Play", if the inverter was not correctly recognized
- Contact your machine tool builder


Error description 230-0329

Error message

Plug & Play (%2) Supply Module detected: %3

Cause of error

The "Plug & Play" function for automatic recognition of drive components through the electronic ID label is active.
An supply module was recognized that differs from the current configuration.

Error correction

- Confirm the "Plug & Play" dialog prompt if the supply module was correctly recognized
- Deactivate "Plug & Play", if the supply module was not correctly recognized and check the configuration
- Contact your machine tool builder


Error description 230-032A

Error message

Axis %1 (%2): Motor %3 detected and registered

Cause of error

The named motor was detected through plug-and-play and entered in the axis configuration under CfgServoMotor->motName.


Error description 230-032B

Error message

Axis %1 (%2): Inverter %3 detected and registered

Cause of error

The named inverter was detected through plug-and-play and entered in the axis configuration under CfgPowerStage->ampName.


Error description 230-032C

Error message

Axis %1 (%2): Supply module %3 detected and registered

Cause of error

The named supply module was detected through plug-and-play and entered in the axis configuration under CfgSupplyModule->name.


Error description 230-032D

Error message

Axis %1 (%2): Plug & play has been deactivated for the motor

Cause of error

Plug-and-play was deactivated in the named axis for the motor.

Error correction

- Check the configuration and the motor being used
- Plug-and-play can be reactivated through CfgServoMotor->plugAndPlay


Error description 230-032E

Error message

Axis %1 (%2): Plug & play has been deactivated for the inverter

Cause of error

Plug-and-play was deactivated in the named axis for the inverter.

Error correction

- Check the configuration and the inverter being used
- Plug-and-play can be reactivated through CfgPowerStage->plugAndPlay


Error description 230-032F

Error message

Axis %1 (%2): Plug & play has been deactivated for supply module

Cause of error

Plug-and-play was deactivated in the named axis for the supply module.

Error correction

- Check the configuration and the supply module being used
- Plug-and-play can be reactivated through CfgSupplyModule->plugAndPlay


Error description 230-0353

Error message

The current monitoring section will not be recorded.

Cause of error

NC program has been altered incompatibly.

Error correction

Delete all recordings of the NC program.


Error description 230-041A

Error message

Position error (axis %2) too large

Cause of error

The difference between position measurements by the position encoder and speed encoder is too large.

Error correction

Check the position and speed encoders.


Error description 230-041B

Error message

Axis %2 cannot be switched on

Cause of error

This axis is to be switched on by the PLC, although it was switched off by DriveOffGroup.

Error correction

Check the PLC program.


Error description 230-041C

Error message

Error bit in safety status (S status) of the HSCI transmission

Cause of error

An error was signaled over the HSCI S status.

Error correction

- Inform your service agency.
- You can find more diagnostic information in the diagnostics menu.


Error description 230-041D

Error message

TRC: Wrong control; axis %1

Cause of error

The compensation file was generated for another control than the one now in use. Copying the compensation file from another control is not allowed.

Error correction

- Recalculate the compensation parameter with TNCopt under Optimization/Torque Ripple Compensation.
- Deactivation of the compensation: Entry in configuration datum Go to "Axes/ParameterSets/[Keyname of parameter block]/CfgControllerComp/" and delete "compTorqueRipple."
- Inform your service agency


Error description 230-041E

Error message

TRC: Compensation file (%1) illegible

Cause of error

The specified compensation file could not be found or read.

Error correction

- Check the compensation file directory, which is entered in machine parameter System/Paths/CfgOemPath/oemTable
- Check compensation file
- To deactivate compensation: Delete the entry in machine parameter
Axes/ParameterSets/[key name of parameter set]/CfgServoMotor/motTorqueRipple
- Inform your service agency


Error description 230-041F

Error message

Error in parameter posEncoderIncr or posEncoderDist (axis %2)

Cause of error

The two machine parameters posEncoderIncr and posEncoderDist in the configuration object CfgAxisHardware are configured incorrectly.
Even if you operate the axes solely with motor encoders (without linear encoders), the two parameters must contain realistic values.

Error correction

- Enter in the machine parameters CfgAxisHardware->posEncoderIncr and CfgAxisHardware->posEncoderDist realistic values for the position or motor encoder.


Error description 230-0420

Error message

No field angle for drive %1

Cause of error

The field angle of a motor with an unaligned encoder has not yet been ascertained.
Absolute encoder with EnDat interface:
- The encoder serial number saved does not fit the encoder
Incremental encoders:
- The SIK serial number saved does not fit the SIK of the control

Error correction

- If required, find the field angle in the "current controller adjustment" mode (press the "FIELD ORIENT." soft key)
- Check the “type of encoder” entry in the motor table and correct it if necessary
- Check the machine parameter motEncType and correct it if required
- Check the machine parameters motPhiRef and motEncSerialNumber. If you want to force a new field angle acquisition, enter the value 0.
- Inform your service agency


Error description 230-0421

Error message

MCU/CCU watchdog mismatch

Cause of error

MCU and CCU have different watchdog values.

Error correction

Inform your service agency.


Error description 230-0422

Error message

Axis motion not allowed while the filter is being changed

Cause of error

All axes must remain stationary while the filter is being edited.

Error correction

Inform your service agency.


Error description 230-0423

Error message

Error in configuration of axis %2

Cause of error

Connections were configured that are not available on this CC.

Error correction

Check the configuration of the axis:
- CfgAxisHardware->posEncoderInput
- CfgAxisHardware->speedEncoderInput
- CfgAxisHardware->inverterInterface
For analog axes via CMA-H expansion module:
- Check whether the expansion module is functioning correctly


Error description 230-0424

Error message

DCM: %1

Cause of error

Dynamic collision monitoring (DCM) stopped all axis movements in order to avoid a collision.


Error description 230-0425

Error message

Unbalance monitoring: measurement not possible

Cause of error

The measurement of the unbalance failed. The spindle could not be accelerated correctly. The programmed nominal speed was not attained.

Error correction

- Inspect the spindle for damage.
- Inform your service agency.


Error description 230-0426

Error message

Unbalance monitoring (user): unbalance too large

Cause of error

The value found by the unbalance monitor was too large.

Error correction

- Balance the signal


Error description 230-0427

Error message

Unbalance monitoring (user): sum of unbalance too large

Cause of error

The unbalance sum calculate by the unbalance monitor was too large.

Error correction

- Balance the signal


Error description 230-0428

Error message

Unbalance monitoring (system): unbalance too large

Cause of error

The value found by the unbalance monitor was too large.

Error correction

- Balance the signal


Error description 230-0429

Error message

Unbalance monitoring (system): sum of unbalance too large

Cause of error

The unbalance sum calculate by the unbalance monitor was too large.

Error correction

- Balance the signal


Error description 230-042A

Error message

Unbalance monitoring: configuration missing

Cause of error

The machine parameters for configuring the unbalance monitoring are not available.

Error correction

- Check the config object CfgUnbalance and correct it if required.


Error description 230-042B

Error message

Unbalance monitoring: invalid spindle defined

Cause of error

No value spindle index was given in the machine parameters for unbalance monitoring.

Error correction

- Check the machine parameters in the config object CfgUnbalance and correct it if required.


Error description 230-042C

Error message

Unbalance monitoring: invalid meas. axis defined

Cause of error

An invalid measuring axis was given in the machine parameters for unbalance monitoring.

Error correction

- Check the machine parameter axisOfMeasure in the config object CfgUnbalance and correct it if required.


Error description 230-042D

Error message

Unbalance monitoring: system monitor is not active

Cause of error

The system monitor of the unbalance monitoring is not active.

Error correction

- Activate the system monitor through the turning cycle
- Check the machine parameters maxUnbalanceOem and limitUnbalanceOem and correct it if required.


Error description 230-042E

Error message

Unbalance monitoring: spindle is not configured

Cause of error

The machine parameters for configuring the spindle are missing for the unbalance monitor.

Error correction

- Check the configuration of the spindle in the config object CfgUnbalance and correct it if required.


Error description 230-042F

Error message

Unbalance monitoring: spindle parameter or index is faulty

Cause of error

The spindle configuration or configuration of the unbalance monitor is faulty. An incorrect spindle index was given or the spindle configuration in the config object CfgUnbalance is incorrect.

Error correction

- Check the spindle index in the CfgAxes config object and correct it if required.
- Check the machine parameters in the config object CfgUnbalance and correct it if required.


Error description 230-0430

Error message

Unbalance monitoring: limit speed has been reached

Cause of error

The maximum permissible shaft speed calculated by the control for measuring the unbalance was attained.

Error correction

- Reduce the speed of the spindle and restart the measurement.


Error description 230-0431

Error message

Unbalance trace: internal error

Cause of error

Internal error in unbalance trace: incorrect status in the IPO in unbalance monitoring

Error correction

- Inform your service agency.


Error description 230-0432

Error message

Unbalance trace: trigger timeout

Cause of error

In the unbalance trace, the trigger conditions defined in the machine configuration were not fulfilled.

Error correction

- Check the machine parameters triggerMin and triggerMax, and correct it if required.


Error description 230-0433

Error message

Unbalance trace: internal error

Cause of error

An incorrect trace channel is active for the unbalance trace.

Error correction

- Inform your service agency.


Error description 230-0434

Error message

Unbalance trace: spindle index refers to an incorrect axis

Cause of error

An incorrect spindle index was given for the unbalance trace. The index refers to an incorrect address.

Error correction

- Check the machine parameters in the config object CfgUnbalance and correct it if required.


Error description 230-0435

Error message

Unbalance trace: machine parameters not defined

Cause of error

The machine parameter for configuring the unbalance traces are not available.

Error correction

- Enter machine parameters in the config object CfgUnbalance.


Error description 230-0436

Error message

Unbalance trace: internal error

Cause of error

The OEM cycle for the unbalance trace is faulty. The shaft speed or the number of revolutions to be measured was not defined. The parameter count or speed must not have the value 0.

Error correction

- Correct the OEM cycle for the unbalance trace. The values for count or speed must not be 0.


Error description 230-0437

Error message

Unbalance trace: incorrect spindle index

Cause of error

An invalid spindle index was given for the unbalance trace.

Error correction

- Check the machine parameter for the spindle and correct if required.


Error description 230-0438

Error message

Unbalance trace: axis for measurement not defined

Cause of error

No measuring axis was defined for the unbalance trace.

Error correction

- Check the machine parameter axisOfMeasure and correct if required.


Error description 230-0439

Error message

Unbalance trace: spindle is not configured

Cause of error

The spindle defined for the unbalance trace was not found in the machine configuration.

Error correction

- Check the machine parameter for the spindle and correct if required.


Error description 230-043A

Error message

Unbalance trace: specified trigger axis does not exist

Cause of error

The trigger axis defined for the unbalance trace does not exist.

Error correction

- Check the machine parameter for the spindle and correct if required.


Error description 230-043B

Error message

Unbalance trace: trigger conditions are not fulfilled

Cause of error

The trigger conditions set for the unbalance trace are no longer fulfilled.

Error correction

- Check the machine parameters triggerMin and triggerMax, and correct it if required.


Error description 230-043C

Error message

Unbalance monitoring: permissible unbalance not defined

Cause of error

A user parameter required for the unbalance monitoring (the maximum permissible unbalance) was not defined.

Error correction

- Enter the user parameter maxUnbalanceUsr.


Error description 230-043D

Error message

Unbalance monitoring: permissible unbalance sum not defined

Cause of error

A user parameter required for the unbalance monitoring (the maximum permissible unbalance sum) was not defined.

Error correction

- Enter the user parameter limitUnbalanceUsr.


Error description 230-043E

Error message

Unbalance monitoring: permissible unbalance not defined

Cause of error

A machine parameter required for the unbalance monitoring, the maximum permissible unbalance (system-wide), was not defined.

Error correction

- Enter the machine parameter maxUnbalanceOem.


Error description 230-043F

Error message

Unbalance monitoring: permissible unbalance sum not defined

Cause of error

A machine parameter required for the unbalance monitoring, the maximum permissible unbalance sum (system-wide), was not defined.

Error correction

- Enter the machine parameter limitUnbalanceOem.


Error description 230-0440

Error message

Real-time-buffer transfer from integr. oscill. is beginning

Cause of error


Error description 230-0441

Error message

Internal error in transmission of oscilloscope measured data

Cause of error

The display of measured value in the oscilloscope is incomplete because of an error in the internal data transmission between the interpolator real-time buffer and the oscilloscope.

Error correction

- Repeat the measurement
- Inform your service agency if the error continues to occur


Error description 230-0442

Error message

Progmmd. limit switch/protection zone incorrect for axis %2

Cause of error

The following constraints apply to limit switches and protection zones for modulo axes:
- The lower limit must be between –360° and +360°.
- The upper limit must be between 0° and +360°.
- The lower limit must be less than the upper limit.
- The difference between the upper and lower limit must be less than 360°.
- If the machine parameter "moveAfterRef" is configured, the axis is not moved further. A warning is output.
- Both protection zones = 0 means: Monitoring is inactive

Error correction

Adjust the value for the protection zone.


Error description 230-0443

Error message

Handwheel superimposition not allowed (M118)

Cause of error

You tried to activate the M118 function during active collision monitoring. The handwheel superimpositioning function with M118 is not allowed in combination with collision monitoring.

Error correction

Remove M118 from the NC program or deactivate the collision monitoring.


Error description 230-0444

Error message

Collision monitoring not possible in turning mode

Cause of error

The collision monitoring cannot monitor turning tools and collision objects that rotate with the lathe spindle.

Error correction

- If necessary, remove the collision objects (CMOs) from the turning kinematics (notify the machine manufacturer).
- Do not insert any turning tools during milling.


Error description 230-0445

Error message

Velocity error (axis %2) too great

Cause of error

The velocity deviation between position the position encoder and the speed encoder is too large.

Error correction

Check the coupling between the position encoder and speed encoder


Error description 230-0446

Error message

Internal error while processing the oscilloscope measuring data

Cause of error

Internal software error: The synchronization of the oscilloscope channels is faulty.

Error correction

- Repeat the measurement
- Inform your service agency if the error continues to occur


Error description 230-0447

Error message

Internal error while processing the oscilloscope measuring data

Cause of error

Internal software error: The synchronization of the oscilloscope channels in combination with the trigger condition is faulty.

Error correction

- Repeat the measurement
- Inform your service agency if the error continues to occur


Error description 230-0448

Error message

Internal error while processing the oscilloscope measuring data

Cause of error

Internal software error: The sequence of the data to be transmitted to the oscilloscope is faulty.

Error correction

- Repeat the measurement
- Inform your service agency if the error continues to occur


Error description 230-0449

Error message

Handwheel: wrong handwheel connected

Cause of error

- The electronic handwheel is not connected.
- An incorrect handwheel is configured in machine parameter System/CfgHandwheel/type.

Error correction

- Connect the handwheel via cable adapter.
- Check the machine parameter System/CfgHandwheel/type.


Error description 230-044A

Error message

Handwheel: Contaminated or damaged

Cause of error

The handwheel reports a problem in signal transmission:
- Rotary encoder in the handwheel is contaminated
- Handwheel is defective

Error correction

- Check the emergency stop and permissive buttons for proper function
- Exchange handwheel if necessary


Error description 230-044B

Error message

Handwheel: Transmission disturbance

Cause of error

- An incorrect handwheel was configured in machine parameter System/CfgHandwheel/type.
- Data transfer between the handwheel and control was disturbed.

Error correction

- Check the machine parameter System/CfgHandwheel/type.
- For wireless handwheel: Reduce distance to receiver
- Switch off possible sources of interference
- Check the connecting cable


Error description 230-044C

Error message

Handwheel: Transmission error

Cause of error

The transmission line is defective or faulty.

Error correction

Inspect the data transfer line for damage.


Error description 230-044D

Error message

Handwheel: Wrong parameter

Cause of error

The initialization values for the connected handwheel are invalid.

Error correction

Check the configuration datum System/CfgHandwheel/initValues.


Error description 230-044E

Error message

Handwheel: Timeout

Cause of error

A time limit was exceeded during communication with the handwheel.

Error correction

- Check the access point of the handwheel
- Check the radio settings


Error description 230-044F

Error message

Handwheel: No connection possible

Cause of error

Cannot connect with the handwheel.
The handwheel might not be in the access point (handwheel holder).

Error correction

Place the handwheel in the access point (handwheel holder).


Error description 230-0450

Error message

Axis %2: Enter CfgReferencing/doubleRefOffset: %3

Cause of error

The reference run was performed twice.

Error correction

Enter the indicated value in the machine configuration (parameter: CfgReferencing/dblRefOffset).


Error description 230-0451

Error message

PLC movement for axis %2 not allowed

Cause of error

The presently active NC program blocks manual axis movements by the manual direction keys or movements by the PLC program.

Error correction

Edit the PLC Program


Error description 230-0452

Error message

DCM: No manual movement allowed during a program run

Cause of error

You tried to make a movement with axis direction keys, a handwheel or PLC command while a program run was active

Error correction

Wait until the program run has ended or change to Single Block mode


Error description 230-0453

Error message

DCM: Program start or continuation not possible

Cause of error

You tried to start a program during an axis movement, e.g. by the axis direction key, handwheel or PLC command.

Error correction

Wait until the motion by axis direction key, handwheel or PLC command has finished


Error description 230-0454

Error message

DCM: No TCPM allowed during active DCM

Cause of error

You tried to move in Manual mode with TCPM during active DCM

Error correction

Deactivate TCPM
Deactivate DCM and move without monitoring


Error description 230-0455

Error message

DCM: Motion of the floating tap holder is not monitored

Cause of error

When DCM is active, you use the "tapping with floating tap holder" cycle. Please note that movements of the floating tap holder are not monitored by DCM. Collision monitoring observes the floating tap holder at its resting position.


Error description 230-0456

Error message

DCM not possible in following error mode or semifeedforward mode

Cause of error

You tried to use DCM with a non-feedforward axes.

Error correction

Change the configuration


Error description 230-0457

Error message

Reference mark not found

Cause of error

The reference mark was not found after covering the distance necessary for distance-coded referencing.

Error correction

- Inform your machine tool builder
- Check the mounted encoder
- Check the machine configuration (parameter "posEncoderRefDist")


Error description 230-0458

Error message

DCM: Check the skipReferencing parameter

Cause of error

You have set the machine parameter "System/CfgMachineSimul/skipReferencing" to the value TRUE. The Dynamic Collision Monitoring (DCM) is not possible with this setting.

Error correction

Set the parameter "skipReferencing" to the value FALSE or activate the programming-station mode (simMode = CcAndExt)


Error description 230-0459

Error message

S-RAM contents of axis %2 are inconsistent

Cause of error

The EnDat axis position values saved in S-RAM are invalid.
The values saved in a file will be used.

Error correction

Check the current position of the axis


Error description 230-045B

Error message

DCM: Activation during a movement

Cause of error

You activated the dynamic collision monitoring (DCM) during a program run or an axis movement.

Error correction

Activate DCM when the machine is at standstill.


Error description 230-045C

Error message

S-RAM contents of axis %2 overwritten with values from file

Cause of error

The EnDat axis position values saved in S-RAM were overwritten by the values saved in a file.

Error correction

Check the current position of the axis


Error description 230-045D

Error message

Axis %2: CfgReferencing/doubleRefOffset: %3 was entered

Cause of error

The reference run was performed twice.

Error correction

The given value was entered in the configuration.


Error description 230-045E

Error message

Oscilloscope active during start of reference machining

Cause of error

The oscilloscope is active and a reference operation was started at the same time. The oscilloscope cannot be used during the reference operation.

Error correction

Close the oscilloscope and repeat the reference operation


Error description 230-045F

Error message

Programmed movement not allowed

Cause of error

No programmed movement of axes is allowed in the "Retract" operating mode.

Error correction

Do not start an NC program as long as the "Retract" operating mode is active.


Error description 230-0460

Error message

Error in configuration of axis %2

Cause of error

The axis has been configured incorrectly.

Error correction

Check the axis configuration at the following places and correct if required:
- CfgSupplyModule->name
- CfgPowerStage->ampPowerSupplyType
- CfgPowerStage->ampBusVoltage
- CfgServoMotor->motSupply


Error description 230-0461

Error message

Configuration of kinematic compensation is faulty

Cause of error

The configuration of the temperature compensation or the kinematic compensation is faulty. The controls traverses without compensation as long as the error is not corrected.
The more exact cause is described in the additional text.

Error correction

- Acknowledge the error in order to continue without compensation
- Correct the configuration


Error description 230-0462

Error message

Temperature compensation is faulty

Cause of error

An error occurred in the calculation of the temperature compensation. The temperature compensation might no longer be working.

Error correction

Check the configuration of the temperature compensation.


Error description 230-0463

Error message

Kinematic compensation is faulty

Cause of error

An error occurred in the calculation of the kinematic compensation. The kinematic compensations might no longer be working.

Error correction

Check the kinematic compensations and and correct them if required.


Error description 230-0464

Error message

EnDat multiturn counter of the %2 axis was corrected

Cause of error

The value for the EnDat multiturn counter saved in the configuration is not plausible.
The value was automatically corrected by the control.

Error correction

Check the current position of the axis


Error description 230-0465

Error message

EnDat multiturn counter of the %2 axis was changed

Cause of error

The value for the EnDat multiturn counter saved in the configuration was exceeded.
The change does not become effective until the control is restarted.

Error correction

Restart the control.


Error description 230-0467

Error message

The KinematicsComp option has not been enabled

Cause of error

An kinematic compensation was configured, but the KinematicsComp option was not enabled.
The kinematic compensation is not in effect.

Error correction

- Correct the configuration or enable the software option.


Error description 230-0468

Error message

Max. compensation value %2 reached in CfgKinSimpleTrans %1

Cause of error

The value for the kinematic temperature compensation at the transformation has exceeded the maximum permissible value.
The compensation is set to the maximum value. The warning is deleted as soon as the maximum value is no longer exceeded.

Error correction

- Check the calculation of the compensation, and correct it if required
- Check the incoming PLC variables


Error description 230-0469

Error message

Max. compensation value %2 reached in axis %1 component %3

Cause of error

The value for the kinematic compensation at the axis has exceeded the maximum permissible value.
The compensation is set to the maximum value. The warning is deleted as soon as the maximum value is no longer exceeded.

Error correction

- Contact your machine tool builder
- Check the value and correct it if required
- Check the incoming PLC variables and tables and correct them if required


Error description 230-046A

Error message

More than %2 fast PLC inputs defined

Cause of error

In the IOC file, more fast PLC inputs are defined than allowed.

Error correction

- Check the IO configuration.
- Inform your service agency


Error description 230-046B

Error message

Fast PLC input on impermissible bus system

Cause of error

- In the IOC file, a fast PLC input was defined on an illegal bus system.
- Fast PLC inputs can be defined only on an HSCI-PL or the internal PL.
The affected PLC input is shown in the additional information.

Error correction

- Check the IO configuration
- Inform your service agency


Error description 230-046C

Error message

Fast PLC inputs with more than one definition

Cause of error

Fast PLC inputs are defined both in the IOC file as well as in the configuration data (machine parameters).
Note that the entry in the configuration data has priority.

Error correction

- Check the IO configuration
- Delete the CfgPlcFastInput configuration parameter (parameter number 103700) from the configuration data, if required
- Inform your service agency


Error description 230-046D

Error message

Input for axis group enabling has incorrect parameters

Cause of error

The PLC input for the axis-group release was not in the IO configuration (IOC file) or it was faulty.

Error correction

- Check the IO configuration.
- Inform your service agency


Error description 230-046E

Error message

Multiple inputs defined for axis group enabling %2

Cause of error

- Per axis group, only one PLC input for the axis-group release was defined.
- In the IOC file, multiple PLC inputs for the axis-group release were defined for one axis group.

Error correction

- Check the IO configuration.
- Inform your service agency


Error description 230-046F

Error message

Input for axis group enabling %s on impermissible bus system

Cause of error

The input for the axis-group release was defined on an illegal bus system in the IO configuration (IOC file).
The input can be defined only on an HSCI-PL or an internal PL.

Error correction

- Check the IO configuration.
- Inform your service agency


Error description 230-0470

Error message

Fast input for spindle has incorrect parameters

Cause of error

The fast input for the spindle was not in the IO configuration (IOC file) or it has incorrect parameters.

Error correction

- Check the IO configuration.
- Inform your service agency


Error description 230-0471

Error message

Several fast inputs defined for spindle %2

Cause of error

More than one fast input was defined for a spindle in the IO configuration (IOC file).
Only one input is allowed.

Error correction

- Check the IO configuration.
- Inform your service agency


Error description 230-0472

Error message

Fast input for spindle %1 on impermissible bus system

Cause of error

- The fast input for the spindle was defined on an illegal bus system.
- The input can be defined only on an HSCI-PL or an internal PL.

Error correction

- Check the IO configuration.
- Inform your service agency


Error description 230-0473

Error message

Fast input cannot be activated

Cause of error

A fast input cannot be activated because the IO configuration does not match the actual hardware configuration.
The affected input is shown in the additional information.
- The control is operated in the simulation mode.
- The IOC file does not match the hardware configuration.
- The options in the configuration are incorrectly set.

Error correction

- Check the hardware configuration
- Check the IO configuration
- Check the options
- Inform your service agency


Error description 230-0474

Error message

Inputs for axis group enabling have multiple definitions

Cause of error

Inputs for axis-group release are defined both in the IOC file as well as in the configuration data (machine parameters).
Note that the entry in the configuration data has priority.

Error correction

- Check the IO configuration
- Delete the configuration parameter driveOffGroupInput (parameter number 100106) if necessary
- Inform your service agency


Error description 230-0475

Error message

Fast input for spindle %2 already defined

Cause of error

Rapid inputs for the spindle are defined both in the IOC file as well as in the configuration data (machine parameters).
Note that the entry in the configuration data (machine parameters) has priority.

Error correction

- Check the IO configuration
- Check the entry in configuration parameter CfgSpindle/MP_fastInput (machine parameter number 401502) and delete it if required
- Inform your service agency


Error description 230-0479

Error message

TRC: The identification was adapted; axis %1; file %2

Cause of error

The compensation file for the TRC was adapted. The values were transferred to the CC controller unit and activated.

Error correction

Note further messages.


Error description 230-047A

Error message

No fast input for spindle %2 (%3)

Cause of error

No fast input was designed for homing or stopping.

Error correction

- Check the IO configuration (IOC file)


Error description 230-047B

Error message

Programmed position error too large. Limit to %1 mm.

Cause of error

- The configured position error is too large for KinematicsComp.
- The configured value is limited.

Error correction

- Correct the corresponding value(s) in the kinematic configuration (machine parameters locErrX, locErrY, locErrZ, locErrA, locErrB, locErrC).
- Inform your service agency


Error description 230-047E

Error message

Axis %2: Double reference name is active

Cause of error

A scanning cycle was started with active double reference run although the position encoder’s reference mark had not yet been scanned.

Error correction

Traverse the reference mark
- Check the entry for double reference run in machine parameter MP_doubleRef
- Inform your service agency


Error description 230-047F

Error message

Current actual position of the axis (%2) cannot be used

Cause of error

- The machine tool builder’s configuration does not allow transfer of the current EnDat position

Error correction

- Inform your service agency


Error description 230-0480

Error message

Max. compensation value %2 reached in axis %1

Cause of error

The value for the kinematic compensation at the axis has exceeded the maximum permissible value.
The compensation is set to the maximum value. The warning is deleted as soon as the value falls 0.1 mm below the maximum value.
Both the kinematic temperature compensation and the compensation via KinematicsComp (software option) go into the kinematic compensation.

Error correction

- Check calculation of compensation values, and correct if required
- Check and the PLC variables and tables going into the compensation and correct them if necessary
- Inform your service agency


Error description 230-0481

Error message

Handwheel %3: Wrong handwheel connected

Cause of error

- The electronic handwheel is not connected.
- An incorrect handwheel is configured in machine parameter System/CfgHandwheel/type.

Error correction

- Connect the handwheel via cable adapter.
- Check the machine parameter System/CfgHandwheel/type.


Error description 230-0482

Error message

Handwheel %3: Contaminated or damaged

Cause of error

The handwheel reports a problem in signal transmission:
- Rotary encoder in the handwheel is contaminated
- Handwheel is defective

Error correction

- Check the emergency stop and permissive buttons for proper function
- Exchange handwheel if necessary


Error description 230-0483

Error message

Handwheel %3: Transmission disturbance

Cause of error

- An incorrect handwheel was configured in machine parameter System/CfgHandwheel/type.
- Data transfer between the handwheel and control was disturbed.

Error correction

- Check the machine parameter System/CfgHandwheel/type.
- For wireless handwheel: Reduce distance to receiver
- Switch off possible sources of interference
- Check the connecting cable


Error description 230-0484

Error message

Handwheel %3: Transmission error

Cause of error

The transmission line is defective or faulty.

Error correction

Inspect the data transfer line for damage.


Error description 230-0485

Error message

Handwheel %3: Wrong parameter

Cause of error

The initialization values for the connected handwheel are invalid.

Error correction

Check the configuration datum System/CfgHandwheel/initValues.


Error description 230-0486

Error message

Handwheel %3: Timeout

Cause of error

A time limit was exceeded during communication with the handwheel.

Error correction

- Check the access point of the handwheel
- Check the radio settings


Error description 230-0487

Error message

Handwheel %3: No connection possible

Cause of error

Cannot connect with the handwheel.
The handwheel might not be in the access point (handwheel holder).

Error correction

Place the handwheel in the access point (handwheel holder).


Error description 230-0488

Error message

No assignment between handwheels and connections

Cause of error

- Two or more handwheels were configured (CfgHandwheel) but no connections assigned
- The automatic assignment to a connection is possible only with a single handwheel

Error correction

- Reduce the number of configured handwheels to one handwheel
- Assign individual handwheels to one connection each (CfgHandwheelList)
- Inform your service agency


Error description 230-0489

Error message

Only one HR 550FS wireless handwheel possible

Cause of error

- More than one active HR 550FS wireless handwheel is configured

Error correction

- Check and adjust the range of action. Only one wireless handwheel can be active: Deactivate wireless handwheels (CfgHandwheel->type) or remove the assignment (CfgHandwheelList)
- Inform your service agency


Error description 230-048C

Error message

Error in acknowledging the SampleRate of the CC

Cause of error

The acknowledged SampleRate of the CC controller unit does not agree with the SampleRate of the set parameters

Error correction

- Check parameter MP_ampPwmFrq for the SampleRate
- Inform your service agency


Error description 230-048D

Error message

Handwheel superimpositioning is ignored

Cause of error

The handwheel superimpositioning cannot be changed during M140 and measuring movements.

Error correction

The handwheel superimpositioning can be changed again when no M140 or measuring movement is active.


Error description 230-048E

Error message

Internal software error during Program Run, Single Block

Cause of error

An internal error occurred that can disturb the block display in Single Block mode.

Error correction

- Delete the error and continue as normal. In very rare cases in Single Block mode the block display might not agree with the operation. The movements are nevertheless made individually.
- If the error should reoccur, please generate a service file and inform your service agency.


Error description 230-048F

Error message

Handwheel %3: Communication error

Cause of error

- Internal communication error with the handwheel

Error correction

- Save service files
- Inform your service agency


Error description 230-0490

Error message

PLC movement for axis %2 was canceled

Cause of error

- An axis movement through the manual direction keys or the PLC program was stopped by a reconfiguration or a system cycle.

Error correction

- Restart the axis movement, if required.


Error description 230-0491

Error message

Retraction from thread completed

Cause of error

The retraction from the thread has been concluded.

Error correction

- NC program is to be continued: acknowledge message and continue NC program with NC start.
- NC program is not to be continued: acknowledge message and terminate NC program with INTERNAL STOP.


Error description 230-0492

Error message

NC software does not match UVR firmware

Cause of error

Faulty combination of NC software and UVR firmware.

Error correction

Inform your service agency


Error description 230-0493

Error message

MCU/UVR watchdog mismatch

Cause of error

The watchdogs on the MC main computer and UVR supply unit have different values.

Error correction

Generate the service files and inform your service agency.


Error description 230-0494

Error message

Message from UVR %2

Cause of error

The UVR supply unit reports an error

Error correction

Inform your service agency


Error description 230-0495

Error message

Incorrect axis index in axis %1

Cause of error

- Machine parameter CfgAxisHardware/MP_ccAxisIndex contains an invalid value.

Error correction

- Check and, if necessary, change the configuration in MP_ccAxisIndex: Valid values are 0 to N-1, where N is the number of control loops on the controller unit concerned. Example: For a CC xx06, the valid values are 0 to 5.
- Inform your service agency


Error description 230-0496

Error message

Input for speed encoder (%1) not valid

Cause of error

Faulty configuration of the speed encoder input for the axis

Error correction

Check the configuration of the axis:
- CfgAxisHardware/MP_speedEncoderInput


Error description 230-0497

Error message

Incorrect inverter or motor connection (%1, inv. %2, motor %3)

Cause of error

- The configured connection for the inverter to the controller unit is not available (CfgAxisHardware/MP_inverterInterface)
- or no inverter is connected to the configured socket (CfgAxisHardware/MP_inverterInterface)
- or the configured connection for the motor on the inverter is not available (CfgAxisHardware/MP_motorConnector).

Error correction

Check the following machine parameters:
- CfgAxisHardware/MP_inverterInterface
- CfgAxisHardware/MP_motorConnector


Error description 230-0498

Error message

Faulty synchronization during a movement

Cause of error

A system error led to an incorrect synchronization

Error correction

Inform your service agency


Error description 230-0499

Error message

CfgLaAxis/MP_axManualJerk (%2) missing for interpol. PLC movement

Cause of error

- Machine parameter CfgLaAxis/MP_axManualJerk must be configured for interpolating PLC movements.

Error correction

- For the PLC axes to be moved in interpolation, check the configuration in the machine parameter CfgLaAxis/MP_axManualJerk.
- Inform your service agency


Error description 230-049A

Error message

Spindle speed?

Cause of error

The NC program cannot be simulated because the spindle speed for the feed per revolution is missing.
A simulation is possible only with the simulation speed FMAX.

Error correction

- Check the NC program and change it if necessary
- Change the simulation speed to FMAX.


Error description 230-049C

Error message

Timeout during command processing by the UVR %2

Cause of error

A UVR was given a command and has not acknowledged it

Error correction

Possible causes:
- HSCI connection interrupted (see other error messages)
- UVR defective


Error description 230-049D

Error message

A parameter change requires switching off the drive

Cause of error

Before changing the directional bit in the parameters, the drive must be switched off.


Error description 230-049E

Error message

Real time coupling function (RTC) together with handwheel active

Cause of error

- Real time coupling function (RTC) is to be closed while the handwheel is active, or
- the handwheel is to be activated while the real time coupling function is active.

Error correction

- Check the NC program and correct it if necessary
- Activate the handwheel at a later time
- Inform your service agency


Error description 230-04A0

Error message

Test of brake %1 for axis %2 was unsuccessful

Cause of error

- Note further messages.

Error correction

- Inform your service agency


Error description 230-04A2

Error message

Touch probe %1 is not supported by the transmitter/receiver unit

Cause of error

The transmitter/receiver unit does not support the touch probe.

Error correction

Select another touch probe
Inform your service agency


Error description 230-04A3

Error message

Collision of the touch probe

Cause of error

The touch probe collision protection has responded.

Error correction

Manually retract the touch probe.


Error description 230-04A4

Error message

Configuration of handwheel on axis %2 is faulty

Cause of error

Connections were configured that are not available on this CC.

Error correction

Check the configuration of the axis:
- CfgAxisHandwheel->hsciCcIndex
- CfgAxisHandwheel->input


Error description 230-04A5

Error message

Handwheel %3: Handwheel is not supported

Cause of error

- The electronic handwheel is not supported with this NC software version

Error correction

- Check the software version
- Inform your service agency
- If required, use an older-model handwheel
- If required, install the service pack of the NC software that supports this handwheel model


Error description 230-04A6

Error message

Multiple handwheels on the same radio channel

Cause of error

There might be several radio handwheels operating in the environment with the same radio channel.

Error correction

- Check the channels selected for the radio handwheels
- Use the configuration dialog to check the frequency spectrum
- Change radio channel if required


Error description 230-04A7

Error message

Other radio devices are disturbing radio handwheel operation

Cause of error

Other devices are disturbing radio handwheel operation

Error correction

- Use the configuration dialog to check the frequency spectrum
- Change radio channel if required


Error description 230-04A8

Error message

Could not activate or deactivate axis %2

Cause of error

In a traverse range switchover, the position, speed and current controller of the axes to be deactivated must be switched off first.

Error correction

- Check the PLC program and adapt it if necessary.
- Inform your service agency.


Error description 230-04A9

Error message

Do not set the switch-off group, parameter set %2

Cause of error

Setting the parameter CfgAxisHardware/MP_driveOffGroup is not permitted in controls with integrated functional safety (FS) from HEIDENHAIN.

Error correction

- Check the parameters.
- The function must be implemented by the machine manufacturer via the SPLC program.
- Inform your service agency.


Error description 230-04AA

Error message

The switch-off group must be set, parameter set %2

Cause of error

The parameter CfgAxisHardware/MP_driveOffGroup must be set for controls without integrated functional safety (FS) from HEIDENHAIN.
Refer to the Technical Manual for your control for the function and constraints of this parameter.

Error correction

- Check the parameters.
- Inform your service agency.


Error description 230-04AB

Error message

Parameter %2 not set for parameter set %3

Cause of error

The parameter must be set for this parameter set.

Error correction

- Check the parameters.
- Inform your service agency.


Error description 230-04AC

Error message

Inputs for axis-group enabling are ignored

Cause of error

Inputs for axis-group enabling were found where the setting CfgHardware/MP_driveOffGroupInputs was defined.
This machine ignores them. The safety functions STO, SBC, and SS1 can only be used via a PAE-H switch-off module.

Error correction

- Delete the setting CfgHardware/MP_driveOffGroupInputs.
- Put the safety functions on terminals of a PAE module and configure them in accordance with the risk analysis of the machine.
- Inform your service agency.


Error description 230-04AD

Error message

PL inputs are not allowed as axis-group enabling

Cause of error

PL inputs for axis-group enabling were defined in the IOCP file.
This machine ignores them.
The safety functions STO, SBC, and SS1 can only be used via a PAE-H switch-off module.

Error correction

- Delete the axis-group enabling machine function from all PL input terminals.
- Put the safety functions on terminals of a PAE module and configure them in accordance with the risk analysis of the machine.
- Inform your service agency.


Error description 230-04AE

Error message

PAE module not configured in IOCP file

Cause of error

No machine functions for axis-group enabling were found in the IOCP file. The safety functions STO, SBC, and SS1 must be configured via a PAE-H switch-off module.
The PAE module is presumably not configured.

Error correction

- Configure the PAE module correctly in the IOCP file.
- Put the safety functions on terminals of a PAE module and configure them in accordance with the risk analysis of the machine.
- Inform your service agency.


Error description 230-04AF

Error message

Axis-group enabling machine function configured on PL module

Cause of error

The axis-group enabling machine function was defined on at least one terminal in the IOCP file even though the module is not a PAE module.
The safety functions STO, SBC, and SS1 can only be used via a PAE-H switch-off module.

Error correction

- Put the safety functions on terminals of a PAE module and configure them in accordance with the risk analysis of the machine.
- Inform your service agency.


Error description 230-04B0

Error message

Invalid PWM frequency configured for axis %2

Cause of error

An incorrect or invalid PWM frequency was configured.
Frequencies up to 10 kHz are possible for CC 61xx and UEC 1xx.
For Gen3 devices, depending on the UM device only frequencies up to 10 kHz are possible, or even only specific individual frequencies.

Error correction

Check and correct the configuration under CfgPowerStage->ampPwmFreq.


Error description 230-04B3

Error message

More safe axes are activated than are enabled in the SIK

Cause of error

The axis options in the SIK specify how many safe axes can be active at the same time. You have activated more safe axes over the machine configuration than are enabled as axis options in the SIK.

Error correction

- Check the machine configuration and correct it if necessary
- If you need more safe axes, you can get a code number from HEIDENHAIN to enable them..


Error description 230-04B4

Error message

SMC: Missing acknowledgment

Cause of error

SMC run-time error:
- The safety-oriented software did not respond within the expected time period.
- Generally high system load

Error correction

Check the system load


Error description 230-04B7

Error message

Error in configuration of axis %2

Cause of error

The axis is not configured correctly.

Error correction

Check the axis configuration in the following machine parameters and correct if required:
- CfgSupplyModule/name
- CfgPowerStage/ampPowerSupplyType
- CfgPowerStage/ampBusVoltage
- CfgPowerStage/supplyModule
- CfgSupplyModule3xx/hsciUvIndex
- CfgPowerStage/pwmPhaseShift
- Inform your service agency


Error description 230-04B9

Error message

The signal cannot be recorded

Cause of error

The necessary access right to record PLC signals is missing.


Error description 230-04BA

Error message

UVR%2 change of parameters requires restart.
Shut down the control and restart it.

Cause of error

The UVR cannot apply the changed machine parameters without restarting.

Error correction

Restart the control


Error description 230-04BC

Error message

Warning from EnDat speed encoder on motor in %1 axis ID: %2 SN: %3

Cause of error

- Lower internal functional limit of the encoder has been exceeded.

Error correction

- Check the mounting of the encoder and correct it if necessary
- Clean the encoder, if possible
- Check whether any of the encoder specifications were not complied with, e.g. the supply voltage or ambient temperature. Ensure that the encoder is operated within the specifications.
- Inform your service agency


Error description 230-04BD

Error message

Advance warning from EnDat position encoder in %1 axis ID: %2 SN: %3

Cause of error

- Internal functional limit of the encoder has been reached. The encoder can still be operated, but it is recommended that the encoder be checked.

Error correction

- Check the mounting of the encoder and correct it if necessary
- Clean the encoder, if possible
- Check whether any of the encoder specifications were not complied with, e.g. the supply voltage or ambient temperature. Ensure that the encoder is operated within the specifications.
- Inform your service agency


Error description 230-04BE

Error message

Warning from EnDat position encoder in %1 axis ID: %2 SN: %3

Cause of error

- Lower internal functional limit of the encoder has been exceeded.

Error correction

- Check the mounting of the encoder and correct it if necessary
- Clean the encoder, if possible
- Check whether any of the encoder specifications were not complied with, e.g. the supply voltage or ambient temperature. Ensure that the encoder is operated within the specifications.
- Inform your service agency


Error description 230-04BF

Error message

Fatal error on inverter %2

Cause of error

- Internal error in the inverter

Error correction

- Note any further messages
- Inform your service agency


Error description 230-04C0

Error message

Emergency stop by inverter %2

Cause of error

- Internal error in the inverter

Error correction

- Note any further messages
- Inform your service agency


Error description 230-04C1

Error message

NC stop by inverter %2

Cause of error

- Internal error in the inverter

Error correction

- Note any further messages
- Inform your service agency


Error description 230-04C2

Error message

Brake outputs can't be read by IOCP file

Cause of error

The IOCP file was not configured or cannot be read

Error correction

Inform your service agency


Error description 230-04C3

Error message

Brake outputs are ignored

Cause of error

"Outputs for brake control" were defined in the IOCP file. These are not supported by the present machine configuration and will therefore be ignored.

Error correction

- Remove configured outputs for brake control from the IOCP file
- Configure outputs for brake control through CfgBrake/MP_connection
- Inform your service agency


Error description 230-04C4

Error message

Two brake outputs refer to the same brake %1

Cause of error

In the IOCP file, two "outputs for brake control" were configured with the same reference to one brake (CfgBrake).

Error correction

- Check the brake control configuration in the IOCP file and correct it
- Inform your service agency


Error description 230-04C5

Error message

Control of brake %2 on axis %3 incorrectly configured

Cause of error

The configured output for brake control in the IOCP file refers to a hardware terminal other than the one currently being used by the axis.

Error correction

- Configure the output for brake control in the IOCP file to the correct terminal
- Inform your service agency


Error description 230-04C6

Error message

Brake %2: MP_connection must not be configured

Cause of error

The machine parameter CfgBrake/connection is not supported by the present machine configuration.

Error correction

Use IOconfig to configure "Output for controlling the brake" through the IOCP file


Error description 230-04C7

Error message

Connection of brake %2 not configured

Cause of error

The output necessary for brake control is missing from the IOCP file

Error correction

- Configure the output for brake control for this brake in the IOCP file
- Inform your service agency


Error description 230-04C8

Error message

Braking connection for brake %2 not configured

Cause of error

Configuration of the brake connection is missing in CfgBrake/MP_connection

Error correction

- Configure the machine parameter CfgBrake/MP_connection
- Inform your service agency


Error description 230-04C9

Error message

Acceptance testing of safety-relevant parameters %1 required

Cause of error

- The hardware configuration was significantly changed, e.g. different model of inverter
- The configuration of the safety-related parameters was changed
- The saved configuration was changed by the hardware defects

Error correction

- Check the safety-relevant configuration for the drive (parameter set)
- Have suitable persons accept the configuration again, if necessary
- Inform your service agency


Error description 230-04CA

Error message

Braking connection for brake %2 incorrectly configured

Cause of error

An incorrect value was configured for the brake connection CfgBrake/MP_connection

Error correction

- Check the entry in the machine parameter CfgBrake/MP_connection and correct it as necessary
- Inform your service agency


Error description 230-04CB

Error message

Axes switched while in motion

Cause of error

- Result of emergency stop during movement
- Clamping operation was switched while the axis was in motion
- Axis was switched off while in motion

Error correction

- If you suspect a PLC error, contact your machine tool builder.


Error description 230-04CC

Error message

Deactivate handwheel for axis %3

Cause of error

The control waits for automatic clamping of this axis. The activated handwheel is preventing this clamping.

Error correction

Disable the handwheel for this axis


Error description 230-04CD

Error message

Error during conversion of motor %1

Cause of error

Converting the motor data from the old table ‘PLC:\table\motor_oem.mot’ to the table MOTOR_OEM failed.

Error correction

- Inform your service agency


Error description 230-04CE

Error message

Communication with CC controller unit faulty

Cause of error

An error occurred during the internal communication with the CC controller unit.
Internal information: error in acknowledging the SampleRate. The requested "blockSize" is not available.


Error description 230-04CF

Error message

A client with this ID is already logged on

Cause of error

The data interface to the configuration server is occupied.

Error correction

Inform your service agency.


Error description 230-04D0

Error message

Configuration server is not ready

Cause of error

No readiness for communication through the data interface with the configuration server.

Error correction

Inform your service agency.


Error description 230-04D1

Error message

The requested parameter is not available

Cause of error

A parameter that is not available was entered.

Error correction

- Check/Correct the entered parameter
- If the error recurs, inform your service agency


Error description 230-04D2

Error message

Faulty axis configuration (%2)

Cause of error

Axes that are not configured on the same CC controller unit are to be operated as torque-master-slaves.

Error correction

Check and correct the configuration


Error description 230-04D3

Error message

Faulty monitoring of the software limit switches

Cause of error

Monitoring of the software limit switch was probably deactivated by the machine manufacturer via a macro.
This is currently no longer permitted.

Error correction

- Contact the machine manufacturer
- Information for machine manufacturers: check handling of the software limit switch in the OEM macro and correct as needed


Error description 230-04D4

Error message

Emergency stop by CC, %2

Cause of error

- Internal error in the controller unit

Error correction

- Note any further messages
- Inform your service agency


Error description 230-04D5

Error message

NC stop by CC, %2

Cause of error

- Internal error in the controller unit

Error correction

- Note any further messages
- Inform your service agency


Error description 230-04D6

Error message

Temp. of the CC too high %2

Cause of error

Temperature sensor detects an excessively high or low temperature within the housing of the controller unit.
- Insufficient heat dissipation for the controller unit
- Contaminated filter pads
- Defective climate control unit in the electrical cabinet
- Defective fan
- Defective temperature sensor
- Unfavorable mounting of components

Error correction

- Clean the filter pads
- Check the climate control unit, and repair it if necessary
- Replace the fan
- Inform your service agency


Error description 230-04D7

Error message

Error in acknowledging the sample rate of the UVR

Cause of error

The acknowledged sample rate of the UVR drive unit does not agree with the expected sample rate

Error correction

If the error recurs, inform your service agency.


Error description 230-04D8

Error message

Error in acknowledging the sample rate of the UVR

Cause of error

The requested "blockSize" of the UVR drive unit is not available.


Error description 230-04DD

Error message

Input for SBC.GLOBAL configured incorrectly

Cause of error

For the use of the SBC.GLOBAL input terminal of the PAE module, the corresponding machine function was either not configured in the IO configuration (IOC file) or it was configured incorrectly.
- No PAE module was configured.
- A PAE module with an outdated version of the HDD file was configured.
- More than one PAE module was configured.
- SBC.GLOBAL was configured on the wrong module.

Error correction

- Check the IO configuration
- Inform your service agency


Error description 230-04DE

Error message

Input for SBC.GLOBAL must not be configured

Cause of error

Do not configure the machine function SBC.GLOBAL in the IO configuration (IOC file) of systems with integrated functional safety.

Error correction

- Check the IO configuration
- Inform your service agency


Error description 230-04E0

Error message

Progmmd. limit switch/protection zone incorrect for axis %2

Cause of error

Protection zones for modulo axes should not be used with this version of the control software.

Error correction

- Remove protection zone for modulo axis
- Do not configure the axis as a modulo axis


Error description 230-04E2

Error message

Start position of axis (%2) not permissible for block scan

Cause of error

The starting position of the axis is outside of the permissible range.

Error correction

- Check the configuration of the software limit switches
- Check the starting points of the axes in the NC program


Error description 230-04E3

Error message

No complete circle was recorded

Cause of error

During evaluation of the measured data, it was found that no complete circle was recorded.

Error correction

- Check whether the configured feed rate was achieved
- Check the configured trigger speed


Error description 230-04E5

Error message

Incorrect UVR/UEC configuration: %2, index invalid: %3

Cause of error

No valid value entered for the machine parameter CfgSupplyModule3xx > hsciUvIndex.

Error correction

Check and correct the parameter: CfgSupplyModule3xx > hsciUvIndex


Error description 230-04E6

Error message

Incorrect UVR/UEC configuration: config. duplicated: %1 - %2

Cause of error

The parameter CfgSupplyModule3xx > hsciUvIndex is identical in the two stated instances of CfgSupplyModule3xx. That is not allowed.

Error correction

Check the parameter in all instances and correct as necessary: CfgSupplyModule3xx > hsciUvIndex


Error description 230-04E7

Error message

Axis movement not permitted while switching the CLP filter

Cause of error

No axis may move while the CLP filter is being switched on or off.
The movement may also result from superimpositioning (e.g., swing-frame grinding).
Possible causes of the filter switching:
- Switch-on or -off of TCPM (also M128 / M129)
- Tilting the working plane

Error correction

Edit the NC program.


Error description 230-04E8

Error message

Underlying velocity is too low

Cause of error

There were changes to the algebraic sign over the course of the actual velocity.
This reduces the quality of the determined characteristic values.

Error correction

- Increase the underlying velocity
- The excitation amplitude might need to be reduced


Error description 230-04E9

Error message

Not enough RAM to evaluate the measured data

Cause of error

Not enough RAM is available to evaluate the "Measure machine status" cycle.

Error correction

- Close any unnecessary applications
- Restart the control


Error description 230-04EA

Error message

MEASURE MACHINE STATUS: memory management faulty

Cause of error

Cannot delete an internal system file for temporary processing.

Error correction

Inform your service agency


Error description 230-04EC

Error message

Axis-group enabling disabled while in motion

Cause of error

Axis-group enabling was disabled for safety reasons.

Error correction

If no reason can be identified, inform your machine tool builder


Error description 230-04ED

Error message

Parameters of current controller are not correct %2

Cause of error

- The current controller (CfgCurrentControl) is not parameterized correctly
Mixed parameterization is not permitted:
Please use only (iCtrlPropGain and iCtrlIntGain) or
(iCtrlPropGainD, iCtrlIntGainD, iCtrlPropGainQ, and iCtrlIntGainQ)

Error correction

- Correct the parameterization of the current controller
Set (iCtrlPropGain = 0 and iCtrlIntGain = 0) or
(iCtrlPropGainD = 0, iCtrlIntGainD = 0, iCtrlPropGainQ = 0, and iCtrlIntGainQ = 0)


Error description 230-04EE

Error message

Parameters of current controller are not correct %2

Cause of error

- The current controller (CfgCurrentControl) is not parameterized correctly
iCtrlPropGain = 0, even though iCtrlIntGain > 0

Error correction

- Correct the parameterization of the current controller:
Set iCtrlPropGain > 0 or iCtrlIntGain = 0


Error description 230-04EF

Error message

Parameters of current controller are not correct %2

Cause of error

- The current controller (CfgCurrentControl) is not parameterized correctly
iCtrlPropGainD = 0, even though iCtrlIntGainD > 0

Error correction

- Correct the parameterization of the current controller:
Set iCtrlPropGainD > 0 or iCtrlIntGainD = 0


Error description 230-04F0

Error message

Parameters of current controller are not correct %2

Cause of error

- The current controller (CfgCurrentControl) is not parameterized correctly
iCtrlPropGainQ = 0, even though iCtrlIntGainQ > 0

Error correction

- Correct the parameterization of the current controller:
Set iCtrlPropGainQ > 0 or iCtrlIntGainQ = 0


Error description 230-04F1

Error message

Configuration error in Monitoring

Cause of error

The configuration of the monitoring tasks (component and process monitoring) failed with the described error.

Error correction

Have your machine manufacturer correct the configuration error.


Error description 230-04F2

Error message

Run-time error during calculation

Cause of error

Run-time error during calculation of the monitoring task

Error correction

Inform your service agency


Error description 230-04F3

Error message

Error with external modules

Cause of error

Regarding a monitoring task, a serious error with external components occurred on the control.

Error correction

Inform your service agency


Error description 230-04F4

Error message

Internal (implementation) error

Cause of error

Serious internal (implementation) error in a monitoring task.

Error correction

Inform your service agency


Error description 230-04F5

Error message

Missing rights

Cause of error

Insufficient rights to perform this action

Error correction

Inform your service agency


Error description 230-04F6

Error message

Monitoring task results in a warning

Cause of error

Action to be performed in a monitoring task issues a warning

Error correction

Inform your service agency


Error description 230-04F7

Error message

Error while setting up Process Monitoring

Cause of error

An error occurred while configuring the process monitoring:
"Monitoring Meta Data" is faulty

Error correction

Inform your service agency


Error description 230-04F8

Error message

Faulty configuration of Multicast data

Cause of error

The configuration for assigning the Multicast data failed with the described error.

Error correction

Have your machine manufacturer correct the configuration error.


Error description 230-04F9

Error message

Internal error in the Multicast data interface

Cause of error

Serious internal (implementation) error in the Multicast data interface.

Error correction

Inform your service agency


Error description 230-04FA

Error message

Realtime Container error in the Multicast data interface

Cause of error

Realtime Container error occurred in the Multicast data interface.

Error correction

Inform your service agency.


Error description 230-04FB

Error message

Realtime Container error in monitoring tasks

Cause of error

Realtime Container error occurred in a monitoring task.

Error correction

Inform your service agency.


Error description 230-04FC

Error message

Error while calculating the indicators

Cause of error

Error occurred in connection with the indicators in a monitoring task.

Error correction

Inform your service agency.


Error description 230-04FD

Error message

Internal error in the NC reactions for monitoring tasks

Cause of error

Error occurred in the reactions of a monitoring task.

Error correction

Inform your service agency.


Error description 230-04FE

Error message

Internal error in monitoring tasks

Cause of error

Serious internal (implementation) error in a monitoring task.

Error correction

Inform your service agency.


Error description 230-04FF

Error message

Error in the table server of monitoring tasks

Cause of error

Errors that affect the monitoring task tables occurred.

Error correction

Inform your service agency.


Error description 230-0500

Error message

Error in the formulas used for monitoring tasks

Cause of error

Errors regarding formulas used in a monitoring task.

Error correction

Inform your service agency.


Error description 230-0501

Error message

Faulty configuration of the monitoring tasks

Cause of error

An error occurred while configuring a monitor.

Error correction

Inform your service agency.


Error description 230-0502

Error message

Software option for component monitoring is not enabled

Cause of error

Component monitoring cannot be used. The necessary software option is not enabled.

Error correction

- Enable the software option for component monitoring in the SIK
- Inform your service agency


Error description 230-0503

Error message

Process Monitoring software option is missing

Cause of error

The software option for process monitoring is not enabled. Process monitoring cannot be used.

Error correction

Inform your service agency


Error description 230-0504

Error message

Cancel program after NC stop because of error %2

Cause of error

Program execution was canceled after an NC stop.
Reason: The CC controller triggered an error.

Error correction

Note the information on remedies while the CC error is displayed.


Error description 230-0505

Error message

Frequency too high for eval. slot %s in envelope curve spectrum

Cause of error

The frequency to be evaluated is beyond the Nyquist frequency.

Error correction

- Select an adequate frequency below the Nyquist frequency


Error description 230-0506

Error message

No monitoring due to an upstream error

Cause of error

Due to an upstream error, Component Monitoring and Process Monitoring were deactivated.

Error correction

Inform your service agency.


Error description 230-0507

Error message

Error during graphical visualization of a monitoring task

Cause of error

An internal error occurred in connection with the graphical visualization of values for component or process monitoring.

Error correction

Check the configuration of the monitoring tasks and make any necessary corrections.


Error description 230-0508

Error message

Process monitoring is deactivated

Cause of error

A monitoring section was defined in the current NC program, but process monitoring is deactivated.

Error correction

Activate process monitoring for the current NC program or adapt the NC program.


Error description 230-0509

Error message

Process monitoring deactivated until next program start

Cause of error

The program sequence was interrupted.

Error correction

Restart execution of the NC program.


Error description 230-050A

Error message

Returning to the contour (backtrack) not possible for tapping

Cause of error

You tried to return to the contour after a program interruption during tapping. This is not possible with the current parameterization (machine parameter backTrack = TRUE).

Error correction

-Manually retract the tool from the thread and interrupt program execution
- Perhaps set the machine parameter backTrack to the value FALSE


Error description 230-050B

Error message

PLC movement for axis %2 was canceled

Cause of error

An axis movement by the PLC program was canceled because the kinematic model was activated during the movement (e.g., by switching the operating mode).

Error correction

Restart the axis movement, if required.


Error description 230-050D

Error message

Limit switch %1 %2 (axis not referenced)

Cause of error

Software limit-switch monitoring active for non-referenced axis. Acknowledging the message permits traverse of the software limit switch.


Error description 230-050E

Error message

Axis configuration for axis %2 obsolete

Cause of error

In the configuration, an entry was found that is no longer used.

Error correction

The obsolete entry should be removed from the configuration.


Error description 230-050F

Error message

Can't activate the SIK option "FS Control Loop Qty."

Cause of error

SIK option 6-30-2 can be activated only if SIK option 6-30-1 is also enabled.

Error correction

Enable SIK option 6-30-1.


Error description 231-4003

Error message

4003 EMERGENCY STOP is active (emergency stop test)

Cause of error


Error description 231-4004

Error message

4004 EMERGENCY STOP is inactive (emergency stop test)

Cause of error


Error description 231-4005

Error message

4005 Stack overflow warning

Cause of error


Error description 231-4007

Error message

4007 No interrupt from the gate array

Cause of error


Error description 231-4008

Error message

4008 Answer to a host command was too late

Cause of error


Error description 231-4009

Error message

4009 False interrupt (AC failure, emergence stop)

Cause of error


Error description 231-400B

Error message

400B Host is prompted to synchronize

Cause of error


Error description 231-4011

Error message

4011 Axis %1: measurement interrupted by NC Stop

Cause of error

The cycle was interrupted by an NC Stop while measuring.
The measurement was canceled and the data discarded.

Error correction

- Continue the cycle with NC Start
- Repeat the measurement


Error description 231-4110

Error message

4110 Encoder contamination in axis %1

Cause of error


Error description 231-4120

Error message

4120 Excessive frequency in encoder for axis %1

Cause of error


Error description 231-4130

Error message

4130 Contamination of Z1 track in encoder for axis %1

Cause of error


Error description 231-4140

Error message

4140 Power module warning: Heat sink temperature in axis %1

Cause of error


Error description 231-4150

Error message

4150 Power module warnung for axis %1

Cause of error


Error description 231-4160

Error message

4160 Gate array status reg. = not nicht stored (axis %1)

Cause of error


Error description 231-4170

Error message

4170 Error in temperature measurement for axis %1

Cause of error


Error description 231-4200

Error message

4200 PLC: Drive is ready for operation in axis %1

Cause of error


Error description 231-4210

Error message

4210 PLC: Drive is not ready for operation in axis %1

Cause of error


Error description 231-4220

Error message

4220 Standstill recognition (V=0 with IQ_max): (axis %1)

Cause of error


Error description 231-4230

Error message

4230 End of standstill recognition in axis %1

Cause of error


Error description 231-4240

Error message

4240 Warning for I^2*t monitoring in axis %1

Cause of error


Error description 231-4250

Error message

4250 End of warning for I^2*t monitoring in axis %1

Cause of error


Error description 231-4260

Error message

4260 Limit through I^2*t monitoring

Cause of error


Error description 231-4270

Error message

4270 End of limit through I^2*t monitoring in axis %1

Cause of error


Error description 231-4280

Error message

4280 Error during REF scan in axis %1

Cause of error


Error description 231-4290

Error message

4290 Drive switch-off (inactive RDY signal) in axis %1

Cause of error


Error description 231-4300

Error message

4300 Drive enable in axis %1

Cause of error


Error description 231-4310

Error message

4310 Drive disabled, e.g. through emergency stop in axis %1

Cause of error


Error description 231-4400

Error message

4400 Excessive servo lag (axis: %1)

Cause of error

- The following error of an axis exceeds one of the following error limits.
- The acceleration entered is too large.
- The motor does not move in spite of “Drive on.”

Error correction

- Reduce the contouring feed rate, increase the rotational speed.
Remove any possible sources of vibration.
Inform your service agency if the error occurs frequently.
- Check the acceleration (CfgFeedLimits/maxAcceleration)
- Check the following error limits (CfgPosControl/servoLagMin[1/2] or servoLagMax[1/2])
- The motor current must not be under limitation during acceleration


Error description 231-4810

Error message

4810 CC (log): actual current value too high %1

Cause of error


Error description 231-5100

Error message

5100 Endless loop: Time monitoring (value: %1)

Cause of error


Error description 231-5200

Error message

5200 Compensated angle error alignment (value: %1)

Cause of error


Error description 231-5300

Error message

5300 Timeout of shaft speed interrupt (value: %1)

Cause of error


Error description 231-5500

Error message

5500 Emergency stop failure

Cause of error


Error description 231-6002

Error message

6002 Status of machine-on input = 1 after "hcSgMaschineEin"

Cause of error


Error description 231-6003

Error message

6003 Status of machine-on input = 0 after "hcSgMaschineEin"

Cause of error


Error description 231-6005

Error message

6005 STOP1 release due to error in T2 test

Cause of error


Error description 231-6006

Error message

6006 Tool changer: "SHS2"-output change to open chuck

Cause of error


Error description 231-6016

Error message

6016 STOP2 release: Incorrect power supply

Cause of error


Error description 231-6017

Error message

6017 STOP2 release: Out of temperature range

Cause of error


Error description 231-6018

Error message

6018 Request for test of pulse deletion

Cause of error


Error description 231-6100

Error message

6100 Cut-out channel test: Status change -STO.A.x %1 = 0->1

Cause of error


Error description 231-6140

Error message

6140 Negative position monitoring with stop 1

Cause of error


Error description 231-6800

Error message

6800 CC (Dbg): test code

Cause of error


Error description 231-6810

Error message

6810 CC (Dbg): switch-off position invalid, outside the limit switches

Cause of error


Error description 231-6820

Error message

6820 CC (log): autotest info

Cause of error


Error description 231-6840

Error message

6840 CC (log): timer info for monitoring the calling of the brake test

Cause of error


Error description 231-6850

Error message

6850 CC (log): LSV2 test command for FS error injection

Cause of error


Error description 231-8000

Error message

8000 CC%2 Warning: Temperature of controller card is high

Cause of error

- The temperature of the controller card has exceeded a warning threshold
- Ambient temperature is too high

Error correction

- Check the air conditioning of the electrical cabinet
- Check whether the fan is working
- Inform your service agency


Error description 231-8001

Error message

8001 CC%2 Warning: Temperature of controller card is low

Cause of error

- The temperature of the controller card has fallen below a warning threshold
- Ambient temperature is too low

Error correction

- Check the air conditioning of the electrical cabinet
- Inform your service agency


Error description 231-8002

Error message

8002 CC%2 warning: Fan speed is low

Cause of error

- The rotational speed of the fan in the CC controller unit has exceeded a warning threshold

Error correction

- Check the fan
- Inform your service agency


Error description 231-8003

Error message

8003 CC%2 early warning: dc-link current too high

Cause of error

- The DC-link voltage of the temperature of the supply module has exceeded a warning threshold

Error correction

- Reduce the DC-link voltage by:
- Adjust the acceleration/braking ramps of the axes/spindles
- Check the "motPbrMax" and "motPMa" machine parameters
- Inform your service agency


Error description 231-8004

Error message

8004 CC test software loaded

Cause of error

- In the control there is a non-released CC test program without valid CRC program checksum
- No valid CRC checksum value was entered in the binary file of the CC software
- The MC software version does not support the CRC checksum comparison

Error correction

- The software can be used after the error acknowledgment for initial servicing or error diagnostics
- Check the software version
- Read out the log
- Inform your service agency


Error description 231-8005

Error message

8005 Oscilloscope signal not supported

Cause of error

- At least one of the selected signals of the internal oscilloscope is not supported with this controller unit (CC422)
- The following signals are not supported by the controller unit:
P mech., P elec., DSP debug, DC-link P, CC DIAG, I actual, actl. Id, Iq max, U noml, int. diag., motor A and motor B

Error correction

- Please do not select the following signals:
- P mech.
- P elec.
- DSP debug
- DC-link P
- CC DIAG
- I actual
- Actl. Id
- U nominal
- int. Diag.
- Motor A
- Motor B
- Max. Iq


Error description 231-8010

Error message

8010 LSV2 transmission error

Cause of error

- Error in data transfer by LSV2 protocol

Error correction

- Press the CE key to acknowledge the error.
- Error does not impair the control functions.
- Inform your service agency.


Error description 231-8040

Error message

8040 Heat sink temp. in UV 1xx

Cause of error

- Heat-sink temperature of UV 1xx power supply unit too high
- Temperature in the electrical cabinet too high
- Contaminated filter pads
- Defective climate control unit in the electrical cabinet
- Defective fan in the UV
- Defective temperature sensor
- If the heat-sink temperature continues to increase, the unit will be switched off

Error correction

- Stop the machine and let it cool down
- Continue working with lower power (reduce the feed rate)
- Clean the filter pads
- Check the climate control unit in the electrical cabinet
- Inform your service agency


Error description 231-8041

Error message

8041 Excessive Iz in UV 1xx

Cause of error

- DC-link current of UV 1xx power supply unit too high
- Overload of the machine while machining a workpiece

Error correction

- Continue working with lower power (reduce feed rate, replace worn tool, etc.)


Error description 231-8042

Error message

8042 CC%2 maximum temperature of controller card exceeded

Cause of error

- The maximum temperature of the controller card (CC) was exceeded
- Ambient temperature is too high

Error correction

- Check the air conditioning of the electrical cabinet
- Check whether the fan is working
- Inform your service agency


Error description 231-8043

Error message

8043 CC%2 temperature of controller card below minimum

Cause of error

- The temperature of the controller card (CC) is below the minimum
- Ambient temperature is too low

Error correction

- Check the air conditioning of the electrical cabinet
- Inform your service agency


Error description 231-8044

Error message

8044 CC%2 Fan speed too low

Cause of error

- The rotational speed of the fan in the CC controller unit has exceeded a monitoring threshold

Error correction

- Check the fan
- Exchange the controller unit
- Inform your service agency


Error description 231-8060

Error message

8060 Leakage current in UV CC%2

Cause of error

- Insulation problem (e.g. defective motor, contamination of the inverter, humidity)
- Check the motor connection for a ground fault

Error correction

- Isolate the cause by deselecting specific axes
- Replace the motor of the affected axis or check for a ground fault
- Replace the power cable of the affected axis or check for a ground fault
- Replace the inverter of the affected axis or check for a ground fault
- Check the motors of all selected axes
- Inform your service agency


Error description 231-8061

Error message

8061 Power module not ready

Cause of error

- Readiness signal of the power supply module is inactive after the servo control starts.
- Master contactor has opened
- Error in PLC program
- Power supply module, inverter defective

Error correction

- Try restarting the inverter. If the error recurs:
- Inform your service agency
- Check the wiring (main contactor)
- Check the PLC program
- Exchange the power supply module


Error description 231-8062

Error message

8062 Limit: Uz too small

Cause of error

- The dc-link voltage from the supply unit fell below the defined limit.

Error correction

- Inform your service agency
- Failure of the power supply at the supply module
- Excessive power consumption by the axes->activate the power limitation of the spindle


Error description 231-8063

Error message

8063 CC%2 timeout in S status test

Cause of error

- The MC activates the S status evaluation too late after a test.
- The maximum test switch-off time was exceeded.

Error correction

- Inform your service agency


Error description 231-8064

Error message

8064 AC powerfail

Cause of error

An error occurred during the AC Fail process.
The line voltage was intermittently interrupted.
Possible causes:
- Power failure
- Dropout in line power
- Defective protection of the line power supply
- Check the wiring of the line power supply

Error correction

- Check the line power circuit breakers
- Check the power supply wiring
- Check the quality of the line voltage (possible dropouts)
- Inform your service agency


Error description 231-8065

Error message

8065 DC powerfail

Cause of error

An error occurred during the DC Fail process. The dc-link voltage is below the specified limit.

Error correction

- Check the dc-link voltage
- Check the DC-link charging contactor for interruptions
- Check the line power supply
- Check the line power circuit breakers
- Check the wiring of the line power
- Check the quality of the line voltage (possible dropouts)
- Inform your service agency


Error description 231-8066

Error message

8066 CC%2 maximum temperature of controller card exceeded

Cause of error

- The maximum temperature of the controller card (CC) was exceeded
- Ambient temperature is too high

Error correction

- Check the air conditioning of the electrical cabinet
- Check whether the fan is working
- Inform your service agency


Error description 231-8067

Error message

8067 CC%2 temperature of controller card below minimum

Cause of error

- The temperature of the controller card (CC) is below the minimum
- Ambient temperature is too low

Error correction

- Check the air conditioning of the electrical cabinet
- Inform your service agency


Error description 231-8068

Error message

8068 CC%2 Fan speed too low

Cause of error

- The rotational speed of the fan in the CC controller unit has exceeded a monitoring threshold

Error correction

- Check the fan
- Exchange the controller unit
- Inform your service agency


Error description 231-8069

Error message

8069 IGBT error in the supply module

Cause of error

- The supply module switched off with an IGBT error (overload).

Error correction

- Check the power consumption of axes and spindle
- Exchange the power supply module
- Inform your service agency


Error description 231-806A

Error message

806A Unknown SPI expansion module

Cause of error

- The SPI plug-in module (for CC or MC) is unknown or provides an unknown code.
- The SPI plug-in module is defective.

Error correction

- Remove the defective SPI plug-in module.
- Exchange the defective SPI plug-in module.
- Inform your service agency.


Error description 231-806B

Error message

806B Powerfail AC drive cntrller

Cause of error

An "AC fail" occurred during operation. This means that the line power supply was temporarily interrupted.
Possible causes:
- Power failure
- Dropout in line power
- Defective protection of the line power supply
- Defective wiring of the line power supply


Error description 231-806C

Error message

806C DC powerfail

Cause of error

An error occurred during the DC Fail process. The dc-link voltage is below the specified limit.

Error correction

- Check the dc-link voltage
- Check the DC-link charging contactor for interruptions
- Check the line power supply
- Check the line power circuit breakers
- Check the wiring of the line power
- Check the quality of the line voltage (possible dropouts)
- Inform your service agency


Error description 231-8080

Error message

8080 Uz UV 1xx exceeds max.

Cause of error

- DC-link voltage of the power supply unit too high
- Defective braking resistor
- Defective power supply unit (infeed/regenerative feedback module)
- Interruption in the primary supply (fuses, wires, etc.)
- Energy recovery not possible

Error correction

- Inform your service agency
- Check the configuration datum (braking of the spindle)
- Check the braking resistor
- Replace the power supply unit
- Check the fuses and wiring of the primary supply


Error description 231-8081

Error message

8081 Uz is too small

Cause of error

- DC-link voltage of the supply unit is too low

Error correction

- Inform your service agency
- Failure of the power supply at the supply module
- Excessive power consumption by the axes->activate the power limitation of the spindle
- Check MP2192


Error description 231-8082

Error message

8082 MC shut-off signal "-STO.A.MC.WD" is active

Cause of error

- The shut-off signal "-STO.A.MC.WD" of the MC is active
- Check the entry in machine parameter CfgCycleTime -> watchdogTime
- Hardware defective
- The drive was switched off due to an internal error of the MC

Error correction

- Inform your service agency


Error description 231-8086

Error message

8086 Probing already active

Cause of error

Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-8092

Error message

8092 Pos. contr. cyc. time error

Cause of error

- MC is providing erroneous cycle time for CC position controller
- Hardware error

Error correction

- Inform your service agency
- Check the configuration datum ipoCycle
- Exchange the drive control board


Error description 231-8093

Error message

8093 CC%2 HSCI communication code=%4 address=%5

Cause of error

- The HSCI communication monitor reports a transmission error
- Hardware of an HSCI participant is defective

Error correction

- Check the HSCI cabling
- Exchange the defective hardware
- Inform your service agency


Error description 231-8093

Error message

8093 CC%2 HSCI data package not received Code=%4 Address=%5

8093 CC%2 HSCI data packet not received Code=%4 Address=%5

Cause of error

There was an error in HSCI communication. An
expected data packet with the above described HSCI
address could not be received.
Code
2101: Missing cyclic data
2102: Missing asynchronous data
2103: Missing asynchronous data 2
2104: Missing cyclic data of low priority
- Sporadic interruption of the HSCI communication through
contact problems (connector) or external EMC disturbance
- Grounding problems in the HSCI system
- Disturbance in the power supply of an HSCI participant
- Power supply fluctuations are too low or too high
Power supply of an HSCI participant
- Defect of an HSCI participant

Error correction

- Check the cabling (HSCI connection)
- Check the ground and power supply of the HSCI participant
- Check the software version.
- Inform your service agency.


Error description 231-8093

Error message

8093 CC%2 HSCI: Wrong ID data from HSCI device Code=%4 Address=%5

Cause of error

There was an error in HSCI communication. an HSCI
device with functional safety FS sent an incorrect identification
data to the HSCI device with the above described HSCI address.
Code
2201: Missing cyclic telegram
2202: Data telegram contains incorrect CRC checksum
2203: Data telegram contains incorrect watchdog counter
2204: Data telegram indicates incorrect channel
2205: Data telegram contains incorrect HSCI address
2206: Data telegram contains incorrect number of inputs
- Incorrect HSCI configuration (IOC file) or
wiring error
- Defect of an HSCI participant

Error correction

- Check the cabling (HSCI connection).
- Check and, if required, correct the HSCI configuration.
- Check the software version.
- Inform your service agency.


Error description 231-8093

Error message

8093 CC%2 Error in HSCI telegram between MC-CC Code=%4 Address=%5

Cause of error

There was an error in HSCI communication. An
expected data packet with the above described HSCI
address could not be received.
Code
2301: Missing telegram from MC to controller unit
2302: Data telegram contains incorrect CRC checksum
2303: Data telegram contains incorrect watchdog counter
- Sporadic problems of the HSCI connection or external disturbance
- Defect of an HSCI participant

Error correction

- Check the cabling (HSCI connection)
- Check the software version.
- Inform your service agency.


Error description 231-8093

Error message

8093 CC%2 Error in HSCI telegram between CCs Code=%4 Address=%5

Cause of error

An error occurred in the HSCI communication between two or more CC 61xx or UEC 1xx controller units.
Code
2401: Missing transmission telegram between the controller units
2402: Data telegram contains incorrect CRC checksum
2403: Data telegram contains incorrect watchdog counter
2404: Incorrect index of a controller unit
- Sporadic interruption of the HSCI communication through
contact problems (connector) or external disturbance
- Defect of an HSCI participant

Error correction

- Check the cabling (HSCI connection)
- Check the software version.
- Inform your service agency.


Error description 231-8093

Error message

8093 CC%2 Configuration error of an HSCI device with FS Code=%4 Address=%5

Cause of error

Errors occurred in the HSCI configuration of an HSCI component with functional
safety (FS).
Code
2207: Incorrect number of configuration commands received
2208: Incorrect device type configured
2209: Incorrect number of inputs configured
2210: Incorrect number of outputs configured
2211: Incorrect module ID received during configuration
2212: Wrong text ID configured
2213: Incorrect device variant configured
- HSCI configuration (IOC file) does not match the
connected HSCI component with FS

Error correction

- Check the cabling (HSCI connection)
- Check and, if required, correct the HSCI configuration.
- Check the software version.
- Inform your service agency.


Error description 231-8093

Error message

8093 CC%2 Alarm message from HSCI device Code=%4 Address=%5

8093 CC%2 Alarm message from HSCI component (FPGA) Code=%4 Address=%5

Cause of error

The HSCI participant (component) with the above described address
reported a transmission alarm.
Code
2500: General FPGA alarm
2501: Cyclic Range violation Rx
2502: Async Range violation Rx
2503: Async2 Range violation Rx
2504: Low priority range violation Rx
2505: Cyclic Range violation Tx
2506: Async Range violation Tx
2507: Async2 Range violation Tx
2508: Low priority range violation Tx
2509: Data inconsistency Rx
2510: Data inconsistency Tx
2511: Frame number error
2512: Sync fail flag
2513: Sync data fail flag
- Sporadic interruption of the HSCI communication through
contact problems (connector) or EMC disturbance
- Defect of an HSCI participant

Error correction

- Check the cabling (HSCI connection).
- Check the software version.
- Inform your service agency.


Error description 231-8094

Error message

8094 CC%2 HSCI sampling interval not transferred

Cause of error

- Internal software error

Error correction

- Inform your service agency


Error description 231-8130

Error message

8130 Motor brake defective %1

Cause of error

- Motor brake defective

Error correction

- Inform your service agency
- Check the motor brake control
- Exchange the motor


Error description 231-8150

Error message

8150 Field orient. successful %1

Cause of error

- Field orientation successful

Error correction

- Press CE to acknowledge the message


Error description 231-8160

Error message

8160 Actual current value too high %1

Cause of error

- The maximum permissible current of the power stage was exceeded

Error correction

- Check the current controller adjustment
- Inform your service agency
- Check the motor table, power stage table and configuration data
- Check the system for short circuits


Error description 231-8190

Error message

8190 Error in TNCopt measurement %1

Cause of error

- The TNCopt measurement was cancelled

Error correction

- Check the TNCopt version
- Check whether the control is active
- Inform your service agency


Error description 231-81A0

Error message

81A0 Invalid diagnostics channel %1

Cause of error

- Invalid CC-diag channel is selected in the oscilloscope.

Error correction

- Select another channel


Error description 231-81A1

Error message

81A1 CC %2 axis %1: Invalid DSP debug channel %4

Cause of error

- Invalid DSP debug signal selected in the oscilloscope

Error correction

- Select another signal


Error description 231-81A2

Error message

81A2 Axis %1: Quantity of channels per inverter exceeded

Cause of error

The maximum permissible number of oscilloscope channels per device was exceeded.

Error correction

Reduce the number of oscilloscope channels for the device.


Error description 231-81A3

Error message

81A3 Axis %1: Quantity of channels per encoder exceeded

Cause of error

The maximum permissible number of oscilloscope channels per device was exceeded.

Error correction

Reduce the number of oscilloscope channels for the device.


Error description 231-81A4

Error message

81A4 Axis %1: result of weighing was deleted

Cause of error

The result of the weighing run was deleted.
Cycle 239 was not deactivated.

Error correction

Deactivate Cycle 239 before switching to another setting.


Error description 231-81A5

Error message

81A5 CC%2 %1: Kanalanzahl des Gebers überschritten

Cause of error

The maximum permissible number of oscilloscope channels per device was exceeded.

Error correction

Reduce the number of oscilloscope channels for the device.


Error description 231-81A5

Error message

81A5 CC%2 encoder %1: number of oscilloscope channels exceeded

Cause of error

The maximum permissible number of oscilloscope channels for this encoder was exceeded.

Error correction

Reduce the number of oscilloscope channels for the encoder.


Error description 231-81B0

Error message

81B0 DQ com error of inverter %1 Po=%4 Dev=%5 Error=%6

Cause of error

- DRIVE-CLiQ communication to the inverter of the named
axis is disturbed
- DRIVE-CLiQ communication at the named output (Po=Port) has
been interrupted
- Error code (error) of the DSA link (third additional info):
- Output in decimal, to be interpreted in binary,
consisting of 8 bits:
Bit(s) Meaning
7 Interrupt triggered
6..5 Error group:
"00" Telegram reception error
"01" Other reception error
"10" Transmission error
"11" Other errors
4 Telegram too early
3..0 More detailed information:
0x1: CRC error
0x2: Telegram too short
0x3: Telegram too long
0x4: Length byte incorrect
0x5: Wrong telegram type
0x6: Incorrect address
0x7: No SYNC telegram
0x8: Unexpected SYNC telegram
0x9: ALARM bit received
0xA: Life sign is missing
0xB: Synchronization error of the
alternative cyclic data traffic

Error correction

- Inspect the DRIVE-CLiQ cabling
- Exchange the inverter
- Exchange the CC controller unit.
- Inform your service agency.


Error description 231-81C0

Error message

81C0 DQ com error motor encdr %1 Po=%4 Dev=%5 Error=%6

Cause of error

- DRIVE-CLiQ communication to the speed encoder (motor encoder)
of the named axis is disturbed.
- DRIVE-CLiQ communication at the named output (Po=Port) has
been interrupted.
- Error code (error) of the DSA link (third additional info):
- Output in decimal, to be interpreted in binary,
consisting of 8 bits:
Bit(s) Meaning
7 Interrupt triggered
6..5 Error group:
"00" Telegram reception error
"01" Other reception error
"10" Transmission error
"11" Other errors
4 Telegram too early
3..0 More detailed information:
0x1: CRC error
0x2: Telegram to short
0x3: Telegram to long
0x4: Length byte incorrect
0x5: Wrong telegram type
0x6: Incorrect address
0x7: No SYNC telegram
0x8: Unexpected SYNC telegram
0x9: ALARM bit received
0xA: Life sign is missing
0xB: Synchronization error of the
alternative cyclic data traffic

Error correction

- Inspect the DRIVE-CLiQ cabling
- Check the encoder connection
- Exchange the speed encoder
- Exchange the CC controller unit.
- Inform your service agency.


Error description 231-8300

Error message

8300 Motor brake defective %1

Cause of error

- Motor brake defective

Error correction

Warning:
Hanging axes cannot be supported under certain circumstances. The axis can fall down.
Do not enter the area of danger under the axis!
- Move the axis to a safe position before power-off
- Inform your service agency
- Check controls for motor brakes
- Exchange the motor


Error description 231-8310

Error message

8310 No current in brake test %1

Cause of error

- Motor is not properly connected
- Inverter is incorrectly connected
- Inverter is defective
- Motor is defective

Error correction

- Inform your service agency
- Check the wiring of the motor and inverter
- Check the inverter
- Check the motor


Error description 231-8320

Error message

8320 PIC: Actual value does not equal the nominal value %1

Cause of error

Possible cause:
The measurement range of current of the inverter is not set to the range specified in the configuration.
This message can appear, for example, if a new CC controller unit has been installed or there was an unexpected change to the configuration.
"PIC" designates a microcontroller inside the inverter that switches and reads back the measurement range of current.
- Nominal value (value in column S of the power module table) = 1, however:
- There is no PIC
- PIC can't be switched
- Access to PIC is deactivated (machine parameter motEncCheckOff, Bit16=1)
- Nominal value (value in column S of the power module table) = 0, however:
- Access to PIC is deactivated (machine parameter motEncCheckOff, Bit16=1) and PIC was already switched to 1

Error correction

- Check the power module entered in the machine configuration
- Check the nominal value of the PIC (value in column S of the power module table)
- Perhaps change the PWM frequency (to >= 5 kHz)
- Perhaps exchange the power module


Error description 231-8330

Error message

8330 Brake test was canceled %1

Cause of error

The brake test was canceled by
- PLC through Module 9161 = 0
- Missing enabling signal (emergency stop, X150, ...)
- Other error message

Error correction

- Check the PLC program
- Check the enabling signals
- Inform your service agency


Error description 231-8420

Error message

8420 Excessive temperature of power module %2.s

Cause of error

- Axis is being loaded too heavily (overload, temperature)
- Insufficient cooling in the electrical cabinet

Error correction

- Reduce the load
– Check the climate control in the electrical cabinet.
- Inform your service agency


Error description 231-8430

Error message

8430 Error during axis change %1

Cause of error

- An axis was removed from the machine configuration while still in the closed control loop

Error correction

- Check the PLC program and edit if necessary
- Check the configuration datum axisMode
- Inform your service agency


Error description 231-8440

Error message

8440 Field orient. successful %1

Cause of error

- Field orientation successfully completed.

Error correction

- Acknowledge the message with CE.


Error description 231-8600

Error message

8600 No drive-on command for %1

Cause of error

- Speed controller is waiting for the "drive on" command; the PLC program has sent no "drive on" command.

Error correction

- Check the PLC program.
- Inform your service agency.
- Check the software version.


Error description 231-8610

Error message

8610 I2T value is too high %1

Cause of error

- The load of the drive is too high for the duration

Error correction

- Reduce the load or the duration
- Inform your service agency
- Check the motor table, power stage table and configuration data
- Check whether the motor and power module are designed for the load


Error description 231-8620

Error message

8620 Load is too high %1

Cause of error

- Drive has maximum current and cannot accelerate
- Excessive load (torque, power) on the drive

Error correction

- Reduce the load on the drive
- Inform your service agency
- Check the motor table, power stage table and configuration data
- Check whether the motor and power module are designed for the load


Error description 231-8630

Error message

8630 Actual current value too high %1

Cause of error

- The maximum permissible current of the power stage was exceeded

Error correction

- Check the current controller adjustment
- Inform your service agency
- Check the motor table, power stage table and configuration data
- Check the system for short circuits


Error description 231-8640

Error message

8640 I2T value of motor is too high %1

Cause of error

- The load of the motor is too high over the duration

Error correction

- Reduce the load or the duration
- Check the motor table and configuration datum
- Check whether the motor is designed for the load
- Inform your service agency


Error description 231-8650

Error message

8650 I2T value of power module is too high %1

Cause of error

- The load of the power module is too high over the duration

Error correction

- Reduce the load or the duration
- Check the power module and configuration datum
- Check whether the power module is designed for the load
- Inform your service agency


Error description 231-8680

Error message

8680 DQ inverter %1: Maximum current limiting

Cause of error

- The maximum current read from the inverter is smaller than the maximum current in the inverter table.
- At a PWM frequency > 4 kHz: The output current has been derated too far.
- The permissible load application of the inverter was exceeded.

Error correction

- Reduce the PWM frequency
- Reduce the application load of the inverter
- Inform your service agency


Error description 231-8690

Error message

8690 Field orientation successful %1

Cause of error

- Field orientation successful

Error correction

- Press CE to acknowledge the message


Error description 231-8800

Error message

8800 Signal LT-RDY inactive %1

Cause of error

- Undesirable inverter switch-off during control of a vertical axis (caused by vertical axis).

Error correction

- Inform your service agency.
- Check the PLC program.
- Check the wiring of the inverter.


Error description 231-8810

Error message

8810 Signal LT-RDY inactive %1

Cause of error

- Undesirable inverter switch-off during control of a vertical axis (caused by vertical axis).

Error correction

- Inform your service agency.
- Check the PLC program.
- Check the wiring of the inverter.


Error description 231-8820

Error message

8820 Field angle unknown %1

Cause of error

- The field angle of the motor on the encoder reference point has not yet been ascertained.

Error correction

- Inform your service agency
- Check the entry in the configuration datum motFieldAdjustMove
- If required, find field angle in the "current controller adjustment" mode (press the "FIELD ORIENT." soft key)
Caution: The motor must be freely rotatable (no clamping, no hanging axis, no mechanical constraints).
- Check the "type of encoder" entry in the motor table


Error description 231-8830

Error message

8830 EnDat: no field angle %1

Cause of error

- The field angle of a motor with unaligned EnDat encoder has not yet been ascertained- The transferred EnDat serial number does match the one saved

Error correction

- Inform your service agency
- If required, find field angle in the "current controller adjustment" mode (press the "FIELD ORIENT." soft key)
- "Type of encoder" entry in the motor table
- Check the configuration datum motEncType


Error description 231-8840

Error message

8840 Axis not available %1

Cause of error

- Starting command for unavailable axis.

Error correction

- Inform your service agency.
- Check the software version.


Error description 231-8850

Error message

8850 Drive still active %1

Cause of error

- Position measurement (Z1 track) was started although the drive is still active.

Error correction

- Inform your service agency.
- Check the software version.


Error description 231-8860

Error message

8860 Input frequency of speed encoder %1

Cause of error

- Noise on speed encoder signals
- Signal connector: Poor contact or penetration of humidity
- Humidity has entered the motor

Error correction

- Inform your service agency
- Check the encoder signals
- Check the shielding


Error description 231-8870

Error message

8870 Input frequency of position encoder %1

Cause of error

- Noise on position encoder signals
- Penetration of humidity

Error correction

- Inform your service agency
- Check the encoder signals
- Check the shielding


Error description 231-8880

Error message

8880 No enabling while field angle %1 is being found

Cause of error

- Enabling is canceled while the field angle is being determined (e.g. PLC program, emergency stop, X150/X151, monitoring function).

Error correction

- Inform your service agency
- Check the PLC program (most frequent cause)


Error description 231-8890

Error message

8890 TRC: Wrong type of motor %1

Cause of error

- The axis for which the torque ripple compensation was activated through MP2260.x is not driven by a synchronous or linear motor.

Error correction

- Inform your service agency
- To deactivate the compensation, delete the entry in MP2260.x


Error description 231-88A0

Error message

88A0 TRC: Wrong control %1

Cause of error

- The compensation file was generated for a different control from this. Using a compensation file copied from another control is not allowed.

Error correction

- Inform your service agency
- Find again the compensation parameters with TNCopt under Optimization/Torque Ripple Compensation
- To deactivate the compensation, delete the entry in MP2260.x


Error description 231-88B0

Error message

88B0 TRC: Wrong file – motor %1

Cause of error

- The compensation file was generated for a motor with a different speed encoder with EnDat interface from this one. Using a compensation file copied from another control is not allowed.

Error correction

- Inform your service agency
- Find again the compensation parameters with TNCopt under Optimization/Torque Ripple Compensation
- To deactivate the compensation, delete the entry in MP2260.x


Error description 231-88C0

Error message

88C0 Max. nominal motor speed %1 exceeded

Cause of error

- Axis: Maximum feed rate is greater than the maximum motor speed (N-MAX) multiplied by the configuration datum distPerMotorTurn
- Spindle: Maximum spindle speed is greater than the maximum motor speed (N-MAX) multiplied by the gear transmission ratio
- The relationship between the line count of the position encoder and that of the motor encoder is faulty
- The N-MAX entry in the motor table is faulty
- Incorrect entry in the configuration datum motName
- EcoDyn: The selected feed rate exceeds the max. permissible voltage

Error correction

- Inform your service agency
- Check the N-MAX entry in the motor table
- Check the configuration data maxFeed, manualFeed and distPerMotorTurn
- Check the configuration data for spindle speed
- Check the STR column in the motor table and line count in the spindle parameter block (configuration datum "posEncoderIncr")
- Check all configuration data under CfgServoMotor


Error description 231-88D0

Error message

88D0 Kinematic compensation %1 not possible

Cause of error

Kinematic compensation via compensation file is possible only for
- Double-speed axes
- PWM frequencies less than or equal to 5 kHz

Error correction

- Check the machine parameter:
- Check the entry in SelAxType.
- Check the entry in AmpPwmFreq.
- Check the compensation file.
- Inform your service agency.


Error description 231-88E0

Error message

88E0 Brake test %1 not possible

Cause of error

- A brake test is not possible because the axis is not in a control loop.

Error correction

- Inform your service agency
- Software error


Error description 231-88F0

Error message

88F0 Inverter and supply module readiness is missing %s

Cause of error

- While the drive was still under servo control, both the Ready
signal of the inverter and the Ready signal of the supply
module were switched to inactive.
- Possible causes:
- UV was switched off over X70
- Fault clearance of the UV:
- Dropout in power supply
- DC-link voltage is too high
- DC-link voltage is too low
- DC-link current is too high
- PLC or external wiring switched UV off
- Noise signals on wiring CC -> UV, CC -> UM
- CC controller unit is defective.

Error correction

- Check the diagnostic LEDs on the UV in the event of an error
- Check the power supply of the UV
- Check the enabling signal on X70
- Check whether the braking resistor is connected for a
non-regenerative power supply.
- Check the cable ground and shield
- Exchange the supply module and the power module
- Exchange the CC controller unit.
- Inform your service agency.


Error description 231-8900

Error message

8900 Noml. speed > %5 1/min: Field weakening inactive %1

Cause of error

- The field weakening is not activated (machine parameter ampVoltProtection = 0)
- The nominal speed was higher than the rotational speed possible without field weakening

Error correction

- Activate the field weakening (set machine parameter ampVoltProtection to be unequal to 0)


Error description 231-8910

Error message

8910 Velocity too high for rotor position measurement %1

Cause of error

- An excessively high velocity was detected during the rotor position measurement
- Cause 1:
The rotor position is measured at a vertical axis without counterweight
- Cause 2:
The motor is in a poor switch-on position. The axis controls a certain position.

Error correction

- Regarding cause 1:
Measure the rotor position with another method. Only methods that measure the rotor position at standstill are allowed.
- Regarding cause 2:
Restart the rotor position measurement
- Inform your service agency


Error description 231-89F0

Error message

89F0 PLC input inactive %s

Cause of error

- A high-speed input is defined in MP4130.0 that stays inactive when the motor is switched on.
- The high-speed input is not enabled over W522.

Error correction

- Inform your service agency
- Check the PLC program
- Check the high-speed PLC input (MP4130.5)


Error description 231-8A00

Error message

8A00 No inverter enabling %1

Cause of error

- Power-on of the drive not possible due to missing enabling of the inverter via –SH1
- Charging contactor and main contactor on the supply unit is not on (e.g. connector X70 on UV)
- Safety relay not on (e.g. connectors X71 and X72 of the UV, X73 of the HEIDENHAIN expansion board for Simodrive)
- PWM bus cable interrupted
- Interruption in the electrical cabinet (unit bus, PWM ribbon cable)
- Defective inverter, (supply unit and/or power modules, compact inverter)
- Defective PWM interface on the control

Error correction

- Inform your service agency
- Check the wiring


Error description 231-8A10

Error message

8A10 AC fail %1

Cause of error

- Power-on of the drive not possible, because an AC-fail signal (power supply) is active.
- At least one phase is missing at the primary connection of the supply module

Error correction

- Inform your service agency
- Check the wiring of the power supply
- Test the power supply


Error description 231-8A20

Error message

8A20 Powerfail %1

Cause of error

- Power-on of the drive not possible, because a powerfail signal (power supply) is active

Error correction

- Inform your service agency
- Check the wiring of the power supply
- Test the power supply
- DC-link voltage


Error description 231-8A30

Error message

8A30 Drive enabling (I32) %1

Cause of error

- Power-on of the drive not possible due to missing drive enabling via I32

Error correction

- Inform your service agency
- Check the wiring of the emergency-stop loop
- Check the wiring for the drive enabling conditions (e.g. door contact, permissive button)
- Measure 24 V- at connector X42/pin 33


Error description 231-8A40

Error message

8A40 Enabling of axis group %1

Cause of error

- Because of missing drive enabling for axis groups (X150/X151), the drive cannot be switched on.

Error correction

- Inform your service agency
- Check the connector on X150/X151 for correct fit
- Check the wiring of X150/X151
- Check the optional configuration datum driveOffGroup.


Error description 231-8A50

Error message

8A50 Inverter not ready %1

Cause of error

- Power-on of the drive not possible, because an inverter is not ready (RDY signal).
- No pulse release, 24 V is missing on the terminal X71 or X72
- On interface PCBs for Siemens inverters, the second axis is not enabled
- Compact inverter, inverter supply unit or power module is defective
- Interruption at inverter bus cable (supply bus, unit bus, PWM bus)
- Defective PWM interface on the control

Error correction

- Correct the defect in the pulse inhibitor on power supply module UV, X71/72
- Replace the defective compact inverter, supply unit or power module
- Replace the defective cable
- Inform your service agency


Error description 231-8A60

Error message

8A60 Field angle incorrect %1

Cause of error

The drive cannot be switched on because of missing field angle information.

Error correction

- Inform your service agency
- Check the entries of the motor table (measuring device)
- If necessary, ascertain the field angle


Error description 231-8A70

Error message

8A70 Drive change active %1

Cause of error

The drive cannot be switched on because of a head exchange or a wye/delta switchover.

Error correction

- Inform your service agency
- Check the PLC program


Error description 231-8A80

Error message

8A80 Error ack. missing %1

Cause of error

The drive cannot be switched on because of a missing error acknowledgment.

Error correction

- Press the emergency stop and switch on again
- Switch on the control voltage
- Inform your service agency
- Check the wiring of the emergency stop


Error description 231-8A90

Error message

8A90 Safety module %1

Cause of error

- Not a safety-oriented control:
- The drive cannot be switched on because the safety module is locked
- Switch-off of the drive through removal of the external drive enabling at the input of the safety module
- Safety module is defective (exchange)
- Safety-oriented control:
- Drive cannot be switched on because of the operating status of the machine
- Drive was switched off because of a change to an illegal operating status of the machine

Error correction

- Inform your service agency
- Safety module is connected only to CC:
- Switch the external drive enabling over the corresponding input at the safety module (apply 24 V)
- Safety modules are connected at MC and CC:
- All drives:
- Check the function of the protective door contact
- Cancel the emergency stop
- Only spindle drive:
- Check the tool holder (closing)
- Check the permissive key
- Check the position of the detachable-key switch
- Exchange the safety module(s)


Error description 231-8AA0

Error message

8AA0 Illegal reference run %1

Cause of error

- A reference value was requested during an active touch probe cycle
- Internal software error

Error correction

- Inform your service agency.
- Check the software version.


Error description 231-8AB0

Error message

8AB0 Illegal probing %1

Cause of error

- A touch probe cycle was started during an active reference run
- Internal software error

Error correction

- Inform your service agency.
- Check the software version.


Error description 231-8AD0

Error message

8AD0 Drive enabling gone (Signal: "-STO.A.MC.WD" active)

Cause of error

- It is not possible to switch the drives on because there is no drive release
- The MC does not trigger the switch-off signal '-STO.A.MC.WD'
- Hardware defective
- Internal software error

Error correction

- Inform your service agency


Error description 231-8AE0

Error message

8AE0 Drive enabling missing in axis %1 (signal: %4)

Cause of error

- The switch-on procedure was canceled due to an existing error condition:
1 = Signal -ES.A (emergency stop MC) is active during switch-on
(emergency stop might have been pressed during switch-on)
2 = Signal -ES.A.HW (emergency stop MC, handwheel) is active during switch-on
(emergency stop might have been pressed during switch-on)
3 = Signal -ES.B (emergency stop CC) is active during switch-on
(emergency stop might have been pressed during switch-on)
4 = Signal -ES.B.HW (emergency stop CC, handwheel) is active during switch-on
(emergency stop might have been pressed during switch-on)
5 = Switch-on procedure not allowed because of a unacknowledged error
6 = Internal software error: addressed axis module/gate array does not exist
7 = Internal error signal -STO.B.CC.WD/-SCC.B.WD active during switch-on
8 = Internal error signal -N0 active during switch-on
9 = Internal error signal PWM error active during switch-on

Error correction

- Check the emergency-stop wiring
- Inform your service agency


Error description 231-8AF0

Error message

8AF0 Encoder %1 defective

Cause of error

- Scale or scale tape contaminated or defective
- Scanning head contaminated or defective
- Signal cable defective
- Encoder input defective on the control
- Penetration of humidity
- The position encoder is contaminated
- Motor encoder cable defective
- Motor control board defective

Error correction

- Inform your service agency
- Exchange the position encoder
- Check the encoder cable
- Exchange the motor control board (or better, the control)


Error description 231-8B10

Error message

8B10 Wrong traverse direction %1

Cause of error

- DIR entry in motor table is incorrect.
- Incorrect power connection of the motor.

Error correction

- Inform your service agency.
- Check the DIR entry in the motor table.
- Check the power connection of the motor.


Error description 231-8B20

Error message

8B20 Error %1 field orientation

Cause of error

- Field orientation impossible for mechanical reasons
- Incorrect relation between electrical field and mechanical motor movement
- Incorrect motor encoder signal
- Error in motor connection
- Mechanical brake not released

Error correction

- Inform your service agency
- Check the configuration data for number of signal periods and distance for the number of signal periods.
- Check the configuration datum for the linear distance of one motor revolution
- For linear motors: check column STR of the motor table
- Check the speed encoder connection
- Check the motor connection
- Release brakes during orientation


Error description 231-8B30

Error message

8B30 Motor temp. %1 too high

Cause of error

- Measured motor temperature is too high
- No temperature sensor
- Motor encoder cable is defective (wire broken)
- Entry in motor table is incorrect
- Incorrect or defective temperature sensor was installed
- Signal connector: Poor contact

Error correction

- Let the motor cool down
- Inform your service agency
- Check the motor encoder cable
- Check the entry in the motor table
- Measure the temperature sensor


Error description 231-8B40

Error message

8B40 No drive release %1

Cause of error

- Inverter not ready
- No pulse release for the power module
- Uz too high
- Power-fail signal active
- With M controls: I32 input inactive
- With P controls: Drive enabling at X50 inactive
In addition, for 246 261-xx (digital current controller):
- For the given axis an illegal motor model (e.g. linear motor) was selected.
- The CC receives a "Drive on" command for a nonexistent axis.
- The power module is not ready when the field orientation starts.
Readiness of the power module is detected through the Ready signal on the PWM cable.
- The power module is not ready when the current controller adjustment begins.

Error correction

- Inform your service agency
- Check the activation and wiring of the pulse release
- Check Uz
- Check the emergency stop circuit
- For a non-regenerative system: Is the braking resistor connected?
- For a regenerative system: Is the energy recovery activated?
- Check the cable ground and shield
- Exchange the power module
- For SIEMENS power converter (inverter): Exchange the interface card
- Exchange the drive control board


Error description 231-8B50

Error message

8B50 Axis module %1 not ready

Cause of error

- Safety relay not on (e.g. connectors X71 and X72 of the UV, X73 of the HEIDENHAIN expansion board for Simodrive)
- PWM bus cable interrupted
- PWM interface on the control defective
- Defective axis module
- No pulse release for the power module

Error correction

- Inform your service agency
- Exchange the power module
- Exchange the HEIDENHAIN expansion board for Simodrive
- Exchange the PWM bus cable


Error description 231-8B60

Error message

8B60 Overcurrent cutoff %1

Cause of error

- Undervoltage, temperature or short-circuit monitor of an IGBT in the inverter has responded.

Error correction

- Let the inverter cool down
- Inform your service agency
- Check the current controller
- Check the motor connection for a short circuit
- Check the motor for a short circuit in the windings
- Exchange the power module


Error description 231-8B70

Error message

8B70 External drive lock %1

Cause of error

- Drive switch-on is blocked by one or more external signals.

Error correction

- Inform your service agency.
- Check the external enabling signal (EMERGENCY STOP, PFAIL, N0).
- Check the PLC program.
- Check the external wiring.


Error description 231-8B80

Error message

8B80 External drive stop %1

Cause of error

- The drive is switched off by an external signal.

Error correction

- Inform your service agency.
- Check the external enabling signal (EMERGENCY STOP, PFAIL, N0).
- Check the PLC program.
- Check the external wiring.


Error description 231-8B90

Error message

8B90 Current controller not ready %1

Cause of error

- Error code: %x
- The power module or current controller is not ready after switch-on.
- The drive is not at a standstill when switched on.

Error correction

- Inform your service agency
- Check the pulse inhibitor
- Check the rotational speed input


Error description 231-8BA0

Error message

8BA0 Incorrect reference signal or line count %1

Cause of error

- Incorrect entry for the line count under STR in the motor table
- Faulty reference signal
- Noise signals
- Motor encoder cable defective (break or short circuit)
- Scale or scale tape contaminated or defective
- Scanning head contaminated or defective
- Signal cable defective
- Encoder input defective on the control
- Penetration of humidity

Error correction

- Inform your service agency
- Check the entry in the motor table
- Check the signals of the speed encoder (PWM 8)
- Check the encoder cable for breaks or short circuits under mechanical load (folding, stretching, etc.)
- Check the shield and its connection in the encoder cable
- Exchange the encoder cable
- Exchange the motor


Error description 231-8BB0

Error message

8BB0 Motor temperature too low %1

Cause of error

- Measured motor temperature too low
- Temperatur sensor incorrectly wired (short circuit)
- Temperature sensor is defective
- Incorrect temperature sensor (KTY84 required)
- Hardware error on encoder input board

Error correction

- Inform your service agency
- Check the wiring
- Test the temperature sensor
- Deselect the monitoring for low temperature limit CfgServoMotor->MotEncCheckOff bit 5
- Exchange the encoder input board


Error description 231-8BC0

Error message

8BC0 Motor current %1 too high

Cause of error

- Incorrect motor or power module selected.
- Volts-per-hertz spindle: Ramp gradient too high
- Power module defective
- Motor cable defective (short circuit)
- Motor defective (short circuit, ground fault)
- Humidity has entered the motor

Error correction

- Inform your service agency
- Are the correct motor and power module selected?
- Volts-per-hertz spindle: Readjust the ramp gradient (OEM)
- Check the motor and motor cable for a ground circuit or short circuit
- Exchange the power module


Error description 231-8BD0

Error message

8BD0 Excessive servo lag in %1

Cause of error

- The following error of a moving axis is greater than the value specified in the configuration datum CfgPosControl->servoLagMax1.
- Overloaded drive
- Insufficient lubrication
- Mechanical stiffness
- Machine vibration
- Hardware error in the control loop
- For analog axes, servo defective

Error correction

- Reduce the contouring feed rate, increase the rotational speed
- Check the lubrication
- Remove mechanical stiffness
- Remove any possible sources of vibration
- Check the parameter CfgFeedLimits->maxAcceleration
- Analog axes: Check the servo
- Inform your service agency if the error occurs frequently


Error description 231-8BE0

Error message

8BE0 Encoder defective %1

Cause of error

- Incorrect nominal increment between two reference marks

Error correction

- Inform your service agency.
- Check the entry in the motor table or CfgAxisHardware->posEncoderRefDist.
- Check whether the reference signal is disturbed.


Error description 231-8BF0

Error message

8BF0 Velocity of the spindle is too low %1

Cause of error

- Traversing speed of the spindle is to slow because of overload
- If the milling power is too high (high power consumption), it lowers the rotational speed of the spindle

Error correction

- Reduce the plunging depth or traversing speed
- Inform your service agency


Error description 231-8C00

Error message

8C00 Encoder on speed input %1 is defective

Cause of error

- There is no motor encoder signal
- There is a break in the motor encoder cable
- The signal amplitude of the motor encoder is missing or too small
- The motor encoder is contaminated
- Incorrect parameters of posEncoderResistor during use of an external Y cable

Error correction

- Check the motor encoder connection
- Check the motor encoder for proper function
- Check the amplitude of the motor encoder signal
- Check configuration in machine parameter PosEncoderResistor. If an external Y cable is used, a 1 has to be entered in this machine parameter.
- Inform your service agency


Error description 231-8C10

Error message

8C10 Encoder on speed input %1 is defective (EnDat)

Cause of error

- Position value of the motor encoder is invalid
- Interruption in motor encoder cable
- Motor encoder defective

Error correction

- Check the motor encoder connection
- Check the motor encoder
- Inform your service agency


Error description 231-8C20

Error message

8C20 Position encoder %1 defective

Cause of error

- There is no position encoder signal
- Interruption of the position encoder cable
- The signal amplitude of the position encoder is missing or too small
- The position encoder is contaminated
- Incorrect values of the machine parameter posEncoderResistor during use of an external Y cable
- Incorrect values of the machine parameter posEncoderFreq at feed rates greater than 50 kHz (counting frequency results from the encoder resolution)

Error correction

- Check the position encoder connection
- Check the function of the position encoder
- Check the amplitude of the position encoder.
- Check settings in machine parameter PosEncoderResistor. If an external Y cable is used, a 1 has to be entered in this machine parameter.
- Check the setting of the machine parameter posEncoderFreq and max. feed velocity. At feed rates greater than 50 kHz (corresponding counting frequency at the position input results from the resolution of the encoder), a 1 must be entered in
posEncoderFreq.
- Inform your service agency


Error description 231-8C30

Error message

8C30 Position encoder %1 defective (EnDat)

Cause of error

- Position value of the position encoder is invalid
- Interruption in position encoder cable
- Position encoder is defective

Error correction

- Check the position encoder connection
- Check the position encoder
- Inform your service agency


Error description 231-8C40

Error message

8C40 Speed input %1 measured value not saved (EnDat)

Cause of error

- Position value of the motor encoder was not latched
- Interruption in motor encoder cable
- Motor encoder defective

Error correction

- Check the motor encoder connection
- Check the motor encoder
- Inform your service agency


Error description 231-8C50

Error message

8C50 Position input %1 measured value not saved (EnDat)

Cause of error

- Position value of the motor encoder was not stored
- Interruption in position encoder cable
- Position encoder is defective

Error correction

- Check the position encoder connection
- Check the position encoder
- Inform your service agency


Error description 231-8C60

Error message

8C60 Signal frequency at encoder of speed input %1

Cause of error

- Noise on speed encoder signals

Error correction

- Check the encoder signals
- Check the shielding
- Inform your service agency


Error description 231-8C70

Error message

8C70 Signal frequency at position encoder %1

Cause of error

- Noise on position encoder signals

Error correction

- Check the encoder signals
- Check the shielding
- Inform your service agency


Error description 231-8C80

Error message

8C80 Amplitude too high at encoder on speed input %1

Cause of error

- The amplitude of the encoder signal is too high or the signal for contamination is active.
- Noise on motor encoder signal
- Short circuit in the motor encoder cable
- Signal amplitude of motor too high

Error correction

- Check the motor encoder connection (ground connection)
- Check the motor encoder
- Inform your service agency


Error description 231-8C90

Error message

8C90 Amplitude too high at position encoder %1

Cause of error

- The amplitude of the position encoder signal is too high or the signal for contamination is active
- Noise on the encoder signal
- Short circuit in the encoder cable
- Encoder signal amplitude too high
- Incorrect values in the machine parameter posEncoderResistor

Error correction

- Check the encoder connection (ground connection)
- Check the encoder
- Check configuration in machine parameter posEncoderResistor. If a position encoder is used (no external Y cable), a 0 has to be entered in this machine parameter.
- Inform your service agency


Error description 231-8CA0

Error message

8CA0 Incorrect reference signal or line count %1

Cause of error

- Incorrect entry for the line count under STR in the motor table
- Faulty reference signal
- Noise signals
- Motor encoder cable defective (break or short circuit)

Error correction

- Check the entry in the motor table
- Check the signals of the speed encoder (PWM 8)
- Check the encoder cable for breaks or short circuits under mechanical load (folding, stretching, etc.)
- Check the shield and its connection in the encoder cable
- Exchange the encoder cable
- Exchange the motor
- Inform your service agency


Error description 231-8CB0

Error message

8CB0 Commutation angle %1 missing

Cause of error

The commutation angle necessary for operating the motor is missing.

Error correction

- Determine the commutation angle again
- In the machine parameters, change the procedure for determining the commutation angle
- Inform your service agency


Error description 231-9200

Error message

9200 Parameter compIpcJerkFact is faulty

Cause of error

- On the CC, the input range for the "compIpcJerkFact" parameter is 0.0 to 0.8

Error correction

- Check the input value in machine parameter "compIpcJerkFact"
- Inform your service agency


Error description 231-9210

Error message

9210 Parameter vCtrlDiffGain %1 is too large

Cause of error

- Differential factor is too large (max. value 0.5 [As^2/rev])

Error correction

- Enter a value less than 0.5 in machine parameter "vCtrlDiffGain"
- Inform your service agency


Error description 231-9220

Error message

9220 Incorrect speed encoder input

Cause of error

- Incorrect entry in the "speedEncoderInput" machine parameter
- The assignment of the speed encoder input to the PWM output is incorrect

Error correction

- Check the "speedEncoderInput" machine parameter
- Inform your service agency


Error description 231-9230

Error message

9230 Unknown motor type

Cause of error

- Incorrect motor type in the motor table
- Unsupported motor type in the motor table
- Incorrect motor data in the motor table

Error correction

- Inform your service agency


Error description 231-9240

Error message

9240 Incorrect encoder type %1

Cause of error

- Selected encoder does not match the connected one
Examples:
EnDat is selected, but an incremental encoder is connected
EnDat 2.1 is selected, but EnDat 2.2 is connected
- The selected encoder is not supported by this CC

Error correction

- Check the machine parameter "motEncType" (or SYS in the motor table)
- Inform your service agency


Error description 231-9250

Error message

9250 Motor encoder: EnDat 2.2 not possible %1

Cause of error

- EnDat communication error
- An encoder with EnDat 2.2 interface is selected in the motor table, although no EnDat 2.2 encoder is connected
- The EnDat 2.2 protocol cannot be read

Error correction

- Check whether the encoder supports EnDat 2.2
- Check the motor table (SYS column)
- Check the machine parameter "motEncType"
- Check the cable ground and shield
- Exchange the motor control board
- Check the cable (compare the cable ID number with the documentation)
- Check the speed encoder cable (defective or too long)
- Check the speed encoder
- Inform your service agency


Error description 231-9260

Error message

9260 Motor parameters changed

Cause of error

- The motor type was changed without switching off the drive

Error correction

- Inform your service agency


Error description 231-9261

Error message

9261 CC%2: algebraic signs not consistent in parameters %1

Cause of error

The entry DIR in the motor table or machine parameter signCorrActualVal is set incorrectly

Error correction

Correct the entry DIR in the motor table or machine parameter signCorrActualVal.
The following rule applies: DIR and signCorrActualVal must be set to the same value.
Refer to the additional information in the Technical Manual, in the chapter "Defining the traverse direction".


Error description 231-9270

Error message

9270 Rated speed of motor unknown

Cause of error

- The entry in the motor table is zero

Error correction

- Inform your service agency


Error description 231-9280

Error message

9280 Parameter filter 1 invalid %1

Cause of error

- Incorrect entry in machine parameter "vCtrlFiltDamping1," "vCtrlFiltFreq1," "vCtrlFiltType1" or "vCtrlFiltBandWith1"
- Internal software error

Error correction

- Check the entry in machine parameter "vCtrlFiltDamping1," "vCtrlFiltFreq1," "vCtrlFiltType1" or "vCtrlFiltBandWith1"
- Check the software version
- Inform your service agency


Error description 231-9290

Error message

9290 Parameter filter 2 invalid %1

Cause of error

- Incorrect entry in machine parameter "vCtrlFiltDamping2," "vCtrlFiltFreq2," "vCtrlFiltType2" or "vCtrlFiltBandWith2"
- Internal software error

Error correction

- Check the entry in machine parameter "vCtrlFiltDamping2," "vCtrlFiltFreq2," "vCtrlFiltType2" or "vCtrlFiltBandWith2"
- Check the software version
- Inform your service agency


Error description 231-92A0

Error message

92A0 Parameter filter 3 invalid %1

Cause of error

- Incorrect entry in machine parameter "vCtrlFiltDamping3," "vCtrlFiltFreq3," "vCtrlFiltType3" or "vCtrlFiltBandWith3"
- Internal software error

Error correction

- Check the entry in machine parameter "vCtrlFiltDamping3," "vCtrlFiltFreq3," "vCtrlFiltType3" or "vCtrlFiltBandWith3"
- Check the software version
- Inform your service agency


Error description 231-92B0

Error message

92B0 Parameter filter 4 invalid %1

Cause of error

- Incorrect entry in machine parameter "vCtrlFiltDamping4," "vCtrlFiltFreq4," "vCtrlFiltType4" or "vCtrlFiltBandWith4"
- Internal software error

Error correction

- Check the entry in machine parameter "vCtrlFiltDamping4," "vCtrlFiltFreq4," "vCtrlFiltType4" or "vCtrlFiltBandWith4"
- Check the software version
- Inform your service agency


Error description 231-92C0

Error message

92C0 Parameter filter 5 invalid %1

Cause of error

- Incorrect entry in machine parameter "vCtrlFiltDamping5," "vCtrlFiltFreq5," "vCtrlFiltType5" or "vCtrlFiltBandWith5"
- Internal software error

Error correction

- Check the entry in machine parameter "vCtrlFiltDamping5," "vCtrlFiltFreq5," "vCtrlFiltType5" or "vCtrlFiltBandWith5"
- Check the software version
- Inform your service agency


Error description 231-92D0

Error message

92D0 Line count of motor has changed

Cause of error

- Line count of the motor has changed, although it was not switched off.

Error correction

- Inform your service agency


Error description 231-92E0

Error message

92E0 Line count for motor encoder incorrect %1

Cause of error

- Encoder line count in the parameter is not equal to the EnDat line count found
- The entry in machine parameter "cfgServoMotor --> motStr" is incorrect
- Incorrect entry under STR in motor table
- EnDat 2.2 motor encoder without line count information must be defined as STR = 1 or "cfgServoMotor --> motStr=1"

Error correction

- Edit the machine parameter "cfgServoMotor --> motStr"
- Change STR in motor table
- Inform your service agency


Error description 231-92F0

Error message

92F0 Incorrect axis assignment

Cause of error

- Incorrect axis assignment with moment master-slave operation
- Master and Slave are not assigned to the same controller motherboard
- Axes in master-slave torque control are permitted only at the following pairs of encoder inputs:
6-axis CC424
X15 and X17
X16 and X18
6-axis CC 6106
X15 to X20
8-axis CC424:
X15 and X17
X16 and X18
X19 and X80
X20 and X81
8-axis CC 6108
X15A to X18A
X15B to X18B
10 axis CC424:
X15 and X17
X16 and X18
10-axis CC 6110
X15A to X18A
X15B to X20B
12-axis CC424:
X15 and X17
X16 and X18
X82 and X84
X83 and X85
14-axis CC424:
X15 and X17
X16 and X18
X19 and X80
X20 and X81
X82 and X84
X83 and X85
16-axis CC424:
X15 and X17
X16 and X18
X19 and X80
X20 and X81
X82 and X84
X83 and X85
X86 and X88
X87 and X89

Error correction

- Change the axis assignment
- Inform your service agency


Error description 231-9300

Error message

9300 Field angle determination %1 not allowed

Cause of error

- Field angle determination is not allowed in this mode
- The method selected for determining the field angle is invalid or not possible with this encoder

Error correction

- Check the entry in machine parameters "motTypeOfFieldAdjust" and "motFieldAdjustMove" and/or the entry in the SYS column of the motor table
- Inform your service agency


Error description 231-9310

Error message

9310 Wrong input for position encoder

Cause of error

- An incorrect input was selected for the position encoder
(machine parameter "posEncoderInput")
- Possible configuration CC61xx:
PWM output <-> position encoder
X51 <-> X201
X52 <-> X202
X53 <-> X203
X54 <-> X204
X55 <-> X205
X56 <-> X206

Error correction

- Check the machine parameter "posEncoderInput"
- Inform your service agency


Error description 231-9320

Error message

9320 Position encoder: EnDat 2.2 not possible %1

Cause of error

- EnDat communication is defective
- An encoder with EnDat 2.2 interface is selected in machine parameter posEncoderType or motEncTyp, although no EnDat 2.2 encoder is connected.
- The EnDat 2.2 protocol cannot be read

Error correction

- Check whether the position encoder supports EnDat 2.2
- Check the machine parameter posEncoderType or motEncTyp
- Check the cable ground and shield
- Exchange the motor control board
- Check the cable (compare the cable ID number with the documentation)
- Check the position encoder cable (defective or too long)
- Check the position encoder
- Inform your service agency


Error description 231-9330

Error message

9330 Incorrect position encoder input configured %1

Cause of error

- The configured position encoder input does not exist

Error correction

- Check the configuration of the position encoder inputs
- Inform your service agency


Error description 231-9340

Error message

9340 PWM frequency error %1

Cause of error

- Entered PWM frequency in parameter "ampPwmFreq" lies outside the permissible input range
- PWM frequencies that may not be combined with each other were selected

Error correction

- Check the parameter "ampPwmFreq"
- Inform your service agency


Error description 231-9350

Error message

9350 PWM frequency too high %1

Cause of error

- PWM frequency selected over 5000 kHz for PWM output X51 or X52, although PWM output X53 or X54 is active

Error correction

- Check machine parameter ampPwmFreq for PWM output X51 or X52
- Deactivate PWM output X53 and/or X54
- Inform your service agency


Error description 231-9360

Error message

9360 Double speed not possible %1

Cause of error

- Control loop on X51 or X52 is defined as 'double speed', although the control loop on X53 or X54 is active
- Control loop on X55 or X56 is defined as 'double speed', although the control loop on X57 or X58 is active (only CC 4xx with 8 control loops)

Error correction

- Define the control loop on X51 or X52 as 'single speed', or deactivate the PWM output X53 or X54
- Define the control loop on X55 or X56 is defined as 'single speed', or deactivate the PWM output X57 or X58 (only CC 4xx with 8 control loops)
- Inform your service agency


Error description 231-9370

Error message

9370 "Inverter.inv" is not supported %1

Cause of error

- The 'Inverter.inv' file is not supported by this software

Error correction

- Replace the 'Inverter.inv' file with 'Motor.amp'
- Inform your service agency


Error description 231-9380

Error message

9380 Voltage protection module parameter %1

Cause of error

- Incorrect entry in machine parameter "ampVoltProtection"
- Internal software error

Error correction

- Check the entry in machine parameter "ampVoltProtection"
- Check the software version
- Inform your service agency


Error description 231-9390

Error message

9390 Increased current controller factors: Wrong motor type %1

Cause of error

- In machine parameter iCtrlAddInfo, the compensation in the current control loop is activated for a motor type other than a synchronous motor (linear motor, asynchronous motor).

Error correction

- Deactivate the compensation for increased current control factors by entering the value "0" in iCtrlAddInfo.


Error description 231-93A0

Error message

93A0 PDT1 feedforward current contrlr: Wrong motor type

Cause of error

- In machine parameter "iCtrlDiffFreqFF," PDT1 feedforward control was activated for the current control circuit of a drive with e.g. a linear or asynchronous motor.
- PDT1 feedforward control is only possible for the current control circuit of a drive with synchronous motor.

Error correction

- Deactivate the PDT1 feedforward by entering the value 0 in machine parameter "iCtrlDiffFreqFF."
- Inform your service agency.


Error description 231-93B0

Error message

93B0 PDT1 feedforward current contrlr.: Invalid cutoff freq.

Cause of error

- Illegal maximum cutoff frequency in machine parameter "iCtrlDiffFreqFF."
- The following are the maximum permissible cutoff frequencies for the respective PWM frequencies:
PWM frequency Maximum cutoff frequency
3333 Hz 800 Hz
4000 Hz 960 Hz
5000 Hz 1200 Hz
6666 Hz 1600 Hz
8000 Hz 1920 Hz
10000 Hz 2400 Hz

Error correction

- Enter the permissible cutoff frequency in machine parameter "iCtrlDiffFreqFF."
- Inform your service agency.


Error description 231-93C0

Error message

93C0 INVERTER.INV is faulty %1

Cause of error

- Incorrect entry in the power module table: INVERTER.INV
- Incorrect entry for I-MAX, U-IMAX or R sensor
- R sensor not identical to U-IMAX/I-MAX

Error correction

- Check the entries for I-MAX, U-IMAX and R sensor
- Inform your service agency


Error description 231-93D0

Error message

93D0 Transmission ratio is incorrect %1

Cause of error

The transmission ratio has incorrect parameters:
- Faulty entry for distPerMotorTurn, i.e. distance per motor revolution
- Incorrect entry in posEncoderIncr, i.e. signal periods of position encoder
- Faulty entry for distance traversed after posEncoderDist, i.e. parameterized signal periods of the position encoder

Error correction

- Inspection of the parameters distPerMotorTurn, posEncoderIncr and posEncoderDist
- Inform your service agency


Error description 231-93E0

Error message

93E0 PWM frequency greater than 5 kHz requires double speed %1

Cause of error

- If the PWM frequency selected in the "ampPwmFreq" machine parameter is greater than 5000 Hz, the machine parameter "ctrlPerformance" must be set to Double Speed

Error correction

- Either reduce the PWM frequency in "ampPwmFreq,"
- or set the "ctrlPerformance" machine parameter to Double Speed
- Inform your service agency


Error description 231-93F0

Error message

93F0 Maximum computer power exceeded

Cause of error

- CC61xx:
The desired computing power in the "ctrlPerformance" machine parameter is not possible.
The following configurations per controller unit are allowed:
Single | Double
6 | 0
4 | 1
2 | 2
0 | 3
"ctrlPerformance" machine parameter = 0 Single Speed
"ctrlPerformance" machine parameter = 1 Double Speed

Error correction

- Reduce the number of axes per controller unit
- Change the double-speed axes to single-speed axes ("ctrlPerformance" machine parameter from 1 to 0)
- Inform your service agency


Error description 231-9400

Error message

9400 Encoders with 11 µA are not supported

Cause of error

- "posEncoderSignal" machine parameter is set to 11 µA

Error correction

- "posEncoderSignal" machine parameter is set to 11 Vpp
- Inform your service agency


Error description 231-9410

Error message

9410 Relation of posEncoderDist to posEncoderIncr is faulty %1

Cause of error

- The relation of CfgAxisHardware->posEncoderDist to CfgAxisHardware->posEncoderIncr does not agree with the values from the EnDat encoder
- With EnDat 2.2: See the Technical Manual of the control

Error correction

- Check the entries CfgAxisHardware->posEncoderDist or CfgAxisHardware->posEncoderInc
- Inform your service agency


Error description 231-9420

Error message

9420 Configuration of X150 not possible %1

Cause of error

- The entry in GenDriveOffGroup (axis group switch-off with X150) is invalid

Error correction

- Correct the entry in GenDriveOffGroup
- Inform your service agency


Error description 231-9430

Error message

9430 Configuration of I32 not possible %1

Cause of error

- The entry in GenEmergencyStopFunction for drive enabling through I32 input is invalid

Error correction

- Correct the entry in GenEmergencyStopFunction
- Inform your service agency


Error description 231-9440

Error message

9440 Configuration of powerfail is not possible %1

Cause of error

- The entry in AmpAcFailSelection for AC fail or power fail is invalid

Error correction

- Correct the entry in AmpAcFailSelection
- Inform your service agency


Error description 231-9450

Error message

9450 Configuration of PWM pattern not possible %1

Cause of error

- The entry in ICtrlPwmInfo (configuration of the PWM pattern) is invalid

Error correction

- Correct the entry in ICtrlPwmInfo
- Inform your service agency


Error description 231-9460

Error message

9460 Configuration of LIFTOFF is not possible %1

Cause of error

- The entry in PowSupplyLimitOfDcVoltage is invalid
- The entry in PowSupplyDcLinkVoltageForSpindleStop is invalid

Error correction

- Correct the entry in PowSupplyLimitOfDcVoltage
- Correct the entry in PowSupplyDcLinkVoltageForSpindleStop
- Inform your service agency


Error description 231-9470

Error message

9470 Configuration of brake output is not possible %1

Cause of error

- The entry in MotBrakeNotExist is invalid

Error correction

- Correct the entry in MotBrakeNotExist
- Inform your service agency


Error description 231-9480

Error message

9480 Configuration of jerk feedforward is not possible %1

Cause of error

- The jerk feedforward over CompIpcJerkFact is not possible

Error correction

- Correct the entry in CompIpcJerkFact
- Recommendation: As an alternative, the torsion feedforward can be used through CompTorsionFact.
- Inform your service agency


Error description 231-9490

Error message

9490 Configuration of active damping is not possible %1

Cause of error

- The active damping through CompActiveDampFactor and CompActiveDampTimeConst is not possible

Error correction

- Correct the entry in CompActiveDampFactor and CompActiveDampTimeConst
- Inform your service agency


Error description 231-94A0

Error message

94A0 Configuration of SyncAxisTorqueDistrFact impossible %1

Cause of error

- The variable torque distribution through SyncAxisTorqueDistrFact is not possible

Error correction

- Correct the entry in SyncAxisTorqueDistrFact
- Inform your service agency


Error description 231-94B0

Error message

94B0 Configuration of speed compensation impossible %1

Cause of error

- The variable shaft speed compensation through SyncAxisSpeedCorrectRatio is not possible

Error correction

- Correct the entry in SyncAxisSpeedCorrectRatio
- Inform your service agency


Error description 231-94C0

Error message

94C0 DQ PWM freq. > 4 kHz requires double speed %1

Cause of error

- If the PWM frequency selected in the "ampPwmFreq" machine parameter is greater than 4000 Hz, the machine parameter "ctrlPerformance" must be set to Double Speed

Error correction

- Either reduce the PWM frequency in "ampPwmFreq,"
- or set the "ctrlPerformance" machine parameter to Double Speed (software option)
- Inform your service agency


Error description 231-94D0

Error message

94D0 DQ-ALM: Check the parameters %1

Cause of error

- Incorrect supply module selected in CfgPowSupply.
- The supply module is not entered in the supply module table Supply.Spy.

Error correction

- Select the correct supply module in CfgPowSupply.
- Inform your service agency


Error description 231-94E0

Error message

94E0 Switching EnDat 2.2 to 1 Vpp requires reinitialization %1

Cause of error

- The encoder was changed from EnDat 2.2 to 1 Vpp or vice versa. A reinitialization of the drive is required.

Error correction

- Reinitialize the system
- Deselect the axis with the machine parameter axisMode (bit x = 0)
- Exit the MP editor
- Reactivate the axis in machine parameter axisMode
(bit x = 1) and set posEncoderType to the desired value
- Re-exit the MP editor
- or restart the system


Error description 231-94F0

Error message

94F0 Impermissible torsion compensation %1

Cause of error

- Torsion compensation is configured, but the system is a single-encoder system.
- Torsion compensation is configured, but stick-slip friction compensation is not configured.

Error correction

- Deactivate torsion compensation with machine parameter compTorsionFact.
- Define the assignment between the position encoder inputs and the axes in posEncoderInput (if position encoder is present), and enter the friction compensation in machine parameter compFrictionT2.
- Inform your service agency


Error description 231-9500

Error message

9500 DQ: Inverter not found %1

Cause of error

- Not able to establish communication with the inverter of the displayed axis.
- The DRIVE-CLiQ line is not connected, or incorrectly connected.
- The supply voltage of the inverter has been interrupted.
- The inverter is defective.
- Machine parameter pwmSignalOutput is incorrect.

Error correction

- Check the cabling.
- Check the supply voltage of the inverter.
- Check the entry in machine parameter pwmSignalOutput.
- Inform your service agency


Error description 231-9510

Error message

9510 PWM frequency change during active servo control %1

Cause of error

- The PWM frequency in machine parameter ampPwmFreq must not be changed while the drive or a corresponding drive is still in a control loop.
Corresponding axis:
X51 - X52
X53 - X54
X55 - X56
X57 - X58
X80 - X81
X82 - X83
X84 - X85

Error correction

- Deactivate the drive controller before changing machine parameter ampPwmFreq
- Inform your service agency


Error description 231-9520

Error message

9520 Erroneous input in vCtrlTimeSwitchOff %1

Cause of error

- In machine parameter vCtrlTimeSwitchOff a time of zero was configured. The time entered must permit a safe braking process.
- In order to prevent an unbraked runout of axes/spindles without mechanical braking, the time in machine parameter vCtrlTimeSwitchOff must be greater than the maximum possible braking time of the axes that can occur through electrical braking.

Error correction

- Enter an appropriate value in machine parameter vCtrlTimeSwitchOff
- Inform your service agency


Error description 231-9530

Error message

9530 DRIVE-CLiQ axis %1 is still active

Cause of error

When an axis is deactivated in a DRIVE-CLiQ system, the associated axis must likewise be deactivated at the same port (e.g. 301).

Error correction

- Deactivate the second axis that is connected to the same connector (e.g. X301).
- The axis must be deactivated through machine parameter axisMode or CfgPlcSStrobe.
- Inform your service agency.


Error description 231-9550

Error message

9550 EnDat2.2 - FS single-encoder system incorrectly configured %1

Cause of error

It was configured so that both only the EnDat 2.2 position encoder and only the EnDat 2.2 shaft speed encoder are to be used for functional safety.
This is not possible.

Error correction

- Check the entry in Machine Parameter CfgAxisSafety-encoderForSafety:
It must either be "speedAndPosEncoder", "speedEncoder" or "posEncoder".
- Special settings for single-encoder systems with EnDat 2.2 FS encoders:
Set "posEncoder" if only the position encoder is to be used for functional safety
or set "speedEncoder" if only the shaft speed encoder is to be used for functional safety
- Standard setting: Set "speedAndPosEncoder" if you want to configure a normal dual-encoder system or
if the affected axis is run in functional safety with only one encoder (single-encoder safety).


Error description 231-9560

Error message

9560 MP entry erroneous: counting pulse per path %1

Cause of error

- Value in machine parameter posEncoderIncr lies outside the permissible range

Error correction

- Check the value in MP_posEncoderIncr and correct it if necessary
- Inform your service agency


Error description 231-9570

Error message

9570 Incorrect parameter entry: path per motor revolution %1

Cause of error

- Value in machine parameter distPerMotorTurn lies outside the permissible range

Error correction

- Check the value in MP_distPerMotorTurn and correct it if necessary
- Inform your service agency


Error description 231-9580

Error message

9580 Parameter filter 6 invalid %1

Cause of error

- Incorrect entry in machine parameter "vCtrlFiltDamping6", "vCtrlFiltFreq6", "vCtrlFiltType6" or "vCtrlBandWidth6"

Error correction

- Check the entry in machine parameter "vCtrlFiltDamping6", "vCtrlFiltFreq6", "vCtrlFiltType6" or "vCtrlBandWidth6"
- Inform your service agency


Error description 231-9590

Error message

9590 Maximum computing power exceeded

Cause of error

-CC61xx:
There is not enough computing power for the activated expanded controller functions.

Error correction

- Deactivate the expanded controller functions
- Reduce the number of axes per controller unit
- Change double-speed axes to single-speed axes (change the machine parameter ctrlPerformance from 1 to 0)
- Inform your service agency


Error description 231-9591

Error message

9591 TRC is not active

Cause of error

TRC is not active because not all parameters have been entered

Error correction

The following parameters are necessary in order to activate TRC:
- Mass moment of inertia of the motor (from the motor table) or acceleration feedforward control CfgControllerComp.compAcc
- Proportional component of the speed controller CfgSpeedControl.vCtrlPropGain
- Transformation ratio CfgAxisHardware.distPerMotorTurn


Error description 231-95A0

Error message

95A0 Entry in motor table faulty: PPW %1

Cause of error

In the motor table, the entry in the column PPW is missing or has the value 0.

Error correction

- Enter the value from the motor manufacturer data sheet in the column PPW
- Inform your service agency


Error description 231-95B0

Error message

95B0 Faulty parameterization in CfgAxisCoupling %1 (info: %4)

Cause of error

The parameterization for the axis coupling is faulty.
The additional data "Info" gives more precise information:
Info = 1: There is no valid master axis for the indicated slave axis
Info = 2: The master axis assigned for the indicated slave axis is not active
Info = 3: An AdvancedTorque slave is simultaneously parameterized as an AdvancedTorque master
Info = 4: An AdvancedTorque slave is simultaneously parameterized as a Torque master or an AdvancedPosition master

Error correction

Info = 1: Check the CfgAxisCoupling-masterAxis parameter
Info = 2: Check the CfgAxisCoupling-masterAxis parameter and the CfgAxis-axisMode or testMode parameter of the master axis
Info = 3: Check the CfgAxisCoupling-masterAxis parameter of all active axes
Info = 4: Check the CfgAxisCoupling-masterAxis parameter of all active axes


Error description 231-9800

Error message

9800 CC%2 MC command unknown %1

Cause of error

- MC command is not allowed for this hardware
- MC command is not allowed at this time
- 0 = error in command code > 255
1...255 = incorrect or invalid command code
- Internal software error

Error correction

- Inform your service agency.
- Check the software version.


Error description 231-9900

Error message

9900 CC%2 CC command unknown %1

Cause of error

- CC command is not allowed for this hardware
- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-A001

Error message

A001 Cancelation of brake-test call monitoring

Cause of error

- Protective door(s) were opened during the brake test
- No drive-ready signal during the brake-test call monitoring

Error correction

- Leave the protective door(s) closed during the brake test
- Ensure the drive readiness during the brake test


Error description 231-A002

Error message

A002 Cancelation of brake-line-test call monitoring

Cause of error

- Guard door(s) were open during the brake control test or brake line test

Error correction

- Leave the guard door(s) closed during the brake control test or brake line test


Error description 231-A003

Error message

A003 SPLC commissioning mode active

Cause of error

- CRC check of the SPLC program is deactivated (machine parameter CfgSafety --> commissioning is set)

Error correction

- The commissioning mode must be deactivated before a machine is delivered (reset commissioning in the machine parameter CfgSafety)
- Inform your service agency


Error description 231-A004

Error message

A004 Short circuit on 24 V of the T.BRK.B signal

Cause of error

- Error during braking control test
- Signal level = +24 V at input: -T.BRK.B of the SPL module
although 0 V is expected due to the control.

Error correction

- Check the external wiring of the brakes and the T.BRK signal.
- Check the relay for the brake control.
- Inform your service agency.


Error description 231-A005

Error message

A005 CC%2 Warning: Controller unit not suited for FS

Cause of error

When checking the safety kernel software SKERN-CC, the control unit detected,
that this hardware (CC, UEC, UMC) is not suitable for control systems with functional safety (FS).
This controller unit fulfills the safety requirements according to EN 13849 and is not
approved for functional safety.

Error correction

- Exchange the affected controller unit (CC, UEC, UMC)
- Inform your service agency.


Error description 231-A006

Error message

A006 SPLC-CC%2: Cross comparison failed, output %4

Cause of error

- Error in the cross comparison of the SPLC-CC outputs.
- SPLC program of the CC[x] defines the output as 0 (LOW). However, the value of the output read from the terminal is 1 (HIGH).

Error correction

- Check the wiring of the output.
- Check the SPLC program: signals for setting and resetting the SPLC outputs should always stay stable for at least 2 SPLC cycles.
- Inform your service agency.


Error description 231-A020

Error message

A020 Short circuit on 24 V of the T.BRK.B signal

Cause of error

- Error during braking control test
- Signal level = +24 V at input: -T.BRK.B of the SPL module
although 0 V is expected due to the control.

Error correction

- Check the external wiring of the brakes and the T.BRK signal.
- Check the relay for the brake control.
- Inform your service agency.


Error description 231-A021

Error message

A021 Cancelation of brake line test. Guard door open

Cause of error

- Guard door(s) were open during the brake control test or brake line test

Error correction

- Leave the guard door(s) closed during the brake control test or brake line test


Error description 231-A040

Error message

A040 CC%2 operating mode not possible

Cause of error

The status of the operating mode switches and the protective doors is not allowed.

Error correction

- Inform your service agency
- Check the setting of the operating mode switches
- Check the status of the switch for the safety doors
- Check the wiring


Error description 231-A041

Error message

A041 CC%2 SOM 4 not possible

Cause of error

- Keylock switch 1 not in automatic mode (BA1)
– Keylock switch 1 defective
- Wiring error

Error correction

- Set keylock switch 1 to automatic mode (BA1)
- Inform your service agency


Error description 231-A042

Error message

A042 CC%2 SOM 4 not released

Cause of error

The BA4 operating mode is selected by key switch but has not been released.

Error correction

- Inform your service agency.


Error description 231-A043

Error message

A043 CC%2 SOM 2 only one axis allowed

Cause of error

The simultaneous movement of more than one axes is not allowed in operating mode BA2 with open safety doors.

Error correction

Wait until all axes are at standstill, and then start only one axis.


Error description 231-A080

Error message

A080 CC%2 operating state not equal MC

Cause of error

- The automatic, SRG, SBH, and SH operating conditions are compared cyclically between the MC and CC. If the values remain unequal for longer than 500 ms, a Stop 1 is released.

Error correction

- Acknowledge the error message with CE
- Switch on the machine
- Inform your service agency
- Check the software version


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The requested safety function for the axis group does not match.
("pp_AxGrpStateReq[Var.]", Var.= axis group)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The motion request for an axis or for the axis group does not match.
("pp_AxGrpActivate[Var.]", Var.= axis group)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The axis-specific movement release does not match.
("pp_AxFeedEnable[Var.]", Var.= axis index)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The request of a stop reaction for the axis group does not match.
("pp_AxGrpStopReq[Var.]", Var.= axis group)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The status of the axis-group-specific permissive button does not match.
("pp_AxGrpPB[Var.]", Var.= axis group)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC The reported condition of the chain of safety relays or chain of normally closed contacts does not match.
("pp_GenFB_NCC", Var.= No meaning)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The requested or reported condition of the machine control voltage does not match.
("pp_GenCVO", Var.= No meaning)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The axis-group-specific permission for drive enable does not match.
("pp_AxGrpPermitDrvOn", Var.= axis group)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The collective status of the machine keys does not match.
("pp_GenMKG", Var.= No meaning)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The status of the signal for the brake-line test does not match.
("pp_GenTBRK", Var.= No meaning)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The safety-related mode of operation SOM active in the SKERN does not match.
("pp_GenSOM", Var.= No meaning)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The status of the read-back outputs does not match.
("readBackOutputs[Var.]", Var.= index number of the output)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The status "SPLc program active" does not match.
("running", Var.= No meaning)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the safety core software in a cross-comparison between MC and CC. The "Stop" request does not match.
("stopReq", Var.= No meaning)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the output data of the safety core software in a cross-comparison between MC and CC The ascertained safety status of the axis group does not match.
("NN_AxGrpState[Var.]", Var.= axis group)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the output data of the safety core software in a cross-comparison between MC and CC The axis-dependent braking control does not match.
("NN_AxBrkReleaseReq[Var.]", Var.= axis index)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the output data of the safety core software in a cross-comparison between MC and CC The motion status of the axis group does not match.
("NN_AxGrpInMotion[Var.]", Var.= axis group)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the output data of the safety core software in a cross-comparison between MC and CC The operating readiness for functional safety (FS) does not match.
("NN_GenSafe", Var. = No meaning)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the output data of the SKERN in a cross-comparison between the A channel and B channel. The axis-dependent braking control for multiple brakes per axis does not match.
("NN_MultiBrkOnAxisReleaseReq[Var.]", Var.= axis index)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the SKERN in a cross-comparison between the A channel and B channel. The value for the feed rate limit does not match.
("pp_AxFeedMax[Var.]", Var.= axis index)

Error correction

- Check the SPLC program
- Inform your service agency


Error description 231-A081

Error message

A081 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the output data of the SKERN in a cross-comparison between the A channel and B channel.
The axis-specific status of the safe absolute position does not match.
("NN_AxSafe[var.]", var.= axis index)

Error correction

- Check the SPLC program
- Restart the control
- Inform your service agency


Error description 231-A082

Error message

A082 CC%2 NE2 level does not change after 0 during dyn. test

Cause of error

- During the dynamic test of the 2nd emergency stop loop (every 1.5 minutes at the latest), a temporary change to 0 V level is expected at the input (NE2). If a 0 V or 24 V level remains continuously on inside the test window of 100 ms, it causes the
error.
- The time window for the dynamic test is too small (computing time problems, software errors)

Error correction

- Check the software version
- Inform your service agency
- Check the wiring
- Check the emergency stop button
- Exchange the hardware


Error description 231-A082

Error message

A082 CC%2 cross comparison no.=%4 Var.=%5 MC=%6 CC=%7

Cause of error

- A difference was found in the input data of the SKERN in a cross-comparison between the A channel and B channel. The value for the readback channels does not match.
("pp_ReadBackOutputs", Var. = Number of the SPLC output)

Error correction

- Check the voltages and wiring of the SPLC output
- Check the SPLC program and correct it if necessary
- Inform your service agency


Error description 231-A083

Error message

A083 CC%2 S input not equal to 0 in dynamic test

Cause of error

- During the dynamic test of the 2nd emergency stop loop (no later than every 1.5 min), a 0 V level is expected at all safety-related door-contact keylock and switch inputs for a short period. This error appears if a 24 V level continues throughout the
test window of 100 ms.
- The time window for the dynamic test is too small (computing time problems, software errors)

Error correction

- Check the software version
- Inform your service agency
- Check the wiring
- Check the door contacts and key switches
- Exchange the hardware


Error description 231-A084

Error message

A084 S timeout in stop reaction SS2 %4 ObjId=%5

Cause of error

- The maximum permissible time for a controlled stop (SS2 – braking on the contour) of the axis group (= ObjId) was exceeded. The maximum permissible time is 30 seconds.

Error correction

- Check the SPLC program and PLC program
- Inform your service agency.


Error description 231-A085

Error message

A085 SKERN-CC%2, X%4: Comm.error during EnDat encoder dynamic sampling

Cause of error

A communication error occurred during forced dynamic sampling of the EnDat encoder.
Both ignore flags were set at the same time.

Error correction

Inform your service agency.


Error description 231-A086

Error message

A086 SKERN-CC%2: Communications error during dynamic sampling of X%4

Cause of error

The dynamic sampling of the EnDat22 encoder could not be performed within the prescribed time.

Error correction

Note further error messages.
Inform your service agency.


Error description 231-A087

Error message

A087 SKERN-CC%2: illegal Ignore bit for EnDat forced dynamic sampling

Cause of error

An active ignore bit was detected outside of an EnDat forced dynamic sampling.

Error correction

- Restart the control
- If the error recurs, inform your service agency


Error description 231-A090

Error message

A090 Drive lock through safety software

Cause of error

- Emergency stop activated (by CC)
- A drive is to be switched on, although the system in in the "emergency stop" condition ( "-ES.B" or "-NE2" signal is active).
- Internal software error

Error correction

- Check the wiring
- Check the software version
- Inform your service agency


Error description 231-A091

Error message

A091 Drive lock through safety software

Cause of error

- Emergency stop activated (of MC)
- A drive is to be switched on, although the system in in the "emergency stop" condition ( "-ES.A" or "-NE1" signal is active).
- Internal software error

Error correction

- Check the wiring
- Check the software version
- Inform your service agency


Error description 231-A092

Error message

A092 Drive lock through safety software

Cause of error

- System test is active
- A drive is to be switched on, although the system is still in a test program
- Internal software error

Error correction

- Check the software version
- Inform your service agency


Error description 231-A093

Error message

A093 Drive lock through FS, stop 1 switch-off active

Cause of error

- Drive locked through functional safety FS
- A drive was supposed to be switched on, although the CC has not yet completed a completed a running stop 1 switch-off
- Internal software error

Error correction

- Check the software version
- Inform your service agency


Error description 231-A094

Error message

A094 Drive lock of spindle, tool holder opened

Cause of error

- A spindle drive was supposed to be switched on while the guard door was open, although the tool holder was open.
- Internal software error

Error correction

- Check the wiring
- Check the software version
- Inform your service agency


Error description 231-A095

Error message

A095 Spindle drive lock, status of permissive button invalid

Cause of error

- A spindle drive was supposed to be switched on while the guard door was open, although the permissive button is not pressed or was not let go beforehand.
- Internal software error

Error correction

- Check the wiring
- Check the software version
- Inform your service agency


Error description 231-A096

Error message

A096 Spindle drive lock, operating mode is not allowed

Cause of error

- A spindle drive was supposed to be switched on while the guard door was open, although the keylock switch was in the 'BA1' position ('unqualified operator').
- Internal software error

Error correction

- Check the keylock switch position
- Check the wiring
- Check the software version
- Inform your service agency


Error description 231-A097

Error message

A097 Drive lock on spindle, SS2 reaction active

Cause of error

- A spindle drive was supposed to be switched on while the guard door was open, although a stop2 reaction is active for the spindle.
- Internal software error

Error correction

- Check the software version
- Inform your service agency


Error description 231-A098

Error message

A098 Drive lock on spindle, STO is active

Cause of error

- A spindle drive was supposed to be switched on while the guard door was open, although the STO safety function (safely switched-off torque) is still active.
- Internal software error

Error correction

- Check the software version
- Inform your service agency


Error description 231-A099

Error message

A099 CC%2 Drive lock - non-deletable system error

Cause of error

- Drive switch-on was prevented because a non-deletable system error occurred.

Error correction

- Check the cause of the system error (see log entry) and correct if if possible.
- Inform your service agency


Error description 231-A200

Error message

A200 Brake test is not allowed %1

Cause of error

- Drive ready signal (RDY signal) or inverter enabling signal is missing.
- Protective door(s) are not closed, although the parameter settings require it.
- The brake to be tested is not assigned to this drive

Error correction

- Check the inverter enabling signals (wiring, PLC program or SPLc program)
- Close the protective door(s)
- Check the parameter settings, and edit them if necessary.
- Inform your service agency


Error description 231-A210

Error message

A210 Faulty control of brake %1: Step %4

Cause of error

- Incorrect signal level at the FS input: "-T.BRK.B" during brake control test
Test step 2 = Release brake through B channel output: +24 V detected although T.BRK should provide 0 V
Test step 3 = Release brake through A channel output: +24 V detected although T.BRK should provide 0 V
Test step 4 = Release brake through A and B channel outputs: 0 V detected although T.BRK should provide +24 V

Error correction

- Check external wiring of the motor brake
- Generate the service files and notify the service agency


Error description 231-A800

Error message

A800 CC limit switch %1+

Cause of error

The permissible positive traverse range (machine parameter CfgAxParSafety/absLimitPos) was exceeded.

Error correction

- Check the value of the positive software limit switch and correct it if necessary: Machine parameter CfgPositionLimits/swLimitSwitchPos
- Check the traverse direction of the axis and correct it if necessary: Machine parameters CfgAxisHardware/signCorrActualVal and CfgAxisHardware/signCorrNomVal
and the DIR column from the motor table or machine parameter CfgServoMotor/motDir
- Inform your service agency


Error description 231-A810

Error message

A810 CC limit switch %1-

Cause of error

The permissible negative traverse range (machine parameter CfgAxParSafety/absLimitNeg) was exceeded.

Error correction

- Check the value of the negative software limit switch and correct it if necessary: Machine parameter CfgPositionLimits/swLimitSwitchNeg
- Check the traverse direction of the axis and correct it if necessary: Machine parameters CfgAxisHardware/signCorrActualVal and CfgAxisHardware/signCorrNomVal
and the DIR column from the motor table or machine parameter CfgServoMotor/motDir
- Inform your service agency


Error description 231-A820

Error message

A820 CC speed greater than SRG %1

Cause of error

The maximum permissible velocity in the SRG operating mode was exceeded.

Error correction

- Reduce the feed rate and shaft speed before opening the safety doors
- Check the operating mode (setting of key-operated switch)
- Inform your service agency
- Check the parameter values


Error description 231-A830

Error message

A830 CC SRG rot. speed = 0 %1

Cause of error

- The maximum permissible velocity is 0 (as per parameter)
- Only spindle drive: the parameter values for the gear ranges are 0
- An illegal operating mode was selected by keylock switch
- There is a circuit error, or a disturbance at input I19 of the operator safety module
- Internal software error

Error correction

- Check the operating mode version (position of keylock switch)
- Check the wiring of the operator safety module inputs.
- Check the parameter values
- Inform your service agency


Error description 231-A840

Error message

A840 CC SBH rot. speed too high %1

Cause of error

- The maximal permissible velocity of the standstill monitoring was exceeded.

Error correction

- Inform your service agency
- Check the drive


Error description 231-A850

Error message

A850 CC SBH rot. speed = 0 %1

Cause of error

- Standstill monitoring was set to 0
- Internal software error

Error correction

- Inform your service agency
- Check CfgAxisHardware->transmission (traverse per motor revolution)


Error description 231-A860

Error message

A860 Traverse in SRG too large %1

Cause of error

- The maximum permissible traverse in the SRG operating mode was exceeded because:
- During probing with oriented spindle stop, the spindle axis was moved by more than 2 revolutions.

Error correction

- Check the probing sequence
- Close the protective doors
- Inform your service agency


Error description 231-A870

Error message

A870 Brake test is not allowed %1

Cause of error

- Drive ready signal (RDY signal) or inverter enabling signal is missing.
- Protective door(s) are not closed, although the parameter settings require it.
- The brake to be tested is not assigned to this drive

Error correction

- Check the inverter enabling signals (wiring, PLC program or SPLc program)
- Close the protective door(s)
- Check the parameter settings, and edit them if necessary.
- Inform your service agency


Error description 231-A880

Error message

A880 1st violation of positive software limit range %1

Cause of error

The drive moved into the positive limit-switch range for the 1st time (machine parameter CfgAxParSafety/absLimitPos)

Error correction

- Move the drive out of the positive limit-switch range
- Check the values of the software limit switches and correct them if necessary: Machine parameters CfgPositionLimits/swLimitSwitchNeg and CfgPositionLimits/swLimitSwitchPos
- Check the traverse direction of the axis and correct it if necessary: Machine parameters CfgAxisHardware/signCorrActualVal and CfgAxisHardware/signCorrNomVal
and the DIR column from the motor table or CfgServoMotor/motDir


Error description 231-A890

Error message

A890 1st violation of negative software limit range %1

Cause of error

The drive moved into the negative limit-switch range for the 1st time (machine parameter CfgAxParSafety/absLimitNeg)

Error correction

- Move the drive out of the negative limit-switch range
- Check the values of the software limit switches and correct them if necessary: Machine parameters CfgPositionLimits/swLimitSwitchNeg and CfgPositionLimits/swLimitSwitchPos
- Check the traverse direction of the axis and correct it if necessary: Machine parameters CfgAxisHardware/signCorrActualVal and CfgAxisHardware/signCorrNomVal
and the DIR column from the motor table or CfgServoMotor/motDir


Error description 231-A8A0

Error message

A8A0 CC nominal-to-actual deviation of position values %1

Cause of error

- The safety function nominal/actual value monitoring of position values has ascertained an excessive deviation.
- The motor is moving while the slide is not, or vice versa
- The mechanical motion transmission is interrupted
- Thermal expansion of mechanical transmission components
- The transmission ratio of the motor to the position encoder is incorrect (machine parameter distPerMotorTurn)
- Improper installation of position encoder on ball screw
- The entry in the axis-specific parameter maxPosDiff is defined too small

Error correction

- Check the mechanical motion transmission
- Check the encoder fastening
- Check the thermal expansion of the mechanical transmission components (e.g. recirculating ball screw)
- Check the transmission ratio of the motor to the position encoder
- Check the installation of the position encoder on the ball screw
- Inform your service agency.


Error description 231-A8C0

Error message

A8C0 Drive lock through FS, %1 has not been checked

Cause of error

- Drive locked through functional safety FS
- A non-checked drive moved in an operating mode other than "reference run" while the guard door was open.
- Internal software error

Error correction

- Check the software version
- Inform your service agency


Error description 231-A8D0

Error message

A8D0 SS1 still active—switch-on not allowed %1

Cause of error

The safety software of the controller unit (SKERN-CC) has prevented the drive from being switched back on.
A triggered SS1 stop reaction was not yet fully concluded.

Error correction

- Try to switch the drive on again.
- If the problem recurs: Check the process of the SPLC and PLC program and inform your service agency.


Error description 231-A8E0

Error message

A8E0 Timeout during braking %1

Cause of error

- The maximum permissible time for a controlled stop (SS2 – braking on the contour) was exceeded

Error correction

- Check the parameter values:
timeLimitStop2: Default time for bringing axes to a controlled standstill for SS2 reaction
- Inform your service agency


Error description 231-A8F0

Error message

A8F0 Drive lock %1 - safety function STO is active

Cause of error

- Drive switch-on was prevented because the safety function STO is presently active for this drive.
- The STO safety function could not be exited. Exiting the STO safety function requires the following:
The activation of the axis group through the SPLC program (PP_AxGrpActivate of the associated axis group)
Enabling of the drive by the SPLC program (PP_AxFeedEnable of the associated axis)
The switch-on command of the PLC program (PLC Module 9161)
- If the message appears during the current controller adjustment of the spindle, the "spindle start" key was not pressed before the adjustment was started.

Error correction

- Press the "spindle start" key before the spindle adjustment
- Press the key for moving the axis on the machine control panel for a longer time
- Optimize program processes in the PLC and SPLC program
- Check the SPLC program and correct if necessary
- Inform your service agency


Error description 231-A900

Error message

A900 S traverse range exceeded when braking at contour (SS2) %1

Cause of error

- When braking at a contour (SS2), the maximum permissible path in the safety-related machine parameter distLimitStop2 was exceeded.

Error correction

- Check the parameter value:
distLimitStop2: Axis-specific limit value for maximum permissible path upon SS2 reaction.
- Inform your service agency


Error description 231-A910

Error message

A910 CC Speed/noml. value deviation too large %1

Cause of error

- The actual velocity deviates for longer than the permissible duration
(feed axes: machine parameter timeToleranceSpeed) by the maximum permissible deviation
(feed axes: machine parameter speedDiffNom) from the nominal velocity value.
- Possible causes:
+ Machine parameter "timeToleranceSpeed" is defined too small
+ Machine parameter "speedDiffNom " is defined too small.
+ I component of the speed controller in the machine parameter "vCtrlIntGain" is defined too small.
+ Is the speed encoder cable connected?
+ Motor encoder defective or loose

Error correction

- Check the machine parameter "timeToleranceSpeed"
- Check the machine parameter "speedDiffNom"
- Check the I component of the speed controller machine parameter "vCtrlIntGain"
- Check the speed encoder mounting
- Check the cable of the speed encoder
- Exchange the speed encoder
- Inform your service agency


Error description 231-A920

Error message

A920 Standstill monitoring SKERN-CC %1

Cause of error

- SKERN-CC detected an impermissibly large axis movement
in the SOS safety condition. The standstill speed
(50 mm/min for feed axes or 10 rpm for spindles) was
also exceeded. The maximum permissible path
in the SOS condition is defined in the machine parameter "positionRangeVmin."
Possible causes:
- Machine parameter "positionRangeVmin" is defined too small.
- The brake was deactivated before the position controller was closed.
- The brake was not activated before the position controller was opened.
- When an axis was switched on, some existing following
error was corrected.
- The brake is defective.
- There was an attempt to move an axis in the SOS condition (PLC?)
- The axis feed-rate enabling by the ApiToSafety datum PP_AxFeedEnable is missing.

Error correction

- Check the entry in machine parameter positionRangeVmin.
- Check the sequence of deactivating the brake and closing the position controller.
- Check the sequence of activating the brake and opening the position controller.
- Check whether there is a following error after an axis is locked.
- Check the interface signal of the SPLC PP_AxFeedEnable for the axis
- Inform your service agency


Error description 231-A930

Error message

A930 Safely limited speed (SLS) exceeded %1

Cause of error

- SKERN-CC detected an impermissibly fast axis movement above
the safe reduced speed.
(SLS2,SLS3,SLS4)
Possible causes:
- Guard door was opened (at high speed) during an axis
movement.
- Machine parameter for reduced speed is defined too small.

Error correction

- Check whether the guard door was opened during an
axis movement.
- SLS2: Check the entry in machine parameter "speedLimitSom2."
- SLS3: Check the entry in machine parameter "speedLimitSom3."
- SLS4: Check the entry in machine parameter "speedLimitSom4."
- Inform your service agency.


Error description 231-A940

Error message

A940 Path exceeded during restricted spindle operation %1

Cause of error

In the limited spindle operation, the maximum
permissible path of 2 revolutions was exceeded.

Error correction

- Check the path of the spindle during limited spindle operation.
- Inform your service agency.


Error description 231-A950

Error message

A950 Safely limited increment (SLI) exceeded %1

Cause of error

- The maximum permissible path was exceeded in the
Safely Limited Increment (SLI) mode.
- Possible causes:
- The selected increment exceeds the value from the
safe machine parameter distLimitJog
- The drive overshoots mechanically when the limit position is
reached
- Drive is not optimally adjusted.

Error correction

- Enter a smaller jog increment.
- Check the entry in the safe machine parameter distLimitJog.
- When the jog increment end position is reached, use the
control's internal oscilloscope to check the actual position value for
overshooting.
- Adjust the drive.
- Inform your service agency.


Error description 231-AC00

Error message

AC00 CC amplitude too high %1

Cause of error

- The amplitude of the encoder signal is too high or the signal for contamination is active.
- Incorrect adjustment between head and encoder, air gap too small (exposed encoders)
- Excessive supply voltage

Error correction

- Check the amplitude of the encoder signal
- Inform your service agency


Error description 231-AC10

Error message

AC10 Motor encoder %1 defective

Cause of error

- Motor encoder contaminated or defective
- Cable defective
- Encoder input defective on the control
- Signal connector: Poor contact or penetration of humidity
- Humidity has entered the motor
- No encoder signal available
- Interruption in motor encoder cable
- Signal amplitude of motor encoder is missing or too small

Error correction

- Inform your service agency
- Check the motor encoder connection
- Check the motor encoder
- Check the amplitude of the encoder signal


Error description 231-AC20

Error message

AC20 CC frequency too high %1

Cause of error

- The maximum input frequency was exceeded at an encoder input.
- Noise on motor encoder signal
- Vibrations on the machine

Error correction

- Inform your service agency
- Check the motor encoder connection (ground connection)
- Check the motor encoder
- Check the encoder signal input frequency
- Remove the vibrations


Error description 231-AC30

Error message

AC30 CC ampl. too high %1 (position)

Cause of error

- The amplitude of the position encoder signal is too high
- Fault in the encoder signal
- Short circuit in the encoder cable
- Signal amplitude of encoder is too high

Error correction

- Inform your service agency
- Check the encoder connection (ground connection)
- Check the encoder


Error description 231-AC40

Error message

AC40 Position encoder %1 defective

Cause of error

- Encoder contaminated
- Encoder defective
- Penetration of humidity
- Scanning head misaligned (distance, parallelism, etc.)
- Encoder cabling defective
- Encoder input defective on the control

Error correction

- Inform your service agency
- Check the encoder connection
- Check the encoder


Error description 231-AC50

Error message

AC50 CC freq. too high %1 (position)

Cause of error

- The maximum input frequency was exceeded at a position encoder input.
- Noise on the encoder signal
- Vibrations on the machine

Error correction

- Inform your service agency
- Check the encoder connection (ground connection)
- Check the encoder
- Check the input frequency of the encoder signal.
- Remove the vibrations


Error description 231-B200

Error message

B200 CC%2 No brake test was conducted %2

Cause of error

- MC makes no test of the motor brake(s) although it is configured by machine parameter setting.
- Cannot enable the motor-brake test(s)
- An axis was deselected by PLC module and the corresponding machine parameter for running a brake test for this axis is still set.

Error correction

- Check the machine parameter for conducting a brake test
- Generate the service files and notify the Service Department


Error description 231-B300

Error message

B300 CC%2 No brake line test was conducted %1

Cause of error

- MC (A channel) makes no test of the brake line, although the machine parameter setting requires it.
- Timeout when calling for test of the brake control by the MC.
- An axis was deselected by PLC module, although the corresponding machine parameter for running the brake line test is still set.

Error correction

- Check the machine parameter for testing the brake control or brake test
- Generate the service files and notify the Service Department


Error description 231-B400

Error message

B400 SKERN-CC%2: watchdog error interface

Cause of error

- Internal software error (watchdog low priority cycle)

Error correction

- Inform your service agency


Error description 231-B800

Error message

B800 CC%2 safe inputs %1 not equal

Cause of error

- A safety-related input of the CC is longer than
400 ms unequal to MC
- Different levels at the safety module input:
4 = Acknowledgement of switch-off
8 = Safe reduced velocity of axes/spindle
10 = Safe reduced velocity of auxiliary axes
11 = Operating mode 3(detachable-key switch 1, Pos3)
(safe controlled stop of axes/spindle)
18 = Operating mode 2 (detachable-key switch 1,Pos2)
19 = Operating mode 4 (detachable-key switch 2)
- Wiring error X65, X66, (X67)
– Safety module defective

Error correction

– Check the wiring X65, X66, (X67)
– Exchange the safety module
- Generate the service files and notify the Service Department


Error description 231-B900

Error message

B900 CC%2 supply voltage %1

Cause of error

- The supply voltage Vcc(x) was out of range.
- +4 = undervoltage Vcc(+5 V)
The load from external components (e.g. encoders) is too large.
- +6 = overvoltage Vcc(+5 V)
The power supply unit is defective.
- +14 = undervoltage Vcc(+15 V)
The power supply unit is defective.
- +16 = overvoltage Vcc(+15 V)
The power supply unit is defective.
- -14 = undervoltage Vcc(-15 V)
The power supply unit is defective.
- -16 = overvoltage Vcc(-15 V)
The power supply unit is defective.

Error correction

- Inform your service agency.
- Measure the supply voltage Vcc(x).
- Vcc(+5 V) < +4.75 V Check the encoder connections.
- Vcc(+5 V) > +5.50 V Exchange the power supply unit.
- Vcc(+15 V) < +14.25 V Exchange the power supply unit.
- Vcc(+15 V) > +16.50 V Exchange the power supply unit.
- Vcc(-15 V) < -14.25 V Exchange the power supply unit.
- Vcc(-15 V) > -16.50 V Exchange the power supply unit.


Error description 231-BA00

Error message

BA00 CC%2 operating temperature %1

Cause of error

- Temperature inside the LE was out of permissible range. (-128... 0...+127 = measured temperature value [°C])
- Temperature sensor on board is defective.
- The electrical-cabinet ventilation is insufficient (fan defective).
- The ambient temperature is too high or too low.

Error correction

- Check the ventilation.
- Inform your service agency.


Error description 231-BB00

Error message

BB00 CC%2 MC command %1 to CC software is not allowed

Cause of error

- MC command not permitted for this software variant of the CC
- MC command not permitted at this point in time. Decimal code = low byte of the command code (0...255)
- Internal software error

Error correction

- Check the software version
- Inform your service agency


Error description 231-C000

Error message

C000 No data exchange with MC

Cause of error

- Communication to the MC was interrupted.
- Internal software error.

Error correction

- Inform your service agency.
- Check the software version.


Error description 231-C001

Error message

C001 Undefined error

Cause of error

Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-C002

Error message

C002 MC command invalid

Cause of error

Internal software error

Error correction

- Inform your service agency
- Check the software verion


Error description 231-C003

Error message

C003 System clock MC not = CC%2

Cause of error

- Hardware error (crystal generator)
- Internal software error

Error correction

- Inform your service agency
- Exchange the drive control board or processor board
- Check the software version


Error description 231-C005

Error message

C005 CC hardware is not supported

Cause of error

- The hardware version of the CC controller unit is not supported by installed the NC software
- Power supply module (UV/UVR) interferes with I2C bus

Error correction

- Check the NC software version
- Check/exchange the X69 ribbon cable
- Exchange the power supply module (UV/UVR)
- Inform your service agency


Error description 231-C006

Error message

C006 I-CTRL communication: TIME

Cause of error

- Communication error between speed and current controller.

Error correction

- Inform your service agency.
- Check the software version.


Error description 231-C007

Error message

C007 DC-link voltage too low

Cause of error

- Line power interrupted
- Inverter defective

Error correction

- Check the line power supply
- Inform your service agency
- Check the inverter


Error description 231-C008

Error message

C008 I-CTRL communication: QUEUE

Cause of error

- Communication error between speed and current controller.

Error correction

- Inform your service agency.
- Check the software version.


Error description 231-C009

Error message

C009 Stack overflow

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-C00A

Error message

C00A PWM triangular signal error

Cause of error

- Hardware error: Triangular signal does not oscillate, or it oscillates with incorrect frequency

Error correction

- Inform your service agency
- Exchange the drive control board


Error description 231-C00B

Error message

C00B Too little main memory

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-C00C

Error message

C00C LSV2, incorrect number of data

Cause of error

- The number of LSV2 data to be read is incorrect
- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-C00D

Error message

C00D CC%2 Checksum error in the DSP program code

Cause of error

- A checksum error was discovered in the program code of the CC controller unit
- Defective CC controller unit

Error correction

- Exchange the hardware
- Inform your service agency


Error description 231-C00E

Error message

C00E Controller software timeout

Cause of error

- Internal software or hardware error

Error correction

- Inform your service agency
- Check the software version
- Exchange the drive control board


Error description 231-C00F

Error message

C00F Error in software timer

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-C010

Error message

C010 Bus error in speed controller

Cause of error

- Access violation on controller periphery.

Error correction

- Inform your service agency.
- Exchange the controller board.


Error description 231-C011

Error message

C011 Softw. synchronization err.

Cause of error

- Missing hardware interrupt after DSP start (>900[ms])
- Missing synchronization command of the MC before drive switch-on
- Hardware is defective (MC or CC)

Error correction

- Exchange the hardware (MC or CC)
- Inform your service agency.


Error description 231-C012

Error message

C012 Pos. control cyc. time err.

Cause of error

- MC is providing erroneous cycle time for CC position controller
- Hardware error

Error correction

- Inform your service agency
- Check the configuration datum ipoCycle
- Exchange the drive control board


Error description 231-C013

Error message

C013 PWM frequency error

Cause of error

- The PWM frequency entered in CfgPowerStage->ampPwmFreq is outside the permissible input range
- The selected PWM frequencies must not be combined

Error correction

- Inform your service agency
- Check CfgPowerStage->ampPwmFreq


Error description 231-C014

Error message

C014 Interpolator, PWM invalid

Cause of error

- Invalid relation between interpolator clock pulse and PWM frequency.

Error correction

- Inform your service agency.
- Change the ratio of interpolator clock pulse to PWM frequency.
- For possible ratios see Technical Manual.


Error description 231-C015

Error message

C015 Interpolator, PWM changed

Cause of error

- Interpolator clock pulse or PWM frequency was changed.

Error correction

- Restart the control.


Error description 231-C016

Error message

C016 Double speed not possible

Cause of error

- Control loop on X51 or X52 is defined as 'double speed', although the control loop on X53 or X54 is active
- Control loop on X55 or X56 is defined as 'double speed', although the control loop on X57 or X58 is active (only CC 4xx with 8 control loops)

Error correction

- Inform your service agency
- Define the control loop on X51 or X52 as 'single speed', or deactivate the PWM output X53 or X54
- Define the control loop on X55 or X56 as 'single speed', or deactivate the PWM output X57 or X58 (only CC 4xx with 8 control loops)


Error description 231-C017

Error message

C017 PWM frequency too high

Cause of error

- For a single-speed control loop, in configuration datum ampPwmFreq the double PWM basic frequency, and in iCtrlPwmType one-half of the current controller cycle time has been set.

Error correction

- Inform your service agency
- Check the configuration datum ampPwmFreq and iCtrlPwmType
- Use a double-speed control loop instead of single-speed


Error description 231-C018

Error message

C018 Master-slave torque: Axis assignment incorrect

Cause of error

- The axis in master-slave torque control are permissible only at X15/X17 or X16/X18.

Error correction

- Inform your service agency.
- Change the axis assignment.


Error description 231-C020

Error message

C020 Faulty Include file

Cause of error

- The MC and CC software were not compiled with the same Include file.

Error correction

- Check the software version and reload if necessary
- Inform your service agency


Error description 231-C021

Error message

C021 Wrong DSP version

Cause of error

- The MC and CC software were not compiled with the same Include file.

Error correction

- Inform your service agency
- Check the software version and reload if necessary


Error description 231-C022

Error message

C022 SMB or SPL configuration error

Cause of error

- Configuration error in the HSCI system
- Configuration error in the safe machine operating panel MB 6xx S or a safe PL 6xxx S
- A new device type has been connected that is not yet supported by the current CC software
- Error in the MC's configuration data to the CC

Error correction

- Software update
- Inform your service agency


Error description 231-C023

Error message

C023 IRQ stack overflow

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-C025

Error message

C025 CC-CC communication, CRC error

Cause of error

- An HSCI station causes an offset error
- Incorrect message size by MC

Error correction

- Software update
- Inform your service agency


Error description 231-C026

Error message

C026 CC-CC communication, watchdog error

Cause of error

- An HSCI station causes an offset error
- Incorrect message size by MC
- Message transmission canceled

Error correction

- Software update
- Exchange the PL 6xxx S
- Inform your service agency


Error description 231-C027

Error message

C027 HSCI message is missing

Cause of error

- HSCI message (low-prio) is missing
- An HSCI station causes an error
- Message list in MC is faulty

Error correction

- Check the HSCI devices
- Software update
- Inform your service agency


Error description 231-C028

Error message

C028 MC acknowledgment is missing

Cause of error

- An HSCI message from the CC to the MC was not acknowledged

Error correction

- Software update
- Inform your service agency


Error description 231-C02B

Error message

C02B Watchdog error for machine operating panel

Cause of error

- Watchdog of the MB 6xx S was not retriggered
- Hardware error on the MB 6xx S

Error correction

- Exchange the MB 6xx S
- Inform your service agency


Error description 231-C02C

Error message

C02C Watchdog error for PL / SPL assembly

Cause of error

- Watchdog module of a PL assembly was not re-triggered correctly
- Firmware error in PL/SPL assembly
- Hardware error in PL/SPL assembly

Error correction

- Check PL and SPL assemblies in HSCI bus diagnosis
- Check the control software version
- Exchange defective PL/SPL assembly (bus diagnosis)
- Inform your service agency


Error description 231-C02D

Error message

C02D Watchdog error, HSCI module

Cause of error

- HSCI module of the CC is defective
-> HSCI messages cannot be received any longer
-> The watchdog is not retriggered any longer
- HSCI cable defective

Error correction

- Check the connection of the HSCI cable
- Check/replace the HSCI cable
- Exchange the CC
- Inform your service agency


Error description 231-C02E

Error message

C02E CC firmware update required

Cause of error

- An update of the firmware is required because of a hardware or software exchange

Error correction

- Inform your service agency


Error description 231-C02F

Error message

C02F Error during control start up

Cause of error

- Internal software error in the MC, CC or an HSCI participant (RunUp)

Error correction

- Inform your service agency


Error description 231-C030

Error message

C030 Alarm with supply voltages CC%2

Cause of error

- The internal supply voltages of the CC are outside of the specified range. Please pay attention to the diagnostic message "0xC038 voltage monitoring"!

Error correction

- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Check the supply voltages on the CC:
- Check the wiring of X69
- Cable length at X69 within specification?
- Exchange the cable on X69
- Exchange the hardware
- Inform your service agency


Error description 231-C031

Error message

C031 Alarm with supply voltages

Cause of error

The supply voltages on a device in the HSCI line are outside of the specified range.
The HSCI bus diagnosis indicates which HSCI component triggered the error. Possible devices:
- MC main computer
- PL inputs/outputs
- MB machine operating panel
- Other CC in the HSCI line
Possible causes:
- Insufficient power supply to the devices
- Short circuit in the power supply
- Short circuit in PL inputs and outputs

Error correction

- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Check the wiring for possible short circuits (e.g., PLC inputs or outputs)
- Exchange the hardware
- Inform your service agency


Error description 231-C032

Error message

C032 System clock of the MC less than CC%2

Cause of error

- MC main computer or CC controller unit is defective.

Error correction

- Inform your service agency.


Error description 231-C033

Error message

C033 System clock of the MC greater than CC%2

Cause of error

- MC main computer or CC controller unit is defective.

Error correction

- Inform your service agency.


Error description 231-C034

Error message

C034 CC%2 self test in S status faulty

Cause of error

- The MC did not correctly end the the self text of the S status signals.
- Internal software error

Error correction

- Check the software version
- Inform your service agency


Error description 231-C035

Error message

C035 CC%2 S status test: invalid test sequence

Cause of error

- During the S status test, the MC did not follow the operational sequence of this test
- Internal MC software error

Error correction

- Inform your service agency


Error description 231-C036

Error message

C036 CC%2 S status test: invalid signal

Cause of error

- During the S status test, the MC requested an unknown or unsupported signal
- Internal MC software error

Error correction

- Inform your service agency


Error description 231-C037

Error message

C037 CC%2 S status test with drives switched on

Cause of error

- The MC requested an S status test while axes are in closed-loop control
- The PLC program initiated the self-test of the control (PLC Module 9144) while axes are still in closed-loop control.
- Internal MC software error

Error correction

- Check the PLC program and correct if necessary.
- Inform your service agency


Error description 231-C038

Error message

C038 Voltage monitoring CC%2 voltage ID: %4

Cause of error

- The voltage monitoring of the CC supply voltage reports an error in the CC displayed.
- The cause of the error message could be the 5 V power supply of the CCs over the power bus (X69). With large line lengths on the power bus, the 5 V power supply may have to be wired additionally over X74. (Use short line lengths
and large line cross section, and check voltage drops on lines between X74.)
- Defective power supply unit in the supply module (5 V power pack in the UV).

Error correction

- Establish a 5 V supply between the supply module and the CCs via X74
- Check the 5 V power supply (usually on supply module X74)
- Check the 5 V power supply on all CCs (X74/CC)
- Check the supply bus (X69)
- Check the wiring:
- Wiring of the supply bus (X69)
- Wiring of the 5 V supply (X74)
- Check the cable length of the supply bus (X69),
if necessary use double lines
- Check the 5 V supply voltage at X74 of all CCs
if necessary, increase the wire cross sections or reduce the cable length
- Check the voltage attenuation on the cable between X74 on the
supply module and X74 on the CCs
- Exchange the power supply
- Exchange defective hardware (CC)
- Inform your service agency, stating the alarm number and Voltage ID


Error description 231-C039

Error message

C039 Hardware error CC%2 assembly ID: %4

Cause of error

- Hardware error found on the CC controller unit.

Error correction

- Exchange the defective hardware/CC
- Read out the log
- Inform your service agency


Error description 231-C03B

Error message

C03B Watchdog error for machine operating panel

Cause of error

- Internal error: Watchdog module of machine operating panel was not re-triggered correctly
- Firmware error in MB 6xx machine operating panel
- Hardware error in MB 6xx machine operating panel

Error correction

- Check the information about the MB 6xx machine operating panel in the bus diagnostics
- Check the version of the NC software
- Exchange the machine operating panel
- Inform your service agency


Error description 231-C03C

Error message

C03C Watchdog error for PL / SPL assembly

Cause of error

- Watchdog module of a PL assembly was not re-triggered correctly
- Firmware error in PL/SPL assembly
- Hardware error in PL/SPL assembly

Error correction

- Check PL and SPL assemblies in HSCI bus diagnosis
- Check the control software version
- Exchange defective PL/SPL assembly (bus diagnosis)
- Inform your service agency


Error description 231-C110

Error message

C110 Unknown motor type %1

Cause of error

- Error in motor table.
- Internal software error.

Error correction

- Inform your service agency.
- Check motor table.
- Check the software version.


Error description 231-C140

Error message

C140 Pole pair no. too large %1

Cause of error

- Incorrect entry in motor table

Error correction

- Inform your service agency
- Check the motor table


Error description 231-C150

Error message

C150 Field current error %1

Cause of error

- Incorrect entry in motor table

Error correction

- Inform your service agency
- Check the motor table


Error description 231-C160

Error message

C160 Grating per. motor enc. %1

Cause of error

- Measured grating period does not agree with the entry in the motor table

Error correction

- Inform your service agency
- Check the motor table (line count)
- Check the motor


Error description 231-C170

Error message

C170 Rotor time constant err. %1

Cause of error

- The rotor time constant calculated from the rotor table is invalid

Error correction

- Inform your service agency
- Check the motor table


Error description 231-C180

Error message

C180 Rated speed error %1

Cause of error

- Incorrect entry in motor table

Error correction

- Inform your service agency
- Check the motor table


Error description 231-C1D0

Error message

C1D0 Current sensor voltage %1

Cause of error

- Incorrect entry in power module

Error correction

- Inform your service agency
- Check the power module table


Error description 231-C1E0

Error message

C1E0 Imax of power module %1

Cause of error

- Incorrect entry in power module table

Error correction

- Inform your service agency
- Check the power module table


Error description 231-C210

Error message

C210 Tmax of motor table %1

Cause of error

- Incorrect temperature entry in motor table

Error correction

- Inform your service agency
- Check the motor table


Error description 231-C240

Error message

C240 Rated I of power module %1

Cause of error

- Incorrect entry in power module table

Error correction

- Inform your service agency
- Check the power module table


Error description 231-C250

Error message

C250 Rated I of motor %1

Cause of error

- Incorrect entry in motor table

Error correction

- Inform your service agency
- Check the motor table


Error description 231-C260

Error message

C260 Imax of motor %1 error

Cause of error

- Incorrect entry in motor table

Error correction

- Inform your service agency
- Check the motor table


Error description 231-C270

Error message

C270 Nmax of motor %1 error

Cause of error

- Incorrect entry in motor table

Error correction

- Inform your service agency
- Check the motor table


Error description 231-C280

Error message

C280 Field angle %1 error

Cause of error

Incorrect entry in CfgServoMotor->MotFieldAngleAdapStartSpeed or CfgServoMotor->MotFieldAngleAdapMaxAngle

Error correction

- Inform your service agency.
Check CfgServoMotor->MotFieldAngleAdapStartSpeed or CfgServoMotor->MotFieldAngleAdapMaxAngle.


Error description 231-C290

Error message

C290 Uz %1 error

Cause of error

- Incorrect entry in CfgPowerStage->ampBusVoltage (dc-link voltage Uz)

Error correction

- Inform your service agency.
- Check the entry CfgPowerStage->ampBusVoltage.


Error description 231-C2A0

Error message

C2A0 Encoder input %1

Cause of error

Incorrect entry in CfgAxisHardware->selectEncoderIn (speed encoder).
Internal software error.

Error correction

Inform your service agency.
Check the entry in CfgAxisHardware->selectEncoderIn.
Check the software version.


Error description 231-C2B0

Error message

C2B0 PWM output %1

Cause of error

- Incorrect entry in parameter "CfgAxisHardware->analogOutput" (nominal speed value output).
- Internal software error.

Error correction

- Internal software error.
- Check parameter "CfgAxisHardware->analogOutput".
- Check the software version.


Error description 231-C2C0

Error message

C2C0 Band-pass parameter %1

Cause of error

- Incorrect entry in CfgSpeedControl->vCtrlFiltDamping1.
- Internal software error.

Error correction

- Inform your service agency.
- Check the entry in CfgSpeedControl->vCtrlFiltDamping1.
- Check the software version.


Error description 231-C2D0

Error message

C2D0 Encoder line count %1

Cause of error

- Encoder line count was changed

Error correction

- Restart the control


Error description 231-C2E0

Error message

C2E0 Motor pole pair number %1

Cause of error

- Motor pole pair number was changed

Error correction

- Restart the control


Error description 231-C2F0

Error message

C2F0 DIR in motor table %1

Cause of error

- DIR in the motor table was changed

Error correction

- Restart the control


Error description 231-C300

Error message

C300 Zn track %1 error

Cause of error

- Motor encoder contaminated or defective
- Cable defective
- Encoder input defective on the control
- Signal connector: Poor contact or penetration of humidity
- Humidity has entered the motor
- No encoder signal available
- Interruption in motor encoder cable
- Signal amplitude of motor encoder is missing or too small

Error correction

- Inform your service agency
- Check the motor encoder connection
- Check the motor encoder
- Check the amplitude of the encoder signal


Error description 231-C310

Error message

C310 Z1 track %1 error

Cause of error

- Motor encoder contaminated or defective
- Cable defective
- Encoder input defective on the control
- Signal connector: Poor contact or penetration of humidity
- Humidity has entered the motor
- No encoder signal available
- Interruption in motor encoder cable
- Signal amplitude of motor encoder is missing or too small

Error correction

- Inform your service agency
- Check the motor encoder connection
- Check the motor encoder
- Check the amplitude of the encoder signal


Error description 231-C330

Error message

C330 Motor temp. too high %1

Cause of error

- Motor encoder cable defective
- Temperature sensor defective
- Signal connector: Poor contact or penetration of humidity
- Humidity has entered the motor

Error correction

- Let the motor cool down
- Inform your service agency
- Check the motor encoder cable
- Measure the temperature sensor


Error description 231-C340

Error message

C340 Unknown counter component %1

Cause of error

- Parameter error at the active axis in machine parameter speedEncoderInput
- Hardware defective (CC)
- Motor encoder defective
- Incorrect software version

Error correction

- Check the machine parameter (speedEncoderInput)
- Check the software version
- Operate the motor at another encoder input
- Exchange the drive control board
- Inform your service agency


Error description 231-C350

Error message

C350 Axis module %1 not ready

Cause of error

- Safety relay not on (e.g. connectors X71 and X72 of the UV, X73 of the HEIDENHAIN expansion board for Simodrive)
- PWM bus cable interrupted
- Interruption in the electrical cabinet
- Defective axis module
- PWM interface on the control defective
- No pulse release for the axis module
- Uz too high
- 5V power supply too weak
- Inverter not ready
- Motor control board defective
- PWM cable defective
- Noise signals

Error correction

- Inform your service agency
- Check the control and cabling of the pulse release
- Check Uz
- If the power supply is not regenerative, is the braking resistor connected?
- If the power supply is regenerative, is the energy recovery activated?
- Check the cable ground and shield
- Exchange the power module
- For P controls, exchange the interface card
- Exchange the motor control board


Error description 231-C370

Error message

C370 Angle error motor encdr. %1

Cause of error

- Wrong commutation angle at reference position
- Motor encoder defective
- Motor encoder replaced
- Cable of motor encoder defective
- Signal connector: Poor contact or penetration of humidity
- Humidity has penetrated the motor
- CC controller unit is defective

Error correction

- Reset or check the commutation angle
- Replace the encoder
- Check motor encoder and leads
- Exchange the CC controller unit
- Inform your service agency


Error description 231-C380

Error message

C380 Motor %1 not controllable

Cause of error

- Motor encoder cable defective
- Motor defective
- I2t monitoring has responded
- Signal connector: Poor contact or penetration of humidity
- Humidity has entered the motor
- Motor brake is on

Error correction

- Check the motor cabling
- Inform your service agency
- Check the motor and the motor encoder cabling
- Check the motor table entry
- Check I2t monitoring


Error description 231-C390

Error message

C390 Error in 3-D touch probe %1

Cause of error

- Internal software error
- Hardware error on drive control board

Error correction

- Check the software version
- Exchange the drive control board
- Inform your service agency


Error description 231-C3A0

Error message

C3A0 Incorrect ref. position %1

Cause of error

- Incorrect motor selected
- Grounding error on motor encoder cable (disturbance on reference signal line)
- Motor encoder defective

Error correction

- Inform your service agency
- Check the motor selection
- Check the cabling of the motor encoder (grounding)
- Exchange the motor


Error description 231-C3B0

Error message

C3B0 Motor %1 does not run under max. current

Cause of error

- Motor locked or blocked
- Inverter defective
- Motor defective
- Wrong motor addressed
- Assignment of PWM outputs entered incorrectly
- Motor power cables mismatched
- Motor encoder cable mismatched
- Incorrect motor connection
- The motor is loaded with the maximum torque

Error correction

- Check the inverter and exchange it if necessary
- Inspect the motor and cabling
- Check the motor load
- Check whether the shaft can run freely
- Check the machine parameters
- Inform your service agency


Error description 231-C3C0

Error message

C3C0 Motor current %1 too high

Cause of error

- Incorrect current controller parameters
- Incorrect parameters in the motor table
- Power module defective
- Motor cable defective
- Motor defective
- Humidity has entered the motor
- Motor control board defective

Error correction

- Inform your service agency
- Are the correct motor and power module selected?
- Check the current control adjustment
- Check the motor and motor cable for a short circuit
- Exchange power module or drive control board


Error description 231-C3D0

Error message

C3D0 PWM component defective %1

Cause of error

- Internal hardware error

Error correction

- Inform your service agency
- Exchange the drive control board


Error description 231-C3E0

Error message

C3E0 Err. in rated U of motor %1

Cause of error

- Motor rated voltage outside of permitted input range

Error correction

- Inform your service agency
- Check the entry in the motor table


Error description 231-C3F0

Error message

C3F0 EnDat not found %1

Cause of error

- EnDat communication error
- Motor encoder contaminated or defective
- Signal cable defective
- Encoder input defective on the control
- Signal connector: Poor contact or penetration of humidity
- Humidity has entered the motor

Error correction

- Inform your service agency
- Check the motor table (SYS column)
- Exchange the motor control board (or better, the control)
- Check the speed encoder cable (defective or too long)
- Check the speed encoder
- Check the cable ground and shield


Error description 231-C400

Error message

C400 Line count incorrect %1

Cause of error

- Line count from the motor table does not match the downloaded values

Error correction

- Inform your service agency
- Check configuration data for linear distance of one motor revolution and distance for the number of signal periods.
- Check the motor table (columns TYPE and STR).
- Check the speed encoder


Error description 231-C410

Error message

C410 Rotor position %1 undefined

Cause of error

- Signal cable defective
- Motor encoder contaminated or defective
- Encoder input defective on the control
- Signal connector: Poor contact or penetration of humidity- Humidity has entered the motor
- Motor control board defective

Error correction

- Inform your service agency
- Exchange the motor
- Check the speed encoder cable
- Exchange the motor control board (or better, the control)


Error description 231-C420

Error message

C420 Uncontrollability %1 caused by incorrect parameters

Cause of error

- Feedforward-control parameters are set incorrectly (acceleration, friction)
- Excessive acceleration
- Controller parameters are set incorrectly (Ki, Kp, Kd)
- Filters set incorrectly (band rejection, low pass)
- Inverter is defective (IGBT)
- Incorrect motor selected in motor table

Error correction

- Inform your service agency
- Check the adjustment of the axes
- Check the inverter


Error description 231-C430

Error message

C430 Error of position input %1

Cause of error

- Position encoder input does not exist.
- Position encoder input is not correctly connected.
- Position encoder input is defective.

Error correction

- Inform your service agency.
- Install the position encoder input.
- Check the connection of the position encoder input.
- Exchange the position encoder input.


Error description 231-C440

Error message

C440 PWM frequency %1 incorrect

Cause of error

- PWM frequency within a control group is incorrect

Error correction

- Inform your service agency
- Check configuration data (PWM frequency)
- PWM frequency > 5000 Hz only with suitable hardware and only with PWM outputs X51, X52, X57 and X58.
- PWM frequency <= 5000Hz must be identical within the control groups.
- PWM frequency > 3200 Hz


Error description 231-C450

Error message

C450 Wrong encoder %1

Cause of error

- Incorrect entry in motor table column SYS.
- Speed encoder cable defective.
- Speed encoder defective.
- Motor control board defective.

Error correction

- Inform your service agency.
- Check the motor table (column SYS).
- Check the motor encoder cable.
- Exchange the motor.
- Exchange the motor control board.


Error description 231-C460

Error message

C460 Motor speed too high %1

Cause of error

- Motor cannot be servocontrolled.

Error correction

- Inform your service agency.
- Check the software version.


Error description 231-C470

Error message

C470 No nominal speed values %1

Cause of error

- Internal software error
- Position controller cycle time too short

Error correction

- Inform your service agency
- Check the software version
- Check the configuration datum CfgCycleTimes->ipoCycle


Error description 231-C480

Error message

C480 V/Hz control mode with encoder %1

Cause of error

- In the motor table, volts-per-hertz control mode is set (STR == 0), but a motor encoder is indicated (SYS <> 0)

Error correction

- Correct the encoder entry in the motor table
- Inform your service agency


Error description 231-C4A0

Error message

C4A0 Inverter %1 is not active

Cause of error

- Charging contactor and main contactor on the supply unit is not on (e.g. connector X70 on UV)
- Safety relay not on (e.g. connectors X71 and X72 of the UV, X73 of the HEIDENHAIN expansion board for Simodrive)
- PWM bus cable interrupted
- Interruption in the electrical cabinet (unit bus, PWM ribbon cable)
- Defective inverter, (supply unit and/or power modules, compact inverter)
- Inverter switched off (PLC, SH1)
- Inverter defective
- Motor defective
- Humidity has entered the motor
- Incorrect motor selected in motor table
- Motor power cables mismatched
- Motor connected incorrectly

Error correction

- Inform your service agency
- Check the inverter and wiring
- Check the motor and wiring


Error description 231-C4C0

Error message

C4C0 No motor current %1

Cause of error

- Motor connected incorrectly or not at all (contactor)
- Inverter defective
- Motor defective
- Incorrect motor selected in motor table
- Motor power cables mismatched
- DC-link voltage missing

Error correction

- Check the connection of the DC link
- Check the motor and wiring
- Check the inverter
- Inform your service agency


Error description 231-C4D0

Error message

C4D0 Error in torque constant %1

Cause of error

- If the value for the torque constant is 0 or >9999, it can have the following causes:
1) Motor.mot: No-load voltage and/or rated rpm have an invalid value (or 0)
2) Motor.sn: The entry for the torque constant is 0 or >9999

Error correction

- Check the motor table


Error description 231-C4E0

Error message

C4E0 Field angle determination %1 is not allowed in this mode

Cause of error

- The selected process for determining the field angle is invalid or impossible with this encoder.

Error correction

- Inform your service agency.
- Check the entry in the SYS column of the motor table (see Technical Manual).


Error description 231-C4F0

Error message

C4F0 Command not allowed

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-C500

Error message

C500 CfgSpeedControl->vCtrlDiffGain %1 too large

Cause of error

- Differential factor is too large (max. value 0.5 [As^2/rev])

Error correction

- Inform your service agency


Error description 231-C510

Error message

C510 Drive release %1 not allowed

Cause of error

- During readout of the electronic ID label the power module must not be in the "ready" status (-SH1 is inactive).

Error correction

- Inform your service agency
- Check the software version


Error description 231-C520

Error message

C520 Timeout in position controller %1

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-C530

Error message

C530 Timeout in speed controller %1

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-C540

Error message

C540 Timeout in current controller %1

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-C550

Error message

C550 Error in calculation of current %1

Cause of error

- This is an internal software error
- Incorrect parameters of the filter in the controller (e.g. bandwidth of the band-rejection filter is very large or the bandwidth = 0 at high center frequency)

Error correction

- Check the machine parameters of the filter for control
- Set the bandwidth of band-rejection filter (machine parameter vCtrlFiltBandWidth) to a value unequal to 0
- Inform your service agency.


Error description 231-C560

Error message

C560 Param. filter 1 invalid %1

Cause of error

- Incorrect entry in CfgSpeedControl->vCtrlFiltDamping1, CfgSpeedControl->vCtrlFiltFreq1 oder CfgSpeedControl->vCtrlFiltType1
- This is an internal software error

Error correction

- Inform your service agency
- Check entries in CfgSpeedControl->vCtrlFiltDamping1, CfgSpeedControl->vCtrlFiltFreq1 or CfgSpeedControl->vCtrlFiltType1
- Check the software version


Error description 231-C570

Error message

C570 Param. filter 2 invalid %1

Cause of error

- Incorrect entry in CfgSpeedControl->vCtrlFiltDamping2, CfgSpeedControl->vCtrlFiltFreq2 or CfgSpeedControl->vCtrlFiltType2
- This is an internal software error

Error correction

- Inform your service agency
- Check entries in CfgSpeedControl->vCtrlFiltDamping2, CfgSpeedControl->vCtrlFiltFreq2 or CfgSpeedControl->vCtrlFiltType2
- Check the software version


Error description 231-C580

Error message

C580 Param. filter 3 invalid %1

Cause of error

- Incorrect entry in CfgSpeedControl->vCtrlFiltDamping3, CfgSpeedControl->vCtrlFiltFreq3 or CfgSpeedControl->vCtrlFiltType3
- This is an internal software error

Error correction

- Inform your service agency
- Check entries in CfgSpeedControl->vCtrlFiltDamping3, CfgSpeedControl->vCtrlFiltFreq3 or CfgSpeedControl->vCtrlFiltType3
- Check the software version


Error description 231-C590

Error message

C590 Param. filter 4 invalid %1

Cause of error

- Incorrect entry in CfgSpeedControl->vCtrlFiltDamping4, CfgSpeedControl->vCtrlFiltFreq4 or CfgSpeedControl->vCtrlFiltType4
- This is an internal software error

Error correction

- Inform your service agency
- Check entries in CfgSpeedControl->vCtrlFiltDamping4, CfgSpeedControl->vCtrlFiltFreq4 or CfgSpeedControl->vCtrlFiltType4
- Check the software version


Error description 231-C5A0

Error message

C5A0 Param. filter 5 invalid %1

Cause of error

- Incorrect entry in CfgSpeedControl->vCtrlFiltDamping5, CfgSpeedControl->vCtrlFiltFreq5 or CfgSpeedControl->vCtrlFiltType5
- This is an internal software error

Error correction

- Inform your service agency
- Check entries in CfgSpeedControl->vCtrlFiltDamping5, CfgSpeedControl->vCtrlFiltFreq5 or CfgSpeedControl->vCtrlFiltType5
- Check the software version


Error description 231-C5B0

Error message

C5B0 Illegal reference run of motor encoder %1

Cause of error

- A touch-probe cycle is active while a reference value is requested by the motor encoder.

Error correction

- Inform your service agency


Error description 231-C5C0

Error message

C5C0 Illegal reference run of position encoder %1

Cause of error

- A touch-probe cycle is active while a reference value is requested by the position encoder.

Error correction

- Inform your service agency


Error description 231-C5E0

Error message

C5E0 Machine parameter compIpcJerkFact is faulty

Cause of error

- On the CC 424, the input range for "compIpcJerkFact" (following error in the jerk phase) is 0.0 to 0.5.

Error correction

- Inform your service agency
- Check the input value in the parameter "compIpcJerkFact"


Error description 231-C5F0

Error message

C5F0 Wrong position-encod. input

Cause of error

- An incorrect input was selected for the position encoder ("posEncoderInput" parameter)
- Possible configurations CC424:
6 control loops: X201 to X206
8 control loops: X201 to X208
10 control loops: PWM outputs X51 to X56: X201 to X206
PWM outputs X57 to X60: X207 to X210
12 control loops: PWM outputs X51 to X56: X201 to X206
PWM outputs X59 to X64: X209 to X214
14 control loops: PWM outputs X51 to X58: X201 to X208
PWM outputs X59 to X64: X209 to X214
16 control loops: PWM outputs X51 to X58: X201 to X208
PWM outputs X59 to X66: X209 to X216
- Possible configuration CC61xx:
PWM output <-> position encoder
X51 <-> X201
X52 <-> X202
X53 <-> X203
X54 <-> X204
X55 <-> X205
X56 <-> X206

Error correction

- Inform your service agency
- Check the configuration datum posEncoderInput


Error description 231-C600

Error message

C600 Current offset %1 is too large

Cause of error

- The current offset of the power stage is too large

Error correction

- Inform your service agency
- Check/replace the PWM cable
- Replace the power module
- PWM output to CC is defective


Error description 231-C610

Error message

C610 TRC: PWM freq. too high %1

Cause of error

- The axis for which the torque ripple compensation was activated through MP2260.x is being driven with a PWM frequency of more than 5000 Hz.

Error correction

- Inform your service agency
- Adjust the PWM frequency for the axis to a value less than or equal to 5000 Hz
- To deactivate the compensation, delete the entry in MP2260.x


Error description 231-C620

Error message

C620 TRC: Invalid parameter %1

Cause of error

- Invalid parameters in the compensation file of the axis

Error correction

- Inform your service agency
- Find again the compensation parameters with TNCopt under Optimization/Torque Ripple Compensation
- To deactivate the compensation, delete the entry in MP2260.x


Error description 231-C640

Error message

C640 PIC switching not possible in %1

Cause of error

- The nominal value(S in inverter.inv) changed
- after DSP start, or
- after the current controller adjustment is started, or
- after the readiness of the power module is switched.

Error correction

- Check the LT entry (configuration datum ampName) in the machine configuration
- Check the nominal value of the PICS (the S column in in inverter.inv)
- If necessary, change the PWM frequency (to >= 5 kHz)
- If necessary, replace the power module


Error description 231-C650

Error message

C650 No ENDAT interpolation factor %1

Cause of error

- No ENDAT interpolation factor received by MC
- This is an internal software error

Error correction

- Check the software version
- Inform your service agency


Error description 231-C660

Error message

C660 Timeout in position controller %1

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-C670

Error message

C670 Motor encoder: EnDat 2.2 not possible %1

Cause of error

- EnDat communication is defective
- An encoder with EnDat 2.2 interface is selected in the motor table, although no EnDat 2.2 encoder is connected
- The EnDat 2.2 protocol cannot be read
- The EnDat measuring system has too low an interpolation rate in EnDat2.2 mode (less than 1024, e.g. EQN 1325). Operation possible only in EnDat2.1 mode

Error correction

- Check whether the encoder supports EnDat 2.2
- Check the motor table (SYS column)
- Check the configuration datum motEncType
- Check the cable ground and shield
- Check the cable (compare the cable ID number with the documentation)
- Check the speed encoder cable (defective or too long)
- Check the speed encoder
- Change EnDat mode (motEncType)
- Exchange the motor control board
- Inform your service agency


Error description 231-C680

Error message

C680 Position encoder: EnDat 2.2 not possible %1

Cause of error

- EnDat communication is defective
- An encoder with EnDat 2.2 interface is selected in posEncoderType, although no EnDat 2.2 encoder is connected
- The EnDat 2.2 protocol cannot be read

Error correction

- Check whether the position encoder supports EnDat 2.2
- Check the configuration datum posEncoderType
- Check the cable ground and shield
- Check the cable (compare the cable ID number with the documentation)
- Check the position encoder cable (defective or too long)
- Check the position encoder
- Change EnDat mode (posEncoderType)
- Exchange the motor control board
- Inform your service agency


Error description 231-C690

Error message

C690 DQ communication error %1

Cause of error

- DRIVE-CLiQ communication is disturbed- DRIVE-CLiQ communication has been interrupted

Error correction

- Inspect the DRIVE-CLiQ cabling
- Inform your service agency


Error description 231-C6A0

Error message

C6A0 Controller software timeout %1 IRQ-ID=%4 BOARD-ID=%2

Cause of error

- The time monitor of the controller software reports an expiration.
- Internal software error

Error correction

- Inform your service agency


Error description 231-C6B0

Error message

C6B0 DQ init error %1 State=%4 ID=%5 Port=%6

Cause of error

- DRIVE-CLiQ initialization error

Error correction

- Evaluation of additional information
- Inform your service agency


Error description 231-C6C0

Error message

C6C0 DQ PWM frequency was changed %1

Cause of error

- With DRIVE-CLiQ devices, switching the PWM frequency with AmpPwmFreq does not become effective until after a reboot.

Error correction

- Acknowledge the error and restart the control.
- Inform your service agency


Error description 231-C6D0

Error message

C6D0 Motor %1 does not react. Power stage not ready

Cause of error

- Motor does not react. Power module is not ready
- The power stage release is faulty
- Inverter is defective
- PWM cable is defective
- Wrong motor selected
- Assignment of PWM outputs entered incorrectly

Error correction

- Check the inverter and exchange it if necessary
- Inspect the motor and the cabling
- Check the motor load
- Check whether the motor can run freely
- Check the machine parameters
- Inform your service agency


Error description 231-C6E0

Error message

C6E0 Amplitude test in axis %1: speed encoder is incorrect, test %4

Cause of error

The internal test of encoder-amplitude monitoring at the speed inputs revealed an error:
Test 1: The test for "Amplitude too low" failed.
Test 2: The test for "Amplitude too high" failed.
- The entry in pwmSignalOutput/analogOffset does not match the wiring of the speed encoders.
- Incorrect entry in machine parameter motEncType (e.g. Z1-track operation selected for EnDat2.2 encoder)
- Speed encoder cable is interrupted, or encoder cable is defective
- Speed encoder is defective
- CC controller unit is defective

Error correction

- Compare/Check the entry in MP pwmSignalOutput/analogOffset to the speed encoder cabling
- Check the entry in machine parameter motEncType
- Check the speed encoder cable / Exchange the cable
- Exchange the speed encoder
- Exchange the CC controller unit
- Inform your service agency


Error description 231-C6F0

Error message

C6F0 Amplitude test in axis %1: pos. encoder is incorrect, test %4

Cause of error

The internal test of encoder-amplitude monitoring at the position inputs revealed an error:
Test 1: The test for "Amplitude too low" failed.
Test 2: The test for "Amplitude too high" failed.
- The entry in posEncoderInput/analogOffset does not match the wiring of the position encoder.
- Incorrect entry in machine parameter posEncodeType (e.g. analog encoder signal selected for digital encoder)
- Position encoder cable is interrupted, or encoder cable is defective
- Position encoder is defective
- CC controller unit is defective

Error correction

- Compare/check the entry in MP posEncoderInput/analogOffset to the position encoder cabling
- Check the entry in machine parameter posEncodeType
- Check the position encoder cable / Exchange the cable
- Exchange the position encoder
- Exchange the CC controller unit
- Inform your service agency


Error description 231-C700

Error message

C700 DQ-ALM: Line power failure %1

Cause of error

- A power phase failure was detected at the DRIVE-CLiQ regenerative module ALM.
- Power voltage supply is disturbed.

Error correction

- Check the protective devices of the line power voltage supply.
- Check the wiring of the line power voltage supply.
- Inform your service agency


Error description 231-C710

Error message

C710 Error in drive switch-off %1

Cause of error

- The drive could not be decelerated to 0 rpm with the time configured in machine parameter vCtrlTimeSwitchOff.
- Possible causes:
- An IGBT of the power module switched off.
- The machine parameter vCtrlTimeSwitchOff is set incorrectly.
- The permissible load was exceeded.

Error correction

- Check the machine parameter vCtrlTimeSwitchOff
- Check the load
- Exchange the CC controller unit
- Inform your service agency


Error description 231-C720

Error message

C720 The software is not suitable for the PLASTIC_INJECTION

Cause of error

PLASTIC_INJECTION commands are not permitted

Error correction

Inform your service agency


Error description 231-C730

Error message

C730 CC%2 CPU0 impermissible data processing

Cause of error

Internal software error: There was an attempt to access an impermissible memory area

Error correction

- Please generate a service file soon, reboot the control, and then generate another service file
- Transmit both service files to the Service department for further inspections by HEIDENHAIN


Error description 231-C740

Error message

C740 CC%2 CPU1 impermissible data processing

Cause of error

Internal software error: There was an attempt to access an impermissible memory area

Error correction

- Please generate a service file soon, reboot the control, and then generate another service file
- Transmit both service files to the Service department for further inspections by HEIDENHAIN


Error description 231-C750

Error message

C750 CC%2 CPU0 impermissible instruction processing

Cause of error

Internal software error: There was an attempt to access an impermissible memory area

Error correction

- Please generate a service file soon, reboot the control, and then generate another service file
- Transmit both service files to the Service department for further inspections by HEIDENHAIN


Error description 231-C760

Error message

C760 CC%2 CPU1 impermissible instruction processing

Cause of error

Internal software error: There was an attempt to access an impermissible memory area

Error correction

- Please generate a service file soon, reboot the control, and then generate another service file
- Transmit both service files to the Service department for further inspections by HEIDENHAIN


Error description 231-C770

Error message

C770 System errors when activating a drive% 1

Cause of error

A drive was switched on that either
- is not active, meaning it is set to inactive in the kinematics configuration, or
- its parameterization has not been completed

Error correction

Inform your service agency


Error description 231-C780

Error message

C780 Error while braking a drive %1

Cause of error

It was not possible to brake the drive when switching off.
An unexpected acceleration of the drive was detected during the braking procedure.
Possible causes:
- Switch-off time is parameterized to be too brief
- Load is too high
- Too much noise in the signals of the speed encoder

Error correction

Remedy:
- Check the machine parameter timeLimitStop1 (system with integrated functional safety (FS)) or delayTimeSTOatSS1 (system with external safety)
- Check the load
- Check the speed encoder
- Inform your service agency


Error description 231-CFF0

Error message

CFF0 Alarm axis CC%2 module=%4 line=%5

Cause of error

- This is an internal software error

Error correction

- Inform your service agency


Error description 231-D000

Error message

D000 CC%2 DP RAM area %1

Cause of error

- Internal software error
1...255 = area number

Error correction

- Inform your service agency.
- Check the software version.


Error description 231-D100

Error message

D100 CC%2 software error %1

Cause of error

- Internal software error
0...255 = code for error in software module/routine

Error correction

- Inform your service agency.
- Check the software version.


Error description 231-D300

Error message

D300 Data transm. SPL to CC, CRC error at HSCI addr.: %1

Cause of error

- HSCI connecting cable is defective or not connected
- Data transmission error in the HSCI system
- A safe PL 6xxx FS is transmitting erroneous data
- Incorrect HSCI message size (MC software)

Error correction

- Check the HSCI connecting cable
- Exchange the safe PL 6xxx FS
- Software update
- Inform your service agency


Error description 231-D400

Error message

D400 Data transm. SPL to CC, watchdog error at HSCI addr.: %1

Cause of error

- Data transmission error in the HSCI system
- A safe PL 6xxx FS is transmitting erroneous data
- The HSCI transmission is disturbed

Error correction

- Software update
- Exchange the PL 6xxx FS
- Inform your service agency


Error description 231-E000

Error message

E000 Start test of the cut-out channels not possible

Cause of error

- Start of the "tests of cutout channels" by PLC not
possible because the control is not in the "AUTO"
condition.
- The motors of at least one axis group are not yet
switched off.

Error correction

- Check the PLC program and correct if necessary.
- Inform your service agency.


Error description 231-E001

Error message

E001 Status NR1/NR2 not equal

Cause of error

- NR2 input incorrectly connected
- Internal software error

Error correction

- Inform your service agency
- Check the wiring
- Check the software version


Error description 231-E002

Error message

E002 Status em.stop input signal not equal to test output: T2

Cause of error

- The signal level of the test output 'T2' differs from that of the 'Emergency Stop' input of the CC.
CC424: '-NE2' signal
CC61xx: '-ES.B' signal

Error correction

- Check the wiring
- Inform your service agency


Error description 231-E003

Error message

E003 PLC module 9169 illegal

Cause of error

- PLC module 9169 in safety-oriented software (illegal)
- Software error

Error correction

- Inform your service agency
- Check the PLC program
- Check the software version


Error description 231-E004

Error message

E004 SH1 status test on active

Cause of error

- The measured status of the '-SH1' signal is 'high' level
- The '-SH1' signal does not change to the 'active' ('low' level) status, although the MC is no longer triggering the corresponding watchdog.

Error correction

- Internal software error
- Hardware defective
- Inform your service agency


Error description 231-E005

Error message

E005 SH1 status test on inactive

Cause of error

- The measured status of the '-SH1' signal is 'low' level
- The '-SH1' signal does not change to the 'inactive' ('high' level) status, although the MC is triggering the corresponding watchdog.

Error correction

- Internal software error
- Hardware defective
- Inform your service agency


Error description 231-E006

Error message

E006 CC%2 input (NE2) not equal to 0

Cause of error

Error in dynamic test of the 2nd emergency-stop loop.
In the dynamic test, O V is expected at input NE2 after no later than 1.5 min. If a voltage of 24 V is present here, this error message appears.

Error correction

- Inform your service agency
- Check the wiring
- Check the emergency-stop button
- Exchange the hardware


Error description 231-E007

Error message

E007 CC%2 S input not equal 0

Cause of error

Error in dynamic test of the 2nd emergency-stop loop.
In the dynamic test, O V is expected at all door contacts and key-operated-switch inputs after no later than 1.5 min. If a voltage of 24 V is present here, this error message appears.

Error correction

- Inform your service agency
- Check the wiring
- Check the door contacts, key-operated switches
- Exchange the hardware


Error description 231-E008

Error message

E008 SRG speed too high

Cause of error

- Safe reduced rotational velocity (SRG) was exceeded
- No standstill in safe controlled stop (SBH) operating mode

Error correction

Inform your service agency


Error description 231-E009

Error message

E009 Incorrect gear range

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-E00A

Error message

E00A Safe machine param. error

Cause of error

- Incorrect CRC checksum found and transferred over SG parameter memory
- Communication error MC <-> CC
- Wrong CC software
- Hardware defect (memory fault)
- Software error

Error correction

- Inform your service agency


Error description 231-E00B

Error message

E00B Cutout channels test error

Cause of error

- Illegal code received for conducting the test.

Error correction

- Inform your service agency
- Internal software error


Error description 231-E00C

Error message

E00C Error in parameter transfer

Cause of error

- Incorrect parameter for analog spindle.
- Software version MC.

Error correction

- Inform your service agency.
- Check the parameter.
- Check the software version.


Error description 231-E00D

Error message

E00D Error in parameter transfer

Cause of error

- Incorrect parameter for analog spindle.
- Software version MC.

Error correction

- Inform your service agency.
- Check the parameter.
- Check the software version.


Error description 231-E00E

Error message

E00E Illegal pulse deletion test

Cause of error

- Command for pulse deletion test was received, although the previous test is not yet finished.

Error correction

- Inform your service agency
- Internal software error


Error description 231-E00F

Error message

E00F Brake test not performed

Cause of error

- MC runs no test of the motor brake(s) although it is necessary according to parameter settings.
- MC does not run the test of the motor brake(s) within 2 seconds.

Error correction

- Inform your service agency


Error description 231-E010

Error message

E010 SH2 status test on active

Cause of error

- The measured status of the '-SH2' signal is 'high' level
- The '-SH2' signal does not change to the 'active' ('low' level) status, although the CC is no longer triggering the corresponding watchdog.

Error correction

- Internal software error
- Hardware defective
- Inform your service agency


Error description 231-E011

Error message

E011 SH2 status test on inactive

Cause of error

- The measured status of the '-SH2' signal is 'low' level
- The '-SH2' signal does not change to the 'inactive' ('high' level) status, although the CC is triggering the corresponding watchdog.

Error correction

- Internal software error
- Hardware defective
- Inform your service agency


Error description 231-E012

Error message

E012 N0 status test on active

Cause of error

- The measured status of the '-N0' signal is 'high' level
- The '-N0' signal does not change to the 'active' ('low' level) status

Error correction

- Software error
- Hardware defective
- Inform your service agency


Error description 231-E013

Error message

E013 N0 status test on inactive

Cause of error

- CCU shut-off signal: -N0 does not switch to high level
- The measured status of the '-N0' signal is 'low' level

Error correction

- Software error
- Hardware defective
- Inform your service agency


Error description 231-E014

Error message

E014 Err. during -N0 signal test

Cause of error

- Change in the level of the CC1 switch-off signal: -N0 is not recognized by the CC0.
- Internal software error
- Hardware error

Error correction

- Check the software version
- Inform your service agency


Error description 231-E015

Error message

E015 CC protective door open in brake test

Cause of error

- The protective doors of the work envelope were opened during the brake test.

Error correction

- Close the protective doors.
- Switch off and then restart the control.
- The switch-off test and brake test will be started automatically.


Error description 231-E018

Error message

E018 CC%2 SPLC alarm ERR-ID=%4 SST0=%5 SST1=%6 OUT=%7

Cause of error

- Error in the SPLC run-time program
Meaning of the alarm ID 100, 101, 102, 104 and 200 to 206:
Internal software error
Meaning of alarm ID 103:
The value of the read-back output with the number "OUT" is
"1", although "0" was commanded by the SPLC for
this output.

Error correction

- Measure for alarm ID 100, 101, 102, 104 and 200 to 206:
Please inform your service agency
- Measure for alarm ID 103:
Check whether the output with the number "OUT" has
a short circuit with +24 V. If this is not the case,
please inform your service agency.
- Inform your service agency.


Error description 231-E019

Error message

E019 CC%2 SPLC configuration error ERR-ID=%4

Cause of error

Alarm ID 1:
- Internal software error
Alarm ID 2:
- Invalid value of machine parameter
CfgSafety.inverseInputNoA, CfgSafety.inverseInputNoB, or
CfgSafety.testInputNo
Alarm ID 3:
- The version of the NC software was changed after the
safety inspection and acceptance of the machine.
- The version of the NC software and the version of the
SplcApiMarker.def file being used that is stored
in the safety-related machine parameter CfgSafety.splcApiVersion
do not match.
Alarm ID 4:
- Permitted number of SPLC markers (1000/2000) was exceeded.
Alarm ID 5:
- Permitted number of SPLC DWORDs (1000/3000) was exceeded.
Alarm ID 6:
- Permitted number of PlcToSPLC transfer markers (64) was exceeded.
Alarm ID 7:
- Permitted number of PlcToSPLC transfer DWORDs (32) was exceeded.
Alarm ID 8:
- Marker transfer area PlcToSPLC is faulty.
Alarm ID 9:
- DWORDs transfer area PlcToSPLC is faulty.

Error correction

Alarm ID 1:
- Inform your service agency
Alarm ID 2:
- Check the values of the machine parameters
CfgSafety.inverseInputNoA, CfgSafety.inverseInputNoB, and
CfgSafety.testInputNo.
Alarm ID 3:
- Transfer the 'SplcApiMarker.def' file appropriate to the
installed NC software version into the SPLC project.
- Enter the value of the constant SPLC_API_VERSION from this
file into the safety-related machine parameter
CfgSafety.splcApiVersion.
- Repeat the safety inspection and acceptance of the machine with
the appropriate comprehensiveness.
Alarm ID 4:
- Check the SPLC program and CfgPlcSafety.splcMarkers
Alarm ID 5:
- Check the SPLC program and CfgPlcSafety.splcDWords
Alarm ID 6 and 8:
- Check the SPLC program and CfgPlcSafety.splcMarkersFromPlc[]
Alarm ID 7 and 9:
- Check the SPLC program and CfgPlcSafety.splcDWordsFromPlc[]


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
200 - Machine parameter axisGroup:
Assigned axis group out of range
201 - Machine parameter axisGroup:
Entered axis group not in use.
202 - Drive type and axis group type do not match.
210 - Permissible number of spindles was exceeded
300 - Machine parameter pwmSignalOutput. Input range exceeded
301 - Machine parameter pwmSignalOutput. The same value was used in two separate entries
400 - Machine parameter timeLimitStop1:
Input range exceeded
401 - Machine parameter timeLimitStop2:
Input range exceeded
600 - Machine parameter distPerMotorTurn:
Input range exceeded
700 - Machine parameter speedLimitSom2, speedLimitSom3, speedLimitSom4, rpmLimitSom2, rpmLimitSom3, rpmLimitSom4:
Permissible velocity limit exceeded
800 - An unknown additional function is activated in the config object CfgSafety
810 - Machine parameter timeToEmStopTest:
Input range exceeded
820 - Machine parameter watchdogTime:
Input range exceeded
900 - Machine parameter brakeAfter:
Entered connective operation is not allowed
901 - Machine parameter brakeAfter:
A connective operation to yourself is not allowed
1000 - Machine parameters plcCount:
PLC / SPLC-MC input range of configured
cycle time has been exceeded
1100 - Machine parameters idleState:
Configuration of subsequent condition after a stop
reaction SS2 is out of the permissible range
1200 - The drive assignment is missing for a safe axis
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
200 - Check the entered value of the axis group
201 - Enter only axis groups that are actually being used
202 - Check the axis group assignment
210 - Check the number of spindles in your system
300 - Check the entity pwmSignalOutput. Input value too large.
301 - Check entity pwmSignalOutput. The same value is in two separate entries.
400 - Check the entered time
Parameter value = maximum permissible time
401 - Check the entered time
Parameter value = maximum permissible time
600 - Check the entered value
700 - Check the value entered in speedLimitSom for axes, rpmLimitSom for spindles
Parameter value = 2 -> SLS_2,
Parameter value = 3 -> SLS_3,
Parameter value = 4 -> SLS_4
800 - Check the entered additional functions
810 - Check the entered time
820 - Check the entered time
900 - Check the input
901 - Check the input
1000 - Check the input (maximum = 30 ms)
1100 - Check the input
1200 - Check the drive assignment
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
200 - Machine parameter axisGroup:
Assigned axis group out of range

Error correction

- Check the ERR ID:
200 - Check the entered value of the axis group
- Inform your service agency


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
201 - Machine parameter axisGroup:
Entered axis group not in use.
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
201 - Enter only axis groups that are actually being used
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
202 - Drive type and axis group type do not match.
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
202 - Check the axis group assignment
- Inform your service agency


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
210 - Permissible number of spindles was exceeded
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
210 - Check the number of spindles in your system
- Inform your service agency


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
300 - Machine parameter pwmSignalOutput. Input range exceeded
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
300 - Check the machine parameter pwmSignalOutput. Input value too large.
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
301 - Machine parameter pwmSignalOutput. The same value was used in two separate entries
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
301 - Check the machine parameter pwmSignalOutput. The same value is entered in two separate entries.
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
400 - Machine parameter timeLimitStop1:
Input range exceeded
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
400 - Check the entered time
Parameter value = maximum permissible time
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
401 - Machine parameter timeLimitStop2:
Input range exceeded
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
401 - Check the entered time
Parameter value = maximum permissible time
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
600 - Machine parameter distPerMotorTurn:
Input range exceeded
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
600 - Check the entered value
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
700 - Machine parameter speedLimitSom2, speedLimitSom3, speedLimitSom4, rpmLimitSom2, rpmLimitSom3, rpmLimitSom4:
Permissible velocity limit exceeded
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
700 - Check the value entered in speedLimitSom for axes, rpmLimitSom for spindles
Parameter value = 2 -> SLS_2,
Parameter value = 3 -> SLS_3,
Parameter value = 4 -> SLS_4
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
800 - An unknown additional function is activated in the config object CfgSafety
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
800 - Check the entered additional functions
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
810 - Machine parameter timeToEmStopTest:
Input range exceeded
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
810 - Check the entered time
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
820 - Machine parameter watchdogTime:
Input range exceeded
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
820 - Check the entered time
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
900 - Machine parameter brakeAfter:
Entered connective operation is not allowed
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
900 - Check the input
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
901 - Machine parameter brakeAfter:
A connective operation to yourself is not allowed
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
901 - Check the input
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
1000 - Machine parameters plcCount:
Input range PLC / SPLC-MC configured
Cycle time was exceeded
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
1000 - Check the input (maximum = 30 ms)
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
1100 - Machine parameters idleState:
Configuration of subsequent condition after a stop
reaction SS2 is out of the permissible range
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
1100 - Check the input
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
1200 - The drive assignment is missing for a safe axis
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
1200 - Check the drive assignment
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data for SKERN are faulty.
The ERR ID provides information on the faulty machine parameter:
1201 - An inactive axis is marked as active in the functional safety environment (FS).
- Faulty parameter values were entered
- An internal software error has occurred

Error correction

- Check the ERR ID:
1201 - Check the axis configuration
- Inform your service agency.


Error description 231-E01A

Error message

E01A CC%2 FS config error SS2 reaction ObjId=%5 Param=%6

Cause of error

The permissible value range for the safe machine parameters distLimitStop2 or rpmLimitSom3AtSS2 was exceeded.
ObjID = Number of the drive with incorrect configuration
Param = Transferred value

Error correction

- Check the entered value
- Inform your service agency


Error description 231-E01A

Error message

E01A CC%2 FS config error SS2 reaction ObjId=%5 Param=%6

Cause of error

The permissible value range for the safe machine parameters distLimitStop2 or rpmLimitSom2AtSS2 was exceeded.
ObjID = Number of the drive with incorrect configuration
Param = Transferred value

Error correction

- Check the entered value
- Inform your service agency


Error description 231-E01A

Error message

E01A CC%2 FS config error SS2 reaction ObjId=%5 Param=%6

Cause of error

The permissible value range for safe machine parameters distLimitStop2 or rpmLimitSom4AtSS2 was exceeded.
ObjID = Number of the drive with incorrect configuration
Param = Transferred value

Error correction

- Check the entered value
- Inform your service agency


Error description 231-E01A

Error message

E01A CC%2 FS configuration error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The transferred configuration data (safe machine parameters) for SKERN contain faulty data.
The ERR-ID describes the error more precisely:
204 – Axis configured as safe axis (i.e. <axisGroup> unequal -1)
But:
The safety-relevant information ("safety bits") is not supported by the speed encoder although the EnDat2.2 mode of the encoder is active and
it is a single-encoder system. This configuration is not permitted for a safe axis.
CC: Number of the CC
ObjId: Drive number (0 <=> X51, 1 <=> X52 etc.)
Param: Axis group (value of the affected MP <axisGroup>)

Error correction

204 - Check the speed encoder. It may have to be exchanged.
– Check the axis configuration
– Inform your service agency


Error description 231-E01B

Error message

E01B CC%2 SPLC program error ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The SPLC program has found an illegal value in an API marker or in an API word in the ApiToSafety (symbolic memory interface of SPLC to the safety software SKERN).
The additional information provides exact information:
ERR-ID = Information
ObjId = Depends on the ERR-ID
Param = Depends on the ERR-ID
ERR_ID:
100: PP_AxGrpStateReq - Range violation SPLC-CC
ObjektID = Axis group
Parameter = Value of the required safety function
200: PP_AxGrpActivate - Illegal marker value
ObjektID = Axis group
Parameter = 1 - SPLC CC marker value illegal
= 2 - SPLC MC marker value illegal
300: PP_AxFeedEnable - Illegal marker value
ObjektID = Axis
Parameter = 1 - SPLC CC marker value illegal
= 2 - SPLC MC marker value illegal
400: PP_AxGrpStopReq - Range violation SPLC CC
ObjektID = Axis group
Parameter = Value of the required safety function
500: PP_AxGrpPB - Illegal marker value
ObjektID = Axis group
Parameter = 1 - SPLC CC marker value illegal
= 2 - SPLC MC marker value illegal
600: PP_GenFB_NCC - Illegal marker value SPLC CC
ObjektID = No meaning
Parameter = No meaning
700: PP_GenCVO - Illegal marker value
ObjektID = No meaning
Parameter = 1 - SPLC CC marker value illegal
= 2 - SPLC MC marker value illegal
800: PP_AxGrpPermitDrvOn - Illegal marker value
ObjektID = Axis group
Parameter = 1 - SPLC CC marker value illegal
= 2 - SPLC MC marker value illegal
900: PP_GenMKG - Illegal marker value SPLC CC
ObjektID = No meaning
Parameter = No meaning
1000: PP_GenTBRK - Illegal marker value SPLC CC
ObjektID = No meaning
Parameter = No meaning

Error correction

- To set API words, use only the definitions of the corresponding datum in "SPlcApiMarker.def"
- Check the range limits of the API word.
- Check the values assigned to the API marker.
- Inform your service agency.


Error description 231-E01C

Error message

E01C CC%2 Illegal FS function ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The SPLC program has requested an illegal safety function over PP_AxGrpStateReq in the ApiToSafety (symbolic memory interface of SPLC to the core safety software SKERN).
ERR-ID = Exact information
ObjId = Axis group causing the error
Param = Depends on the ERR-ID
ERR_ID:
100: Requested safety function is not supported
Param = Requested safety function
200: The safety function SLI_S was requested for a axis group that is not of the spindle type.
Param = No meaning
300: The safety function SLI_2, SLI_3 or SLI_4 was requested for an axis group that is of the spindle type. This safety function is not allowed for spindles.
Param = Requested safety function
400: The safety function SLS_4 or SLI_4 was requested for a axis group and the function is not enabled.
Param = Requested safety function
401: A direct change is requested from the safety function SLS_2, SLI_2, SLS_3 or SLI_3 into the safety function SLS_4 or SLI_4.
This direct change is not allowed.
Parameter = Requested safety function
402: A direct change is requested from the safety function SLS_4 or SLI_4 into the safety function SLS_2, SLI_2, SLS_3 or SLI_3.
This direct change is not allowed.
Parameter = Requested safety function
500: The SPLC requested the safety function STO or STO_O for an axis group whose drives are still in the control loop. The requested safety function can be requested only if all drives of this axis group have been switched off.
Parameter = Value of the required safety function

Error correction

- Check the ERR ID:
100 - Use only safety functions that are supported with this software level.
200 - Request the safety function SLI_S only for axis groups with spindles.
300 - For spindles, request only the SLI_S function.
400 - Do not request a safety function or enable the safety related operating mode SOM 4 in machine parameter permitSom4.
(Check the preconditions for enabling)
401 - Switch off the drives between the change of safety function and request SOS for at least one cycle.
402 - See 401
500 - Switch-off with the stop functions over PP_AxGrpStopReq.
- Inform your service agency


Error description 231-E01C

Error message

E01C CC%2 Illegal FS function ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The SPLC program has requested an illegal safety function over PP_AxGrpStateReq in the ApiToSafety (symbolic memory interface of SPLC to the core safety software SKERN).
ERR-ID = Exact information
ObjId = Axis group causing the error
Param = Depends on the ERR-ID
ERR_ID:
100: Requested safety function is not supported
Param = Requested safety function

Error correction

- Check the ERR ID:
100 - Use only safety functions that are supported with this software level.
- Inform your service agency


Error description 231-E01C

Error message

E01C CC%2 Illegal FS function ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The SPLC program has requested an illegal safety function over PP_AxGrpStateReq in the ApiToSafety (symbolic memory interface of SPLC to the core safety software SKERN).
ERR-ID = Exact information
ObjId = Axis group causing the error
Param = Depends on the ERR-ID
ERR_ID:
200: The safety function SLI_S was requested for a axis group that is not of the spindle type.
Param = No meaning

Error correction

- Check the ERR ID:
200 - Request the safety function SLI_S only for axis groups with spindles.
- Inform your service agency


Error description 231-E01C

Error message

E01C CC%2 Illegal FS function ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The SPLC program has requested an illegal safety function over PP_AxGrpStateReq in the ApiToSafety (symbolic memory interface of SPLC to the core safety software SKERN).
ERR-ID = Exact information
ObjId = Axis group causing the error
Param = Depends on the ERR-ID
ERR_ID:
300: The safety function SLI_2, SLI_3 or SLI_4 was requested for a axis group that is not of the spindle type. This safety function is not permissible for spindles.
Param = Requested safety function

Error correction

- Check the ERR ID:
300 - For spindles, request only the SLI_S function.
- Inform your service agency


Error description 231-E01C

Error message

E01C CC%2 Illegal FS function ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The SPLC program has requested an illegal safety function over PP_AxGrpStateReq in the ApiToSafety (symbolic memory interface of SPLC to the core safety software SKERN).
ERR-ID = Exact information
ObjId = Axis group causing the error
Param = Depends on the ERR-ID
ERR_ID:
400: The safety function SLS_4 or SLI_4 was requested for a axis group and the function is not enabled.
Param = Requested safety function

Error correction

- Check the ERR ID:
400 - Do not request the safety function, or enable Bit #0 in MP560 Bit#0. (Check the preconditions for enabling)
- Inform your service agency


Error description 231-E01C

Error message

E01C CC%2 Illegal FS function ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The SPLC program has requested an illegal safety function over PP_AxGrpStateReq in the ApiToSafety (symbolic memory interface of SPLC to the core safety software SKERN).
ERR-ID = Exact information
ObjId = Axis group causing the error
Param = Depends on the ERR-ID
ERR_ID:
401: A direct change is requested from the safety function SLS_2, SLI_2, SLS_3 or SLI_3 into the safety function SLS_4 or SLI_4. This direct change is not allowed.
Parameter = Requested safety function

Error correction

- Check the ERR ID:
401 - Switch off the drives between the change of safety function and request SOS for at least one cycle.
- Inform your service agency


Error description 231-E01C

Error message

E01C CC%2 Illegal FS function ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The SPLC program has requested an illegal safety function over PP_AxGrpStateReq in the ApiToSafety (symbolic memory interface of SPLC to the core safety software SKERN).
ERR-ID = Exact information
ObjId = Axis group causing the error
Param = Depends on the ERR-ID
ERR_ID:
402: A direct change is requested from the safety function SLS_4 or SLI_4 into the safety function SLS_2, SLI_2, SLS_3 or SLI_3. This direct change is not allowed.
Parameter = Requested safety function

Error correction

- Check the ERR ID:
401 - Switch off the drives between the change of safety function and request SOS for at least one cycle.
402 - See 401
- Inform your service agency


Error description 231-E01C

Error message

E01C CC%2 Illegal FS function ERR-ID=%4 ObjId=%5 Param=%6

Cause of error

- The SPLC program has requested an illegal safety function over PP_AxGrpStateReq in the ApiToSafety (symbolic memory interface of SPLC to the core safety software SKERN).
ERR-ID = Exact information
ObjId = Axis group causing the error
Param = Depends on the ERR-ID
ERR_ID:
500: The SPLC requested the safety function STO or STO_O for an axis group whose drives are still in the control loop. The requested safety function can be requested only if all drives of this axis group have been switched off.
Parameter = Value of the required safety function

Error correction

- Check the ERR ID:
500 - Switch-off with the stop functions over PP_AxGrpStopReq.
- Inform your service agency


Error description 231-E01D

Error message

E01D CC%2 SKERN Start requirement not fulfilled Id=%4, V=%4

Cause of error

- The requirements for starting cyclic operation are not fulfilled.

Error correction

- ID=1: Configuration was not successful.
Check the additional information of the error messages E01A or E019.
- ID=2: Check whether an error message E01E occurred.
- ID=3: Your hardware version does not fulfill the requirements for safe operation.
- Inform your service agency


Error description 231-E01E

Error message

E01E CC%2 SKERN Version comparison failed

Cause of error

- In the SKERN software version comparison, a difference between the MC and CC was found.

Error correction

- Check the MC and CC software versions and make sure to use identical software versions on CC and MC.
- Inform your service agency


Error description 231-E01F

Error message

E01F CC%2 SPLC program requests invalid change of operating mode

Cause of error

- The SPLC program requests an illegal change of the safe operating mode via the date ApiToSafety.PP_GenSOM.

Error correction

- Check the SPLC program. The following changes are not permitted:
S_MODE_SOM_2 -> S_MODE_SOM_4
S_MODE_SOM_3 -> S_MODE_SOM_4
S_MODE_SOM_4 -> S_MODE_SOM_2
S_MODE_SOM_4 -> S_MODE_SOM_3
- Inform your service agency


Error description 231-E020

Error message

E020 CC%2 Incorrect SPLC-RTS data ID=%4 Info1=%5 Info2=%6

Cause of error

- When the cyclic data from the SPLC were checked, an error was found.

Error correction

- Check the software versions
- Inform your service agency


Error description 231-E021

Error message

E021 Cut-out signal status incorrect CC%2 Nom:%4 ErrMask:%5 Sgn:%6

Cause of error

An error occurred in the self-test for safety. A faulty output condition was found before the cut-out channel test: At least on of the examined cut-out signals has the wrong condition.
These are the meanings of the abbreviations:
Nom (nominal condition of the cut-out signals, decimal notation, interpret in binary):
0: Lock / 1: Release through the corresponding cut-out signal (bits 0 to 9 of Nom)
Bit0:STOS.A.MC, Bit1:STO.A.MC.WD, Bit2:STO.A.P.x, Bit3:STO.A.PIC, Bit4:STO.B.CC.WD
Bit5:STO.B.P.x, Bit6:STO.A.CC, Bit7:STO.A.SPL.WD, Bit8:STOx.A.RES, Bit9:STO.A.T
ErrMask (error mask, decimal notation, interpret in binary):
The corresponding switch-off signal (bits 0 – 9 of ErrMask) locks although it should release, or releases although it should lock.
Sgn (cut-out signal to be tested):
0: STOS.A.MC
1: STO.A.MC.WD
2: STO.A.P.x
3: STO.A.PIC
4: STO.B.CC.WD
5: STO.B.P.x
6: STO.A.CC
7: STO.A.SPL.WD
8: STOx.A.RES
9: STO.A.T

Error correction

- Check the wiring (PWM cable)
- Replace the defective hardware (power module, controller unit)
- Inform your service agency


Error description 231-E022

Error message

E022 CC%2 SKERN-CC: Error in configuration data ID=%4

Cause of error

A data error was found during cyclic checking of the configuration data.
- Internal software error

Error correction

- Create a service file
- Inform your service agency


Error description 231-E023

Error message

E023 CC%2 dynamic test ID=%4 Info1=%5 Info2=%6

Cause of error

- An error was found during the dynamic test (minute test)

Error correction

- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: Time exceeded in A channel test

Cause of error

The dynamic test of the PLC peripheral devices (PL, MB, UEC)
was cancelled during the A-channel test.
- Internal software error
- Error in the HSCI communication between MC and
HSCI peripheral device

Error correction

- Exchange the defective HSCI peripheral component.
- Check the software version.
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: CC software interrupt mask %5

Cause of error

The CC interrupt mask was changed during the dynamic test of
the B-channel peripheral devices (PL, MB, UEC).
- Internal software error
- Defective peripheral device
- Defective CC 61xx controller unit

Error correction

- Check the software version.
- Exchange the defective CC 61xx
- Exchange the defective peripheral device
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: Invalid test ID %5

Cause of error

During the dynamic test of the PLC peripheral devices (PL, MB,
UEC) of the B channel, an incorrect test ID was transferred from the MC to the CC.
It is possible that the connected periphery
does not match the configured periphery.
- Incorrect peripheral device configured
- Internal software error
- Disturbance of the HSCI communication

Error correction

- Use the HSCI-BUS diagnostics to check the connected periphery.
- If required, correct the HSCI configuration.
- Check the software version.
- Exchange the peripheral device.
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: Error in B channel PL input no. %5

Cause of error

The dynamic test of the PLC peripheral devices (PL, MB, UEC)
discovered that an input to be tested did not switch to
the 0 level.
- Incorrect S machine parameters SMP587
- Wiring error of the test groups/test outputs
- Error in the configuration file (IOC file)
- Disturbance of HSCI communication

Error correction

- Check the entry in the machine parameter SMP587
- Check the HSCI-BUS diagnostics
- Check the wiring and HSCI configuration
- Exchange the peripheral device.
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: -ES.B inactive test ID=%5

Cause of error

The dynamic test of the PLC peripheral devices (PL, MB)
discovered that an ES.B input was not activated or
the input is defective.
- Wiring error of the test groups/test outputs
- Error in the configuration file (IOC file)

Error correction

- Check the HSCI-BUS diagnostics. If necessary, correct the HSCI configuration
- Check/correct the wiring
- Exchange the peripheral device.
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: -ES.B.HW inactive test ID=%5

Cause of error

The dynamic test of the PLC peripheral devices (MB, PL)
discovered that an ES.B.HW input was not activated or
the input is defective.
- Wiring error of the test groups/test outputs
- Error in the HSCI configuration file (IOC file)

Error correction

- Check the HSCI-BUS diagnostics. If necessary, correct the HSCI configuration
- Check/correct the wiring
- Exchange the peripheral device.
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: Error in B channel: test ID=%5

Cause of error

The dynamic test of the PLC peripheral devices (PL, MB, UEC)
discovered an error in the test flow. An incorrect ID
appeared at the end of the test.
- Internal software error

Error correction

- Check the software version.
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: Error in B channel: test ID=%5

Cause of error

The dynamic test of the PLC peripheral devices (PL, MB, UEC)
was was not conducted for the given test ID.
- Error in the configuration file (IOC file)
- Internal software error

Error correction

- Check the HSCI-BUS diagnostics. If necessary, correct the HSCI configuration
- Check the software version.
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: Processor check error %5

Cause of error

Error in the flow of the dynamic test
- Internal software error

Error correction

- Check the software version.
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: Error in B channel: test ID=%5

Cause of error

The dynamic test of the PLC peripheral devices (PL, MB, UEC)
was was not conducted for the given test ID.
- Error in the HSCI configuration file (IOC file)
- Internal software error

Error correction

- Check the HSCI-BUS diagnostics. If necessary, correct the HSCI configuration
- Check the software version.
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: Error in B channel: test ID=%5

Cause of error

Error during the dynamic test of the PLC periphery devices (PL, MB, UEC)
Missing acknowledgment of the TEST.B output.
- Incorrect wiring of the TEST.B output.
- Short circuit of the TEST.B output
- Incorrect firmware version of the peripheral device

Error correction

- Check the software version.
- Check the wiring of the TEST.B output
- Run a software or firmware update
- Exchange the faulty device.
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: Error in B channel: test ID=%5

Cause of error

Error during the dynamic test of the PLC periphery devices (PL, MB, UEC).
No expected switch from 1 to 0 of the test output TEST.B detected.
- Incorrect wiring of the TEST.B output.
- Short circuit of the TEST.B output
- Incorrect firmware version of the peripheral device

Error correction

- Check the software version.
- Check the wiring of the TEST.B output
- Run a software or firmware update
- Exchange the faulty device.
- Inform your service agency.


Error description 231-E023

Error message

E023 CC%2 Dynamic test ID=%4 aborted: Error in B channel: test ID=%5

Cause of error

Error during the dynamic test of the PLC periphery devices (PL, MB, UEC).
No expected switch from 0 to 1 of the test output TEST.B detected.
- Incorrect wiring of the TEST.B output.
- Short circuit of the TEST.B output
- Incorrect firmware version of the peripheral device

Error correction

- Check the software version.
- Check the wiring of the TEST.B output
- Run a software or firmware update
- Exchange the faulty device.
- Inform your service agency.


Error description 231-E024

Error message

E024 CC%2 alarm self-test Addr:%4, Dev:%5, Actl:%6, Noml:%7

Cause of error

The self-test detected an internal process error.

Error correction

- Inform your service agency.


Error description 231-E025

Error message

E025 CC%2 error: self-test ErrId:%4, Par1:%5, Par2:%6, Par3:%7

Cause of error

The self-test detected an internal process error.

Error correction

- Check the software versions
- Inform your service agency.


Error description 231-E026

Error message

E026 CC%2 Illegal MC software installed

Cause of error

An illegal software version of the MC software (autotest version) was detected.

Error correction

- Check the software versions
- Inform your service agency.


Error description 231-E027

Error message

E027 CC%2 Error: Safety function STO AxGrp=%3 ErrId=%4

Cause of error

The Safe Torque Off safety function (STO) was not complied with for the given axis group.

Error correction

- Check whether this is an aftereffect and, if so, correct its cause.
- Inform your service agency.


Error description 231-E028

Error message

E028 CC%2 MB/PLB does not respond. Device ID: %3

Cause of error

- HSCI components with functional safety (FS) no longer responds (B channel): MB machine operating panel or PLB 6xxx
- Component was separated during operation with the HSCI bus
- 24 V NC power supply of the component was interrupted
- The entered device ID provides information on the affected parameter:
5 = System module on PLB 62xx FS
7 = MB 6xx FS
15 = Expansion PLB (without system module) PLB 61xx FS, PLB 60xx FS
17 = Integrated PLB of the UEC controller unit
- Faulty firmware of the PLB or the MB

Error correction

- Check the MB and PLB in the HSCI bus diagnosis
- Save service files
- Check the HSCI connections
- Check the 24 V power supply of the MB and the PLB
- Inform your service agency


Error description 231-E029

Error message

E029 CC%2 Test step not possible (ID=%3)

Cause of error

One of the following steps in the safety self-test is not possible in a drive system with
DRIVE-CLiQ inverters due to the hardware. The safety self-test can be configured through safe machine parameters in the configuration datum with CfgSafety.

Error correction

The given ID number indicates the appropriate test that must be deactivated for a system with DRIVE-CLiQ inverters.
ID = 100: Test of the brake control. Test the setting in machine parameter testNotBrakeLine.
ID = 200: Cutout channel test via signals STO.A.G / STOS.A.G. Check the setting in machine parameter testNotStoGlobal.
ID = 300: Cutout channel test via signals internal to the control. Test the setting in machine parameter testNotStoIntrnl.
- Note: These settings must be changed only by the machine tool builder.
- Inform your service agency.


Error description 231-E02A

Error message

E02A CC%2 SKERN-CC: Response: norm. closed contact unequal A=%4, B=%5

Cause of error

The acknowledgment signal of the normally closed contact chain PP_GenFB_NCC of the A channel does not
match the signal of the B channel.

Error correction

- Check signals FB_NCC.A and FB_NCC.B
- Check the wiring of the normally closed contact chain
- Check the SPLC program
- Inform your service agency


Error description 231-E02B

Error message

E02B SKERN-CC: dynamic sampling test of safe PL input:%5 faulty

Cause of error

The dynamic test of the PLC peripheral devices (PL, MB, UEC)
discovered that an input to be tested did not switch to
the 0 level.
- Incorrect S machine parameters SMP587
- Wiring error of the test groups/test outputs
- Error in the configuration file (IOC file)
- Disturbance of HSCI communication

Error correction

- Check the entry in the machine parameter SMP587
- Check the HSCI-BUS diagnostics
- Check the wiring and HSCI configuration
- Exchange the peripheral device.
- Inform your service agency.


Error description 231-E02C

Error message

E02C SKERN-CC: dynamic sampling test of ES.B faulty

Cause of error

The dynamic test of the PLC peripheral devices (PL, MB)
discovered that an ES.B input was not activated or
the input is defective.
- Wiring error of the test groups/test outputs
- Error in the configuration file (IOC file)

Error correction

- Check the HSCI-BUS diagnostics. If necessary, correct the HSCI configuration
- Check/correct the wiring
- Exchange the peripheral device.
- Inform your service agency.


Error description 231-E02D

Error message

E02D SKERN-CC: dynamic sampling test of ES.B.HW faulty

Cause of error

The dynamic test of the PLC peripheral devices (MB, PL)
discovered that an ES.B.HW input was not activated or
the input is defective.
- Wiring error of the test groups/test outputs
- Error in the HSCI configuration file (IOC file)

Error correction

- Check the HSCI-BUS diagnostics. If necessary, correct the HSCI configuration
- Check/correct the wiring
- Exchange the peripheral device.
- Inform your service agency.


Error description 231-E030

Error message

E030 CC%2 process error in safety self-test %4

Cause of error

An internal process error has occurred during the self test:
- Internal software error

Error correction

- Save the service file
- Restart the control.
- Inform your service agency.


Error description 231-E031

Error message

E031 CC%2 FS outputs not "0" 0-31:%4 32-63:%5

Cause of error

- In the safety self-test, the WD.B.SPL FS outputs remain set during the watchdog test, although they were supposed to be reset.
0-31: Bit-encoded status of the FS outputs 0 to 31
31-63: Bit-encoded status of the FS outputs 32 to 63
64-95: Bit-encoded status of the FS outputs 64 to 95
96-127: Bit-encoded status of the FS outputs 96 to 127
- Short circuit of an FS output on +24 V
- Hardware defective

Error correction

- Check the wiring of the FS outputs.
- Exchange the hardware
- Generate the service files and notify the Service Department


Error description 231-E032

Error message

E032 CC%2 power supply unit not ready for operation

Cause of error

- In the safety self-test, the supply unit does not indicate readiness for operation
- The RDY.PS signal is inactive for one of the following reasons:
- No release at the X70 connector of the supply unit
- Short circuit of the KDR commutation reactor
- Incorrect wiring of the KDR
- Hardware defective

Error correction

- Check the wiring on the connector X70
- Check the KDR wiring
- Exchange the hardware
- Generate the service files and notify the Service Department


Error description 231-E033

Error message

E033 CC%2 FS outputs not "0" 64-95:%4 96-127:%5

Cause of error

- In the safety self-test, the WD.B.SPL FS outputs remain set during the watchdog test, although they were supposed to be reset.
0-31: Bit-encoded status of the FS outputs 0 to 31
31-63: Bit-encoded status of the FS outputs 32 to 63
64-95: Bit-encoded status of the FS outputs 64 to 95
96-127: Bit-encoded status of the FS outputs 96 to 127
- Short circuit of an FS output on +24 V
- Hardware defective

Error correction

- Check the wiring of the FS outputs.
- Exchange the hardware
- Generate the service files and notify the Service Department


Error description 231-E110

Error message

E110 Timeout in current measurement %1

Cause of error

- Current measuring during safety self-test exceeds the defined time

Error correction

- Internal software error
- Inform your service agency


Error description 231-E120

Error message

E120 CC safe function call error

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-E130

Error message

E130 Test current is too small %1

Cause of error

- The test current measured in the measurement of the current during the safety self-test is too small
- The current control loop has not been adjusted
- Drive enabling at PWM output is missing at the time of measurement of the current
- The current sensor is defective

Error correction

- As a test, switch off the measurement of the current in CfgSafety via safe machine parameter testNotCurrent. The resulting error messages provide information on possibly faulty signals for drive enabling.
- Adjust the current controller
- Check the current sensor
- Inform your service agency


Error description 231-E140

Error message

E140 Mot. current %1 not equal 0

Cause of error

- The current measured in the pulse deletion test is too great
- One of the cutout channels "-AP1.x", "-SH1AB", "-AP2.x" or "-SH2.WD" is not effective

Error correction

- Check the wiring
- Inform your service agency


Error description 231-E150

Error message

E150 RDY.x status stays active %1

Cause of error

- The measured status of the 'RDY.x' signal is active
- The 'RDY.x' signal does not change to the 'inactive' ('low' level) status, although the MC is blocking the power module through a corresponding enabling signal.

Error correction

- Internal software error
- Hardware defective
- Inform your service agency


Error description 231-E160

Error message

E160 RDY.x status is inactive %1

Cause of error

- The measured status of the 'RDY.x' signal is inactive
- The 'RDY.x' signal does not change to the 'active' ('high' level) status, although the MC is blocking the power module through a corresponding enabling signal.

Error correction

- Internal software error
- Hardware defective
- Inform your service agency


Error description 231-E170

Error message

E170 Pos. error too large %1

Cause of error

- Defect in the mounting of the position encoder
- Incorrect thermal, linear or nonlinear compensation
- Excessive backlash

Error correction

- Check the parameter value (maximum position deviation between MC and CC during operation)
- Check the parameter value in CfgAxisComp->linearCompValue (linear axis error compensation for analog axes)
- Check the parameter value in CfgAxisComp->backLashType1 (backlash compensation)
- Check the mounting of the position encoder- Inform your service agency


Error description 231-E180

Error message

E180 Z1-track amplitude too high %1

Cause of error

- The amplitude of the Z1-track encoder signal for the speed encoder is too high
- Noise on motor encoder signal
- Short circuit in the motor encoder cable
- Z1-track signal amplitude of motor encoder too high

Error correction

- Check the connection of the motor encoder
- Check the cable of the speed encoder
- Check the motor encoder
- Inform your service agency


Error description 231-E190

Error message

E190 RDY.x status of axes stays active (safety relay) %1

Cause of error

- Measured status of the '-STO.A.G' signals remain inactive during the test (high level)
- The '-STO.A.G' signal does not change to the 'active' status (low level), even though the MC sets the corresponding signal status
- The power stage (inverter) of at least 1 feed axis or auxiliary axis is not locked through the '-STO.A.G' signal.

Error correction

- Check the wiring
- Hardware defective
- Inform your service agency


Error description 231-E1A0

Error message

E1A0 RDY.x status of axes stays inactive (safety relay) %1

Cause of error

- Measured status of the '-STO.A.G' signals remain active during the test (high level)
- The '-STO.A.G' signal does not change to the 'inactive' status (high level), even though the MC sets the corresponding signal status
- The power stage (inverter) of at least 1 feed axis or auxiliary axis is locked through the '-STO.A.G' signal.

Error correction

- Check the wiring
- Hardware defective
- Inform your service agency


Error description 231-E1C0

Error message

E1C0 RDY.x status of spindle stays active (safety relay) %1

Cause of error

- Status of the '-STOS.A.G' signals remain inactive during the test (high level)
- '-STOS.A.G' signal does not change to the 'active' status (low level), even though the MC assigns the corresponding signal status
- The power stage (inverter) of the spindle is not locked through the '-STOS.A.G' signal.

Error correction

- Check the wiring
- Hardware defective
- Inform your service agency


Error description 231-E1E0

Error message

E1E0 CC%2 RDY.x status remains active (safety relay)%1

Cause of error

- An error occurred during the watchdog test WD.A.STO of the PL 6xxxFS. A power stage (inverter) is not switched off through the -STOS.A.G or -STO.A.G signal.
- Faulty or missing wiring of -STO.A.G, -STOS.A.G or X71, X72 of the power module (UV, UE)
- Error in parameters of the control of X71, X72 through -STO.A.G, -STOS.A.G in SMP
- Hardware defective

Error correction

- Check the wiring
- Check SMP
- Exchange the hardware
- Generate the service files and notify the Service Department


Error description 231-E200

Error message

E200 Timeout during emergency stop (SS1) %1

Cause of error

- The maximum permissible braking time for stopping at the emergency braking ramp (SS1 reaction) was exceeded

Error correction

- Check the machine parameter:
timeLimitStop1: Default time for stopping at the emergency braking ramp for SS1 reaction
- Inform your service agency


Error description 231-E220

Error message

E220 Standstill monitoring SKERN-CC %1

Cause of error

- SKERN-CC detected an impermissibly large axis movement
in the SOS safety condition. The standstill speed, however,
was not exceeded. The maximum
permissible path is defined in the machine parameter MP positionRangeVmin .
Possible causes:
- Machine parameter "positionRangeVmin" is defined too small.
- The brake was deactivated before the position controller was closed.
- The brake was not activated before the position controller was opened.
- When an axis was switched on, some existing following
error was corrected.
- The brake is defective.
- There was an attempt to move an axis in the SOS condition (PLC?)

Error correction

- Check the entry in machine parameter positionRangeVmin.
- Check the sequence of deactivating the brake and closing the position controller.
- Check the sequence of activating the brake and opening the position controller.
- Check whether there is a following error after an axis is locked.
- Inform your service agency.


Error description 231-E230

Error message

E230 Axis %1 STO safety function not fulfilled

Cause of error

The Safe Torque Off safety function (STO) was not complied with for the given axis.

Error correction

- Check whether this is an aftereffect and, if so, correct its cause.
- Inform your service agency.


Error description 231-E240

Error message

E240 Axis %1 faulty braking process

Cause of error

- Axis was incorrectly braked during an SS1 reaction.
Possible causes:
- Adjusted delay time of the dv/dt monitoring
(timeToleranceDvDt) is insufficient. An acceleration might occur
after expiration of the delay time.
- Drive is not optimally adjusted
- Brake ramp in machine parameter motEmergencyStopRamp is not correctly adjusted

Error correction

- Check the entry in machine parameter timeToleranceDvDt
- Check the adjusted braking ramp for emergency stops
in machine parameter motEmergencyStopRamp
- Check the velocity of the drive during the braking process
with the control's internal oscilloscope
- Adjust the drive.
- Inform your service agency


Error description 231-E250

Error message

E250 Error in cut-out channel %1 Ch:%4 St:%5 St-2ndCh:%6 Sgn:%7

Cause of error

An error occurred in the self-test for safety. The cut-out channel test detected an error. Key to abbreviations of the error message:
Ch (cut-out channel concerned):
1: STO.A.x
2: STO.B.x
3: STO.A.G
4: STOS.A.G
5: STO.A.G and STOS.A.G
St (actual status of the cut-out channel):
0: cut-out channel is inactive, although it is supposed to be active
1: cut-out channel is active, although it is supposed to be inactive
St-2ndCh (actual status of the second cut-out channel):
0: cut-out channel is inactive
1: cut-out channel is active
The second cut-out channel is STO.A.x if Ch=2 and
STO.B.x if Ch=1, Ch=3, CH=4, and CH=5
Sgn (cut-out channel concerned):
0: STOS.A.MC 1: STO.A.MC.WD
2: STO.A.P.x 3: STO.A.PIC
4: STO.B.CC.WD 5: STO.B.P.x
6: STO.A.CC 7: STO.A.SPL.WD
8: STOx.A.RES 9: STO.A.T
99: no cut-out signal

Error correction

- Check the wiring (PWM cable)
- Replace the defective hardware (power module, controller unit)
- Inform your service agency


Error description 231-E251

Error message

E251 SKERN-CC%2: checksum error cross-comparison data from SKERN-MC

Cause of error

A difference was found between the checksum transmitted by the MC and the checksum formed by the CC.

Error correction

- Reboot the control.
- Inform your service agency


Error description 231-F000

Error message

F000 CC%2 S-function call error %1

Cause of error

- Internal software error

Error correction

- Inform your service agency
- Check the software version


Error description 231-F100

Error message

F100 No brake test was conducted %1

Cause of error

- MC runs no test of the motor brake(s) although it is necessary according to parameter settings.
- The call for testing a motor brake lasts longer than 5 seconds.

Error correction

- Inform your service agency


Error description 231-F200

Error message

F200 No brake line test was conducted %1

Cause of error

- MC runs no test of the motor brake line although it is necessary according to parameter settings.
- The call for testing a brake line lasts longer than 10 seconds.

Error correction

- Inform your service agency


Error description 231-F300

Error message

F300 CC%2 Cancelation of the cutout channel test %1

Cause of error

- The switch-off test was ended automatically because the maximum permissible delay time was exceeded.
- The NC did not properly finish a test section.
- The NC does not perform a certain test.

Error correction

- Check whether a previous system error of the NC led to the cancelation of the test section
- Check the software version
- Inform your service agency


Error description 234-0001

Error message

Insufficient memory

Cause of error

Too many clients are configured for the Ethernet transmission.

Error correction

Inform your service agency


Error description 234-0002

Error message

HSCI Ethernet connection interrupted

Cause of error

The Ethernet transmission is disturbed.

Error correction

- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Check the wiring
- Inform your service agency


Error description 234-0003

Error message

HSCI Ethernet configuration without CC

Cause of error

If the HSCI is configured or connected, a CC must also be connected to the HSCI.

Error correction

- Check the cabling
- Inform your service agency


Error description 234-0004

Error message

Internal software error

Cause of error

Not enough memory for the job at hand

Error correction

Inform your service agency


Error description 234-0005

Error message

Internal software error

Cause of error

HSCI initialization not completed

Error correction

Inform your service agency


Error description 234-0006

Error message

Internal software error

Cause of error

High-speed inputs not initialized on the PLB 6xxx (HSCI).

Error correction

Inform your service agency


Error description 234-0007

Error message

Fast input does not exist

Cause of error

A high-speed input on a PLB 6xxx (HSCI) adjusted in the configuration data of the control is missing.

Error correction

- Ensure that the input has been configured with IOconfig.
- Please keep in mind that the input has to be of the bit data type.
- Dual-channel inputs (FS) cannot be used.


Error description 234-0008

Error message

HSCI total amount of data too great

Cause of error

The number of permissible HSCI data telegrams or their total size was exceeded.

Error correction

Inform your service agency.


Error description 234-0009

Error message

Too many HSCI telegrams

Cause of error

The maximum number of HSCI datagrams was exceeded.
The IO configuration contains too many HSCI devices.

Error correction

Inform your service agency.


Error description 234-000A

Error message

HSCI data has reached critical size.

Cause of error

The total number of HSCI data has reached a critical size.
This increases the risk of transmission errors.

Error correction

- Reduce the number of HSCI components on the HSCI bus.
- Inform your service agency.


Error description 234-000B

Error message

HSCI data size too large for HSCI device

Cause of error

The permissible total data amount for an HSCI device has been exceeded.

Error correction

Inform your service agency.


Error description 234-000C

Error message

Impermissible HSCI device detected on X501 of the MC

Cause of error

At least one HSCI device was detected on the X501 connection of the MC that is not suited for operation on this connection.

Error correction

Check the devices connected to X501.
The following devices are not allowed on this connection:
- CC controller units (including UECs and UMCs)
- PL 6xxx FS
- More than one dual-channel machine operating panel (e.g. MB 620FS, PL 6001FS)


Error description 234-000D

Error message

Error during initialization of the SPI module (MCU)

Cause of error

Could not create memory for the SPI inputs and outputs.

Error correction

Switch the control off and back on.
If the error recurs, inform your service agency.


Error description 234-000E

Error message

Maximum number of controller units exceeded

Cause of error

There are too many CC controller units connected to the HSCI bus.

Error correction

- Note the maximum number of the respective HSCI participants. Refer to the Technical Manual for your control for more information about this.
- Check the HSCI configuration.
- Inform your service agency.


Error description 234-000F

Error message

Maximum number of PLB or MB exceeded

Cause of error

There are too many PLB 6xxx units or MB machine operating panels connected to the HSCI bus.

Error correction

- Note the maximum number of the respective HSCI participants. Refer to the Technical Manual for your control for more information about this.
- Check the HSCI configuration.
- Inform your service agency.


Error description 234-0010

Error message

Maximum number of HSCI devices exceeded

Cause of error

Too many HSCI devices (CC + UxC + PL 6xxx + MB) were detected on the HSCI bus.

Error correction

- Note the maximum number of the respective HSCI participants. Refer to the Technical Manual for your control for more information about this.
- Check the HSCI configuration.
- Inform your service agency.


Error description 234-0011

Error message

HSCI handwheel configuration error

Cause of error

Too many handwheels were detected on HSCI devices, or the handwheels are not allowed for this control

Error correction

- Check the configuration and number of connected handwheels
- Inform your service agency


Error description 234-0012

Error message

HSCI touch probe configuration error

Cause of error

Too many touch probes were detected on HSCI devices, or the touch probes are not allowed for this control

Error correction

- Check the configuration and number of touch probes
- Inform your service agency


Error description 234-0013

Error message

Error while reading the HSCI information

Cause of error

An error occurred during the import of hardware information for HSCI initialization.

Error correction

- Restart the control
- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Check the HSCI wiring
- Inform your service agency


Error description 234-0014

Error message

Fault an HSCI interface X500 of the MC

Cause of error

- Problems at the X500 HSCI interface connection of the MC
- Bad or missing HSCI connection at X500

Error correction

- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Check the connecting element at X500 of the MC
- Check the HSCI cable and HSCI devices connected at X500
- Check the MC main computer for defects and exchange it if necessary
- Inform your service agency


Error description 234-0015

Error message

Fault an HSCI interface X501 of the MC

Cause of error

- Problems at the X501 HSCI interface connection of the MC
- Bad or missing HSCI connection at X501

Error correction

- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Check the connecting element at X501 of the MC
- Check the HSCI cable and HSCI devices connected at X501
- Check the MC main computer for defects and exchange it if necessary
- Inform your service agency


Error description 234-0017

Error message

HSCI data not updated

Cause of error

- HSCI data have not been updated since the last cycle
- Internal software error

Error correction

- Check the voltage supply to the devices
- Check the HSCI connecting cable
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
If the error recurs:
- Create service files and save them
- Inform your service agency


Error description 234-0019

Error message

Incorrect firmware version of the HSCI master component

Cause of error

The firmware version of the HSCI master FPGAs is incompatible with the installed NC software version.

Error correction

Inform your service agency.


Error description 234-001A

Error message

HSCI telegram list too long

Cause of error

- Too many HSCI devices are connected or configured on the HSCI bus of the main computer (MC).
- Main computer (MC) is defective

Error correction

- Reduce the number of devices in the HSCI configuration or HSCI bus
- If the error occurs without previous change of the HSCI configuration, then the MC has a hardware error. In this case, exchange the main computer (MC).
- Inform your service agency


Error description 234-001C

Error message

HSCI communication interrupted

Cause of error

During operation, an illegal change in the number of
HSCI participants was found on the HSCI bus.
You can find additional information on the error location in the bus diagnostics
of the control or through the INTERNAL INFO soft key.

Error correction

- Check the HSCI cable connections
- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Inform your service agency


Error description 234-001D

Error message

Error during HSCI initialization

Cause of error

Necessary memory areas could not be created during initialization of the HSCI master component.

Error correction

- Restart the control
If the error recurs:
- Create service files and save them
- Inform your service agency


Error description 234-001E

Error message

Initialization error of HSCI interface X500

Cause of error

An error occurred during initialization of the interface component for the HSCI interface X500

Error correction

- Restart the control
If the error recurs:
- Create service files and save them
- Inform your service agency


Error description 234-001F

Error message

Initialization error of HSCI interface X501

Cause of error

An error occurred during initialization of the interface component for the HSCI interface X501 of the main computer (MC)

Error correction

- Restart the control
If the error recurs:
- Create service files and save them
- Inform your service agency


Error description 234-0020

Error message

HSCI communication error

Cause of error

The received frame number of an HSCI frame does not match the expected frame number.

Error correction

- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
If the error recurs:
- Create service files and save them
- Inform your service agency


Error description 234-0021

Error message

HSCI communication error

Cause of error

The DMA from the MC memory to the HSCI master is still active when the HSCI transfer starts.
Possible causes:
- Internal software error
- Large number of "failed frames"

Error correction

If the error occurs together with a large number of failed frames:
- Check the HSCI cable connections
- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
The number of failed frames is shown in the bus diagnostics of the MC HSCI master.
If the error recurs:
- Create service files and save them
- Inform your service agency


Error description 234-0022

Error message

HSCI communication error

Cause of error

There has been no DMA from the MC memory to the HSCI master since the last HSCI data exchange.
Possible causes:
- Internal software error
- Large number of "failed frames"

Error correction

If the error occurs together with a large number of failed frames:
- Check the voltage supply to the devices
- Check the HSCI cable connections
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
The number of failed frames is shown in the bus diagnostics of the MC HSCI master.
If the error recurs:
- Create service files and save them
- Inform your service agency


Error description 234-0024

Error message

HSCI communication error

Cause of error

The HSCI transfer jobs were not yet completed when a new DMA transfer began from the MC memory to the HSCI master.
Possible causes:
- Internal software error
- Too many "failed frames"

Error correction

If the error occurs together with a large number of failed frames:
- Check the HSCI cable connections
- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
The number of failed frames is shown in the bus diagnostics of the MC HSCI master.
If the error recurs:
- Create service files and save them
- Inform your service agency


Error description 234-0025

Error message

HSCI communication error

Cause of error

- HSCI communication error (by DMA) has occurred.

Error correction

- Create service files and save them
- Inform your service agency


Error description 234-0026

Error message

HSCI communication error

Cause of error

- An HSCI communication error has occurred.

Error correction

- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Create service files and save them
- Inform your service agency


Error description 235-0001

Error message

Installation error

Cause of error

The firmware file could not be opened. It was either not found or is faulty.

Error correction

Inform your machine tool builder


Error description 235-0002

Error message

Installation error

Cause of error

The firmware file could not be opened because it is faulty.

Error correction

Inform your service agency


Error description 235-0003

Error message

Hardware error

Cause of error

Error during download of the firmware file. Either an error occurred during data transmission of the file, or the file has a wrong firmware version.

Error correction

Inform your machine tool builder


Error description 235-0004

Error message

Hardware error

Cause of error

Timeout when downloading the firmware file. The CCU did not respond within the expected time. CCU is defective or the firmware version is incorrect.

Error correction

Inform your machine tool builder


Error description 235-0005

Error message

Hardware error

Cause of error

Timeout during the checksum calculation. The CCU did not respond within the expected time. CCU is defective or the firmware version is incorrect.

Error correction

Inform your machine tool builder


Error description 235-0006

Error message

Hardware error

Cause of error

Firmware checksum check failed. Incorrect CCU checksum. CCU is defective or the firmware version is incorrect.

Error correction

Inform your machine tool builder


Error description 235-0007

Error message

Hardware error

Cause of error

Timeout after downloading the first part of the firmware. The CCU did not respond within the expected time. CCU is defective or the firmware version is incorrect.

Error correction

Inform your machine tool builder


Error description 235-0008

Error message

Hardware error

Cause of error

Timeout after downloading the second part of the firmware. The CCU did not respond within the expected time. CCU is defective or the firmware version is incorrect.

Error correction

Inform your machine tool builder


Error description 235-0009

Error message

Hardware error

Cause of error

Timeout when checking whether the bootcode is running. The CCU did not respond within the expected time. CCU is defective or the bootcode version is incorrect.

Error correction

Inform your machine tool builder


Error description 235-000A

Error message

Installation error

Cause of error

The bootcode file could not be opened. It was either not found or is faulty.

Error correction

Inform your machine tool builder


Error description 235-000B

Error message

Installation error

Cause of error

The bootcode file could not be read because it is faulty.

Error correction

Inform your service agency


Error description 235-000C

Error message

Hardware error

Cause of error

There are too many HSCI devices connected to the control.

Error correction

Remove some of the HSCI devices. Contact your machine tool builder.


Error description 235-000D

Error message

Hardware error

Cause of error

HSCI device is not running. The CCU did not respond within the expected time. CCU is defective or the firmware version is incorrect.

Error correction

Inform your machine tool builder


Error description 235-000E

Error message

Hardware error

Cause of error

This CCU is not supported. An unknown CCU is connected to the control.

Error correction

Inform your machine tool builder


Error description 235-000F

Error message

Hardware error

Cause of error

Timeout when checking whether the CCU runs. The CCU did not respond within the expected time. CCU is defective or the firmware version is incorrect.

Error correction

Inform your machine tool builder


Error description 235-0010

Error message

Installation error

Cause of error

Configuration settings for CCU422 missing

Error correction

Inform your service agency


Error description 235-0011

Error message

Installation error

Cause of error

Configuration settings for CCU422 are faulty

Error correction

Inform your service agency


Error description 235-0012

Error message

Hardware error

Cause of error

Error during asynchronous data transfer

Error correction

Inform your machine tool builder


Error description 235-0013

Error message

Hardware error

Cause of error

Timeout during identification of the CCU software. The CCU did not respond within the expected time. CCU is defective or the firmware version is incorrect.

Error correction

Inform your machine tool builder


Error description 235-0014

Error message

Installation error

Cause of error

Invalid initialization parameters. The configuration settings are faulty.

Error correction

Inform your service agency


Error description 235-0015

Error message

Hardware error

Cause of error

Incompatible security ID of the mainboard and CCU. The mainboard and CCU have different security IDs.

Error correction

Inform your machine tool builder


Error description 235-0016

Error message

Hardware error

Cause of error

Syscon Register check failed. The Syscon registers do not have the expected values. The hardware might be defective.

Error correction

Inform your machine tool builder


Error description 235-0017

Error message

Hardware error

Cause of error

Initialization of the device failed. An error occurred during initialization of the device.

Error correction

Inform your machine tool builder


Error description 235-0018

Error message

Installation error

Cause of error

Could not open the file for writing. Faulty configuration.

Error correction

Inform your service agency


Error description 235-0019

Error message

Installation error

Cause of error

Could not read the file configuration. Faulty configuration file.

Error correction

Inform your service agency


Error description 235-001A

Error message

Installation error

Cause of error

Could not write the hardware.sys file. The configuration did not give a path for hardware.sys.

Error correction

Inform your service agency


Error description 235-001B

Error message

Hardware error

Cause of error

An error occurred during device initialization.

Error correction

Inform your machine tool builder


Error description 235-001C

Error message

Installation error

Cause of error

The mainboard was not detected.

Error correction

Inform your machine tool builder


Error description 235-001D

Error message

Internal software error

Cause of error

Could not generate server interface

Error correction

Inform your service agency


Error description 235-001E

Error message

Internal software error

Cause of error

Creation of the interrupt service routine failed

Error correction

Inform your service agency


Error description 235-001F

Error message

Internal software error

Cause of error

Interrupt does not exist

Error correction

Inform your service agency


Error description 235-0020

Error message

Internal software error

Cause of error

Cannot process any further service functions for the given interrupt (max. 3)

Error correction

Inform your service agency


Error description 235-0021

Error message

Internal software error

Cause of error

Undefined error

Error correction

Inform your service agency


Error description 235-0022

Error message

Internal software error

Cause of error

Mainboard is not supported by the hardware server

Error correction

Inform your service agency


Error description 235-0023

Error message

Hardware error

Cause of error

Unknown hardware configuration. The test for whether the processor system is single or dual failed.

Error correction

Inform your machine tool builder


Error description 235-0024

Error message

Installation error

Cause of error

Software for a single-processor system is running on a dual-processor system. Wrong software.

Error correction

Inform your machine tool builder


Error description 235-0025

Error message

Hardware error

Cause of error

Reading the HIK failed. The hardware might be defective.

Error correction

Maschinenhersteller benachrichtigen


Error description 235-0026

Error message

Hardware error

Cause of error

Reading the glue signature failed. The hardware might be defective.

Error correction

Inform your machine tool builder


Error description 235-0027

Error message

Installation error

Cause of error

Unknown hardware. G50 identification failed.

Error correction

Inform your machine tool builder


Error description 235-0028

Error message

Hardware error

Cause of error

There is no network card or there is an internal software error. Reading the MAC address failed.

Error correction

Inform your machine tool builder


Error description 235-0029

Error message

Internal software error

Cause of error

There is a reading error from PCI base16

Error correction

Inform your service agency


Error description 235-002A

Error message

Internal software error

Cause of error

There is a reading error from PCI base32

Error correction

Inform your service agency


Error description 235-002B

Error message

Installation error

Cause of error

This software does not support this control. Wrong hardware or hardware is defective.

Error correction

Inform your machine tool builder


Error description 235-002C

Error message

Installation error

Cause of error

Wrong hardware.

Error correction

Inform your machine tool builder


Error description 235-002D

Error message

Internal software error

Cause of error

Access to DPRAM failed

Error correction

Inform your service agency


Error description 235-002E

Error message

Hardware will be simulated

Cause of error

The control could not find a CCU and therefore switched into the simulation mode.

Error correction

- Check the CCU
- Check the connection to the CCU


Error description 235-002F

Error message

PROFIBUS/PROFINET: Hardware error

Cause of error

The TNC cannot address the PROFIBUS/PROFINET interface.
The interface is defective or incompatible with the TNC.

Error correction

Inform your service agency


Error description 235-0030

Error message

Firmware on ProfiNet interface is faulty or missing

Cause of error

The ProfiNet interface does not have any firmware.

Error correction

Inform your machine tool builder


Error description 235-0031

Error message

Firmware inspection on ProfiNet interface failed

Cause of error

The TNC cannot open the firmware file for the ProfiNet interface.

Error correction

Inform your machine tool builder


Error description 235-0032

Error message

Firmware update on ProfiNet interface failed

Cause of error

The TNC cannot read the firmware file for the ProfiNet interface.

Error correction

Inform your machine tool builder


Error description 235-0033

Error message

Error in firmware file for ProfiNet interface

Cause of error

The TNC found a checksum error in the firmware file for the ProfiNet interface.

Error correction

Inform your service agency


Error description 235-0034

Error message

Firmware update on ProfiNet interface failed

Cause of error

Error during the firmware update on the ProfiNet interface.

Error correction

Inform your machine tool builder


Error description 235-0035

Error message

ProfiNet: Hardware error

Cause of error

The TNC cannot configure the ProfiNet interface.
Possible causes:
- The configuration data for the ProfiNet interface are incomplete or incorrect.
- The firmware of the ProfiNet interface is not compatible with the control software.

Error correction

Inform your machine tool builder


Error description 235-0036

Error message

ProfiNet: Hardware error

Cause of error

The firmware of the ProfiNet interface is not compatible with TNC.

Error correction

Inform your machine tool builder


Error description 235-0037

Error message

Initialization of ProfiNet interface failed

Cause of error

The TNC cannot read a ProfiNet project file.

Error correction

Inform your machine tool builder


Error description 235-0038

Error message

Initialization of ProfiNet interface failed

Cause of error

The ProfiNet interface requests unavailable project files from the TNC.

Error correction

Inform your machine tool builder


Error description 235-0039

Error message

CBE cannot be started

Cause of error

Unsuccessful start of the ProfiNet interface CBE30.

Error correction

Inform your machine tool builder


Error description 235-003A

Error message

Error in memory locking

Cause of error

Required memory could not be reserved.

Error correction

Inform your service agency


Error description 235-003B

Error message

Firmware update not possible

Cause of error

Internal error during firmware update!

Error correction

Inform your machine tool builder


Error description 235-003C

Error message

Version information missing in firmware file

Cause of error

No version information was found in a firmware file.

Error correction

Inform your machine tool builder


Error description 235-003D

Error message

Firmware could not be started

Cause of error

Unsuccessful device firmware start.

Error correction

Inform your machine tool builder


Error description 235-003E

Error message

Error in the hardware configuration

Cause of error

An error was found in the hardware configuration.

Error correction

Inform your machine tool builder


Error description 235-003F

Error message

Error in ProfiNet communication

Cause of error

An error occurred during communication with a unit on the ProfiNet bus.

Error correction

- Check all devices and connections
- Contact your machine tool builder


Error description 235-0040

Error message

No access to the configuration

Cause of error

Required configuration data could not be requested from configuration server.

Error correction

Inform your service agency


Error description 235-0041

Error message

No access to event server

Cause of error

Failed access to event server.

Error correction

Inform your service agency


Error description 235-0042

Error message

CC controller unit cannot be started

Cause of error

A CC controller unit cannot be started or the firmware could not be correctly transferred.

Error correction

- CC controller unit
- Contact your machine tool builder


Error description 235-0043

Error message

HSCI watchdog could not be deleted

Cause of error

The HSCI watchdog could not be deleted.

Error correction

Inform your service agency


Error description 235-0044

Error message

Error in HSCI communication

Cause of error

An error occurred during communication with a unit on the HSCI bus.

Error correction

- Check the voltage supply to the devices
- Check all devices and connections
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Inform your service agency


Error description 235-0045

Error message

HSCI connection error

Cause of error

A connection error was found on the HSCI bus.

Error correction

- Check all devices and connections
- Check the connection sequence of the HSCI connecting cables (X500 -> X502 or X501 -> X502)
- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Inform your service agency


Error description 235-0046

Error message

Error in detection of CC controller unit

Cause of error

An error occurred during detection of the connected CC controller unit.

Error correction

Inform your service agency


Error description 235-0047

Error message

Error in message from CC

Cause of error

Erroneous information was received from a CC.

Error correction

Inform your service agency


Error description 235-0048

Error message

Error in message from PL module

Cause of error

Erroneous information was received from a PL module.

Error correction

Inform your service agency


Error description 235-0049

Error message

PL error

Cause of error

A PL module has reported an error.

Error correction

Inform your service agency


Error description 235-004A

Error message

Software versions of PL module and MC do not match

Cause of error

The software versions of the PL module and the MC computer unit do not match.

Error correction

Inform your machine tool builder


Error description 235-004B

Error message

PL module could not be started

Cause of error

PL program could not be started.

Error correction

- Check the PL module
- Inform your service agency


Error description 235-004C

Error message

PL: No bus model found

Cause of error

No bus module was found in a PL module.

Error correction

- Check the PL module
- Inform your service agency


Error description 235-004D

Error message

Unknown PL software

Cause of error

A PL module has unknown software.

Error correction

- Check the PL module
- Inform your service agency


Error description 235-004E

Error message

Too many slots on PL module

Cause of error

A PL module has more slots than allowed.

Error correction

- Check the PL module
- Inform your service agency


Error description 235-004F

Error message

Error in identification of the hardware

Cause of error

A hardware unit could not be properly identified.

Error correction

Inform your service agency


Error description 235-0050

Error message

Hardware not found

Cause of error

A required hardware unit was not found.

Error correction

- Check all devices and connections
- Inform your service agency


Error description 235-0051

Error message

Error in communication with SPI module

Cause of error

An error occurred during communication with an SPI module.

Error correction

Inform your service agency


Error description 235-0052

Error message

Error in a file operation

Cause of error

A file operation has failed.

Error correction

Inform your service agency


Error description 235-0053

Error message

Error during hardware detection

Cause of error

Error during hardware detection

Error correction

Inform your service agency


Error description 235-0054

Error message

Access of non-supported hardware

Cause of error

A connected hardware unit is not supported by the software in use.

Error correction

Inform your machine tool builder


Error description 235-0055

Error message

Firmware update required (%1)

Cause of error

A firmware update is required on an assembly.
The assembly concerned is indicated in the additional information.

Error correction

This firmware update requires a confirmation by the user.
Note the following messages.


Error description 235-0056

Error message

Firmware update required (%1)

Cause of error

A firmware update is required on an assembly.
The assembly concerned is indicated in the additional information.

Error correction

- Shut down the control software.
- Manually start the firmware update on the HeROS console.


Error description 235-0057

Error message

Firmware update is running (%1)

Cause of error

At present the control is updating the firmware on an assembly.
The assembly concerned is indicated in the additional information.

Error correction

Wait until the firmware update has been completed.
Note the following messages.


Error description 235-0058

Error message

Firmware update has been completed (%1)

Cause of error

The firmware update was completed successfully.
The assembly concerned is indicated in the additional information.


Error description 235-0059

Error message

Firmware update failed (%1)

Cause of error

The firmware update has failed.
The assembly concerned is indicated in the additional information.

Error correction

- Note further error messages.
- Eliminate the cause of error.
- Shut down the control and restart.
The firmware update will be repeated automatically the next time the control is started.


Error description 235-005A

Error message

Firmware update failed (%1)

Cause of error

The firmware update has failed.
The assembly concerned is indicated in the additional information.

Error correction

The assembly might now no longer be usable.
Inform your service agency.


Error description 235-005B

Error message

Control software shutdown delayed

Cause of error

At present the control software cannot be shut down because a firmware update is in progress.

Error correction

Wait until the firmware update has been completed.
The control software then shuts down automatically.


Error description 235-005C

Error message

System error

Cause of error

An as yet unimplemented function of a server was called.

Error correction

Inform your service agency


Error description 235-005D

Error message

System error

Cause of error

A server cannot find the sender of a message.

Error correction

Inform your service agency


Error description 235-005E

Error message

System error

Cause of error

A server cannot reach the sender of a message.

Error correction

Inform your service agency


Error description 235-005F

Error message

System error

Cause of error

A software error has occurred.

Error correction

Inform your service agency


Error description 235-0060

Error message

Not enough main memory (RAM)

Cause of error

There is not enough working memory (RAM) on the MC to operate the control.

Error correction

Inform your service agency


Error description 235-0061

Error message

Incompatible peripheral device (%1)

Cause of error

A peripheral device is incompatible with this control software and they cannot be operated together.
The device concerned is indicated in the additional information.

Error correction

- Exchange the device
- Inform your service agency


Error description 235-0062

Error message

Unknown device on HSCI bus (%1)

Cause of error

The NC software identifies every connected device by means of a device table.
The table indicates whether the device is supported by the software version installed on the control.
A device that the software does not support or that is not yet entered in the device table is connected to the HSCI bus.
The device concerned is indicated in the additional information.
The device table might have been overwritten by installing an update that was generated by an older software version.

Error correction

- Inform your service agency.
- Update the NC software if the device is not supported by the currently installed version of the NC software.
- Update the device table. The installed software might be able to control a new device that is not yet listed in the device table. In this case the device table must be updated.


Error description 235-0063

Error message

Unknown device on the ProfiNet interface (%1)

Cause of error

The NC software identifies every connected devices by means of a device table.
The table indicates whether the device is supported by the software version installed on the control.
A device that the software does not support or that is not yet entered in the device table is connected over the ProfiNet interface.
The device concerned is indicated in the additional information.

Error correction

- Inform your service agency
- Run an update of the NC software if the device is not supported by the currently installed version of NC software.
- Update the device table. A new device that is not yet listed in the device table might be supported by the installed software. In this case an update of the device table is required.


Error description 235-0064

Error message

Unknown device on the DriveCLiQ interface (%1)

Cause of error

The NC software identifies every connected devices by means of a device table.
The table indicates whether the device is supported by the software version installed on the control.
A device that the software does not support or that is not yet entered in the device table is connected over the DriveCLiQ interface.
The device concerned is indicated in the additional information.

Error correction

- Inform your service agency
- Run an update of the NC software if the device is not supported by the currently installed version of NC software.
- Update the device table. A new device that is not yet listed in the device table might be supported by the installed software. In this case an update of the device table is required.


Error description 235-0065

Error message

Device table is faulty

Cause of error

The device table is incorrect or cannot be used by the control.

Error correction

Inform your service agency.


Error description 235-0066

Error message

Device (%1) reports error: %2

Cause of error

A device connected with the control has an error.
The device concerned is indicated in the additional information.
Possible causes:
- The device code programmed on the device is incorrect.
- The device's firmware is not compatible with the control software.
- The device is defective.

Error correction

Inform your machine tool builder.


Error description 235-0067

Error message

Error on device (%1)

Cause of error

An error has occurred on a device connected with the control.
The device concerned is indicated in the additional information.
Possible causes:
- The device code programmed on the device is incorrect.
- The device's firmware is not compatible with the control software.
- The device is defective.

Error correction

Inform your machine tool builder.


Error description 235-0068

Error message

Exchange the peripheral device (%1)

Cause of error

During startup it was discovered that a hardware component connected to the control is not compatible with the current level of the NC software.
The device concerned is indicated in the additional information.
A required update of the device's firmware is not possible.
HEIDENHAIN recommends exchanging the component as soon as possible.

Error correction

Contact your service agency.


Error description 235-0069

Error message

PROFINET: Protocol error

Cause of error

A PROFINET end device has transmitted data to the control that the control cannot interpret.
It could be that the version of the PROFINET protocol used by the PROFINET end device is not supported by the TNC,
The PROFINET end device concerned is indicated in the additional information.

Error correction

Inform your service agency.


Error description 235-006A

Error message

Error in communication with the PROFINET controller

Cause of error

An error occurred in the communication between the control and the PROFINET controller.

Error correction

Inform your service agency.


Error description 235-006B

Error message

IOC file not configured

Cause of error

No file name was given for the IOC file.

Error correction

Configure the file name IOC file


Error description 235-006C

Error message

Error in IOC file

Cause of error

There is an error in the IOC file.
The additional information provides more data.

Error correction

- Check and correct the IOC file with the PC software IOconfig.
- Inform your service agency.


Error description 235-006D

Error message

Insufficient or faulty command parameters

Cause of error

A command with faulty or insufficient parameters was transferred to the part of the NC software responsible for the control of the hardware components.

Error correction

- Check the parameters
- Inform your service agency.


Error description 235-006E

Error message

IOC file cannot be opened

Cause of error

The IOC file could not be opened.
The file name is indicated in the additional information.

Error correction

Check the configuration of the IOC file name.


Error description 235-006F

Error message

IOC file format error

Cause of error

Control cannot interpret the IOC file.
The file format is faulty or unknown.

Error correction

Check the IOC file with the PC software IOconfig.


Error description 235-0070

Error message

Incorrect format version of the IOC file

Cause of error

The IOC file cannot be processed because it is in the wrong format version.
Minimum required format version:
- PROFIBUS: IOC-V2
- AS-i: IOC-V2
- HSCI: IOC-V3
- PROFINET: IOC-V4

Error correction

Check the IOC file and provide the correct format version.


Error description 235-0071

Error message

IOC file: No PROFINET controller is configured

Cause of error

The PROFINET controller cannot be configured because there is no data for it in the IOC file.

Error correction

Use the PC software IOconfig to configure the PROFINET controller.


Error description 235-0072

Error message

PROFINET: Too many devices configured

Cause of error

More PROFINET devices were configured than allowed.

Error correction

- Observe the additional information.
- Reduce the number of configured devices.


Error description 235-0073

Error message

PROFINET: project setup error

Cause of error

The configuration of the PROFINET topology is faulty.

Error correction

- Observe the additional information.
- Correct the IOC file.


Error description 235-0074

Error message

PROFINET: Process data memory is insufficient

Cause of error

The maximum size of the process data for PROFINET devices has been exceeded.

Error correction

Reduce the number of PROFINET end devices or the connected modules.


Error description 235-0075

Error message

PROFINET: No common RT class supported

Cause of error

A PROFINET end device cannot be activated by the control because the control and the end device have no common RT class.
The device concerned is indicated in the additional information.

Error correction

Configure the PROFINET end device that can be operated with RT class 1.


Error description 235-0076

Error message

PROFINET interface not activated

Cause of error

The control cannot activate the PROFINET interface because there is an error.

Error correction

- Note further messages.
- Eliminate the cause of error.
- Shut the control down and restart it.


Error description 235-0077

Error message

HSCI cabling error: Controller connected to X501

Cause of error

At least one controller unit (CC, UEC, UMC) was connected via HSCI to X501 of the MC.
However, controller units must be connected to X500 of the MC.

Error correction

- Check the HSCI cabling
- Connect all controller units (CC, UEC, UMC) an X500 of the MC
- If the problem continues, please generate a service file and inform your service agency


Error description 235-0078

Error message

HSCI cabling error: Too many devices on X501

Cause of error

There are too many HSCI components connected to X501 of the MC

Error correction

- Check the HSCI cabling.
- Use the default values of your control's Technical Manual for the maximum number of HSCI components.
- Check the HSCI configuration. It may be possible to connect HSCI components to the X500 connector of the MC.
- Generate the service files and inform your service agency.


Error description 235-0079

Error message

No contact to ProfiNet terminal

Cause of error

Interrupted communication between the control and a ProfiNet terminal.

Error correction

Check the hardware setup, the IOC file and the options set.
You can find more information in the PROFINET diagnostics.


Error description 235-007A

Error message

Faulty module configuration on ProfiNet terminal

Cause of error

The ACTUAL and NOMINAL configuration do not match on a ProfiNet terminal:
- A module is configured, but it has not be plugged into the device.
- A different module is configured than is plugged into the device.

Error correction

Check the hardware setup, the IOC file and the options set.
You can find more information in the PROFINET diagnostics.


Error description 235-007B

Error message

Unknown device on SPI bus (%1)

Cause of error

The NC software identifies every connected devices by means of a device table.
The table indicates whether the device is supported by the software version installed on the control.
A device that the software does not support or that is not yet entered in the device table is connected with the SPI bus.
The device concerned is indicated in the additional information.

Error correction

- Inform your service agency.
- Run an update of the NC software if the device is not supported by the currently installed version of NC software.
- Update the device table. A new device that is not yet listed in the device table might be supported by the installed software. In this case an update of the device table is required.


Error description 235-007C

Error message

Error during read-in of the machine configuration data

Cause of error

The file(s) of the machine configuration or machine parameters cannot be read. It is either missing or damaged.

Error correction

- Start control as a programming station
- Check the file(s) of the machine configuration (machine parameters) and, if required, recreate or correct them
- Inform your service agency


Error description 235-007D

Error message

PLCE partition has not yet been formatted

Cause of error

The encrypted PLCE partition has not yet been formatted.

Error correction

- Start the PLCE setup dialog
- Enter an encryption password
- Format the PLCE partition


Error description 235-007E

Error message

Encryption password for PLCE partition incorrect

Cause of error

The PLCE partition could not be integrated because the encryption password is incorrect or the partition is not yet formatted.

Error correction

- Start the PLCE setup dialog.
- Enter the correct encryption password.
- Include the partition.
or
- Enter a new encryption password.
- Format the PLCE partition.
- Include the partition.


Error description 235-007F

Error message

PLCE partition cannot be integrated

Cause of error

The PLCE partition is already being used at present and therefore cannot be included.

Error correction

- Manually enable the PLCE partition or
- Reboot the control


Error description 235-0080

Error message

No password available for PLCE partition

Cause of error

An existing PLCE partition cannot be integrated for the following reasons:
- Failure to read the password from the SIK.
- Nor is the password available anywhere else.

Error correction

Ensure that the correct SIK is inserted in the MC.


Error description 235-0081

Error message

Machine configuration file (.mcg) %1 is faulty

Cause of error

There is an error in the machine configuration.
You will find more detailed information on the error in the additional information.

Error correction

Inform your service agency.


Error description 235-0083

Error message

Error during import of the machine configuration file (.mcg) %1

Cause of error

The machine configuration file (.mcg) cannot be imported.
You will find more detailed information on the error in the additional information.

Error correction

- Check the configuration datum CfgPlcPath.compCfgFile.
- Inform your service agency.


Error description 235-0085

Error message

Topology error in IOC file

Cause of error

The options set in the machine configuration do not match those in the IOC file.
You will find more detailed information on the error in the additional information.

Error correction

- Check the options set in the machine configuration and in the IOC file.
- Inform your service agency.


Error description 235-0086

Error message

Supervisor takes over control of PROFINET terminal

Cause of error

A supervisor has taken control of a PROFINET terminal connected to the control.
The machine cannot be switched back on until the supervisor has returned control.

Error correction

- Tell the supervisor to return control to the NC control
- Acknowledge the error
- Switch on the machine
- You can find more information in the PROFINET diagnostics


Error description 235-0087

Error message

NC software not supported by hardware

Cause of error

– The presently installed NC software version is not supported by this control hardware.
- The MC main computer offers too little computing power to support all functions of the installed software.

Error correction

- Check the combination of NC software and control hardware
– Inform your service agency


Error description 235-0088

Error message

Illegal parallel connection of two power modules

Cause of error

- Two different power modules were connected parallel through an adapter.
- Only power modules of the same type can be connected in parallel.
- The affected devices are shown in the additional information.

Error correction

- Check the connection of the power modules and correct it.
- Inform your service agency.


Error description 235-008A

Error message

Not possible to switch the HSCI data rate

Cause of error

The HSCI data rate of 1 Gbit/s was preset in the configuration datum MP_dataRateHsci in CfgHardware.
However, the HSCI system cannot be operated with this data rate because
- no HSCI device was connected, or
- at least one connected HSCI device is not suited for a 1 Gbit/s data rate.

Error correction

Check the connected HSCI devices for suitability for a 1 Gbit/s data rate.
In the configuration datum MP_dataRateHsci in CfgHardware, select the data rate 100 Mbit/s or “as fast as possible.”


Error description 235-008B

Error message

Switchover of HSCI data rate has failed

Cause of error

The HSCI data rate of 1 Gbit/s was preset in the configuration datum MP_dataRateHsci in CfgHardware.
However, the HSCI system could not be switched to the 1 Gbit/s data rate.
There might be connecting cables in the HSCI system that are not made for this data rate.

Error correction

Check the HSCI cable for suitability for the 1 Gbit/s data rate.
In the configuration datum MP_dataRateHsci in CfgHardware, select the data rate 100 Mbit/s or “as fast as possible.”


Error description 235-008C

Error message

Configure the HSCI data rate to 100 Mbit

Cause of error

In the configuration datum MP_dataRateHsci in CfgHardware, the HSCI data rate “as fast as possible” was selected.
The control found that all connected HSCI are suited for the 1 Gbit/s data rate, but there is at least one cable in the HSCI system that is not suited for this data rate.
Because of this hardware configuration, system startup is delayed.

Error correction

To speed up the system startup, do the following:
In the configuration datum MP_dataRateHsci in CfgHardware, select the data rate 100 Mbit/s or
check the HSCI cable for suitability for the 1 Gbit/s data rate.


Error description 235-008D

Error message

Required HSCI data rate cannot be attained

Cause of error

There is at least one device in the HSCI system that requires a data rate of 1 Gbit/s for operation.
However, this data rate cannot be set because at least one further device in the HSCI system is not suited for a data rate of 1 Gbit/s.

Error correction

Check all HSCI devices for suitability for a 1 Gbit/s data rate.


Error description 235-008E

Error message

Required HSCI data rate cannot be attained.

Cause of error

There is at least one device in the HSCI system that requires a data rate of 1 Gbit/s for operation.
However, this data rate cannot be set because at least one connecting cable in the HSCI system is not suited for a data rate of 1 Gbit/s.

Error correction

Check the HSCI connecting cable for suitability for a data rate of 1 Gbits.


Error description 235-008F

Error message

HSCI data rate of 1 Gbit/s is required

Cause of error

The HSCI data rate of 100 Mbit/s was preset in the configuration datum MP_dataRateHsci in CfgHardware.
- However, at least one connected HSCI device requires a 1 Gbit/s data rate for operation.

Error correction

In the configuration datum MP_dataRateHsci in CfgHardware, select the 1 Gbit/s setting or “as fast as possible.”


Error description 235-0090

Error message

No original HEIDENHAIN driver software

Cause of error

Software for the operation of devices of a third manufacturer has been loaded via IOconfig to the control. It is not original HEIDENHAIN software.
This software is not activated.

Error correction

- Use only original HEIDENHAIN software.
- Inform your service agency.


Error description 235-0091

Error message

Driver software cannot be activated

Cause of error

Software for the operation of devices of a third manufacturer was transferred via IOconfig to the controller.
Due to an error, this software cannot be activated.

Error correction

- Note the additional information
- Inform your service agency


Error description 235-0092

Error message

Not enough memory on periphery hardware (%1)

Cause of error

Since not enough memory is available on a device, that device cannot be run with this control software.
The device concerned is indicated in the additional information.

Error correction

- Exchange device
- Inform your service agency


Error description 235-0093

Error message

Identification requested over PROFINET

Cause of error

A participant in a PROFINET network, usually a programming device, is demanding that the control identify itself.


Error description 235-0094

Error message

Error while initializing the device %2, SN: %4

Cause of error

The device %2 (ID number %3, serial number %4, path %1) could not be initialized.

Error correction

Inform your service agency


Error description 235-0095

Error message

Excessive propagation time in HSCI system

Cause of error

Too many HSCI participants are connected to the HSCI bus, or the total length of the HSCI cables is too long.

Error correction

- Reduce the number of HSCI participants
- Use shorter HSCI cables


Error description 235-0096

Error message

Error while evaluating a filter condition in the IOCP file

Cause of error

DEFINE missing in the MCG file.
Faulty filter condition in the IOCP file.
The incorrectly evaluated condition is shown in the additional data.
The name of the MCG file is shown in the additional data.

Error correction

- Check the MCG file and correct it if necessary
- Check the filter condition in the IOCP file and correct it if necessary


Error description 235-0097

Error message

IOC options defined more than once

Cause of error

IOC options are defined twice in the configuration or in the MCG file.

Error correction

Correct the configuration: remove the superfluous IOC options


Error description 235-0098

Error message

Empty IOC option defined

Cause of error

An empty IOC option is defined in the configuration or in the MCG file.

Error correction

Correct the configuration: remove the empty IOC option


Error description 235-0099

Error message

Configured device not in the HSCI chain

Cause of error

The following configured devices are missing in the HSCI chain:
Info: Type (name from configuration)
%1
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Device not connected at that address

Error correction

- Check configuration and the options in effect
- Check cabling of the HSCI chain
You can use the diagnostics functions of the control for this.


Error description 235-009A

Error message

Configured device not in the HSCI chain

Cause of error

At least one configured device is missing in the HSCI chain.
Due to ambiguities, the missing devices cannot be identified precisely. The possible devices are listed below:
Configuration [Device type (name)]:
%1
Hardware [Device type (HSCI address, serial number)]:
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Device not connected at that address

Error correction

- Check configuration and the options in effect
- Check cabling of the HSCI chain
You can use the diagnostics functions of the control for this.


Error description 235-009B

Error message

Wrong device in the HSCI chain

Cause of error

The device at HSCI address %3 is not the one that was configured:
Configuration [Device type (name)]:
%1
Hardware [Device type (HSCI address, serial number)]:
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Incorrect device connected

Error correction

- Check configuration and the options in effect
- Check cabling of the HSCI chain
You can use the diagnostics functions of the control for this.


Error description 235-009C

Error message

Two devices swapped in the HSCI chain

Cause of error

The following two devices in the HSCI chain are swapped compared with the configuration:
Info: Type (HSCI address, serial number)
%1
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Incorrect cabling in HSCI chain

Error correction

- Check configuration and the options in effect
- Check cabling of the HSCI chain
You can use the diagnostics functions of the control for this.


Error description 235-009D

Error message

Device not configured in the HSCI chain

Cause of error

The following devices are not configured in the HSCI chain:
Info: Type (HSCI address, serial number)
%1
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Extra device connected

Error correction

- Check configuration and the options in effect
- Check cabling of the HSCI chain
You can use the diagnostics functions of the control for this.


Error description 235-009E

Error message

Non-configured device in the HSCI chain

Cause of error

At least one device in the HSCI chain is not configured.
Due to ambiguities, the extra devices cannot be identified precisely. The possible devices are listed below:
Configuration [Device type (name)]:
%1
Hardware [Device type (HSCI address, serial number)]:
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Extra device connected

Error correction

- Check configuration and the options in effect
- Check cabling of the HSCI chain
You can use the diagnostics functions of the control for this.


Error description 235-009F

Error message

Hardware setup does not match configuration

Cause of error

The hardware expansion in the HSCI chain does not match the configuration. The deviation is so large that the control cannot provided relevant information.
Configuration [Device type (name)]:
%1
Hardware [Device type (HSCI address, serial number)]:
%2
Possible causes:
- Incorrect IOCP file loaded
- Option for configuring the hardware expansion was set incorrectly

Error correction

- Check the IOCP file
- Check configuration and the options in effect
- Check cabling of the HSCI chain
You can use the diagnostics functions of the control for this.


Error description 235-00A0

Error message

Inverter not found at HSCI device

Cause of error

The following inverters are not present for device %4 with the serial number %5 at HSCI address %3:
Info: Type (port)
%1
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Inverter not connected

Error correction

- Check configuration and the options in effect
- Check the module structure of the device
You can use the diagnostics functions of the control for this.


Error description 235-00A1

Error message

Wrong module in HSCI device

Cause of error

The following modules on device %4 with serial number %5 at HSCI address %3 do not match the configuration:
Info: Type (slot)
Configuration:
%1
Hardware:
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Incorrect module connected

Error correction

- Check configuration and the options in effect
- Check the connected module
You can use the diagnostics functions of the control for this.


Error description 235-00A2

Error message

Wrong inverter at HSCI device

Cause of error

The following inverters on device %4 with the serial number %5 at HSCI address %3 do not match the configuration:
Configuration: [Type (port)]
%1
Hardware [Type (port, serial number)]:
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Incorrect inverter connected

Error correction

- Check configuration and the options in effect
- Check the connected inverter
You can use the diagnostics functions of the control for this.


Error description 235-00A3

Error message

Module in wrong slot

Cause of error

The following modules are in the wrong slot of device %4 with the serial number %5 at HSCI address %3:
Info: Type (nominal slot<->actual slot)
%1
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Modules in wrong slots

Error correction

- Check configuration and the options in effect
- Check position of module in device
You can use the diagnostics functions of the control for this.


Error description 235-00A4

Error message

Inverter at wrong port

Cause of error

The following inverters are at the wrong port on device %4 with the serial number %5 at HSCI address %3:
Info: Type (nominal port<->actual port)
%1
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Inverter connected incorrectly

Error correction

- Check configuration and the options in effect
- Check the inverter connection
You can use the diagnostics functions of the control for this.


Error description 235-00A5

Error message

Two modules swapped

Cause of error

On device %4 with the serial number %5 at HSCI address %3, two modules are swapped compared to the configuration:
Info: Type (nominal slot<->actual slot)
%1
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Modules in wrong slot

Error correction

- Check configuration and the options in effect
- Check positions of the modules
You can use the diagnostics functions of the control for this.


Error description 235-00A6

Error message

Two inverters swapped

Cause of error

On device %4 with the serial number %5 at HSCI address %3, two inverters are swapped compared to the configuration:
Info: Type (nominal port<->actual port)
%1
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Inverter connected incorrectly

Error correction

- Check configuration and the options in effect
- Check the inverter connections
You can use the diagnostics functions of the control for this.


Error description 235-00A7

Error message

Extra module in HSCI device

Cause of error

The following non-configured modules are on device %4 with the serial number %5 at HSCI address %3:
Info: Type (slot)
%1
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Extra module connected

Error correction

- Check configuration and the options in effect
- Check the module structure of the device
You can use the diagnostics functions of the control for this.


Error description 235-00A8

Error message

Extra inverter at HSCI device

Cause of error

The following non-configured inverters are on device %4 with the serial number %5 at HSCI address %3:
Info: Type (port, serial number)
%1
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Extra inverter connected

Error correction

- Check configuration and the options in effect
- Check the connected inverters
You can use the diagnostics functions of the control for this.


Error description 235-00A9

Error message

Module extension does not match configuration

Cause of error

On device %4 with the serial number %5 at HSCI address %3, the connected modules do not match the configuration.
The deviation is so large that the control cannot provided relevant information.
Info: Type (slot)
Configuration:
%1
Hardware:
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Incorrect modules connected

Error correction

- Check configuration and the options in effect
- Check the module structure
You can use the diagnostics functions of the control for this.


Error description 235-00AA

Error message

Connected inverters do not match configuration

Cause of error

On device %4 with the serial number %5 at HSCI address %3, the connected inverters do not match the configuration.
The deviation is so large that the control cannot provided relevant information.
Configuration [Type (port)]:
%1
Hardware [Type (port, serial number)]:
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Incorrect inverter connected

Error correction

- Check configuration and the options in effect
- Check the connected inverters
You can use the diagnostics functions of the control for this.


Error description 235-00AC

Error message

Module missing in HSCI device

Cause of error

On device %4 with the serial number %5 at HSCI address %3, at least one configured module is missing.
Due to ambiguities, the missing modules cannot be identified precisely. The possible devices are listed below:
Info: Type (slot)
Configuration:
%1
Hardware:
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Module not connected
- Module in wrong slot

Error correction

- Check configuration and the options in effect
- Check the module structure of the device
You can use the diagnostics functions of the control for this.


Error description 235-00AD

Error message

Inverter not found at HSCI device

Cause of error

On device %4 with the serial number %5 at HSCI address %3, at least one configured inverter is missing.
Due to ambiguities, the missing inverters cannot be identified precisely. The possible devices are listed below:
Configuration [Type (port)]:
%1
Hardware [Type (port, serial number)]:
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Inverter not connected
Inverter connected to wrong port

Error correction

- Check configuration and the options in effect
- Check the module structure of the device
You can use the diagnostics functions of the control for this.


Error description 235-00AE

Error message

Extra module in HSCI device

Cause of error

On device %4 with the serial number %5 at HSCI address %3, at least one non-configured module is connected.
Due to ambiguities, the extra modules cannot be identified precisely. The possible devices are listed below:
Info: Type (slot)
Configuration:
%1
Hardware:
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Extra module connected
- Module in wrong slot

Error correction

- Check configuration and the options in effect
- Check the module structure of the device
You can use the diagnostics functions of the control for this.


Error description 235-00AF

Error message

Extra inverter at HSCI device

Cause of error

On device %4 with the serial number %5 at HSCI address %3, at least one non-configured inverter is connected.
Due to ambiguities, the extra inverters cannot be identified precisely. The possible devices are listed below:
Configuration [Type (port)]:
%1
Hardware [Type (port, serial number)]:
%2
Possible causes:
- Option for configuring the hardware expansion was set incorrectly
- Extra inverter connected
Inverter connected to wrong port

Error correction

- Check configuration and the options in effect
- Check the connected inverters
You can use the diagnostics functions of the control for this.


Error description 236-A001

Error message

Command cannot be run

Cause of error

The ProfiNet software module cannot run a command.
Possible causes:
- The addressed ProfiNet end device is in a condition that prevents execution of the command.
- The addressed ProfiNet end device does not exist or is not available.
- The command code unknown

Error correction

Inform your service agency


Error description 236-A002

Error message

Error during read-in of ProfiNet configuration data

Cause of error

The ProfiNet software module cannot read its configuration data.

Error correction

Check the configuration data and restart the control.


Error description 236-A003

Error message

Initialization of ProfiNet interface failed

Cause of error

An error occurred during device initialization of the ProfiNet interface.
Possible causes:
- The TNC cannot speak to the ProfiNet interface.
- The firmware of the ProfiNet interface is not compatible with the control software.
- The configuration data for the ProfiNet interface are incorrect.

Error correction

Inform your machine tool builder.


Error description 236-A004

Error message

Change of operating mode in ProfiNet interface failed

Cause of error

The ProfiNet interface failed to switch between the asynchronous and cyclic operating modes.
Possible cause:
Internal error on the ProfiNet interface

Error correction

Inform your machine tool builder


Error description 236-A005

Error message

ProfiNet: Assignment of drives incorrectly configured

Cause of error

Inconsistent assignment of the drives connected over ProfiNet with the axes managed by the TNC.
The configuration data under System/ProfiNet/ParameterSets are incomplete.

Error correction

Check the configuration.


Error description 236-A006

Error message

ProfiNet: Error during assignment of drives

Cause of error

The TNC cannot assign an axis to a drive connected over ProfiNet.
Possible causes:
- The configuration data under ProfiNet/ParameterSets are incorrect.
- There is a fault in a drive.

Error correction

Remove the cause of error and acknowledge the error message


Error description 236-A007

Error message

Watchdog error on the ProfiNet interface

Cause of error

The ProfiNet interface does not react to signals from the MC.
Possible cause:
ProfiNet interface is defective

Error correction

Inform your machine tool builder


Error description 236-A101

Error message

No contact to ProfiNet end device %1

Cause of error

The ProfiNet end device does not respond.
Possible causes:
- Error in project setup
- Inconsistent configuration of the ProfiNet end device name
- Interrupted connection between TNC and ProfiNet end device
- There is a fault in the ProfiNet end device.

Error correction

Check the ProfiNet topology and project setup. Acknowledge the error.


Error description 236-A102

Error message

Error during access to ProfiNet end device %1

Cause of error

The TNC cannot initialize the ProfiNet end device.

Error correction

Acknowledge the error


Error description 236-A103

Error message

Contact lost to ProfiNet end device %1

Cause of error

Interrupted communication between TNC and a ProfiNet end device.
Possible causes:
- The end device was separated from the control.
- There is a fault in the end device.

Error correction

Check the ProfiNet end device. Acknowledge the error


Error description 236-A104

Error message

Error during access to ProfiNet end device %1

Cause of error

An error occurred during initialization of the ProfiNet end device.
The TNC cannot find any configuration data for a slot on the end device, or the data are erroneous.

Error correction

Check the configuration data under System/ProfiNet/Slots. Acknowledge the error


Error description 236-A121

Error message

Error during access to ProfiNet end device %1

Cause of error

An error occurred during initialization of the ProfiNet end device.
The TNC cannot access the configuration data of the ProfiNet end device.

Error correction

Check the configuration and acknowledge the error


Error description 236-A122

Error message

Error during access to ProfiNet end device %1

Cause of error

An error occurred during initialization of the ProfiNet end device.
The ProfiNet end device does not support the TNC-compatible version of the ProfiDrive profile.

Error correction

Check the configuration and acknowledge the error


Error description 236-A123

Error message

Error during access to ProfiNet end device %1

Cause of error

An error occurred during initialization of the ProfiNet end device.
There are more drive objects logged in on the ProfiNet end device for cyclic data exchange with the TNC as on the ProfiNet interface.

Error correction

Check the ProfiNet project setup and acknowledge the error


Error description 236-A201

Error message

ProfiNet: Error while initializing the drive %1

Cause of error

The TNC cannot initialize the drive.
There are no correct configuration data for this drive.

Error correction

Check Configuration data and system/ProfiNet/Slots as well as the telegram project data. Acknowledge the error


Error description 236-A202

Error message

ProfiNet: Error while initializing the drive %1

Cause of error

The TNC cannot initialize the drive.
Possible causes:
- The TNC cannot access the configuration data of the drive.
- The type of drive is not supported by the TNC or is configured incorrectly on the TNC.
- The TNC and drive have different telegram types configured for cyclic data exchange.
- The TNC cannot access the buffer memory for fault messages.
- The TNC cannot access the buffer memory for warnings.

Error correction

Check the project setup data and acknowledge the error


Error description 236-A203

Error message

ProfiNet: Drive %1 does not react

Cause of error

The drive does not react to the control signals of the TNC.
There is a fault in the drive.

Error correction

Eliminate the cause and acknowledge the error


Error description 236-A204

Error message

ProfiNet: Drive %1 does not react

Cause of error

The drive does not react.
Possible causes:
- The connection between the TNC and drive was interrupted.
- There is a fault in the drive.

Error correction

Eliminate the cause and acknowledge the error


Error description 236-A211

Error message

ProfiNet: Drive %1 reports a fault

Cause of error

The drive reports a fault.
Watch further messages for more detailed information on the type of fault.

Error correction

Eliminate the cause and acknowledge the error


Error description 236-A212

Error message

ProfiNet: Drive %1 reports error code %2

Cause of error

The drive reports a fault.

Error correction

Remove the cause of error and acknowledge the message.


Error description 236-A213

Error message

ProfiNet: Drive %1 reports warning code %2

Cause of error

The drive is sending a warning.

Error correction

Remove the cause and acknowledge the message.


Error description 236-A221

Error message

ProfiNet: Drive %1 cannot be switched on

Cause of error

The TNC cannot switch on the drive.
Possible cause:
There is a fault in the drive.

Error correction

Eliminate the cause, acknowledge the error, and switch on again.


Error description 236-A222

Error message

Error during parameter set switchover to drive %1

Cause of error

An error occurred during a parameter set switchover on the drive.
Possible cause:
There is a fault in the drive.

Error correction

Eliminate the cause, acknowledge the error, and switch on again.


Error description 236-A301

Error message

Error when homing the axis %2

Cause of error

The TNC cannot home the axis.
Possible cause:
There is a fault in the drive.

Error correction

Eliminate the cause and acknowledge the error.


Error description 236-A302

Error message

Probe failed: Axis %2

Cause of error

An error occurred during the probing process.
Possible cause:
There is a fault in the drive.

Error correction

Eliminate the cause and acknowledge the error.


Error description 236-A401

Error message

Faulty motor encoder (drive/encoder: %1)

Cause of error

The drive encoder reports an error.
The error code is provided in the additional information.

Error correction

Eliminate the cause and acknowledge the error.


Error description 236-A402

Error message

Motor encoder (drive/encoder: %1) does not react

Cause of error

The encoder does not react to the control signals of the TNC.
Possible causes:
- The connection between the TNC and drive was interrupted.
- There is a fault in the drive controller.

Error correction

Eliminate the cause and acknowledge the error.


Error description 236-A403

Error message

Data transfer over PROFINET was interrupted

Cause of error

The PROFINET controller did not complete the process data transfer in time.

Error correction

Inform your service agency.


Error description 237-10001

Error message

10001 CC%2 Alarm for software test

Cause of error

- In the automatic software test an alarm was released

Error correction

- Inform your service agency


Error description 237-10003

Error message

10003 CC%2 System error in error memory management %4 %5

Cause of error

- Control was not properly shut down
- Hardware problem

Error correction

- Shut down the control, the switch it off and on.
- Inform your service agency


Error description 237-10004

Error message

10004 CC%2 Active drive during switch-off process

Cause of error

- A drive was still in the feedback loop during the switch-off process
- A drive was switched on during the switch-off process

Error correction

- Check the PLC program
- Inform your service agency


Error description 237-10005

Error message

10005 Drive switch-off error code: %4

Cause of error

- Switch-off due to an external emergency stop signal
- Error code:
1 = Signal -ES.A (emergency stop input on PL, MB)
2 = Signal -ES.A.HW (emergency stop input of the handwheel)
3 = Signal -ES.B (emergency stop input on PL, MB)
4 = Signal -ES.B.HW (emergency stop input of the handwheel)
Further error codes: internal code

Error correction

- Check additional information from alarm message 0x10005.
- Check the position of the emergency stop switch.
- Inform your service agency.


Error description 237-10006

Error message

10006 CC%2 SPLC-RTS status change=%4, new=%5

Cause of error


Error description 237-10007

Error message

10007 CC%2 Follow condition for AxGrp=%4, CC=%5, MC=%6, Cause=%7

Cause of error

-

Error correction

-


Error description 237-10008

Error message

10008 Error in data format of ASCII command, alarm code %4

Cause of error

- The CC controller has detected a syntax error in a transmitted ASCII command.
- The faulty command was either sent by the commissioning tool TNCopt, or
- the syntax of the compensation file in machine parameter compTorqueRipple is faulty.
The results of adjustments through TNCopt are saved in the compensation file.

Error correction

- If TNCopt was used, repeat the affected measurement with
TNCopt.
- Deactivate syntax monitoring for ASCII commands with
MiscCtrlFunctions bit 7 = 1.
- Deactivate the compensation file in the parameter compTorqueRipple.
- Inform your service agency.


Error description 237-10009

Error message

10009 CC%2 Follow condition for genSafe Id=%4, timer=%5, %6, %7

Cause of error


Error description 237-1000A

Error message

1000A CC%2 SS2 Request of IO device DeviceVariant=%4, count=%5

Cause of error


Error description 237-1000B

Error message

1000B CC%2 Force the S status bit - bit=%4, mode=%5

Cause of error


Error description 237-1000C

Error message

1000C CC%2 axis group: stop=%4 cause=%5 axis group=%6 condition=%7

Cause of error


Error description 237-1000E

Error message

1000E CC%2 file access action=%4, %5, %6

Cause of error

Error when accessing file
Additional info
0: Action
2: Open
4: Write
5: Read
6: Delete
7: Rename
8: Directory
103: Close
250: ASYNC interface was not enabled
251: Waiting for ASYNC acknowledge from MC
252: The MC hasn't sent any hcFILE_IO (acknowledge)
253: The MC hasn't sent any ASYNC telegram
300: Not allowed during an interrupt
301: File header is corrupt
Additional info 1, 2: MC error message

Error correction

- Inform your service agency


Error description 237-1000F

Error message

1000F Alarm not cleared; repeated alarm output


Error description 237-10010

Error message

10010 CC%2 ACC parameter ID=%4 Info1=%5

Cause of error

There is an error in the ACC parameter file:
- This file was created with a wrong version of TNCopt
- The file contains invalid parameter data

Error correction

- Use TNCopt to generate a new ACC parameter file
- Check the software version.
ID=1 Option missing
ID=2 Invalid axis entry
ID=10 Use is possible only on hardware with limited number of axes
ID=300 Missing acceleration feedforward control (MP2600)
ID=301 Motor's mass moment of inertia is missing from the motor table
ID=302 Constant for torque calculation is missing from the motor table
- Inform your service agency


Error description 237-10011

Error message

10011 Syntax in %4 in line %5 in column %6

Cause of error

- Syntax error in displayed file.
- Function is not supported in the displayed file with this software version

Error correction

- Check the syntax in the displayed file
- Use TNCopt to regenerate the displayed file
- Use appropriate machine parameters to deactivate the function
- Inform your service agency


Error description 237-10013

Error message

10013 NOD input in %4 in line %5 is incorrect

Cause of error

- Syntax error in displayed file.
- Function is not supported in the displayed file with this software version

Error correction

- The maximum number of nodes was exceeded.
- Reduce the number of nodes (NOD)
- Use TNCopt to regenerate the displayed file
- Use appropriate machine parameters to deactivate the function
- Inform your service agency


Error description 237-10014

Error message

10014 Invalid axis in %4 in line %5 (SAX)

Cause of error

- Syntax error in displayed file.
- Axis coupling not permissible or not possible

Error correction

- Axis coupling (SAX) is not possible because the axis is on another board
- Axis coupling (SAX) is not possible because the axis is deselected
- Use appropriate machine parameters to deactivate the function
- Use TNCopt to regenerate the displayed file
- Inform your service agency


Error description 237-10015

Error message

10015 Compensation point errors in %4 in line %5

Cause of error

- Syntax error in the displayed file
- Compensation point (NODE) not defined

Error correction

- Too many compensation points (NODx) in defined in the displayed file
- Use TNCopt to regenerate the displayed file
- Use appropriate machine parameters to deactivate the function
- Inform your service agency


Error description 237-10016

Error message

10016 Max. number of blocks in %4 exceeded

Cause of error

- Syntax error in the displayed file
- Maximum number of interpolation blocks has been exceeded

Error correction

- Maximum number of interpolation blocks has been exceeded
- Reduce the number of interpolation blocks
- Use TNCopt to regenerate the displayed file
- Inform your service agency


Error description 237-10017

Error message

10017 Controller unit performance too low

Cause of error

- The computing performance of the controller unit is not enough for the selected function
- Too many axes were configured for the controller unit

Error correction

- Deactivation of the expanded compensations
- Check the power of the controller unit used
- Inform your service agency


Error description 237-10018

Error message

10018 Compensation point errors in %4

Cause of error

- Syntax error in the displayed file
- Compensation points are incorrectly defined

Error correction

- Faulty compensation points (NODx) in the displayed file
- Compensation points (NODx) have to be in ascending order
- Use TNCopt to regenerate the displayed file
- Inform your service agency


Error description 237-10019

Error message

10019 Error in %4 in line %5

Cause of error

- Syntax error in the displayed file
- Faulty signal (SIGx) in the displayed line

Error correction

- The signal (SIGx) is not possible because the index is unknown
- Use appropriate machine parameters to deactivate the function
- Use TNCopt to regenerate the displayed file
- Inform your service agency


Error description 237-1001A

Error message

1001A File %4 does not exist

Cause of error

Displayed file could not be opened

Error correction

- Use TNCopt to regenerate the displayed file
- Edit machine parameters to deactivate the relevant function
- Inform your service agency


Error description 237-1001B

Error message

1001B CC (log): faulty memory area

Cause of error


Error description 237-1001C

Error message

1001C %4

Cause of error

No help text available


Error description 237-1001D

Error message

1001D %4

Cause of error

No help text available


Error description 237-1001E

Error message

1001E %4

Cause of error

No help text available


Error description 237-1001F

Error message

1001F Condensation water on supply module

Cause of error

- Temperature in electrical cabinet is too low
Condensation water on supply module

Error correction

- Check the electrical cabinet temperature
- Inform your service agency


Error description 237-10020

Error message

10020 Controller unit defective: CC%2

Cause of error

- The given CC controller unit is defective and must be exchanged.

Error correction

- Exchange the CC controller unit
- Inform your service agency


Error description 237-10021

Error message

10021 CC%2 file access action=%4, %5, %6

Cause of error

Warning about file access
Additional data
2: Opening of file not executed
Additional data 1,2: MC error message
Additional data[2] = 11: EAGAIN


Error description 237-10022

Error message

10022 CC %2 axis %1: Measurement was not finished correctly.

Cause of error

- This is an internal software error

Error correction

- Inform your service agency


Error description 237-10023

Error message

10023 CC%2: X%6 FO sign. strgth below warng threshld %1 (value = -%4dB)

Cause of error

- The signal strength of the FO connection (fiber optic cable to the UM converter) has fallen below a defined warning threshold

Error correction

- Check the optical fiber connections:
- Is the green LED on?
- Is the optical fiber plug fully engaged?
- Is the tip of the optical fiber clean?
- Ensure the proper bend radius
- Exchange the optical fiber


Error description 237-10024

Error message

10024 CC%2: X%6 FO signal weaker than minimum value %1 (Wert = -%4dB)

Cause of error

- The signal strength of the fiber optic connection (fiber optic cable to the UM converter) has fallen below a permissible minimum value

Error correction

- Check the fiber optic connection:
- Is the green LED on?
- Is the optical fiber plug fully engaged?
- Is the tip of the optical fiber clean?
- Ensure the proper bend radius
- Exchange the optical fiber


Error description 237-10025

Error message

10025 CC FSuC reports error %1

Cause of error

The FSuC (Functional Safety Microcontroller) on the CC reports an error.
For further information, note the following alarm messages (239-xxxx)!


Error description 237-10026

Error message

10026 CC%2: UEC dc-link current too high (I-nom: %4, I-act: %5)

Cause of error

- Excessive DC-link current of the UEC
- Machine is overloaded while machining the workpiece

Error correction

- Continue working, but with less power (reduce the feed rate, replace a blunt tool, etc.)
- Reduce the power being consumed simultaneously by all drives
- Reduce or limit the spindle power
- Reduce the spindle acceleration
- Ensure that the spindle and axes accelerate at different times
- Reduce the cutting depths


Error description 237-10027

Error message

10027 CC%2: UEC dc-link voltage too high (U-min: %4, U-act: %5)

Cause of error

- DC-link voltage of the UEC is too high

Error correction

- Check the braking resistor of the UEC and exchange it if necessary
- Check the wiring of the braking resistor
- Check the line fuses
- For operation with an optional RM regenerative module:
- Check the regenerative module and exchange it if necessary
- Check the wiring of the regenerative module (power grid side and DC link)
- Replace the UEC if necessary


Error description 237-10028

Error message

10028 CC%2: UEC dc-link voltage too low (U-min: %4, U-act: %5)

Cause of error

- DC-link voltage of the UEC is too low

Error correction

- Check the wiring of the UEC
- Check the 3-phase voltage supply of the UEC
- Check the line fuses
- Monitor for sporadic power failures


Error description 237-10029

Error message

10029 CC%2: UEC dc-link voltage too high with RM (U-max: %4, U-act: %5)

Cause of error

The DC-link voltage is too high despite the use of an RM regenerative module.

Error correction

- For operation with an optional RM regenerative module:
- Check the regenerative module and exchange it if necessary
- Check the wiring of the regenerative module (power grid side and DC link)
- Check the line fuse
- For operation without an RM regenerative module:
- Deactivate the machine parameter uecRecoveryModule


Error description 237-1002A

Error message

1002A CC%2: too many UM units connected to one CC

Cause of error

- Too many UM inverters are connected to the stated CC controller unit.
- For each CC, the maximum number of UM inverters (or motor connections) is limited to the number of axes possible on the CC.

Error correction

- Distribute the UM inverters over other CC controller units or adapt the configuration
- Remove UM inverters that aren't being used (or use one-axis modules instead of two-axis modules)
- Inform your service agency


Error description 237-1002B

Error message

1002B CC%2: inconsistent hardware configuration

Cause of error

Correct operation of the CC controller unit is not possible. A fundamental step during hardware identification of the CC revealed an inconsistent/damaged configuration.
There are two ways for such a possibility to arise:
1. Problems in the voltage supply to the CC, such as electrical contact problems, electromagnetic interference, or phenomena in the power-up sequence of the power source.
2. A hardware defect within the CC, possibly caused by problems in the voltage supply

Error correction

- Check the voltage supply, especially ribbon cables of the CC and the redundant 5V supply over X74
- Check for bent pins in the X69 box headers
- Exchange the affected CC
- Inform your service agency


Error description 237-1002C

Error message

1002C CC%2: missing HFL LP transmission

Cause of error

Possible causes:
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- No immediate corrective action is necessary, since no error situation has occurred yet
- Recommended preventive measures:
- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination


Error description 237-1002D

Error message

1002D CC%2 %1: notable HFL transmission; error code: %4

Cause of error

Possible causes:
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- No immediate corrective action is necessary, since no error situation has occurred yet
- Recommended preventive measures:
- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination


Error description 237-1002E

Error message

1002E CC%2 %1: notable HFL transmission (ext.); error code: %4

Cause of error

Possible causes:
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- No immediate corrective action is necessary, since no error situation has occurred yet
- Recommended preventive measures:
- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination


Error description 237-1002F

Error message

1002F CC%2 %1: faulty HFL transmission; error code: %4

Cause of error

Possible causes:
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination
- Exchange the UM3
- Exchange the CC3
- Inform your service agency


Error description 237-10030

Error message

10030 CC%2 %1: faulty HFL transmission (ext.); error code: %4

Cause of error

Possible causes:
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination
- Exchange the UM3
- Exchange the CC3
- Inform your service agency


Error description 237-10031

Error message

10031 CC%2 interface violation MC command %4

Cause of error

Internal system error: the interface description was not adhered to in the command given.

Error correction

- Perform a software update if possible
- Inform your service agency


Error description 237-10032

Error message

10032 CC%2: supply module readiness missing %1

Cause of error

Supply module readiness was rescinded even though drives were still being controlled.
Possible causes:
- The Power Save mode of the UVR was activated (PLC Module 9047) even though drives were still being controlled.
- The supply module is in a faulty state

Error correction

- Inform your service agency
- Check the PLC program (do not switch the UVR to Power Save mode while drives are still being controlled)
- Check the supply module for faults


Error description 237-13000

Error message

13000 CC%2: inverter reports error %1

Cause of error

UM inverter or compact inverter reports errors.
For further information, note the following alarm messages (13xxx)!


Error description 237-13003

Error message

13003 UM: IGBT error %1 (maximum current: %4A, phase %5)

Cause of error

- Undervoltage monitor or short-circuit monitor of an IGBT has responded in the UM inverter or UEC compact inverter.

Error correction

- Check the current controller adjustment
- Check for proper motor connection and short circuit
- Check the motor for an interwinding fault
- Inform your service agency
- Exchange the power module


Error description 237-13004

Error message

13004 UM: HW overcurrent shutdown %1 (maximum current: %4A, phase %5)

Cause of error

The fast hardware overcurrent monitoring in the UM inverter or UEC compact inverter has responded
- Possible causes:
- Current controller parameterized incorrectly
- Short-circuit
- Defective power module
- Excessive current ripple, for example due to an unfavorable combination of motor, inverter, and PWM frequency

Error correction

- Check the current controller adjustment
- Check the motor connection for a short circuit
- Check the motor for an interwinding fault
- If necessary, use a stronger inverter
- Increase the PWM frequency
- If necessary, replace defective power module
- Inform your service agency


Error description 237-13005

Error message

13005 UM: PWM nominal value faulty %1

Cause of error

- The controller unit supplies no PWM nominal value or an invalid one for the motor, or provides the nominal value too late
- Controller configuration (machine parameters) faulty
- Internal software error

Error correction

- Check the controller configuration or machine parameters for PWM frequency, encoder inputs/outputs and nominal value outputs
- Check the software version
- Check the machine for correct shield connections and grounding
- Check the motor and power cables for correct shield connections and terminal connections
- Inform your service agency


Error description 237-13006

Error message

13006 UM: Communication error in FO connection CC%2 %1 (info = %4)

Cause of error

- UM inverter or UEC compact inverter reports errors in communication via an optical fiber (HFL, HEIDENHAIN Fiber Link) with the controller unit
- Info provides information about the exact cause of the error for the diagnosis

Error correction

- Check the optical fiber connections (HFL):
- Is the green LED on?
- Is the optical fiber plug fully engaged?
- Is the tip of the optical fiber clean?
- Ensure the proper bend radius
- Exchange the optical fiber
- Check the machine for correct shield connections and grounding
- Check the motor and power cables for correct shield connections and terminal connections


Error description 237-13008

Error message

13008 UM: Voltage monitor B CC%2 %1 (voltage ID: %4)

Cause of error

- Voltage monitoring on the inverter has responded

Error correction

- Check the voltage supply
- Inform your service agency
- Exchange the power module


Error description 237-13009

Error message

13009 UM: DRIVE OFF signal is active %1

Cause of error

- Power supply unit (UVR or UEC) reports a fault

Error correction

- Check the power supply unit
- Inform your service agency


Error description 237-1300A

Error message

1300A UM: Heatsink temp. greater than warning thrshld. %1 (value: %4°C)

Cause of error

- Heat sink temperature has exceeded a defined warning threshold

Error correction

- Let the UM inverter or UEC compact inverter cool off
- Check the fan for function and contamination


Error description 237-1300A

Error message

1300A UM: overload / heat sink (warning) %1 (%4°C)

Cause of error

An excessive temperature of the power electronics or the heat sink was detected in the UM inverter or the UEC compact inverter.
Possible causes:
- Excessive cutting power
- Excessive feed rate
- Excessive continuous load
- Axis moved against an obstacle or limit stop
- Holding brake of axis applied during machining
- Excessive temperature in the electrical cabinet (cooling failed)
- Excessive axis or spindle acceleration
- Fan of the UM inverter or UEC compact inverter defective

Error correction

- Inform your service agency
- Reduce the cutting power
- Reduce the feed rate
- Reduce the continuous load
- Reduce the axis or spindle acceleration (MP_maxAcceleration under CfgFeedLimits)
- Check the holding brake of the axis (function/wiring)
- Check the climate control unit in the electrical cabinet
- Check the fan of the UM inverter or UEC compact inverter and replace it if necessary


Error description 237-1300B

Error message

1300B UM: Heatsink temp. greater than max. value %1 (value: %4°C)

Cause of error

- Heat sink temperature has exceeded the maximum permissible value

Error correction

- Let the UM inverter or UEC compact inverter cool off
- Check the fan for function and contamination


Error description 237-1300B

Error message

1300B UM: overload / heat sink %1 (%4°C)

Cause of error

An excessive temperature of the power electronics or the heat sink was detected in the UM inverter or the UEC compact inverter.
Possible causes:
- Excessive cutting power
- Excessive feed rate
- Excessive continuous load
- Axis moved against an obstacle or limit stop
- Holding brake of axis applied during machining
- Excessive temperature in the electrical cabinet (cooling failed)
- Excessive axis or spindle acceleration
- Fan of the UM inverter or UEC compact inverter defective

Error correction

- Inform your service agency
- Reduce the cutting power
- Reduce the feed rate
- Reduce the continuous load
- Reduce the axis or spindle acceleration (MP_maxAcceleration under CfgFeedLimits)
- Check the holding brake of the axis (function/wiring)
- Check the climate control unit in the electrical cabinet
- Check the fan of the UM inverter or UEC compact inverter and replace it if necessary


Error description 237-1300E

Error message

1300E UM: SW overcurrent monitoring %1 (actual value: %4Aeff)

Cause of error

- Software overcurrent monitoring in the UM inverter or UEC compact inverter has responded

Error correction

Check the current controller adjustment.
- Check the motor connection for a short circuit
- Check the motor for an interwinding fault
- Inform your service agency
- Exchange the power module


Error description 237-1300F

Error message

1300F UM power-up test: HIK faulty CC%2 %1 %10

Cause of error

- An error in the hardware identification key (HIK) was detected in the switch-on test of the UM converter or UEC compact inverter

Error correction

- Inform your service agency
- Exchange the power module


Error description 237-1300F

Error message

1300F UM power-up test: internal component faulty CC%2 %1 %10

Cause of error

- An inadmissible internal component identifier (FPGA ID) was detected or the component could not be accessed during the switch-on test of the UM or UEC compact inverter

Error correction

- Inform your service agency
- Check the software version


Error description 237-1300F

Error message

1300F UM power-up test: analog interface faulty CC%2 %1 %10

Cause of error

- During the switch-on test of the UM or UEC compact inverter, it was determined that an analog interface in the inverter is not functioning properly

Error correction

- Restart the control
- Inform your service agency


Error description 237-1300F

Error message

1300F UM power-up test: temp. measurement not possible CC%2 %1 %10

Cause of error

- It was not possible to read the values of the heat sink temperature sensor in the switch-on test of the UM or UEC compact inverter
- Sensor or associated interface (I2C) defective

Error correction

- Inform your service agency


Error description 237-1300F

Error message

1300F UM power-up test: memory component (FRAM) defective CC%2 %1 %10

Cause of error

- The FRAM could not be identified in the switch-on test of the UM converter or UEC compact inverter

Error correction

- Restart the control
- Inform your service agency


Error description 237-1300F

Error message

1300F UM power-up test: serial interface (SPI ) faulty CC%2 %1 %10

Cause of error

- During the switch-on test of the UM or UEC compact inverter, it was determined that the serial interface (SPI) to the FSuC in the inverter is not functioning properly

Error correction

- Restart the control
- Inform your service agency


Error description 237-1300F

Error message

1300F UM power-up test: meas. of current faulty CC%2 %1 %10 (info = %5)

Cause of error

- During the switch-on test of the UM or UEC compact inverter, it was determined that the measurement of current in the inverter is faulty
- When the drive has been switched off, the permissible maximum offset current has been exceeded in one or more phases:
(info is displayed decimally but is to be interpreted as binary)
- Bit 0: Phase U
- Bit 1: Phase V
- Bit 2: Phase W

Error correction

- Inform your service agency


Error description 237-1300F

Error message

1300F UM power-up test: temp. value faulty CC%2 %1 %10 (value=%5°C)

Cause of error

- In the switch-on test of the UM converter or UEC compact inverter, a heat sink temperature outside the permitted range was read out
- Heat sink too hot
- Sensor or associated interface defective

Error correction

- Let the device cool off
- Inform your service agency


Error description 237-1300F

Error message

1300F UM power-up test: fan defective CC%2 %1 %10

Cause of error

During the switch-on test of the UM inverter or UEC compact inverter, it was determined that the fan for cooling of the electronics in the inverter is not functioning properly.

Error correction

- Check the fan
- Exchange the inverter
- Inform your service agency


Error description 237-1300F

Error message

1300F UM power-up test: internal lead defective CC%2 %1 %10

Cause of error

During the switch-on test of the UM inverter or the UEC compact inverter, it was determined that an internal lead to the FSuC (Functional Safety Microcontroller) is defective.

Error correction

- Exchange the inverter
- Inform your service agency


Error description 237-13012

Error message

13012 UM: WD monitoring has responded %1 (received:%4, expected:%5)

Cause of error

- UM inverter or UEC compact inverter reports that watchdog on controller unit is no longer being updated

Error correction

- Restart the control
- Check the machine for correct shield connections and grounding
- Check the motor and power cables for correct shield connections and terminal connections
- Inform your service agency


Error description 237-13014

Error message

13014 UM: Optical waveguide connection faulty %1

Cause of error

- UM inverter or UEC compact inverter reports faults in the FO connection (fiber optic connection between controller unit and inverter)

Error correction

- Check the optical fiber connection:
- Is the green LED on?
- Is the optical fiber plug fully engaged?
- Is the tip of the optical fiber clean?
- Ensure the proper bend radius
- Exchange the optical fiber


Error description 237-13015

Error message

13015 UM: Erroneous heatsink temperature value %1

Cause of error

- The UM inverter or UEC compact inverter reports errors when accessing the I2C bus for reading the heat sink temperature sensor
- No temperature sensor is connected or the connection is faulty
- Temperature sensor is defective
- I2C controller is defective

Error correction

- Restart the control
- Inform your service agency


Error description 237-13016

Error message

13016 UM: Invalid UM debug channel %4 %1

Cause of error

- Invalid UM debug signal selected in the oscilloscope

Error correction

- Select another signal


Error description 237-13017

Error message

13017 UM: Erroneous heatsink temperature value %1

Cause of error

- The UM inverter or UEC compact inverter reports errors when accessing the I2C bus for reading the heat sink temperature sensor
- No temperature sensor is connected or the connection is faulty
- Temperature sensor is defective
- Improper function of I2C controller

Error correction

- Restart the control
- Inform your service agency


Error description 237-1301A

Error message

1301A UM: FO signal weaker than warng threshld CC%2 %1 (value=-%4dB)

Cause of error

- The signal strength of the FO connection (fiber optic cable to the UM converter) has fallen below a defined warning threshold

Error correction

- Check the optical fiber connections:
- Is the green LED on?
- Is the optical fiber plug fully engaged?
- Is the tip of the optical fiber clean?
- Ensure the proper bend radius
- Exchange the optical fiber


Error description 237-1301B

Error message

1301B UM: FO signal weaker than minimum value CC%2 %1 (value=-%4dB)

Cause of error

- The signal strength of the fiber optic connection (fiber optic cable to the UM converter) has fallen below a permissible minimum value

Error correction

- Check the fiber optic connection:
- Is the green LED on?
- Is the optical fiber plug fully engaged?
- Is the tip of the optical fiber clean?
- Ensure the proper bend radius
- Exchange the optical fiber


Error description 237-1301C

Error message

1301C UM: communication fault CC%2 %1, error code=%4

Cause of error

The HFL communication component of the inverter reports an error
Possible causes:
- Electromagnetic disturbances
- Hardware defective
- Optical fibers (HFL) not connected correctly
- Insufficient bend radius of the optical fibers (HFL)

Error correction

- Create a service file (error code gives information about the exact cause of the error for the diagnosis at HEIDENHAIN)
- Inform your service agency
- If required, exchange the hardware
- Use TNCdiag to check the damping of the fiber-optic connections (HFL). If the damping is too high:
- Check the optical fiber connections
- Comply with the guidelines in the Technical Manual regarding the cable routing
- Check the machine for correct shield connections and grounding
- Check the motor and power cables for correct shield connections and terminal connections


Error description 237-1301D

Error message

1301D UM: logical disturbance of data reception CC%2 %1, error code=%4

Cause of error

The communication component for the optical fiber connection (HFL) to the inverters reports an error
Possible causes:
- Hardware defective
- Electromagnetic disturbances
- Optical fibers (HFL) not connected correctly
- Insufficient bend radius of the optical fibers (HFL)

Error correction

- Create a service file (error code gives information about the exact cause of the error for the diagnosis at HEIDENHAIN)
- Inform your service agency
- If required, exchange the hardware
- Use TNCdiag to check the damping of the fiber-optic connections (HFL). If the damping is too high:
- Check the optical fiber connections
- Comply with the guidelines in the Technical Manual regarding the cable routing
- Check the machine for correct shield connections and grounding
- Check the motor and power cables for correct shield connections and terminal connections


Error description 237-1301E

Error message

1301E UM: physical disturbance of data reception CC%2 %1, error code=%4

Cause of error

The communication component for the optical fiber connection (HFL) to the inverters reports an error
Possible causes:
- Hardware defective
- Electromagnetic disturbances
- Optical fibers (HFL) not connected correctly
- Insufficient bend radius of the optical fibers

Error correction

- Create a service file (error code gives information about the exact cause of the error for the diagnosis at HEIDENHAIN)
- Inform your service agency
- If required, exchange the hardware
- Use TNCdiag to check the damping of the fiber-optic connections (HFL). If the damping is too high:
- Check the optical fiber connections
- Comply with the guidelines in the Technical Manual regarding the cable routing
- Check the machine for correct shield connections and grounding
- Check the motor and power cables for correct shield connections and terminal connections


Error description 237-1301F

Error message

1301F UM: Inverter not ready %1 (info = %4)

Cause of error

- Since a UM converter or UEC compact inverter is not ready, it is not possible to switch on the drive
- Reason for lack of inverter readiness:
(information is shown decimally. Please interpret as binary)
- Bit 0: "STO.A.P.x"
- Bit 1: "STO.B.H.P.x"
- Bit 2: "STO.B.L.P.x"
- Bit 3: Signal for PWM release not set
- Bit 4: Error in switch-on test
- Bit 5: Drive motor is not (fully) configured

Error correction

- Inform your service agency
- Exchange the power module if necessary


Error description 237-13020

Error message

13020 UM: Readiness was lost %1 (info = %4)

Cause of error

- UM inverter or UEC compact inverter was switched off during operation
- Reason for lack of inverter readiness:
(information is shown decimally. Please interpret as binary)
- Bit 0: "STO.A.P.x"
- Bit 1: "STO.B.H.P.x"
- Bit 2: "STO.B.L.P.x"
- Bit 3: Signal for PWM release not set
- Bit 4: Error in switch-on test

Error correction

- Check the entry in MP_delayTimeSTOatSS1 and increase the value if necessary (the parameterized time here must be greater than the value in MP_vCtrlSwitchOffDelay)
- Inform your service agency
- Exchange the power module if necessary


Error description 237-13021

Error message

13021 UM: Faulty Include file CC%2 %1

Cause of error

- Software from CC controller unit, UM inverter or UEC compact inverter have not been compiled with the same include file.

Error correction

- Check the software version and update it if necessary
- Inform your service agency


Error description 237-13025

Error message

13025 UM: Stack overflow CC%2 %1

Cause of error

- Internal software error on the UM inverter or UEC compact inverter

Error correction

- Inform your service agency
- Check the software version


Error description 237-13026

Error message

13026 UM: IRQ stack overflow CC%2 %1

Cause of error

- Internal software error on the UM inverter or UEC compact inverter

Error correction

- Inform your service agency
- Check the software version


Error description 237-13027

Error message

13027 UM (log): stack overflow early warning CC%2 %1

Cause of error


Error description 237-13028

Error message

13028 UM (log): IRQ stack overflow early warning CC%2 %1

Cause of error


Error description 237-13029

Error message

13029 UM: Temperature sensor provides invalid measured values %1

Cause of error

The temperature sensor on the heat sink of the UM inverter or UEC compact inverter provides invalid measured values:
- No temperature sensor is connected or the connection is missing
- Temperature sensor is defective

Error correction

- Restart the control
- Inform your service agency


Error description 237-1302A

Error message

1302A UM: leakage current too high %1

Cause of error

Isolation problem (e.g. defective motor, contamination within the inverter, humidity)

Error correction

- Replace the motor of the affected axes or check for a ground fault
- Replace the power cable of the affected axes or check for a ground fault
- Replace the inverter of the affected axes or check for a ground fault
- Inform your service agency


Error description 237-1302C

Error message

1302C UM: Test software loaded

Cause of error

The inverter has a software version that has not been released yet, and has no valid checksum
- This software has neither been tested nor released

Error correction

- After acknowledging the error message you can use this software for test purposes
- Check the software version
- Create service files
- Contact your service agency


Error description 237-1302D

Error message

1302D UM: Temperature sensor provides invalid measured values %1

Cause of error

The temperature sensor on the heat sink of the UM inverter or UEC compact inverter provides invalid measured values:
- No temperature sensor is connected or the connection is missing
- Temperature sensor is defective

Error correction

- Restart the control
- Inform your service agency


Error description 237-1302E

Error message

1302E UM: Controller software timeout %1

Cause of error

- The time monitor of the inverter software is reporting an exceedance
- Internal software error

Error correction

- Inform your service agency


Error description 237-1302F

Error message

1302F UM: Controller software timeout %1

Cause of error

- The time monitor of the inverter software is reporting an exceedance
- Internal software error

Error correction

- Inform your service agency


Error description 237-13032

Error message

13032 UM3xx must be exchanged or rebuilt %1 (Ser-Nr.: %4)

Cause of error

Umrichter mit Bremsschaltung ohne internen Pullup-Widerstand werden ab 27.05.2019 nicht mehr unterstützt

Error correction

Hardware umbauen oder tauschen
(Bei Fragen an Georg Zehentner (Tel. 1845) wenden)


Error description 237-13033

Error message

13033 UM FSuC reports error CC%2 %1 %10

Cause of error

The FSuC (Functional Safety Microcontroller) on the inverter reports an error.
For further information, note the following alarm messages (239-xxxx)!


Error description 237-13034

Error message

13034 UM: Parameters for the thermal model are missing %1 (Ser-Nr.: %4)

Cause of error

Umrichter ohne HIK-Parameter für das thermische Modell werden bald nicht mehr unterstützt

Error correction

HIK umprogrammieren lassen


Error description 237-13035

Error message

13035 UM: barrier layer temp. > warning threshold %1 (value: %4°C)

Cause of error

The calculated barrier layer temperature has exceeded a defined warning threshold.

Error correction

- Reduce the profile load
- Let the UM inverter or UEC compact inverter cool off
- Check the fan for function and contamination


Error description 237-13035

Error message

13035 UM: overload / IGBT (warning) / %1 (%4°C)

Cause of error

An excessive temperature of the power electronics or the heat sink was detected in the UM inverter or the UEC compact inverter.
Possible causes:
- Excessive cutting power
- Excessive feed rate
- Excessive continuous load
- Axis moved against an obstacle or limit stop
- Holding brake of axis applied during machining
- Excessive temperature in the electrical cabinet (cooling failed)
- Excessive axis or spindle acceleration
- Fan of the UM inverter or UEC compact inverter defective

Error correction

- Inform your service agency
- Reduce the cutting power
- Reduce the feed rate
- Reduce the continuous load
- Reduce the axis or spindle acceleration (MP_maxAcceleration under CfgFeedLimits)
- Check the holding brake of the axis (function/wiring)
- Check the climate control unit in the electrical cabinet
- Check the fan of the UM inverter or UEC compact inverter and replace it if necessary


Error description 237-13036

Error message

13036 UM: barrier layer temp. > maximum value %1 (value: %4°C)

Cause of error

The calculated barrier layer temperature has exceeded the maximum permissible value.

Error correction

- Reduce the profile load
- Let the UM inverter or UEC compact inverter cool off
- Check the fan for function and contamination


Error description 237-13036

Error message

13036 UM: overload / IGBT %1 (%4°C)

Cause of error

An excessive temperature of the power electronics or the heat sink was detected in the UM inverter or the UEC compact inverter.
Possible causes:
- Excessive cutting power
- Excessive feed rate
- Excessive continuous load
- Axis moved against an obstacle or limit stop
- Holding brake of axis applied during machining
- Excessive temperature in the electrical cabinet (cooling failed)
- Excessive axis or spindle acceleration
- Fan of the UM inverter or UEC compact inverter defective

Error correction

- Inform your service agency
- Reduce the cutting power
- Reduce the feed rate
- Reduce the continuous load
- Reduce the axis or spindle acceleration (MP_maxAcceleration under CfgFeedLimits)
- Check the holding brake of the axis (function/wiring)
- Check the climate control unit in the electrical cabinet
- Check the fan of the UM inverter or UEC compact inverter and replace it if necessary


Error description 237-13037

Error message

13037 UM (log): histogram read error CC%2 %1

Cause of error


Error description 237-13038

Error message

13038 UM: CC%2 %1 CPU0 impermissible data processing

Cause of error

Internal software error: There was an attempt to access an impermissible memory area

Error correction

- Please generate a service file soon, reboot the control, and then generate another service file
- Transmit both service files to the Service department for further inspections by HEIDENHAIN


Error description 237-13039

Error message

13039 UM: CC%2 %1 CPU1 impermissible data processing

Cause of error

Internal software error: There was an attempt to access an impermissible memory area

Error correction

- Please generate a service file soon, reboot the control, and then generate another service file
- Transmit both service files to the Service department for further inspections by HEIDENHAIN


Error description 237-1303A

Error message

1303A UM: CC%2 %1 CPU0 impermissible instruction processing

Cause of error

Internal software error: There was an attempt to access an impermissible memory area

Error correction

- Please generate a service file soon, reboot the control, and then generate another service file
- Transmit both service files to the Service department for further inspections by HEIDENHAIN


Error description 237-1303B

Error message

1303B UM: CC%2 %1 CPU1 impermissible instruction processing

Cause of error

Internal software error: There was an attempt to access an impermissible memory area

Error correction

- Please generate a service file soon, reboot the control, and then generate another service file
- Transmit both service files to the Service department for further inspections by HEIDENHAIN


Error description 237-1303C

Error message

1303C UM: fan speed too low CC%2 %1

Cause of error

The speed of the fan for cooling of the electronics in the inverter has fallen below the monitoring threshold.

Error correction

- Check the fan
- Exchange the inverter
- Inform your service agency


Error description 237-1303D

Error message

1303D UM: short circuit of brakes was detected %1 (Info: %4)

Cause of error

- The inverter detected a short circuit in the motor brake.
- Info provides information about the exact cause of the error:
Info = 1: Short circuit between BR+ and BR-
Info = 2: Short circuit between BR+ and housing

Error correction

Warning:
Hanging axes cannot be supported under certain circumstances. The axis can drop.
Do not enter the area of danger under the axis!
- Move the axis to a safe position before power-off
- Inform your service agency
- Check controls for motor brakes
- Exchange motor


Error description 237-1303F

Error message

1303F UM: faulty FSuC Include file CC%2 %1

Cause of error

The interface versions of internal components (SOC and FSuC) on the inverter do not match.

Error correction

- Check the software version and run an update if necessary
- Inform your service agency


Error description 237-13040

Error message

13040 UM: too many faulty CC telegrams in sequence %1

Cause of error

Too many telegrams in sequence were lost during transmission of the nominal voltage values from the CC to the UM.
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination
- Exchange the UM3
- Exchange the CC3
- Inform your service agency


Error description 237-13041

Error message

13041 UM: too many faulty CC telegrams during the monitoring period %1

Cause of error

Too many telegrams were lost during transmission of the nominal voltage values from the CC to the UM during the monitoring period.
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination
- Exchange the UM3
- Exchange the CC3
- Inform your service agency


Error description 237-13042

Error message

13042 UM: excessive error frequency of CC telegrams %1

Cause of error

The frequency of faulty telegrams during transmission of the nominal voltage values from the CC to the UM is above the limit value.
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination
- Exchange the UM3
- Exchange the CC3
- Inform your service agency


Error description 237-13043

Error message

13043 UM: conspicuous CC telegrams during the monitoring period %1

Cause of error

There are peculiar telegrams during transmission of the nominal voltage values from the CC to the UM.
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination
- Exchange the UM3
- Exchange the CC3
- Inform your service agency


Error description 237-13044

Error message

13044 UM: conspicuous CC telegrams outside the monitoring period %1

Cause of error

There are peculiar telegrams during transmission of the nominal voltage values from the CC to the UM.
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination
- Exchange the UM3
- Exchange the CC3
- Inform your service agency


Error description 237-13045

Error message

13045 UM: overload / IGBT (emergency stop) %1 (%4°C)

Cause of error

An excessive temperature of the power electronics or the heat sink was detected in the UM inverter or the UEC compact inverter.
Possible causes:
- Excessive cutting power
- Excessive feed rate
- Excessive continuous load
- Axis moved against an obstacle or limit stop
- Holding brake of axis applied during machining
- Excessive temperature in the electrical cabinet (cooling failed)
- Excessive axis or spindle acceleration
- Fan of the UM inverter or UEC compact inverter defective

Error correction

- Inform your service agency
- Reduce the cutting power
- Reduce the feed rate
- Reduce the continuous load
- Reduce the axis or spindle acceleration (MP_maxAcceleration under CfgFeedLimits)
- Check the holding brake of the axis (function/wiring)
- Check the climate control unit in the electrical cabinet
- Check the fan of the UM inverter or UEC compact inverter and replace it if necessary


Error description 237-13046

Error message

13046 UM: overload / IGBT (STO) %1 (%4°C)

Cause of error

An excessive temperature of the power electronics or the heat sink was detected in the UM inverter or the UEC compact inverter.
Possible causes:
- Excessive cutting power
- Excessive feed rate
- Excessive continuous load
- Axis moved against an obstacle or limit stop
- Holding brake of axis applied during machining
- Excessive temperature in the electrical cabinet (cooling failed)
- Excessive axis or spindle acceleration
- Fan of the UM inverter or UEC compact inverter defective

Error correction

- Inform your service agency
- Reduce the cutting power
- Reduce the feed rate
- Reduce the continuous load
- Reduce the axis or spindle acceleration (MP_maxAcceleration under CfgFeedLimits)
- Check the holding brake of the axis (function/wiring)
- Check the climate control unit in the electrical cabinet
- Check the fan of the UM inverter or UEC compact inverter and replace it if necessary


Error description 237-13047

Error message

13047 %4 CC%2 %1 %10

Cause of error


Error description 237-13048

Error message

13048 UM3: sequencer sync pulse outside the tolerance range %1

Cause of error

The synchronization pulse for an internal sequencer in the inverter was (too often) outside of the specified tolerance range.
Electromagnetic noise or faulty electrical contacts:
- of the 24 V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination
- Exchange the UM3
- Exchange the CC3
- Inform your service agency


Error description 237-13049

Error message

13049 UM: missing HFL LP transmission

Cause of error

Possible causes:
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- No immediate corrective action is necessary, since no error situation has occurred yet
- Recommended preventive measures:
- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination


Error description 237-1304A

Error message

1304A UM: notable HFL transmission CC%2 %1; error code: %4

Cause of error

Possible causes:
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- No immediate corrective action is necessary, since no error situation has occurred yet
- Recommended preventive measures:
- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination


Error description 237-1304B

Error message

1304B UM: notable HFL transmission (ext.) CC%2 %1; error code: %4

Cause of error

Possible causes:
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- No immediate corrective action is necessary, since no error situation has occurred yet
- Recommended preventive measures:
- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination


Error description 237-1304C

Error message

1304C UM: faulty HFL transmission CC%2 %1; error code: %4

Cause of error

Possible causes:
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination
- Exchange the UM3
- Exchange the CC3
- Inform your service agency


Error description 237-1304D

Error message

1304D UM: faulty HFL transmission (ext.) CC%2 %1; error code: %4

Cause of error

Possible causes:
Electromagnetic noise or faulty electrical contacts:
- of the 24V supply voltage
- of the DC-link voltage
- in the motor cabling
- in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing and clamping, and also for contamination
- Exchange the UM3
- Exchange the CC3
- Inform your service agency


Error description 237-1304E

Error message

1304E UM: short-circuit braking not permitted %1 (info: %4)

Cause of error

- Short-circuit braking is activated because the parameter CfgPowerStage/delayTimeSTOatSS0 is greater than 0
- However, short-circuit braking is not permitted for:
- Asynchronous motor (info: 1)
- Sine-wave drive UMS (info: 2)
- If more than one cause is given, then info > 2

Error correction

- Short-circuit braking must be deactivated explicitly:
- Set CfgPowerStage-delayTimeSTOAtSS0 to 0


Error description 237-1304F

Error message

1304F UM: overflow of an internal communication buffer CPU0 CC%2 %1

Cause of error

An internal buffer in the UM inverter or UEC compact inverter for buffering messages to the CC controller unit overflowed.

Error correction

Inform your service agency


Error description 237-13050

Error message

13050 UM: overflow of an internal communication buffer CPU1 CC%2 %1

Cause of error

An internal buffer in the UM inverter or UEC compact inverter for buffering messages to the CC controller unit overflowed.

Error correction

Inform your service agency


Error description 237-13051

Error message

13051 UM: no software support (HIK, model bit) CC%2 %1

Cause of error

The UM inverter or UEC compact inverter being used is not supported by this version of the NC software.
More diagnostic information:
A model bit that is not supported is set in the HIK (Hardware Identification Key) of the inverter.

Error correction

- Update the software
- Exchange the inverter
- Inform your service agency


Error description 237-13052

Error message

13052 UM: HIK faulty (model bits not plausible) CC%2 %1

Cause of error

The UM inverter or UEC compact inverter being used is not supported by this version of the NC software.
More diagnostic information:
The plausibility check of the HIK (Hardware Identification Key) in the inverter failed because of an impermissible combination of model bit and version bit.

Error correction

- Exchange the inverter
- Inform your service agency


Error description 237-13053

Error message

13053 UM: HIK faulty (block %4 missing) CC%2 %1

Cause of error

The UM inverter or UEC compact inverter being used cannot be operated.
More diagnostic information:
A block that is required was not programmed in the HIK (Hardware Identification Key) of the inverter.

Error correction

- Exchange the inverter
- Inform your service agency


Error description 237-13054

Error message

13054 UM: HIK faulty (block %4 missing) CC%2 %1

Cause of error

The UM inverter or UEC compact inverter being used cannot be operated.
More diagnostic information:
A block in the HIK (Hardware Identification Key) of the inverter is missing a required entry.

Error correction

- Exchange the inverter
- Inform your service agency


Error description 237-13055

Error message

13055 UM: HIK faulty (plausibility check) CC%2 %1

Cause of error

The UM inverter or UEC compact inverter being used is not supported by this version of the NC software.
More diagnostic information:
The check of the HIK (Hardware Identification Key) in the inverter failed. The value of one or more entries is not plausible.

Error correction

- Exchange the inverter
- Inform your service agency


Error description 237-13056

Error message

13056 UM: brake-line damage detected %1

Cause of error

- The inverter detected a line break in the motor brake.

Error correction

Warning:
Hanging axes cannot be supported under certain circumstances. The axis can drop.
Do not enter the area of danger under the axis!
- Move the axis to a safe position before power-off
- Inform your service agency
- Check controls for motor brakes
- Check the brake, and exchange it if necessary


Error description 237-137FF

Error message

137FF UM: Alarm CC%2 %1 module = %4 line = %5

Cause of error

- Internal error in the UM inverter or UEC compact inverter

Error correction

- Inform your service agency


Error description 237-13800

Error message

13800 UM (FS.B):CRC error in FS communication %1 (nom.:%4,act.:%5)

Cause of error

- Checksum (CRC) in cyclic communication with SKERN-CC is faulty.

Error correction

- Inform your service agency


Error description 237-13801

Error message

13801 UM (FS.B):FS communication telegram counter %1 nom.:%4 act.:%5

Cause of error

- Telegram counter in cyclic communication with SKERN-CC is faulty.

Error correction

- Inform your service agency


Error description 237-13802

Error message

13802 UM (FS.B):UM-DriveID error in FS communicatn. %1 nom.:%4 act.:%5

Cause of error

- UM.driveID contains errors in cyclic communication with SKERN-CC

Error correction

- Inform your service agency


Error description 237-13803

Error message

13803 UM (FS.B):Error during deactivation of the FS communication %1

Cause of error

- Error during deactivation of the FS communication with the UM or UEC
- The signals STO.B and SBC.B were not set during the deactivation of the axis.

Error correction

- Drives must be turned off before deactivating an axis.
- Check the (S)PLC program, and adapt it if necessary.


Error description 237-13804

Error message

13804 UM (FS.B):Topology checking of UM parameters failed %1

Cause of error

- Received parameters do not match the topology of the setup
- Configuration of the machine parameters MP_hsciCcIndex, MP_inverterInterface, or MP_motorConnector is incorrect

Error correction

- Check the configuration of MP_hsciCcIndex, MP_inverterInterface, and MP_motorConnector, and adapt if necessary
- Inform your service agency


Error description 237-13805

Error message

13805 UM (FS.B): FS configuration data were falsified %1

Cause of error

- UM parameters were corrupted and do not match the calculated checksum (UM.DRIVE-ID)

Error correction

- Reboot of the control
- Inform your service agency


Error description 237-13806

Error message

13806 UM (FS.B): UM-DriveID from UM(FS.A) and UM(FS.B) are unequal %1

Cause of error

- Calculated checksums (UM-DRIVE.ID) for UM parameters between UM(FS.A) and UM(FS.B) are different

Error correction

- Inform your service agency


Error description 237-13807

Error message

13807 UM (FS.B):Error during the parameterization of the UM (FS.A) %1

Cause of error

- Faulty data transfer between UM(FS.A) and UM(FS.B).
- The received data were corrupted on the bus line or recognized as invalid by the UM(FS.A).

Error correction

- Inform your service agency
- If necessary, replace the inverter


Error description 237-13808

Error message

13808 UM (FS.B): reconfiguration of UM3 parameters not possible %1

Cause of error

- Safety-relevant parameters of the inverter were changed
(delayTimeSTOatSS0/SS1, delayTimeSBCatSS0/SS1 or driveOffGroup)

Error correction

- Restart the control in order to apply the new parameters


Error description 237-13809

Error message

13809 UM (FS.B):Switch-on readiness lacking %1 1:%4 2:%5 3:%6 4:%7 5:%8

Cause of error

- The conditions for the switch-on readiness of the UM are not given:
-- Info1 = 1: No valid configuration received for this axis
-- Info2 = 1: SS0 stop reaction active for this axis
-- Info3 = 1: Self-test for this axis has not yet run without error
-- Info4 = 1: STEST.PERMIT set as release for the UM self-test
-- Info5 = 1: Restart prevented due to the previous SS0 and SS1F


Error description 237-1380A

Error message

1380A UM (FS.B): CRC error in PAE communication %1 (nom.:%4,act.:%5)

Cause of error

- Checksum (CRC) in cyclic communication with PAE is faulty.

Error correction

- Inform your service agency


Error description 237-1380B

Error message

1380B UM (FS.B): PAE communication telegram counter %1 nom.:%4 act.:%5

Cause of error

- Telegram counter in cyclic communication with PAE is faulty.

Error correction

- Inform your service agency


Error description 237-1380C

Error message

1380C UM (FS.B): error during deactivation, %1 not in safe state

Cause of error

- The axis is to be deactivated, but the axis is not in a safe state
- STO and SBC are still enabled

Error correction

- Put the axis in a safe state before deactivating it


Error description 237-13820

Error message

13820 UM (FS.B): 3.3 V (FS.A) voltage monitor exceeded CC%2 %1

Cause of error

- The internal voltage monitor found that the 3.3 V voltage of the FS.A is too high

Error correction

Restart the control; if the error occurs again, then:
- Check the X76 jumper plugs
- Replace device
- Inform your service agency


Error description 237-13821

Error message

13821 UM (FS.B): 3.3V(FS.A) voltage monitor below limit CC%2 %1

Cause of error

- The internal voltage monitor detected that the 3.3 V voltage of the FS.A is too low

Error correction

Restart the control; if the error occurs again, then:
- Check the X76 jumper plugs
- Replace device
- Inform your service agency


Error description 237-13822

Error message

13822 UM (FS.B): 5V voltage monitor exceeded CC%2 %1

Cause of error

- The internal voltage monitor detected that the 5 V voltage is too high

Error correction

Restart the control; if the error occurs again, then:
- Check the X76 jumper plugs
- Replace device
- Inform you service agency


Error description 237-13823

Error message

13823 UM (FS.B): 5V voltage monitor below limit CC%2 %1

Cause of error

- The internal voltage monitor found that the 5 V voltage is too low

Error correction

Restart the control; if the error occurs again, then:
- Check the X76 jumper plugs
- Replace device
- Inform your service agency


Error description 237-13824

Error message

13824 UM (FS.B): Watchdog FS.A has responded CC%2 %1

Cause of error

- UM inverter or UEC compact inverter reports that watchdog of the A-channel (FSuC) is no longer being updated

Error correction

- Restart the control
- Inform your service agency


Error description 237-13825

Error message

13825 UM (FS.B): Temp. greater than warning threshold CC%2 %1 (%4°C)

Cause of error

- Processor temperature has exceeded a defined warning threshold

Error correction

- Let the UM inverter or UEC compact inverter cool off
- Check the fan for function and contamination


Error description 237-13826

Error message

13826 UM (FS.B): Temp. greater than maximum value CC%2 %1 (%4°C)

Cause of error

- Processor temperature has exceeded the maximum permissible value

Error correction

- Let the UM inverter or UEC compact inverter cool off
- Check the fan for function and contamination


Error description 237-13827

Error message

13827 UM (FS.B): Error in the safety self-test CC%2 %1 %10 Info0: %4

Cause of error

- Error during FS self-test.
Info 0:
0 = Emergency stop during the self-test
1 = Test-initialization
2 = Test of the brake control, part 1
3 = Test of the brake control, part 2
4 = Test of the brake control, part 3
5 = Test of the STO cut-out signal, part 1
6 = Test of the STO cutout signal, part 2
7 = Test of the STO cutout signal, part 3
8 = Test of the PWM pulse inhibitor, positive test
9 = Test of the PWM pulse inhibitor, low-side negative test
10 = Test of the PWM pulse inhibitor, high-side negative test
11 = Test of the watchdog, channel A
12 = Test of the watchdog, channel B
13 = Test of the voltage monitor, channel B lower limit
14 = Test of the voltage monitor, channel B upper limit
15 = Test of the voltage monitor, channel A
16 = Test of temperature value measurement, channel B
17 = Test of the SS0 stop request
18 = Test of the SS1 stop request
19 = Test of the timers, channel A timer 1
20 = Test of the timers, channel A timer 2
21 = Test of the timers, channel B
22 = Not all required tests have been performed

Error correction

- When Info 0 = 0: If necessary, unlock emergency stop, and restart the control.
- When Info 0 = 2-4: Error of the brake control. Inspect the wiring of the holding brakes.
- When Info 0 = 5-21: Inform your service agency. If required, exchange the hardware.
- When Info 0 = 1/22: Inform your service agency.


Error description 237-13828

Error message

13828 UM (FS.B): SS1F request from UM(FS.A) CC%2 %1

Cause of error

-SS1F request (REQ.SS1F signal) from UM(FS.A) active.

Error correction

Note further pending error messages.


Error description 237-13830

Error message

13830 UM (log): SS1 request from PAE

Cause of error


Error description 237-13831

Error message

13831 UM (log): PAE test returns rising edge STEST_OK

Cause of error


Error description 237-13832

Error message

13832 UM (FS.B): Faulty start condition for PAE test %1 Info0:%4

Cause of error

The condition for starting the self-test of the PAE module is not given on the B channel side:
At the time of the self-test, the drive must be set to STO and SBC.
Info 0 describes the cause bit-encoded
- Bit 0: STO.B.H not active
- Bit 1: STO.B.L not active
- Bit 2: SBC.B not active

Error correction

- Stop the drive before the start of the self-test (STO and SBC must be active)
- Inform your service agency


Error description 237-13833

Error message

13833 UM (FS.B): Faulty start condition, self-test %1 Info0:%4 Info1:%5

Cause of error

The condition for starting the self-test of the UM is not given
At the time of the self-test, the drive must be set to STO and SBC.
Further conditions must also be met.
Info 0 describes the cause bit-encoded
- Bit 0: STEST.Permit missing
- Bit 1: STO.A not active
- Bit 2: STO.B.H not active
- Bit 3: STO.B.L not active
- Bit 4: SBC.A not active
- Bit 5: SBC.B not active
- Bit 6: SEU error occurred
- Bit 7: STEST.OK of PAE missing

Error correction

- Stop the drive before the start of the self-test (STO and SBC must be active)
- Check the (S)PLC program, and adapt it if necessary
- Inform your service agency


Error description 237-13834

Error message

13834 UM (FS.B): PAE reports internal error (-REQ.SS1F) %1

Cause of error

The PAE-H PL module reports an internal error (switch-off due to -REQ.SS1F)
Possible causes:
- Maximum temperature exceeded
- Supply voltage not correct
- PAE module not connected correctly
- Internal PAE error

Error correction

- Check the expanded information in the bus diagnostics
- Stay within the temperature range
- Check the power supply
- Exchange the PAE-H module
- Inform your service agency


Error description 237-13835

Error message

13835 UM (FS.B):Temperature below warning threshold CC%2 %1 (%4°C)

Cause of error

The processor temperature has fallen below a defined warning threshold. The ambient temperature in the electrical cabinet must be greater than +1°C.

Error correction

- Check the temperature conditions in the electrical cabinet
- Exchange the hardware
- Inform your service agency


Error description 237-13836

Error message

13836 UM (FS.B):Temperature lower than min. value CC%2 %1 (%4°C)

Cause of error

The processor temperature has fallen below the permissible minimum value. The ambient temperature in the electrical cabinet must be greater than 0°C.

Error correction

- Check the temperature conditions in the electrical cabinet
- If present: Check the climate control unit
- Exchange the hardware
- Inform you service agency


Error description 237-13837

Error message

13837 UM (FS.B): brake control faulty CC%2 %1 %10 Info0:%4

Cause of error

The test of the brake control detected a fault.
Refer to Info0 for the possible cause.
Info 0:
1 = Brake configured but not detected
2 = Short-circuit of the high-side or of the brake with 24V
3 = Short-circuit of the low-side or of the brake with 0V
4 = Short-circuit of the high-side with 24V and short-circuit of the low-side with 0V
5 = Supply voltage too low (< 23.75 V)

Error correction

- Check the supply voltage (23.75 V to 26.25 V)
- Check the wiring of the brake
- Inform your service agency


Error description 237-13838

Error message

13838 UM (FS.B): An SS0 or SS1F is preventing a restart %1

Cause of error

- A previous SS0 or SS1F reaction of the inverter is preventing the drive from being switched on.

Error correction

- Restart the control.


Error description 237-13839

Error message

13839 UM (FS.B): unreleased testing software loaded: CC%2 %1

Cause of error

An unreleased test software is installed on the inverter:
- This software has neither been tested nor officially released
- No checksum will be calculated for this software
This software is intended solely for testing purposes!

Error correction

This software or firmware must be replaced by a software or firmware that has been officially released:
- Create service files
- Inform your service agency


Error description 237-1383A

Error message

1383A UM: Checksum error in the program code CC%2 %1

Cause of error

- A checksum error was detected in the program code of the inverter.
- Inverter defective.

Error correction

- Inform your service agency
- If required, exchange the hardware


Error description 237-1383B

Error message

1383B UM (Log): Invalid switch of communication status %1

Cause of error


Error description 237-13890

Error message

13890 UM (FS.B): faulty FS Include file CC%2 %1 (act: %4 nom: %5)

Cause of error

- SKERN-CC and UM (FS.B) software have not been compiled with the same Include file.

Error correction

- Check the NC software version, and reinstall it if necessary
- Inform your service agency


Error description 237-13891

Error message

13891 UM(FS.B): Start of UM self-test via PLC module not permitted %1

Cause of error

The start of the UM self-test via PLC Module 9144 in mode 2 is not supported for axis %1.
The function is supported only with internal functional safety (FS).


Error description 237-13F00

Error message

13F00 UMFSSW: error while deactivating axis %1

Cause of error

Deactivation of a safe axis is not supported by the functional safety (SKERN-CC).

Error correction

Restart the control without deactivating the safe axis


Error description 237-13F01

Error message

13F01 Test command was received in released software!

Cause of error

Error injection was demanded for a release software. This is not permissible!

Error correction

- Use autotest software!
- Inform your service agency


Error description 237-14002

Error message

4002 CC (log): additional info from the DllError module

Cause of error


Error description 237-14800

Error message

4800 CC (log): contamination in encoder system %1

Cause of error


Error description 237-14840

Error message

4840 CC (log): stack overflow early warning

Cause of error


Error description 237-14850

Error message

4850 CC (log): motor not finely tuned

Cause of error


Error description 237-14860

Error message

4860 CC (log): alarm "Motor brake defective (0x8300)" suppressed %1

Cause of error


Error description 237-14970

Error message

4970 CC (log): overwrite the parameter "MotTypeOfFieldAdjust"

Cause of error


Error description 237-149A0

Error message

49A0 CC (log): IRQ stack overflow early warning

Cause of error


Error description 237-17FFC

Error message

17FFC Axis %1: PLC module 9311 no longer supported.

Cause of error

This function is no longer supported by this software version.

Error correction

Inform your service agency


Error description 237-17FFD

Error message

17FFD CC %2 controller clock slave axis %1 not identical to master axis

Cause of error

The parameters MP_ctrlPerformance and MP_ampPwmFreq are parameterized differently for the master and slave.

Error correction

- Check the entries in MP_ctrlPerformance and MP_ampPwmFreq, and set them to the same values for master and slave.
- Inform your service agency.


Error description 237-17FFE

Error message

17FFE Axis %1: Measurement canceled

Cause of error

- Note further messages.

Error correction

- Repeat the measurement.


Error description 237-17FFF

Error message

17FFF Axis %1: Amplitude of excitation signal is too high

Cause of error

Limit of provided current or voltage reached during the measurement.

Error correction

- Reduce the amplitude of the excitation signal


Error description 237-18000

Error message

18000 CC %2: Not enough memory available.

Cause of error

- The memory requirements for the requested measurement are too high.

Error correction

- Reduce the recording time.
- Reduce the recording rate.


Error description 237-18001

Error message

18001 Axis %1 Alarm for software test

Cause of error

- In the automatic software test an alarm was released

Error correction

- Inform your service agency


Error description 237-18003

Error message

18003 kv factor of the cmp file is not equal to MP %1

Cause of error

- The kv factors in a cmp file and parameter file are different

Error correction

- Change the kv factor (kvfactor) in the machine parameter file to the value from the cmp file (compTorqueRipple)
- Inform your service agency.


Error description 237-18004

Error message

18004 ki factor of the cmp file is not equal to MP %1

Cause of error

- The ki factors in a cmp file and machine parameter file are different

Error correction

- Change the ki factor (vCtrlIntGain) in the parameter file to the value from the cmp file (compTorqueRipple)
- Inform your service agency.


Error description 237-18006

Error message

18006 DQ-ALM %1: Uz nominal value too low

Cause of error

- The DC-link voltage of a DRIVE-CLiQ ALM
power supply as defined in the machine
parameter "ampBusVoltage" is smaller than the
rectified line voltage.

Error correction

- Check the entry in machine parameter "ampBusVoltage."
- Inform your service agency.


Error description 237-18007

Error message

18007 EnDat para. invalid: axis %1code:%4 value: %5

Cause of error

- During the initialization of the EnDat motor encoder for
the given axis, a parameter value was detected that
is not supported.
- The code of the error message describes the cause:
100: EnDat 2.1 Parameters of the encoder manufacturer, word 20/21:
"Measuring step or measuring steps per revolution" = 0 is not
supported by the controller software if it is needed to
calculate the commutation of a motor.
101: EnDat 2.1 Parameters of the encoder manufacturer, word 17:
"Number of distinguishable revolutions" is supported only
up to 65534.
102: EnDat 2.1 Parameters of the encoder manufacturer, word 13:
CC424 "Number of clock pulses to transmit the
position value (transmission format)" is supported
up to 32.
200: EnDat 2.2 Parameters of the encoder manufacturer, word 4:
"Scaling factor for temperature" unknown.

Error correction

- Exchange the encoder
- Inform your service agency


Error description 237-18008

Error message

18008 EnDat parameter invalid in axis:%1 Code:%4 Value:%5

Cause of error

- During the initialization of the EnDat position encoder
for the given axis, a parameter value was detected that is not supported.
- The code of the error message describes the cause:
101: EnDat 2.1 Parameters of the encoder manufacturer, word 17:
"Number of distinguishable revolutions" is supported only
up to 65534.
200: EnDat 2.2 Parameters of the encoder manufacturer, word 4:
"Scaling factor for temperature" unknown.

Error correction

- Exchange the encoder
- Inform your service agency.


Error description 237-18009

Error message

18009 Communic. error, EnDat motor enc. %1, err. code %4

Cause of error

- An error occurred with the EnDat motor encoder
- The error code describes the cause:
- 101 and 102:
The encoder generated an internal error message. A further alarm 0x1800F describes the exact cause.
- 103, 104 and 105:
An error occurred in communication.
Possible causes:
- Defective encoder line
- Encoder line is not suitable for digital EnDat communication at high clock frequency
- Disturbances on the encoder line (e.g. through insufficient shielding)

Error correction

- Check additional information from alarm message 0x1800F
- Check the encoder line
- Check whether the encoder line is suited for digital transmission at high frequency
- Exchange the encoder
- Exchange the hardware (CC)
- Inform your service agency.


Error description 237-1800A

Error message

1800A Communic. error, EnDat pos. encoder %1, error code %4

Cause of error

- An error occurred with the EnDat position encoder
- The error code describes the cause:
- 101 and 102:
The encoder generated an internal error message. A further alarm 0x18010 describes the exact cause.
- 103, 104 and 105:
An error occurred in communication.
Possible causes:
- Defective encoder line
- Encoder line is not suitable for digital EnDat communication at high clock frequency
- Disturbances on the encoder line (e.g. through insufficient shielding)

Error correction

- Check additional information from alarm message 0x18010
- Check the encoder line
- Check whether the encoder line is suited for digital transmission at high frequency
- Exchange the encoder
- Exchange the hardware (CC)
- Inform your service agency.


Error description 237-1800B

Error message

1800B Axis %1 inverter switch off over -STO.A.x (signal: %4)

Cause of error

- The inverter was switched off by a signal within the control:
1 = "-STO.A.MC.WD"
2 = "-STO.A.P.x"
3 = "-STO.A.PIC"
4 = "-STO.A.CC"

Error correction

- Check the entry in MP_vCtrlTimeSwitchOff (up to NCK version 597110-13) or MP_delayTimeSTOatSS1 (as of NCK version 597110-14) and, if necessary, increase the value in MP_delayTimeSTOatSS1 or reduce the value in MP_vCtrlSwitchOffDelay.
- Inform your service agency


Error description 237-1800C

Error message

1800C Reinitialization of the motor %1 is required

Cause of error

- The drive has to be reinitialization because the max. encoder frequency (VCtrlEncoderInputFunctions, bit 0) was changed

Error correction

- Reinitialize the encoder
- Deselect the axis with the machine parameter axisMode (bit x = 0)
- Exit the MP editor:
- Reactivate the axis in machine parameter axisMode (bit x = 0) and set posEncoderType to the desired value
- Re-exit the MP editor
- or reset the control (restart)
- Inform your service agency


Error description 237-1800D

Error message

1800D Encoder frequency up to 800 kHz not supported CC%2 %1

Cause of error

- The max. encoder frequency of 800 kHz was selected for the motor encoder (VCtrlEncoderInputFunctions, bit 0 = 1)
The hardware does not support this frequency.

Error correction

- Set the max. encoder frequency to 500 kHz (VCtrlEncoderInputFunctions, bit 0 = 0)
- Inform your service agency


Error description 237-1800E

Error message

1800E Excessive motor encoder frequency %1

Cause of error

- The permissible encoder frequency at the motor encoder input was far exceeded.
The monitoring thresholds are:
- VCtrlEncoderInputFunctions, bit 0 = 0: 600 kHz
- VCtrlEncoderInputFunctions, bit 1 = 1: 1000 kHz

Error correction

- Reduce the max. motor speed
- Set the parameter of the motor encoder's input circuit to high frequency (not with CC 424):
VCtrlEncoderInputFunctions bit 0 = 1
- Inform your service agency


Error description 237-1800F

Error message

1800F Error in EnDat motor encoder %1, error code %4

Cause of error

- The EnDat motor encoder reports an error
- The error code describes the cause:
1 = Failure of the illumination
2 = Incorrect signal amplitude
4 = Incorrect position value
8 = Overvoltage in the power supply
16 = Undervoltage in the power supply
32 = Overcurrent
64 = Battery exchange needed

Error correction

- Check the installation of the encoder
- Check the power supply of the encoder
- If required, exchange the battery
- Exchange the encoder
- Inform your service agency.


Error description 237-18010

Error message

18010 Error in EnDat position encoder %1, error code %4

Cause of error

- The EnDat position encoder reports an error
- The error code describes the cause:
1 = Failure of the illumination
2 = Incorrect signal amplitude
4 = Incorrect position value
8 = Overvoltage in the power supply
16 = Undervoltage in the power supply
32 = Overcurrent
64 = Battery exchange needed

Error correction

- Check the installation of the encoder
- Check the power supply of the encoder
- If required, exchange the battery
- Exchange the encoder
- Inform your service agency.


Error description 237-18011

Error message

18011 Motor encoder: %1 Cause: %4, source: %5, alarm: %6

Cause of error

- An error occurred during forced dynamic sampling of error statuses in the EnDat 2.2 motor encoder

Error correction

- Check the encoder cable
- Check the encoder and, if necessary, exchange it
- Check the CC controller unit or UEC and, if necessary, exchange it
- Inform your service agency
Please indicate the complete error text: cause, source and alarm


Error description 237-18012

Error message

18012 Position encoder: %1 Cause: %4, source: %5, alarm: %6

Cause of error

- An error occurred during forced dynamic sampling of error statuses in the EnDat 2.2 position encoder

Error correction

- Check the encoder cable
- Check the encoder and, if necessary, exchange it
- Check the CC controller unit or UEC and, if necessary, exchange it
- Inform your service agency
Please indicate the complete error text: cause, source and alarm


Error description 237-18013

Error message

18013 DQ encoder %1: error condition %4 determined

Cause of error

- One of the safety signals of the DRIVE-CLiQ encoder
reports a device error.
- Meaning of the additional information:
101 = Internal error bit F1 is set.
102 = Internal error bit F2 is set.
103 = Internal bit "Position Ok PO" is missing.
104 = Internal error bit "Fault Severity 0 XG1" is set.

Error correction

- Exchange the defective encoder.
- Inform your service agency.


Error description 237-18014

Error message

18014 Sp. head change err. in DQ axis %1, port %4, err. %5

Cause of error

An error occurred during a spindle head change accompanied by PHY Power Down and Up.
The corresponding PHY is assigned to the given port.
Error = error code (BMCR = "Basic mode control" register of the PHY):
1: BMCR before PHY Power Down not OK
2: BMCR after PHY Power Down not OK
3: BMCR after PHY Power Up not OK
4: BMCR after PHY Power Up is OK, but timeout

Error correction

Inform your service agency.


Error description 237-18015

Error message

18015 PWM freq. axis %1 <= 4 kHz. Restart required.

Cause of error

During initial servicing of the control the PWM frequency of an axis is less than or equal to 4 kHz.
This axis is not assigned to the I2C master CC.

Error correction

- Switch the control off and on again
- Alarm occurs in spite of repeated restarts:
- Exchange defective CC or
- Exchange the backup battery of the MC
- Inform your service agency.


Error description 237-18017

Error message

18017 SPI expansion module: transmission error %4

Cause of error

- The SPI plug-in board (module for CC or MC) for controlling
analog axes or for reading analog actual values
cannot respond correctly.
- SPI plug-in module is defective.
- Wiring error on the SPI plug-in module

Error correction

- Check the external wiring, especially analog inputs and outputs
connected to the SPI plug-in module.
- Exchange the SPI plug-in board (module for CC or MC).
- Inform your service agency.


Error description 237-18018

Error message

18018 SPI expansion module: error in module, number %4

Cause of error

- The SPI plug-in board (module for CC or MC) for controlling
analog axes or for reading analog actual values
cannot respond correctly.
- SPI plug-in module is defective.
- Wiring error on the SPI plug-in module

Error correction

- Check the external wiring, especially analog inputs and outputs
connected to the SPI plug-in module.
- Exchange the SPI plug-in board (module for CC or MC).
- Inform your service agency.


Error description 237-18019

Error message

18019 Clearable positioning error %1, ES %4

Cause of error

A clearable positioning error has occurred (following error
too large) due to an active emergency-stop input. In this case, the CC controller unit
brakes the drive immediately. The result is a following error.
The additional info indicates the active emergency-stop input:
1 = Emergency stop A (ES.A)
2 = Emergency stop A with handwheel (ES.A.HW)
3 = Emergency stop B (ES.B)
4 = Emergency stop B with handwheel (ES.B.HW)
5 = Emergency stop B Functional Safety
6 = Emergency stop B Functional Safety with handwheel

Error correction

- Check the external wiring, especially the emergency stop inputs.
- Inform your service agency


Error description 237-1801A

Error message

1801A Non-clearable positioning error %1, ES %4

Cause of error

A positioning error that cannot be cleared (excessive servo lag)
occurred as the result of an active emergency-stop input. In this case,
the CC controller unit brakes the motor immediately. This results in
a servo-lag error. The additional information
indicates the active emergency-stop input:
1 = Emergency Stop A
2 = Emergency Stop A Handwheel
3 = Emergency Stop B
4 = Emergency Stop B Handwheel
5 = Emergency Stop B Functional Safety
6 = Emergency Stop B Functional Safety Handwheel
7 = Emergency Stop A Functional Safety
8 = Emergency Stop A Functional Safety Handwheel

Error correction

- Check the external wiring, especially the emergency-stop inputs
- Inform your service agency


Error description 237-1801B

Error message

1801B SPI module in wrong slot

Cause of error

A single SPI module (e.g. CMA-H) solely in SPI slot 2 is not permissible.

Error correction

- Insert the SPI module in slot 1 of the controller unit. Only once the control has been switched off and is free of potential!
- If the problem continues, inform your service agency.


Error description 237-1801C

Error message

1801C SPI expansion board not supported

Cause of error

- Hardware (CC controller) does not support the SPI expansion board.
- CC controller assembly is too old.

Error correction

- Replace CC controller assembly with a current model.
- Inform your service agency.


Error description 237-1801D

Error message

1801D Overcurrent at analog output on SPI expansion module

Cause of error

Current at output exceeds 20 mA Possible causes:
- Short circuit to 0 V or to other voltage sources
- Short circuit to other outputs

Error correction

- Check the connection of the shield (on both sides, low impedance. Refer to your control’s Technical Manual).
- Check the cabling for short circuits to 0 V, to voltage sources or outputs of other channels.
- Check the input impedance of the receiver.
- Inform your service agency.


Error description 237-1801E

Error message

1801E Excessive temperature at SPI expansion module

Cause of error

Temperature in the output driver exceeded 105 °C.

Error correction

Inform your service agency.


Error description 237-1801F

Error message

1801F Supply voltage on the SPI expansion module too low

Cause of error

Supply voltage of the output driver is too low:
- Voltage drop due to overload or short circuit
- Supply voltage through CC/UEC/MC too low

Error correction

- Check the supply voltage.
- Check the wiring of the outputs.
- Avoid overloads by deactivating one or more output channels.
- Inform your service agency.


Error description 237-18020

Error message

18020 Overcurrent on the analog output of the SPI expansion module

Cause of error

Message accompanies the ¿SHORT_CIRCUIT¿, error message if the error occurred only
briefly and corrected itself.

Error correction

No remedial actions required because the error has been settled.


Error description 237-18021

Error message

18021 Error in the CMP file: Supply pointer (SP) is faulty

Cause of error

CMP file: Supply pointer (SP) "UCCS" compensations is faulty.
The supply pointer points to the infeed point for which the respective compensation is active.
Possible input values:
-1: Void -> Output value of the block can be used for UCCP.
0: UCCS block 0
1: UCCS block 1
2: UCCS block 0
3: UCCS block 3
4: UCCS block 4
5: UCCS block 5
6: IqNom
7: WNom

Error correction

- Deactivate CMP file in machine parameters
- Create CMP file again.
- Inform your service agency.


Error description 237-18022

Error message

18022 CMP file: Axis transfer in the "UCCS" compensation is faulty.

Cause of error

CMP file: The axis transfer in the "UCCS" compensations is faulty.
The axis information from the MC, i.e. the transferred axis index does not agree with the axis index of the active axis. There is an internal software error.

Error correction

- Deactivate CMP file in machine parameters
- Create CMP file again.
- Inform your service agency.


Error description 237-18023

Error message

18023 CMP file: Def. function (FUNC) in UCCS compensations is faulty

Cause of error

CMP file: A faulty function (FUNC) was used in the UCCS compensations.
The following functions are possible:
0: DoNothing (-> deactivation)
1: Polynomial
2: Inverse polynomial
3: IIR filter, 2nd order
4: Sine
5: Hyperbolic sine
6: Segment-defined function
7: Adaptive filter

Error correction

- Deactivate CMP file in machine parameters
- Create CMP file again.
- Inform your service agency.


Error description 237-18024

Error message

18024 CMP file: Signal definition SIG0 or SIG1 of UCCS is faulty

Cause of error

CMP file: Definition of the input signals SIG0 or SIG1 von UCCS/UCCP is faulty.
The following input quantities are allowed:
–1: Not active
0: Value entered in the machine parameter (only UCCP)
1: Output value for block 0
2: Output value for block 1
3: Output value for block 2
4: Output value for block 3
5: Output value for block 4
6: Feedforward current
7: Feedforward acceleration
8: Feedforward velocity
9: Nominal speed
10: Following error
11: Nominal current
12: Integral current
13: Nominal voltage
14: Ud
15: Uq
16: IqNom
17: IdNom
18: IqAct
19: IdAct
20: Motor temperature
21: Commutation angle

Error correction

- Deactivate CMP file in machine parameters
- Create CMP file again.
- Inform your service agency.


Error description 237-18025

Error message

18025 CMP file: Axis index (SAX) in the UCCS compensations is faulty

Cause of error

CMP file: Axis index (SAX) in the UCCS compensations is faulty.
The axis index points at its own axis or another axis that must be located on the same CC board. The given index is with respect to the index of the machine-parameter file.

Error correction

- Deactivate CMP file in machine parameters
- Create CMP file again.
- Inform your service agency.


Error description 237-18026

Error message

18026 CMP file: Entry (ENTR) in the "UCCS" compensations is faulty

Cause of error

CMP file: Entry (ENTR) in the "UCCS" compensations is faulty.
"Entry" defines whether the UCCS compensation is applied additively or multiplicatively. The following input is allowed:
0: Application deactivated
1: Additive application
2: Multiplicative application

Error correction

- Deactivate CMP file in machine parameters
- Create CMP file again.
- Inform your service agency.


Error description 237-18027

Error message

18027 "Expanded compensations" and "TRC" are not simultaneous

Cause of error

The "TRC = Torque Ripple Compensation" and "Expanded compensations" functions could not be used at the same time.

Error correction

- Deselect the TRC compensation through the appropriate machine parameter or
- Select the expanded compensations
- Inform your service agency


Error description 237-18028

Error message

18028 CC%2: invalid command %4 received

Cause of error

A communication error occurred between the main computer (MC) and the controller unit (CC).
Possible causes:
- Faulty HSCI wiring
- Internal software error
- Installed software version is not officially released

Error correction

- Check the voltage supply to the devices
- Check the HSCI cabling
- Check the HSCI connections (plugged in?)
- Check the software version
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Inform your service agency


Error description 237-18029

Error message

18029 CC%2 incrmtl. actl. val. measrmt. w/ motor enc. %1

Cause of error

- Encoder defective
- Data transfer from encoder faulty
- Internal software error

Error correction

- Check the encoder cable and its connection
- Exchange the encoder cable
- Exchange the encoder
- Check the software version.
- Inform your service agency.


Error description 237-18030

Error message

18030 CC%2 incrmtl. actl. value measrmt. w/ pos. enc. %1

Cause of error

- Encoder defective
- Data transfer from encoder faulty
- Internal software error

Error correction

- Check the encoder cable and its connection
- Exchange the encoder cable
- Exchange the encoder
- Check the software version.
- Inform your service agency.


Error description 237-18031

Error message

18031 CC%2 nominal speed value (PWM) incorrect %1

Cause of error

The controller unit provides no valid nominal speed value for the motor, or provides it too late:
- Controller configuration (machine parameters) faulty
- Internal software error

Error correction

- Check the controller configuration or machine parameters for PWM frequency, encoder inputs/outputs and nominal value outputs
- Check the software version.
- Inform your service agency.


Error description 237-18032

Error message

18032 Maximum number of CCs was exceeded

Cause of error

The permissible number of CC controller units has been exceeded.

Error correction

- Reduce the number of CCs.
- Inform your service agency.


Error description 237-18033

Error message

18033 Syntax error in PAC compensation file

Cause of error

- Syntax error in the compensation file for PAC
- Faulty function type in the compensation file for PAC

Error correction

- Use TNCopt to recreate a compensation file for PAC
- Inform your service agency


Error description 237-18034

Error message

18034 Invalid axis assignment in PAC compensation file

Cause of error

- Invalid axis assignment in the compensation file for PAC
- Syntax error in the compensation file for PAC

Error correction

- Check the axis assignment in the compensation file for PAC
- Use TNCopt to recreate a compensation file for PAC
- Inform your service agency


Error description 237-18035

Error message

18035 Syntax error in CTC compensation file

Cause of error

- Invalid input point in the compensation file for CTC
- Syntax error in the compensation file for CTC

Error correction

- Use TNCopt to recreate a compensation file for CTC
- Inform your service agency


Error description 237-18036

Error message

18036 CC%2 Drive:%1 stop=%4 cause=%5 axis group=%6 condition=%7

Cause of error


Error description 237-18037

Error message

18037 Required software option not enabled: %4

Cause of error

The entered software option has not been enabled, although you tried to activate a function connected with it.

Error correction

- Check the software options using the SIK code number
- Contact a representative of the machine manufacturer or HEIDENHAIN.


Error description 237-18038

Error message

18038 Incorrect entry in CTC compensation file

Cause of error

- Syntax error in the compensation files of the “expanded compensation” of the CTC function

Error correction

- Use TNCopt to recreate a compensation file for CTC
- Inform your service agency


Error description 237-18039

Error message

18039 Speed encoder line count of %1 is incorrect. %4 was expected.

Cause of error

Rotary encoders:
- Encoder line count in the parameter is not equal to the EnDat line count found
- The entry in machine parameter "cfgServoMotor --> motStr" is incorrect
- Incorrect entry under STR in motor table
- EnDat 2.2 rotational speed encoder without line count information must be defined as STR = 1 or "cfgServoMotor --> motStr=1"
Linear encoders:
- the grating period in the parameter deviates from the grating period found by EnDat
- The entry in machine parameter posEncodeType or posEncoderIncr is faulty
- For EnDat 2.2 linear encoders without specified grating period, the value of the measuring step (e.g. 1 nm or 10 nm) must be parameterized

Error correction

Rotary encoders:
- Enter the correct line count in machine parameter "cfgServoMotor --> motStr"
- Enter the displayed line count under STR in the motor table
Linear encoders:
- Enter the displayed grating period in machine parameter posEncoderDist or posEncoderIncr
Inform your service agency.


Error description 237-1803A

Error message

1803A Configuration error %1 posEncoderDist=%4, posEncoderIncr=%5

Cause of error

Faulty configuration:
- The context from the machine parameters CfgAxisHardware->posEncoderDist to CfgAxisHardware->posEncoderIncr does not agree with the values from the EnDat encoder
- With EnDat 2.2: See the Technical Manual of the control

Error correction

- Check the entries of the machine parameters CfgAxisHardware->posEncoderDist or CfgAxisHardware->posEncoderInc and replace them with the displayed values
- Inform your service agency.


Error description 237-1803B

Error message

1803B CC%2: command %4 received with invalid addressing %5

Cause of error

A communication error occurred between the main computer (MC) and the controller unit (CC).
Possible causes:
- Faulty HSCI wiring
- Internal software error
- Installed software version is not officially released

Error correction

- Check the voltage supply to the devices
- Check the HSCI cabling
- Check the HSCI connections (plugged in?)
- Check the software version
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Inform your service agency


Error description 237-1803C

Error message

1803C Incorrect parameter entry in CC compensation file under UCCS

Cause of error

- Invalid entry in the compensation files of the expanded compensation (CTC, PAC, LAC, ...)
- The installed software version does not support this entry

Error correction

- Check the entries of the compensation files
- Inform your service agency


Error description 237-1803D

Error message

1803D Incorrect entry in PAC compensation file

Cause of error

- Invalid entry in the compensation file for PAC
- Installed software version does not support this entry

Error correction

- Check the entries of the compensation file
- Inform your service agency


Error description 237-1803E

Error message

1803E Error in current controller

Cause of error

In spite of the given nominal current, the current controller could not measure any actual current (= 0). Possible causes:
- Line to motor interrupted
- Error in the control of the wye-delta contactor
- Defective power module

Error correction

- Check the motor lines
- Check the wiring and function of the wye-delta contactor
- Exchange the power module, if necessary
- Inform your service agency


Error description 237-1803F

Error message

1803F Syntax error in compensation file LAC

Cause of error

Error in the syntax of the "expanded compensations"
Type of the "Load Adaptive Control" function is unknown

Error correction

Generation of a new LAC compensation files through TNCopt
Inform your service agency.


Error description 237-18041

Error message

18041 Number of maximum compensation blocks (CTC/PAC) exceeded

Cause of error

– Maximum number of CTC blocks exceeded
– Maximum number of PAC blocks exceeded
– Maximum number of other blocks of the extended compensations exceeded

Error correction

– Revise extended compensation files with TNCopt
– Deactivation of extended compensations via MP2700/CfgControllerComp.enhancedComp
- Inform your service agency


Error description 237-18042

Error message

18042 Syntax error in compensation file MAC

Cause of error

Error in the syntax of the "expanded compensations"
Type of the "Motion Adaptive Control" function is unknown

Error correction

- Use TNCopt to generate a new MAC compensation file
- Inform your service agency


Error description 237-18044

Error message

18044 There is no compensation file for CTC

Cause of error

Compensation file is missing

Error correction

- Use TNCopt to generate a compensation file
- Deactivate the compensation file in CfgControllerComp.enhancedComp
- Inform your service agency


Error description 237-18045

Error message

18045 There is no compensation file for PAC

Cause of error

Compensation file is missing

Error correction

- Use TNCopt to generate a compensation file
- Deactivate the compensation file in CfgControllerComp.enhancedComp
- Inform your service agency


Error description 237-18046

Error message

18046 There is no compensation file for LAC

Cause of error

Compensation file is missing

Error correction

- Use TNCopt to generate a compensation file
- Deactivate the compensation file in CfgControllerComp.enhancedComp
- Inform your service agency


Error description 237-18047

Error message

18047 There is no compensation file for MAC

Cause of error

Compensation file is missing

Error correction

- Use TNCopt to generate a compensation file
- Deactivate the compensation file in CfgControllerComp.enhancedComp
- Inform your service agency


Error description 237-18048

Error message

18048 There is no compensation file for ACC

Cause of error

Compensation file is missing

Error correction

- Use TNCopt to generate a compensation file
- Deactivate the compensation file in CfgControllerComp.enhancedComp
- Inform your service agency


Error description 237-1804A

Error message

1804A There is no compensation file for UCCS

Cause of error

Compensation file is missing

Error correction

- Use TNCopt to generate a compensation file
- Deactivate the compensation file in CfgControllerComp.enhancedComp
- Inform your service agency


Error description 237-1804B

Error message

1804B There is no compensation file for UCCP

Cause of error

Compensation file is missing

Error correction

- Use TNCopt to generate a compensation file
- Deactivate the compensation file in CfgControllerComp.enhancedComp
- Inform your service agency


Error description 237-1804C

Error message

1804C EnDat position encoder: Transmission rate axis %1

Cause of error

- The communication with the encoder is not possible at the
velocity required for servo control.

Error correction

- Check the cable and connecting elements of the signal path
- Exchange the encoder
- Exchange the CC
- Inform your service agency


Error description 237-1804D

Error message

1804D EnDat motor encoder: Transmission rate axis %1

Cause of error

- The communication with the encoder is not possible at the
velocity required for servo control.

Error correction

- Check the cable and connecting elements of the signal path
- Exchange the encoder
- Exchange the CC
- Inform your service agency


Error description 237-1804E

Error message

1804E SPI trigger card activates %1 trigger rate %4 Hz

Cause of error

- The synchronization of external encoders through an
SPI trigger card in the CC was activated with
CfgCCAuxil.miscCtrlFunct1, bit 10

Error correction

- Check the entry in CfgCCAuxil.miscCtrlFunct1, bit 10
- Inform your service agency


Error description 237-1804F

Error message

1804F EnDat2.2 configured but not detected %1 info %4 %5 %6

Cause of error

An EnDat2.2 encoder was configured, but the control could not switch it to the EnDat2.2-Modus mode.
Info contains the following three additional information data:
1) 1: This is about the shaft speed encoder
2: This is about the position encoder
2) Connector offset
e.g. connector offset = 3 and additional info 1) = 2:
Connector X204 is affected
3) EnDat error word

Error correction

- Check the entry in Machine Parameter CfgAxisHardware-posEncoderType:
The value CC_EXTERN_ENDAT_2_2 must not be set unless the position encoder is an EnDat 2.2 encoder.
- Check the selected motor:
The current settings expect a motor with EnDat2.2 encoder.
- Check the entry in Machine Parameter CfgServoMotor-motEncType.
- Check the status of the EnDat2.2 encoder with the aid of DriveDiag:
Check the pending alarms.


Error description 237-18050

Error message

18050 CC%2 %1 AVD parameter ID=%4

Cause of error

There is an error in the AVD parameter file:
- The file contains invalid parameter data
- An incorrect version of TNCopt may have been used to create it

Error correction

- Deactivate AVD in the configuration (enhancedComp/MP2700)
- Make a new AVD file with a current version of TNCopt
- Check the software version
ID=10 Can only be used on hardware with a limited number of axes
- Inform your service agency
ID=107 Kv factor of position controller does not match AVD parameter PAR7
ID=108 Kp factor of speed controller does not match AVD parameter PAR8
ID=109 Ki factor of speed controller does not match AVD parameter PAR9
ID=205 File version not valid
ID=300 Motor overcurrent due to incorrect AVD parameter assignment


Error description 237-18051

Error message

18051 Axis %2: Number of the UV is in error

Cause of error

- Number of the UV power supply unit in the machine parameter is faulty

Error correction

- Check the number of the UV power supply unit in the machine parameter
- Inform your service agency


Error description 237-18052

Error message

18052 Axis %2: Faulty entry in ICTRL compensation file

Cause of error

- Invalid entry in the compensation file for ICTRL
- Installed software version does not support this entry

Error correction

- Check the entries in the compensation file for ICTRL
- Inform your service agency


Error description 237-18053

Error message

18053 %4 %1

Cause of error

No help text available


Error description 237-18054

Error message

18054 %4 %1

Cause of error

No help text available


Error description 237-18055

Error message

18055 %4 %1

Cause of error

No help text available


Error description 237-18056

Error message

18056 CC %2 axis %1: Filter %4 in the speed control loop is instable

Cause of error

- The filter parameter set is inconsistent.
- The filter frequency defined in the machine parameter MP_vCtrlFilterFreqX is too low or too high.

Error correction

- Check the entries in the machine parameters MP_vCtrlFilterTypeX, MP_vCtrlFilterFreqX, MP_vCtrlFilterDampingX and MP_vCtrlFilterBandWidthX, whereby X stands for the displayed filter number.
- Inform your service agency


Error description 237-18057

Error message

18057 CC %2 axis %1: Filter %4 in the position control loop is instable

Cause of error

- The filter parameter set is inconsistent
- The filter frequency defined in the machine parameter MP_vCtrlFilterFreqX is too low or too high

Error correction

- Check the entries in the machine parameters MP_vCtrlFilterTypeX, MP_vCtrlFilterFreqX, MP_vCtrlFilterDampingX and MP_vCtrlFilterBandWidthX, whereby X stands for the displayed filter number.
- Inform your service agency


Error description 237-18058

Error message

18058 CC %2 axis %1: IPC is instable %4

Cause of error

- IPC time constant is too large

Error correction

- Check machine parameters MP_compIpcT1 and MP_compIpcT2
- Inform your service agency


Error description 237-18059

Error message

18059 CC %2 axis %1: AVD instable %4

Cause of error

- The adjusted AVD frequency is too low or too high.

Error correction

- Inspect the AVD frequency with a current version of TNCopt
- Generation of a new AVD file through TNCopt
- Inform your service agency


Error description 237-1805A

Error message

1805A CC %2 axis %1: AVD instable %4

Cause of error

- The adjusted AVD frequency is too low or too high.

Error correction

- Inspect the AVD frequency with a current version of TNCopt
- Generation of a new AVD file through TNCopt
- Inform your service agency


Error description 237-1805B

Error message

1805B CC %2 axis %1: AVD filter is instable %4

Cause of error

- The parameter set of the AVD filter 13 (type 22) is inconsistent
- The defined frequency of the AVD filter 13 (type 22) is too high or too low
- The adjusted AVD frequency is too high or too low.

Error correction

- Use the current TNCopt version to check the AVD filter 13.
- Inspect the AVD frequency using TNCopt
- Generation of a new AVD file through TNCopt
- Inform your service agency


Error description 237-1805C

Error message

1805C CC %2 axis %1: Measurement with AVD is instable %4

Cause of error

- Internal software error

Error correction

- Check the software version.
- Inform your service agency


Error description 237-1805D

Error message

1805D Maximum number of function blocks exceeded %1

Cause of error

- Maximum number of LAC function blocks exceeded
- Maximum number of function blocks of the extended compensations exceeded

Error correction

- Revise extended compensation files with TNCopt
- Deactivation of extended compensations via <ParameterSet>.CfgControllerComp.enhancedComp
- Inform your service agency


Error description 237-1805E

Error message

1805E Feed-in point in %4 in line %4 is faulty

Cause of error

- Syntax error in the displayed file
- The given feed-in point is not supported

Error correction

- Generation of a new compensation file through TNCopt
- Deactivation of extended compensations
- Inform your service agency


Error description 237-1805F

Error message

1805F Error in %4 in line %5

Cause of error

- Syntax error in the displayed file
- Signal index (SIGx) in the displayed line is faulty

Error correction

- Use TNCopt to regenerate the displayed file
- Deactivation of extended compensations via <ParameterSet>.CfgControllerComp.enhancedComp
- Inform your service agency


Error description 237-18060

Error message

18060 Faulty assignment in %4

Cause of error

- Input or output cannot be accessed for compensation (e.g. is on another controller board)
- Faulty assignment in the displayed file

Error correction

- Use TNCopt to regenerate the compensation file
- Compensations by axis coupling possible only for axes on the same controller board
- Inform your service agency


Error description 237-18062

Error message

18062 CC %2 axis %1: AVD Filter 1%4 in position control loop instable

Cause of error

- The filter parameter set is inconsistent
- The filter frequency is defined too high or too low

Error correction

- Use the current TNCopt version to check the AVD filters 11 and 12
- Generation of a new AVD file through TNCopt
- Inform your service agency


Error description 237-18063

Error message

18063 CC %2 axis %1: ACC instable %4

Cause of error

- Internal software error

Error correction

- Check the software version.
- Inform your service agency


Error description 237-18064

Error message

18064 CC %2 axis %1: ACC instable %4

Cause of error

- Internal software error

Error correction

- Check the software version.
- Inform your service agency


Error description 237-18065

Error message

18065 CC %2 axis %1: ACC instable %4

Cause of error

- Internal software error

Error correction

- Check the software version.
- Inform your service agency


Error description 237-18066

Error message

18066 CC %2 axis %1: ACC instable %4

Cause of error

- Internal software error

Error correction

- Check the software version.
- Inform your service agency


Error description 237-18067

Error message

18067 CC %2 axis %1: CPF is instable %4

Cause of error

- Separation frequency of the Crossover Position Filters (CPF) is too low

Error correction

- Check the separation frequency (MP_compActDampFreq)
- Inform your service agency


Error description 237-18068

Error message

18068 Axis %1: FSC filter instable (%4)

Cause of error

The FSC filter parameters are faulty.

Error correction

- Check the FSC parameters
- Use TNCopt to optimize the FSC parameters
- Deactivate FSC (set FscAccToIq to 0)
- Inform your service agency


Error description 237-18069

Error message

18069 Axis %1: FSC filter instable (%4)

Cause of error

The FSC filter parameters are faulty.

Error correction

- Check the FSC parameters
- Use TNCopt to optimize the FSC parameters
- Deactivate FSC (set FscAccToIq to 0)
- Inform your service agency


Error description 237-1806B

Error message

1806B CC %2 axis %1: Filter is instable %4

Cause of error

- Internal software error

Error correction

- Check the software version.
- Inform your service agency


Error description 237-1806C

Error message

1806C "Machine Parameter" in %4 in line %5 is in error

Cause of error

- Syntax error in displayed file.
- The given machine parameter is not supported

Error correction

- Generation of a new compensation file through TNCopt
- Deactivation of the expanded compensations
- Inform your service agency


Error description 237-1806D

Error message

1806D Syntax error in FN22 function

Cause of error

- Error in FN22 syntax

Error correction

Inspect the syntax in the FN22 function
Deactivate the FN22 function or the superimposed cycle
Inform your service agency


Error description 237-1806E

Error message

1806E Faulty assignment in %4

Cause of error

- Faulty assignment in the displayed file

Error correction

- Use TNCopt to regenerate the compensation file
- Inform your service agency


Error description 237-1806F

Error message

1806F Cycle 239 has been canceled

Cause of error

Cycle 239 was canceled
No mass/mass moment of inertia was estimated

Error correction

Repeat Cycle 239


Error description 237-18070

Error message

18070 CC%2 %1 Current limit in control loop

Cause of error

The current limitation in the control loop responded
The AVD function was deactivated. Possible causes:
- Excessive acceleration
- Feedforward-control parameter(s) incorrect
- Type of AVD damping incorrect
- AVD damping factor too high

Error correction

- Check the nominal acceleration
- Check the feedforward-control parameter(s)
- Check the AVD parameterization
- Adapt the parameter(s) if necessary
- - Inform your service agency


Error description 237-18071

Error message

18071 CC%2 function only available with EnDat encoder %1

Cause of error

The crossover position filter is possible only with an EnDat encoder.

Error correction

Deselect the crossover position filter
Use of an EnDat linear encoder
Inform your service agency


Error description 237-18072

Error message

18072 Spindle overload %1

Cause of error

- The spindle was briefly overloaded

Error correction

- Reduce the feed rate
- Reduce the infeed
- Check the cutting data


Error description 237-18073

Error message

18073 Transfer machine parameters axis %1


Error description 237-18074

Error message

18074 CC%2 %1 measured mass moment of inertia: %4 [kg'*m*m*0.001]

Cause of error


Error description 237-18075

Error message

18075 CC%2 %1 measured mass: %4 [kg*0.001]


Error description 237-18076

Error message

18076 CC%2 %1 acceleration threshold not reached: %4 [percent]

Cause of error

The required axis acceleration was not reached during the weighing run.
The mass or mass moment of inertia can be estimated only if a specific minimum acceleration is reached.

Error correction

- Set override potentiometer to 100%
- Increase the traverse distance for the weighing run


Error description 237-18078

Error message

18078 CC %2 axis %1: parameter %4 not supported by the software.

Cause of error

- Machine parameters are no longer supported by the installed NC software version.

Error correction

- Delete the machine parameters or set them to their initial value.
- Inform your service agency


Error description 237-18079

Error message

18079 CC%2: disturbance in UM communication, error code=%4

Cause of error

The communication component for the optical fiber connection (HFL) to the inverters reports an error
Possible causes:
- Hardware defective
- Electromagnetic disturbances
- Optical fibers (HFL) not connected correctly
- Insufficient bend radius of the optical fibers

Error correction

- Create a service file (error code gives information about the exact cause of the error for the diagnosis at HEIDENHAIN)
- Inform your service agency
- If required, exchange the hardware
- Use TNCdiag to check the damping of the fiber-optic connections (HFL). If the damping is too high:
- Check the optical fiber connections
- Comply with the guidelines in the Technical Manual regarding the cable routing
- Check the machine for correct shield connections and grounding
- Check the motor and power cables for correct shield connections and terminal connections


Error description 237-1807A

Error message

1807A CC%2: Internal connection fault, Error code=%4

Cause of error

The communication component of an internal connection is reporting an error.
Possible causes:
- Electromagnetic interference
- Hardware defective

Error correction

- Check the encoder cables, particularly shield connections
- Comply with the guidelines in the Technical Manual regarding the cable routing
- Exchange the hardware
- Create a service file (error code gives information about the exact cause of the error for the diagnosis at HEIDENHAIN)
- Inform your service agency


Error description 237-1807B

Error message

1807B CC%2: logical disturbance of data reception %1, error code=%4

Cause of error

The communication component for the optical fiber connection (HFL) to the inverters reports an error
Possible causes:
- Hardware defective
- Electromagnetic disturbances
- Optical fibers (HFL) not connected correctly
- Insufficient bend radius of the optical fibers

Error correction

- Create a service file (error code gives information about the exact cause of the error for the diagnosis at HEIDENHAIN)
- Inform your service agency
- If required, exchange the hardware
- Use TNCdiag to check the damping of the fiber-optic connections (HFL). If the damping is too high:
- Check the optical fiber connections
- Comply with the guidelines in the Technical Manual regarding the cable routing
- Check the machine for correct shield connections and grounding
- Check the motor and power cables for correct shield connections and terminal connections


Error description 237-1807C

Error message

1807C CC%2: Internal port %5 fault, Error code=%4

Cause of error

The communication component of an internal connection is reporting an error
Possible causes:
- Electromagnetic interference
- Defective hardware

Error correction

- Check the encoder cables, particularly shield connections
- Comply with the guidelines in the Technical Manual regarding the cable routing
- Exchange the hardware
- Create a service file (error code gives information about the exact cause of the error for the diagnosis at HEIDENHAIN)
- Inform your service agency


Error description 237-1807D

Error message

1807D CC%2: physical disturbance of data reception %1, error code=%4

Cause of error

The communication component for the optical fiber connection (HFL) to the inverters reports an error.
Possible causes:
- Hardware defective
- Electromagnetic disturbances
- Optical fibers (HFL) not connected correctly
- Insufficient bend radius of the optical fibers

Error correction

- Use TNCdiag to check the damping of the optical fiber connections (HFL);
if the damping is too high:
- Check the optical fiber connections
- Comply with the guidelines in the Technical Manual regarding the cable routing
- If necessary, exchange the hardware
- Create a service file (error code gives information about the exact cause of the error for the diagnosis at HEIDENHAIN)
- Inform your service agency
- Check the machine for correct shield connections and grounding
- Check the motor and power cables for correct shield connections and terminal connections


Error description 237-1807E

Error message

1807E CC%s: Internal connection fault, Error code=%4

Cause of error

The component for internal optical fiber connections reports an error
Possible causes:
- Electromagnetic disturbances
- Hardware defective

Error correction

- Check the encoder cables, particularly shield connections
- Refer to the guidelines in the Technical Manual regarding the cable routing
- Exchange the hardware
- Create a service file (error code information about the exact cause of the error for the diagnosis at HEIDENHAIN)
- Contact your service agency


Error description 237-1807F

Error message

1807F UM 3xx inverter not found %1

Cause of error

- No communication with the inverter of the displayed axis
- Optical fibers connected incorrectly or not at all
- Supply voltage of the inverter is missing
- The machine parameters CfgAxisHardware->inverterInterface, CfgAxisHardware->motorConnector,
or CfgAxisHardware->hsciCcIndex are not parameterized correctly.
- Inverter defective

Error correction

- Check the cabling
- Check the supply voltage of the inverters
- Check the entries in the machine parameters
- Replace the inverter
- Contact your service agency


Error description 237-18082

Error message

18082 There is no input for position encoder %1

Cause of error

- A non-existent input was selected for the position encoder (entry in MP_posEncoderInput)

Error correction

- Check machine parameter MP_posEncoderInput
- Inform your service agency


Error description 237-18083

Error message

18083 There is no input for speed encoder %1

Cause of error

- A non-existent input was selected for the tachometer (entry in MP_speedEncoderInput)

Error correction

- Check machine parameter MP_speedEncoderInput
- Inform your service agency


Error description 237-18084

Error message

18084 No outlet for optical waveguide %1

Cause of error

- A non-existent output was selected for the fiber-optic cable to the inverter UM (entry in MP_inverterInterface)

Error correction

- Check the machine parameter MP_inverterInterface
- Inform your service agency


Error description 237-18085

Error message

18085 There is no motor connection on the inverter %1

Cause of error

- The selected motor connection (entry in MP_motorConnector) is not present on the UM inverter or UEC compact inverter.

Error correction

- Check the machine parameter MP_motorConnector
- Inform your service agency


Error description 237-18086

Error message

18086 %1 LAC: Measured mass moment of inertia: %4 [0.001*kg*m*m]


Error description 237-18087

Error message

18087 %1 LAC: measured mass: %4 [0.001*kg]


Error description 237-18089

Error message

18089 WD monitoring has responded %1 (received:%4, expected:%5)

Cause of error

CC controller unit or UEC compact inverter reports that watchdog is no longer updated on UM inverter or UEC compact inverter

Error correction

- Restart the control
- Check the machine for correct shield connections and grounding
- Check the motor and power cables for correct shield connections and terminal connections
- Inform your service agency


Error description 237-1808A

Error message

1808A Initial communication with inverter failed CC%2 %1

Cause of error

No communication could be established with the inverter when booting the control.

Error correction

- Check the power supply
- Inform your service agency
- Replace the inverter


Error description 237-1808B

Error message

1808B ICTRL_xx.cmp parameter file faulty

Cause of error

- Incorrect entry in parameter file ICTRL_xx.cmp

Error correction

- Generation of a new parameter file via TNCopt
- Variable parameter unknown
- Variable parameter not permitted for this function
- Inform your service agency


Error description 237-1808C

Error message

1808C Parameter entered: "%1 WearAdaptFriction = %4"

Cause of error

- Wear parameter(s) defined


Error description 237-1808D

Error message

1808D Error in the determination of "WearAdaptFriction"

Cause of error

An error occurred while determining "WearAdaptFriction"
- The velocity profile is not suitable for determining the wear parameter
- The velocity profile is too long; as a result, the data recording is aborted too soon.
- The velocity profile is too short; as a result, no constant velocity is reached for measured-value recording.

Error correction

- Adapt the velocity profile for determining the characteristic value for the wear
- Inform your service agency


Error description 237-1808E

Error message

1808E PWM switching not permitted during operation

Cause of error

- The parameter for the PWM frequency was changed during operation.
- The initial machine parameters contain a different PWM frequency.

Error correction

- All machine parameter subfiles must have the same PWM settings.
- For all subfiles and all axes that are on the same PWM output, change the PWM frequency to the same value.
- Inform your service agency.


Error description 237-1808F

Error message

1808F CC%2 incompatible motor system %1, X%4 connection

Cause of error

The configured encoder input of the controller unit can evaluate only digital, purely serial measuring systems
This input does not support encoders with 1Vpp signals.

Error correction

- If the motor encoder being used is a 1Vpp encoder: use inputs X401 to X406 of this CC and configure them through CfgAxisConfig/MP_speedEncoderInput.
- If it is an encoder with purely serial EnDat interface: set the parameter CfgServoMotor/MP_motEncType to the correct value.
- Inform your service agency.


Error description 237-18090

Error message

18090 CC%2 incompatible position encoder %1, X%4 connection

Cause of error

The configured encoder input of the controller unit can evaluate only digital, purely serial measuring systems
This input does not support encoders with 1Vpp signals.

Error correction

- If the position encoder being used is a 1Vpp encoder: use inputs X401 to X406 of the CC and configure them through CfgAxisConfig/MP_posEncoderInput.
- If it is an encoder with purely serial EnDat interface: set the parameter CfgAxisHardware/MP_posEncoderType to the correct value.
- Inform your service agency


Error description 237-18091

Error message

18091 Speed controller: P factor or reset time too small in axis %1

Cause of error

- P-factor of the speed controller in MP_vCtrlPropGain under CfgSpeedControl is too small
- Reset time of the speed controller MP_vCtrlPropGain or MP_vCtrlIntGain is too short
- Bit 20 of MP_miscCtrlFunct0 under CfgCCAuxil is set, although P factor and reset time are not too small

Error correction

- Increase the P factor in MP_vCtrlPropGain
- Reduce the I factor in MP_vCtrlIntGain
- Reset bit 20 of MP_miscCtrlFunct0


Error description 237-18092

Error message

18092 Controller software timeout BOARD-ID %2

Cause of error

- The time monitor of the controller software reports an expiration.
- Internal software error

Error correction

- Inform your service agency


Error description 237-18093

Error message

18093 Controller software timeout BOARD-ID %2

Cause of error

- The time monitor of the controller software reports an expiration.
- Internal software error

Error correction

- Inform your service agency


Error description 237-18094

Error message

18094 CC%2 error during EnDat3 initialization %1

Cause of error

- A problem occurred during initialization of the EnDat3 interface (AddInfo[0] == 0).
- Communication with the EnDat3 encoder is not possible (AddInfo[0] == 1).

Error correction

- Restart the control
- Exchange the CC controller unit
- Check the encoder connecting cable
- Remove the encoder from power for at least 5 seconds (disconnect the encoder from the control) and then restart the control
- Exchange the encoder


Error description 237-18096

Error message

18096 Parameters of current controller are not correct %1 info %4

Cause of error

- The current controller (CfgCurrentControl) is not parameterized correctly
Info = 1: Mixed parameterization is not permitted:
Please use only (iCtrlPropGain and iCtrlIntGain) or
(iCtrlPropGainD, iCtrlIntGainD, iCtrlPropGainQ, and iCtrlIntGainQ)
Info = 2: iCtrlPropGain = 0, even though iCtrlIntGain > 0
Info = 3: iCtrlPropGainD = 0, even though iCtrlIntGainD > 0
Info = 4: iCtrlPropGainQ = 0, even though iCtrlIntGainQ > 0

Error correction

- Correct the parameterization of the current controller
Info = 1: Set (iCtrlPropGain = 0 and iCtrlIntGain = 0) or
(iCtrlPropGainD = 0, iCtrlIntGainD = 0, iCtrlPropGainQ = 0, and iCtrlIntGainQ = 0)
Info = 2: Set iCtrlPropGain > 0 or iCtrlIntGain = 0
Info = 3: Set iCtrlPropGainD > 0 or iCtrlIntGainD = 0
Info = 4: Set iCtrlPropGainQ > 0 or iCtrlIntGainQ = 0


Error description 237-18097

Error message

18097 Axis %1: measurement not possible

Cause of error

The axis was moved beyond the traverse limit during the measurement.

Error correction

Position the axis so that there is sufficient clearance to the traverse limits.
Reduce the underlying velocity.


Error description 237-18098

Error message

18098 Axis %1: Application of the excitation signal canceled.

Cause of error

Drive is off or was switched off while the excitation signal was applied.

Error correction

Repeat the measurement with all drives switched on.


Error description 237-18099

Error message

18099 Shaft-speed-dependent PWM frequency switching not possible %1

Cause of error

- A shaft-speed-dependent switching of the PWM frequency is configured with CfgCurrentControl/MP_iCtrlPwmType = 2.
The software version being used does not yet support this functionality for Gen 3 drives.

Error correction

- Set the parameter CfgCurrentControl->iCtrlPwmType to 0.
- If necessary, permanently set the PWM frequency to the higher value.
- Inform your service agency.


Error description 237-1809A

Error message

1809A TNCopt adjustment sequence was started

Cause of error

An automatic adjustment sequence was started in TNCopt. TNCopt is controlling
the control. The movement of the axes can be started automatically.

Error correction

- Check whether TNCopt is connected to the control and an adjustment sequence was started.


Error description 237-1809B

Error message

1809B Axes %1: Oscillation detected.

Cause of error

An oscillation was detected during the measurement.

Error correction

Reduce the amplitude of the excitation signal.
Ensure that the control loops have sufficient stability reserves.


Error description 237-1809C

Error message

1809C Type of referencing not permissible %1

Cause of error

The mode set in the parameter CfgReferencing->refType is not possible with the present encoder.

Error correction

Enter a referencing mode suitable to the encoder in the stated parameter.


Error description 237-1809D

Error message

1809D CC%2: faulty internal connection

Cause of error

Interrupted communication to a device-internal controller.
Possible causes:
- Supply voltage outside of the permissible tolerance
- Hardware defective

Error correction

- Check the supply voltage of the affected CC and dimension it according to the manual.
- Exchange the CC.
- Inform your service agency.


Error description 237-1809E

Error message

1809E CC%2: faulty internal connection

Cause of error

Interrupted communication to a device-internal controller.
Possible causes:
- Supply voltage outside of the permissible tolerance
- Hardware defective

Error correction

- Check the supply voltage of the affected CC and dimension it according to the manual.
- Exchange the CC.
- Inform your service agency.


Error description 237-1809F

Error message

1809F Axis %1: value of amplitude not in permissible range

Cause of error

The value of the amplitude of the excitation signal for the measurement of the frequency response is outside of the permissible range.

Error correction

- Inform your machine tool builder
- Check the OEM macro for Cycle 238 (Measure machine status, CfgSystemCycle->OEM_MACHSTAT_MEAS)
- Check the value for the excitation amplitude
- Recommended setting: Enter the amplitude as a factor of the rated current. A typical value is 0.3.


Error description 237-180A0

Error message

180A0 Non-released inverter software loaded

Cause of error

The inverter contains test software that has not been released.
This software may only be used for internal testing purposes.

Error correction

- Check the software version
- Generate service files
- Inform your service agency


Error description 237-180A1

Error message

180A1 "Time exceeded" trigger

Cause of error

The event that triggers the trigger did not occur in time.
The programmed feed rate was not reached.

Error correction

Reduce the programmed feed rate.


Error description 237-180A2

Error message

180A2 Axis %1: %4 is not supported by the CC controller unit

Cause of error

The configured function is not supported in combination with the controller unit being used (CC or UxC).

Error correction

- Deactivate the function
- Inform your service agency


Error description 237-180A3

Error message

180A3 Axis %1: zero crossover of the %4 speed in '%5' measurement

Cause of error

While recording the Bode plot, a zero crossover of a measured velocity was detected.
For this type of measurement, non-linear effects of friction at velocity=0 should be avoided.

Error correction

Increase the ratio of the underlying velocity to the excitation amplitude


Error description 237-180A4

Error message

180A4 CC%2: maximum computing load has risen for axis %1

Cause of error

Due to a changed or newly activated set of machine parameters, the computing load of the CC
has increased compared to the load through the initial or previous set of machine parameters.
Factors in the computing load are the parameters for the PWM frequency (CfgPowerStage > ampPwmFreq), the controller performance
(CfgAxisHardware > ctrlPerformance), and the current controller cycle time (CfgCurrentControl > iCtrlPwmType).

Error correction

- Reboot the control to initially load the changed set of parameters while booting.
- Initially load the set of machine parameters with the highest computing load (if necessary
with the attribute Axes->PhysicalAxes->(axis designation)->deactivatedAtStart = TRUE)
and only then activate the set of machine parameters appropriate for the current hardware configuration
(with less computing load).


Error description 237-180A5

Error message

180A5 Axis %1: error occurred during measurement

Cause of error

- This is an internal software error

Error correction

- Inform your service agency


Error description 237-180A6

Error message

180A6 Axis %1: waterfall diagram measurement: v_nom not constant

Cause of error

The nominal velocity v_nom is not constant while recording the waterfall chart.

Error correction

- Inform your machine manufacturer
- Check/correct the OEM macro for Cycle 238 Measure Machine Status (CfgSystemCycle > OEM_MACHSTAT_MEAS)
- Increase the lead and lag time


Error description 237-180A7

Error message

180A7 CC%2: communication error w/ EnDat3 speed encoder, error code %6

Cause of error

- An error occurred during communication with the EnDat3 encoder
- The error code describes the cause:
- 0, 1: Error in the physical layer (PHY)
- 2: CRC error of the HPF or an LPF
- 3: WD error; no response from the encoder was detected during the timeout
- Possible causes:
- Defective encoder
- Defective encoder connecting cable
- Noise on the encoder connecting cable

Error correction

- Exchange the encoder
- Check the connecting cable, and exchange it if necessary
- Exchange the CC controller unit


Error description 237-180A8

Error message

180A8 CC%2: communication error w/ EnDat3 pos. encoder, error code %6

Cause of error

- An error occurred during communication with the EnDat3 encoder
- The error code describes the cause:
- 0, 1: Error in the physical layer (PHY)
- 2: CRC error of the HPF or an LPF
- 3: WD error; no response from the encoder was detected during the timeout
- Possible causes:
- Defective encoder
- Defective encoder connecting cable
- Noise on the encoder connecting cable

Error correction

- Exchange the encoder
- Check the connecting cable, and exchange it if necessary
- Exchange the CC controller unit


Error description 237-180A9

Error message

180A9 CC %2: EnDat3 speed encoder reports error, error code %6

Cause of error

The EnDat3 encoder reports an error during cyclic communication
The error code describes the cause:
- 6: Generation of data failed or encoder system failure
- 7: Singleturn position faulty
- 8: Multiturn position faulty
- 9: Permissible ambient conditions of the encoder exceeded (e.g. temperature)
- 10: Permissible electrical operating conditions exceeded (current and/or voltage too high or too low)
- 11, 12, 13, 14: Device-specific error message 0-3 (note the encoder documentation)
- 15: Unspecified error message

Error correction

- Check the encoder
- Ensure the correct ambient conditions of the encoder
- Exchange the encoder


Error description 237-180AA

Error message

180AA CC %2: EnDat3 position encoder reports error, error code %6

Cause of error

The EnDat3 encoder reports an error during cyclic communication
The error code describes the cause:
- 6: Generation of data failed or encoder system failure
- 7: Singleturn position faulty
- 8: Multiturn position faulty
- 9: Permissible ambient conditions of the encoder exceeded (e.g. temperature)
- 10: Permissible electrical operating conditions exceeded (current and/or voltage too high or too low)
- 11, 12, 13, 14: Device-specific error message 0-3 (note the encoder documentation)
- 15: Unspecified error message

Error correction

- Check the encoder
- Ensure the correct ambient conditions of the encoder
- Exchange the encoder


Error description 237-180AB

Error message

180AB CC%2: error in cyclic com. w/ EnDat3 speed encoder, error code %6

Cause of error

The encoder reports an error during cyclic communication
The error code describes the cause:
- 4: Invalid position data were transmitted
- 5: A request code is not supported by the encoder
- 6: An error that cannot be associated was signaled

Error correction

- Check the encoder
- Check any additional queries
- Exchange the encoder
- Exchange the CC controller unit
- Inform your service agency


Error description 237-180AC

Error message

180AC CC%2: error in cyclic com. w/ EnDat3 pos. encoder, error code %6

Cause of error

The encoder reports an error during cyclic communication
The error code describes the cause:
- 4: Invalid position data were transmitted
- 5: A request code is not supported by the encoder
- 6: An error that cannot be associated was signaled

Error correction

- Check the encoder
- Check any additional queries
- Exchange the encoder
- Exchange the CC controller unit
- Inform your service agency


Error description 237-180AD

Error message

180AD CC%2: warning by EnDat3 encoder to %10; warning code: %6

Cause of error

A warning was signaled during communication with the encoder
The warning code describes the cause:
- 0: Encoder status/maintenance
- 1: Close to the limits of the permissible ambient conditions (e.g. temperature)
- 2: Close to the limits of the permissible electrical operating conditions (current/voltage)
- 3: Temperature warning threshold exceeded
- 4: Almost down to minimum battery charge
- 5-8: Encoder-specific warning 0-3
- 9: Unspecified warning from encoder
- 10: A warning that cannot be associated is being signaled
A serious encoder error could occur soon

Error correction

Measures depending on the warning code:
- 0: Servicing of the encoder is recommended
- 1, 4: Check compliance with the ambient conditions (e.g. temperature) and initiate measures
- 2: Check compliance with the electrical operating conditions (e.g. ensure the voltage supply)
- 3: Ensure compliance with the electrical operating conditions, change the battery soon
- 5-8: Initiate measures as per the encoder documentation
- 9, 10: Check the encoder; exchange the encoder; inform your service agency


Error description 237-180AE

Error message

180AE CC%2: temperature warning by EnDat3 encoder to %10

Cause of error

The encoder has detected an impending violation of the permissible ambient conditions:
Temperature exceedance

Error correction

- Ensure that the permissible ambient conditions are maintained (e.g., ensure sufficient cooling)
- Check the encoder, and exchange it if necessary
- Inform your service agency


Error description 237-180B0

Error message

180B0 CC (Log): data of an EnDat3 LowPrio transmission are invalid

Cause of error


Error description 237-180B1

Error message

180B1 Time exceeded during communication with UM 3xx at %1

Cause of error

The described UM 3xx did not react to a communication request from the CC in time.
Possible causes
- Electromagnetic noise or faulty electrical contacts of the 24V supply voltage
- Electromagnetic noise or faulty electrical contacts of the DC-link voltage
- Electromagnetic noise or faulty electrical contacts in the motor cabling
- Electromagnetic noise or faulty electrical contacts in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine and wiring for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing, and also for contamination and correct clamping
- Exchange the UM 3xx inverter
- Exchange the CC 3xx controller unit
- Generate a service file and inform your service agency


Error description 237-180B2

Error message

180B2 Error in communication with UM 3xx at %1

Cause of error

Telegrams were lost during transmission of the actual current values from the UM to the CC.
Possible causes
- Electromagnetic noise or faulty electrical contacts of the 24V supply voltage
- Electromagnetic noise or faulty electrical contacts of the DC-link voltage
- Electromagnetic noise or faulty electrical contacts in the motor cabling
- Electromagnetic noise or faulty electrical contacts in the brake cabling
- Contamination or poor optical coupling of the HFL-
- Internal system error

Error correction

- Check the machine and wiring for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing, and also for contamination and correct clamping
- Exchange the UM 3xx inverter
- Exchange the CC 3xx controller unit
- Generate a service file and inform your service agency


Error description 237-180B3

Error message

180B3 Time exceeded during communication with internal component at %1

Cause of error

The position-value converter component assigned to the connector did not react to a communication request from the processor in time.
Possible causes
- Electromagnetic noise or faulty electrical contacts of the 24V supply voltage
- Electromagnetic noise or faulty electrical contacts in the encoder cabling
- Electromagnetic noise or faulty electrical contacts in the shield connection
- Internal system error

Error correction

- Check the machine and wiring for correct shield connection and grounding
- Check the encoder cabling for correct clamping
- Exchange the affected encoder or other encoders in the same column
- so for X401 also X402, X431, or X432
- so for X403 also X404, X433, or X434
- so for X405 also X406, X435, or X436
- Exchange the CC 3xx controller unit
- Generate a service file and inform your service agency


Error description 237-180B4

Error message

180B4 Error in communication with internal component at %1

Cause of error

Communication with the position-value converter component for the described connector is impaired.
Possible causes
- Electromagnetic noise or faulty electrical contacts of the 24V supply voltage
- Electromagnetic noise or faulty electrical contacts in the encoder cabling
- Electromagnetic noise or faulty electrical contacts in the shield connection
- Internal system error

Error correction

- Check the machine and wiring for correct shield connection and grounding
- Check the encoder cabling for correct clamping
- Exchange the affected encoder or other encoders in the same column
- so for X401 also X402, X431, or X432
- so for X403 also X404, X433, or X434
- so for X405 also X406, X435, or X436
- Exchange the CC 3xx controller unit
- Generate a service file and inform your service agency


Error description 237-180B5

Error message

180B5 Too many faulty telegrams of a UM 3xx in sequence %1

Cause of error

Too many telegrams in sequence were lost during transmission of the actual current values from the UM to the CC.
Possible causes
- Electromagnetic noise or faulty electrical contacts of the 24V supply voltage
- Electromagnetic noise or faulty electrical contacts of the DC-link voltage
- Electromagnetic noise or faulty electrical contacts in the motor cabling
- Electromagnetic noise or faulty electrical contacts in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine and wiring for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing, and also for contamination and correct clamping
- Exchange the UM 3xx inverter
- Exchange the CC 3xx controller unit
- Generate a service file and inform your service agency


Error description 237-180B6

Error message

180B6 Too many faulty telegrams of a UM 3xx %1

Cause of error

Too many telegrams were lost during transmission of the actual current values from the UM to the CC during the monitoring period.
Possible causes
- Electromagnetic noise or faulty electrical contacts of the 24V supply voltage
- Electromagnetic noise or faulty electrical contacts of the DC-link voltage
- Electromagnetic noise or faulty electrical contacts in the motor cabling
- Electromagnetic noise or faulty electrical contacts in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine and wiring for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing, and also for contamination and correct clamping
- Exchange the UM 3xx inverter
- Exchange the CC 3xx controller unit
- Generate a service file and inform your service agency


Error description 237-180B7

Error message

180B7 Excessive error frequency for telegrams of UM 3xx %1

Cause of error

The frequency of faulty telegrams during transmission of the actual current values from the UM to the CC is above the limit value.
Possible causes
- Electromagnetic noise or faulty electrical contacts of the 24V supply voltage
- Electromagnetic noise or faulty electrical contacts of the DC-link voltage
- Electromagnetic noise or faulty electrical contacts in the motor cabling
- Electromagnetic noise or faulty electrical contacts in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- Check the machine and wiring for correct shield connection and grounding
- Check the power cables for correct clamping
- Check the HFL for correct routing, and also for contamination and correct clamping
- Exchange the UM 3xx inverter
- Exchange the CC 3xx controller unit
- Generate a service file and inform your service agency


Error description 237-180B8

Error message

180B8 Conspicuous telegrams of UM 3xx %1 below the reporting threshold

Cause of error

There are peculiar telegrams during transmission of the actual current values from the UM to the CC.
Possible causes
- Electromagnetic noise or faulty electrical contacts of the 24V supply voltage
- Electromagnetic noise or faulty electrical contacts of the DC-link voltage
- Electromagnetic noise or faulty electrical contacts in the motor cabling
- Electromagnetic noise or faulty electrical contacts in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- No immediate corrective action is necessary, since no error situation has occurred yet
- Possible preventive measure: check the machine for correct shield connection and grounding
- Possible preventive measure: check the power cables for correct clamping
- Possible preventive measure: check the HFL for correct routing, and also for contamination and correct clamping


Error description 237-180B9

Error message

180B9 Conspicuous telegrams of UM 3xx %1

Cause of error

There are peculiar telegrams during transmission of the actual current values from the UM to the CC.
Possible causes
- Electromagnetic noise or faulty electrical contacts of the 24V supply voltage
- Electromagnetic noise or faulty electrical contacts of the DC-link voltage
- Electromagnetic noise or faulty electrical contacts in the motor cabling
- Electromagnetic noise or faulty electrical contacts in the brake cabling
- Contamination or poor optical coupling of the HFL

Error correction

- No immediate corrective action is necessary, since no error situation has occurred yet
- Possible preventive measure: check the machine for correct shield connection and grounding
- Possible preventive measure: check the power cables for correct clamping
- Possible preventive measure: check the HFL for correct routing, and also for contamination and correct clamping


Error description 237-180BA

Error message

180BA CC%2 EnDat2.2 incremental: faulty absolute value %1

Cause of error

- Reference run was faulty
- Reversal during the reference run
- The same reference mark was traversed more than once

Error correction

- Separate the encoder from the power supply (for at least 10 seconds)
- Switch off the power supply of the machine (main power switch off and on)


Error description 237-180BB

Error message

180BB Faulty FSuC Include file CC%2 %1

Cause of error

The interface versions of internal components (SOC and FSuC) on the CC do not match.

Error correction

- Check the software version and run an update if necessary
- Inform your service agency


Error description 237-180BC

Error message

180BC Field-angle adjustment: chkPosHoldFieldAdj = 0 axis %1

Cause of error

- A field angle adjustment was started even though the parameter CfgControllerAuxil > chkPosHoldFieldAdj has the value 0
- Only for spindles is it possible to deactivate position monitoring during a field angle adjustment
- This is not permitted for axes

Error correction

- Set CfgControllerAuxil > chkPosHoldFieldAdj to a value greater than 0


Error description 237-180BD

Error message

180BD Position monitoring for field-angle adjustment %1, ES %4

Cause of error

- The maximum position deviation was exceeded during the field angle adjustment.
The additional information indicates the active emergency-stop input, if set:
0 = No emergency-stop input is set
1 = Emergency Stop A
2 = Emergency Stop A Handwheel
3 = Emergency Stop B
4 = Emergency Stop B Handwheel
5 = Emergency Stop B Functional Safety
6 = Emergency Stop B Functional Safety Handwheel
7 = Emergency Stop A Functional Safety
8 = Emergency Stop A Functional Safety Handwheel

Error correction

- Check the parameter CfgControllerAuxil > chkPosHoldFieldAdj and increase it, if necessary
- Check the external wiring, especially the emergency-stop inputs
- Check the encoder and motor data


Error description 237-180BE

Error message

180BE Monitoring of servo lag inactive %1

Cause of error

- The parameter CfgPosControl > servoLagMax2 has the value 0
- Only for spindles is it possible to deactivate servo-lag monitoring.
This is not permitted for axes.

Error correction

- Set CfgPosControl > servoLagMax2 to a value greater than 0


Error description 237-180BF

Error message

180BF Overflow of an internal communication buffer CPU0 CC%2

Cause of error

An internal buffer in the CC controller unit for buffering messages to the MC main computer overflowed.

Error correction

Inform your service agency


Error description 237-180C0

Error message

180C0 Overflow of an internal communication buffer CPU1 CC%2

Cause of error

An internal buffer in the CC controller unit for buffering messages to the MC main computer overflowed.

Error correction

Inform your service agency


Error description 237-180C1

Error message

180C1 Non-supported CC hardware CC%2 in use

Cause of error

By setting bit 31 in CfgCCAuxil/miscCtrlFunct1, a CC 61xx controller unit not supported by this software version is used intentionally.
The proper functioning of the software cannot be ensured.

Error correction

- Exchange the CC (use ID 66263x-03 or higher)
- Inform your service agency


Error description 237-180C2

Error message

180C2 CC hardware is not supported CC%2

Cause of error

The CC 61xx controller unit being used is not supported by this software version.

Error correction

- Exchange the CC (use ID 66263x-03 or higher)
- Inform your service agency


Error description 237-180C3

Error message

180C3 CC%2: error injection CC_ENCFPGA_VAR_%4 not valid for %1!

Cause of error

- An invalid or not yet supported error injection was triggered.
- The transfer parameters for the error injection are not plausible.

Error correction

Adapt the additional information of the host command hcTAMPER_WITH_ENCODER_TRANSMISSION.


Error description 237-180C4

Error message

180C4 CC%2: corrupt encoder data via CC_ENCFPGA_VAR_%4 in %1!

Cause of error

- An error injection was triggered via hcTAMPER_WITH_ENCODER_TRANSMISSION


Error description 237-180C5

Error message

180C5 MP transfer: Structure with ID %4 has size mismatch of %5

Cause of error

- Size mismatch of an MP structure on the MC and CC.
- This warning is just a reminder for R&D and has no functional meaning.


Error description 237-180C6

Error message

180C6 Axis %1: TRC cycle: feed rate not constant during measurement

Cause of error

The feed rate is not constant during measurement in the TRC cycle.

Error correction

- Increase the parameter trcCycLeadTime


Error description 237-180C7

Error message

180C7 Axis %1: incomplete parameterization of TRC cycle

Cause of error

The TRC cycle is parameterized incompletely or incorrectly.

Error correction

- Check the TRC cycle parameters in CfgTorqueRipple
- Use TNCopt for parameterization


Error description 237-180C8

Error message

180C8 Axis %1: large difference (%5%) in reference meas.: harmonic %4

Cause of error

There is a significant difference between the results of the two reference measurements in the TRC cycle.
This can have a negative effect on the decisions of the optimizer and the adjustment quality.
A possible cause could be a change in the lubrication condition, for example.

Error correction

Provide the most constant conditions possible during the cycle (such as the lubrication condition of the axes).


Error description 237-180C9

Error message

180C9 Axis %1: TRC cycle: canceled due to max. iterations of %4

Cause of error

Optimization was terminated after the maximum number of iterations.
The criterion for cancellation (trcCycAmplTol) has not been attained.

Error correction

- Remove the configured motor harmonic whose compensation was not recommended (set to active) by the TRC cycle
- Inform your service agency


Error description 237-180CA

Error message

180CA CC %2 axis %1: TRC cycles: trcCycMaxMeasDist %4 [mm/°] too small

Cause of error

The maximum permissible measuring distance is too small so that there is no period at constant feed rate or this period is too short.

Error correction

- Increase the parameter trcCycMaxMeasDist if possible.
- Reduce the feed rate (trcCycMeasFeed) or increase the jerk and acceleration to keep the distance needed for acceleration and deceleration small.
- Reduce the parameter trcCycLeadTime


Error description 237-180CB

Error message

180CB Axis %1: cycle had to be canceled

Cause of error

The feed-rate override entered is too low.
NC stop or drive off during cycle run.
Please note any further pending messages.

Error correction

Restart the cycle


Error description 237-18500

Error message

18500 SKERN-CC%2: encoder error CRC X%4

Cause of error

- Checksum error for the encoder data

Error correction

- Reboot the control
- Exchange the controller unit (CC or UEC) if necessary
- Inform your service agency


Error description 237-18501

Error message

18501 SKERN-CC%2: encoder error BlockID X%4

Cause of error

- Block ID error for the encoder data

Error correction

- Reboot the control
- Exchange the controller unit (CC or UEC) if necessary
- Inform your service agency


Error description 237-18502

Error message

18502 SKERN-CC%2: encoder error amplitude too small X%4

Cause of error

- Amplitude of encoder is too low

Error correction

- Check power supply of the encoder
- Check encoder cabling
- Replace encoder
- Inform your service agency


Error description 237-18503

Error message

18503 SKERN-CC%2: encoder error amplitude too large X%4

Cause of error

- Amplitude of encoder is too high

Error correction

- Check encoder cabling
- Replace encoder if necessary
- Inform your service agency


Error description 237-18504

Error message

18504 SKERN-CC%2: encoder error frequency incorrect X%4

Cause of error

- Frequency error in the encoder signals

Error correction

- Check encoder cabling including the shielding
- Replace encoder if necessary
- Inform your service agency


Error description 237-18505

Error message

18505 SKERN-CC%2: encoder error latch counter not incremented X%4

Cause of error

- Faulty latch counter in the encoder data
- No new encoder data received

Error correction

- Reboot the control
- Exchange the controller unit (CC or UEC) or encoder (only if EnDat) if necessary
- Check the encoder connection and cabling
- Inform your service agency


Error description 237-18506

Error message

18506 SKERN-CC%2: encoder error pin ID X%4

Cause of error

- PIN ID in the encoder data incorrect

Error correction

- Exchange the controller unit (CC or UEC) if necessary
- Inform your service agency


Error description 237-18507

Error message

18507 SKERN-CC%2: encoder error EnDat22 F1 bit set X%4

Cause of error

- Error bit F1 set in the EnDat22 encoder

Error correction

- Pay attention to the subsequent alarms
- Check/replace encoder cabling
- Replace encoder
- Inform your service agency


Error description 237-18508

Error message

18508 SKERN-CC%2: encoder error EnDat22 F2 bit set X%4

Cause of error

- Error bit F2 set in the EnDat22 encoder

Error correction

- Pay attention to the subsequent alarms
- Check/replace encoder cabling
- Replace encoder
- Inform your service agency


Error description 237-18509

Error message

18509 SKERN-CC%2: encoder error EnDat22 CRC X%4

Cause of error

- Checksum error for the EnDat22 encoder data

Error correction

- Check/replace encoder cabling
- Replace encoder
- Inform your service agency


Error description 237-1850A

Error message

1850A SKERN-CC%2: encoder error block number X%4

Cause of error

The block number in the encoder data is incorrect.

Error correction

- Exchange the controller unit (CC or UEC) if necessary
- Inform your service agency


Error description 237-18510

Error message

18510 SKERN-CC%2: encoder error invalid overflow value X%4

Cause of error

- Invalid overflow value for the encoder data

Error correction

- Inform your service agency


Error description 237-18511

Error message

18511 SKERN-CC%2: encoder error: group error in the EnDat master X%4

Cause of error

There is an error with the encoder (EnDat master).

Error correction

Inform your service agency


Error description 237-18520

Error message

18520 SKERN-CC%2: CRC error in cyclic inverter communication %1

Cause of error

- CRC error in cyclic FS communication with the inverter

Error correction

- Reboot the control
- Inform your service agency


Error description 237-18521

Error message

18521 SKERN-CC%2: counter error in cyclic inverter communication %1

Cause of error

- Faulty packet counter in cyclic FS communication with the inverter

Error correction

- Reboot the control
- Inform your service agency


Error description 237-18522

Error message

18522 SKERN-CC%2: checksum faulty %1

Cause of error

- Checksum error of the UM-DriveID in cyclic FS communication with the inverter

Error correction

- Reboot the control
- Inform your service agency


Error description 237-18523

Error message

18523 UM (FS.B): CRC error during cyclic UM communication CC%2 %1

Cause of error

- CRC error in cyclic FS communication with the inverter

Error correction

- Reboot the control
- Inform your service agency


Error description 237-18524

Error message

18524 UM (FS.B): counter error during cyclic UM communication CC%2 %1

Cause of error

- Faulty packet counter in cyclic FS communication with the inverter

Error correction

- Reboot the control
- Inform your service agency


Error description 237-18525

Error message

18525 UM (FS.B): checksum error CC%2 %1

Cause of error

- Checksum error of the UM-DriveID in cyclic FS communication with the inverter

Error correction

- Reboot the control
- Inform your service agency


Error description 237-18530

Error message

18530 SKERN-CC%2: axis state during SMP change not STO %1

Cause of error

- The axis was not in STO when one of the following parameters was changed:
hsciCcIndex, inverterInterface, motorConnector

Error correction

- Switch the affected drive off or put it in STO before changing the parameter(s)
- Check the PLC/SPLC program, and adapt it if necessary
- Inform your service agency


Error description 237-18531

Error message

18531 SKERN-CC%2: watchdog error SKERN

Cause of error

- Internal software error (watchdog low priority cycle)

Error correction

- Inform your service agency


Error description 237-18540

Error message

18540 SKERN-CC%2: Error during test of signal amplitude X%4

Cause of error

An encoder with incremental signals is connected to the indicated connection. An error occurred with this encoder while testing the signal amplitude:
- The dynamic sampling of an excessively high signal amplitude could not be completed successfully
- The dynamic sampling of an excessively low signal amplitude could not be completed successfully

Error correction

- Check connections and cable of the encoder
- Replace encoder or cable
- Inform your service agency


Error description 237-18541

Error message

18541 EnDat encoder at X%4: Forced dynamic sampling failed

Cause of error

An encoder with EnDat interface is connected to the indicated connection. An error occurred with this encoder during forced dynamic sampling. Possible causes:
- Encoder not connected correctly
- Encoder defective

Error correction

- Check connections and cable of the encoder
- Replace encoder or cable
- Inform your service agency


Error description 237-18542

Error message

18542 SKERN-CC%2: single-event-upset error (SEU) was determined

Cause of error

- Internal software error
- Possible sporadic error due to EMC irradiation

Error correction

- Restart the control
- Check the shielding or shield connection of the devices
- Shield or remove possible EMC interferences
- Inform your service agency


Error description 237-18544

Error message

18544 SKERN-CC%2: Inverter SS0 request axis %1

Cause of error

- The inverter requests an SS0 stop function through the cyclic UM(FS.B) communication

Error correction

- Note any further messages from the inverter
- Reboot the control


Error description 237-18545

Error message

18545 SKERN-CC%2: Inverter SS1F request axis %1

Cause of error

- The inverter requests an SS1F stop function through the cyclic UM(FS.B) communication

Error correction

- Note any further messages from the inverter
- Reboot the control


Error description 237-18546

Error message

18546 SKERN-CC%2: Inverter watchdog error FSuC axis %1

Cause of error

- FS.B of the inverter reports a watchdog error FS.A (WDF.A)
- FS.A of the inverter is no longer ready

Error correction

- Reboot the control
- Inform your service agency
- Exchange the inverter, if necessary


Error description 237-18547

Error message

18547 SKERN-CC%2: Inverter FS.A supply voltage faulty axis %1

Cause of error

- An internal supply voltage is too high or too low

Error correction

- Note any further messages from the inverter
- Check the supply voltage of the inverter (jumper plug X76)
- Reboot the control
- Inform your service agency
- Exchange the inverter, if necessary


Error description 237-18548

Error message

18548 SKERN-CC%2: Inverter requests an SS1 reaction axis %1

Cause of error

- The inverter requests an SS1 stop reaction through the cyclic UM(FS.B) communication

Error correction

- Note any further messages from the inverter


Error description 237-18549

Error message

18549 SKERN-CC%2: Inverter requests an SS2 reaction axis %1

Cause of error

- The inverter requests an SS2 stop reaction through the cyclic UM(FS.B) communication

Error correction

- Note any further messages from the inverter


Error description 237-18550

Error message

18550 Test command was received in released software!

Cause of error

Error injection was demanded for a release software. This is not permissible!

Error correction

- Use autotest software!
- Inform your service agency


Error description 237-18552

Error message

18552 SKERN-CC%2: Stuck-At error on the temperature channel

Cause of error

- The A/D converter channel (on the controller unit) for measuring the board temperature is defective
- The firmware of the controller unit has detected a fault

Error correction

- Exchange the controller unit (CC or UEC) if necessary
- Inform your service agency


Error description 237-18553

Error message

18553 SKERN-CC%2: Stuck-at error in voltage channel %4

Cause of error

- Controller unit is defective (ADC channel).
- Driver problem of the firmware of the controller unit (CC, UEC).

Error correction

- Inform your service agency.
- Exchange the controller unit (CC, UEC), if necessary.


Error description 237-18554

Error message

18554 UM (FS.B): CC%2 SS0 request %1

Cause of error

- The inverter requests an SS0 stop function through the cyclic UM(FS.B) communication

Error correction

- Note any further messages from the inverter
- Reboot the control


Error description 237-18555

Error message

18555 UM (FS-B): UM requests SS1F CC%2 %1

Cause of error

- The inverter requests an SS1F stop function through the cyclic UM(FS.B) communication

Error correction

- Note any further messages from the inverter
- Reboot the control


Error description 237-18556

Error message

18556 UM (FS.B): watchdog error UM-FS.A CC%2 %1

Cause of error

- FS.B of the inverter reports a watchdog error FS.A (WDF.A)
- FS.A of the inverter is no longer ready

Error correction

- Reboot the control
- Inform your service agency
- Exchange the inverter, if necessary


Error description 237-18557

Error message

18557 UM (FS.B): UM-FS.A improper power supply CC%2 %1

Cause of error

- An internal supply voltage is too high or too low

Error correction

- Note any further messages from the inverter
- Check the supply voltage of the inverter (jumper plug X76)
- Reboot the control
- Inform your service agency
- Exchange the inverter, if necessary


Error description 237-18558

Error message

18558 UM (FS.B): UM requests SS1 reaction CC%2 %1

Cause of error

- The inverter requests an SS1 stop reaction through the cyclic UM(FS.B) communication

Error correction

- Note any further messages from the inverter


Error description 237-18559

Error message

18559 UM (FS.B): UM requests SS2 reaction CC%2 %1

Cause of error

- The inverter requests an SS2 stop reaction through the cyclic UM(FS.B) communication

Error correction

- Note any further messages from the inverter


Error description 237-1855A

Error message

1855A SKERN-CC%2: EnDat forced dynamic sampling not performed

Cause of error

Checking of the Endat22 forced dynamic sampling at the end of the first self-test failed.
No successful EnDat forced dynamic sampling performed in the last 168 hours was detected.

Error correction

- Check the encoder for a defect or fault
- Exchange the encoder


Error description 237-1855B

Error message

1855B SKERN-CC%2: interval violation upon EnDat forced dynamic sampling

Cause of error

- The minimum time interval (4 hours) until the next EnDat forced dynamic sampling was violated (AddInfo[4] = 2)
- The maximum time interval (168 hours) until the next EnDat forced dynamic sampling was violated (AddInfo[4] = 1)

Error correction

- Restart the control
- If the error recurs, inform your service agency


Error description 237-1855C

Error message

1855C SKERN-CC%2: errors during EnDat forced dynamic sampling

Cause of error

The detected dynamic error bit does not match the forced dynamic sampling error.

Error correction

- Restart the control
- - Check the encoder for a defect or fault
- Exchange the encoder
- If the error recurs after exchanging the encoder, inform your service agency


Error description 237-1855D

Error message

1855D SKERN-CC%2: error while testing the test position, axis %1

Cause of error

A condition for testing the test position was violated; possible causes:
- Internal position does not match the parameterized testing position
- Fatal error state is active
- Axis not referenced
- Axis in motion
- Permissive button not pressed

Error correction

- Check and correct the possible causes of the problems
- Check the test position for plausibility
- If all causes can be excluded, inform your service agency


Error description 237-1855E

Error message

1855E CC%2: Host command hcS_SWITCH_FS_CONFIG (0x22D) not permitted!

Cause of error

- The host command was received while in an implausible state.
- The internal state is %5, and the state %4 was expected.

Error correction

- Check the firmware for MC-CC compatibility.
- Inform your service agency.


Error description 237-1855F

Error message

1855F CC%2: Timeout error in host command hcS_SWITCH_FS_CONFIG (0x22D)!

Cause of error

- The host command was not received within a permitted timeout time.
- The reconfiguration status is %4, but the configured timeout is %5 seconds.

Error correction

- Check the firmware for MC-CC compatibility.
- Inform your service agency.


Error description 237-18800

Error message

18800 SKERN-CC%2: encoder warning amplitude too small X%4

Cause of error

- Amplitude of encoder is too low

Error correction

- Check power supply of the encoder
- Check encoder cabling
- Replace encoder
- Inform your service agency


Error description 237-18801

Error message

18801 Autotest manipulation via hcS_AUTO_TEST_SKERN_CC is active!

Cause of error

- An error injection was triggered
- No officially released software version is installed

Error correction

- Check the software version of the control
- Install a released software version
- Inform your service agency


Error description 237-18802

Error message

18802 SKERN-CC: Test software without safety approval is loaded

Cause of error

The CC contains a test software with safety approval
- This software has neither been tested nor released
- No checksum will be calculated

Error correction

- After acknowledging the error message you can use this software only for tests
- Check the software version
- Create service files
- Contact your service agency


Error description 237-18803

Error message

18803 CC%2 synchronization of SPLC run-time system lost

Cause of error

The mechanism for the synchronization of the SPLC run-time system routine on all CC controller units returned an error.

Error correction

- Generate a service file
- Contact your service agency
- Restart the control


Error description 237-18804

Error message

18804 SKERN CC%2: FS configuration error connector number %1

Cause of error

The type of EnDat encoder being used is not supported.
Only linear or rotatory EnDat encoders are supported for applications with functional safety (FS).
Either an EIB or an unknown EnDat encoder was detected for the encoder parameterized under CfgAxParSafety->encoderForSafety.

Error correction

Check the encoder configuration under CfgAxParSafety->encoderForSafety


Error description 237-18805

Error message

18805 SKERN-CC%2: faulty EnDat safety property %1

Cause of error

Faulty EnDat safety bits were detected.
EnDat safety bits have the same state, but should be inverted.
Possible causes:
- Faulty memory of the EnDat encoder
- Error in transmission of the memory address to the CC controller unit

Error correction

- Restart the control
- Exchange the encoder if the error recurs
- If the error recurs after exchanging, inform your service agency


Error description 237-18806

Error message

18806 SKERN-CC%2: check for completeness of self-test deactivated

Cause of error

The completeness check at the end of the self-test was deactivated by manipulation.
This is allowed only within a HEIDENHAIN-internal test.
An error reaction will be triggered every four hours.


Error description 237-18807

Error message

18807 SKERN-CC%2: timeout of inactive self-test completeness check

Cause of error

The completeness check at the end of the self-test was deactivated by manipulation.
This is allowed only within a HEIDENHAIN-internal test.
An error reaction will be triggered every four hours.


Error description 237-19000

Error message

19000 DQ-LT %1: Overcurrent ID=%4; fault value=%5

Cause of error

The power module of the encoder detected overcurrent.
- Closed-loop control is incorrectly parameterized
- Motor has a short circuit or ground fault
- Volts-per-hertz mode: Run-up ramp is set too small
- U/f mode: Rated current of the motor is significantly greater than that of the motor module
- Incoming power: High discharging and recharging currents in the event of line power failure
- Incoming power: High recharging currents in the event of motor overload and failure of the DC-link voltage
- Incoming power: Short circuit currents during switch-on due to missing commutating reactor.
- Power lines are not correctly connected.
- The power lines exceed the maximum permissible length.
- Power module defective.
Fault value (interpret bit-wise):
Bit 0: Phase U.
Bit 1: Phase V.
Bit 2: Phase W.

Error correction

- Check the motor data; if required, repeat initial servicing
- Check the motor circuit configuration (wye-delta).
- Volts-per-hertz mode: Increase the run-up ramp
- U/f mode: Check the assignment of the rated currents of the motor and motor modules
- Incoming power: Check the line power quality
- Incoming power: Decrease the motor load
- Incoming power: Correct connection of the line commutating reactor
- Check the power cable connections.
- Check the power cables for short-circuit or ground fault.
- Check the length of the power cable connections.
- Exchange the power module


Error description 237-19001

Error message

19001 DQ-MotEnc %1: ref. mark distance ID=%4; fault value=%5

Cause of error

The measured reference-mark distance does not correspond to the parameterized reference-mark distance.
For distance-coded encoders, the reference-mark distance is determined from detected pairs of reference marks.
This means that if a reference mark is missing, depending on the pair generation, this cannot result in a fault and also has no effect in the system.
Fault value (interpret decimal value):
Last measured reference-mark distance in increments (4 increments = 1 encoder pulse).
The algebraic sign designates the direction of motion when detecting the reference-mark distance.

Error correction

- Check that the encoder cables are routed in compliance with EMC.
- Check the plug connections.
- Check the encoder type (encoder with equidistant reference marks).
- Replace the encoder or encoder cable.


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cut-out channel test was autonomously aborted by an error during the test run.
The control does not finish a test step correctly.
The control does not perform a certain test.

Error correction

Check whether a previous system error of the control led to the cancellation of the test section.
Check the software version.
Inform your service agency.


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cutout channel test was ended autonomously because of an error.
An error occurs in the pp_GenFB_NCC signal (PL system module).
The control does not finish a test step correctly

Error correction

- Check whether a previous system error of the control led to the cancellation of a test section
- Check the wiring of the signal pp_GenFB_NCC
- Inform your service agency


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cutout channel test was ended autonomously because of an error.
An error occurs in the –ES.B signal (PL system module).
The control does not finish a test step correctly.

Error correction

Check whether a previous system error of the control led to the cancellation of a test section
Check the wiring of the signal –ES.B.
Inform your service agency


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cutout channel test was ended autonomously because of an error.
An error occurs in the CVO signal (PL system module).
The control does not finish a test step correctly.

Error correction

Check whether a previous system error of the NC led to the cancellation of a test section
Check the wiring of the signal CVO
Inform your service agency


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cutout channel test was ended autonomously because of an error.
An error occurs in the RDY.PS (X69-17a) signal of the supply module.
The control does not finish a test step correctly.

Error correction

Check whether a previous system error of the NC led to the cancellation of a test section
Check the wiring of the signal RDY.PS (X69-17a)
Inform your service agency


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cutout channel test was ended autonomously because of an error.
An error occurs in the pp_GenMKG signal (SMOP).
The control does not finish a test step correctly.

Error correction

Check whether a previous system error of the NC led to the cancellation of a test section
Check the wiring of the signal pp_GenMKG
Inform your service agency


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cutout channel test was ended autonomously because of an error.
An error occurs in the pp_AxGrpStateReq == S_STATE_AUTO signal.
The control does not finish a test step correctly.

Error correction

Check whether a previous system error of the NC led to the cancellation of a test section
Check the wiring of the guard door/signal pp_AxGrpStateReq == S_STATE_AUTO
Inform your service agency


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cutout channel test was ended autonomously because of an error.
An error occurs in the pp_GenFB_NCC signal (PL system module).
The control does not finish a test step correctly.

Error correction

-Check whether a previous system error of the control led to the cancellation of a test section
Check the wiring of the signal pp_GenFB_NCC
- Inform your service agency


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cutout channel test was ended autonomously because of an error during the test run or in the hardware/wiring.
The control does not finish a test step correctly.
The control does not perform a certain test.

Error correction

- Check whether a previous system error of the control led to the cancellation of a test section
- Check the hardware/wiring (PWM ribbon cable) and exchange it if necessary
- Inform your service agency


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cutout channel test was ended autonomously because of an error during the test run or in the hardware.
The control does not finish a test step correctly.
The control does not perform a certain test.

Error correction

- Check whether a previous system error of the control led to the cancellation of a test section
- Check the hardware and exchange it if necessary
- Inform your service agency


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cutout channel test was ended autonomously because of an error during the test run or in the hardware.
The control does not finish a test step correctly.
The control does not perform a certain test.

Error correction

- Check whether a previous system error of the control led to the cancellation of a test section
- Check the hardware/wiring for whether SPL/SMOP A outputs are permanently at a High level
- Inform your service agency


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

The cutout channel test was ended autonomously because of an error during the test run or in the hardware.
The control does not finish a test step correctly.
The control does not perform a certain test.

Error correction

- Check whether a previous system error of the control led to the cancellation of a test section
- Check the hardware/wiring for whether SPL/SMOP B outputs are permanently at a High level
- Inform your service agency


Error description 237-1F300

Error message

1F300 CC%2 Cancelation of the cutout channel test %4

Cause of error

An error occurred during the test run, or another error occurred; this led to the drive being switched off and cancellation of the brake test.
The control does not finish a test step correctly.
The control does not perform a certain test.

Error correction

- Check whether a previous system error of the control led to the cancellation of a test section
- Check the software version
- Inform your service agency


Error description 237-3001

Error message

13001 UM3: schwerwiegender Fehler (Stopp-Reaktion SS1) %1

Cause of error

Für weitere Informationen nachfolgende Alarmmeldungen (13xxx) beachten!


Error description 237-3002

Error message

13002 UM3: Interne Überwachung (Stopp-Reaktion SS2) %1

Cause of error

Für weitere Informationen nachfolgende Alarmmeldungen (13xxx) beachten!


Error description 237-3007

Error message

13007 UM3: VarioLink-Kommunikationsfehler %1

Cause of error

- Umrichter meldet Fehler in der VarioLink-Kommunikation

Error correction

- Steuerung neu starten
- Variolink-Verbindung überprüfen


Error description 237-3010

Error message

13010 UM3: Umrichter meldet Fehler in der asynchronen Kommunikation %1

Cause of error

- Umrichter meldet Fehler in der asynchronen Kommunikation mit der CC

Error correction

- Steuerung neu starten
- Kundendienst benachrichtigen


Error description 237-3011

Error message

13011 UM3: CC meldet Fehler in der asynchronen Kommunikation %1

Cause of error

- CC meldet Fehler in der asynchronen Kommunikation mit dem Umrichter

Error correction

- Steuerung neu starten
- Kundendienst benachrichtigen


Error description 237-3018

Error message

13018 UM3: CC antwortet nicht auf Message %4 vom Umrichter %1

Cause of error

- CC antwortet innerhalb einer vorgegebenen Zeit nicht auf die angegebene Message vom Umrichter
(Message Code ist dezimal angezeigt, aber hexadezimal zu interpretieren)

Error correction

- Steuerung neu starten
- Kundendienst benachrichtigen


Error description 237-3019

Error message

13019 UM3: Umrichter antwortet nicht auf Kommando %4 von der CC %1

Cause of error

- Der Umrichter antwortet innerhalb einer vorgegebenen Zeit nicht auf das angegebene Kommando von der CC
(Kommando Code ist dezimal angezeigt, aber hexadezimal zu interpretieren)

Error correction

- Steuerung neu starten
- Kundendienst benachrichtigen


Error description 237-3801

Error message

13801 UM-FSSW:Telegrammzähler Fehler FS-Kommunikation %1 Soll:%4 Ist:%5

Cause of error


Error description 237-3802

Error message

13802 UM-FSSW: UM-DriveID Fehler FS-Kommunikation %1 Soll:%4 Ist:%5

Cause of error


Error description 237-3804

Error message

13804 UM-SOC: Topology inspection of the UM parameters failed %1

Cause of error


Error description 237-3805

Error message

13805 UM-SOC: FS configuration data were falsified %1 %4 %5

Cause of error


Error description 237-3806

Error message

13806 UM-SOC: UM-DriveID from UM-SOC and UM-FSuC are unequal %1 %4 %5

Cause of error


Error description 237-3820

Error message

13820 UM-SOC: Spannungsüberwachung 3,3V-FSuC überschritten

Cause of error


Error description 237-3891

Error message

13891 UM-SOC: Fehlerhafte Include-Datei (erhaltene Version:%4 - erwartete Version:%5)

Cause of error

- Software von Reglereinheit und Umrichter(FS) sind nicht mit der gleichen Include-Datei compiliert worden.

Error correction

- Softwareversion prüfen und gegebenenfalls neu laden
- Kundendienst benachrichtigen


Error description 237-8800

Error message

18800 SKERN-CC: Geberwarnung Amplitude zu niedrig X%4

Cause of error


Error description 238-1000

Error message

1000 UVR%2 overcurrent

Cause of error

The power supply unit hat detected an exceedance of the permissible current on its supply connection

Error correction

Inform your service agency


Error description 238-1001

Error message

1001 UVR%2 phase current too high

Cause of error

The line current consumed by the power supply unit is close to the maximum permissible value

Error correction

- Inspect the design of the inverter system
- Reduce the power consumption of the inverter system
- Inform your service agency


Error description 238-1002

Error message

1002 UVR%2 DC-link voltage too high

Cause of error

The power supply unit has detected that the DC-link voltage is too high

Error correction

Inform your service agency


Error description 238-1003

Error message

1003 UVR%2 error in power supply

Cause of error

The supply unit hat detected a faulty power supply network.

Error correction

- Check the supply connection, and ensure correct supply connection
- Inform your service agency


Error description 238-1004

Error message

1004 UVR%2 DC-link voltage too low

Cause of error

The power supply unit is reporting that the DC-link voltage is too low.

Error correction

- Check the supply connection
- Check the parameters and stability of the supply network
- Inform your service agency


Error description 238-1006

Error message

1006 UVR%2 leakage current too high

Cause of error

The leakage current monitor of the power supply unit has detected an impermissibly high value.

Error correction

- Check the wiring of the power modules and motors
- Check the motor lines and DC link for sufficient insulation resistance to ground
- Inform your service agency


Error description 238-1007

Error message

1007 UVR%2 temperature too high at heat sink

Cause of error

The temperature of the heat sink in the UVR exceeds a critical value.

Error correction

Reduce the load


Error description 238-1008

Error message

1008 UVR%2 error in control of IGBT

Cause of error

The supply unit has detected an error with the IGBT drive circuit

Error correction

Inform your service agency


Error description 238-100A

Error message

100A UVR%2 temperature at heat sink critically high

Cause of error

The heat-sink temperature in the UVR supply unit is reaching critical values.

Error correction

- Reduce the power drawn from the DC link
- Check the temperature or climate control unit of the electrical cabinet
- Check for ventilation clearances around the power supply unit
- Inform your service agency


Error description 238-100B

Error message

100B UVR%2 error in DC-link charge

Cause of error

The power supply unit has detected a fault during charging of the DC link.

Error correction

- Check the DC-link bus mounting or the DC-link wiring for a short circuit
- Inform your service agency.


Error description 238-100C

Error message

100C UVR%2 service mode activated

Cause of error

The service mode of the UVR has been activated. Control of the UVR now occurs over the service interface.

Error correction

End the service mode at the service interface.


Error description 238-100D

Error message

100D UVR%2 faulty PWM control

Cause of error

The PWM drive circuit monitor is reporting an error

Error correction

Inform your service agency


Error description 238-100E

Error message

100E UVR%2 hardware detection faulty

Cause of error

The hardware detection of the power supply unit (so-called HIK) is faulty

Error correction

Inform your service agency


Error description 238-100F

Error message

100F UVR%2 configuration error

Cause of error

The configuration of the UVR power supply unit is faulty.

Error correction

- Check the configuration of the power supply unit, and correct it as necessary (CfgSupplyModule3xx)
- Inform your service agency


Error description 238-1010

Error message

1010 UVR%2 low voltage faulty

Cause of error

The supply voltage monitor in the supply unit is reporting an error

Error correction

Inform your service agency


Error description 238-1011

Error message

1011 UVR%2 failure of fan for power supply unit

Cause of error

The UVR power supply unit has detected a fault in the supply unit fan.

Error correction

- Check the supply unit fan for whether it is possibly blocked by objects or contamination
- Inform your service agency


Error description 238-1012

Error message

1012 UVR%2 software error

Cause of error

Internal fault of the power supply unit

Error correction

Inform your service agency


Error description 238-1013

Error message

1013 UVR%2 error during self-test

Cause of error

A fault has arisen in the power supply unit during the internal self-test.

Error correction

- Check the wiring of the supply unit
- Inform your service agency


Error description 238-1014

Error message

1014 UVR%2 control error

Cause of error

A fault has arisen in the regulator in the power supply unit

Error correction

Inform your service agency


Error description 238-1015

Error message

1015 UVR%2 overload in the +24V of the integrated power supply unit

Cause of error

The current consumption of the 24 V consumers on the integrated power supply unit of the UVR exceeds the maximum permissible value.

Error correction

- Check the wiring of the +24 V (X76, X90) of the power supply unit integrated into the UVR
- Check consumers on +24 V, and reduce as needed
- Check the planning of the machine according to the technical manual of your inverter system
- Check the configuration of CfgSupplyModule3xx/MP_ps24VMaxLoadCurr
- Inform your service agency


Error description 238-1016

Error message

1016 UVR%2 CRC error during HSCI transmission

Cause of error

A checksum error was detected during data transmission over HSCI.

Error correction

- Check the HSCI connections and HSCI cables
- Inform your service agency


Error description 238-1017

Error message

1017 UVR %2 maximum permissible DC-link capacitance exceeded

Cause of error

The UVR power supply unit has detected an impermissibly high DC-link capacitance.

Error correction

- Check the design of the inverter system
- Reduce the number of modules connected to the DC-link (UM, CMH)
- Inform your service agency


Error description 238-1018

Error message

1018 UVR%2 processor temperature reaching critical values

Cause of error

The processor temperature in the UVR is reaching critical values.

Error correction

- Check the temperature in the electrical cabinet
- Check the climate control unit for proper functioning
- Inform your service agency


Error description 238-1019

Error message

1019 UVR%2 maximum temperature of processor exceeded

Cause of error

The maximum temperature of the processor in the supply unit has been exceeded.

Error correction

- Check the temperature in the electrical cabinet
- Check the climate control unit for proper functioning
- Reduce the power of the inverter system
- Inform your service agency


Error description 238-101A

Error message

101A UVR%2 synchronization with line power supply failed

Cause of error

The synchronization between the supply unit and the supply network was not successful.

Error correction

- Check for a faulty connection of the main supply conductors
- Check SITOR fuses for the inverter system
- Check the power supply network
- Inform your service agency


Error description 238-101B

Error message

101B UVR%2 value of DC-link center voltage too high

Cause of error

The UVR power supply unit has detected that the amount of the DC-link mean voltage is reaching impermissibly high values.

Error correction

- Check the supply voltages of the UVR (line voltage).
- Ensure that operation occurs on a TN network. Operation on TT or IT networks is not permitted. Please refer to the technical manual of your inverter system.
- Inform your service agency.


Error description 238-101C

Error message

101C UVR%2 faulty measurement of voltage

Cause of error

The supply unit is reporting an error in the DC-link voltage measurement

Error correction

Inform your service agency


Error description 238-101D

Error message

101D UVR%2 configured DC-link voltage too low

Cause of error

The DC-link voltage configured in MP_dcLinkVoltage is too small.
The configured DC-link voltage must be greater than the rectifier value of the live line voltage. If a power supply unit is operated, for example, with a line voltage of 3AC 480 V,
the machine manufacturer must increase the DC-link voltage to be generated to DC 720 V by means of MP_dcLinkVoltage.

Error correction

- Check the entry in the parameter CfgSupplyModule3xx/MP_dcLinkVoltage and adjust it if necessary.
- Inform your service agency.


Error description 238-101E

Error message

101E UVR%2 temperature sensor is supplying faulty data

Cause of error

The temperature sensor in the supply unit is defective or is returning faulty data.

Error correction

- Inform your service agency


Error description 238-101F

Error message

101F UVR%2 wrong or no KDR connected

Cause of error

The inductance of the commutating reactor was determined to be too low.
Perhaps no commutating reactor is connected, or the connection is faulty.

Error correction

- Check whether the commutating reactor is connected correctly
- Check the inductance of the commutating reactor
- Inform your service agency


Error description 238-1021

Error message

1021 UVR%2 DC-link voltage too low

Cause of error

The power supply unit reports that the DC-link voltage is too low.

Error correction

- Check the power connection
- Inform your service agency


Error description 238-1022

Error message

1022 UVR%2 DC-link voltage low: charging circuit activated

Cause of error

The charging circuit of the power supply unit was activated because the DC-link voltage was too low.

Error correction

- Check the power connection
- Inform your service agency


Error description 239-0001

Error message

1 CC-FSUC: internal error CC%2 %1

Cause of error

Internal software error (unexpected program sequence)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0002

Error message

2 MC-FSUC: internal error

Cause of error

Internal software error (unexpected program sequence)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0003

Error message

3 UM-FSUC: internal error CC%2 %1 %10

Cause of error

Internal software error (unexpected program sequence)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0004

Error message

4 CC-FSUC: voltage error CC%2 %1

Cause of error

Voltage monitoring reports an error.

Error correction

- Check the voltage supply of the affected units ("24 V" status LED on the unit)
- Inform your service agency


Error description 239-0005

Error message

5 MC-FSUC: voltage error

Cause of error

Voltage monitoring reports an error.

Error correction

- Check the voltage supply of the affected units ("24 V" status LED on the unit)
- Inform your service agency


Error description 239-0006

Error message

6 UM-FSUC: voltage error CC%2 %1 %10

Cause of error

Voltage monitoring reports an error.

Error correction

- Check the voltage supply of the affected units ("24 V" status LED on the unit)
- Inform your service agency


Error description 239-0007

Error message

7 CC-FSUC: temperature error CC%2 %1 (temperature: %6,%7°C)

Cause of error

Temperature monitoring reports an error.

Error correction

- Check the temperature in the electrical cabinet
- Inform your service agency


Error description 239-0008

Error message

8 MC-FSUC: temperature error (temperature: %6,%7°C)

Cause of error

Temperature monitoring reports an error.

Error correction

- Check the temperature in the electrical cabinet
- Inform your service agency


Error description 239-000A

Error message

A CC-FSUC: parameterization failed CC%2 %1

Cause of error

The FS microcontroller received invalid parameter data.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-000C

Error message

C UM-FSUC: FS parameters inconsistent CC%2 %1 %10

Cause of error

The FS microcontroller received inconsistent parameter data.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-000D

Error message

D CC-FSUC: cyclic communication failed CC%2 %1

Cause of error

Cyclic communication between the MC and CC FS microcontroller failed.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-000F

Error message

F UM-FSUC: cyclic communication failed CC%2 %1 %10

Cause of error

Cyclic communication between the MC and UM FS microcontroller failed.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0010

Error message

10 CC-FSUC: software inconsistent CC%2 %1

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0011

Error message

11 MC-FSUC: software inconsistent

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0012

Error message

12 UM-FSUC: software inconsistent CC%2 %1 %10

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0013

Error message

13 CC-FSUC: stack error CC%2 %1

Cause of error

Internal software error (stack memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0014

Error message

14 MC-FSUC: stack error

Cause of error

Internal software error (stack memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0015

Error message

15 UM-FSUC: stack error CC%2 %1 %10

Cause of error

Internal software error (stack memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0016

Error message

16 CC-FSUC: internal software error CC%2 %1

Cause of error

Internal software error (Single Event Upset)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0017

Error message

17 MC-FSUC: internal software error

Cause of error

Internal software error (Single Event Upset)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0018

Error message

18 UM-FSUC: internal software error CC%2 %1 %10

Cause of error

Internal software error (Single Event Upset)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0019

Error message

19 CC-FSUC: RAM error CC%2 %1

Cause of error

Internal software error (RAM memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-001A

Error message

1A MC-FSUC: RAM error

Cause of error

Internal software error (RAM memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-001B

Error message

1B UM-FSUC: RAM error CC%2 %1 %10

Cause of error

Internal software error (RAM memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-001C

Error message

1C CC-FSUC: voltage monitoring impaired CC%2 %1

Cause of error

The FS microcontroller reports defective monitoring of the voltage.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-001D

Error message

1D MC-FSUC: voltage monitoring impaired

Cause of error

The FS microcontroller reports defective monitoring of the voltage.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-001E

Error message

1E UM-FSUC: voltage monitoring impaired CC%2 %1 %10

Cause of error

The FS microcontroller reports defective monitoring of the voltage.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-001F

Error message

1F CC-FSUC: initial software consistency check CC%2 %1

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0020

Error message

20 MC-FSUC: initial software consistency check

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0021

Error message

21 UM-FSUC: initial software consistency check CC%2 %1 %10

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0022

Error message

22 CC-FSUC: cyclic communication overloaded CC%2 %1

Cause of error

The FS microcontroller has received too many cyclic telegrams.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0024

Error message

24 UM-FSUC: cyclic communication overloaded CC%2 %1 %10

Cause of error

The FS microcontroller has received too many cyclic telegrams.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0025

Error message

25 CC-FSUC: cyclic communication impaired CC%2 %1

Cause of error

Cyclic communication on the FS microcontroller is impaired.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0026

Error message

26 MC-FSUC: cyclic communication impaired

Cause of error

Cyclic communication on the FS microcontroller is impaired.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0027

Error message

27 UM-FSUC: cyclic communication impaired CC%2 %1 %10

Cause of error

Cyclic communication on the FS microcontroller is impaired.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-002A

Error message

2A UM-FSUC: impermissible Reconfiguration CC%2 %1 %10

Cause of error

The FS microcontroller was reconfigured even though it had already received valid FS configuration data.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-002D

Error message

2D UM-FSUC: device parameters inconsistent CC%2 %1 %10

Cause of error

The FS microcontroller received inconsistent configuration data.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0030

Error message

30 UM-FSUC: FS configuration data of B channel invalid CC%2 / %1 10

Cause of error

Upon request by the B channel, the FS microcontroller set the FS configuration data to invalid.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0033

Error message

33 UM-FSUC: invalid request for self-test CC%2 %1 %10

Cause of error

The FS microcontroller received a request to start the self-test even though STO and SBC are not active.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0036

Error message

36 UM-FSUC: self-test canceled CC%2 %1 %10

Cause of error

The FS microcontroller canceled a running self-test because of an error.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0039

Error message

39 UM-FSUC: B channel voltage error CC%2 %1 %10

Cause of error

The B channel reports a voltage error.

Error correction

- Check the voltage supply of the affected units ("24 V" status LED on the unit)
- Inform your service agency


Error description 239-003C

Error message

3C UM-FSUC: watchdog B timed out CC%2 %1 %10

Cause of error

The watchdog of the B channel timed out.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-003D

Error message

3D CC-FSUC: internal watchdog defective CC%2 %1

Cause of error

Could not configure the internal watchdog of the FS microcontroller.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-003E

Error message

3E MC-FSUC: internal watchdog defective

Cause of error

Could not configure the internal watchdog of the FS microcontroller.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-003F

Error message

3F UM-FSUC: internal watchdog defective CC%2 %1 %10

Cause of error

Could not configure the internal watchdog of the FS microcontroller.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0042

Error message

42 UM-FSUC: internal communication error CC%2 %1 %10

Cause of error

The FS microcontroller detected an error in the cyclic communication within the inverter.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0045

Error message

45 UM-FSUC: cyclic communication inconsistent CC%2 %1 %10

Cause of error

The FS microcontroller detected an error in the cyclic communication with the MC.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0048

Error message

48 UM-FSUC: cyclic communication inconsistent CC%2 %1 %10

Cause of error

The FS microcontroller detected an error in the cyclic communication with the PAE module.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-004B

Error message

4B UM-FSUC: motor connection wrong CC%2 %1 %10 (E: X%4, P: X%5)

Cause of error

The FS microcontroller detected an incorrect assignment of a motor connection.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-004E

Error message

4E UM-FSUC: implausible parameterization CC%2 %1 %10

Cause of error

The FS microcontroller detected an incorrect sequence during parameterization.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-004F

Error message

4F CC-FSUC: initialization error CC%2 %1

Cause of error

Internal software error (initialization failed)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0050

Error message

50 MC-FSUC: initialization error

Cause of error

Internal software error (initialization failed)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0051

Error message

51 UM-FSUC: initialization error CC%2 %1 %10

Cause of error

Internal software error (initialization failed)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0052

Error message

52 CC-FSUC: temperature warning CC%2 %1 (temperature: %6°C)

Cause of error

Temperature monitoring reports a warning.

Error correction

- Check the temperature in the electrical cabinet
- Inform your service agency


Error description 239-0053

Error message

53 MC-FSUC: temperature warning (temperature: %6°C)

Cause of error

Temperature monitoring reports a warning.

Error correction

- Check the temperature in the electrical cabinet
- Inform your service agency


Error description 239-0055

Error message

55 CC-FSUC: SS1F reaction requested CC%2 %1

Cause of error

Serious error detected.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0057

Error message

57 UM-FSUC: SS1F reaction requested CC%2 %1 %10

Cause of error

Serious error detected.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0058

Error message

58 CC-FSUC: incorrect interface version CC%2 %1

Cause of error

The interface versions of internal components do not match.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0059

Error message

59 MC-FSUC: incorrect interface version

Cause of error

The interface versions of internal components do not match.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-005A

Error message

5A UM-FSUC: incorrect interface version CC%2 %1 %10

Cause of error

The interface versions of internal components do not match.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-005B

Error message

5B CC-FSUC: comparison of interface version missing CC%2 %1

Cause of error

The interface versions of internal components must be exchanged. The adjustment has not taken place yet.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-005C

Error message

5C MC-FSUC: comparison of interface version missing

Cause of error

The interface versions of internal components must be exchanged. The adjustment has not taken place yet.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-005D

Error message

5D UM-FSUC: comparison of interface version missing CC%2 %1 %10

Cause of error

The interface versions of internal components must be exchanged. The adjustment has not taken place yet.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0101

Error message

101 CC-FSUC: internal error CC%2 %1

Cause of error

Internal software error (unexpected program sequence)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0102

Error message

102 MC-FSUC: internal error

Cause of error

Internal software error (unexpected program sequence)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0103

Error message

103 UM-FSUC: internal error CC%2 %1 %10

Cause of error

Internal software error (unexpected program sequence)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0111

Error message

111 CC-FSUC: voltage error CC%2 %1

Cause of error

Voltage monitoring reports an error.

Error correction

- Check the voltage supply of the affected units ("24 V" status LED on the unit)
- Inform your service agency


Error description 239-0112

Error message

112 MC-FSUC: voltage error

Cause of error

Voltage monitoring reports an error.

Error correction

- Check the voltage supply of the affected units ("24 V" status LED on the unit)
- Inform your service agency


Error description 239-0113

Error message

113 UM-FSUC: voltage error CC%2 %1 %10

Cause of error

Voltage monitoring reports an error.

Error correction

- Check the voltage supply of the affected units ("24 V" status LED on the unit)
- Inform your service agency


Error description 239-0121

Error message

121 CC-FSUC: temperature error CC%2 %1 (temperature: %7,%8°C)

Cause of error

Temperature monitoring reports an error.

Error correction

- Check the temperature in the electrical cabinet
- Inform your service agency


Error description 239-0122

Error message

122 MC FSUC: temperature error (temperature: %7,%8°C)

Cause of error

Temperature monitoring reports an error.

Error correction

- Check the temperature in the electrical cabinet
- Inform your service agency


Error description 239-0131

Error message

131 CC-FSUC: parameterization failed CC%2 %1

Cause of error

The FS microcontroller received invalid parameter data.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0133

Error message

133 UM-FSUC: FS parameters inconsistent CC%2 %1 %10

Cause of error

The FS microcontroller received inconsistent parameter data.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0141

Error message

141 CC-FSUC: cyclic communication failed CC%2 %1

Cause of error

Cyclic communication between the MC and CC FS microcontroller failed.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0143

Error message

143 UM-FSUC: cyclic communication failed CC%2 %1 %10

Cause of error

Cyclic communication between the MC and UM FS microcontroller failed.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0151

Error message

151 CC-FSUC: software inconsistent CC%2 %1

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0152

Error message

152 MC-FSUC: software inconsistent

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0153

Error message

153 UM-FSUC: software inconsistent CC%2 %1 %10

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0161

Error message

161 CC-FSUC: stack error CC%2 %1

Cause of error

Internal software error (stack memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0162

Error message

162 MC-FSUC: stack error

Cause of error

Internal software error (stack memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0163

Error message

163 UM-FSUC: stack error CC%2 %1 %10

Cause of error

Internal software error (stack memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0171

Error message

171 CC-FSUC: internal software error CC%2 %1

Cause of error

Internal software error (Single Event Upset)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0172

Error message

172 MC-FSUC: internal software error

Cause of error

Internal software error (Single Event Upset)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0173

Error message

173 UM-FSUC: internal software error CC%2 %1 %10

Cause of error

Internal software error (Single Event Upset)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0181

Error message

181 CC-FSUC: RAM error CC%2 %1

Cause of error

Internal software error (RAM memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0182

Error message

182 MC-FSUC: RAM error

Cause of error

Internal software error (RAM memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0183

Error message

183 UM-FSUC: RAM error CC%2 %1 %10

Cause of error

Internal software error (RAM memory)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0191

Error message

191 CC-FSUC: voltage monitoring impaired CC%2 %1

Cause of error

The FS microcontroller reports defective monitoring of the voltage.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0192

Error message

192 MC-FSUC: voltage monitoring impaired

Cause of error

The FS microcontroller reports defective monitoring of the voltage.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0193

Error message

193 UM-FSUC: voltage monitoring impaired CC%2 %1 %10

Cause of error

The FS microcontroller reports defective monitoring of the voltage.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01A1

Error message

1A1 CC-FSUC: initial software consistency check CC%2 %1

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01A2

Error message

1A2 MC-FSUC: initial software consistency check

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01A3

Error message

1A3 UM-FSUC: initial software consistency check CC%2 %1 %10

Cause of error

Internal software error (software corrupt)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01B1

Error message

1B1 CC-FSUC: cyclic communication overloaded CC%2 %1

Cause of error

The FS microcontroller has received too many cyclic telegrams.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01B2

Error message

1B2 MC FSUC: cyclic communication overloaded

Cause of error

The FS microcontroller has received too many cyclic telegrams.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01B3

Error message

1B3 UM-FSUC: cyclic communication overloaded CC%2 %1 %10

Cause of error

The FS microcontroller has received too many cyclic telegrams.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01C1

Error message

1C1 CC-FSUC: cyclic communication impaired CC%2 %1

Cause of error

Cyclic communication on the FS microcontroller is impaired.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01C2

Error message

1C2 MC FSUC: cyclic communication impaired

Cause of error

Cyclic communication on the FS microcontroller is impaired.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01C3

Error message

1C3 UM-FSUC: cyclic communication impaired CC%2 %1 %10

Cause of error

Cyclic communication on the FS microcontroller is impaired.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01D3

Error message

1D3 UM-FSUC: impermissible Reconfiguration CC%2 %1 %10

Cause of error

The FS microcontroller was reconfigured even though it had already received valid FS configuration data.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01E3

Error message

1E3 UM-FSUC: device parameters inconsistent CC%2 %1 %10

Cause of error

The FS microcontroller received inconsistent configuration data.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-01F3

Error message

1F3 UM-FSUC: FS configuration data of B channel invalid CC%2 / %1 10

Cause of error

Upon request by the B channel, the FS microcontroller set the FS configuration data to invalid.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0203

Error message

203 UM-FSUC: invalid request for self-test CC%2 %1 %10

Cause of error

The FS microcontroller received a request to start the self-test even though STO and SBC are not active.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0213

Error message

213 UM-FSUC: self-test canceled CC%2 %1 %10

Cause of error

The FS microcontroller canceled a running self-test because of an error.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0223

Error message

223 UM-FSUC: B channel voltage error CC%2 %1 %10

Cause of error

The B channel reports a voltage error.

Error correction

- Check the voltage supply of the affected units ("24 V" status LED on the unit)
- Inform your service agency


Error description 239-0233

Error message

233 UM-FSUC: watchdog B timed out CC%2 %1 %10

Cause of error

The watchdog of the B channel timed out.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0241

Error message

241 CC-FSUC: internal watchdog defective CC%2 %1

Cause of error

Could not configure the internal watchdog of the FS microcontroller.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0242

Error message

242 MC-FSUC: internal watchdog defective

Cause of error

Could not configure the internal watchdog of the FS microcontroller.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0243

Error message

243 UM-FSUC: internal watchdog defective CC%2 %1 %10

Cause of error

Could not configure the internal watchdog of the FS microcontroller.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0253

Error message

253 UM-FSUC: internal communication error CC%2 %1 %10

Cause of error

The FS microcontroller detected an error in the cyclic communication within the inverter.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0263

Error message

263 UM-FSUC: cyclic communication inconsistent CC%2 %1 %10

Cause of error

The FS microcontroller detected an error in the cyclic communication with the MC.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0273

Error message

273 UM-FSUC: cyclic communication inconsistent CC%2 %1 %10

Cause of error

The FS microcontroller detected an error in the cyclic communication with the PAE module.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0283

Error message

283 UM FSUC: motor connection wrong CC%2 %1 %10 (E: X%5, P: X%6)

Cause of error

The FS microcontroller detected an incorrect assignment of a motor connection.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-0293

Error message

293 UM-FSUC: implausible parameterization CC%2 %1 %10

Cause of error

The FS microcontroller detected an incorrect sequence during parameterization.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02A1

Error message

2A1 CC-FSUC: initialization error CC%2 %1

Cause of error

Internal software error (initialization failed)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02A2

Error message

2A2 MC-FSUC: initialization error

Cause of error

Internal software error (initialization failed)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02A3

Error message

2A3 UM-FSUC: initialization error CC%2 %1 %10

Cause of error

Internal software error (initialization failed)

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02B1

Error message

2B1 CC FSUC: temperature warning CC%2 %1 (temperature: %7°C)

Cause of error

Temperature monitoring reports a warning.

Error correction

- Check the temperature in the electrical cabinet
- Inform your service agency


Error description 239-02B2

Error message

2B2 MC FSUC: temperature warning (temperature: %7°C)

Cause of error

Temperature monitoring reports a warning.

Error correction

- Check the temperature in the electrical cabinet
- Inform your service agency


Error description 239-02C1

Error message

2C1 CC-FSUC: SS1F reaction requested CC%2 %1

Cause of error

Serious error detected.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02C2

Error message

2C2 MC FSUC: SS1F reaction requested

Cause of error

Serious error detected.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02C3

Error message

2C3 UM-FSUC: SS1F reaction requested CC%2 %1 %10

Cause of error

Serious error detected.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02D1

Error message

2D1 CC-FSUC: incorrect interface version CC%2 %1

Cause of error

The interface versions of internal components do not match.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02D2

Error message

2D2 MC-FSUC: incorrect interface version

Cause of error

The interface versions of internal components do not match.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02D3

Error message

2D3 UM-FSUC: incorrect interface version CC%2 %1 %10

Cause of error

The interface versions of internal components do not match.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02E1

Error message

2E1 CC-FSUC: comparison of interface version missing CC%2 %1

Cause of error

The interface versions of internal components must be exchanged. The adjustment has not taken place yet.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02E2

Error message

2E2 MC-FSUC: comparison of interface version missing

Cause of error

The interface versions of internal components must be exchanged. The adjustment has not taken place yet.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02E3

Error message

2E3 UM-FSUC: comparison of interface version missing CC%2 %1 %10

Cause of error

The interface versions of internal components must be exchanged. The adjustment has not taken place yet.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-02F3

Error message

2F3 UM-FSUC: deactivation of drive failed CC%2 %1 %10

Cause of error

The drive could not be deactivated since it is not in a safe state.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-FFF1

Error message

FFF1 CC-FSUC: ALARM TEST CC%2 %1

Cause of error

The functional safety microcontroller received a test alarm.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-FFF2

Error message

FFF2 MC-FSUC: ALARM TEST

Cause of error

The functional safety microcontroller received a test alarm.

Error correction

- Generate the service file
- Inform your service agency


Error description 239-FFF3

Error message

FFF3 UM-FSUC: ALARM TEST CC%2 %1 %10

Cause of error

The functional safety microcontroller received a test alarm.

Error correction

- Generate the service file
- Inform your service agency


Error description 23A-0000

Error message

Internal error on device: %2

Cause of error

- Error during program run
- Invalid error message
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0001

Error message

Internal error on device: %2

Cause of error

- Program or hardware configuration faulty
- Test environment is active
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0003

Error message

Internal access error on device: %2

Cause of error

HSCI PHY: hardware is not responding
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0004

Error message

Internal error on device: %2

Cause of error

- Error during program run (NULL pointer)
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0005

Error message

Internal error on device: %2

Cause of error

- Parameter transfer invalid
- Illegal value
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0006

Error message

Internal error on device: %2

Cause of error

- Parameter transfer invalid
- Illegal argument
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0007

Error message

Error while executing command on device: %2

Cause of error

Received data invalid
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0008

Error message

Internal error on device: %2

Cause of error

Device index invalid
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0009

Error message

Internal error on device: %2

Cause of error

Internal registration of function: Error during program run
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-000B

Error message

Timeout during communication with device: %2

Cause of error

HFL sender: interface at full capacity or not ready for operation
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-000E

Error message

Timeout during communication with device: %2

Cause of error

Device is not responding
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0014

Error message

Faulty data transmission with device: %2

Cause of error

Received data invalid
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0015

Error message

Internal error on device: %2

Cause of error

Interface index invalid
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0018

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL Master: an error occurred at the interface
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0019

Error message

Error in communication with device:%2

Cause of error

Inverter (HFL): an error occurred at the interface
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-001A

Error message

Initialization of interface faulty for device: %2

Cause of error

SPI: an error occurred at the interface
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-001B

Error message

Error in communication with device:%2

Cause of error

SPI: an error occurred at the interface
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-001C

Error message

Error in communication with device:%2

Cause of error

SPI: an error occurred at the interface
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-001D

Error message

Timeout during communication with device: %2

Cause of error

HSCI (DMA): interface at full capacity or not ready for operation
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-001E

Error message

Error in communication with device:%2

Cause of error

HSCI (DMA): an error occurred at the interface
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-001F

Error message

Error in communication with device:%2

Cause of error

HFL (DMA): an error occurred at the interface
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0020

Error message

Timeout during communication with device: %2

Cause of error

HFL: interface at full capacity or not ready for operation
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0021

Error message

Internal error on device: %2

Cause of error

- Error during program run
- XADC not initialized
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0022

Error message

Internal error on device: %2

Cause of error

- Error during program run
- XADC already initialized
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0023

Error message

Internal error on device: %2

Cause of error

- Program or hardware configuration faulty
- Entry not found in HDT
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0025

Error message

Initialization of interface faulty for device: %2

Cause of error

- Device is busy or not ready for operation
- Encoder FPGA: configuration failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0026

Error message

Internal error on device: %2

Cause of error

Encoder-FPGA Flash ID: program or hardware configuration faulty
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0027

Error message

Internal error on device: %2

Cause of error

Encoder FPGA DRAM: program or hardware configuration faulty
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0028

Error message

Internal access error on device: %2

Cause of error

Encoder FPGA Flash: hardware is not responding
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0029

Error message

Initialization of interface faulty for device: %2

Cause of error

Encoder FPGA Master (HFL): an error occurred at the interface
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-002A

Error message

Internal error on device: %2

Cause of error

FSuC bootloader: invalid firmware loaded
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-002B

Error message

Invalid firmware loaded on device: %2

Cause of error

FSuC firmware: firmware update failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-002C

Error message

Invalid firmware loaded on device: %2

Cause of error

FSuC VMT: firmware update failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-002D

Error message

Internal error on device: %2

Cause of error

FSuC HIK: invalid firmware loaded
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-002E

Error message

Internal error on device: %2

Cause of error

- Error during program run
- FSuC firmware not started
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-002F

Error message

Error in communication with device:%2

Cause of error

FSuC: invalid received data
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0030

Error message

Timeout during communication with device: %2

Cause of error

FSuC: device is not responding
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0031

Error message

Timeout during communication with device: %2

Cause of error

FSuC: device at full capacity or not ready for operation
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0032

Error message

Firmware update failed on device: %2

Cause of error

FSuC: invalid firmware loaded
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0033

Error message

Error in communication with device:%2

Cause of error

FSuC: invalid parameter transfer
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0034

Error message

Error in communication with device:%2

Cause of error

- HSCI: an error occurred at the interface
- Local error register is set
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0035

Error message

Error in communication with device:%2

Cause of error

- HSCI: an error occurred at the interface
- External error register is set
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0036

Error message

Timeout during communication with device: %2

Cause of error

HSCI: device is not responding
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0037

Error message

Error in communication with device:%2

Cause of error

HSCI: self-test of interface failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0039

Error message

Internal access error on device: %2

Cause of error

Flash module: Hardware initialization failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-003A

Error message

Internal access error on device: %2

Cause of error

Flash module: access to hardware failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-003B

Error message

Internal access error on device: %2

Cause of error

Flash module: access to hardware failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-003C

Error message

Internal access error on device: %2

Cause of error

Flash module: access to hardware failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-003D

Error message

Internal access error on device: %2

Cause of error

Flash module: access to hardware failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-003E

Error message

Internal access error on device: %2

Cause of error

Flash module: invalid parameter transfer
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-003F

Error message

Internal access error on device: %2

Cause of error

Flash module: invalid received data
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0040

Error message

Internal access error on device: %2

Cause of error

Flash module: configuration of the hardware failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0041

Error message

Internal access error on device: %2

Cause of error

Internal access error on device: %2
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0042

Error message

Internal error on device: %2

Cause of error

Zynq initialization: error during program run
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0043

Error message

Internal error on device: %2

Cause of error

Start of the application software: error during program run
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0044

Error message

Internal access error on device: %2

Cause of error

eFuse status: access to hardware failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0045

Error message

Internal access error on device: %2

Cause of error

eFuse key: access to hardware failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0046

Error message

Internal error on device: %2

Cause of error

eFuse configuration data: error during program run
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0047

Error message

Internal access error on device: %2

Cause of error

eFuse write-operation: access to hardware failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0048

Error message

Internal access error on device: %2

Cause of error

RAM: invalid parameter transfer
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0049

Error message

Internal access error on device: %2

Cause of error

RAM: hardware test failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-004A

Error message

Internal access error on device: %2

Cause of error

FRAM: hardware initialization failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-004F

Error message

Internal access error on device: %2

Cause of error

FRAM: hardware is not responding
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0050

Error message

Internal access error on device: %2

Cause of error

Diagnostics Flash: hardware initialization failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0052

Error message

Internal access error on device: %2

Cause of error

Diagnostics Flash: hardware test failed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0053

Error message

Internal error on device: %2

Cause of error

- Error during program run
- Invalid image size
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0054

Error message

Faulty boot image on device: %2

Cause of error

- Image data are incomplete or inconsistent
- Application software not found
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0055

Error message

Faulty boot image on device: %2

Cause of error

- Image data are incomplete or inconsistent
- Boot image not found
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0056

Error message

Faulty boot image on device: %2

Cause of error

- Image data are incomplete or inconsistent
- Fall-back boot image not found
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0057

Error message

Faulty boot image on device: %2

Cause of error

- Image data are incomplete or inconsistent
- Primary boot image not found
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0058

Error message

Faulty boot image on device: %2

Cause of error

Fall-back boot image: incorrect image offset
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0059

Error message

Faulty boot image on device: %2

Cause of error

Primary boot image: incorrect image offset
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-005A

Error message

Faulty boot image on device: %2

Cause of error

Image offset incorrect
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-005B

Error message

Faulty boot image on device: %2

Cause of error

Image data are incomplete or inconsistent
- Generate the service file and inform your service agency
No authentication data are available
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-005C

Error message

Faulty boot image on device: %2

Cause of error

Byte converter: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-005D

Error message

Internal error on device: %2

Cause of error

-Received data invalid
- Terminal: invalid character
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-005E

Error message

Internal error on device: %2

Cause of error

-Received data invalid
- Terminal: input too long
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0060

Error message

Faulty boot image on device: %2

Cause of error

Info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0061

Error message

Faulty boot image on device: %2

Cause of error

Info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0062

Error message

Faulty boot image on device: %2

Cause of error

Info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0063

Error message

Faulty boot image on device: %2

Cause of error

Info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0064

Error message

Faulty boot image on device: %2

Cause of error

Info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0065

Error message

Faulty boot image on device: %2

Cause of error

Info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0066

Error message

Faulty boot image on device: %2

Cause of error

Info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0067

Error message

Faulty boot image on device: %2

Cause of error

Info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0068

Error message

Faulty boot image on device: %2

Cause of error

Info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0069

Error message

Faulty boot image on device: %2

Cause of error

Info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-006A

Error message

Faulty boot image on device: %2

Cause of error

Info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-006B

Error message

Internal error on device: %2

Cause of error

- Device index invalid
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-006C

Error message

Error while executing command on device: %2

Cause of error

-Device index invalid
- Driver assignment not possible
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-006D

Error message

Error while executing command on device: %2

Cause of error

- Device index invalid
- Command was not processed
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-006E

Error message

Internal error on device: %2

Cause of error

Interface designation invalid
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-006F

Error message

Internal error on device: %2

Cause of error

- Error during program run
- Error during main initialization phase
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0070

Error message

Faulty boot image on device: %2

Cause of error

Image authentication: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0071

Error message

Error while detecting device for device: %2

Cause of error

- Program or hardware configuration faulty
- Capture limit reached
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0072

Error message

Error while detecting device for device: %2

Cause of error

- Image data are incomplete or inconsistent
- Faulty entry
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0073

Error message

Error while detecting device for device: %2

Cause of error

Device at full capacity or not ready for operation
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0074

Error message

Internal error on device: %2

Cause of error

FPGA ID: program or hardware configuration faulty
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0075

Error message

Error while executing command on device: %2

Cause of error

- Command invalid
- No HIK available for reading out
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0076

Error message

Internal error on device: %2

Cause of error

HIK: invalid parameter transfer
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0077

Error message

Error while executing command on device: %2

Cause of error

- Parameter transfer invalid
- Maximum command size (in) exceeded
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0078

Error message

Error while executing command on device: %2

Cause of error

- Parameter transfer invalid
- Maximum command size (out) exceeded
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0079

Error message

Error while executing command on device: %2

Cause of error

- Parameter transfer invalid
- Error in the command sequence
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-007A

Error message

Error while executing command on device: %2

Cause of error

- Parameter transfer invalid
- Address invalid
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-007D

Error message

Error while executing command on device: %2

Cause of error

- Parameter transfer invalid
- Message ID invalid
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-007E

Error message

Error while executing command on device: %2

Cause of error

- Parameter transfer invalid
- Command invalid
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-007F

Error message

Faulty boot image on device: %2

Cause of error

Encoder FPGA info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0080

Error message

Faulty boot image on device: %2

Cause of error

Encoder FPGA info section: image data are incomplete or inconsistent
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0081

Error message

Internal error on device: %2

Cause of error

- Program or hardware configuration faulty
- Test environment is active
%1
ID number: %3, serial number: %4

Error correction

- Generate the service file and inform your service agency


Error description 23A-0082

Error message

Internal error on device: %2

Cause of error

- Hardware initialization failed
- Internal XADC voltage reference is active
%1
ID number: %3, serial number: %4

Error correction

- Restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0083

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: self-test of interface failed (VMK)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0084

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: self-test of interface failed (VSK)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0085

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: self-test of interface failed (VMLS)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0086

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: self-test of interface failed (VMS)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0087

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: self-test of interface failed (VMPS)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0088

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: self-test of interface failed (VSLPS)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0089

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VMTX)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-008A

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VSTX)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-008B

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VMTO)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-008C

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VSTO)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-008D

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VMRX)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-008E

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VSRX)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-008F

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VMSTX)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0090

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VMI)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0091

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VSI)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0092

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VMSRX)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0093

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VMPE)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 23A-0094

Error message

Initialization of interface faulty for device: %2

Cause of error

HFL: an error occurred at the interface (VSPE)
%1
ID number: %3, serial number: %4

Error correction

- Check the interface connections and restart the control
- If the problem recurs, generate a service file and inform your service agency


Error description 240-07D0

Error message

No permission to write

Cause of error

Sie haben eine schreibgeschützte Datei zum Editieren angewählt.

Error correction

Vor dem Editieren Schreibschutz aufheben:
Schlüsselzahl 86357 eingeben.


Error description 240-07D1

Error message

File '%1' not found

Cause of error

Diese Datei wurde nicht gefunden

Error correction

Datei neu anlegen oder generieren lassen


Error description 240-07D2

Error message

File type of '%1' incorrect

Cause of error

Sie haben eine falsche Datei angewählt

Error correction

Wählen Sie eine andere Datei an


Error description 240-07D3

Error message

File '%1' is encrypted

Cause of error

Sie haben eine verschlüsselte Datei angewählt

Error correction

Geben Sie den Schlüsselcode ein


Error description 240-07D4

Error message

Access to '%1' is blocked

Cause of error

You tried to edit an NC program while it was running in a Program Run mode.

Error correction

- Stop the NC program run


Error description 240-07D5

Error message

Invalid file path: '%1'

Cause of error


Error description 240-0800

Error message

Key non-functional

Cause of error

The key is not allowed in this status or it has no function.

Error correction

Press another key or soft key.


Error description 240-0804

Error message

NC program not saved

Cause of error

The NC program is write protected and therefore cannot be saved.

Error correction

- Open the file manager and cancel the write protection for the NC program. Then use the Programming mode of operation to select and save the NC program.
- Or, as an alternative, save the NC program under another name.


Error description 240-0CA3

Error message

Error in internal communication

Cause of error

Internal software error.

Error correction

Inform your service agency


Error description 240-0CA4

Error message

Error in an internal process

Cause of error

Internal software error.

Error correction

Inform your service agency


Error description 240-0CA5

Error message

Cycle data faulty or incomplete

Cause of error

The stored description of the cycle is incorrect or incomplete.
Check whether there are further error messages with more information on the possible cause.

Error correction

Define the cycle description correctly


Error description 241-07D0

Error message

Key non-functional

Cause of error

In this context the key has no function.


Error description 241-07D2

Error message

Text not found

Cause of error

The ASCII editor could not find the desired text in a file.

Error correction

Search for another text (note upper and lower case letter).


Error description 241-09C4

Error message

Machine configuration error

Cause of error

A machine parameter has a faulty value. For more information see the soft key INTERNAL INFORMATION (Text0...2).

Error correction

- Correct the machine parameter
- Inform your service agency


Error description 241-09C5

Error message

Internal software error

Cause of error

Internal control error:
- Insufficient memory
- Other, nonspecified errors

Error correction

Inform your service agency.


Error description 241-09C6

Error message

Data record already locked

Cause of error

The table editor was instructed to edit a locked data record.

Error correction

Release the lock (e.g.: terminate the NC program or tool change) and repeat the instruction.


Error description 241-09C7

Error message

Data record with incorrect length

Cause of error

In the table editor, a table was entered containing at least one line whose length differs from the length of the line with the column name.

Error correction

Open the table with the text editor and shorten the problem line at its end or fill it with spaces.
Alternatively, for example if several lines are faulty, you can use the file manager to copy the table into a new fault-free table.


Error description 241-09C8

Error message

Pocket table incorrect

Cause of error

- The pocket table contains more spindle pockets than are given in the machine parameter CfgAxes.spindleIndices.

Error correction

- Delete the invalid pockets from the pocket table


Error description 241-09C9

Error message

Incorrect value `%1` in update rule `%2`

Cause of error

Incorrect syntax of the update rule:
- The keyword is missing or spelled incorrectly
- The keyword is unknown
- Invalid number for a rule
- Incorrect or unknown symbolic table name
- The entered column is missing in the table
- Column list is unequal during a copying statement

Error correction

- Note the additional information on the error message.
- Remember that the error can also be before the indicated place!
- Enter the statement in the correct syntax, or contact your machine tool builder.


Error description 241-09CA

Error message

Update rule "%1" erroneous

Cause of error

The update rule for updating a table is faulty and cannot be applied.

Error correction

- Please pay attention to other pending error messages.
- Enter the statement for updating the table in the correct syntax, or contact your machine tool builder.


Error description 241-09CB

Error message

Error while importing the table '%1' in '%2'

Cause of error

Table import failed.

Error correction

- Note the additional data on the error message. To do so, press the INTERNAL INFO soft key.
- Note further pending error messages.
- Inform your service agency.


Error description 241-09CC

Error message

Table '%1' erroneous

Cause of error

The update to the table failed since the table is faulty.

Error correction

Please ensure that the table
- has the correct syntax
- exists
- is not write-protected
If necessary, contact your machine tool builder


Error description 241-09CD

Error message

Error while updating table '%1'

Cause of error

The update of the table failed.

Error correction

- Please pay attention to other pending error messages.
- Pay attention to the additional information regarding the error message or contact your machine tool builder.


Error description 241-09D0

Error message

Access to file %1 during update denied

Cause of error

- The file cannot be updated because access to the table is not possible
- The file might still be in use by the control or an external application

Error correction

- Press NC stop, close all files or release them in the external application, and try again.
- If an update is still not possible: restart the control until the power-interrupted message appears. Then restart the update.


Error description 241-09D1

Error message

File %1 changed through import

Cause of error

The entered file was automatically modified during import:
- Program name
- Special characters removed
- End block inserted

Error correction

- Check the file
- Note the changes and check
- Use the file only if you feel that it is correct


Error description 241-0C03

Error message

File or file path '%1' invalid

Cause of error

The file name or path for the file operation update is incorrect. Update failed.

Error correction

- Note the additional data on the error message. To do so, press the INTERNAL INFO soft key.
- Note further pending error messages.
- Check the syntax of the file name and path for the file operation.
- Check whether the file and path actually exist.
- Inform your service agency.


Error description 241-0C04

Error message

Error during update in file operation

Cause of error

File operation of an update rule failed.

Error correction

- Note the additional data on the error message. To do so, press the INTERNAL INFO soft key.
- Note further pending error messages.
- Inform your service agency.


Error description 241-0C05

Error message

Update rule "%1" erroneous

Cause of error

The update rule for the file operation is faulty and has failed.

Error correction

- Note the additional data on the error message. To do so, press the INTERNAL INFO soft key.
- Note further pending error messages.
- Check the syntax of the command for the file.
- Inform your service agency


Error description 241-0C2A

Error message

Table layout can't be changed

Cause of error

You tried to change the number or layout of the table columns.
The width of columns cannot be reduced.
The table files must not be write-protected.

Error correction

- Do not reduce the column width
- Close open tables and change the table layout before acknowledging the Power Interrupted message


Error description 242-07D0

Error message

Key non-functional

Cause of error

In this context the key has no function.


Error description 242-07D1

Error message

File invalid

Cause of error

- The file to be inserted in the text was not found
- No file selected
- Selected file is already being edited by the text editor
- Selected file is already being edited by another application
- Invalid file

Error correction

- Select another file
- Close the file in another application


Error description 242-07D3

Error message

Intermediate memory empty

Cause of error

You attempted to insert blocks from intermediate memory, although you haven't copied anything since power has been on.

Error correction

Before you can insert anything from intermediate memory you must first fill it using the copy function.


Error description 242-07D4

Error message

Text not found

Cause of error

The ASCII editor could not find the desired text in a file.

Error correction

Search for another text (note upper and lower case letter).


Error description 242-07D5

Error message

Input error

Cause of error

You enter a value that exceeds the permissible input range.

Error correction

Check input value.


Error description 242-07D7

Error message

No permission to write

Cause of error

The called file is write-protected. Sometimes it can no longer be saved under this name.

Error correction

- Save the file under another name - Select another file - Cancel write protection


Error description 242-07DA

Error message

File not saved

Cause of error

The file is write-protected and could not be saved.

Error correction

- Cancel the write-protection in the file management. Select the text editor and save the file again.
- Save the file under another name.


Error description 243-00F5

Error message

Serial number?

Cause of error


Error description 245-03F5

Error message

Configuration server not ready

Cause of error

The system-inherent communication over the data interface to the configuration server is not ready.

Error correction

Inform your service agency.


Error description 245-03F6

Error message

Unable to open configuration server queue

Cause of error

Error in the system-inherent communication.

Error correction

Inform your service agency.


Error description 245-03F7

Error message

Unable to read configuration data '%1'

Cause of error

Error in the system-inherent communication.

Error correction

Inform your service agency.


Error description 245-03F8

Error message

Unable to write configuration data '%1'

Cause of error

Error in the system-inherent communication.

Error correction

Inform your service agency.


Error description 245-03F9

Error message

Error in the PGM-MGT configuration %1

Cause of error

Invalid for incorrect data in the configuration of the file management

Error correction

Correct the corresponding data and save


Error description 245-03FA

Error message

Internal error!

Cause of error

Internal software error in the file management

Error correction

Inform your service agency


Error description 245-03FB

Error message

Process not available

Cause of error

A process entered in the configuration data cannot be activated.

Error correction

Inform your service agency.


Error description 245-03FC

Error message

ClientQueue (%1) could not be opened

Cause of error

Error in system-inherent communication

Error correction

Inform your service agency.


Error description 245-03FD

Error message

General error in internal system queue (%1)

Cause of error

Error in system-inherent communication

Error correction

Inform your service agency.


Error description 245-03FE

Error message

No receiver for internal system message

Cause of error

Error in system-inherent communication

Error correction

Inform your service agency.


Error description 245-03FF

Error message

Processor check error

Cause of error

Internal software error

Error correction

Inform your service agency


Error description 245-0401

Error message

Failed to send internal message

Cause of error

Error in system-inherent communication

Error correction

Inform your service agency.


Error description 245-040D

Error message

Ext. in-/output not ready

Cause of error

- The interface is not connected
- The external device is not switched on or is not ready
- The transmission cable is defective or incorrect

Error correction

Check the data transmission line.


Error description 245-0413

Error message

Problems recognizing the USB device!

Cause of error

- The USB device in use has not been detected
- The USB device could not be integrated into the system

Error correction

- Remove the USB device and try again
- Try it with another USB device


Error description 245-0414

Error message

Problems removing the USB device!

Cause of error

- The USB device used was not correctly removed or was not logged off by means of the soft-key function
- A file is still open on the USB device
- The USB device could not be released from the system

Error correction

- Use the soft-key function to log the relevant USB device off correctly
- Close the applications with access to a file on the USB device


Error description 245-0416

Error message

Serial data transmission is faulty

Cause of error

- The interface is not correctly configured
- The transmission cable is defective or incorrect
- Invalid file for the selected interface configuration

Error correction

- Check the interface configuration of both communication partners
- Check the data transmission line
- Check whether a valid file is available for transmission


Error description 245-0417

Error message

File system error: %1

Cause of error


Error description 245-0851

Error message

Display program could not be started.

Cause of error

A selection box is still open for starting an external display program

Error correction

Bring the hidden selection box back into the foreground, if necessary with the HeROS task bar
- Either select the desired display program for further editing,
- or cancel the selection of the display program


Error description 245-0861

Error message

Changing the access rights is not permitted: %1

Cause of error

Changing of the access rights to the file or directory is permitted only for the owner or the "root" user.


Error description 250-138B

Error message

Program was edited

Cause of error

The current NC program, or one of the NC programs that have called the current NC program, was changed. It is therefore impossible to go back into the program.

Error correction

- Check whether the changed program should be started
Use the mid-program startup function or the GOTO function to select the desired location to go back into the program. HEIDENHAIN recommends using the mid-program startup function to go back into the program.


Error description 250-138C

Error message

Not enough main memory (RAM)

Cause of error

The control has too little physical main memory.

Error correction

Equip the hardware with at least 128 MB RAM.


Error description 250-138D

Error message

Current program not selected. Select with file manager.

Cause of error

The displayed program was not selected in the program run.

Error correction

Use the file manager to select a program at the beginning.


Error description 250-138E

Error message

Program was edited during program run!

Cause of error

A program was edited during program run.

Error correction

Check whether the edited program should be run.


Error description 250-138F

Error message

Cycle Query dialog box could not be opened!

Cause of error

A dialog box is already open.

Error correction

Close the open dialog box, and restart the program.


Error description 250-1390

Error message

Application cannot be activated: %1

Cause of error

The other application has not been started or has another title.

Error correction

Start the other application manually.


Error description 250-1391

Error message

Error while transferring command to PLC server

Cause of error

Internal software error.

Error correction

Inform your service agency.


Error description 250-1392

Error message

Error while transferring command to SQL server

Cause of error

Internal software error.

Error correction

Inform your service agency.


Error description 250-1393

Error message

Error in internal communication

Cause of error

Internal software error.

Error correction

Inform your service agency.


Error description 250-1394

Error message

Error in an internal process

Cause of error

Internal software error.

Error correction

Inform your service agency.


Error description 250-1395

Error message

Error in an internal process

Cause of error

Internal software error.

Error correction

Inform your service agency.


Error description 250-1396

Error message

Program resumption not possible

Cause of error

The program cannot be continued from the point of interruption.

Error correction

Use GoTo to position to the start of program, or select the program again.
If you are machining a pallet, then update the pallet table (perhaps set W-STATUS to BLANK).
Then the program can be started.


Error description 250-1397

Error message

Axis movement canceled

Cause of error

A reference run in an axis was stopped or canceled before the target position was reached.

Error correction

- Check the axis, acknowledge the error, and restart the reference run
- If appropriate, press the permissive button to confirm that a non-referenced or non-checked axis is to be moved


Error description 250-1398

Error message

File access not possible

Cause of error

The file cannot be accessed. Perhaps it was deleted.

Error correction

Select another file.


Error description 250-1399

Error message

File access not possible

Cause of error

The file is not a valid NC program for this control.

Error correction

Select another program.


Error description 250-139A

Error message

NC program not selected

Cause of error

The NC program was not selected through the file management (PGM MGT key).

Error correction

To be able to start this program, select it in the file management (PGM MGT key) of start it with the selected program in mid-program startup.


Error description 250-13A7

Error message

Connection setup to DNC not possible

Cause of error

Cannot connect with the DNC.


Error description 250-13A8

Error message

Connection setup to DNC not possible

Cause of error

Cannot connect with the DNC.
TeleService is already being used by another application.

Error correction

- Restart the control.
- If the problem continues, inform your service agency.


Error description 250-13A9

Error message

Connection setup to DNC not possible

Cause of error

Cannot connect with the DNC.
The machine parameter for TeleService is improperly configured.

Error correction

The machine parameter for TeleService, "CfgServiceRequest," must be correctly configured.


Error description 250-13AA

Error message

TeleService request is in error

Cause of error

TeleService could not be activated or deactivated.


Error description 250-13AB

Error message

TeleService request is in error

Cause of error

Unable to send TeleService request.

Error correction

Check the network connections and retry.


Error description 250-13AC

Error message

TeleService request is in error

Cause of error

The machine parameter for TeleService is improperly configured.

Error correction

The machine parameter for TeleService, "CfgServiceRequest," must be correctly configured.


Error description 250-13AE

Error message

Table access not possible

Cause of error

The table cannot be accessed. The file was probably deleted.

Error correction

Make a new table.


Error description 250-13AF

Error message

Preset table is faulty

Cause of error

No preset is marked as active in the preset table, or multiple presets are marked at the same time.

Error correction

Correct the preset table. Only one preset can be marked as active.


Error description 250-13B6

Error message

Configuration parameter cannot be saved

Cause of error

The control tried to write data to a write-protected configuration file.

Error correction

- Inform your service agency


Error description 250-13B7

Error message

Table cannot be selected

Cause of error

A configuration parameter required for selecting the table could not be written to.

Error correction

- Inform your service agency.


Error description 250-13B8

Error message

Machine kinematic configuration has too many rotary axes

Cause of error

You have defined more than two axes as rotary axes. The working plane cannot be tilted with more that two rotary axes. Machine kinematics with more than two rotary axes are not supported by the control.

Error correction

- Change the machine configuration: Use a kinematic configuration with no more than 2 rotary axes.


Error description 250-13BD

Error message

PLC pop-up window (Module 9216) not possible

Cause of error

A PLC pop-up window (PLC Module 9216) cannot be shown in the current operating situation.

Error correction

Activate the machine operation or close a dialog already open.


Error description 250-13BE

Error message

Tool number does not exist

Cause of error

The tool number required for selection of a pocket number is not in the table.

Error correction

- Correct the tool table


Error description 250-13BF

Error message

Tool does not exist

Cause of error

The tool is not present in the tool table.

Error correction

- Correct the tool table
- Select a tool table that contains the tool.


Error description 250-13C0

Error message

No tool pocket available

Cause of error

There is no fitting tool pocket in the pocket table for the tool.

Error correction

- Provide a fitting tool pocket


Error description 250-13C1

Error message

Pop-up window (Module 9217) not possible

Cause of error

A PLC pop-up window (PLC Module 9217) cannot be shown in the current operating situation.

Error correction

Activate the Machine operating mode or close an already open dialog box.


Error description 250-13C2

Error message

Cycle Query dialog is not possible in this state!

Cause of error

A cycle query dialog (PLC Module 9291) cannot be shown in the current operating situation.

Error correction

- Check the PLC program and correct if necessary


Error description 250-13C3

Error message

Check the "Evaluation of EnDat" dialog window

Cause of error

The "Evaluation of EnDat encoder" dialog window cannot be displayed because is overlapped by a background operating mode.

Error correction

Activate a machine operating mode and confirm the "Evaluation of EnDat encoder" dialog window.


Error description 250-13C4

Error message

Program selection not possible

Cause of error

The selection of an NC program is presently not allowed.

Error correction

Select the Program Run mode of operation


Error description 250-13C5

Error message

Current status of the axis not received

Cause of error


Error description 250-13C6

Error message

Program start not supported

Cause of error

The start of the NC program is not supported in this condition.

Error correction

- Move the axes over the reference marks
- Reconduct the program start


Error description 250-13C7

Error message

Operation not supported

Cause of error

The control cannot be operated while it is in this state.

Error correction

Please wait until the axes have been referenced.


Error description 250-13C9

Error message

Current block (%1) not selected

Cause of error

After an interruption in the program run, the control cannot resume program run from the present cursor location.

Error correction

Select the desired location for resuming the program with "GOTO" + block number, or with the mid-program startup function.


Error description 250-13CA

Error message

Start the program in the Program Run mode

Cause of error

An error occurred in the previous program run

Error correction

Switch to the Program Run mode of operation and restart the program


Error description 250-17D3

Error message

Reference run is not possible

Cause of error

The reference run is not possible at present because the axis is in use.

Error correction

Restart the reference run at a later time.


Error description 250-F306

Error message

Program selection not possible

Cause of error

An external program selection (over DNC, OPC UA, or the PLC) could not be executed because the file manager is open.

Error correction

- Select the program and close the file manager.
- Or close the file manager and select the program externally (over DNC, OPC UA, or the PLC).


Error description 250-F308

Error message

File manager was closed through an external program selection

Cause of error

While the file manager was open, the control received a command for an external program start (over DNC, OPC UA, or the PLC).
The file manager was closed and the external program selection was conducted.


Error description 250-F30C

Error message

Preset table is faulty

Cause of error

No preset is marked as active in the preset table, or multiple presets are marked at the same time.

Error correction

Correct the preset table


Error description 250-F319

Error message

Function could not be executed %1

Cause of error

The function called (e.g. pressing of a soft key) could not be executed.

Error correction

- Call the function again later
- If the problem continues, inform your service agency


Error description 250-F31A

Error message

Execution canceled -- next start from beginning of table

Cause of error

- Program aborted by user
- Program aborted because of an NC error
- Attempt at starting failed because of a missing table entry

Error correction

Remove the cause of the error. The next program start will take place from the beginning of the table.


Error description 250-F31D

Error message

Host computer operation is not possible

Cause of error

Host computer operation cannot be enabled because a machining process is currently running.

Error correction

Terminate the current operation and then activate host computer operation.


Error description 250-F322

Error message

Illegal program type

Cause of error

The program type of the file is not valid.

Error correction

Select a valid NC program


Error description 250-F323

Error message

3DROT active: Axis positions cannot be tested

Cause of error

You have attempted to test an axis even though the function "Rotate working plane" is active. Axis positions cannot be tested if the working plane is tilted.

Error correction

Deactivate "Tilt the working plane" and test the axis positions again


Error description 250-F324

Error message

Component %1 cannot be displayed due to limits currently configured

Cause of error

Possible causes:
- A component with fewer than four limits was entered in the machine configuration under CfgComponentMon/components[]
- The values of the limits are not in ascending order.

Error correction

- Correct the machine configuration under CfgComponentMon/components[] or select another component in the "CM Detail" tab


Error description 250-F329

Error message

Monitoring task %1 cannot be displayed.

Cause of error

Possible causes:
- A monitoring task with fewer than four limits was entered in the machine configuration under Monitoring/CfgMonPreferences/monitoringTasks[]
- The values of the limits of the entry in CfgMonComponent are not in ascending order.
- No value is entered for CfgMonComponent/display.

Error correction

- Check and if necessary correct the machine configuration under Monitoring/CfgMonComponent, or
- Select another monitoring task in the "MON Detail" tab


Error description 250-F32A

Error message

Table cannot be activated

Cause of error

Activation of a different datum or compensation table is not possible while a block is being machined.

Error correction

Either wait until the active block has finished, or (if possible without danger) press the "Internal stop" soft key while the block is being machined.


Error description 250-F32E

Error message

Monitoring task %1 cannot be displayed.

Cause of error

The monitoring task cannot be displayed. Possible causes:
- The display settings for this monitoring task are incomplete or faulty
- The configured limits do not permit display of the monitoring task

Error correction

- Check the configuration and adapt it if necessary: CfgMonComponent > display
- Select a different monitoring task


Error description 250-F332

Error message

Program cannot be run

Cause of error

Either there is an error in the program, or the program has been modified.

Error correction

- Check whether the program is free of errors, and execute a GOTO or reset before restarting
- Use the GOTO function in order to select the desired starting point for the restart. Or use a reset to restart the simulation from the beginning of the program.


Error description 250-F333

Error message

Preset was not stored

Cause of error

An error occurred while saving the preset.

Error correction

- Check the preset table and correct it if necessary
- Restart the control
- Try to save the preset again
- If the error recurs, save the service file and inform your service agency


Error description 250-F334

Error message

Preset was not reset

Cause of error

An error occurred while resetting the preset.

Error correction

- Check the preset table and correct it if necessary
- Restart the control
- Try to save the preset again
- If the error recurs, save the service file and inform your service agency


Error description 250-F335

Error message

This file cannot be displayed

Cause of error

Access to the file was denied.

Error correction

Check the access rights for the file


Error description 250-F33C

Error message

Check the "Evaluation of EnDat encoder" dialog window

Cause of error

The "Evaluation of EnDat encoder" dialog window can't be opened, because the "Traverse reference points" dialog box is not active.

Error correction

Activate the "Traverse reference points" dialog box and confirm the "Evaluation of EnDat encoder" dialog window.


Error description 250-F33D

Error message

GPS: settings have not been saved yet

Cause of error

You edited entries in the global program settings but did not save these entries.

Error correction

Apply or discard the settings


Error description 251-0D92

Error message

Communication error when reading the configuration data

Cause of error

An internal communication error has occurred in the internal oscilloscope during interrogation of the configuration data.

Error correction

- Check the configuration of the parameter set and correct if necessary
- Inform your service agency


Error description 251-0D93

Error message

Unexpected answer when reading the active parameter set

Cause of error

An internal communication error has occurred in the internal oscilloscope during interrogation of the configuration data.

Error correction

- Check the configuration of the parameter set and correct if necessary
- Inform your service agency


Error description 251-0D94

Error message

Login for reading the configuration data has failed

Cause of error

An internal communication error has occurred in the internal oscilloscope during interrogation of the configuration data.

Error correction

- Check the configuration of the parameter set and correct if necessary
- Inform your service agency


Error description 251-0D95

Error message

Internal communication error in oscilloscope

Cause of error

An internal communication error has occurred in the internal oscilloscope during log-in to the Channel Manager.

Error correction

Inform your service agency.


Error description 251-0D96

Error message

Internal communication error in oscilloscope

Cause of error

An internal communication error has occurred in the internal oscilloscope during registration for operating modes.

Error correction

Inform your service agency.


Error description 251-0D97

Error message

Step function has been deactivated

Cause of error

Due to an operating mode change, the jump function was deactivated in the integrated oscilloscope.

Error correction

Run the jump function in manual mode


Error description 251-0D98

Error message

Incorrect operating mode was selected for step function

Cause of error

The jump function can be activated only in manual mode.

Error correction

Change to the manual operating mode


Error description 251-0D99

Error message

Parameter set cannot be read

Cause of error

Interrogation of the active parameter set of an axis has failed.

Error correction

Check the parameter sets of the axis


Error description 251-0D9B

Error message

Initializing parameters cannot be read

Cause of error

An error occurred during import of the initialization parameters for the jump function of the active axis.

Error correction

Check the initialization file


Error description 251-0D9C

Error message

Error while restoring the parameters

Cause of error

The restoration of and the original parameters of an axis has failed.

Error correction

Check the axis parameters after deactivation of the jump function


Error description 251-0D9D

Error message

Parameter-set code of an axis does not exist

Cause of error

The identifier of the parameter set for restoring the original axis parameters is missing.

Error correction

After deactivation of the jump function, check the parameters of the axis and correct them if necessary


Error description 251-0D9F

Error message

Step function cannot be activated

Cause of error

The reference marks for one or more axes were not scanned.

Error correction

- Home the axes
- Reselect the jump function in the integrated oscilloscope


Error description 251-0DA0

Error message

Step function cannot be activated

Cause of error

An internal communication error has occurred. The status of the axis's parameter set or the status of the reference run could not be ascertained.

Error correction

- Reselect the jump function in the integrated oscilloscope
- Inform your service agency if the error occurs repeatedly


Error description 251-0DA1

Error message

Parameter set cannot be initialized

Cause of error

The active parameter set of an axis could not be initialized for the jump function.

Error correction

- Reselect the jump function in the integrated oscilloscope
- Inform your service agency if the error occurs repeatedly


Error description 251-0DA6

Error message

Step function cannot be activated

Cause of error

An error occurred during import of the initialization parameters or the parameter sets for the jump function.

Error correction

Check the parameter sets and initialization parameters, and correct if required.


Error description 251-0DA7

Error message

Actual-to-nominal value transfer is faulty

Cause of error

No actual-to-nominal value transfer could be executed after deactivation of the jump function.

Error correction

Inform your service agency if this error occurs repeatedly


Error description 251-0DB7

Error message

The selected signal is not supported

Cause of error

The selected position signal is not supported by the control hardware.

Error correction

Choose another signal.


Error description 251-0DD5

Error message

Selected CC signal is not available

Cause of error

When the data record is started, the selected signal can not be assigned to the CC.

Error correction

If the error occurs repeatedly, please inform your service agency.


Error description 251-0DD6

Error message

Error in synchronization of data channels to the PLC

Cause of error

Synchronization error between IPO and PLC at start of data recording. Signals from the PLC are to be recorded, but the IPO does not receive a response from the PLC.

Error correction

If the error occurs repeatedly, please inform your service agency.


Error description 251-0DD7

Error message

Error in synchronization of CC signals

Cause of error

Synchronization error between IPO and CC at start of data recording. CC signals are to be recorded, but the IPO does not receive a response from the CC.

Error correction

If the error occurs repeatedly, please inform your service agency.


Error description 251-0DD8

Error message

Number of CC signals exceeded

Cause of error

The permissible number of CC signals has been exceeded.

Error correction

Limit the number of CC signals to the permissible maximum.


Error description 251-0DD9

Error message

Unexpected sampling rate during acknowledgment of CC data channel

Cause of error

When a CC data channel is acknowledged, the cycle time of the acknowledgment does not correspond to the expected cycle time.

Error correction

Check the parameter settings for the cycle time.


Error description 251-0DDA

Error message

Number of data channels for recording with CC clock exceeded.

Cause of error

When recording with the CC clock, the number of data channels is limited.

Error correction

Limit the number of data channels when recording with CC clock to the permissible maximum.


Error description 251-0DE2

Error message

The selected signal is not supported

Cause of error

The right to IPO-/CC-Dbg signals is missing


Error description 251-0DE3

Error message

The signal cannot be recorded

Cause of error

The right needed to record IPO or CC-Dbg signals is missing.

Error correction

Log on to the control as a user who has the right to read OEM interface data (e.g. as the function user 'oemdataaccessread').


Error description 251-0DE4

Error message

The signal cannot be recorded

Cause of error

The right to record PLC signals is missing


Error description 251-0DE5

Error message

The application cannot be started

Cause of error

The right to run the internal control oscilloscope is missing


Error description 251-0DE6

Error message

The selected signal is not supported

Cause of error

The right to PLC signals is missing


Error description 251-0E18

Error message

Check data of the SCO file

Cause of error

You opened an older version of a SCO file; this file is not compatible with the current version.

Error correction

Check the loaded data.


Error description 251-0E28

Error message

The trace file could not be saved

Cause of error

Trace file cannot be written to.

Error correction

Check whether write-access is granted for the selected partition (e.g. PLC).


Error description 251-0E29

Error message

File could not be read

Cause of error

A file could not be accessed for reading.

Error correction

Check whether read-access is granted for the selected partition (e.g. PLC).


Error description 251-0E2A

Error message

Necessary right for recording a signal is missing

Cause of error

When loading a file or initializing the control, changed user rights have caused a signal to not have the necessary rights for recording
The signal is set to OFF in the selection dialog box of the integrated oscilloscope.


Error description 251-0E2B

Error message

Signal ID not found in list of enabled signals

Cause of error

The signal ID used was not found in the list of permitted signals. The signal is set to OFF in the selection dialog box of the integrated oscilloscope.


Error description 251-0E2C

Error message

Recording of signal not permitted

Cause of error

There is no recording right for this signal. The signal is set to OFF in the selection dialog box of the integrated oscilloscope.


Error description 251-0E2D

Error message

Signal ID not found in selection list

Cause of error

The signal ID used was not found in the list of of the selection dialog box of the integrated oscilloscope. The signal is set to OFF.
The registered user might not have the right to access the signal.

Error correction

Log-on as a user with the necessary access right


Error description 251-0E34

Error message

Selected UVR signal is not available

Cause of error

When data recording is started, the selected signal of the UVR cannot be assigned.

Error correction

If the error occurs repeatedly, please inform your service agency.


Error description 251-0E35

Error message

Error in synchronization of CC or UVR signals

Cause of error

Synchronization error between interpolator, CC controller unit, or UVR at start of data recording. CC or UVR signals are to be recorded, but the interpolator receives no response from the CC or UVR.

Error correction

If the error occurs repeatedly, please inform your service agency.


Error description 251-0E36

Error message

Trigger condition Signal [SAVED] not fulfilled in reference trace

Cause of error

A signal was set to [SAVED] even though a trigger condition has not been fulfilled for the reference trace.

Error correction

Before the signal state [SAVED] can be used, a trigger condition must be fulfilled for the reference trace, otherwise the signal curve cannot be associated chronologically.


Error description 251-0E37

Error message

Trigger condition Signal [SAVED] not fulfilled in current trace

Cause of error

The signal state [SAVED] is being used even though no trigger condition has been fulfilled for the current trace.

Error correction

If the signal state [SAVED] is to be used, then a trigger condition must be fulfilled for the current trace. Otherwise the signal curve cannot be associated chronologically.


Error description 260-01FB

Error message

Cannot find PLC module: %1

Cause of error

Cannot find the selected PLC module.

Error correction

Select another PLC module or inform your service agency.


Error description 260-01FC

Error message

Error in temporary file

Cause of error

The temporary file could not be generated.

Error correction

Select another PLC program or inform your service agency.


Error description 260-01FD

Error message

Compiler not found

Cause of error

The PLC compiler / PET interpreter could not be loaded.

Error correction

Inform your service agency.


Error description 260-01FE

Error message

Program/table with invalid format

Cause of error

The PLC program / the PET table has an incorrect format.

Error correction

Correct the program/table.


Error description 260-01FF

Error message

PLC compiler configuration incorrect

Cause of error

The configuration file for the PLC compiler contains errors.

Error correction

Correct the configuration file. Note further error messages regarding this.


Error description 260-0200

Error message

Insufficient memory for the PLC compiler/PET

Cause of error

Insufficient memory to load the PLC compiler / PET.

Error correction

Release some memory and compile again.


Error description 260-0202

Error message

System error in the PLC

Cause of error

The following causes of error are intended to help the service personnel to isolate and correct the PLC system error.
- A PLC program cannot be loaded because the control type is configured incorrectly.
- A PLC program cannot be loaded because the error table for the PLC compiler is configured incorrectly.
- A PLC program cannot be loaded because an unexpected file system error occurred.
- Symbol definitions for the PLC program cannot be read or contain unexpected data.
- There is another internal PLC system error

Error correction

Inform your service agency.


Error description 260-0203

Error message

Command cannot be executed at present

Cause of error

The command cannot be executed at present because either an NC program is running or a compiler process is already active.

Error correction

Stop the program run and restart the compiler process.


Error description 260-0204

Error message

The command cannot be executed at present

Cause of error

The command cannot be executed at present because autostart is already active.

Error correction

End autostart and restart the compiler process.


Error description 260-0205

Error message

PLC program could not be started

Cause of error

The PLC program was compiled correctly but the PLC could not be started.

Error correction

Select another PLC program and compile it; or inform your service agency.


Error description 260-0206

Error message

No active PLC program

Cause of error

The PLC program has not started and therefore no program for tracing is active.

Error correction

Select another PLC program and compile it; or inform your service agency.


Error description 260-0207

Error message

No access to PLC symbol file (%1)

Cause of error

A PLC symbol file cannot be accessed.

Error correction

Compile the PLC program again or select another PLC program.


Error description 260-0208

Error message

Local symbol. Cannot be displayed

Cause of error


Error description 260-0209

Error message

No valid PLC operand

Cause of error

The input contains no valid PLC operands.

Error correction

Please enter the correct PLC operand name.


Error description 260-020A

Error message

Update of operand data not possible

Cause of error

The operand data update is not possible at present.

Error correction

Compile the PLC-Programm again or inform your service agency.


Error description 260-020B

Error message

Source file invalid

Cause of error


Error description 260-020C

Error message

No active error table

Cause of error

The error table is not active.

Error correction

Reselect the error table and compile.


Error description 260-020D

Error message

Compilation of PLC program failed

Cause of error

The PLC program could not be compiled.

Error correction

Select another PLC program and compile.


Error description 260-020E

Error message

Compilation of PLC error table failed

Cause of error

The error table could not be compiled.

Error correction

Select another error table and compile.


Error description 260-020F

Error message

Operand being loaded in watchlist....

Cause of error


Error description 260-0210

Error message

Operand not recognized!

Cause of error


Error description 260-0211

Error message

Operand %1 loaded in watchlist

Cause of error


Error description 260-021D

Error message

Command not possible at this time: Trace function is active

Cause of error

The command cannot be executed at present. An external tracer is active, which is why the command is not permissible.

Error correction

End the external tracer and give the command again.


Error description 260-021E

Error message

Command not possible at this time: Self-test is active

Cause of error

The command cannot be executed at present. The safety self-test is active, which is why the command is not permissible.

Error correction

Wait for the end of the self-test, and then give the command again.


Error description 260-0221

Error message

Operand %1 not activated/deactivated

Cause of error

The given operand could not be activated or deactivated in the I/O force list.

Error correction

Please check the I/O force list and correct it if necessary.


Error description 260-0224

Error message

Operand %1 was set twice

Cause of error

The given operand was entered more than once in the I/O force list

Error correction

- Adapt selection. PLC operands of the same name should be listed only once in the I/O force list.
- If there are multiple entries, the last operand in the list applies!


Error description 260-0235

Error message

Data request not permitted

Cause of error

Due to missing user rights, no data can be requested from the PLC.

Error correction

- Check the user rights
- If necessary, grant the current user the necessary additional rights


Error description 270-0001

Error message

System error in SQL server

Cause of error

A software error has occurred in the SQL server.

Error correction

Inform your service agency.


Error description 270-0002

Error message

System error in SQL server

Cause of error

A function of the SQL server has been called, although the function has not yet been implemented.

Error correction

Inform your service agency.


Error description 270-0003

Error message

System error in SQL server

Cause of error

The SQL server cannot determine the sender of a message.

Error correction

Inform your service agency.


Error description 270-0004

Error message

System error in SQL server

Cause of error

The SQL server cannot contact the sender of a message.

Error correction

Inform your service agency.


Error description 270-0005

Error message

Symbolic name %1 is not resolvable

Cause of error

A given symbolic table name cannot be resolved with the configuration data.

Error correction

– Check the configuration data
- Contact your machine tool builder


Error description 270-0006

Error message

Table %1 not found

Cause of error

A table file cannot be found in the given path.

Error correction

- Correct the given path name
- Copy or move the file to the given location


Error description 270-0007

Error message

Error while accessing file %1

Cause of error

An error occurred while accessing the indicated file:
- The file is not ISO Latin-15 encoded and begins with a Byte Order Mark (BOM)
- The file contains impermissible control characters, particularly the string 'NUL'
- Reading of the file is not permissible
- The file is to be deleted, but may not be written
- The file is to be renamed, but may not be written
- A previous access to the already open file failed
- There are already too many open files in the file system
- The file system does not permit the creation of any more files
- The file system reports some other error

Error correction

- Check the encoding of the file, change it if necessary, and remove the Byte Order Mark
- Check whether the file contains impermissible control characters and remove them
- Check and adapt the access rights to this file if necessary
- Check the status of the file system, and repair the file system if necessary


Error description 270-0008

Error message

Table %1 erroneous

Cause of error

A given table file has a faulty file name or contains incorrect syntax in the table description.

Error correction

- Check the file name of the table, and correct it if required The file name of a table may consist of only the following characters:
- Letters from a to z and A to Z
- The digits 0 to 9
- A period (.)
- An underscore (_)
- Check the table description and adapt it if required. It must contain, in this sequence and spelling, the keyword BEGIN, the table name, and optionally the keyword MM or INCH for the unit of measure
- Contact your machine manufacturer


Error description 270-0009

Error message

Table %1 incomplete

Cause of error

A give table file does not end with the keyword [END]. This file might be incomplete.

Error correction

- Check whether the table file is complete. If necessary, add the keyword [END] on its own line at the end of the file
- If necessary, contact your machine tool builder


Error description 270-000A

Error message

Definition of column %1 is faulty or missing

Cause of error

The table contains a column for which either there is no description in the configuration data or in the table itself, or whose description in the table is faulty.

Error correction

- Add to or correct the column description
- If necessary, contact your machine tool builder


Error description 270-000B

Error message

Field name %1 already assigned

Cause of error

A given table file contains one field name more than once.

Error correction

- Correct the table
- If necessary, contact your machine tool builder


Error description 270-000C

Error message

Syntactically incorrect SQL statement

Cause of error

A given SQL statement has incorrect syntax.

Error correction

- Enter the statement in the correct syntax
- If necessary, contact your machine tool builder


Error description 270-000D

Error message

Literal not concluded

Cause of error

A literal in a given SQL statement does not end with the required ' character.

Error correction

Enter the statement in the correct syntax, or contact your machine tool builder.


Error description 270-000E

Error message

Field name %1 not found

Cause of error

An SQL statement was given with a field name that is not contained in the table.

Error correction

- Enter the statement in the correct syntax
- If necessary, contact your machine tool builder


Error description 270-000F

Error message

Data record already locked

Cause of error

There was an attempt to lock access to or to edit a data record that was already locked from somewhere else.

Error correction

- Remove the external lock and repeat the statement
- If necessary, contact your machine tool builder


Error description 270-0010

Error message

Data record with incorrect length

Cause of error

A given table contains at least one data record whose length differs from the length of the line with the field names.

Error correction

- Shorten the data record or fill it with space characters
- If necessary, contact your machine tool builder


Error description 270-0011

Error message

No further data records found

Cause of error

No further data records were found in response to an SQL query.

Error correction

Reformulate the query if the desired data record has not already been found.


Error description 270-0012

Error message

Incorrect default value for field

Cause of error

There was an attempt to insert a data record in a table, where an incorrect default value was given for at least one field in the description.

Error correction

- Correct the default value. In most cases it cannot be saved in the available field length.
- If necessary, contact your machine tool builder


Error description 270-0013

Error message

Incorrect value for field

Cause of error

There was an attempt to edit a data record in a table, where an incorrect value was given for at least one field.

Error correction

- Correct the given value. Usually it cannot be saved in the available field length.
- If necessary, contact your machine tool builder


Error description 270-0014

Error message

Incorrect number of values

Cause of error

There was an attempt to insert or change a data record in a table, where the number of values do not match the number of selected fields.

Error correction

- Correct the statement
- If necessary, contact your machine tool builder


Error description 270-0015

Error message

System error in SQL server

Cause of error

Unknown error in the SQL server.

Error correction

Inform your service agency.


Error description 270-0016

Error message

Table synonym already exists

Cause of error

An attempt was made to generate for the table a logical name that already exists.

Error correction

Select another name or delete the existing name first.


Error description 270-0017

Error message

Table synonym not found

Cause of error

There was an attempt to delete or edit a nonexistent logical name for a table.

Error correction

Select another name.


Error description 270-0018

Error message

Table already exists

Cause of error

An attempt was made to create a new table, although a table with this name already exists.

Error correction

Select another table name.


Error description 270-0019

Error message

Table is still open

Cause of error

An attempt was made the change a table description or delete a table, although the table is still open.

Error correction

Close the table first.


Error description 270-001A

Error message

Configuration datum cannot be modified

Cause of error

An attempt was made to create or change a logical name for a table. However, the corresponding configuration datum cannot be written.

Error correction

Stop the machining and then try again to generate or change the logical name.


Error description 270-001B

Error message

Description of the columns cannot be read

Cause of error

No description of the columns can be found for the table, because the type of table is not included in the configuration data, or the description of columns saved in the table itself is incomplete or syntactically incorrect.

Error correction

Check the configuration data and add a description of the type of table. Open the table with a text editor and delete or edit the column description saved in the table.


Error description 270-001C

Error message

Table contains no columns

Cause of error

An attempt was made to make or open a table without columns.

Error correction

Delete the table and make a new one.


Error description 270-001D

Error message

Table is write-protected

Cause of error

There was an attempt to make or edit a table on a write-protected storage medium or on one marked as write protected.

Error correction

Remove the write protection.


Error description 270-001E

Error message

Column %1 already exists in table

Cause of error

An attempt was made in a table to insert an existing column twice.

Error correction

Enter another column name.


Error description 270-001F

Error message

Index already defined

Cause of error

An attempt was made to create an index for a table using an index name that was already defined.

Error correction

Check the SQL statement and enter a different index name.


Error description 270-0020

Error message

Index not found

Cause of error

An attempt was made to delete an index that does not exist.

Error correction

Enter a valid name.


Error description 270-0021

Error message

Value %1 is not unique

Cause of error

The indicated value appears more than once in a column configured for unique values.

Error correction

Change the values in the column such that each value is unique.


Error description 270-0022

Error message

Column %1 cannot be indexed

Cause of error

An attempt was made to create an index for a column that was not configured for unique values.

Error correction

Change the values in the column such that each value is unique and configure the column for unique values, or enter a different column for indexing.


Error description 270-0023

Error message

Caption of the column %1 too long

Cause of error

The key name given for the column configuration is just as long as or longer than the given column width.

Error correction

- Enter a larger value for the column width
- If necessary, contact your machine tool builder


Error description 270-0024

Error message

Configuration datum %1 - %2
contains no value

Cause of error

The designated attribute of the column configuration contains an empty string.

Error correction

- Enter a valid value
- Delete the attribute if no default value is needed
- If necessary, inform your machine manufacturer


Error description 270-0025

Error message

Configuration datum %1 - %2
contains syntactically incorrect value %3

Cause of error

The designated attribute of the column configuration contains a syntactically incorrect value.

Error correction

- Enter a valid value
- If necessary, inform your machine manufacturer


Error description 270-0026

Error message

Configuration datum %1 - %2
contains a value %3 that is too long

Cause of error

The designated attribute of the column configuration contains a value that cannot be entered in the column with the given width

Error correction

- Enter a larger value for the column width
- Enter another value for the attribute
- If necessary, inform your machine manufacturer


Error description 270-0027

Error message

Unnecessary configuration datum
%1 - %2

Cause of error

The indicated attribute for the column configuration is not defined for the data type of the column.

Error correction

Delete the attribute or contact your machine tool builder.


Error description 270-0028

Error message

Configuration datum %1 - %2
contains value %3 out of range

Cause of error

The designated attribute of the column configuration lies outside of the value range. It might, for example, be smaller than the minimum value.

Error correction

- Enter a valid value
- If necessary, inform your machine manufacturer


Error description 270-0029

Error message

Configuration of table type %1 refers to
undefined column %2

Cause of error

The column designated in the configuration of the table type is not defined.

Error correction

- Check the column name
- Delete the column
- Delete the column from the configuration of the table type
- If necessary, contact your machine tool builder


Error description 270-002A

Error message

Primary key of table type %1 refers to
undefined column %2

Cause of error

The designated primary key is not a column of the table type.

Error correction

- Check the primary key
- Enter the column designated in the list of columns as the primary key of the table
- If necessary, inform your machine manufacturer


Error description 270-002B

Error message

Foreign key of table type %1 refers to
undefined column %2

Cause of error

The indicated foreign key is not a column of this table type.

Error correction

Check the entry for the foreign key, or enter a column identified in the list of columns as the foreign key for this table, or contact your machine tool builder.


Error description 270-002C

Error message

Foreign key of the table type %1 contains invalid
referential action %3

Cause of error

Incorrect syntax in the referential action for the designated foreign key.

Error correction

- Check the given referential action
- If necessary, inform your machine manufacturer


Error description 270-002D

Error message

Configuration datum %1 - %2
contains errors

Cause of error

The indicated configuration datum contains errors. The erroneous values were replaced by default values for operating the SQL server.

Error correction

- Correct the indicated configuration datum
- Check whether the primaryKey parameter has the correct initial value for the table column
- If necessary, inform your machine manufacturer


Error description 270-002E

Error message

Configuration datum %1 - %2
contains errors

Cause of error

The given configuration datum has errors and was not accepted for operating the SQL server.

Error correction

- Correct the given configuration datum
- If necessary, inform your machine manufacturer


Error description 270-002F

Error message

No column given

Cause of error

The SQL does not specify a column.

Error correction

Enter at least one column in the statement.


Error description 270-0030

Error message

Primary key may not be altered

Cause of error

The column for the primary key may not be renamed or removed from the table.

Error correction

Check the entered SQL statement.


Error description 270-0031

Error message

Update %1 not possible

Cause of error

An attempt was made to change a value in the column indicated as primary key for the table.

Error correction

Check the entered SQL statement.


Error description 270-0032

Error message

Value of primary key %1 missing

Cause of error

An attempt was made to enter a line in the table, even though there was no value entered in the primary key column of the table.

Error correction

Check the entered SQL statement.


Error description 270-0033

Error message

Column %1 contains no value

Cause of error

An attempt was made to delete a value from the indicated column. However, a value must be entered in this column.

Error correction

Check the entered SQL statement and assign a valid value to the column.


Error description 270-0034

Error message

Erroneous value for %1

Cause of error

An attempt was made to enter a syntactically incorrect value to the column.

Error correction

Check the entered SQL statement and assign a valid value to the column.


Error description 270-0035

Error message

Value for %1 is too long

Cause of error

An attempt was made to enter a value wider than the column width to the column.

Error correction

Check the entered SQL statement and assign a valid value to the column.


Error description 270-0036

Error message

Erroneous value for %1

Cause of error

An attempt was made to enter a value outside the value range to the column.

Error correction

Check the entered SQL statement and assign a valid value to the column.


Error description 270-0037

Error message

Data record %1 cannot be inserted, changed or deleted

Cause of error

There was an attempt to insert, change or delete a data record that either makes reference through a foreign key to a non-available data record or to which at least one other data record makes reference through a foreign key. The specified referential
action would leave an invalid reference.

Error correction

Check the SQL statement and correct the references first.


Error description 270-0038

Error message

Data record %1 cannot be changed

Cause of error

There was an attempt to change a data record that uses a foreign key to refer to another data record. The specified referential action would change a data record that was already changed by the SQL statement itself.

Error correction

Check the SQL statement and correct the references first.


Error description 270-0039

Error message

Data record already deleted

Cause of error

There was an attempt to access a data record that was already deleted by another statement.

Error correction

- Correct the statement
- If necessary, contact your machine tool builder


Error description 270-003A

Error message

Error in table name or table type %1

Cause of error

The given table name or type has incorrect syntax. Table names and types must begin with a letter and can otherwise contain letters, numerals and the underscore character.

Error correction

Check and correct the table name or type.


Error description 270-003B

Error message

Data medium almost full

Cause of error

When table files were closed, it was impossible to save a compact version of the files due to insufficient space remaining on the data medium.

Error correction

Delete any unnecessary files on the data medium.


Error description 270-003C

Error message

The modification key does not designate a time stamp column

Cause of error

A modification key was entered in the table configuration, but the corresponding column does not have the type TSTAMP.

Error correction

Select the column type TSTAMP or configure another time stamp column as modification key.


Error description 270-003D

Error message

The modification key designates a read only column

Cause of error

A modification key was entered in the table configuration and the corresponding column was declared only readable. This is not allowed because this column must always take the current time stamp for changes.

Error correction

Remove READONLY in the column configuration or configure another column as modification key.


Error description 270-003E

Error message

The modification key designates a unique column

Cause of error

A modification key was entered in the table configuration and the corresponding column was declared unique. This is not allowed because the same time stamp might be saved in two or more lines when changes are close together in time.

Error correction

Remove UNIQUE in the column configuration or configure another column as modification key.


Error description 270-003F

Error message

Merging of incompatible tables

Cause of error

Two tables were entered for merging that have different basic types. The basic types are derived from the file footers and headers in the tables.

Error correction

Check the file footers and headers of both table files and their configuration. If the tables have different basic types, they cannot be merged.


Error description 270-0040

Error message

Column %1 for special functions is not allowed

Cause of error

The column given for a special function (primary key, foreign key, timestamp or password) does not exist, has the wrong file type or is too narrow. Further information:
- Columns for a foreign key have to have the same data type as the column for the primary key.
- The column for the timestamp must have the TSTAMP data type and be at least 19 characters wide.
- The column for the password must have the TEXT data type and be at least 15 characters wide.
- The columns for the timestamp and password must not be write-protected or ambiguous.

Error correction

Correct the description of the table type or the column in the configuration data


Error description 270-0041

Error message

Data record %1 is protected by password

Cause of error

You tried to delete, edit or cancel the password protection of a table's password-protected data record.

Error correction

- To change the data record, reenter the password in the password column or cancel the password protection.
- Cancel the password protection before deleting the data record.
- To cancel the password protection, enter the exclamation mark character "!" in the password column and immediately enter the password.


Error description 270-0042

Error message

Data record %1 was changed without authorization

Cause of error

The checksum calculated for table's data record does not agree with the stored checksum.
The table file was manipulated by an external application or damaged on the storage medium.

Error correction

Import a backup copy of the affected table file.


Error description 270-0043

Error message

The table file %1 might have been manipulated

Cause of error

Not all data records in the table file have checksums saved in the column for the password.
Data records might have been changed by an external application.

Error correction

Check all data records for correctness or import a backup copy of the table file.


Error description 280-0064

Error message

FN 14: error code %1

Cause of error

Error forced by the function FN14 (ISO: D14).
This function calls preprogrammed messages of the machine tool builder (for example from an OEM cycle).
If with FN14 (D14) is reached during a program run or test run, the program is interrupted and the corresponding message is displayed.

Error correction

Look for a description of the error in the machine tool manual. Restart the program after the cause of the error has been removed.


Error description 280-03E8

Error message

Spindle must be turning

Cause of error

You called a fixed cycle without first switching on the spindle.

Error correction

Edit the part program.


Error description 280-03E9

Error message

Tool axis is missing

Cause of error

You programmed a positioning block with tool radius compensation without first calling a tool.

Error correction

Edit the part program.


Error description 280-03EA

Error message

Tool radius too small

Cause of error

- The tool radius is too small for the selected operation.
- Cycle 3 "Slot": You defined a width greater than four times the tool radius.
- Cycle 240: You entered a centering diameter greater than the tool diameter.
- Cycle 210 "Slot" or Cycle 211 "Circular Slot": The slot width is six times greater than the tool radius.

Error correction

- Use a tool with a larger radius.
- Cycle 3 "Slot": Define the slot width to be greater than the tool diameter and smaller than four times the tool radius.
- Cycle 240: Use a larger tool.
- Cycle 210 "Slot" or Cycle 211 "Circular Slot": Define the slot width to be greater than the tool diameter and smaller than six times the tool radius.


Error description 280-03EB

Error message

Tool radius too large

Cause of error

- Contour milling: The radius of an arc block at an inside corner is smaller than the tool radius.
- Thread milling: The thread core diameter is smaller than the tool diameter.
- Slot milling: The slot width for roughing is smaller than the tool diameter.
- Cycle 251, rectangular pocket: The rounding radius Q220 is smaller than the tool radius.
- Cycle 214: The given workpiece-blank diameter is smaller than the tool diameter

Error correction

- Use a smaller tool
- Slot milling: If necessary, use a smaller oversize (Q368)
- Cycle 214: Use a smaller tool; correct the workpiece-blank diameter


Error description 280-03EC

Error message

Range exceeded

Cause of error

During digitizing the stylus went out of the defined digitizing range.

Error correction

Check the data in the Range cycle, especially the entry for the touch probe axis.


Error description 280-03ED

Error message

Start position incorrect

Cause of error

Digitizing with contour lines: Incorrect starting position selected.

Error correction

Check the axes defined in the Contour Lines cycle.


Error description 280-03EE

Error message

Rotation not permitted

Cause of error

Rotation was programmed before a touch probe cycle.

Error correction

Reset the rotation cycle.


Error description 280-03EF

Error message

Scaling factor not permitted

Cause of error

A scaling factor was programmed before a touch probe cycle.

Error correction

Reset the scaling factor or the axis-specific scaling cycles.


Error description 280-03F0

Error message

Mirroring not permitted

Cause of error

Mirroring was programmed before a touch probe cycle.

Error correction

Reset the mirroring cycle.


Error description 280-03F1

Error message

Datum shift not permitted

Cause of error

Datum shift is active.

Error correction

Reset the datum shift.


Error description 280-03F2

Error message

Feed rate is missing

Cause of error

You did not program a feed rate.

Error correction

Edit the NC program. FMAX is effective only for the block in which it is programmed.


Error description 280-03F3

Error message

Entry value incorrect

Cause of error

- The value you entered is out-of-range.
- Cycle 209 (ISO: 209): You entered the value 0 as infeed depth for chip breaking (Q257).

Error correction

- Enter the correct value.
- Enter a value other than 0 in Q257.


Error description 280-03F4

Error message

Wrong sign programmed

Cause of error

The programmed dwell time in the Dwell Time cycle, Peck Drilling cycle, or Tapping cycle is negative (through Q parameter).

Error correction

Edit the cycle parameter.


Error description 280-03F5

Error message

Entered angle not permitted

Cause of error

- The solid angles programmed in Cycle 19 Tilt Working Plane (DIN/ISO: G80) cannot be realized with the current attachment (e.g. universal head where only one hemisphere is accessible).
- Run probing cycle only with paraxial angular position.
- The point angle (T-ANGLE) defined for the active tool is 180°.

Error correction

- Edit the solid angle entered.
- Run probing cycle only with paraxial angular position.
- Use angular values greater than 0 and less than 180°.


Error description 280-03F6

Error message

Touch point inaccessible

Cause of error

No touch point was reached during the TCH-PROBE 0 cycle (ISO: G55) or when using the manual probing cycles.

Error correction

- Pre-position the touch probe closer to the workpiece.


Error description 280-03F7

Error message

Too many points

Cause of error

Automatic establishment of points for the digitizing range in the Positioning with Manual Data Input operating mode: Number of stored points (max. 893) exceeded.

Error correction

Re-record digitizing range after increasing the point spacing.


Error description 280-03F8

Error message

Contradictory entry

Cause of error

The values that you entered are contradictory.

Error correction

Check the input values.


Error description 280-03F9

Error message

CYCL DEF incomplete

Cause of error

- You deleted part of a cycle.
- You have inserted other part program blocks within a cycle.

Error correction

- Redefine the complete cycle again
- Delete part program blocks programmed within a cycle.


Error description 280-03FA

Error message

Plane wrongly defined

Cause of error

While defining the Contour Lines cycle (TCH PROBE 7) you programmed a height axis in the starting point.

Error correction

Edit the part program.


Error description 280-03FB

Error message

Wrong axis programmed

Cause of error

- An incorrect axis is programmed in the highlighted block.
- Touch Probe Cycle 403: You programmed in incorrect compensation axis (Q312).

Error correction

- Check whether you have programmed an axis twice.
- Touch Probe Cycle 403: In parameter Q312, select only compensation axes that are present in the kinematic description.


Error description 280-03FC

Error message

Wrong rpm

Cause of error

The programmed spindle speed does not lie in the existing pattern of spindle speed stages.

Error correction

Enter the correct rotational speed.


Error description 280-03FD

Error message

Radius comp. undefined

Cause of error

You programmed a radius-compensated single-axis positioning block which without the radius compensation does not result in tool movement (e.g. IX+0 R+, ISO: G7).

Error correction

Edit the part program.


Error description 280-03FE

Error message

Rounding-off not permitted

Cause of error

In the positioning block before a rounding arc (RND, ISO: G25) either you programmed a movement only in the tool axis or you used the M function M98 to cancel compensation.

Error correction

Edit the part program.


Error description 280-03FF

Error message

Rounding radius too large

Cause of error

- In the definition of a contour, a contour pocket or a contour train, you programmed a rounding arc (RND, ISO: G25) with so large a radius that it does not fit between the adjoining elements.
- In a fixed cycle (rectangular pocket/rectangular stud), you defined a rounding arc that cannot be inserted.

Error correction

- Define a smaller rounding radius in the contour subprogram
- Check the cycle definition and correct the input values


Error description 280-0400

Error message

Program start undefined

Cause of error

Type of interpolation undefined.

Error correction

Restart the part program.


Error description 280-0401

Error message

Excessive subprogramming

Cause of error

You nested more than 8 subprogram calls (CALL LBL xx, ISO: Lx,0).

Error correction

Check whether all your subprograms are concluded with LBL 0 (ISO:G98 L0).


Error description 280-0402

Error message

Angle reference missing

Cause of error

In an LP/CP block (ISO: G10, G11, G12, G13) no polar angle or incremental polar angle is defined, i.e.:
- The distance between the last programmed position and the pole is less than or equal to 0.1 µm.
- No rotation is programmed between pole assumption and an LP/CP block.

Error correction

- Program the absolute polar angle.
- Check the position of the pole.
- If necessary, reset the rotation.


Error description 280-0403

Error message

No fixed cycle defined

Cause of error

There is no fixed cycle defined before Cycle 220/221 (circular/linear point pattern).

Error correction

Define a fixed cycle before Cycle 220/221.


Error description 280-0404

Error message

Insufficient slot width

Cause of error

The width defined in the slot cycle cannot be machined with the active tool.

Error correction

Use a smaller tool.


Error description 280-0405

Error message

Pocket too small

Cause of error

The side lengths defined in the Pocket Milling cycle are too small.

Error correction

Use a smaller tool.


Error description 280-0406

Error message

Q202 not defined

Cause of error

There is no plunging depth (Q202) defined in the fixed cycles 200 to 215.

Error correction

Enter a plunging depth in the fixed cycle.


Error description 280-0407

Error message

Q205 not defined

Cause of error

In the Universal Drilling cycle, you have not defined the minimum plunging depth.

Error correction

Enter a minimum plunging depth in the fixed cycle.


Error description 280-0408

Error message

Q218 must be greater than Q219

Cause of error

Pocket milling cycle: Q218 must be greater than Q219.

Error correction

Correct the values in the fixed cycle.


Error description 280-0409

Error message

Fixed cycle not allowed

Cause of error

Fixed cycle cannot be run in the CIRCULAR PATTERN or LINEAR PATTERN cycle.

Error correction

Use another fixed cycle.


Error description 280-040A

Error message

CYCL 211 not permitted

Cause of error

Cycle 211 cannot be run in the CIRCULAR PATTERN or LINEAR PATTERN cycle.

Error correction

Use another fixed cycle.


Error description 280-040B

Error message

Q220 too large

Cause of error

Pocket finishing or stud finishing cycle: Rounding radius Q220 is too large.

Error correction

Correct the rounding radius in the fixed cycle.


Error description 280-040C

Error message

Q222 must be greater than Q223

Cause of error

Stud finishing cycle: Workpiece blank diameter Q222 must be greater than the finished part diameter Q223.

Error correction

Correct the workpiece blank diameter in the fixed cycle.


Error description 280-040D

Error message

Q244 must be greater than 0

Cause of error

Circular Pattern cycle: You entered a pitch circle diameter of zero.

Error correction

Correct the pitch circle diameter in the cycle.


Error description 280-040E

Error message

Q245 must not equal Q246

Cause of error

Circular Pattern cycle: Enter a stopping angle equal to the starting angle.

Error correction

Correct the starting or stopping angle in the cycle.


Error description 280-040F

Error message

Angle range must be under 360°

Cause of error

Circular Pattern cycle: You entered an angle range greater than 360°.

Error correction

Correct the starting or stopping angle in the cycle.


Error description 280-0410

Error message

Q223 must be greater than Q222

Cause of error

In the Circular Pocket Finishing cycle, you entered a finished-part diameter (Q223) smaller than the workpiece-blank diameter (Q222).

Error correction

Edit Q222 in the cycle definition.


Error description 280-0411

Error message

Q214: 0 not permitted

Cause of error

In the definition of Cycle 204 you have entered the disengaging direction 0.

Error correction

In Q214, enter a value from 1 to 4.


Error description 280-0412

Error message

Traverse direction not defined

Cause of error

In a probing cycle you entered 0 for the traverse direction Q267.

Error correction

For Q267, enter either +1 (for positive traverse direction) or -1 (for negative traverse direction).


Error description 280-0413

Error message

No datum table active

Cause of error

Probing cycle for datum setting: The measured point is to be written in a datum table. However, you have not activated a datum table in a program run mode.

Error correction

In the Program Run, Single Block or Program Run, Full Sequence mode, activate a datum table in which the point is to be written.


Error description 280-0414

Error message

Position error: center in axis 1

Cause of error

Probing cycle for workpiece measurement: Center of 1st axis outside of position tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-0415

Error message

Position error: center in axis 2

Cause of error

Probing cycle for workpiece measurement: Center of 2st axis outside of position tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-0416

Error message

Hole diameter too small

Cause of error

Probing cycle for workpiece measurement: Hole diameter too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-0417

Error message

Hole diameter too large

Cause of error

- Probing cycle for workpiece measurement: Hole diameter tolerance exceeded.
- Cycle 208: The programmed hole diameter (Q335) cannot be machined with the active tool.

Error correction

- Check the workpiece and, if necessary, the measuring log.
- Cycle 208: Use a larger tool. Hole diameter must not be larger than twice the tool diameter.


Error description 280-0418

Error message

Stud diameter too small

Cause of error

Probing cycle for workpiece measurement: Stud diameter too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-0419

Error message

Stud diameter too large

Cause of error

Probing cycle for workpiece measurement: Stud diameter too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-041A

Error message

Pocket too small: rework axis 1

Cause of error

Probing cycle for workpiece measurement: Pocket length in 1st axis too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-041B

Error message

Pocket too small: rework axis 2

Cause of error

Probing cycle for workpiece measurement: Pocket width in 2nd axis too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-041C

Error message

Pocket too large: scrap axis 1

Cause of error

Probing cycle for workpiece measurement: Pocket length in 1st axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-041D

Error message

Pocket too large: scrap axis 2

Cause of error

Probing cycle for workpiece measurement: Pocket width in 2nd axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-041E

Error message

Stud too small: scrap axis 1

Cause of error

Probing cycle for workpiece measurement: Stud length in 1st axis too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-041F

Error message

Stud too small: scrap axis 2

Cause of error

Probing cycle for workpiece measurement: Stud width in 2nd too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-0420

Error message

Stud too large: rework axis 1

Cause of error

Probing cycle for workpiece measurement: Stud length in 1st axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-0421

Error message

Stud too large: rework axis 2

Cause of error

Probing cycle for workpiece measurement: Stud width in 2nd axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 280-0422

Error message

Meas. cycle: length exceeds max

Cause of error

Probing cycle 425 or 427: The measured length exceeds the maximum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 280-0423

Error message

Meas. cycle: length below min

Cause of error

Probing cycle 425 or 427: The measured length is below the minimum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 280-0424

Error message

TCHPROBE 426: length exceeds max

Cause of error

Probing cycle 426: The measured length exceeds the maximum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 280-0425

Error message

TCHPROBE 426: length below min

Cause of error

Probing cycle 426: The measured length is below the minimum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 280-0426

Error message

TCHPROBE 430: diameter too large

Cause of error

Probing cycle 430: The measured bolt-hole-circle diameter exceeds the maximum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 280-0427

Error message

TCHPROBE 430: diameter too small

Cause of error

Probing cycle 430: The measured bolt-hole-circle diameter is below the minimum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 280-0428

Error message

No measuring axis defined

Cause of error

You failed to define the measuring axis in one of the measuring cycles 400, 402, 420, 425, 426 or 427.

Error correction

Check Q272 in the corresponding cycle.
Permissible input values: 1 or 2;
for Cycle 427: 1, 2 or 3.


Error description 280-0429

Error message

Tool breakage tolerance exceeded

Cause of error

During workpiece inspection using a measuring cycle, the tool breakage tolerance RBREAK given in the tool table was exceeded.

Error correction

Check whether the tool is damaged.


Error description 280-042A

Error message

Enter Q247 unequal 0

Cause of error

In a measuring cycle you entered in parameter Q247 an angular step of 0.

Error correction

Enter an angular step (Q247) other than 0.


Error description 280-042B

Error message

Enter Q247 greater than 5

Cause of error

In a measuring cycle, you entered in parameter Q247 an angular step smaller than 5 degrees.

Error correction

To ensure sufficient measuring accuracy, enter an angular step (Q247) greater than 5 degrees.


Error description 280-042C

Error message

Datum table?

Cause of error

A datum table is required to run an NC program. However, there is no table saved in the control's NC memory, or there are more than one table but none of them is activated.

Error correction

Activate a datum table in the Program Run, Full Sequence operating mode.


Error description 280-042D

Error message

Enter direction Q351 unequal 0

Cause of error

In a fixed cycle you did not define the cutting direction (climb or up-cut).

Error correction

Define the cutting direction as climb milling (= 1) or up-cut milling (= -1).


Error description 280-042E

Error message

Thread depth too large

Cause of error

The programmed thread depth plus 1/3 of the pitch is greater than the drilling or sinking depth.

Error correction

Program the total hole depth to be at least 1/3 of a thread pitch smaller that the total hole depth.


Error description 280-042F

Error message

Missing calibration data

Cause of error

You have attempted to perform a measurement with Cycle 440 without first performing a calibration.

Error correction

Repeat Cycle 440, but with Q363 = 0 (calibrate).


Error description 280-0430

Error message

Tolerance exceeded

Cause of error

The limits entered in the tool table TOOL.T in the LTOL or RTOL column were exceeded.

Error correction

Check the limit values for the active calibration tool.


Error description 280-0431

Error message

Mid-program startup active

Cause of error

Mid-program startup is not permitted with the programmed function.

Error correction

Mark the programmed function with "skip blocks" and activate this setting. Then run the mid-program startup again.


Error description 280-0432

Error message

ORIENTATION not permitted

Cause of error

- Your machine does not offer spindle orientation
- Spindle orientation not possible

Error correction

- Refer to your machine manual!
- Check machine parameter mStrobeOrient and enter the numerical designation of the M function or -1 for spindle orientation by the NC. Refer to your machine manual!


Error description 280-0433

Error message

3-D ROT not permitted

Cause of error

You tried to conduct one of the following functions while the working plane was tilted:
- Setting a reference point
- A touch probe cycle 40x for measuring a misalignment

Error correction

Deactivate the tilted working plane function and restart the program.


Error description 280-0434

Error message

Activate 3DROT

Cause of error

In the Manual operating mode, the Tilt Working Plane function is inactive.

Error correction

Activate 3DROT in Manual mode.


Error description 280-0435

Error message

Check the depth sign

Cause of error

The cycle can only be performed in the negative direction (Cycle 204: positive direction) because the configuration parameter displayDepthErr is set to "on".

Error correction

- Enter a negative depth (Cycle 204: positive depth) in order to perform the cycle
- Set the configuration parameter displayDepthErr to "off" in order to perform the cycle in positive direction (Cycle 204: negative direction)
- Enter the diameter in Cycle 240 as a negative value in order to perform the operation in the negative direction of the tool axis.


Error description 280-0436

Error message

Q303 in meas. cycle undefined!

Cause of error

In one of the measuring cycles 410 to 418, you did not define the parameter Q303 (measured value transfer)(current value = -1). For reasons of security, however, selection of the measured value transfer is required to write the results of measurement in
a table (datum table or preset table).

Error correction

Change parameter Q303 (measured value transfer) in the measuring cycle that is causing the error:
- Q303=0: Write the measured values with respect to the active workpiece coordinate system into the active datum table (activate in the program with Cycle 7!).
- Q303=1: Write the measured values with respect to the active machine-based coordinate system (REF values) into the preset table (activate in the program with Cycle 247!).
- Q303=-1: Measured value transfer is undefined. This value is automatically generated by the TNC when you download a program that was written on a TNC 4xx or with an old software level of the iTNC 530, or if during the cycle definition you skipped the
prompt for the measured value transfer with the END key.


Error description 280-0437

Error message

Tool axis not allowed

Cause of error

- You called probing cycle 419 with an illegal tool axis.
- You called the PATTERN DEF function in connection with an illegal tool axis.

Error correction

- Only call probing cycle 419 with the tool axis X, Y or Z.
- Use the PATTERN DEF function only with the tool axis Z (TOOL CALL Z).


Error description 280-0438

Error message

Calculated values incorrect

Cause of error

In probing cycle 418, the TNC calculated too large a value. You may have defined in an incorrect sequence for the four holes to be probed.

Error correction

Check the probing sequence. Refer to the User's Manual for Touch Probe Cycles.


Error description 280-0439

Error message

Contradictory measuring points

Cause of error

- In one of the probing cycles 400, 403 or 420, you defined a contradictory combination of measuring points and measuring axes.
- The selection of measuring points in Cycle 430 results in division by 0.

Error correction

- For measuring axis = reference axis (Q272=1), the parameters Q264 and Q266 are defined at different values.
- For measuring axis = minor axis (Q272=2), the parameters Q263 and Q265 are defined at different values.
- For measuring axis = probe axis (Q272=3), the parameters Q263 and Q265 or Q264 and Q266 are defined at different values.
- Select the measuring points so that they always have different coordinates in all axes.


Error description 280-043A

Error message

Incorrect clearance height!

Cause of error

In Cycle 20 (ISO: G120), you entered a clearance height (Q7) that is lower than the coordinate of the workpiece surface (Q5).

Error correction

Enter a clearance height (Q7) that is higher than the coordinate of the workpiece surface (Q5).


Error description 280-043B

Error message

Contradictory plunge type!

Cause of error

The plunging strategy defined in Cycles 251 to 254 contradicts the defined plunging angle of the active tool.

Error correction

Change parameter Q366 in one of the Cycles 251 to 254 or the plunging angle ANGLE of the tool in the tool table. Permissible combinations of parameter Q366 and the plunging ANGLE are:
For perpendicular plunging: Q366 = 0 and ANGLE = 90
For helical plunging: Q366 = 1 and ANGLE > 0
For inactive tool table, define Q366 with 0 (only perpendicular plunging allowed).


Error description 280-043C

Error message

This fixed cycle not allowed

Cause of error

- You attempted to run a fixed cycle in connection with Cycle 220 or 221 although it cannot be combined with these cycles.
- You tried to run the Cycle 209 with a feed rate factor for retraction (Q403).

Error correction

- You cannot combine Cycles 220 and 221 with the following fixed cycles:
- Cycles of the SLI and SLII groups
- Cycles 210 and 211
- Cycles 230 and 231
- Cycle 254
- Feed rate factor 403 is allowed only with a setting in MP3010 unequal to 7.


Error description 280-043D

Error message

Line is write-protected

Cause of error

- You tried to edit or erase a write-protected line in the preset table.
- You tried to write a value in the active line of the preset table.

Error correction

- Overwriting the active preset is not allowed. Use another preset number.
- The write protection was activated by your machine manufacturer. Maybe fixed datum was defined in this line. If you want to cancel write protection, contact your machine tool builder.
- You defined the write protection in the TNC.SYS file. If required, cancel the write-protection there.
- You tried to change line 0. It cannot be changed.


Error description 280-043E

Error message

Oversize greater than depth

Cause of error

SL cycles II or milling cycles 25x: You have entered an allowance for floor greater than the milling depth.

Error correction

- SL cycles II: Check Q4 in Cycle 20 (ISO: G120).
- Milling cycles 25x: Check allowance Q369 and depth Q201.


Error description 280-043F

Error message

No point angle defined

Cause of error

In Cycle 240 Centering you defined parameter Q343 such that centering is done with respect to the diameter.
In a drilling cycle you defined parameter Q395 such that the depth is in reference to the tool diameter.
You programmed a cycle for chamfering. The point angle for this must be between 1 and 179 degrees.
However, no point angle is defined for the active tool.

Error correction

- Set parameter Q343=0 (centering to entered depth).
- Set parameter Q395=0 (depth in reference to the tool tip).
- Define the point angle in the column T-ANGLE of the tool table TOOL.T.


Error description 280-0440

Error message

Contradictory data

Cause of error

The combination of the parameters Depth (Q201) and Diameter (Q344) defined in Cycle 240 Centering under Select depth/diameter (Q343) is not allowed.

Error correction

Possible definitions:
Q343=1 (entered diameter active): Q201 must be equal to 0 and Q344 must not be equal to 0.
Q343=0 (entered depth active): Q201 must not be equal to 0 and Q344 must be equal to 0.


Error description 280-0441

Error message

Slot position 0 not allowed!

Cause of error

You tried to run Cycle 254 with the slot position 0 (Q367=0) in conjunction with the point pattern Cycle 221.

Error correction

Use slot position Q367 = 1, 2 or 3 if you want to run Cycle 254 with the point pattern cycle 221


Error description 280-0442

Error message

Enter an infeed not equal to 0

Cause of error

You defined a fixed cycle with the depth 0.

Error correction

Enter a depth unequal to 0.


Error description 280-0443

Error message

Switchover of Q399 not allowed

Cause of error

You tried to switch on the touch probe cycle 441 to switch on the angle tracking, although this function is deactivated by configuration datum.

Error correction

In the probe table, set the angle tracking in the TRAC column to ON and then recalibrate the touch probe.


Error description 280-0444

Error message

Tool not defined

Cause of error

You have called a tool that is not defined in the tool table.

Error correction

- Add the missing tool to the tool table.
- Use another tool.


Error description 280-0445

Error message

Tool number not allowed

Cause of error

In a TOOL CALL or TOOL DEF block you tried to define a tool number although it is prohibited by machine parameter.

Error correction

- Use the tool name.
- Adapt machine parameter 7483. If required, contact your machine manufacturer.


Error description 280-0446

Error message

Tool name not allowed

Cause of error

In a TOOL CALL or TOOL DEF block you tried to define a tool name although it is prohibited by machine parameter.

Error correction

- Use the tool number.
- If required, contact your machine tool builder


Error description 280-0447

Error message

Software option not active

Cause of error

You tried to use a software option that is not enabled on your TNC.

Error correction

Contact your machine tool builder or the control manufacturer to purchase the software option.


Error description 280-0448

Error message

Kinematics cannot be restored

Cause of error

You tried to restore kinematics that do not match the currently active kinematics.

Error correction

Restore only kinematics that you have saved previously from an identical kinematics description.


Error description 280-0449

Error message

Function not permitted

Cause of error

You tried to use a feature that is not enabled on your TNC by the Feature Content Level (FCL) management.

Error correction

By default, FCL functions are locked after a software update. By entering the code number 65535 in the SIK menu, you can enable these functions for a certain period of time for test purposes. You can enable FCL functions permanently by purchasing and
entering a code number. For more information, contact your machine tool builder or the control manufacturer.


Error description 280-044A

Error message

Contradictory workpc. blank dim.

Cause of error

The workpiece blank dimensions you have defined in a fixed cycle are smaller than the dimensions of the finished part.

Error correction

Check the cycle definition and correct the input values.


Error description 280-044B

Error message

Measuring position not allowed

Cause of error

The kinematic measurement resulted in a measuring position of 0° in one of the three rotary axes. This is not allowed.

Error correction

Select the starting angle, stopping angle and, if applicable, number of measurements on all three axes in a way that does not result in any 0° positions.


Error description 280-044C

Error message

Kinematic access not possible

Cause of error

The control could not access the active kinematic description (read or write).
- There is no valid kinematic description.
- The kinematic description is write-protected.

Error correction

- Use a valid kinematic description.
- Cancel write-protection for a kinematic description.


Error description 280-044D

Error message

Meas. pos. not in traverse range

Cause of error

You have defined a measured position that lies outside of the rotary axis's traverse range.

Error correction

Select the start angle and/or end angle in the cycle so that the measured position lies within the traverse range.


Error description 280-044E

Error message

Preset compensation not possible

Cause of error

You tried to run a compensation of the preset although not all the entries required for it are in the kinematic description. You can only run the preset compensation if transformations in three separate axes in the machine coordinate system are entered
in the kinematic description.

Error correction

Change the number of measuring points in the cycle so that the control can run a preset compensation. If necessary, contact the machine manufacturer.


Error description 280-044F

Error message

Tool radius too large

Cause of error

- The dimensions you defined in one of the Cycles 251 to 254 are too small.
- The lateral oversize in one of the Cycles 251 to 254 is too large.

Error correction

- Use a smaller tool
- Reduce the oversize.


Error description 280-0450

Error message

Plunging type is not possible

Cause of error

In one of the cycles 251 to 254 you defined a plunging strategy that is not possible with the dimensions defined in the cycle.

Error correction

Use a smaller tool or another plunging strategy.
Set the configuration datum suppressPlungeErr to "on" in order to suppress this monitoring, or use RCUTS in the tool table.
Use a tool with a sufficiently large cutting width and define this width in the RCUTS column of the tool table.


Error description 280-0451

Error message

Plunge angle incorrectly defined

Cause of error

You defined an incorrect plunge angle (ANGLE column in the tool table) for the selected plunging strategy.

Error correction

Define a plunge angle greater than 0° and smaller than 90°.


Error description 280-0452

Error message

Angular length is undefined

Cause of error

You defined in the cycle an angular length of 0°.

Error correction

Define an angular length greater than 0° in the cycle definition.


Error description 280-0453

Error message

Slot width is too large

Cause of error

You defined the circular slot width at least as large as the pitch circle diameter.

Error correction

Enter a slot width smaller than the pitch circle diameter in the cycle definition.


Error description 280-0454

Error message

Scaling factors not equal

Cause of error

You attempted to scale a circular contour element with differing axis-specific scaling factors.

Error correction

Scale the axes of circular contour elements with the


Error description 280-0455

Error message

Tool data inconsistent

Cause of error

A tool whose data do not match those calibrated by the touch probe is active.

Error correction

Transmit the calibrated data of the touch probe to the tool table and perform a TOOL CALL in order to load the changed data.


Error description 280-0456

Error message

MOVE not possible

Cause of error

In a KinematicsOpt cycle you selected a rotary axis positioning with the MOVE function although that is not possible with the existing configuration.

Error correction

Deactivate the MOVE function:
- Enter a retraction height Q408 greater than 0.
- Define the retraction height Q408 high enough to allow rotary movements without collisions.


Error description 280-0457

Error message

Presetting not allowed!

Cause of error

- You tried to save a datum in the preset table, although this function is locked by machine parameter.
- Touch Probe Cycle 403: Setting the datum in the axis you select is not allowed. It would lead to errors during the tilting of the working plane or in connection with TCPM (M128).

Error correction

- Set the machine parameter MP7295 = 0 for the axes X, Y and Z. If necessary, consult with your machine tool builder.
- Check the compensation axis you selected. A datum can be set in the compensation axis only in the first rotary table axis (seen from the workpiece).


Error description 280-0458

Error message

Thread angle too small!

Cause of error

Sum of overrun and pitch is larger than the thread length.

Error correction

- Increase the thread length (in Cycle 831 the length of the overrun is as large as the pitch)


Error description 280-0459

Error message

3-D ROT status is contradictory!

Cause of error

The 3-D Rot status for the MANUAL and AUTOMATIC operating modes does not match.

Error correction

In 3-D Rot in the MANUAL and AUTOMATIC operating modes, set the same status (ACTIVE/INACTIVE).


Error description 280-045A

Error message

Configuration is incomplete

Cause of error

The configuration data are not prepared for this application.

Error correction

- Inform your machine tool builder.


Error description 280-045B

Error message

No turning tool is active

Cause of error

A turning tool is required for the executed function.

Error correction

- Insert a turning tool (defined via TYPE column in the tool table).


Error description 280-045C

Error message

Tool orientation is inconsistent

Cause of error

The tool orientation TO does not agree with the selected operation.

Error correction

Check the entry for the tool orientation of the turning tool and the selection ( AXIAL / RADIAL ) of the cycle being used.


Error description 280-045D

Error message

Angle not possible!

Cause of error

The entered angle is not possible.
A taper angle cannot be 0 or 180 degrees.

Error correction

- Correct the value for the entered angle.
- Enter a taper angle between 0 and 180 degree, or between 0 and -180 degrees.


Error description 280-045E

Error message

Radius too small!

Cause of error

The radius of the programmed circle is too small.
Thread milling: The offset for countersinking on the face is too small.

Error correction

- Check the programmed values for the circle block.
- Thread milling: Program an offset greater than 0 for countersinking on the face.


Error description 280-045F

Error message

Thread runout too short!

Cause of error

The thread runout is too short.
The minimum length is calculated as: thread runout * thread depth / safety clearance.

Error correction

- Increase the value for the thread runout.


Error description 280-0460

Error message

Contradictory meas. points

Cause of error

The measured points result in two parallel lines: cannot calculate an intersection.
Cannot calculate a straight line from identical measuring points.

Error correction

Choose measuring points so that all the individual points have different coordinates.
Two measuring points on a straight line have to have different coordinates.


Error description 280-0461

Error message

Too many limits

Cause of error

Too many limits were selected for face milling.

Error correction

Set no more than 3 limits for face milling.


Error description 280-0462

Error message

Machining strategy with limits not possible

Cause of error

Spiral machining strategy: face milling with limits is not possible

Error correction

Deactivate the limits or select another machining strategy.


Error description 280-0463

Error message

Machining direction not possible

Cause of error

The machining direction is not possible in compliance with the overlap factor.

Error correction

Select another machining direction.


Error description 280-0464

Error message

Check the thread pitch!

Cause of error

The programmed thread pitch differs from the thread pitch of the active tool.

Error correction

Check the value of the thread pitch (PITCH column) in the tool table.
If the value of the thread pitch for the active tool is 0, there is no monitoring.


Error description 280-0465

Error message

Angle cannot be calculated

Cause of error

The inclination angle cannot be calculated.
There is no appropriate tilting axis configured in the kinematic description.
The programmed inclination angle lies outside of the tilting axis's traverse range.
The indexable insert of the tool has been rotated.

Error correction

Check the programmed angle and the preferred direction.
Ensure that no rotation (SPB-INSERT) is entered in the tool table.


Error description 280-0466

Error message

Eccentric turning not possible

Cause of error

The control is not configured for eccentric turning.
A coupling function is already active through the machine manufacturer.
The spindle rotates while a coupling function is to be performed.

Error correction

The machine manual provides further information.
Check the entry in the configuration datum eccLimSpeedFactor or eccLimRadAcc.
Stop the spindle before performing the coupling function.


Error description 280-0467

Error message

No milling tool is active

Cause of error

The active tool is not defined as a milling cutter.

Error correction

In the tool table, check the entry in the TYPE column.
Cycle 880: The hob must be defined as a milling cutter.
Cycle 292: Without option 50, a turning tool must also be defined as a milling cutter.


Error description 280-0468

Error message

Insufficient length of cutting edge

Cause of error

The indicated tooth length of the active tool does not suffice for the machining operation.

Error correction

In the LCUTS column of the tool table, define the length of the teeth.
In Cycle 880, check the entry for Q553.
If LCUTS=0, Cycle 880 does not monitor the tooth length.


Error description 280-0469

Error message

Gear definition is inconsistent or incomplete

Cause of error

Module, tooth number and head diameter are incomplete or contradictory

Error correction

You have to enter at least 2 of the 3 parameters for module/tooth number/tip circle diameter (not equal to 0).
Check the module, tooth number and tip circle diameter , because the given values are contradictory.


Error description 280-046A

Error message

No finishing allowance provided

Cause of error

No oversize is programmed even though only finishing is selected in the machining strategy.

Error correction

Define an oversize for the finishing machining operation.


Error description 280-046B

Error message

Line does not exist in table

Cause of error

The programmed action cannot be executed because
the given table line does not exist.

Error correction

Check your NC program.
Create the given line in your preset or datum table.


Error description 280-046C

Error message

Probing process not possible

Cause of error

There is no workpiece touch probe in the spindle.
No direction or path is defined for probing.

Error correction

Insert a touch probe in the spindle.
Select the desired angle probing direction by soft key.


Error description 280-046D

Error message

Coupling function not possible

Cause of error

The commanded coupling function cannot be performed.

Error correction

A coupling function has already been activated by the machine tool builder.
The kinematic design of the axis to be coupled is not supported.
The machine manual provides further information.


Error description 280-046E

Error message

Fixed cycle is not supported by this NC software

Cause of error

The programmed machining cycle is not supported by this control.

Error correction

Cycle 290 Interpolation turning:
- Adapt the NC program - Use Cycle 291 or 292


Error description 280-046F

Error message

Touch probe cycle is not supported by this NC software

Cause of error

The programmed touch probe cycle is not supported by this NC software.

Error correction

Replacement for Cycle 441: Fast probing:
Assign a line from the touch-probe table with the desired properties to a tool index.


Error description 280-0470

Error message

NC program aborted

Cause of error

The NC program was aborted through operator action.

Error correction

If required, check the data in your NC program.
After the cancellation of the NC program, continue with NC start.


Error description 280-0471

Error message

Touch probe data incomplete

Cause of error

The data of the touch probe are incomplete or incorrectly defined.

Error correction

Check the entries of the touch probe table(TYPE column).


Error description 280-0472

Error message

LAC function not possible

Cause of error

The LAC function is not configured for this axis.

Error correction

Check whether the axis concerned exists (CfgChannelAxis-->progAxis).
Check whether LAC is activated for the axis concerned (CfgControllerComp-->enhancedComp).
Contact your machine tool builder.


Error description 280-0473

Error message

Rounding radius or chamfer is too large!

Cause of error

Input parameter Q220: Rounding radius or chamfer is too large

Error correction

Check parameter Q220 and correct the input value if required.


Error description 280-0474

Error message

Axis angle not equal to tilt angle

Cause of error

Probing function not permitted while working plane is inactive: the position of the tilted axes is not equal to 0°.
Probing function not permitted while working plane is active: the position of the tilted axes does not match the active angular values.

Error correction

Working plane is inactive: move the tilting axes to the home position.
Working plane is active: move the tilting axes to the correct position or adapt the angular values.


Error description 280-0475

Error message

Character height not defined

Cause of error

The transfer value in the input parameters Q513 “Character height” and Q574 “Text length” is 0.

Error correction

In the input parameter Q513, define the desired character height.
In the input parameter Q574, define the maximum permissible text length.
Define the value 0 for character height in Q513 if you want to scale the engraving to the value defined for text length in Q574.


Error description 280-0476

Error message

Excessive character height

Cause of error

The programmed engraving with the defined character height Q513 results in a longer text than is defined in Q574.

Error correction

Reduce the character height in Q513 so that the programmed engraving is no longer than defined in Q574.
Set the value for Q574 higher or to zero in order to make a longer engraving possible.
Enter the value 0 in Q513 if you want to scale the engraving to the text length set in Q574.


Error description 280-0477

Error message

Tolerance error: Workpiece rework

Cause of error

The probed dimension on the workpiece is outside of the defined tolerance.
Too little material was removed. The workpiece can be reworked.


Error description 280-0478

Error message

Tolerance error: Workpiece scrap

Cause of error

The probed dimension on the workpiece is outside of the defined tolerance.
Too much material was removed. The workpiece is scrap.


Error description 280-0479

Error message

Faulty dimension definition

Cause of error

The definition of a measure or a tolerance cannot be interpreted.

Error correction

Note the rules for defining a measured or tolerance.


Error description 280-047A

Error message

Illegal entry in compensation table

Cause of error

There is a faulty entry in the corresponding compensation table.
- The AXIS columns must not refer to linear axes.
- The PLC columns must contain no entries.

Error correction

Adapt the configuration or the contents of the compensation table.


Error description 280-047B

Error message

Transformation not possible

Cause of error

Some transformations between the working plane and basic coordinate system are not allowed for the function performed.
Rotations between the tool cutting edge and tool spindle, for example in the tool carrier, are not allowed.

Error correction

Remove the basic rotation and mirroring between the working plane and basic coordinate system.
Try out rotations between the tool cutting edge and the tool spindle.


Error description 280-047C

Error message

Tool spindle incorrectly configured

Cause of error

There is an error in the tool spindle configuration.

Error correction

Contact your machine tool builder.
Check whether the spindle is listed in CfgAxes/spindleIndices.
Check the attributes “progKind” and “dir” in CfgProgAxis.


Error description 280-047D

Error message

Offset of the turning spindle unknown

Cause of error

A offset set in the rotary spindle for the milling operation cannot be considered for the necessary coupling of the eccentric turning.
An offset can be defined by the workpiece datum, pallet datum or PLC datum.

Error correction

If you can ensure that no offset is needed, you can continue machining.
In order to consider the offset, the configuration must be changed. Contact your machine tool builder.
The rotary spindle must be included as axis in turning mode in the programmable axes (CfgChannelAxes/progAxes or CfgKinSimpleModel/progAxes).
This rotary axis must make reference to the active channel spindle (CfgProgAxis/relatedAxis).


Error description 280-047E

Error message

Global program settings are active

Cause of error

The selected function is not possible with active global program settings.

Error correction

Deactivate the global program settings in order to perform the selected function.


Error description 280-047F

Error message

Faulty configuration of OEM macros

Cause of error

Only one of the two macros for interpolation turning was configured.

Error correction

Contact your machine tool builder.
Configure the macro either under CfgSystemCycle OEM_INTERPTURN_ON and OEM_INTERPTURN_OFF, or don’t use either of the two macros.


Error description 280-0480

Error message

The combination of programmed oversizes is not possible

Cause of error

A combination of programmed oversizes is not possible.

Error correction

Define either an equidistant oversize or a longitudinal and transverse.


Error description 280-0481

Error message

Measured value not captured

Cause of error

No measured value was ascertained within a probing function.

Error correction

Check whether the probing process was performed.
The points can only be evaluation only if a probing process has been successfully conducted.


Error description 280-0482

Error message

Check the monitoring of the tolerance

Cause of error

A consideration of the tolerance is not possible due to an inconsistent working plane.

Error correction

Check the measurement result or correct the settings for the tilted working plane.


Error description 280-0483

Error message

Hole is smaller than the stylus tip

Cause of error

The diameter of the stylus tip is greater than the diameter of the hole to be measured.

Error correction

Use a smaller stylus tip to measure this hole.


Error description 280-0484

Error message

Preset cannot be set

Cause of error

A correct reference point cannot be written due to an inconsistent machining plane.

Error correction

Correct the setting for tilting the working plane.
This monitoring is active due to the configuration of the machine parameter CfgPresetSettings.chkTiltingAxes.
If necessary, contact your machine tool builder.


Error description 280-0485

Error message

Alignment of a rotary table is not possible

Cause of error

There is no suitable rotary table in the active machine kinematic model.
The axis of the rotary table is not perpendicular in the current workpiece coordinate system.

Error correction

Make sure that there is a rotary table axis with which you can align the workpiece.
If necessary, check whether a 3-D basic rotation prevents meaningful alignment.


Error description 280-0486

Error message

Alignment of rotary axes is not possible

Cause of error

Aligning rotary axes to a determined plane is supported only if the basic rotation is also adopted.
Aligning a rotary table is not supported if the determined angle is also to be used as a basic rotation.

Error correction

Check the values in the input parameters Q1121 and Q1126.


Error description 280-0487

Error message

Infeed limited to length of cutting edge

Cause of error

If a cutting edge length is specified in the LCUTS column in TOOL.T, the TNC restricts the infeed to this value.

Error correction

Check the value of the cutting edge length (LCUTS in TOOL.T) and the programmed infeed.
Enter the value 0 as the cutting length to switch off this monitoring.


Error description 280-0488

Error message

Machining depth defined as 0

Cause of error

There is no machining because the machining depth has been programmed with the value zero.

Error correction

Program the machining depth with a value unequal to zero.


Error description 280-0489

Error message

Tool type is unsuitable

Cause of error

In the tool table, a tool type that is not suitable for this operation is defined in the TYP column.

Error correction

Check and correct the entry in the tool table


Error description 280-048A

Error message

Finishing allowance not defined

Cause of error

No machining operation will be performed, since neither an allowance for the side nor an allowance for the depth was programmed for the finishing operation.

Error correction

Check the input parameters for the finishing allowances and the machining strategy, and correct them if required.


Error description 280-048B

Error message

Machine datum could not be written

Cause of error

The value of the machine datum (MP_refPos) cannot be changed.
The required change amount is greater than MP_maxModification/5, or MP_positionDiffRef/5.

Error correction

If you restore this data record the active machine kinematics might be inaccurate.
Check the values and make the necessary adjustments manually.
If necessary, inform your machine manufacturer.


Error description 280-048C

Error message

Spindle for synchronization could not be ascertained

Cause of error

Could not determine the spindle to be synchronized.
The spindle can be determined automatically only if exactly two spindles are configured in the system.
The spindle to be synchronized must not be the active channel spindle.

Error correction

- If more than two spindles are configured, the spindle to be synchronized must be defined in the macro OEM_CYCLGEAR_PRE.
- Contact your machine tool builder.


Error description 280-048D

Error message

Function is not possible in the active operating mode

Cause of error

The programmed function is not possible in the active operating mode.

Error correction

For example, use FUNCTION MODE MILL or FUNCTION MODE TURN to activate the operating mode intended for the programmed function.


Error description 280-048E

Error message

Oversize defined too large

Cause of error

The programmed allowance is greater than the entire machining depth.
With gear teeth the machining depth corresponds to the tooth height: tooth height = 2 * module + trough-to-tip clearance

Error correction

Check the value of the programmed allowance.


Error description 280-048F

Error message

Number of teeth not defined

Cause of error

The number of teeth has not been defined for the active tool.
The programmed machining operation requires the information about the number of teeth.

Error correction

In CUT column of the tool table, define the number of teeth.


Error description 280-0490

Error message

Machining depth does not increase monotonously

Cause of error

A calculated machining depth does not increase monotonously.
The programmed entries result in a machining depth that was already exceeded by a previous cut.

Error correction

Reduce either the first infeed or the number of infeeds.
The last infeed must be smaller than the first one.
Check the following entries:
- First infeed Q586
- Last infeed Q587
- Number of infeeds Q584


Error description 280-0491

Error message

Infeed does not decrease monotonously

Cause of error

A calculated infeed does not decrease strictly monotonously.
The programmed entries result in at least one infeed that is greater than or equal to the previous one.

Error correction

Increase the number of infeeds or the first infeed.
Reduce the last infeed.
The last infeed must be smaller than the first one.
Check the following entries:
- First infeed Q586
- Last infeed Q587
- Number of infeeds Q584


Error description 280-0492

Error message

Tool radius not defined correctly

Cause of error

The physical tool radius (sum of R and DR from the tool table) is less than zero.
If the physical tool radius equals zero, the selected machining cycle instead uses the programmed delta value DR.
The effective tool radius (sum of R and DR from the tool table and the programmed delta value DR) is less than or equal to zero.

Error correction

Enter the correct radius of the tool in the tool table.
A programmed delta value DR must not lead to an effective tool radius of less than or equal to zero.


Error description 280-0493

Error message

Mode for retraction to clearance height not possible

Cause of error

The programmed mode for retraction to clearance height will be ignored for manual pre-positioning.

Error correction

When manually pre-positioning to the probing object, make sure that this movement is without collision.


Error description 280-0494

Error message

Gear wheel definition incorrect

Cause of error

The definition of the tooth geometry is incomplete or contradicts itself.
The module and number of teeth are necessary for the definition of a gear tooth system according to DIN 3990 (ISO 6336).
Outside diameter and tooth height are optional entries.
The outside diameter must be greater than the inside diameter.

Error correction

Enter the module and the number of teeth.
If there are deviations from DIN 3990 (ISO 6336) then you can define the outside diameter and tooth height.
Check the definition of the outside diameter and tooth height.


Error description 280-0495

Error message

Probing object contains different types of dimension definition

Cause of error

You didn't use the same type of dimension definition for all coordinates of an object to be probed.
- For manual pre-positioning: Enter a question mark (?) at the beginning of a dimension definition in order to define manual pre-positioning.
- For defining the actual position: Enter the at sign (@) after stating the nominal position in order to define the actual position.

Error correction

You must program the same type of dimension definition in the principal, secondary, and tool axes of an object to be probed.
Correct the faulty dimension definition.


Error description 280-0496

Error message

Dimension definition contains impermissible characters

Cause of error

A dimension definition contains impermissible characters.
- More than one decimal separator is in a value.
- There are additional characters after the dimension definition.
- Impermissible characters were used.

Error correction

Correct the dimension definition.
Example for freely toleranced dimension: "20-0.01+0.02"
Example for ISO 286: "20H7"
Example for general tolerance in accordance with ISO 2768: "20m"


Error description 280-0497

Error message

Actual value in dimension definition faulty

Cause of error

The actual value is not indicated correctly in a dimension definition:
- The preceding delimiter '@' is missing.
- The definition of a value after the delimiter '@' is missing.
The indicated Q parameter may not be used after the delimiter.

Error correction

Correct the definition of the actual value.
You can only use Q1900 to Q1999 to transfer variable values.


Error description 280-0498

Error message

Starting point of hole too deep

Cause of error

The starting point Q379 of a hole is defined to be larger or equivalent to the total depth Q201 of the hole.
The dwell depth Q435 is less than or equal to the starting point Q379.

Error correction

Define the starting point to be within the specified hole depth.
Define the dwell depth to be greater than the starting point and less than the machining depth.


Error description 280-0499

Error message

Dimension def.: Nominal value missing for manual pre-positioning

Cause of error

When probing with manual pre-positioning, the nominal values are missing for all directions at one position.

Error correction

Define a nominal value for at least one direction.
You should define a nominal value in at least the directions that you can specify exactly with the probing process.
For manual pre-positioning, define the nominal value after the '?'.


Error description 280-049A

Error message

A replacement tool is not available

Cause of error

The programmed tool is locked or the tool life has expired and no replacement tool is available.

Error correction

Check the columns TL, RT, CUR_TIME, and TIME2 of the programmed tool.
If you programmed a tool number then the replacement tool is defined in the column RT.
If you are using a tool name then define the same name for the replacement tool.


Error description 280-049B

Error message

OEM macro is not defined

Cause of error

No macro is configured for this cycle.

Error correction

- In CfgSystemCycle, enter a key for the corresponding macro:
- Cycle 238 requires a key with the name OEM_MACHSTAT_MEAS.
- Simultaneous finishing with FreeTurn tools requries a key with the name OEM_FREETURN_SIMUL_ON and OEM_FREETURN_SIMUL_OFF.
- Contact the machine tool builder.


Error description 280-049C

Error message

Measurement not possible with auxiliary axis

Cause of error

An OEM macro defined an axis to be measured that is not possible with this type of measurement.
This measurement cannot be performed with auxiliary axes (PLC axes).

Error correction

- Change the type of measurement or the axis to be measured
- Contact your machine tool builder


Error description 280-049D

Error message

Start position not possible with modulo axis

Cause of error

The movement commanded in the OEM macro leads through the zero crossover of a modulo axis.

Error correction

- Pre-position the modulo axis such that the commanded movement does not lead through the zero crossover
- Contact your machine tool builder


Error description 280-049E

Error message

Function only possible if door is closed

Cause of error

The function you selected can be executed only if the guard doors are closed.

Error correction

Close the guard doors.


Error description 280-049F

Error message

Number of possible records exceeded

Cause of error

Not enough memory is available in order to process the data.
Cycle 453: Excessive number of measuring points.

Error correction

Reduce the number of records.
Cycle 453: Reduce the number of rows in the compensation table (*.kco).
Contact your machine tool builder.


Error description 280-04A0

Error message

Inconsistent machining plane due to axis angle with basic rot.

Cause of error

Tilting the working plane with axis angles in combination with a basic rotation leads to an inconsistent working plane.
The axis angles do not match the tilting angles. This can lead to flawed machining operations.

Error correction

Avoid the combination of a basic rotation and tilting the working plane with axis angles.


Error description 280-04A1

Error message

Transfer parameter contains an impermissible value

Cause of error

A transfer parameter from an OEM macro to the cycle is not in the permitted range.

Error correction

- Check the values transferred from the OEM macro to the cycle
- Contact your machine manufacturer


Error description 280-04A2

Error message

Tooth width RCUTS is defined too large

Cause of error

The tooth width RCUTS is defined too large for helical or reciprocating plunging in cycles 251 to 254.

Error correction

For helical or reciprocating plunging the tooth width must be less than the tool radius
Correct the value for tooth width RCUTS in the tool table.


Error description 280-04A3

Error message

Usable length LU of the tool is too small

Cause of error

The programmed machining depth is greater than the usable length of the tool.

Error correction

Check the usable length LU in the tool table.
Correct the machining depth or use a different tool.


Error description 280-04A4

Error message

The defined chamfer is too large

Cause of error

The programmed chamfer is too large.

Error correction

Define a greater machining depth for the tip of the tool.
Use a tool with a larger radius.


Error description 280-04A5

Error message

Chamfer angle cannot be machined with the active tool

Cause of error

The programmed angle of the chamfer cannot be machined with the active tool.

Error correction

Check the value in input parameter Q354:
The chamfer angle must be half of the point angle (T-ANGLE) of the tool.
Enter the value 0 in Q354 in order to create a chamfer with half of the point angle (T-ANGLE) of the tool.


Error description 280-04A6

Error message

The allowances do not define any stock removal

Cause of error

No stock removal is defined.
The programmed allowance at the beginning of the machining operation is not greater than the allowance remaining at the end of the operation.

Error correction

Define the lateral allowance at the beginning of the machining operation (Q368) to be greater than the allowance at the end of the operation (Q14).


Error description 280-04A7

Error message

Spindle angle not unique

Cause of error

You tried to orient the tool spindle even though the relative position between the input and tool coordinate systems prevents an unambiguous determination of the spindle angle.
During a probing operation the center offset (CAL_OF1 and CAL_OF2) defined for the touch probe cannot be taken into account correctly.

Error correction

Avoid a spindle orientation under these conditions:
- Status of the transformations and position of tilting axes
- Active turning operation
Probing:
- Exactly align the touch probe mechanically and do not define any values for the center offset (CAL_OF1 and CAL_OF2).


Error description 280-04A8

Error message

Internal software error: wrong or faulty command

Cause of error

An internal software error has occurred.
An unexpected or faulty command was received.

Error correction

Inform your service agency


Error description 280-04A9

Error message

Probing procedure is not possible

Cause of error

The defined probing procedure cannot be performed with the active tool.

Error correction

Check whether the active tool is a touch probe.
If the tool is not a touch probe, then you can apply the current coordinates with the actual position capture key.


Error description 280-04AA

Error message

Type of the object to be probed is not possible

Cause of error

The type of the object selected to be probed cannot be probed in this situation.

Error correction

Select a different object to be probed.
- Inform your service agency.


Error description 280-04AB

Error message

Input value not permitted

Cause of error

One of the input values is not in the valid range.

Error correction

Check and correct the input values.


Error description 280-04AC

Error message

No data available for processing

Cause of error

No data found to be processed.

Error correction

Select the rows with the data you want to process.
Enter nominal values for the processing.


Error description 280-04AD

Error message

Object to be probed cannot be repeated

Cause of error

The object you selected to be probed cannot be re-probed.
Changes to the basic rotation or the rotary-axis offset prevent correct calculation of the overall result.

Error correction

If necessary, re-probe all objects to be probed with the probing function.


Error description 280-04AE

Error message

Limitation for island missing

Cause of error

In the definition of an island, the associated boundary is missing.

Error correction

Use Cycles 1281 or 1282 to define a boundary geometry for an island (Q650=1).


Error description 280-04AF

Error message

Cannot process the data

Cause of error

The selected information cannot be used by this processing method.
A basic rotation or an offset cannot be written to a datum table.
A basic rotation cannot be written to a pallet preset.
The combination of offset and shift (X,Y,Z) cannot be written to a pallet preset.

Error correction

Change the information selected.
Use a different processing method.


Error description 280-04B0

Error message

Rotation of the tool coordinate system not permitted

Cause of error

An impermissible rotation of the tool coordinate system is in effect.
This rotation can result in an improper motion during lift-off.

Error correction

Reset this rotation, for example with Cycle 801.
Contact your machine tool builder.


Error description 280-04B1

Error message

NC Start was ignored

Cause of error

NC Start was ignored since the current situation does not permit it.

Error correction

- Check the entries and correct them if necessary
- Only press NC Start when the operational situation permits it


Error description 280-04B2

Error message

Circle cannot be calculated

Cause of error

Could not calculate a circle from the measured points.
The number of points or the distance between them is insufficient.

Error correction

Check the number and positions of the points for circle calculation.


Error description 280-04B3

Error message

Probing of an extrusion not possible

Cause of error

An extrusion that cannot be probed was defined as probing object.
An extrusion cannot be combined with a manual pre-positioning task for which a '?' is programmed in the position definition.

Error correction

Check your entries in Cycle 1493.
Check the definition of the position of the probing object.


Error description 280-04B4

Error message

Nominal position not defined correctly

Cause of error

No nominal position is defined, or it contains tolerances.

Error correction

Enter a nominal position for all coordinate directions.
Enter a tolerance along the surface-normal vector instead of for the nominal position.


Error description 280-04B5

Error message

Retraction behavior not possible with multiple plunging

Cause of error

Only linear retraction is possible with multiple plunging.

Error correction

If necessary, adjust the input parameters Q462 Retraction mode and Q562 Multiple plunging.


Error description 280-04B6

Error message

Basic rotation will be rescinded

Cause of error

A basic rotation is in effect in the active preset.
In order for the sequence to work correctly, the called probing cycle requires that this basic rotation be rescinded.

Error correction

Check your entries.
Clear this message and press NC-START in order to rescind the basic rotation and continue with the probing cycle.
Or perform an internal stop in order to cancel the probing cycle and check your entries.


Error description 280-04B7

Error message

Repeat last measurement?

Cause of error

The last measurement could not be performed correctly.

Error correction

Refer to the preceding messages concerning the last measurement.
You can acknowledge these messages and then repeat the last measurement with NC Start.


Error description 280-04B8

Error message

Continue with next measurement?

Cause of error

This measurement cannot be performed correctly.

Error correction

Refer to the preceding messages concerning the measurement.
Check the configuration for this measurement.
You can acknowledge these messages and jump to the next measurement with NC Start.


Error description 280-04B9

Error message

File not found

Cause of error

The specified file could not be found.

Error correction

Ensure that the specified file exists and that the given path is correct.


Error description 280-04BA

Error message

The entire plunging depth is greater than the tooth height

Cause of error

The sum of the defined infeeds does not match the tooth height.
Twice the tooth height results from the difference between the outside diameter and the inside diameter.
If the total infeed is greater than the tooth height, the machining operation is not carried out.
If the total infeed is less than the tooth height, the machining operation can still be carried out.

Error correction

Check the sum of all infeeds in the INFEED column, and correct them if necessary.


Error description 280-04BB

Error message

The entire plunging depth is less than the tooth height

Cause of error

The sum of the defined infeeds does not match the tooth height.
Twice the tooth height results from the difference between the outside diameter and the inside diameter.
If the total infeed is greater than the tooth height, the machining operation is not carried out.
If the total infeed is less than the tooth height, the machining operation can still be carried out.

Error correction

Check the sum of all infeeds in the INFEED column, and correct them if necessary.


Error description 280-04BC

Error message

File cannot be opened

Cause of error

Could not open the file specified in the cycle.

Error correction

Check whether the file is there, whether the path is correct, and whether the file is in a readable format.


Error description 280-04BF

Error message

Status of transformations for simultaneous turning is not correct

Cause of error

The status of the transformations is not correct for the requested simultaneous turning operation with a FreeTurn tool.
TCPM must be activated before the cycle can run.
Before the cycle was run, a transformation was activated that is not possible with this type of operating mode.

Error correction

Activate TCPM before calling the cycle.
Check your corrections in the WPL-CS, such as: FUNCTION CORRDATA WPL.


Error description 280-04C0

Error message

Preset cannot be modified after probe objects have been probed

Cause of error

The modifications to the preset are not possible.
Modifications to the preset are only possible as long as no object has been probed yet.

Error correction

Discard objects that have already been probed by ending the manually selected probing function.
Then you can make the changes to the preset.


Error description 280-04C1

Error message

Tolerance does not match probing direction

Cause of error

The result of a probing motion is outside of the tolerance, and the direction of the probing motion does not match the defined tolerance.

Error correction

Check the programmed tolerances regarding the defined probing direction and the extrusion direction.


Error description 280-04C2

Error message

Offset in pallet reference point not permitted

Cause of error

Setting up of a workpiece with an offset in the active pallet preset is not permitted.

Error correction

When setting up workpieces, use pallet presets with spatial angles instead of offsets.


Error description 280-04C3

Error message

Global program settings are active

Cause of error

A workpiece cannot be set up if global program settings are active.

Error correction

Deactivate global program settings in order to run the selected function


Error description 280-04C4

Error message

Global program settings are active

Cause of error

Activating the global program settings function can falsify measurement results.

Error correction

HEIDENHAIN recommends deactivating the global program settings before using the function


Error description 280-04C5

Error message

Cycle can be executed only in the Testing mode

Cause of error

In the current machine state, this cycle can be executed only in the Testing mode.
The corresponding software option is missing for further modes, or the machine configuration has not been adapted correctly.

Error correction

Contact your machine manufacturer in order to use other modes.


Error description 280-04C7

Error message

Tool carrier can't be monitored correctly

Cause of error

The tool carrier defined in the "KINEMATIC" column cannot be considered correctly in the current constellation,
since the tool spindle is configured as a spindle and the turning tool will be reversed in Cycle 800 (Q498=1).
This can have an effect on collision monitoring and the path calculations of turning cycles.

Error correction

Check the effects precisely and change the conditions, if necessary.
If needed, you can add a new index to your turning tool in the tool management.
In this index you define your turning tool rotated by 180°, so that you can use Q498=0 in Cycle 800.


Error description 280-04C8

Error message

Probing function doesn't support stylus type

Cause of error

A stylus type that is not supported by the selected probing function is entered in the STYLUS column of the touch probe table.

Error correction

Check the stylus type entered.
Use a probing function that supports the entered stylus type.


Error description 280-04C9

Error message

Slot smaller than stylus tip

Cause of error

The diameter of the stylus tip is greater than the width of the slot to be measured.
For the STYLUS L-TYPE, the diameter of the stylus tip plus center offset is greater than the width of the slot to be measured.

Error correction

Use a smaller stylus tip to measure this slot.
For the STYLUS L-TYPE, use a smaller center offset to measure this slot.


Error description 280-04CA

Error message

Determination of machine datum with inclination angle not 0

Cause of error

When executing Cycle 451 with mode Q406=3, the machine datum is corrected for a rotary axis.
However, the inclination angle (Q413, Q417, Q421) programmed in the cycle deviates from the machine datum.

Error correction

If you don't determine the machine datum of a rotary axis at its home position, unfavorable results can occur.
Check the cycle entries and change the values in Q413, Q417 or Q421 to 0 if necessary.


Error description 280-04CB

Error message

Feed-rate potentiometer is effective for L stylus!

Cause of error

The entry in machine parameter CfgProbes/overrideForMeasure makes the feed-rate potentiometer effective for probing procedures.
You achieve the maximum accuracy by using the same speed for calibration and for actual probing.

Error correction

Please ensure that the feed-rate potentiometer is always at 100% (if possible) when probing with an L stylus.
Contact your machine manufacturer to configure the machine parameter CfgProbes/overrideForMeasure.


Error description 280-04CC

Error message

Spindle orientation not possible

Cause of error

A touch probe with an L stylus requires spindle orientation (TRACK=ON)
In its current state, the machine does not support spindle orientation.
Spindle orientation is not defined for the touch probe.

Error correction

Check the entry in the TRACK column of the touch probe table.
Perhaps use the touch probe only in milling mode.
Contact your machine manufacturer to configure the machine parameter mStrobePos for the active spindle.


Error description 280-04CD

Error message

Touch point not reached

Cause of error

The defined touch point could not be reached.
The program was not aborted, since the corresponding error message is being suppressed with Q371 in Cycle 441.

Error correction

In order to proceed with the operation correctly, use Q183 to evaluate the status of the probing cycle in the NC program.


Error description 280-04CE

Error message

Probe cycle started with stylus already deflected

Cause of error

You tried to start a probing cycle although the stylus is still deflected.

Error correction

Increase the retraction path


Error description 280-04CF

Error message

Not a valid row for a preset

Cause of error

No preset is active.
An invalid row of a workpiece or pallet preset table was transferred.

Error correction

In order to activate a preset, you must first select the desired row.


Error description 280-05DC

Error message

Error in pallet management

Cause of error

Internal control error.

Error correction

Inform your service agency.


Error description 280-05DD

Error message

Error in pocket table

Cause of error

Error in pocket table:
- Pockets or tools appear twice.
- There is no value in column T for the spindle pocket.
- The tool in the spindle is not in the tool table.
- The TOOL_P symbol does not point to a pocket table or it is not set.
- The pocket table is write-protected or it does not exist.

Error correction

- Correct the pocket table.
- There is no value in column T for the spindle pocket.
- The tool in the spindle is not in the tool table.
- The TOOL_P symbol does not point to a pocket table or it is not set.
- The pocket table is write-protected or it does not exist.


Error description 280-05DE

Error message

Fixture not activated

Cause of error

Pallet changer: The started NC program belongs to a fixture that is not on the pallet.

Error correction

Activate the correct fixture.


Error description 280-05DF

Error message

Wrong pallet

Cause of error

Pallet changer: The NC program that was started belongs to a pallet that is not at the machining position.
The LOCATION column of the pallet table does not contain "MA".

Error correction

Change to the proper pallet (LOCATION == MA).


Error description 280-05E0

Error message

Pallet line locked!

Cause of error

You attempted to run a locked pallet line.

Error correction

To resume program run, unlock the line or continue with the next line. If necessary, refer to your machine manual.


Error description 280-05E1

Error message

Datum table missing

Cause of error

You selected a datum table that does not exist in the control's NC memory.

Error correction

Select an existing datum table or make the desired table.


Error description 280-05E2

Error message

Measuring probe not defined

Cause of error

- You called a touch probe that is not defined in the touch probe table.
- The touch probe table is write-protected or it does not exist.

Error correction

- Add the missing touch probe to the touch probe table.
- Create a touch probe table or cancel the write protection.


Error description 280-05E3

Error message

Incorrect tool data

Cause of error

Incorrect tool data:
- Tool appears twice.
- TOOL symbol does not point to a tool table or it is not set.
- The tool table is write-protected or it does not exist.
- Tool table is locked because of the Test Run or Programming operating mode.

Error correction

- Correct the tool table.
- Reassign the TOOL symbol or create an equivalent tool table.
- Create a tool table or cancel the write protection.
- Close the the Test Run or Programming operating mode.


Error description 280-05E4

Error message

Tool number 0 not permitted

Cause of error

A tool definition with the number "0" is not permitted.

Error correction

Edit the part program.


Error description 280-05E5

Error message

Tool not defined

Cause of error

You have called a tool that is not defined in the tool table.

Error correction

- Add the missing tool to the tool table.
- Use another tool.


Error description 280-05E6

Error message

No appropriate tool found

Cause of error

Automatic tool search: No suitable tool was found in the tool table.

Error correction

Check the tool table.


Error description 280-05E7

Error message

Calculated tool number too large

Cause of error

- Calculation of a tool number from a Q parameter resulted in a value outside the permissible range of 0 to 32767.
- You have called a tool number that is greater than the number of tools defined in the tool table.

Error correction

Edit the part program.


Error description 280-05E8

Error message

Tool definition is missing

Cause of error

In a TOOL CALL (ISO: T..) you entered a tool number for which there is no definition in the program.

Error correction

Edit the part program.


Error description 280-05E9

Error message

Tool number already assigned

Cause of error

You attempted to give a tool more than one definition.

Error correction

Edit the part program.


Error description 280-05EA

Error message

Tool definition not permitted

Cause of error

You programmed a tool definition with radius or length (TOOL DEF, ISO: G99).

Error correction

- Delete the TOOL DEF block (G99 block).
- Use the tool preselection without radius and length(TOOL DEF, ISO: G51).


Error description 280-05EB

Error message

TOOL DEF w/o length or radius

Cause of error

The definition of a tool (TOOL DEF, ISO: G99) is missing the value for tool length or tool radius.

Error correction

Complete the TOOL DEF block (G99 block).


Error description 280-05EC

Error message

Max. tool age expired

Cause of error

The service life of the called tool has expired and you have not defined a replacement tool.

Error correction

Check the tool and, if necessary, exchange it or define a replacement tool.


Error description 280-05ED

Error message

Tool locked

Cause of error

The tool was locked (e.g. after breakage).

Error correction

Check the tool and, if necessary, change it or unlock it in the tool table.


Error description 280-05EE

Error message

Tool table is missing

Cause of error

Either you did not select a tool table or the selected table is not in the control's NC memory.

Error correction

Select an available tool table or create one.


Error description 280-05EF

Error message

FN14_1519

Cause of error

FN14_1519

Error correction

FN14_1519


Error description 280-05F0

Error message

Helical plunging not possible

Cause of error

Q366 = 1

Error correction

Edit the part program


Error description 280-05F1

Error message

FN14_1521

Cause of error

FN14_1521

Error correction

FN14_1521


Error description 280-05F2

Error message

No touch probe data

Cause of error

- No touch probe inserted
- No tool axis active for the touch probe
- Contradictory touch probe data

Error correction

- Insert the touch probe
- Define the tool axis in the touch probe call
- Check the touch probe data


Error description 280-05F3

Error message

SQL command failed

Cause of error

An SQL command used in the cycle could not be executed.

Error correction

Inform your service agency.


Error description 280-05F4

Error message

FN14_1524

Cause of error

FN14_1524

Error correction

FN14_1524


Error description 280-05F5

Error message

FN14_1525

Cause of error

FN14_1525

Error correction

FN14_1525


Error description 280-05F6

Error message

FN14_1526

Cause of error

FN14_1526

Error correction

FN14_1526


Error description 280-05F7

Error message

Error in pallet management

Cause of error

Error in pallet management:
- The pallet table does not exist or is write-protected.
- TARGET and FN17/18 ID510 NR22 are used simultaneously in the PAL row.

Error correction

- Create a pallet table or cancel write-protection.
- Do not use TARGET and FN17/18 ID510 NR22 simultaneously in the PAL row.


Error description 280-05F8

Error message

Error in preset table

Cause of error

The preset table is faulty. Possible causes:
- The preset table is write-protected or it does not exist.
- Line 0 does not exist.
- The is no line with ACTNO = 1.

Error correction

- Please make the preset table or cancel the write protection
- Enter the line 0 in the preset table
- Set ACTNO in one line to zero


Error description 280-05F9

Error message

Incorrect datum table

Cause of error

Incorrect datum table:
- The datum table is write-protected or it does not exist.

Error correction

- Create a datum table or cancel the write protection.


Error description 280-05FA

Error message

Tool change during mid-program startup not possible

Cause of error

Tool change not possible during mid-program startup. The active tool is not in the spindle for program run after mid-program startup.

Error correction

Please contact your machine tool builder.


Error description 280-05FB

Error message

Calibrate touch probe

Cause of error

You tried to automatically measure a tool although the tool touch probe is not yet calibrated.

Error correction

Calibrate the TT tool touch probe with the cycle TCH PROBE 30.


Error description 280-05FC

Error message

Tool axis is missing

Cause of error

You called a fixed cycle without first activating a tool.

Error correction

Edit the NC program.


Error description 280-05FD

Error message

CYCL DEF incomplete

Cause of error

- You deleted part of a cycle
- You inserted other NC blocks within a cycle

Error correction

- Redefine the complete cycle
- Delete NC blocks within a cycle


Error description 280-05FE

Error message

TOOL.T: Enter number of teeth

Cause of error

Automatic tool measurement: Number of teeth not entered into tool table.

Error correction

Enter the number of teeth (CUT) into TOOL.T.


Error description 280-05FF

Error message

Enter tool radius greater than 0

Cause of error

You defined the cutter radius for the active tool in the tool table as less than or equal to 0.

Error correction

You can only measure a tool with a positive radius. Change the radius in the table.


Error description 280-0600

Error message

Tolerance in the parameter measureTolerance[1;2] is too low

Cause of error

The tolerance entered in the "measureTolerance1" parameter cannot be achieved during tool radius measurement with the TT.

Error correction

- Increase the permissible tolerance for finding tool teeth with spindle orientation in the "measureTolerance2" parameter
- Reduce the positioning window of the spindle in the "posTolerance" parameter
- Check whether a burr has formed on the probe contact. Remove the burr, if there has.
- Exchange the tool touch probe, if required


Error description 280-0601

Error message

Tool locked

Cause of error

The tool was locked (e.g. after breakage).

Error correction

Check the tool and, if necessary, change it or unlock it in the tool table.


Error description 280-0602

Error message

Error in tool measurement configuration

Cause of error

The configuration of the tool measurement is incorrect or incomplete.

Error correction

Check the tool measurement configuration and edit or extend it, if required.


Error description 280-0603

Error message

Tool measurement locked

Cause of error

Tool measurement is disabled.

Error correction

Check the tool measurement configuration and edit it, if required.


Error description 280-0604

Error message

Tool measurement: Functionality not yet implemented

Cause of error

The desired functionality is not implemented.
- The tool axis is not the Z axis. (NC program: TOOL CALL)
- Sum of "YL + DYL" is greater than +/– 5.0 mm. (Tool table)
- Value of SPB-INSERT does not equal 0 degrees. (Tool table)
- Value of ANGLE is greater than 90 degrees or sum of ANGLE + PANGLE is greater than or equal to 180 degrees. (Tool table)
- The value TO is not supported for tool types. (Tool table)
- The value of stylusAxis is not Z_Positive. (Configuration)

Error correction

Check the NC program, tool table, and tool measurement configuration and edit them as necessary.


Error description 280-0605

Error message

Orientation not configured

Cause of error

- Your machine might not offer spindle orientation
- Spindle orientation not possible

Error correction

- Refer to your machine manual!
- Check the "spindleOrientMode" machine parameter and use the NC to enter -1 or the value of the M function for spindle orientation.


Error description 280-0606

Error message

Arithmetical error

Cause of error

Internal calculations have resulted in a non-representable numerical value.

Error correction

Check the input values.


Error description 280-0607

Error message

Cycle error

Cause of error

Internal control error

Error correction

Inform your service agency


Error description 280-0608

Error message

Tool broken

Cause of error

Automatic tool measurement: The breakage tolerance (LBREAK or RBREAK) from the tool table was exceeded.

Error correction

Check the tool and, if necessary, replace it.


Error description 280-0609

Error message

Calibrate TT in tilted plane

Cause of error

You attempted to run a cycle for tool measurement while the tilted-plane function was active, although the touch probe was not calibrated in the tilted working plane.

Error correction

Run the calibration cycle 30 while the working plane is tilted.


Error description 280-060A

Error message

Calibrate TT in non-tilted plane

Cause of error

You attempted to run a cycle for tool measurement, although the touch probe was last calibrated in a tilted working plane.

Error correction

Run the calibration cycle 30 when the working plane is not tilted.


Error description 280-060B

Error message

TT not parallel to tool axis

Cause of error

You attempted to run a cycle for tool measurement although the touch probe axis is not parallel to the tool axis.

Error correction

Position the axes so that the touch probe axis and tool axis are parallel.


Error description 280-060C

Error message

Tool index not allowed

Cause of error

You called a fixed cycle for tool measurement with a step drill.


Error description 280-060D

Error message

Turning tool incompletely defined

Cause of error

- You called a turning tool that is not defined in the turning tool table.
- The turning tool table is faulty or missing.

Error correction

- Add the missing tool to the turning tool table.
- Create or correct the turning tool table.


Error description 280-060E

Error message

Probing direction not in probe plane

Cause of error

You configured a probing direction that does not lie in the touch probe plane.

Error correction

Correct the machine parameter probingDirRadial


Error description 280-060F

Error message

Unbalance detection failed

Cause of error

Fehler bei Unwuchterfassung aufgetreten

Error correction

Weitere Fehlermeldungen beachten


Error description 280-0610

Error message

Excessive unbalance

Cause of error

Maximum unbalance amplitude exceeded

Error correction

Detect the unbalance again, with compensation


Error description 280-0611

Error message

Configuration for unbalance detection wrong

Cause of error

The configuration of the unbalance detection is incorrect or incomplete.

Error correction

Check the unbalance detection configuration and edit or extend it, if required.


Error description 280-0612

Error message

Radius of replacement tool not suitable

Cause of error

- During automatic exchange of a replacement tool (M101), the TNC did not find a suitable tool in the tool table.
- The total radius R + DR of the replacement tool is greater and/or R2 + DR2 is less than the radius of the current tool when 3-D compensation is active.

Error correction

- Define a replacement tool with suitable radii.
- Perhaps use M107 to deactivate monitoring of the tool radii.


Error description 280-0613

Error message

Invalid tool axis programmed

Cause of error

You have programmed a tool axis other than Z.

Error correction

Edit the NC program.


Error description 280-0614

Error message

Tool table locked

Cause of error

The tool file (TOOL.T) cannot be edited while the TNC is executing a tool call. Pressing the EDIT ON/OFF soft key provokes this error message.

Error correction

Exit the mode by selecting the "EDIT ON/OFF" soft key.
Then acknowledge the message and resume program run with NC Start.


Error description 280-0615

Error message

Unbalance calculation failed

Cause of error

An error occurred while calculating the unbalance. The entered value is not in the unbalance table.

Error correction

- Modify the entered value
- Expand the unbalance table


Error description 280-0616

Error message

Tool must not be altered

Cause of error

A change of tool number or tool index is not allowed at present. This test was activated by the machine tool builder within the TOOL CALL macro.

Error correction

Inform your machine tool builder


Error description 280-0617

Error message

Traverse mode for retraction not possible

Cause of error

The “tilted system” and “tool axis” traverse modes are not possible because of the machine configuration.

Error correction

Select the “machine axes” or “thread” traverse modes and repeat the retraction.


Error description 280-0618

Error message

Tool life expired

Cause of error

The remaining tool life is not enough for the precalculated machining time.
- The service life of the called tool is insufficient and you haven’t defined a sister tool.
- The tool-usage file is not available or not up to date.

Error correction

- The tool is to be used anyway: acknowledge the message and continue the NC program with NC start.
- The tool is not to be used: cancel the NC program with an INTERNAL STOP.
o Check the tool and, if necessary, exchange it or define a replacement tool.
o Create or update a tool-usage file. Run the desired program in the
Test Run mode of operation. Ensure that creation of a tool usage file is activated in the configuration.


Error description 280-0619

Error message

Tool life expired

Cause of error

The remaining tool life is not enough for the precalculated machining time.
- The service life of the called tool has expired and you have not defined a sister tool.
- The tool usage file is not available or not up to date.

Error correction

- Check the tool and, if necessary, exchange it or define a sister tool.
- Create or update a tool usage file.
- Run the desired program in the Test Run mode of operation.
- Ensure that the tool usage file is activated in the configuration.


Error description 280-061A

Error message

Feed rate limiting has been canceled

Cause of error

- Feed rate limiting was canceled by the operator.
- Reactivation of the feed rate limiting is not possible in the Retraction operating mode.

Error correction

- Use the feed rate potentiometer F to limit the feed rate.
- Be very careful when moving the axes.


Error description 280-061B

Error message

Pallet line with completed part

Cause of error

The pallet line under the cursor is marked as a completed part and can therefore no longer be executed.

Error correction

Select a pallet line in which a workpiece blank or an incomplete part is entered.


Error description 280-061C

Error message

Access to pallet preset table failed

Cause of error

Access to pallet preset table was not possible.
The pallet preset table might not exist or is faulty.

Error correction

Inform your service agency.


Error description 280-061D

Error message

Automatic continuation of pallet machining not possible

Cause of error

Automatic continuation of pallet machining not possible.

Error correction

- Pallet machining was not continued by the OEM cycle.
- Check the entry for the OEM macro in OEM_PAL_RESUMPTION.
- Inform your service agency.


Error description 280-061E

Error message

Strategy for continuing the pallet machining is not supported


Error description 280-061F

Error message

Thread-cutting process was interrupted

Cause of error

Automatic continuation of pallet machining not possible.

Error correction

- Note any further error messages.
- Correct the cause of error and repeat the operation.
- Inform your service agency.


Error description 280-0620

Error message

Pallet table locked

Cause of error

An editor locked any further execution of the pallet table

Error correction

- Exit the editing or input mode
- Then acknowledge the message and resume the pallet machining with NC start.


Error description 280-0621

Error message

Tool not defined completely

Cause of error

You called a tool that is not completely defined in the tool table:
- There is no value for the tool radius and/or length.

Error correction

- Check and complete the tool entries.
- Use another tool.


Error description 280-0622

Error message

Row does not exist in preset table

Cause of error

Could not activate the programmed preset. The given line does not exist in the preset table.

Error correction

- Check the preset table
- Add the given line to the preset table.


Error description 280-0623

Error message

Row does not exist in pallet preset table

Cause of error

Could not activate the programmed number of the pallet preset.
The given line does not exist in the pallet preset table.

Error correction

- Check the pallet preset table
- Add the given line to the pallet preset table.


Error description 280-0624

Error message

Preset table not found

Cause of error

Could not open the preset table selected for the test run.

Error correction

- Select existing preset table again, or
- Create a new preset table


Error description 280-06A4

Error message

Camera not reacting

Cause of error

The image processing cycle cannot communicate with the camera or does not answer.

Error correction

Restart the NC software or remove the image processing cycle from the NC program.
- Inform your service agency.


Error description 280-06A5

Error message

Camera not responding

Cause of error

The image processing cycle cannot communicate with the camera or does not answer.

Error correction

Restart the NC software or remove the image processing cycle from the NC program.
- Inform your service agency.


Error description 280-06A6

Error message

File for camera position does not exist

Cause of error

The control cannot move the camera to the desired position
because the table with the position data is missing.

Error correction

Inform your service machine tool builder.


Error description 280-06A7

Error message

Line does not exist in the position table

Cause of error

The control cannot move the camera to the desired position because the desired line number is missing in the table for position data.

Error correction

Inform your machine tool builder


Error description 280-06A8

Error message

Communication with camera not possible

Cause of error

The image processing cycle cannot communicate with the camera
because the internal data structure for communication is missing.

Error correction

- Inform your service agency.


Error description 280-06A9

Error message

Camera provides no images

Cause of error

No live image was received from the camera.

Error correction

- Test whether the live image is shown correctly in the Manual operating mode
- If this is not the case, restart the control
- If both actions don't help, contact your service agency


Error description 280-06AA

Error message

A name for the monitoring point is missing

Cause of error

The monitoring point has no name

Error correction

Enter a name for the monitoring point in the image processing cycle


Error description 280-06AB

Error message

Not allowed to call an unbalance cycle in milling mode

Cause of error

A unbalance cycle cannot be started in milling mode

Error correction

Start the unbalance cycle in turning mode


Error description 280-07D0

Error message

Invalid error consequence

Cause of error

Invalid error consequence

Error correction

Internal error


Error description 280-07D1

Error message

No space released

Cause of error

No location released for inserting the tool.
On the wheel head there are no are no locations released for inserting the grinding wheel.
Error correction: Release locations for inserting the tool (table: WHEEL.PGW).

Error correction

Release locations for inserting the tool (table: WHEEL.PGW).


Error description 280-07D2

Error message

No valid physical space

Cause of error

No valid, physical location on wheel head.
Selected location on wheel head is invalid. Location number is greater than 9.

Error correction

Select valid location (0...9).


Error description 280-07D3

Error message

Space not released

Cause of error

Location for inserting the tool not released.
The selected location on the wheel head has not been released and therefore cannot be accept a grinding wheel.

Error correction

Select another location for insertion.


Error description 280-07D4

Error message

Tool is already inserted

Cause of error

The tool to be inserted is already clamped in another location.

Error correction

Select another tool (other tool number) or remove the tool from another location (not only physical, but also logical).


Error description 280-07D5

Error message

No space released

Cause of error

No released location found.
No other vacant location was found on the wheel head.

Error correction

Remove tool from another location and use the set-up function to release the location.


Error description 280-07D6

Error message

No identical space

Cause of error

No released, identical location found.
There is no other logical location on the wheel head with the same physical position.

Error correction

Remove tool from another location and use the set-up function to release the location.


Error description 280-07D7

Error message

No further tool found

Cause of error

No other tool found that meets the search criteria.

Error correction

Adapt the search criteria.


Error description 280-07D8

Error message

No further tool found

Cause of error

No tool found that meets the search criteria.

Error correction

Adapt the search criteria.


Error description 280-07D9

Error message

Invalid tool type

Cause of error

An unsupported tool type was selected, or the tool type is not permitted together with a function.

Error correction

Check the tool type.


Error description 280-07DA

Error message

Tool type not allowed

Cause of error

Tool type not allowed, not released.
In the set-up function a tool was selected that is not supported at present.

Error correction

Select another tool type.


Error description 280-07DB

Error message

Data not loaded

Cause of error

Data were not accepted because the tool number was changed.
In the set-up function, the number (reference) of the current tool was changed. Because of this, all edited data were discarded and the data of the tool with the new number were loaded.

Error correction

None


Error description 280-07DC

Error message

No entry in table

Cause of error

No entry in table / Access failed.
An attempt to access a table failed. It could be that the desired entry is missing or the format of a column doesn't fit.

Error correction

Check the values.


Error description 280-07DD

Error message

Invalid parameter value

Cause of error

Invalid parameter value.
A parameter has an invalid value.

Error correction

Check the values of the parameters.


Error description 280-07DE

Error message

Invalid command

Cause of error

Invalid command.
An invalid command (FN19 command) was programmed to the PLC.

Error correction

Check the command / Check the PLC program.


Error description 280-07DF

Error message

Error in table access

Cause of error

Error in table access (no handle).
An attempt to access a table failed. It could be that the desired entry is missing, the format of a column doesn't fit, the table doesn't exist, etc.

Error correction

Check the values.


Error description 280-07E0

Error message

No grinding wheel

Cause of error

Current tool is not a grinding wheel.
It is expected that the current tool be a grinding wheel, which is not the case. To find the location of a dresser, for example, the current tool must be a grinding wheel.

Error correction

Exchange the grinding wheel.


Error description 280-07E1

Error message

Invalid tool number

Cause of error

Invalid tool number.
The tool number is out of range.

Error correction

Enter the correct number (1...99).


Error description 280-07E2

Error message

Invalid alignment

Cause of error

Invalid dresser alignment.
The alignment of a dresser doesn't fit the selected grinding wheel edge.

Error correction

Select another wheel edge or another dresser alignment.


Error description 280-07E3

Error message

No dresser defined

Cause of error

No dresser defined.
A function expects that a dresser has been defined/programmed, which is not the case.

Error correction

Define/program a dresser.


Error description 280-07E4

Error message

Dresser not defined

Cause of error

Dresser not captured for this wheel.
You tried to work with a dresser whose location hasn't been found for the current wheel.

Error correction

Capture/set-up the dresser.


Error description 280-07E5

Error message

Not a valid wheel type

Cause of error

Not a valid wheel type.
Invalid wheel type programmed.

Error correction

Select the correct wheel type.


Error description 280-07E6

Error message

Ref. of dresser to wheel edge

Cause of error

Reference of dresser to wheel edge is incorrect.
The dresser is being used in reference to another wheel edge, as if it were captured/set-up.

Error correction

Repeat the capture/setup of the dressing attachment.


Error description 280-07E7

Error message

Relieved wheel not possible

Cause of error

Wheel side: Relieved wheel not possible.
The length of the relief is not possible, or the combination with other parameters of the wheel side is not possible.

Error correction

Check the parameters of the wheel side.


Error description 280-07E8

Error message

Chamfer width missing

Cause of error

Wheel side: Chamfer width missing.
A chamfer width is expected but was not programmed.

Error correction

Check the parameters of the wheel side.


Error description 280-07E9

Error message

Chamfer greater than side len. X

Cause of error

Wheel side: Chamfer greater than side length X.

Error correction

Check the parameters of the wheel side.


Error description 280-07EA

Error message

Angle of the relief is incorrect

Cause of error

Wheel side: Angle of the relief is incorrect.
The angle of the relief has an invalid value.

Error correction

Check the parameters of the wheel side.


Error description 280-07EB

Error message

FN14_2027

Cause of error

FN14_2027

Error correction

FN14_2027


Error description 280-07EC

Error message

FN14_2028

Cause of error

FN14_2028

Error correction

FN14_2028


Error description 280-07ED

Error message

FN14_2029

Cause of error

FN14_2029

Error correction

FN14_2029


Error description 280-07EE

Error message

Dressing strategy: corner radius not permitted

Cause of error

If a corner radius (RV, RV1, RV2) is defined, then a dressing strategy must be selected that dresses the diameter and the side at the same time.

Error correction

Select a different dressing cycle, or set corner radius to 0


Error description 280-07EE

Error message

FN14_2030

Cause of error

FN14_2030

Error correction

FN14_2030


Error description 280-07EF

Error message

Dressing strategy: wheel edge not supported

Cause of error

The combination of dressing cycle and active wheel edge is not allowed

Error correction

Activate a different wheel edge or select a different dressing cycle


Error description 280-07EF

Error message

FN14_2031

Cause of error

FN14_2031

Error correction

FN14_2031


Error description 280-07F0

Error message

Selected dressing strategy is not supported

Cause of error

A reciprocating strategy was programmed although this is not supported.
A reciprocating strategy can be used only if the dressing movement consists of a straight line.
A “Special grinding point” type of grinding wheel cannot be used with the “reciprocating” strategy.

Error correction

Select a different dressing strategy


Error description 280-07F0

Error message

FN14_2032

Cause of error

FN14_2032

Error correction

FN14_2032


Error description 280-07F1

Error message

Dressing mode already active, tool not allowed

Cause of error

If dressing mode (FUNCTION DRESS BEGIN) is activated before the dressing cycle, then no tool may be programmed in the dressing cycle.

Error correction

- Clear the tool number/name
- Remove FUNCTION DRESS BEGIN before the dressing cycle


Error description 280-07F1

Error message

FN14_2033

Cause of error

FN14_2033

Error correction

FN14_2033


Error description 280-07F2

Error message

Type of grinding wheel not allowed, not approved

Cause of error

The dressing cycle is not suitable for the selected type of grinding wheel, or has not been released yet.

Error correction

Select a different dressing cycle


Error description 280-07F2

Error message

FN14_2034

Cause of error

FN14_2034

Error correction

FN14_2034


Error description 280-07F3

Error message

Tool is not a dressing wheel or roll

Cause of error

A relationship between the cutting speeds was programmed even though the dressing tool is neither a dressing wheel nor a roll.

Error correction

- Change the type of dressing tool
- Either do not program the relationship between the cutting speeds, or set it to 0


Error description 280-07F3

Error message

FN14_2035

Cause of error

FN14_2035

Error correction

FN14_2035


Error description 280-07F4

Error message

FN14_2036

Cause of error

FN14_2036

Error correction

FN14_2036


Error description 280-07F5

Error message

FN14_2037

Cause of error

FN14_2037

Error correction

FN14_2037


Error description 280-07F6

Error message

FN14_2038

Cause of error

FN14_2038

Error correction

FN14_2038


Error description 280-07F7

Error message

FN14_2039

Cause of error

FN14_2039

Error correction

FN14_2039


Error description 280-07F8

Error message

FN14_2040

Cause of error

FN14_2040

Error correction

FN14_2040


Error description 280-07F9

Error message

FN14_2041

Cause of error

FN14_2041

Error correction

FN14_2041


Error description 280-07FA

Error message

FN14_2042

Cause of error

FN14_2042

Error correction

FN14_2042


Error description 280-07FB

Error message

FN14_2043

Cause of error

FN14_2043

Error correction

FN14_2043


Error description 280-07FC

Error message

FN14_2044

Cause of error

FN14_2044

Error correction

FN14_2044


Error description 280-07FD

Error message

FN14_2045

Cause of error

FN14_2045

Error correction

FN14_2045


Error description 280-07FE

Error message

FN14_2046

Cause of error

FN14_2046

Error correction

FN14_2046


Error description 280-07FF

Error message

FN14_2047

Cause of error

FN14_2047

Error correction

FN14_2047


Error description 280-0800

Error message

FN14_2048

Cause of error

FN14_2048

Error correction

FN14_2048


Error description 280-0801

Error message

FN14_2049

Cause of error

FN14_2049

Error correction

FN14_2049


Error description 280-0834

Error message

Infeed not defined

Cause of error

Infeed not defined.
The definition command for this infeed was not programmed.

Error correction

Define/program the infeed.


Error description 280-0835

Error message

Infeed direction not defined

Cause of error

Infeed direction not defined.
The infeed direction is unknown. That means that the start position of the infeed is identical with the end position, and no infeed direction is known from a previous command.

Error correction

At least in the first infeed command, program an end position unequal to the starting position.


Error description 280-0836

Error message

Undersize

Cause of error

Undersize.
During grinding with a dimensional control, the control has already responded at the start of the command.
This means that the diameter to be ground already has a finishing dimension or undersize.
If more than one cycle is programmed in sequence with a dimensional control, it can be normal for the rough size to be too small. However, at least the last cycle must be free of such error.

Error correction

Check the workpiece / Check the setting of the dimensional control.


Error description 280-0837

Error message

FN14_2103

Cause of error

FN14_2103

Error correction

FN14_2103


Error description 280-0838

Error message

Oversize

Cause of error

Oversize.
During grinding with a dimensional control, the control has not responded.
This means that the diameter to be ground was not reached. The workpiece has an oversize.

Error correction

Check the workpiece / Check the setting of the dimensional control.


Error description 280-0839

Error message

FN14_2105

Cause of error

FN14_2105

Error correction

FN14_2105


Error description 280-083A

Error message

Signal already active at start

Cause of error

Signal already active at start.
During grinding with an external signal (probe etc.) the signal responded before the movement was started.

Error correction

Compare the workpiece dimensions with the program and correct the program if necessary.


Error description 280-083B

Error message

FN14_2107

Cause of error

FN14_2107

Error correction

FN14_2107


Error description 280-083C

Error message

Signal has not responded

Cause of error

Signal has not responded.
During grinding with an external signal (probe etc.) the signal did not respond during the movement.

Error correction

Compare the workpiece dimensions with the program and correct the program if necessary.


Error description 280-083D

Error message

FN14_2109

Cause of error

FN14_2109

Error correction

FN14_2109


Error description 280-083E

Error message

B axis in wrong position

Cause of error

B axis in wrong position.
For a function, the B axis was expected to be in a defined position. The B axis is not in this position.

Error correction

Check the position of the B axis.


Error description 280-083F

Error message

No grinding wheel

Cause of error

Tool to be dressed is not a grinding wheel.
Only grinding wheels can be dressed.

Error correction

Check the tool type.


Error description 280-0840

Error message

Dressing location not released

Cause of error

Dressing location has not been not released.
A selected dressing location has not been not released.

Error correction

Select another dresser location.


Error description 280-0841

Error message

Wheel edges not released

Cause of error

Backward grinding (edges 4-6) not released.
The edges 4 to 6 are not released for the selected location. This means that "backward" grinding is not allowed.

Error correction

Select a wheel edge in front (1 to 3).


Error description 280-0842

Error message

Wheel location not occupied

Cause of error

Location on wheelhead not occupied.
There is no tool at the desired location.

Error correction

Select another location or tool.


Error description 280-0843

Error message

Wheel location not released

Cause of error

Location on wheelhead not released.
No tool is allowed at the desired location. It is locked against occupation.

Error correction

Select another location, or release this one for occupation.


Error description 280-0844

Error message

Dressing location not occupied

Cause of error

Dresser location is not occupied.
The desired dresser attachment location is not occupied.

Error correction

Select another location or place a dressing attachment in the location.


Error description 280-0845

Error message

T-call parameter invalid

Cause of error

Parameter during tool call is out of valid range.

Error correction

Check the tool call.


Error description 280-0846

Error message

Wheel settings not defined

Cause of error

The settings of the grinding wheel are not defined.
For certain setup functions it is expected that for a grinding wheel the settings (position of the head) have been defined/set up.

Error correction

Define / set up the settings.


Error description 280-0847

Error message

Wheel data not defined

Cause of error

Wheel data not captured (diameter, width, etc.).
For certain setup functions it is expected that for one grinding wheel the settings (position of the head) have been defined/set up.

Error correction

Capture/set up the grinding wheel data.


Error description 280-0848

Error message

Wheel not inserted

Cause of error

The grinding wheel is not mounted.
Either no grinding wheel was mounted (logical wheel location number = 0 or wheel number = 0) or you attempted to work with a wheel other than the one that was mounted.

Error correction

Use tool call to mount the wheel.


Error description 280-0849

Error message

Wheel location changed

Cause of error

Wheel pocket changed.
When the dresser was captured, the grinding wheel was at another location.

Error correction

Repeat the capture/setup of the dressing attachment.


Error description 280-084A

Error message

Dressing location changed

Cause of error

Dressing location changed.
When the wheel was evaluated, the dressing attachment was at another location.

Error correction

Repeat the evaluation/setup of the dressing attachment.


Error description 280-084C

Error message

Feed rate not programmed

Cause of error

Feed rate not programmed.No feed rate was programmed, or it was programmed as zero.

Error correction

Program the feed rate for a velocity other than zero.


Error description 280-084D

Error message

Wheel missing

Cause of error

Wheel missing.
You tried to work with a location that is not occupied by a grinding wheel.

Error correction

Occupy the location with a grinding wheel.


Error description 280-084E

Error message

No valid tool selected

Cause of error

No valid tool selected.
You tried to work with a tool that is not allowed for the current operation, or no tool is even selected.

Error correction

Select a valid tool.


Error description 280-084F

Error message

FN14_2127

Cause of error

FN14_2127

Error correction

FN14_2127


Error description 280-0850

Error message

Not a valid dresser type

Cause of error

Not a valid dresser type.
You tried to work with a dresser that is not allowed for the current operation, or the dresser type is not defined.

Error correction

Define/check the dresser type.


Error description 280-0852

Error message

No event programmed

Cause of error

No event programmed.
You tried to run a function for which an event (touch probe, dimensional control, etc.) has to be defined, but no event is defined.

Error correction

Define/program the event.


Error description 280-0853

Error message

Invalid event programmed

Cause of error

Invalid event programmed.An event was program that is not or not yet supported, or the event does not match the function.

Error correction

Program another event.


Error description 280-0854

Error message

FN14_2132

Cause of error

FN14_2132

Error correction

FN14_2132


Error description 280-0855

Error message

Event happened before movement

Cause of error

Event happened before movement.
An event has already happened before the associated movement was started.

Error correction

Check the program. Depending on the event, however, this may be correct behavior.


Error description 280-0856

Error message

FN14_2134

Cause of error

FN14_2134

Error correction

FN14_2134


Error description 280-0857

Error message

FN14_2135

Cause of error

FN14_2135

Error correction

FN14_2135


Error description 280-0858

Error message

Event did not happen

Cause of error

The event did not happen.
A movement with an event was programmed and the movement was completed without the event occurring.

Error correction

Check the program. Depending on the event, however, this may be correct behavior.


Error description 280-0859

Error message

FN14_2137

Cause of error

FN14_2137

Error correction

FN14_2137


Error description 280-085A

Error message

No swing stroke

Cause of error

No swing stroke programmed.
In a swing grinding operation, no swing stroke was programmed, or the stroke was programmed as zero.

Error correction

Check the swing cycle.


Error description 280-085B

Error message

Jig grinding, reciprocating stroke: tool axis not allowed

Cause of error

The current tool axis is not supported by reciprocation cycle 1000

Error correction

Reciprocation cycle 1000 is possible only with X, Y, or Z as tool axis


Error description 280-085B

Error message

FN14_2139

Cause of error

FN14_2139

Error correction

FN14_2139


Error description 280-085C

Error message

Jig grinding: reciprocating stroke already stopped

Cause of error

A reciprocation stop (cycle 1002) was programmed even though the reciprocation movement has already stopped.

Error correction

Check the NC program
Mid-program startup, a change of operating mode, and other actions stop an active reciprocation movement


Error description 280-085C

Error message

FN14_2140

Cause of error

FN14_2140

Error correction

FN14_2140


Error description 280-085D

Error message

Jig grinding: reciprocating stroke already defined

Cause of error

A reciprocation cycle (cycle 1000) was defined even though a reciprocation cycle is already active.

Error correction

Clear the previous reciprocation cycle definition (cycle 1002) before defining a new reciprocation cycle.


Error description 280-085D

Error message

FN14_2141

Cause of error

FN14_2141

Error correction

FN14_2141


Error description 280-085E

Error message

Immediate stop only permitted if reciprocation def. gets deleted

Cause of error

The parameter combination "Immediate stop" and "Do not delete reciprocation definition" is not allowed.

Error correction

Check the combination of parameter values, and correct as necessary


Error description 280-085E

Error message

FN14_2142

Cause of error

FN14_2142

Error correction

FN14_2142


Error description 280-085F

Error message

FN14_2143

Cause of error

FN14_2143

Error correction

FN14_2143


Error description 280-0860

Error message

FN14_2144

Cause of error

FN14_2144

Error correction

FN14_2144


Error description 280-0861

Error message

FN14_2145

Cause of error

FN14_2145

Error correction

FN14_2145


Error description 280-0862

Error message

FN14_2146

Cause of error

FN14_2146

Error correction

FN14_2146


Error description 280-0863

Error message

FN14_2147

Cause of error

FN14_2147

Error correction

FN14_2147


Error description 280-0864

Error message

FN14_2148

Cause of error

FN14_2148

Error correction

FN14_2148


Error description 280-0865

Error message

FN14_2149

Cause of error

FN14_2149

Error correction

FN14_2149


Error description 280-0866

Error message

Wrong axis programmed

Cause of error

An axis was programmed that is not allowed for the present function.

Error correction

Check the program.


Error description 280-0867

Error message

No axis programmed

Cause of error

No axis programmed.
In a function that needs at least one programmed axis, no axis was programmed.

Error correction

Check the program.


Error description 280-0868

Error message

M command not allowed

Cause of error

M command not allowed.
An M command was programmed that is invalid or is not allowed at this time.

Error correction

Check the program.


Error description 280-0869

Error message

FN14_2153

Cause of error

FN14_2153

Error correction

FN14_2153


Error description 280-086A

Error message

FN14_2154

Cause of error

FN14_2154

Error correction

FN14_2154


Error description 280-086B

Error message

FN14_2155

Cause of error

FN14_2155

Error correction

FN14_2155


Error description 280-086C

Error message

FN14_2156

Cause of error

FN14_2156

Error correction

FN14_2156


Error description 280-086D

Error message

FN14_2157

Cause of error

FN14_2157

Error correction

FN14_2157


Error description 280-086E

Error message

FN14_2158

Cause of error

FN14_2158

Error correction

FN14_2158


Error description 280-086F

Error message

FN14_2159

Cause of error

FN14_2159

Error correction

FN14_2159


Error description 280-0870

Error message

Pitch <= 0

Cause of error

Thread grinding: Pitch <= 0.
For thread grinding, the pitch must be greater than 0.

Error correction

Correct the parameter.


Error description 280-0871

Error message

Rotational speed = 0

Cause of error

Thread grinding: Rotational speed = 0.
For thread grinding, the rotational speed must not be 0.

Error correction

Correct the parameter.


Error description 280-0872

Error message

Cutting length = 0

Cause of error

Thread plunge grinding: Cutting length = 0.
For thread plunging, the cutting length must not be 0.

Error correction

Correct the parameter.


Error description 280-0873

Error message

Velocity = 0

Cause of error

Thread plunge grinding: Velocity Ve, Vm or Vk = 0.
For thread plunging, none of the three velocities can be zero.

Error correction

Correct the parameter.


Error description 280-0874

Error message

Signs differ

Cause of error

Thread plunge grinding: Different signs for E, M and K.
For thread plunge grinding, the algebraic signs of the parameters E, M and K must be identical.

Error correction

Correct the parameter.


Error description 280-0875

Error message

Pitch = 0

Cause of error

Thread plunge grinding: Thread depth = 0.
For thread plunging, the thread depth must not be 0.

Error correction

Correct the parameter.


Error description 280-0876

Error message

FN14_2166

Cause of error

FN14_2166

Error correction

FN14_2166


Error description 280-0877

Error message

FN14_2167

Cause of error

FN14_2167

Error correction

FN14_2167


Error description 280-0878

Error message

FN14_2168

Cause of error

FN14_2168

Error correction

FN14_2168


Error description 280-0879

Error message

FN14_2169

Cause of error

FN14_2169

Error correction

FN14_2169


Error description 280-087A

Error message

FN14_2170

Cause of error

FN14_2170

Error correction

FN14_2170


Error description 280-087B

Error message

FN14_2171

Cause of error

FN14_2171

Error correction

FN14_2171


Error description 280-087C

Error message

FN14_2172

Cause of error

FN14_2172

Error correction

FN14_2172


Error description 280-087D

Error message

FN14_2173

Cause of error

FN14_2173

Error correction

FN14_2173


Error description 280-087E

Error message

FN14_2174

Cause of error

FN14_2174

Error correction

FN14_2174


Error description 280-087F

Error message

FN14_2175

Cause of error

FN14_2175

Error correction

FN14_2175


Error description 280-0880

Error message

FN14_2176

Cause of error

FN14_2176

Error correction

FN14_2176


Error description 280-0881

Error message

FN14_2177

Cause of error

FN14_2177

Error correction

FN14_2177


Error description 280-0882

Error message

FN14_2178

Cause of error

FN14_2178

Error correction

FN14_2178


Error description 280-0883

Error message

FN14_2179

Cause of error

FN14_2179

Error correction

FN14_2179


Error description 280-0884

Error message

Block scan over probe functions not allowed

Cause of error

Block scan over probe functions not allowed.
A block scan was started over a block with a probe function.

Error correction

Run the block without block scan.
Touch probe functions cannot be run in block scan.


Error description 280-0885

Error message

Command not allowed during block scan

Cause of error

Command not allowed during block scan.
A command or cycle cannot be run in block scan.

Error correction

Run the block without block scan.
Some commands cannot be run in block scan.


Error description 280-0886

Error message

Command not executed due to block scan

Cause of error

Command not executed due to block scan.
A command or cycle was not run due to in block scan.

Error correction

None


Error description 280-0887

Error message

Measuring function not executed due to block scan

Cause of error

Measuring function not executed due to block scan.
A command or cycle containing a measuring function was not run due to block scan.

Error correction

None


Error description 280-0888

Error message

Elimination of air grinding was not executed due to block scan

Cause of error

Elimination of air grinding was not executed due to block scan.
A command or cycle containing the "Eliminate air grinding" function was not run due to block scan.

Error correction

None


Error description 280-0889

Error message

Block scan is not possible on this block

Cause of error

Block scan is not possible on this block.
The control does not support a block scan on the selected block.

Error correction

Select a block scan on another block.


Error description 280-088A

Error message

FN14_2186

Cause of error

FN14_2186

Error correction

FN14_2186


Error description 280-088B

Error message

FN14_2187

Cause of error

FN14_2187

Error correction

FN14_2187


Error description 280-088C

Error message

FN14_2188

Cause of error

FN14_2188

Error correction

FN14_2188


Error description 280-088D

Error message

FN14_2189

Cause of error

FN14_2189

Error correction

FN14_2189


Error description 280-088E

Error message

Command not allowed in the simulation

Cause of error

Command not allowed in simulation.
The command is not supported by the control in the simulation.

Error correction

Do not use the command in the simulation.


Error description 280-088F

Error message

FN14_2191

Cause of error

FN14_2191

Error correction

FN14_2191


Error description 280-0890

Error message

FN14_2192

Cause of error

FN14_2192

Error correction

FN14_2192


Error description 280-0891

Error message

FN14_2193

Cause of error

FN14_2193

Error correction

FN14_2193


Error description 280-0892

Error message

FN14_2194

Cause of error

FN14_2194

Error correction

FN14_2194


Error description 280-0893

Error message

FN14_2195

Cause of error

FN14_2195

Error correction

FN14_2195


Error description 280-0894

Error message

FN14_2196

Cause of error

FN14_2196

Error correction

FN14_2196


Error description 280-0895

Error message

FN14_2197

Cause of error

FN14_2197

Error correction

FN14_2197


Error description 280-0896

Error message

FN14_2198

Cause of error

FN14_2198

Error correction

FN14_2198


Error description 280-0897

Error message

FN14_2199

Cause of error

FN14_2199

Error correction

FN14_2199


Error description 280-0898

Error message

No safety clearance at diameter

Cause of error

No safety clearance at diameter.
No safety clearance was programmed at the diameter of the grinding wheel. When the dresser approaches the grinding wheel, it moves toward the wheel edge up to a safety clearance. To ensure that the diamond does not touch the wheel at this position, the
safety clearance must be at least as large as half the dresser width.

Error correction

Define a safety clearance at the diameter.


Error description 280-0899

Error message

No safety clearance on the outside

Cause of error

No safety clearance on the outside.
No safety clearance was programmed at the outer side of the grinding wheel. When the dresser approaches the grinding wheel, it moves toward the wheel edge up to a safety clearance. To ensure that the diamond does not touch the wheel at this position,
the safety clearance must be at least as large as half the dresser width.

Error correction

Define a safety clearance on the outer side.


Error description 280-089A

Error message

No safety clearance on the inside

Cause of error

No safety clearance on the inner side.
No safety clearance was programmed at the inner side of the grinding wheel. When the dresser approaches the grinding wheel, it moves toward the wheel edge up to a safety clearance. To ensure that the diamond does not touch the wheel at this position,
the safety clearance must be at least as large as half the dresser width.

Error correction

Define a safety clearance on the inner side.


Error description 280-089B

Error message

Dresser too wide

Cause of error

Dresser too wide (safety clearance too small).
When the dresser approaches the grinding wheel, it moves toward the wheel edge up to a safety clearance. To ensure that the diamond does not touch the wheel at this position, the safety clearance must be at least as large as half the dresser width.

Error correction

Check the safety clearances.


Error description 280-089C

Error message

Insufficient diameter

Cause of error

Wheel diameter is too small.
The wheel has less than the minimum permissible diameter. The minimum diameter requirement might have been violated during dressing or in a corresponding entry during setup.

Error correction

Correct the entry or adjust the minimum wheel diameter.
You might have to insert another wheel.


Error description 280-089D

Error message

Insufficient width

Cause of error

Wheel width is too small.
The wheel has less than the minimum permissible width. The minimum width requirement might have been violated during dressing or in a corresponding entry during setup.

Error correction

Correct the entry or adjust the minimum wheel width.
You might have to insert another wheel.


Error description 280-089E

Error message

Outer side of wheel incorrect

Cause of error

Outer side of wheel incorrect.
Incorrect values or incorrect combination of parameters that define the outer side of the wheel.

Error correction

Check the parameters of the outer side of the wheel.


Error description 280-089F

Error message

Inner side of wheel incorrect

Cause of error

Inner side of wheel incorrect.
Incorrect values or incorrect combination of parameters that define the inner side of the wheel.

Error correction

Check the parameters of the inner side of the wheel.


Error description 280-08A0

Error message

FN14_2208

Cause of error

FN14_2208

Error correction

FN14_2208


Error description 280-08A0

Error message

Dressing roller violates retraction amounts

Cause of error

The cutter width of the dressing roller is greater than the width and retraction amounts AA and AI of the grinding wheel together.
Cycle 1018: An edge of the dresser is outside of the retraction amounts AA or AI of the grinding wheel.

Error correction

- Check the retraction amounts of the grinding wheel
- Cycle 1018: Also check the center offset


Error description 280-08A1

Error message

FN14_2209

Cause of error

FN14_2209

Error correction

FN14_2209


Error description 280-08A2

Error message

Intermed. dressing not allowed

Cause of error

Intermediate dressing not allowed.
Intermediate dressing is not allowed in the present condition of the machine, or no dressing is defined in the running program.

Error correction

Define dressing in the program.


Error description 280-08A3

Error message

FN14_2211

Cause of error

FN14_2211

Error correction

FN14_2211


Error description 280-08A4

Error message

FN14_2212

Cause of error

FN14_2212

Error correction

FN14_2212


Error description 280-08A5

Error message

FN14_2213

Cause of error

FN14_2213

Error correction

FN14_2213


Error description 280-08A6

Error message

FN14_2214

Cause of error

FN14_2214

Error correction

FN14_2214


Error description 280-08A7

Error message

FN14_2215

Cause of error

FN14_2215

Error correction

FN14_2215


Error description 280-08A8

Error message

FN14_2216

Cause of error

FN14_2216

Error correction

FN14_2216


Error description 280-08A9

Error message

FN14_2217

Cause of error

FN14_2217

Error correction

FN14_2217


Error description 280-08AA

Error message

FN14_2218

Cause of error

FN14_2218

Error correction

FN14_2218


Error description 280-08AB

Error message

FN14_2219

Cause of error

FN14_2219

Error correction

FN14_2219


Error description 280-08AC

Error message

FN14_2220

Cause of error

FN14_2220

Error correction

FN14_2220


Error description 280-08AC

Error message

Wheel edge geometry not supported

Cause of error

Dressing cycle and grinding wheel geometry do not match.

Error correction

- Check the wheel geometry
- Select a different dressing cycle


Error description 280-08AD

Error message

FN14_2221

Cause of error

FN14_2221

Error correction

FN14_2221


Error description 280-08AD

Error message

Invalid shape of grinding wheel on the outer side

Cause of error

An invalid wheel shape was defined for the outer side of the grinding wheel

Error correction

- Check the wheel shape defined for the outer side
- Check the combination of grinding wheel parameters for the outer side


Error description 280-08AE

Error message

FN14_2222

Cause of error

FN14_2222

Error correction

FN14_2222


Error description 280-08AE

Error message

Invalid shape of grinding wheel on the inner side

Cause of error

An invalid wheel shape was defined for the inner side of the grinding wheel

Error correction

- Check the wheel shape defined for the inner side
- Check the combination of grinding wheel parameters for the inner side


Error description 280-08AF

Error message

FN14_2223

Cause of error

FN14_2223

Error correction

FN14_2223


Error description 280-08AF

Error message

Depth of grinding wheel too large

Cause of error

The depth of the grinding wheel is greater than its radius.
This can be caused by dressing.

Error correction

Check the depth of the grinding wheel


Error description 280-08B0

Error message

FN14_2224

Cause of error

FN14_2224

Error correction

FN14_2224


Error description 280-08B0

Error message

Dimension of grinding wheel negative

Cause of error

A grinding wheel parameter has become negative. This can be caused by dressing.

Error correction

Check the grinding wheel parameters


Error description 280-08B1

Error message

FN14_2225

Cause of error

FN14_2225

Error correction

FN14_2225


Error description 280-08B1

Error message

Minimum value of grinding wheel radius not reached

Cause of error

The current radius of the grinding wheel is smaller than the minimum permissible radius.
This can be caused by dressing.

Error correction

Check the grinding wheel parameters


Error description 280-08B2

Error message

FN14_2226

Cause of error

FN14_2226

Error correction

FN14_2226


Error description 280-08B3

Error message

FN14_2227

Cause of error

FN14_2227

Error correction

FN14_2227


Error description 280-08B4

Error message

FN14_2228

Cause of error

FN14_2228

Error correction

FN14_2228


Error description 280-08B5

Error message

FN14_2229

Cause of error

FN14_2229

Error correction

FN14_2229


Error description 280-08B6

Error message

FN14_2230

Cause of error

FN14_2230

Error correction

FN14_2230


Error description 280-08B7

Error message

FN14_2231

Cause of error

FN14_2231

Error correction

FN14_2231


Error description 280-08B8

Error message

FN14_2232

Cause of error

FN14_2232

Error correction

FN14_2232


Error description 280-08B9

Error message

FN14_2233

Cause of error

FN14_2233

Error correction

FN14_2233


Error description 280-08BA

Error message

FN14_2234

Cause of error

FN14_2234

Error correction

FN14_2234


Error description 280-08BB

Error message

FN14_2235

Cause of error

FN14_2235

Error correction

FN14_2235


Error description 280-08BC

Error message

FN14_2236

Cause of error

FN14_2236

Error correction

FN14_2236


Error description 280-08BD

Error message

FN14_2237

Cause of error

FN14_2237

Error correction

FN14_2237


Error description 280-08BE

Error message

FN14_2238

Cause of error

FN14_2238

Error correction

FN14_2238


Error description 280-08BF

Error message

FN14_2239

Cause of error

FN14_2239

Error correction

FN14_2239


Error description 280-08C0

Error message

FN14_2240

Cause of error

FN14_2240

Error correction

FN14_2240


Error description 280-08C1

Error message

FN14_2241

Cause of error

FN14_2241

Error correction

FN14_2241


Error description 280-08C2

Error message

FN14_2242

Cause of error

FN14_2242

Error correction

FN14_2242


Error description 280-08C3

Error message

FN14_2243

Cause of error

FN14_2243

Error correction

FN14_2243


Error description 280-08C4

Error message

FN14_2244

Cause of error

FN14_2244

Error correction

FN14_2244


Error description 280-08C5

Error message

FN14_2245

Cause of error

FN14_2245

Error correction

FN14_2245


Error description 280-08C6

Error message

FN14_2246

Cause of error

FN14_2246

Error correction

FN14_2246


Error description 280-08C7

Error message

FN14_2247

Cause of error

FN14_2247

Error correction

FN14_2247


Error description 280-08C8

Error message

FN14_2248

Cause of error

FN14_2248

Error correction

FN14_2248


Error description 280-08C9

Error message

FN14_2249

Cause of error

FN14_2249

Error correction

FN14_2249


Error description 280-08CA

Error message

FN14_2250

Cause of error

FN14_2250

Error correction

FN14_2250


Error description 280-08CB

Error message

FN14_2251

Cause of error

FN14_2251

Error correction

FN14_2251


Error description 280-08CC

Error message

FN14_2252

Cause of error

FN14_2252

Error correction

FN14_2252


Error description 280-08CD

Error message

FN14_2253

Cause of error

FN14_2253

Error correction

FN14_2253


Error description 280-08CE

Error message

FN14_2254

Cause of error

FN14_2254

Error correction

FN14_2254


Error description 280-08CF

Error message

FN14_2255

Cause of error

FN14_2255

Error correction

FN14_2255


Error description 280-08D0

Error message

FN14_2256

Cause of error

FN14_2256

Error correction

FN14_2256


Error description 280-08D1

Error message

FN14_2257

Cause of error

FN14_2257

Error correction

FN14_2257


Error description 280-08D2

Error message

FN14_2258

Cause of error

FN14_2258

Error correction

FN14_2258


Error description 280-08D3

Error message

FN14_2259

Cause of error

FN14_2259

Error correction

FN14_2259


Error description 280-08D4

Error message

FN14_2260

Cause of error

FN14_2260

Error correction

FN14_2260


Error description 280-08D5

Error message

FN14_2261

Cause of error

FN14_2261

Error correction

FN14_2261


Error description 280-08D6

Error message

FN14_2262

Cause of error

FN14_2262

Error correction

FN14_2262


Error description 280-08D7

Error message

FN14_2263

Cause of error

FN14_2263

Error correction

FN14_2263


Error description 280-08D8

Error message

FN14_2264

Cause of error

FN14_2264

Error correction

FN14_2264


Error description 280-08D9

Error message

FN14_2265

Cause of error

FN14_2265

Error correction

FN14_2265


Error description 280-08DA

Error message

FN14_2266

Cause of error

FN14_2266

Error correction

FN14_2266


Error description 280-08DB

Error message

FN14_2267

Cause of error

FN14_2267

Error correction

FN14_2267


Error description 280-08DC

Error message

FN14_2268

Cause of error

FN14_2268

Error correction

FN14_2268


Error description 280-08DD

Error message

FN14_2269

Cause of error

FN14_2269

Error correction

FN14_2269


Error description 280-08DE

Error message

FN14_2270

Cause of error

FN14_2270

Error correction

FN14_2270


Error description 280-08DF

Error message

FN14_2271

Cause of error

FN14_2271

Error correction

FN14_2271


Error description 280-08E0

Error message

FN14_2272

Cause of error

FN14_2272

Error correction

FN14_2272


Error description 280-08E1

Error message

FN14_2273

Cause of error

FN14_2273

Error correction

FN14_2273


Error description 280-08E2

Error message

FN14_2274

Cause of error

FN14_2274

Error correction

FN14_2274


Error description 280-08E3

Error message

FN14_2275

Cause of error

FN14_2275

Error correction

FN14_2275


Error description 280-08E4

Error message

FN14_2276

Cause of error

FN14_2276

Error correction

FN14_2276


Error description 280-08E5

Error message

FN14_2277

Cause of error

FN14_2277

Error correction

FN14_2277


Error description 280-08E6

Error message

FN14_2278

Cause of error

FN14_2278

Error correction

FN14_2278


Error description 280-08E7

Error message

FN14_2279

Cause of error

FN14_2279

Error correction

FN14_2279


Error description 280-08E8

Error message

FN14_2280

Cause of error

FN14_2280

Error correction

FN14_2280


Error description 280-08E9

Error message

FN14_2281

Cause of error

FN14_2281

Error correction

FN14_2281


Error description 280-08EA

Error message

FN14_2282

Cause of error

FN14_2282

Error correction

FN14_2282


Error description 280-08EB

Error message

FN14_2283

Cause of error

FN14_2283

Error correction

FN14_2283


Error description 280-08EC

Error message

FN14_2284

Cause of error

FN14_2284

Error correction

FN14_2284


Error description 280-08ED

Error message

FN14_2285

Cause of error

FN14_2285

Error correction

FN14_2285


Error description 280-08EE

Error message

FN14_2286

Cause of error

FN14_2286

Error correction

FN14_2286


Error description 280-08EF

Error message

FN14_2287

Cause of error

FN14_2287

Error correction

FN14_2287


Error description 280-08F0

Error message

FN14_2288

Cause of error

FN14_2288

Error correction

FN14_2288


Error description 280-08F1

Error message

FN14_2289

Cause of error

FN14_2289

Error correction

FN14_2289


Error description 280-08F2

Error message

FN14_2290

Cause of error

FN14_2290

Error correction

FN14_2290


Error description 280-08F3

Error message

FN14_2291

Cause of error

FN14_2291

Error correction

FN14_2291


Error description 280-08F4

Error message

FN14_2292

Cause of error

FN14_2292

Error correction

FN14_2292


Error description 280-08F5

Error message

FN14_2293

Cause of error

FN14_2293

Error correction

FN14_2293


Error description 280-08F6

Error message

FN14_2294

Cause of error

FN14_2294

Error correction

FN14_2294


Error description 280-08F7

Error message

FN14_2295

Cause of error

FN14_2295

Error correction

FN14_2295


Error description 280-08F8

Error message

FN14_2296

Cause of error

FN14_2296

Error correction

FN14_2296


Error description 280-08F9

Error message

FN14_2297

Cause of error

FN14_2297

Error correction

FN14_2297


Error description 280-08FA

Error message

FN14_2298

Cause of error

FN14_2298

Error correction

FN14_2298


Error description 280-08FB

Error message

FN14_2299

Cause of error

FN14_2299

Error correction

FN14_2299


Error description 280-08FC

Error message

FN22 command faulty

Cause of error

Error from system function: An FN22 command resulted in an error.

Error correction

Cancel the program, correct the parameter of the FN22, and restart.


Error description 280-08FD

Error message

Parameter block does not exist

Cause of error

Parameter block does not exist
You tried to activate a nonexistent parameter block for an axis.

Error correction

Select an existing parameter block.


Error description 280-08FE

Error message

Command not allowed

Cause of error

Command not allowed
This command is not supported by the control.

Error correction

Do not use the command


Error description 280-08FF

Error message

Command not allowed at this point

Cause of error

Command not allowed at this point
A command supported by the control was used in the wrong context or with the wrong condition of the control.
This could be, for example, a grinding command within a dressing program.

Error correction

Check/correct the program


Error description 280-0900

Error message

FN14_2304

Cause of error

FN14_2304

Error correction

FN14_2304


Error description 280-0901

Error message

FN14_2305

Cause of error

FN14_2305

Error correction

FN14_2305


Error description 280-0902

Error message

FN14_2306

Cause of error

FN14_2306

Error correction

FN14_2306


Error description 280-0903

Error message

FN14_2307

Cause of error

FN14_2307

Error correction

FN14_2307


Error description 280-0904

Error message

FN14_2308

Cause of error

FN14_2308

Error correction

FN14_2308


Error description 280-0905

Error message

FN14_2309

Cause of error

FN14_2309

Error correction

FN14_2309


Error description 280-0906

Error message

FN14_2310

Cause of error

FN14_2310

Error correction

FN14_2310


Error description 280-0907

Error message

FN14_2311

Cause of error

FN14_2311

Error correction

FN14_2311


Error description 280-0908

Error message

FN14_2312

Cause of error

FN14_2312

Error correction

FN14_2312


Error description 280-0909

Error message

FN14_2313

Cause of error

FN14_2313

Error correction

FN14_2313


Error description 280-090A

Error message

FN14_2314

Cause of error

FN14_2314

Error correction

FN14_2314


Error description 280-090B

Error message

FN14_2315

Cause of error

FN14_2315

Error correction

FN14_2315


Error description 280-090C

Error message

FN14_2316

Cause of error

FN14_2316

Error correction

FN14_2316


Error description 280-090D

Error message

FN14_2317

Cause of error

FN14_2317

Error correction

FN14_2317


Error description 280-090E

Error message

FN14_2318

Cause of error

FN14_2318

Error correction

FN14_2318


Error description 280-090F

Error message

FN14_2319

Cause of error

FN14_2319

Error correction

FN14_2319


Error description 280-0910

Error message

FN14_2320

Cause of error

FN14_2320

Error correction

FN14_2320


Error description 280-0911

Error message

FN14_2321

Cause of error

FN14_2321

Error correction

FN14_2321


Error description 280-0912

Error message

FN14_2322

Cause of error

FN14_2322

Error correction

FN14_2322


Error description 280-0913

Error message

FN14_2323

Cause of error

FN14_2323

Error correction

FN14_2323


Error description 280-0914

Error message

FN14_2324

Cause of error

FN14_2324

Error correction

FN14_2324


Error description 280-0915

Error message

FN14_2325

Cause of error

FN14_2325

Error correction

FN14_2325


Error description 280-0916

Error message

FN14_2326

Cause of error

FN14_2326

Error correction

FN14_2326


Error description 280-0917

Error message

Non-circular channel not active

Cause of error

Non-circular channel not active
A command was programmed that expects an active non-circular channel (non-circular program).

Error correction

Check/correct the program


Error description 280-0918

Error message

Non-circ. channel still active

Cause of error

Non-circular channel still active
A command was programmed that is not allowed with an active non-circular channel.
This could be, for example, an M3, M4 or M5.

Error correction

Check/correct the program


Error description 280-0919

Error message

Command only allowed in non-circular channel

Cause of error

Command only allowed in non-circular channel
A command was programmed in a normal program that is allowed only in a contour program (non-circular program).
A contour program (non-circular program) was started as a normal program.

Error correction

Check/correct the program
Start the non-circular program by means of a cycle and not in full sequence/single block


Error description 280-091A

Error message

Incorrect contour command

Cause of error

Incorrect contour command: The sequence of commands (Cycles 175, 178, 179) is not suited for running a contour program. For example, a contour program is started although none was loaded.

Error correction

Check the sequence of the commands 175, 178 and 179.


Error description 280-091B

Error message

Error in contour machining

Cause of error

Error in contour machining.


Error description 280-091C

Error message

Contour program faulty

Cause of error

Contour program error: A Cycle 176 was programmed at the beginning of a contour program (noncircular contour). There is an error in the combination of possible parameters.

Error correction

Check the parameters of Cycle 176 in the contour program.


Error description 280-092F

Error message

Tool axis X, Y, Z permitted

Cause of error

Only X, Y, and Z are possible as tool axes


Error description 280-0930

Error message

Starting spindle angle missing

Cause of error

For the imaging of tools, at least the spindle angle of one tooth must be known.

Error correction

- Run TCH PROBE Cycle 624 in order to determine the tooth angles
- Enter the spindle angle in the VTC-TOOLS.TAB table


Error description 280-0931

Error message

Max. tilt angle exceeded

Cause of error

The maximum tilting angle of the probe contact was exceeded.

Error correction

Check the setup of the probe contact, and correct it if required.
The tilting angle of the probe contact must be within the prescribed limits of both axes.


Error description 280-0932

Error message

Spindle speed not possible

Cause of error

The spindle shaft speed cannot be set for the panorama image.

Error correction

- Please contact your machine manufacturer


Error description 280-0933

Error message

Spindle speed not possible

Cause of error

The spindle shaft speed cannot be set for the breakage control.

Error correction

- Please contact your machine tool builder


Error description 280-0934

Error message

Camera data faulty

Cause of error

Incorrect internal camera data.
Caution: Collisions are possible when running the VTC cycles!

Error correction

- Please contact HEIDENHAIN


Error description 280-0935

Error message

Spindle angle unknown

Cause of error

The spindle angles of the tool teeth have not been determined yet.

Error correction

- Run VTC Cycle 624
- Or enter the angles in the TNC:\table\VTC-TOOLS.TAB table


Error description 280-0936

Error message

Option for panorama image is missing

Cause of error

The VTC option for panorama images is not enabled

Error correction

- Consult your contact person at HEIDENHAIN


Error description 280-0937

Error message

Spindle name?

Cause of error

The spindle designation is missing or unknown.

Error correction

- Enter the spindle name in the table PLC:\VTC\VTC.TAB


Error description 280-0938

Error message

Error in VTC.TAB

Cause of error

Entries in the table PLC:\VTC\VTC.TAB are incorrect:
- An entry is missing from the feed rate fields
- Both FMAX and a numerical value were entered for a feed rate
- An incorrect string was entered instead of FMAX

Error correction

Check VTC.TAB and enter the values correctly


Error description 280-093A

Error message

Excessive number of teeth

Cause of error

The permissible quantity of tool teeth was exceeded. Tools with no more than 32 teeth can be inspected.


Error description 280-093B

Error message

Incorrect VTC API version

Cause of error

The camera cycles do not match the programming interface of the VTC application

Error correction

- Inform your service agency


Error description 280-093C

Error message

Impermissible character in job name

Cause of error

An impermissible character was entered for the job name in the Q string QS620.

Error correction

- Edit the NC program
- Check whether any special characters, such as ?, ; , or a blank have been entered


Error description 280-093E

Error message

Incorrect value for contact angle at R2

Cause of error

The value for the contact angle is always positive and is limited to 0..90 degrees.

Error correction

- Check the NC program and correct it


Error description 280-0940

Error message

Contact angle of 0 degrees is not permitted

Cause of error

For spherical and toroid cutters, a value of 0 degrees is not permitted for the contact angle.

Error correction

- Correct the value in parameter Q629


Error description 280-0941

Error message

Cycle cannot be used with drilling tools

Cause of error

Detection of the cutting edge angle cannot be used for drilling tools.
Individual teeth of drilling tools cannot be detected with camera 1.


Error description 280-0942

Error message

Approaching/tilting to camera not possible

Cause of error

The contact point on the cutter cannot be moved to the camera's focus point.
Preconditions or possible causes:
- Table kinematics and angle heads are not supported
- The tool axis must be the Z axis
- Swivel head orientations greater than 45 degrees from the zero position are not possible
- Distance of at least 5 mm to the camera glass cannot be maintained


Error description 280-0943

Error message

Value not in permitted range

Cause of error

The value for the contact angle must be within the range 0 to 90 degrees.

Error correction

Change the numerical value in the cycle


Error description 280-0944

Error message

Error in table VTC-TOOLS.TAB

Cause of error

The entry for the contact angle is missing from the table.

Error correction

Correct the table by entering a value for the contact angle


Error description 280-0945

Error message

Tool contact angle Q629 doesn't equal 0

Cause of error

For cylindrical milling cutters and drills the value for the tool contact angle Q629 must equal 0

Error correction

- Edit the NC program


Error description 280-0946

Error message

Selection of view in Q622 doesn't equal 0

Cause of error

When using Camera 2, Q622 must equal 0

Error correction

- Edit the NC program


Error description 280-0947

Error message

Calculation of wear on dressing tool not possible

Cause of error

Measurement of a grinding tool revealed wear on the associated dressing tool. It can be determined correctly only if the tool length XL of the dressing tool is not zero.

Error correction

- Correctly define XL of the dressing tool (the dressing tool being used is defined in the tool data of the grinding wheel)
- For the grinding wheel, change the correction method to "grinding wheel with correction"


Error description 280-0948

Error message

Wear on dressing tool exceeds breakage tolerance

Cause of error

Measurement of a grinding tool revealed wear on the associated dressing tool. It exceeds the tool breakage tolerance RBREAK of the dressing tool.

Error correction

- Check the grinding tool for damage
- Check the associated dressing tool for damage (the dressing tool being used is defined in the tool data of the grinding wheel)
- Check the tool data of the associated dressing tool
- For the grinding wheel, change the correction method to "grinding wheel with correction"


Error description 292-0001

Error message

Look-ahead: internal software error

Cause of error

Error correction

Inform your service agency.


Error description 292-0002

Error message

ProfilePool: internal software error

Cause of error

Error correction

Inform your service agency.


Error description 292-0003

Error message

ProfilePool: internal software error

Cause of error

Error correction

Inform your service agency.


Error description 292-0004

Error message

ProfilePool: internal software error

Cause of error

Error correction

Inform your service agency.


Error description 292-0005

Error message

Look-ahead: internal software error

Cause of error

Error correction

Inform your service agency.


Error description 292-0006

Error message

Thread cutting: Spindle synchronized too late
(distance, position controller)

Cause of error

During thread cutting with controlled spindle, the control could not synchronize the spindle soon enough.

Error correction

1.) Increase the safety clearance
2.) Check the position control loop (kv factor and tolerance window)


Error description 292-0007

Error message

Axes switched while in motion

Cause of error

- Result of emergency stop during movement
- Clamping operation was switched while the axis was in motion
- Axis was switched off while in motion

Error correction

- If you suspect a PLC error, contact your machine tool builder.


Error description 292-0008

Error message

Incorrect sequence of contour machining

Cause of error

You used an illegal combination of contour machining commands.

Error correction

Correct the NC program


Error description 292-0009

Error message

%1

Cause of error


Error description 292-000A

Error message

Parameters for contour machining not allowed

Cause of error

Control commands for non cylindrical machining are not supported (FN22 FNR720).

Error correction

Inform your service agency


Error description 292-000B

Error message

Clamping mode switched too early

Cause of error

- PLC program has reset PP_AxClampModeRequest (W1038) too early, even before the drives were switched back on.

Error correction

- Inform your machine tool builder.


Error description 292-000C

Error message

System error: No feed rate

Cause of error

A movement without feed rate occurred for no apparent reason.

Error correction

Inform your machine tool builder.


Error description 292-000D

Error message

No spindle available for feed per revolution!

Cause of error

No spindle is available for the tool.

Error correction

Correct the kinematic configuration / switch off M14


Error description 292-000E

Error message

New start after immediate stop of noncylindr. contour not allowed

Cause of error

If the noncylindrical contour was stopped with G179 STOPP=1, a new start with G178 is not allowed.

Error correction

Delete the complete noncylindrical contour with G179 STOPP=3 and reload.


Error description 292-000F

Error message

Noncircular program too long for RAM

Cause of error

The current noncircular program is too long. Not enough free RAM is available to run the program.

Error correction

Correct or reduce the NC program.


Error description 292-0010

Error message

CMO is not in the current kinematic description

Cause of error

You tried to activate or deactivate a collision monitored object (CMO) for monitoring.
The control cannot fine the CMO in the currently selected kinematics.

Error correction

Correct the name of the CMO to be activated or deactivated.


Error description 292-0011

Error message

Tool is not monitored for collisions

Cause of error

The selected tool has the value zero or a negative value as the radius or length. There will be no monitoring for collisions.


Error description 292-0012

Error message

Tool is not allowed for collision monitoring

Cause of error

You have inserted a tool that cannot be monitored for collision by DCM (e.g. a non-cylindrical tool).

Error correction

Please use another tool.


Error description 292-0013

Error message

General system error in the collision monitoring

Cause of error

A general system error has occurred in the collision monitoring.

Error correction

Inform your service agency.


Error description 292-0014

Error message

DCM: %1

Cause of error

Dynamic collision monitoring (DCM) stopped the program in order to avoid a collision.


Error description 292-0015

Error message

Spindle turning too fast

Cause of error

The axis cannot follow because the spindle is turning too fast for the programmed thread.

Error correction

Decrease the spindle speed.


Error description 292-0016

Error message

DCM inactive: Axis has not yet been homed

Cause of error

DCM is inactive because one or more axes have no reference.

Error correction

Do a reference run in the axes


Error description 292-0017

Error message

DCM inactive: RTC (Real Time Coupling) activated

Cause of error

DCM is inactive because for one or more axes the real-time coupling function is active (RTC).

Error correction

Cancel the real-time couplings (RTC)


Error description 292-0019

Error message

Axes have not been homed, although DCM is active

Cause of error

Axes were not yet moved over the reference marks and DCM is switched on.
The NC program run was aborted.

Error correction

- Deactivate DCM if non-referenced axes are used


Error description 292-001A

Error message

Lagged axes with active DCM

Cause of error

In the current NC program, an axis is moved in the following error mode while the DCM collision monitoring is active. The collision monitoring of axes with following error is not supported.
The NC program run was aborted.

Error correction

- Edit the NC program, use FUNCTION DCM to deactivate DCM, or
- Use the soft key to switch DCM off


Error description 292-001B

Error message

Thread cutting: Spindle synchronization aborted!

Cause of error

During tapping with servo-controlled spindle, the movement was interrupted during spindle synchronization.
The tool axis did not come to a stop until after reaching the safety clearance, although the spindle is still turning.

Error correction

- Check the tool and workpiece for possible damage.
- Generate the service file and inform your service agency


Error description 292-001D

Error message

DCM inactive: Facing-slide kinematics are activated

Cause of error

DCM collision monitoring is inactive because a facing slide kinematic model was activated.

Error correction

- Deactivate the facing slide kinematics again.


Error description 292-001E

Error message

Facing slide activated with active DCM

Cause of error

The facing slide was activated and collision monitoring (DCM) is switched on.
The NC program run was aborted.

Error correction

- Deactivate DCM, if a facing slide is used.


Error description 292-001F

Error message

Deactivate handwheel for axis %1

Cause of error

The control waits for automatic clamping of this axis. The activated handwheel is preventing this clamping.

Error correction

Disable the handwheel for this axis


Error description 292-0020

Error message

Configuration of CfgDCM/manualModeDistance is faulty

Cause of error

The value configured for CfgDCM/manualModeDistance is less than the minimum permissible value.

Error correction

Adapt the machine configuration


Error description 292-0021

Error message

Machine configuration is incorrect

Cause of error

The configuration of the parameter profileType or profileTypeHi is faulty. If "advancedTrapezoidal" is to be configured, then this setting must be set in both the profileType parameter as well as in profileTypeHi.
The settings currently do not match.

Error correction

Modify the configuration: Configure the value "advancedTrapezoidal" in profileType and in profileTypeHi


Error description 292-0022

Error message

Look-ahead: internal software error. Code %1

Cause of error

The control has detected an internal software error dealing with the motion control.

Error correction

Inform your service agency


Error description 292-0023

Error message

%3 3-D model not loaded %2

Cause of error

Could not load the 3-D model because it does not fulfill the quality requirements.
The following requirements are in place for 3-D models:
- All dimensions in mm
- No gaps between triangles ("waterproof")
- No overlapping
- No degenerated triangles

Error correction

Regenerate the 3-D model and transfer it to the control.


Error description 292-0024

Error message

%3 3-D model not loaded %2

Cause of error

Error while reading the 3-D model: the file contains too many triangles.

Error correction

- Use a rougher 3-D model
- Generate the 3-D model with the CAD program again and transfer it to the control. In many CAD programs the level of detail can be set when exporting.


Error description 292-0025

Error message

%3 3-D model not loaded %2

Cause of error

Error while reading the 3-D model: the file could not be opened or is not a supported 3-D data format.

Error correction

- Check the path and correct it if necessary
- Reload the file


Error description 293-0001

Error message

Internal error in Look-Ahead Chain Module

Cause of error

Error correction

Inform your service agency.


Error description 293-0002

Error message

Illegal filter type 2

Cause of error

The second nominal value filter must not be of the cutter-location type.

Error correction

Adjust the configuration.


Error description 293-0003

Error message

Axis %1 with 2 filters

Cause of error

Two filters are activated in the parameter set of one axis.

Error correction

Adjust the configuration.


Error description 293-0004

Error message

Incorrect filter form in axis %1

Cause of error

Only position filters with HSC form are allowed.

Error correction

Adjust the configuration


Error description 293-0005

Error message

No cutter-location filter active

Cause of error

The tolerance for rotary axes with M128 was
- configured or programmed, although no nominal-value filter of the cutter-location type is active.
- configured or programmed, although none of the loaded axis parameters works with the 1st filter.

Error correction

Adjust the configuration or edit the program.


Error description 293-0006

Error message

Tolerance for rotary axes inactive

Cause of error

The tolerance for rotary axes with M128 was deactivated because you switched to a set of axis parameters without cutter-location filter. Therefore the normal path tolerance is being again used for all axes. The tolerance for rotary axes with M128 stays
active until the cutter-location filter is used again.

Error correction

A correction is not essential.
The warning can be suppressed by deactivating the tolerance for rotary axes before the axis parameter switchover.


Error description 293-0007

Error message

Axis parameters for logical axis %1 were lost

Cause of error

Internal error
The most recently programmed axis parameters of the axis named were lost in an abnormal program cancellation.
Therefore the configured parameters will be used.

Error correction

The control continues operation without correction.
If you still know the lost axis parameters, you can program them again.


Error description 293-0008

Error message

Parameters from another axis were programmed %1

Cause of error

The axis for which the axis parameters were programmed do not belong to the channel.

Error correction

Edit the program


Error description 293-0009

Error message

Parameters from another axis were configured %1

Cause of error

A logical axis is assigned to another, physical axis.
The parameter of this physical axis cannot be overwritten by the values of the logical axis.

Error correction

Change the configuration


Error description 293-000A

Error message

Missing axis parameters in CfgAxis of %1

Cause of error

The configuration of an axis has no entries for the axis parameters used here.

Error correction

Change the configuration


Error description 293-000B

Error message

Two cutter-location filters

Cause of error

Both position filters are of the cutter-location type.

Error correction

Change the configuration.


Error description 293-000C

Error message

Position filter is missing

Cause of error

With a position filter of the cutter-location type, the second filter must be of the position type.

Error correction

Change the configuration.


Error description 293-000D

Error message

Two position filters in axis %1

Cause of error

Two position filters of the position type are configured for the same axis.

Error correction

Change the configuration.


Error description 293-000E

Error message

No position filter in axis %1

Cause of error

For axes with cutter-location filters, the second filters must also be configured.

Error correction

Change the configuration.


Error description 293-000F

Error message

The option for axis-specific jerk has not been enabled

Cause of error

Axis-specific jerk values were activated in the machine configuration, but the option was not yet enabled.
Now the jerk that is valid in the channel was activated for the axis.

Error correction

- Delete the parameters MP_axPathJerk and MP_axPathJerkHi for axis-specific jerk from the machine configuration or enable the software option.


Error description 293-0010

Error message

The option for the feed rate filter has not been enabled

Cause of error

A time constant for the feed rate filter was configured in the machine configuration, but the option was not yet enabled.
The feed rate filter was deactivated by the NC software.

Error correction

- Delete the parameter MP_filterFeedTime for the time constant of the feed rate filter from the machine configuration or enable the software option.


Error description 293-0011

Error message

In Program Run it is not allowed to switch the filter on or off

Cause of error

A filter can be switched on or off by changing the filter form, filter order or the frequency.
Filter switched on: Form is not "Off" and the order is greater than 1.
Filter switched off: Form is "Off" and the order is less than 1.
Only for HSC filters: Filter is switched off if frequency = 0.
The programmed parameters for the filter were not adopted.

Error correction

- Edit the program or the cycle.


Error description 293-0012

Error message

Faulty configuration of the nominal position value filters

Cause of error

The following filter parameters are no longer supported and must no longer be configured:
- CfgFilter/typeFilter1,
typeFilter2,
orderFilter1,
orderFilter2,
- CfgPositionFilter/filter1Shape,
filter2Shape,
filter1LimitFreq,
filter2LimitFreq

Error correction

The old parameters of the position nominal value filter are automatically deleted by a correctly run configuration update.
The following conditions must be met in order to conduct the update:
- The config object CfgFilter must completely match the old level (with no new parameters).
- Either only new parameters or only old parameters are permitted for each CfgPositionFilter config object in the system.


Error description 293-0013

Error message

Name of parameter set (%1) for axis (%2) already assigned

Cause of error

Two or more axes are using the same parameter set. The names of parameter sets must be unique for each axis.

Error correction

- Assign a unique name for each of the parameter sets.


Error description 293-0014

Error message

Option for limiting the radial acceleration not enabled

Cause of error

A maximum value for the radial acceleration was configured in the machine configuration, but the option was not yet enabled.
The limit to the radial acceleration was deactivated by the NC software.

Error correction

- Delete the maxTransAcc and maxTransAccHi parameters for limiting the radial acceleration from the machine configuration or enable the software option.


Error description 293-0015

Error message

The DCC calculation module was activated


Error description 293-0016

Error message

Filter settings for virtual axis %1 not allowed

Cause of error

An individual filter setting was configured for a virtual axis. That is not allowed for virtual axes. The individual filter setting was deactivated by the NC.
An axis is virtual if CfgAxis/axisMode has the value "Virtual".

Error correction

- Configuration: Delete the config object CfgPositionFilter for this axis and use CfgKeySynonym to connect it with the real axis
- FN17: Use FN17 to delete filter settings from the NC program
- Cycle 32: Delete HSC mode from Cycle 32


Error description 293-0017

Error message

ADP must be active during use of DCM tolerances

Cause of error

The additional tolerances CfgDCM/maxLinearTolerance and CfgDCM/maxAngleTolerance are configured and ADP is not active. This is not allowed.

Error correction

Switch-on ADP by configuring CfgHardware/setupADP = Premium.
Comply with the information on ADP in the Technical Manual.


Error description 293-0018

Error message

Excessive contour error (%1 mm) in thread (%2 mm permitted)

Cause of error

The adjusted tolerance for successive threads was exceeded

Error correction

- Edit the NC program If possible, reduce the spindle speed.
- If a larger deviation is acceptable, increase the tolerance for threads.
- Inform your service agency.


Error description 293-0019

Error message

End of successive threads not reached

Cause of error

The programmed end point of the successive thread was not reached.

Error correction

- Check the NC program and edit it if necessary
- Reduce the spindle speed, if possible


Error description 293-001A

Error message

Invalid number programmed for FN17/18 No%1

Cause of error

- Incorrect number of FN17/18 programmed during access to look-ahead parameters.
- The is no look-ahead parameter under this number.

Error correction

- Correct the corresponding FN17 or FN18 command.


Error description 293-001B

Error message

Invalid axis programmed in FN17/18 IDX%1

Cause of error

- Incorrect axis/spindle was programmed through FN17 or FN 18 during access to look-ahead parameters.
- There is no axis or spindle with this axis index.

Error correction

- Correct the corresponding FN17 or FN18 command.


Error description 293-001C

Error message

Vertical movement not allowed in the middle of successive threads

Cause of error

- A movement perpendicular to the threaded axis was programmed in the middle of the thread.
- A perpendicular movement is allowed only in the form of lift-off at the end of the thread.

Error correction

- Check the NC program and adapt it if necessary


Error description 293-001E

Error message

Programmed feed rate too small

Cause of error

The programmed feed rate is too small.

Error correction

Edit the NC program.


Error description 293-001F

Error message

The NC program is longer than %1

Cause of error

The total distance moved in the NC program is greater than permitted.

Error correction

Shorten the NC program. Remove infinite loops.


Error description 293-0020

Error message

Internal error in LookAheadChain module. Code %1

Cause of error

The control has detected an internal software error dealing with the motion control.

Error correction

Inform your service agency


Error description 293-0021

Error message

Impermissible dynamic calculation of non-registered axis %1

Cause of error

Look-ahead is supposed to calculate the dynamics of an axis that is not registered.
The cause could be a deactivated axis that is used in the kinematics. That is not allowed.

Error correction

- Activate the deactivated axis, check the machine configuration, and correct it if required
- Activate another machine kinematic configuration through the NC program
- Edit the machine configuration or activate another machine kinematic configuration


Error description 293-0022

Error message

NC program contains more than %1 blocks

Cause of error

The NC program contains too many blocks.

Error correction

Shorten the NC program. Remove infinite loops.


Error description 296-0004

Error message

Process monitoring recordings are not compatible

Cause of error

The process monitoring settings were changed in the machine configuration. This makes existing recordings invalid.

Error correction

Delete existing recordings and perform new reference machining operations.


Error description 296-0005

Error message

Process monitoring recordings are not compatible

Cause of error

There are process monitoring recordings for this NC program that come from an older version of the control software. They are not compatible with the current software version.

Error correction

Delete existing recordings and perform new reference machining operations.


Error description 296-0006

Error message

Process Monitoring export: memory limit almost reached.

Cause of error

Die Obergrenze der Verzeichnisgröße für automatische Exporte der Prozessüberwachung ist fast erreicht.

Error correction

Maschinenhersteller informieren und Verzeichnis leeren lassen.


Error description 296-0007

Error message

Not enough free hard disk space for Process Monitoring

Cause of error

Für die Prozessüberwachung steht nicht genügend Festplattenspeicher zur Datenerfassung zur Verfügung.

Error correction

Prozessüberwachung deaktivieren oder mehr Festplattenspeicher zur Verfügung stellen.


Error description 296-0008

Error message

Manufacturer texts for component monitoring are missing

Cause of error

The machine configuration does not contain the machine parameter CfgOemTranslation with the key "COMPMON" for configuring the manufacturer-specific texts for component monitoring.

Error correction

- Configure CfgOemTranslation with the key "COMPMON"


Error description 296-0009

Error message

Manufacturer texts for process monitoring are missing

Cause of error

In der Maschinenkonfiguration fehlt der Maschinenparameter CfgOemTranslation mit Schlüssel "PROCMON" zur Konfiguration der herstellerspezifischen Texte für die Prozessüberwachung.

Error correction

- CfgOemTranslation mit Schlüssel "PROCMON" konfigurieren


Error description 2A0-0001

Error message

Ext. in-/output not ready

Cause of error

- The interface is not connected.
- The external device is either switched off or not ready.
- The transmission cable is defective or incorrect.

Error correction

Check the data transfer line.


Error description 2A0-0002

Error message

Error

Cause of error

This message indicates that there is an error message on the screen now in the background.

Error correction

Switch to the background mode and acknowledge the error message.


Error description 2A0-0003

Error message

Interface already assigned

Cause of error

You attempted to assign an already occupied data interface.

Error correction

End the data transmission and restart it.


Error description 2A0-0004

Error message

Baud rate not possible

Cause of error

The baud rates set at the two data interfaces do not permit simultaneous transmission over both interfaces.

Error correction

Select another baud rate.


Error description 2A0-0005

Error message

Data transfer erroneous

Cause of error

E During data transfer with BCC the <NAK> signal
was received 15 times in succession.
A to H Error code of the receiver module with one
w/o E of the following causes:
- The baud rate settings of the TNC and peripheral
device do not match.
- The parity bit is erroneous.
- Erroneous data frame
(e.g.: no stop-bit).
- The receiver module of the interface is
defective.
K During transmission of an error to the TNC the
<1> character was not transmitted after the <ESC>
character.
L After the error sequence <ESC><1> an incorrect
error number was received (error numbers 0 to 7
are permitted).
M During data transmission with BCC the <NAK>
character was transmitted 15 times in succession.
N An expected acknowledgment <ACK> or <NAK> was not
transmitted after a certain time.

Error correction

Check the data transfer channel.


Error description 2A0-0006

Error message

LSV2: Line interrupted

Cause of error

- DSR signal missing

Error correction

- Check the data transfer line


Error description 2A0-0007

Error message

LSV2: Transmission error

Cause of error

- Character error in the telegram

Error correction

- Check the data transfer line


Error description 2A0-0008

Error message

LSV2: Transmission error

Cause of error

- Checksum error in the received telegram

Error correction

- Check the data transfer line
- If the error recurs, inform your service agency


Error description 2A0-0009

Error message

LSV2: Transmission error

Cause of error

- Checksum error in the transmitted telegram

Error correction

- Check the data transfer line
- If the error recurs, inform your service agency


Error description 2A0-000A

Error message

LSV2: Timeout error

Cause of error

- No reaction from distant terminal (T1)

Error correction

- If the error recurs, inform your service agency
- Check the LSV2TIME1 entry in OEM.SYS


Error description 2A0-000B

Error message

LSV2: Transmission error

Cause of error

- Distant terminal not ready

Error correction

- Check the communications software of distant terminal


Error description 2A0-000C

Error message

LSV2: Timeout error

Cause of error

- Telegram incomplete, ETX missing (T0)

Error correction

- Check the communications software of distant terminal
- If the error recurs, inform your service agency
- Check the LSV2TIME0 entry in OEM.SYS


Error description 2A0-000D

Error message

LSV2: Timeout error

Cause of error

- No reaction from distant terminal (T2)

Error correction

- Check the communications software of distant terminal
- If the problem recurs, inform your service agency
- Check the LSV2TIME2 entry in OEM.SYS


Error description 2A0-000E

Error message

LSV2: Outgoing transmiss. error

Cause of error

- Internal software error

Error correction

- If the problem recurs, inform your service agency
- Check the software version


Error description 2A0-000F

Error message

Key non-functional

Cause of error

In this context the key has no function.


Error description 2A0-0010

Error message

Illegal file name

Cause of error

Syntax error during file-name input.

Error correction

Use no more than 16 characters for file names.


Error description 2A0-0011

Error message

Key is locked

Cause of error

You pressed a key that is locked at present by the NC software.

Error correction

If necessary, repeat the function at a later time.


Error description 2A0-0012

Error message

Function not permitted

Cause of error

You tried to use a feature that is not enabled on your control by the Feature Content Level (FCL) management.

Error correction

By default, FCL functions are locked after a software update. By entering the code number 65535 in the SIK Menu, you can enable these functions for a certain period of time for test purposes. You can enable FCL functions permanently by purchasing and
entering a code number. For more information, contact your machine tool builder or the service agency for the control.


Error description 2A0-0013

Error message

Two rotary positions not allowed

Cause of error

In a pattern or a frame, you tried to define two rotary positions at once.

Error correction

Define only the rotary position of the reference axis or minor axis.


Error description 2A0-0014

Error message

File name already exists

Cause of error

You tried to assign a name to a new file, although that name already exists.

Error correction

Use another file name.


Error description 2A0-0015

Error message

Function not enabled

Cause of error

You tried to use a software option that is not enabled on your control.

Error correction

Contact your machine tool builder or the service agency for the control to purchase the software option.


Error description 2A0-0016

Error message

Caution: Prepos. height defined!

Cause of error

You have hidden or disabled a point for which a pre-positioning height is defined. In some cases this could lead to a collision.

Error correction

Check if the next points can be approached without danger.


Error description 2A0-0017

Error message

Too little free memory on SYS:

Cause of error

There is not enough memory on the system partition SYS:. Proper function of the control can no longer be ensured.

Error correction

- Reboot the control.
- Inform your service agency


Error description 2A0-0018

Error message

Too little free memory on SYS:

Cause of error

There is not enough memory on the system partition SYS:. Proper function of the control can no longer be ensured.

Error correction

- Reboot the control.
- Inform your service agency


Error description 2A0-0019

Error message

Too little free memory on SYS:

Cause of error

There is not enough memory on the system partition SYS:. Proper function of the control can no longer be ensured.

Error correction

- Reboot the control.
- Inform your service agency


Error description 2A0-001A

Error message

Too little free memory on SYS:

Cause of error

There is not enough memory on the system partition SYS:. Proper function of the control can no longer be ensured.

Error correction

- Reboot the control.
- Inform your service agency


Error description 2A0-001B

Error message

Too little free memory on SYS:

Cause of error

There is not enough memory on the system partition SYS:. Proper function of the control can no longer be ensured.

Error correction

- Reboot the control.
- Inform your service agency


Error description 2A0-001C

Error message

Too little free memory on PLC:

Cause of error

There is not enough memory on the PLC: partition. Proper function of the control can no longer be ensured.

Error correction

Inform your machine tool builder.


Error description 2A0-001D

Error message

Too little free memory on PLC:

Cause of error

There is not enough memory on the PLC: partition. Proper function of the control can no longer be ensured.

Error correction

Inform your machine tool builder.


Error description 2A0-001E

Error message

Too little free memory on PLC:

Cause of error

There is not enough memory on the PLC: partition. Proper function of the control can no longer be ensured.

Error correction

Inform your machine tool builder.


Error description 2A0-001F

Error message

Too little free memory on PLC:

Cause of error

There is not enough memory on the PLC: partition. Proper function of the control can no longer be ensured.

Error correction

Inform your machine tool builder.


Error description 2A0-0020

Error message

Too little free memory on PLC:

Cause of error

There is not enough memory on the PLC: partition. Proper function of the control can no longer be ensured.

Error correction

Inform your machine tool builder.


Error description 2A0-0021

Error message

Too little free memory on TNC:

Cause of error

You saved too many files or excessively large files on the TNC: partition of the control. If you save any more files you will prevent safe operation of the control.

Error correction

- Delete NC programs that are no longer required
- Delete backup files of NC programs (*.bak) that are no longer required
- Delete service files that are no longer required
- If a machining process is now in progress, do not under any circumstance save any more files. It would endanger the success of the operation.


Error description 2A0-0022

Error message

Too little free memory on TNC:

Cause of error

You saved too many files or excessively large files on the TNC: partition of the control. If you save any more files you will prevent safe operation of the control.

Error correction

- Delete NC programs that are no longer required
- Delete backup files of NC programs (*.bak) that are no longer required
- Delete service files that are no longer required
- If a machining process is now in progress, do not under any circumstance save any more files. It would endanger the success of the operation.


Error description 2A0-0023

Error message

Too little free memory on TNC:

Cause of error

You saved too many files or excessively large files on the TNC: partition of the control. If you save any more files you will prevent safe operation of the control.

Error correction

- Delete NC programs that are no longer required
- Delete backup files of NC programs (*.bak) that are no longer required
- Delete service files that are no longer required
- If a machining process is now in progress, do not under any circumstance save any more files. It would endanger the success of the operation.


Error description 2A0-0024

Error message

Too little free memory on TNC:

Cause of error

You saved too many files or excessively large files on the TNC: partition of the control. If you save any more files you will prevent safe operation of the control.

Error correction

- Delete NC programs that are no longer required
- Delete backup files of NC programs (*.bak) that are no longer required
- Delete service files that are no longer required
- If a machining process is now in progress, do not under any circumstance save any more files. It would endanger the success of the operation.


Error description 2A0-0025

Error message

Too little free memory on TNC:

Cause of error

You saved too many files or excessively large files on the TNC: partition of the control. If you save any more files you will prevent safe operation of the control.

Error correction

- Delete NC programs that are no longer required
- Delete backup files of NC programs (*.bak) that are no longer required
- Delete service files that are no longer required
- If a machining process is now in progress, do not under any circumstance save any more files. It would endanger the success of the operation.


Error description 2A0-0026

Error message

Not enough free RAM.

Cause of error

There is little free RAM available. If you use any more RAM you will prevent safe operation of the control.

Error correction

- Deactivate memory-intensive applications such as the editor graphics or the Test Run mode.
- Reboot the control.


Error description 2A0-0027

Error message

Not enough free RAM.

Cause of error

There is little free RAM available. If you use any more RAM you will prevent safe operation of the control.

Error correction

- Deactivate memory-intensive applications such as the editor graphics or the Test Run mode.
- Reboot the control.


Error description 2A0-0028

Error message

Not enough free RAM.

Cause of error

There is little free RAM available. If you use any more RAM you will prevent safe operation of the control.

Error correction

- Deactivate memory-intensive applications such as the editor graphics or the Test Run mode.
- Reboot the control.


Error description 2A0-0029

Error message

Not enough free RAM.

Cause of error

There is little free RAM available. If you use any more RAM you will prevent safe operation of the control.

Error correction

- Deactivate memory-intensive applications such as the editor graphics or the Test Run mode.
- Reboot the control.


Error description 2A0-002A

Error message

Not enough free RAM.

Cause of error

There is little free RAM available. If you use any more RAM you will prevent safe operation of the control.

Error correction

- Deactivate memory-intensive applications such as the editor graphics or the Test Run mode.
- Reboot the control.


Error description 2A0-002B

Error message

Cannot switch modes of operation

Cause of error

You started the pattern generator or the contour programming while in a machining form and from there tried to switch to another operating mode.

Error correction

Close the pattern generator or contour programming and then close the form input mode (saving or discarding the data) before you switch to another operating mode.


Error description 2A0-002C

Error message

Auto. keyboard lock was opened

Cause of error

The TNC locks keys during a status change, but the lock was opened because the status change was not completed within 15 seconds.

Error correction

Wait until the status change is complete.


Error description 2A0-002D

Error message

Tree view buildup canceled

Cause of error

After selecting a long smarT.NC program, you canceled the buildup of the tree view. The TNC therefore cannot show the complete tree structure of the program within smarT.NC, nor can you test or run the program.

Error correction

Select the program again and this time wait until the TNC has finished building the tree view.


Error description 2A0-002E

Error message

PGM being edited in parallel

Cause of error

You tried to edit form data that are being edited in the Programming and Editing mode.

Error correction

Cancel your editing in the Programming and Editing mode and make the desired changes in the smarT.NC mode.


Error description 2A0-002F

Error message

Program header already exists

Cause of error

You tried to insert the UNIT 700 (program header), although it already exists.

Error correction

Make changes in the existing program header.


Error description 2A0-0030

Error message

Clipboard is empty!

Cause of error

You tried to insert a block from the clipboard, but the clipboard is empty.

Error correction

First fill the clipboard with the COPY BLOCK or CUT BLOCK.


Error description 2A0-0031

Error message

System memory overflow

Cause of error

This error occurs when the TNC does not have enough buffer memory for calculations, e.g. for generating complex FK graphics while machining a complex part.

Error correction

Acknowledge the error message by pressing CE and repeat the function.


Error description 2A0-0032

Error message

Function not permitted!

Cause of error

You tried to use a workpiece blank definition from an .hu program, but you did not select the current contour program from an .hu program.

Error correction

Use the function only when you have started the contour program from a UNIT program.


Error description 2A0-0033

Error message

File does not exist

Cause of error

You tried to use the "Recent Files" function to open a file that was moved or no longer exists.

Error correction

Select a different file or open a new file.


Error description 2A0-0034

Error message

File format has changed

Cause of error

This error message will be displayed upon opening a binary file (*.H,*.T...) if the binary format has changed since the previous output version.

Error correction

Delete the file.


Error description 2A0-0035

Error message

smarT.NC: Programming
smarT.NC:
Programming

Cause of error


Error description 2A0-0036

Error message

smarT.NC: Defining contours
smarT.NC:
Contour def.

Cause of error


Error description 2A0-0037

Error message

smarT.NC: Defining positions
smarT.NC:
Position def.

Cause of error


Error description 2A0-0038

Error message

Application %1 cannot be started

Cause of error

- Due to a lack of system resources (e.g. during memory-intensive HSC machining), a part of the system software cannot be loaded.
- The TNC cannot interpret the format of a DXF file.
- The DXF file is destroyed.

Error correction

- Call the desired function again at a later time.
- Ensure that the DXF file is available in R12 (ASCII) format.
- If required, recreate the DXF file.


Error description 2A0-0039

Error message

%1

Cause of error


Error description 2A0-003A

Error message

Programming graphics impossible

Cause of error

Programming graphics generation had to be terminated due to an internal error.

Error correction

Select the NC program again and restart generation of a new programming graphic (RESET+START soft key)


Error description 2A0-003B

Error message

smarT.NC: Select DXF elements
smarT.NC:
Select elements

Cause of error


Error description 2A0-003C

Error message

Erroneous DXF file

Cause of error

You tried to open a DXF file that cannot be edited by the TNC.

Error correction

- Check whether the DXF file is available in ASCII format.
- Have the DXF file read out in AutoCAD R12 (AC1009€) format.
If the problem recurs, try to make the DXF file with another CAD system.
- If necessary, inform your service agency.


Error description 2A0-003D

Error message

Use of DXF_CONVERTER not possible

Cause of error

You tried to open a DXF file that cannot be edited by the TNC.

Error correction

- Check whether the DXF file is available in ASCII format.
- Have the DXF file read out in AutoCAD R12 (AC1009€) format.
If the problem recurs, try to make the DXF file with another CAD system.
- If necessary, inform your service agency.


Error description 2A0-003E

Error message

Program-run graphics impossible!

Cause of error

The TNC is being so heavily utilized to machine the current workpiece that there is no more capacity available for the program-run graphics.

Error correction

No corrective action possible.


Error description 2A0-003F

Error message

Global PGM settings deactivated

Cause of error

In the smarT.NC operating mode you selected the Program Run submode although global program settings were active.

Error correction

The TNC automatically deactivates all active global program settings. Reactivate the settings, if necessary, when you continue working in the Program Run, Single Block or Program Run, Full Sequence operating mode.


Error description 2A0-0040

Error message

smarT.NC: Program run
smarT.NC:
Program run

Cause of error


Error description 2A0-0041

Error message

To retract: NC start

Cause of error


Error description 2A0-0042

Error message

Selected block not addressed

Cause of error

After an interruption of the program run the TNC can no longer resume the program run from the cursor's present location.

Error correction

Press GOTO and enter a block number to select the desired location for returning to the program, or select the mid-program startup function.


Error description 2A0-0043

Error message

Test graphic not possible

Cause of error

At present, the system is preventing use of the test graphic.

Error correction

Use the test graphic at a later time.


Error description 2A0-0044

Error message

smarT.NC: Testing
smarT.NC:
Testing

Cause of error


Error description 2A0-0045

Error message

Tool file?

Cause of error

There are several tool tables in the NC memory and no table is activated in the Test Run operating mode.

Error correction

Activate the tool table in the Test Run operating mode (status "S").


Error description 2A0-0047

Error message

GOTO table line

Cause of error


Error description 2A0-0048

Error message

Locked axis was programmed

Cause of error

- You programmed a locked axis in a part program block.
- A traverse was calculated for a locked axis (e.g. due to an active rotation).
- A programmed axis is a freely traversing rotary axis.

Error correction

- If necessary, activate the axis.
- Delete the axis from the part program block.


Error description 2A0-0049

Error message

Spindle must be turning

Cause of error

You called a fixed cycle without first switching on the spindle.

Error correction

Edit the part program.


Error description 2A0-004A

Error message

Tool axis is missing

Cause of error

You called a fixed cycle without first activating a tool.

Error correction

Edit the part program.


Error description 2A0-004B

Error message

Tool radius too small

Cause of error

- The tool radius is too small for the selected operation.
- Cycle 3 "Slot": You defined a width greater than four times the tool radius.
- Cycle 240: You entered a centering diameter greater than the tool diameter.
- Cycle 210 "Slot" or Cycle 211 "Circular Slot": The slot width is six times greater than the tool radius.

Error correction

- Use a tool with a larger radius.
- Cycle 3 "Slot": Define the slot width to be greater than the tool diameter and smaller than four times the tool radius.
- Cycle 240: Use a larger tool.
- Cycle 210 "Slot" or Cycle 211 "Circular Slot": Define the slot width to be greater than the tool diameter and smaller than six times the tool radius.


Error description 2A0-004C

Error message

Tool radius too large

Cause of error

- Contour milling: The radius of an arc block at an inside corner is smaller than the tool radius.
- Thread milling: The thread core diameter is smaller than the tool diameter.
- Slot milling: The slot width for roughing is smaller than the tool diameter.
- Cycle 251, rectangular pocket: The rounding radius Q220 is smaller than the tool radius.
- Cycle 214: The given workpiece-blank diameter is smaller than the tool diameter

Error correction

- Use a smaller tool
- Slot milling: If necessary, use a smaller oversize (Q368)
- Cycle 214: Use a smaller tool; correct the workpiece-blank diameter


Error description 2A0-004D

Error message

Range exceeded

Cause of error

During digitizing the stylus went out of the defined digitizing range.

Error correction

Check the data in the Range cycle, especially the entry for the touch probe axis.


Error description 2A0-004E

Error message

Start position incorrect

Cause of error

Digitizing with contour lines: Incorrect starting position selected.

Error correction

Check the axes defined in the Contour Lines cycle.


Error description 2A0-004F

Error message

Rotation not permitted

Cause of error

- Rotation not permitted during digitizing.
- Rotation not permitted during automatic measuring (measuring cycles 400 to 418) together with 3-D rotation.
- 3-D rotation not permitted together with Cycle 247.

Error correction

- Delete the Rotation cycle.
- Reset the rotation (manual mode).
- Reset 3-D rotation.


Error description 2A0-0050

Error message

Scaling factor not permitted

Cause of error

You programmed a scaling factor before the TCH PROBE 0 cycle (ISO: G55) or before the digitizing cycles.

Error correction

Delete the Scaling Factor or the Axis-Specific Scaling


Error description 2A0-0051

Error message

Mirroring not permitted

Cause of error

You programmed a mirror image before the TCH PROBE 0 cycle (ISO: G55) or before the digitizing cycles.

Error correction

Delete the Mirror Image cycle.


Error description 2A0-0052

Error message

Datum shift not permitted

Cause of error

Digitizing with contour lines: Datum shift is active.

Error correction

Delete the datum shift.


Error description 2A0-0053

Error message

Feed rate is missing

Cause of error

You did not program a feed rate.

Error correction

Edit the NC program. FMAX is effective only for the block in which it is programmed.


Error description 2A0-0054

Error message

Entry value incorrect

Cause of error

- The value you entered is out-of-range.
- Cycle 209 (ISO: 209): You entered the value 0 as infeed depth for chip breaking (Q257).

Error correction

- Enter the correct value.
- Enter a value other than 0 in Q257.


Error description 2A0-0055

Error message

Contradictory signs in cycle

Cause of error

The algebraic signs of the setup clearance, total hole depth and plunging depth do not match.

Error correction

Enter identical signs.


Error description 2A0-0056

Error message

Entered angle not permitted

Cause of error

- The solid angles programmed in Cycle 19 Tilt Working Plane (DIN/ISO: G80) cannot be realized with the current attachment (e.g. universal head where only one hemisphere is accessible).
- Run probing cycle only with paraxial angular position.
- The point angle (T-ANGLE) defined for the active tool is 180°.

Error correction

- Edit the solid angle entered.
- Run probing cycle only with paraxial angular position.
- Use angular values greater than 0 and less than 180°.


Error description 2A0-0057

Error message

Touch point inaccessible

Cause of error

In the TCH PROBE 0 (ISO: G55) cycle or during use of the manual probe cycles no touch point was reached within the traverse defined in machine parameter MP6130.

Error correction

- Pre-position the touch probe to the workpiece.
- Increase the value in MP6130.


Error description 2A0-0058

Error message

Too many points

Cause of error

Automatic establishment of points for the digitizing range in the Positioning with Manual Data Input operating mode: Number of stored points (max. 893) exceeded.

Error correction

Re-record digitizing range after increasing the point spacing.


Error description 2A0-0059

Error message

Contradictory entry

Cause of error

The values that you entered are contradictory.

Error correction

Check the input values.


Error description 2A0-005A

Error message

CYCL DEF incomplete

Cause of error

- You deleted part of a cycle.
- You have inserted other part program blocks within a cycle.

Error correction

- Redefine the complete cycle again
- Delete part program blocks programmed within a cycle.


Error description 2A0-005B

Error message

Height axis not permitted here

Cause of error

While defining the Contour Lines cycle (TCH PROBE 7) you programmed a height axis in the starting point.

Error correction

Edit the part program.


Error description 2A0-005C

Error message

Wrong axis programmed

Cause of error

- An incorrect axis is programmed in the highlighted block.
- Touch Probe Cycle 403: You programmed in incorrect compensation axis (Q312).

Error correction

- Check whether you have programmed an axis twice.
- Touch Probe Cycle 403: In parameter Q312, select only compensation axes that are present in the kinematic description.


Error description 2A0-005D

Error message

Wrong rpm

Cause of error

You entered an invalid spindle speed.

Error correction

Enter the correct speed, refer to the machine manual.


Error description 2A0-005E

Error message

Radius comp. undefined

Cause of error

- In the definition of a contour, a contour pocket or a contour train you neglected to program radius compensation.
- You have called a machining cycle with the tool radius 0.

Error correction

- Set a tool radius compensation in the contour subprogram to define whether the contour is for a pocket or island.
- Define a tool radius other than 0.


Error description 2A0-005F

Error message

Rounding-off undefined

Cause of error

You programmed in sequence a positioning block without radius compensation, a rounding arc (RND, ISO: G25), and a circle block with radius compensation.

Error correction

Edit the part program.


Error description 2A0-0060

Error message

Rounding radius too large

Cause of error

- In the definition of a contour, a contour pocket or a contour train, you programmed a rounding arc (RND, ISO: G25) with so large a radius that it does not fit between the adjoining elements.
- In a fixed cycle (rectangular pocket/rectangular stud), you defined a rounding arc that cannot be inserted.

Error correction

- Define a smaller rounding radius in the contour subprogram
- Check the cycle definition and correct the input values


Error description 2A0-0061

Error message

Program start undefined

Cause of error

The TNC cannot exactly calculate the geometry from the present position (e.g., the programmed coordinates of the first positioning block are the same as the compensated actual position).

Error correction

- Restart the part program.
- Use mid-program startup to return to the point of interruption.


Error description 2A0-0062

Error message

Excessive subprogramming

Cause of error

In a Contour Pocket cycle or a Contour Train cycle you called more than 6 programs (PGM CALL, ISO: %..).
A program call can also be:
- Cycle 12 (PGM CALL, ISO: G39)
- Calling an OEM cycle

Error correction

Edit the part program.


Error description 2A0-0063

Error message

Angle reference missing

Cause of error

In an LP/CP block (ISO: G10, G11, G12, G13) no polar angle or incremental polar angle is defined, i.e.:
- The distance between the last programmed position and the pole is less than or equal to 0.1 µm.
- No rotation is programmed between pole assumption and an LP/CP block.

Error correction

- Program the absolute polar angle.
- Check the position of the pole.
- If necessary, reset the rotation.


Error description 2A0-0064

Error message

No fixed cycle defined

Cause of error

There is no fixed cycle defined before Cycle 220/221 (circular/linear point pattern).

Error correction

Define a fixed cycle before Cycle 220/221.


Error description 2A0-0065

Error message

Insufficient slot width

Cause of error

The width defined in the slot cycle cannot be machined with the active tool.

Error correction

Use a smaller tool.


Error description 2A0-0066

Error message

Pocket too small

Cause of error

The side lengths defined in the Pocket Milling cycle are too small.

Error correction

Use a smaller tool.


Error description 2A0-0067

Error message

Q202 not defined

Cause of error

There is no plunging depth (Q202) defined in the fixed cycles 200 to 215.

Error correction

Enter a plunging depth in the fixed cycle.


Error description 2A0-0068

Error message

Q205 not defined

Cause of error

In the Universal Drilling cycle, you have not defined the minimum plunging depth.

Error correction

Enter a minimum plunging depth in the fixed cycle.


Error description 2A0-0069

Error message

Q218 must be greater than Q219

Cause of error

Pocket milling cycle: Q218 must be greater than Q219.

Error correction

Correct the values in the fixed cycle.


Error description 2A0-006A

Error message

CYCL 210 not permitted

Cause of error

Fixed cycle cannot be run in the CIRCULAR PATTERN or LINEAR PATTERN cycle.

Error correction

Use another fixed cycle.


Error description 2A0-006B

Error message

CYCL 211 not permitted

Cause of error

Cycle 211 cannot be run in the CIRCULAR PATTERN or LINEAR PATTERN cycle.

Error correction

Use another fixed cycle.


Error description 2A0-006C

Error message

Q220 too large

Cause of error

Pocket finishing or stud finishing cycle: Rounding radius Q220 is too large.

Error correction

Correct the rounding radius in the fixed cycle.


Error description 2A0-006D

Error message

Q222 must be greater than Q223

Cause of error

Stud finishing cycle: Workpiece blank diameter Q222 must be greater than the finished part diameter Q223.

Error correction

Correct the workpiece blank diameter in the fixed cycle.


Error description 2A0-006E

Error message

Q244 must be greater than 0

Cause of error

Circular Pattern cycle: You entered a pitch circle diameter of zero.

Error correction

Correct the pitch circle diameter in the cycle.


Error description 2A0-006F

Error message

Q245 must not equal Q246

Cause of error

Circular Pattern cycle: Enter a stopping angle equal to the starting angle.

Error correction

Correct the starting or stopping angle in the cycle.


Error description 2A0-0070

Error message

Angle range must be under 360°

Cause of error

Circular Pattern cycle: You entered an angle range greater than 360°.

Error correction

Correct the starting or stopping angle in the cycle.


Error description 2A0-0071

Error message

Q223 must be greater than Q222

Cause of error

In the Circular Pocket Finishing cycle, you entered a finished-part diameter (Q223) smaller than the workpiece-blank diameter (Q222).

Error correction

Edit Q222 in the cycle definition.


Error description 2A0-0072

Error message

Q214: 0 not permitted

Cause of error

In the definition of Cycle 204 you have entered the disengaging direction 0.

Error correction

In Q214, enter a value from 1 to 4.


Error description 2A0-0073

Error message

Traverse direction not defined

Cause of error

In a probing cycle you entered 0 for the traverse direction Q267.

Error correction

For Q267, enter either +1 (for positive traverse direction) or -1 (for negative traverse direction).


Error description 2A0-0074

Error message

No datum table active

Cause of error

Probing cycle for datum setting: You want the TNC to write the measured point into a datum table, but you have not activated a datum table in a program run mode (status M).

Error correction

In the single block or full sequence program run mode, activate the datum table into which you want the measured point to be entered.


Error description 2A0-0075

Error message

Position error: center in axis 1

Cause of error

Probing cycle for workpiece measurement: Center of 1st axis outside of position tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0076

Error message

Position error: center in axis 2

Cause of error

Probing cycle for workpiece measurement: Center of 2st axis outside of position tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0077

Error message

Hole diameter too small

Cause of error

Probing cycle for workpiece measurement: Hole diameter too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0078

Error message

Hole diameter too large

Cause of error

- Probing cycle for workpiece measurement: Hole diameter tolerance exceeded.
- Cycle 208: The programmed hole diameter (Q335) cannot be machined with the active tool.

Error correction

- Check the workpiece and, if necessary, the measuring log.
- Cycle 208: Use a larger tool. Hole diameter must not be larger than twice the tool diameter.


Error description 2A0-0079

Error message

Stud diameter too small

Cause of error

Probing cycle for workpiece measurement: Stud diameter too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-007A

Error message

Stud diameter too large

Cause of error

Probing cycle for workpiece measurement: Stud diameter too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-007B

Error message

Pocket too small: rework axis 1

Cause of error

Probing cycle for workpiece measurement: Pocket length in 1st axis too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-007C

Error message

Pocket too small: rework axis 2

Cause of error

Probing cycle for workpiece measurement: Pocket width in 2nd axis too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-007D

Error message

Pocket too large: scrap axis 1

Cause of error

Probing cycle for workpiece measurement: Pocket length in 1st axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-007E

Error message

Pocket too large: scrap axis 2

Cause of error

Probing cycle for workpiece measurement: Pocket width in 2nd axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-007F

Error message

Stud too small: scrap axis 1

Cause of error

Probing cycle for workpiece measurement: Stud length in 1st axis too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0080

Error message

Stud too small: scrap axis 2

Cause of error

Probing cycle for workpiece measurement: Stud width in 2nd too small for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0081

Error message

Stud too large: rework axis 1

Cause of error

Probing cycle for workpiece measurement: Stud length in 1st axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0082

Error message

Stud too large: rework axis 2

Cause of error

Probing cycle for workpiece measurement: Stud width in 2nd axis too large for tolerance.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0083

Error message

Meas. cycle: length exceeds max

Cause of error

Probing cycle 425 or 427: The measured length exceeds the maximum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0084

Error message

Meas. cycle: length below min

Cause of error

Probing cycle 425 or 427: The measured length is below the minimum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0085

Error message

TCHPROBE 426: length exceeds max

Cause of error

Probing cycle 426: The measured length exceeds the maximum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0086

Error message

TCHPROBE 426: length below min

Cause of error

Probing cycle 426: The measured length is below the minimum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0087

Error message

TCHPROBE 430: diameter too large

Cause of error

Probing cycle 430: The measured bolt-hole-circle diameter exceeds the maximum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0088

Error message

TCHPROBE 430: diameter too small

Cause of error

Probing cycle 430: The measured bolt-hole-circle diameter is below the minimum permissible value.

Error correction

Check the workpiece and the measuring log.


Error description 2A0-0089

Error message

No measuring axis defined

Cause of error

You failed to define the measuring axis in one of the measuring cycles 400, 402, 420, 425, 426 or 427.

Error correction

Check Q272 in the corresponding cycle.
Permissible input values: 1 or 2;
for Cycle 427: 1, 2 or 3.


Error description 2A0-008A

Error message

Tool breakage tolerance exceeded

Cause of error

During workpiece inspection using a measuring cycle, the tool breakage tolerance RBREAK given in the tool table was exceeded.

Error correction

Check whether the tool is damaged.


Error description 2A0-008B

Error message

Enter Q247 unequal 0

Cause of error

In a measuring cycle you entered in parameter Q247 an angular step of 0.

Error correction

Enter an angular step (Q247) other than 0.


Error description 2A0-008C

Error message

Enter Q247 greater than 5

Cause of error

In a measuring cycle, you entered in parameter Q247 an angular step smaller than 5 degrees.

Error correction

To ensure sufficient measuring accuracy, enter an angular step (Q247) greater than 5 degrees.


Error description 2A0-008D

Error message

Datum table?

Cause of error

A datum table is required to machine a part program. Either there is no table in the control's NC memory, or several tables have be saved and none activated.

Error correction

Activate the datum table in the Program Run, Full Sequence mode (status M).


Error description 2A0-008E

Error message

Enter direction Q351 unequal 0

Cause of error

In a fixed cycle you did not define the cutting direction (climb or up-cut).

Error correction

Define the cutting direction as climb milling (= 1) or up-cut milling (= -1).


Error description 2A0-008F

Error message

Thread depth too large

Cause of error

The programmed thread depth plus 1/3 of the pitch is greater than the drilling or sinking depth.

Error correction

Program the total hole depth to be at least 1/3 of a thread pitch smaller that the total hole depth.


Error description 2A0-0090

Error message

Missing calibration data

Cause of error

You have attempted to perform a measurement with Cycle 440 without first performing a calibration.

Error correction

Repeat Cycle 440, but with Q363 = 0 (calibrate).


Error description 2A0-0091

Error message

Tolerance exceeded

Cause of error

The limits entered in the tool table TOOL.T in the LTOL or RTOL column were exceeded.

Error correction

Check the limit values for the active calibration tool.


Error description 2A0-0092

Error message

Mid-program startup active

Cause of error

Mid-program startup is not permitted with the programmed function.

Error correction

Mark the programmed function with "skip blocks" and activate this setting. Then run the mid-program startup again.


Error description 2A0-0093

Error message

ORIENTATION not permitted

Cause of error

- Your machine does not offer spindle orientation
- Spindle orientation not possible

Error correction

- Refer to your machine manual!
- Check machine parameter 7442 and enter the numerical designation of the M function or -1 for spindle orientation by the NC. Refer to your machine manual!


Error description 2A0-0094

Error message

3DROT not permitted

Cause of error

You tried to conduct one of the following functions while the working plane was tilted:
- Setting a reference point
- A touch probe cycle 40x for measuring a misalignment

Error correction

Deactivate the tilted working plane function and restart the program.


Error description 2A0-0095

Error message

Activate 3DROT

Cause of error

In the Manual operating mode, the Tilt Working Plane function is inactive.

Error correction

Activate 3DROT in Manual mode.


Error description 2A0-0096

Error message

Check the depth sign

Cause of error


Error description 2A0-0097

Error message

Q303 in meas. cycle undefined!

Cause of error

In one of the measuring cycles 410 to 418, you did not define the parameter Q303 (measured value transfer)(current value = -1). For reasons of security, however, selection of the measured value transfer is required to write the results of measurement in
a table (datum table or preset table).

Error correction

Change parameter Q303 (measured value transfer) in the measuring cycle that is causing the error:
- Q303=0: Write the measured values with respect to the active workpiece coordinate system into the active datum table (activate in the program with Cycle 7!).
- Q303=1: Write the measured values with respect to the active machine-based coordinate system (REF values) into the preset table (activate in the program with Cycle 247!).
- Q303=-1: Measured value transfer is undefined. This value is automatically generated by the TNC when you download a program that was written on a TNC 4xx or with an old software level of the iTNC 530, or if during the cycle definition you skipped the
prompt for the measured value transfer with the END key.


Error description 2A0-0098

Error message

Tool axis not allowed

Cause of error

- You called probing cycle 419 with an illegal tool axis.
- You called the PATTERN DEF function in connection with an illegal tool axis.

Error correction

- Only call probing cycle 419 with the tool axis X, Y or Z.
- Use the PATTERN DEF function only with the tool axis Z (TOOL CALL Z).


Error description 2A0-0099

Error message

Calculated values incorrect

Cause of error

In probing cycle 418, the TNC calculated too large a value. You may have defined in an incorrect sequence for the four holes to be probed.

Error correction

Check the probing sequence. Refer to the User's Manual for Touch Probe Cycles.


Error description 2A0-009A

Error message

Contradictory measuring points

Cause of error

- In one of the probing cycles 400, 403 or 420, you defined a contradictory combination of measuring points and measuring axes.
- The selection of measuring points in Cycle 430 results in division by 0.

Error correction

- For measuring axis = reference axis (Q272=1), the parameters Q264 and Q266 are defined at different values.
- For measuring axis = minor axis (Q272=2), the parameters Q263 and Q265 are defined at different values.
- For measuring axis = probe axis (Q272=3), the parameters Q263 and Q265 or Q264 and Q266 are defined at different values.
- Select the measuring points so that they always have different coordinates in all axes.


Error description 2A0-009B

Error message

Incorrect clearance height!

Cause of error

In Cycle 20 (ISO: G120), you entered a clearance height (Q7) that is lower than the coordinate of the workpiece surface (Q5).

Error correction

Enter a clearance height (Q7) that is higher than the coordinate of the workpiece surface (Q5).


Error description 2A0-009C

Error message

Contradictory plunge type!

Cause of error

The plunging strategy defined in Cycles 251 to 254 contradicts the defined plunging angle of the active tool.

Error correction

Change parameter Q366 in one of the Cycles 251 to 254 or the plunging angle ANGLE of the tool in the tool table. Permissible combinations of parameter Q366 and the plunging ANGLE are:
For perpendicular plunging: Q366 = 0 and ANGLE = 90
For helical plunging: Q366 = 1 and ANGLE > 0
For inactive tool table, define Q366 with 0 (only perpendicular plunging allowed).


Error description 2A0-009D

Error message

This fixed cycle not allowed

Cause of error

- You attempted to run a fixed cycle in connection with Cycle 220 or 221 although it cannot be combined with these cycles.
- You tried to run the Cycle 209 with a feed rate factor for retraction (Q403).

Error correction

- You cannot combine Cycles 220 and 221 with the following fixed cycles:
- Cycles of the SLI and SLII groups
- Cycles 210 and 211
- Cycles 230 and 231
- Cycle 254
- Feed rate factor 403 is allowed only with a setting in MP3010 unequal to 7.


Error description 2A0-009E

Error message

Line is write-protected

Cause of error

- You tried to edit or erase a write-protected line in the preset table.
- You tried to write a value in the active line of the preset table.

Error correction

- Overwriting the active preset is not allowed. Use another preset number.
- The write protection was activated by your machine manufacturer. Maybe fixed datum was defined in this line. If you want to cancel write protection, contact your machine tool builder.
- You defined the write protection in the TNC.SYS file. If required, cancel the write-protection there.
- You tried to change line 0. It cannot be changed.


Error description 2A0-009F

Error message

Oversize greater than depth

Cause of error

SL cycles II or milling cycles 25x: You have entered an allowance for floor greater than the milling depth.

Error correction

- SL cycles II: Check Q4 in Cycle 20 (ISO: G120).
- Milling cycles 25x: Check allowance Q369 and depth Q201.


Error description 2A0-00A0

Error message

Point angle not defined

Cause of error

In Cycle 240 Centering you defined parameter Q343 such that centering is done with respect to the diameter.
In a drilling cycle you defined parameter Q395 such that the depth is in reference to the tool diameter.
You programmed a cycle for chamfering. The point angle for this must be between 1 and 179 degrees.
However, no point angle is defined for the active tool.

Error correction

- Set parameter Q343=0 (centering to entered depth).
- Set parameter Q395=0 (depth in reference to the tool tip).
- Define the point angle in the column T-ANGLE of the tool table TOOL.T.


Error description 2A0-00A1

Error message

Contradictory data

Cause of error

The combination of the parameters Depth (Q201) and Diameter (Q344) defined in Cycle 240 Centering under Select depth/diameter (Q343) is not allowed.

Error correction

Possible definitions:
Q343=1 (entered diameter active): Q201 must be equal to 0 and Q344 must not be equal to 0.
Q343=0 (entered depth active): Q201 must not be equal to 0 and Q344 must be equal to 0.


Error description 2A0-00A2

Error message

Slot position 0 not allowed!

Cause of error

You tried to run Cycle 254 with the slot position 0 (Q367=0) in conjunction with the point pattern Cycle 221.

Error correction

Use slot position Q367 = 1, 2 or 3 if you want to run Cycle 254 with the point pattern cycle 221


Error description 2A0-00A3

Error message

Enter an infeed not equal to 0.

Cause of error

You defined a fixed cycle with the depth 0.

Error correction

Enter a depth unequal to 0.


Error description 2A0-00A4

Error message

Switchover of Q399 not allowed

Cause of error

You tried to switch on the touch probe cycle 441 to switch on the angle tracking, although this function is deactivated by machine parameter 6165.

Error correction

Set the machine parameter 6165 = 1 (MOD function, code number 123) and then recalibrate the touch probe.


Error description 2A0-00A5

Error message

Tool not defined

Cause of error

You have called a tool that is not defined in the tool table.

Error correction

- Add the missing tool to the tool table.
- Use another tool.


Error description 2A0-00A6

Error message

Tool number not allowed

Cause of error

In a TOOL CALL or TOOL DEF block you tried to define a tool number although it is prohibited by machine parameter.

Error correction

- Use the tool name.
- Adapt machine parameter 7483. If required, contact your machine manufacturer.


Error description 2A0-00A7

Error message

Tool name not allowed

Cause of error

In a TOOL CALL or TOOL DEF block you tried to define a tool name although it is prohibited by machine parameter.

Error correction

- Use the tool number.
- If required, contact your machine tool builder


Error description 2A0-00A8

Error message

Software option not active

Cause of error

You tried to use a software option that is not enabled on your TNC.

Error correction

Contact your machine tool builder or the control manufacturer to purchase the software option.


Error description 2A0-00A9

Error message

Kinematics cannot be restored

Cause of error

You tried to restore kinematics that do not match the currently active kinematics.

Error correction

Restore only kinematics that you have saved previously from an identical kinematics description.


Error description 2A0-00AA

Error message

Function not permitted

Cause of error

You tried to use a feature that is not enabled on your TNC by the Feature Content Level (FCL) management.

Error correction

By default, FCL functions are locked after a software update. By entering the code number 65535 in the SIK menu, you can enable these functions for a certain period of time for test purposes. You can enable FCL functions permanently by purchasing and
entering a code number. For more information, contact your machine tool builder or the control manufacturer.


Error description 2A0-00AB

Error message

Contradictory workpc. blank dim.

Cause of error

The workpiece blank dimensions you have defined in a fixed cycle are smaller than the dimensions of the finished part.

Error correction

Check the cycle definition and correct the input values.


Error description 2A0-00AC

Error message

Measuring position not allowed

Cause of error

The kinematic measurement resulted in a measuring position of 0° in one of the three rotary axes. This is not allowed.

Error correction

Select the starting angle, stopping angle and, if applicable, number of measurements on all three axes in a way that does not result in any 0° positions.


Error description 2A0-00AD

Error message

Handwheel inactive

Cause of error


Error description 2A0-00AE

Error message

HR not allowed

Cause of error


Error description 2A0-00AF

Error message

Wrong operating mode
for handwheel

Cause of error


Error description 2A0-00B0

Error message

Manual

Cause of error


Error description 2A0-00B1

Error message

Handwheel

Cause of error


Error description 2A0-00B2

Error message

Manual input

Cause of error


Error description 2A0-00B3

Error message

Single Block

Cause of error


Error description 2A0-00B4

Error message

Full Sequence

Cause of error


Error description 2A0-00B5

Error message

Edit table

Cause of error


Error description 2A0-00B6

Error message

T%s: Remaining tool life too short

Cause of error

The remaining tool life (TIME2 column in the tool table) of the tool indicated in the error text has been exceeded.

Error correction

- Use a new tool.
- Correct the current tool life (CUR.TIME column in the tool table).
A complete list of the tools whose tool life has expired is contained in the TOOLLIST.ERR file stored in the TNC:\ directory.


Error description 2A0-00B7

Error message

FN 14: Error code %s

Cause of error

Forced error through function FN14 (ISO: D14). With this function the TNC calls the preprogrammed messages of the machine manufacturer (e.g. from an OEM cycle). If during a program run or test run the TNC comes to a block with FN14 (D14), it stops
operation and displays a message. You must then restart the program.

Error correction

Refer to the User's Manual for a description of the error. Correct the error and restart the program.


Error description 2A0-00B8

Error message

FN 14: error code %-3u

Cause of error

Forced error through function FN14 (ISO: D14). With this function the TNC calls the preprogrammed messages of the machine manufacturer (e.g. from an OEM cycle). If during a program run or test run the TNC comes to a block with FN14 (D14), it stops
operation and displays a message. You must then restart the program.

Error correction

Refer to the User's Manual for a description of the error. Correct the error and restart the program.


Error description 2A0-00B9

Error message

Calculated error no. too large

Cause of error

Calculation of an error number for the FN14 function (ISO: D14) from a Q parameter resulted in a value outside the permissible range of 0 to 499.

Error correction

Edit the part program.


Error description 2A0-00BA

Error message

Tool %s not defined

Cause of error

You called a tool that is not contained in the tool magazine.

Error correction

Check the pocket table and add the tool if required.
A complete list of the tools that are not contained in the tool magazine can be found in the the TOOLLIST.ERR file stored in the TNC:\ directory.


Error description 2A0-00BB

Error message

block scan inconsistent %s

Cause of error

During restoration of the machine status after a block scan (mid-program startup), the conditions on the machine regarding spindle speed (S), traverse range (R) or preset (P) were not the same as calculated in the block scan.

Error correction

- Shut down the control and restart it.
- Inform your machine tool builder.


Error description 2A0-00BC

Error message

Limit switch %.2s-

Cause of error

The calculated path of the tool exceeds the traversing range (software limit switch) of the machine
- Software limit switch was reached in a manual operating mode

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.
- Move the tool in the opposite direction.


Error description 2A0-00BD

Error message

Limit switch %.2s-

Cause of error

The calculated tool path exceeds the machine's traverse limits.
Negative traverse range is defined with MP92x.x.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.


Error description 2A0-00BE

Error message

Limit switch %.2s+

Cause of error

- The calculated path of the tool exceeds the traversing range (software limit switch) of the machine
- Software limit switch was reached in a manual operating mode

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.
- Move the tool in the opposite direction.


Error description 2A0-00BF

Error message

Limit switch %.2s+

Cause of error

The calculated tool path exceeds the machine's positive traverse limits.
Positive traverse range is defined with MP91x.x.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.


Error description 2A0-00C0

Error message

Required element missing

Cause of error

Not all required data have been entered in an NC block.

Error correction

Add the missing information.


Error description 2A0-00C1

Error message

File does not exist

Cause of error

- The given file does not exist.
- The given file has been deleted since last used.
- You tried to select a file whose name exceeds the permitted length.
- smarT.NC: You selected an .HU program that uses a point table that does not exist on the TNC hard disk.
- You entered an incorrect path under >MOD >Print (print test).
- You tried to open and edit a file protected by SELinux (access check).

Error correction

- Use an existing file for the selected file operation.
- Pay attention to the maximum permissible length of the file name.
- Check the .HU program for missing point tables and restore or read-in the missing files
- Correct the path entry.
- Deactivate SELinux temporarily.


Error description 2A0-00C2

Error message

File type missing or incorrect

Cause of error

You tried to create a new file without first defining the appropriate file type.

Error correction

Enter the correct file type.


Error description 2A0-00C3

Error message

No datum table selected

Cause of error

You tried to select a datum number by soft key although no datum table is selected in the program header.

Error correction

- Under options in the program header (UNIT 700), enter a datum table from
which the datums can be selected.
- Make sure that you have entered the correct path name in the
UNIT 141 or in the program header (UNIT 700).


Error description 2A0-00C4

Error message

No polar coordinates possible

Cause of error

You pressed the P key to enter polar coordinates. Polar coordinates are not programmable for the active function.

Error correction

Enter Cartesian coordinates to program the active function, or use a function that permits polar coordinate input.


Error description 2A0-00C5

Error message

Incremental input not allowed

Cause of error

You attempted to enter an incremental value by pressing the I key.

Error correction

Enter an absolute value.


Error description 2A0-00C7

Error message

MC: System error in SPLC-RTS

Cause of error

- Internal software error in the run-time system (RTS) of the SPLC on the MC

Error correction

Inform your service agency


Error description 2A0-00C8

Error message

Faulty recognition of PL/MB hardware

Cause of error

An error occurred during detection and evaluation of the safety-related PL and MB hardware.

Error correction

- Check the connection and function of HSCI-PLs and MB
- Inform your service agency


Error description 2A0-00C9

Error message

I/O assembly %1 reports an error

Cause of error

A safety-related HSCI-PL or the MB supplies invalid data.

Error correction

- Find and exchange the faulty device
- Inform your service agency


Error description 2A0-00CA

Error message

I/O assembly %1 reports an error

Cause of error

A safety-related HSCI-PL or the MB reports an error.

Error correction

- Check the wiring and condition of the PLs or the MB.
- Inform your service agency


Error description 2A0-00CB

Error message

MC: System error in SPLC-RTS

Cause of error

- Internal software error in the run-time system (RTS) of the SPLC by the MC

Error correction

Inform your service agency


Error description 2A0-00CC

Error message

MC: System error in SPLC-RTS

Cause of error

- Internal software error in the run-time system (RTS) of the SPLC by the MC

Error correction

Inform your service agency


Error description 2A0-00CD

Error message

Run-time error in SPLC program

Cause of error

- Run-time error in the SPLC program

Error correction

Inform your service agency


Error description 2A0-00CE

Error message

SPLC cannot load program

Cause of error

The SPLC program cannot be loaded.

Error correction

Inform your service agency


Error description 2A0-00CF

Error message

SPLC program has changed

Cause of error

The SPLC program or the NC software was changed after the machine safety acceptance.

Error correction

Restore the original SPLC program or perform the safety acceptance again.


Error description 2A0-00D0

Error message

SPLC program cannot run

Cause of error

SPLC program cannot be started

Error correction

- Note further error messages.
- Inform your service agency


Error description 2A0-00D1

Error message

Machine not in safe operation

Cause of error

The control commissioning is not yet concluded. The functional safety of the machine is not ensured.


Error description 2A0-00D2

Error message

Configuration of SPLC inputs

Cause of error

The configuration of the SPLC inputs with inverse logic is faulty.

Error correction

- Check configuration in safety-related machine parameters inpNoInverseA and inpNoInverseB.
- Inform your service agency


Error description 2A0-00D3

Error message

Configuration of SPLC inputs

Cause of error

The configuration of the SPLC inputs that are participating in the minute test is faulty.

Error correction

- Check configuration in safety-related machine parameter inpNoDynTest.
- Inform your service agency


Error description 2A0-00D4

Error message

Configuration of SPLC cycle time

Cause of error

Configured cycle time for SPLC is too long or too short.

Error correction

- Check configuration in machine parameter plcCount.
- Inform your service agency


Error description 2A0-00D5

Error message

Functional Safety (FS) not ensured!

Cause of error

This installation of the control software is a test version:
- This control software may be used only for test purposes!
- The functional safety of the machine is not guaranteed!
- Therefore be careful when running the machine, particularly when the guard doors are open!


Error description 2A0-00D6

Error message

ACCESSLEVEL: Function locked

Cause of error

- Desired function in the active ACCESSLEVEL is locked

Error correction

- Enable the function through ACCESSLEVEL


Error description 2A0-00D7

Error message

Protected File!

Cause of error

You cannot edit or erase this program until the protection has been removed.

Error correction

Cancel the program protection.


Error description 2A0-00D8

Error message

smarT.NC: Copy/Cut
smarT.NC:
Copy

Cause of error


Error description 2A0-00D9

Error message

Changed NC software version

Cause of error

- The NC software version was changed after the machine safety acceptance.
- NC software version and version of the file used, SplcApiMarker.def, do not match.

Error correction

- Transfer the SplcApiMarker.def file appropriate to the installed NC software version into the SPLC project.
- Enter the value of the constant SPLC_API_VERSION from this file into the safety-related machine parameter splcApiVersion in CfgSafety
- Repeat the safety inspection and approval of the machine with the appropriate comprehensiveness.
- Inform your service agency


Error description 2A0-00DA

Error message

Error in SPLC configuration data

Cause of error

- The configuration data for the SPLC are incorrect. It is not possible to translate the PLC program until these data are corrected.

Error correction

- Correct the configuration data for SPLC Note further error messages regarding this.
- Inform your service agency


Error description 2A0-00DB

Error message

Incorrect condition of safe output %1

Cause of error

- Indicated SPLC output is logical 1 (+24 V), although SPLC specifies logical 0 (0 V) for the output.
- Faulty wiring (short circuit to +24 V)
- PLD module defective

Error correction

- Check the wiring
- Exchange the defective PLD module
- Inform your service agency


Error description 2A0-00DC

Error message

AFC: No reference power recorded

Cause of error

Adaptive Feed Control (AFC), learning mode:
The TNC could not find any reference power.
Possible cause: Test cut in the air

Error correction

Repeat the teach-in cut.


Error description 2A0-00DD

Error message

Faulty assignment of tool/cut no.

Cause of error

AFC: In the AFC settings the assignment of the current cut number to the current tool is faulty.

Error correction

Repeat the teaching process.
The TNC automatically resets the current cut to "Teach".


Error description 2A0-00DE

Error message

Wiring of SPLC input %1

Cause of error

According to the configuration (CfgSafety / inpNoDynTest), the SPLC input named in the text participates in the dynamic test but does not drop out although the corresponding test output was switched off.

Error correction

- Check the wiring
- Check the configuration


Error description 2A0-00DF

Error message

Wiring of emergency stop

Cause of error

An emergency stop input does not drop out, although the associated test output was switched off.

Error correction

Check the wiring. All emergency stop circuits must be supplied with current over the corresponding test outputs.


Error description 2A0-00E0

Error message

Wrong input %1 for dynamic test

Cause of error

The indicated SPLC input cannot be tested with the minute test (dynamic test)
- No physical PLC input with the indicated number exists
- The PLC input is neither on a system PL (PLB 62xxFS) nor on a safe machine operating panel (MB 6xxFS) even though there is more than one system PL in the HSCI system.

Error correction

- Check machine parameter inpNoDynTest in CfgSafety.
- Inform your service agency.


Error description 2A0-00E1

Error message

MC error during cross comparison at input %1

Cause of error

The two terminals of a dual-channel FS input have differing logical conditions.
Possible causes:
- Key on the machine operating panel was pressed on a slant
- Breakage in the wiring of an FS input
- Short circuit on 0 V or 24 V in the wiring of an FS input
- Incorrect configuration (SMP) of inverse FS inputs (e.g. with antivalent or inverted signal)

Error correction

- Check the keys on the machine operating panel. If one of the keys had been pressed at an incorrect angle, then no further measures are necessary
- Check the wiring of the affected dual-channel input
- Inform your service agency
Note that the input cannot be put back into the trigger state until both input terminals are in the idle state.


Error description 2A0-00E2

Error message

Unexpected condition of SPLC input %1

Cause of error

According to the machine parameter configuration, the given SPLC input in the idle state should be providing 0 V and another channel 24 V.
This is not the case.
Possible causes:
- Configuration of the SPLC input is faulty
- Input is not in the idle state during the self-test
- Wiring is faulty.
- The connected handwheel is not suitable for functional safety (FS)
- The handwheel has been replaced by an unsuitable dummy plug (not suitable for FS)

Error correction

- Check the wiring
- Check the configuration
- Check connected handwheel and exchange it if necessary
- Check the dummy plug and exchange it if necessary
- Inform your service agency


Error description 2A0-00E3

Error message

Select override:
Handw./ Op. panel
CAUTION F/S values

Cause of error


Error description 2A0-00E4

Error message

Control strategy not found in AFC.TAB. Default will be used.

Cause of error

The control could not find the control strategy assigned to the active workpiece in the table AFC.TAB.

Error correction

Correct the entries in the AFC column of the tool table or in the AFC.TAB table.


Error description 2A0-00E5

Error message

Input marker %1 set by SPLC program

Cause of error

- The SPLC program has an input marker set to the value TRUE (= 1). This is not allowed.
- Input markers can be deleted by the SPLC program (= 0), but they cannot be set (= 1)

Error correction

- Check the SPLC program and correct it if necessary
- Inform your service agency


Error description 2A0-00EC

Error message

AFC parameters not allowed in turning mode

Cause of error

An AFC parameter was programmed that is not permitted in turning mode, e.g. TIME or DIST.

Error correction

Check the NC program and adapt it if necessary


Error description 2A0-00ED

Error message

Program-run graphics: Incomplete display

Cause of error

The TNC is so busy machining the current workpiece that the program-run graphics are sometimes not being updated, and can therefore be incomplete.

Error correction

No corrective action possible


Error description 2A0-00EE

Error message

AFC: No idle power recorded

Cause of error

The acceleration phase to the starting speed could not be concluded before the first cutting block was reached; therefore the idle power could not be determined.

Error correction

Only perform the first cutting block once it is ensured that the starting speed has been reached.


Error description 2A0-00EF

Error message

AFC: function is not in effect; inconsistent input values

Cause of error

A FUNCTION MODE ... command was executed after the TOOL CALL. That is not allowed.

Error correction

Edit the NC program


Error description 2A8-0003

Error message

Place handwheel in charger

Cause of error

The wireless handwheel is not located in the charging station although the handwheel mode is not active. If the rechargeable battery of the handwheel is emptied or there is interference in the radio connection, the TNC releases an emergency stop.
In this case the program run is canceled.

Error correction

Always place the handwheel in the loading station when you are not working with it.


Error description 2A8-0004

Error message

Configuration error in OEM handwheel menu or soft key

Cause of error

The configuration of an OEM handwheel menu or an OEM handwheel soft key is incomplete or faulty.

Error correction

Inform your service agency.


Error description 2A8-0007

Error message

Battery almost empty. Place handwheel into the charging station

Cause of error

The wireless handwheel’s rechargeable battery is almost empty.
If the rechargeable battery loses charge, it interrupts the connection to the handwheel.
This results in an emergency stop and the program run is aborted!

Error correction

- Now place the handwheel onto the charging station to restore its charge.
- Recommendation: Always keep the handwheel in the charging when not in use.


Error description 2A9-0001

Error message

Faulty BLK FORM

Cause of error

The given workpiece blank definition is faulty and could not be interpreted by the control.

Error correction

- Correct the BLK FORM in the NC program.


Error description 2A9-0002

Error message

Incorrect tool data

Cause of error

The 3-D simulation graphic cannot process the tool data.

Error correction

Adapt the tool data


Error description 2A9-0003

Error message

3-D simulation graphic is being recalculated...


Error description 2A9-0004

Error message

Graphics memory exhausted

Cause of error

No more graphics memory is available for displaying the 3D material removal simulation. The simulation was automatically aborted, so as not to endanger the system stability.

Error correction

- Adjust the graphics settings, e.g set the model quality to "low"
- Restart the simulation


Error description 2A9-0005

Error message

3-D test graphic is being recalculated

Cause of error

The representation of the material removal simulation uses to much graphics memory. Simulation with the set level of detail is not possible.
In order to finish simulating the NC program, a simplified workpiece model with lower memory requirements was switched to automatically.
This can reduce the level of detail.


Error description 2A9-0009

Error message

Rapid-traverse cut near block %1

Cause of error

The simulation detected possible cutting of material at rapid traverse near the indicated block number.

Error correction

- Check the position and size of the BLK FORM
- Increase the quality of the simulation
- Edit the NC program


Error description 2A9-000B

Error message

System error when calculating the graphics

Cause of error

System error during internal calculation of the 3-D graphical representation during program run or a test run.

Error correction

Inform your service agency


Error description 2A9-000C

Error message

Violation of the workpiece near block %1

Cause of error

The simulation detected a possible violation of the workpiece by a non-cutting part of the tool (holder or shank) near the indicated block number.

Error correction

Check the position and size of the BLK FORM, as well as the tool data, and edit the NC program if necessary


Error description 2A9-000D

Error message

%2 3-D model not loaded %1

Cause of error

Error while reading the 3-D model: the file could not be opened or is not a supported 3-D data format.

Error correction

- Check the path and correct it if necessary
- Reload the file


Error description 2A9-000E

Error message

%2 3-D model not loaded %1

Cause of error

Could not load the 3-D model because it does not fulfill the quality requirements.
The following requirements are in place for 3-D models:
- All dimensions in mm
- No gaps between triangles ("waterproof")
- No overlapping
- No degenerated triangles

Error correction

Regenerate the 3-D model and transfer it to the control.


Error description 2A9-000F

Error message

%2 3-D model not loaded %1

Cause of error

Error while reading the 3-D model: the file contains too many triangles.

Error correction

- Use a rougher 3-D model
- Generate the 3-D model with the CAD program again and transfer it to the control. In many CAD programs the level of detail can be set when exporting.


Error description 2A9-0010

Error message

Workpiece could not be exported

Cause of error

Could not write the file.

Error correction

- Check the path and correct it if necessary
- Check the available memory


Error description 2A9-0011

Error message

Ext. workpiece monitoring temporarily deactivated

Cause of error

Too many blocks with violations of the workpiece were found.
Extended workpiece monitoring will be deactivated until the next BLK FORM.

Error correction

Check and correct as necessary:
- Tool data
- Position and shape of the workpiece
- Cuts at FMAX


Error description 2A9-0012

Error message

Workpiece could not be exported

Cause of error

There is no workpiece present.


Error description 2A9-001E

Error message

Real-time graphical simulation stopped

Cause of error

The RAM currently available does not suffice to display the real-time graphical simulation.


Error description 2A9-001F

Error message

Graphical simulation was switched to 2.5D

Cause of error

Only little RAM is available for displaying the graphical simulation. 2.5D mode was switched to in order to save RAM.


Error description 2A9-0020

Error message

Fixture violation near block %1

Cause of error

A possible violation of the fixture by a cutting part or a non-cutting part of the tool was detected near the indicated block number.

Error correction

- Check the fixture position
- Check the tool data
- Edit the NC program, if necessary


Error description 2AA-0005

Error message

Database error

Cause of error

Access to the table was not possible for the following reasons:
- The table is write-protected
- The table is corrupted
- The table does not exist

Error correction

Check the table


Error description 2D4-0000

Error message

Start of Python script "%1" failed

Cause of error

Communication with the PLC necessary for starting the Python script has failed.

Error correction

- Compile the PLC program
- Restart the Python script


Error description 2D4-0001

Error message

Start of Python script "%1" failed

Cause of error

The exact cause of the error is unknown.

Error correction

Inform your service agency.


Error description 2D4-0002

Error message

Start of Python script "%1" failed

Cause of error

The Python option is not enabled For Python applications to be run on the control, the "Python OEM Process" software option must be enabled in the SIK.

Error correction

- "Python OEM process" software option was not enabled in the SIK


Error description 2D4-0003

Error message

Start of Python script "%1" failed

Cause of error

Too little free working memory available to run the Python script.

Error correction

- Assign less memory requirement to the Python script over the machine configuration ("memLimit" machine parameter)
- Close running Python processes to free memory.


Error description 2D4-0004

Error message

Start of Python script "%1" failed

Cause of error

The value of the machine parameter "memLimit" (maximum process memory) is invalid.

Error correction

- Check the machine parameter "memLimit" and correct it


Error description 2D4-0005

Error message

Start of Python script "%1" failed

Cause of error

The path entered in the machine configuration for the Python script is invalid.

Error correction

- Correct the machine parameter in the CfgSoftkeyOverlay config object.


Error description 2D4-0006

Error message

Start of Python script "%1" failed

Cause of error

The name entered in the machine configuration for the Python process is invalid.

Error correction

- Correct the machine parameter "jobName" in the CfgSoftkeyOverlay config object.


Error description 2D4-0007

Error message

Start of Python script "%1" failed

Cause of error

A Python process with the same name is already running.

Error correction

- If desired, terminate the running Python process


Error description 2D4-0008

Error message

Start of Python script "%1" failed

Cause of error

In the machine configuration there are invalid parameters defined for the Python script.

Error correction

- Correct the machine parameter "parameter" in the CfgSoftkeyOverlay config object.


Error description 303-0001

Error message

Referenced OPC UA namespace %1 does not exist

Cause of error

The entities CfgOpcUaObject and CfgOpcUaPlcVar with the following keys do not refer to an existing OPC UA namespace configuration:
%1
The nodes stated and all child elements will not be created.

Error correction

Check the withinNamespace attribute


Error description 303-0002

Error message

Referenced OPC UA parent node %1 does not exist

Cause of error

The entities CfgOpcUaObject and CfgOpcUaPlcVar with the following keys use the attribute parentNode to refer to a parent node that does not exist:
%1
The nodes and all child elements will not be created.

Error correction

Check the parentNode attribute


Error description 303-0003

Error message

Invalid value for nodeIdIdentifier %1

Cause of error

nodeIdType was set to Numeric
in the configuration datum
%1.
However, the value entered for nodeIdIdentifier is not a numeric value.
The node and all child elements will not be created.

Error correction

Check the nodeIdType and nodeIdIdentifier attributes in the indicated configuration datum


Error description 303-0004

Error message

Invalid value for publicationDate %1

Cause of error

The publication date entered in the configuration datum
%1
does not match the format YYYY-MM-DDThh:mm:ss.sssTZD.

Error correction

Check the configuration datum


Error description 303-0005

Error message

Multiple definitions of the namespace URI %1

Cause of error

The namespace URI of an OPC UA namespace must be unique.
The namespaceUri in the CfgOpcUaNamespace entities with the following keys is identical:
%1 (%2 entities)
Only the first namespace configuration stated is active.

Error correction

Check the configuration of the namespaceUri


Error description 303-0006

Error message

Value not permitted for namespaceUri %1

Cause of error

The OPC UA namespace URI entered in the configuration datum
%1
is not permitted, since it is too similar to other names or namespace URIs that have already been assigned.
The namespace and all nodes it contains will not be created.

Error correction

Select a different URI for the OPC UA namespace


Error description 303-0007

Error message

Multiple use of NodeId %1

Cause of error

The same NodeId was configured for the entities CfgOpcUaObject and CfgOpcUaPlcVar with the following keys:
%1 (%2 entities)
Only the first node stated will be created.

Error correction

Check the configuration of the withinNamespace, nodeIdType, and nodeIdIdentifier attributes


Error description 303-0008

Error message

Attribute %1 was not configured

Cause of error

No value was entered
in the configuration datum
%1.
It is absolutely essential. The node and all child elements will not be created.

Error correction

Check the configuration datum


Error description 303-0009

Error message

Cyclic parent-child relationship

Cause of error

The entities CfgOpcUaObject and CfgOpcUaPlcVar with the following keys form a cyclic reference though their parentNode attributes:
%1
This is not permitted. The nodes stated and all child elements will not be created.

Error correction

Check the respective parentNode attributes


Error description 303-000A

Error message

Invalid namespace URI %1

Cause of error

An invalid namespace URI was entered in the namespaceUri attribute
in the configuration datum
%1.
The node and all child elements will not be created.

Error correction

Enter a correct namespace URI


Error description 303-000B

Error message

Invalid parent node: %1

Cause of error

The entity CfgOpcUaObject
%1
references an CfgOpcUaPlcVar entity as parent node.
This is not allowed. The node and all child elements will not be created.

Error correction

Check the parentNode attribute


Error description 303-000C

Error message

Impermissible multiple use of browseName %1

Cause of error

The same browseName is used below the same parent node in the entities CfgOpcUaObject and CfgOpcUaPlcVar with the following keys:
%1 (%2 entities)
Only the first node stated will be created.

Error correction

Check the configuration of the browseName attribute


Error description 303-000D

Error message

More than %1 variables are configured

Cause of error

The machine manufacturer configured many variables for access through OPC UA NC Server.
If OPC UA clients order subscriptions to all of these variables, a system overload can occur.
%2 variables are configured.

Error correction

Reduce the number of variables


Error description 303-000E

Error message

The configuration of the OPC UA NC Server has changed

Cause of error

The OEM-specific configuration of OPC UA NC Server was changed. The changes will take effect the next time the server is restarted.

Error correction

Restart the server to activate the changes. Active connections will be disconnected.


Error description 303-0012

Error message

Invalid range specified %1

Cause of error

The range specified in the configuration datum
%1
is not valid. The minimum value is greater than the maximum value.
The variable node will not be created.

Error correction

Check the configuration datum


Error description 303-0013

Error message

Incomplete range specified %1

Cause of error

The range specified in the configuration datum
%1
is not complete. Either the minimum value or the maximum value is missing.
The variable node will not be created.

Error correction

Check the configuration datum


Error description 303-0014

Error message

EURange outside of InstrumentRange

Cause of error

The range specified for EURange in the configuration datum
%1
exceeds the range specified for InstrumentRange
in the configuration datum
%2
InstrumentRange indicates the maximum permissible range of values, and therefore must not be exceeded by EURange.
The variable node will not be created.

Error correction

Check the configuration datum


Error description 303-0015

Error message

Unknown UnitCode %1

Cause of error

The UnitCode entered in the configuration datum
%1
is unknown to the control.
The variable node will not be created.

Error correction

Check the configuration datum


Error description 303-0016

Error message

Unknown PLC symbol %1

Cause of error

A PLC symbol name was entered in the configuration datum
%1
, but the name is not defined in the PLC program.

Error correction

Check the configuration datum


Error description 303-0017

Error message

Meta-information does not match the PLC operand

Cause of error

Meta-information for numerical values was configured
in the configuration datum
%1.
However, the data type of the indicated PLC operand is not numerical.
The meta-information will be ignored.

Error correction

Delete the meta-information or indicate the correct PLC operand


Error description 303-0018

Error message

Meta-information does not match the PLC operand

Cause of error

A valuePrecision was entered in the
configuration datum
%1.
However, this is supported only for the data types Word and DWord.
The indicated valuePrecision will be ignored.

Error correction

Delete the value for valuePrecision or enter a correct PLC operand


Error description 303-0019

Error message

Invalid index for PLC symbol %1

Cause of error

A PLC symbol with an invalid index
was addressed in the configuration datum
%1.

Error correction

Check the configuration datum


Error description 303-001A

Error message

PLC symbol %1 has no valid data value

Cause of error

A PLC symbol name that does not describe a valid data value (e.g., a PLC structure)
was entered in the configuration datum
%1.

Error correction

Check the configuration datum.
(The elements of PLC structures can be configured as separate variables.)


Error description 303-001B

Error message

Write-access configured for PLC constant

Cause of error

In the configuration datum
%1,
valueWritable was used to configure the PLC operand as writable.
However, the indicated PLC operand is a constant and therefore cannot be changed.
The attribute valueWritable will be ignored.

Error correction

Check the configuration datum


Error description 320-0001

Error message

Error while sending message to PLC

Cause of error


Error description 320-0002

Error message

PLC program not successfully compiled

Cause of error


Error description 320-0003

Error message

Argument out of range

Cause of error


Error description 320-0004

Error message

PLC is running in simulation mode

Cause of error


Error description 320-0005

Error message

PLC compiler argument ( %1 ) missing

Cause of error


Error description 320-0006

Error message

Invalid PLC call parameter

Cause of error


Error description 320-000A

Error message

Programmed spindle speed is too low

Cause of error

The spindle speed that programmed is too low.

Error correction

Program a faster shaft speed or check the configuration
datum Axes->ParameterSets->????->CfgFeedLimits->minFeed.
"????" designates the current name of the data record from the configuration.


Error description 320-000B

Error message

Rotational speed programmed for spindle too high

Cause of error

The shaft speed that you programmed for this axis is too low.

Error correction

Program a faster shaft speed or check the configuration datum Axes->ParameterSets->????->CfgFeedLimits->minFeed.
"????" designates the current name of the configuration set.


Error description 320-000C

Error message

%1

Cause of error

siehe Maschinenhandbuch

Error correction

siehe Maschinenhandbuch


Error description 320-000D

Error message

The PLC program has been stopped

Cause of error

The PLC program was stopped because of a system error in the PLC.

Error correction

Inform your machine tool builder.


Error description 320-000E

Error message

Error in PLC program

Cause of error

An error occurred during execution of the PLC program.

Error correction

Inform your machine tool builder.


Error description 320-000F

Error message

System error in the PLC

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 320-0010

Error message

General system error

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 320-0011

Error message

Spindle speed programmed without configured spindle

Cause of error

No spindle available, but speed has been programmed.

Error correction

Configure the spindle (CfgAxes->spindleIndices) or do not program a spindle speed.


Error description 320-0012

Error message

Configuration datum %1/%2
contains errors

Cause of error

The given configuration datum contains errors and was not accepted for control operation.

Error correction

Correct the given configuration data or inform your machine tool builder.


Error description 320-0013

Error message

Configuration datum %1
for channel %2 missing

Cause of error

The given configuration datum was not found.

Error correction

Add the given configuration datum or inform your machine tool builder.


Error description 320-0014

Error message

Configuration datum %1
for channel %2 already defined

Cause of error

The given configuration datum causes a multiple definition of an output to the PLC.

Error correction

Correct the given configuration data or inform your machine manufacturer.


Error description 320-0015

Error message

Operand %1
for configuration datum %2 not found

Cause of error

The operand described in the given configuration data was not defined in the PLC.

Error correction

Correct the given configuration data, select another PLC program and/or inform your machine manufacturer.


Error description 320-0016

Error message

Data of PLC strobe for channel %1
could not be transferred

Cause of error

The data belonging to the given output to the PLC could not be saved in PLC markers.

Error correction

Correct the associated configuration datum or inform your machine tool builder.


Error description 320-0017

Error message

Configuration and PLC program incompatible

Cause of error

A PLC program has been selected that is not compatible with the configuration of the machine.
Necessary prerequisites for the successful operation of the PLC program:
- PLC programs that operate with the numerical memory interface API 1.0 (TNC flag interface) can only control one operating mode group, one NC channel, and one spindle.
- PLC programs that use the symbolic memory interface API 3 must create the API data structures in the number suitable for the configuration.
- The correct values for the system parameters AXIS_COUNT and SPINDLE_COUNT must be defined in the configuration file of the PLC compiler.
- PLC programs must define a sufficiently large memory image. All permanently assigned, non-volatile, or absolutely addressed flags must fall within the memory image.
- PLC programs have to define all markers to which configuration data are to be assigned at the start of the PLC program.
- Pay attention to any other, previously issued warnings.

Error correction

- Check the machine configuration
- Check the configuration file of the PLC compiler for correct values
- Use a suitable PLC program
- Inform your service agency


Error description 320-0018

Error message

Inconsistent PLC program

Cause of error

The API version in the selectable PLC program is not compatible with the control software or the definition of the API version in the PLC program is faulty.

Error correction

Update the ApiMarker.DEF file from the PLC project of the machine, or correct the PLC program.


Error description 320-0019

Error message

Error in PLC program: Input was changed

Cause of error

The PLC program tried to change an input marker (e.g. I3).

Error correction

Correct the PLC program. Input markers can only be read, never written.


Error description 320-001A

Error message

PLC error table cannot be read
(%1)

Cause of error

The PLC cannot read your error table. It could be that the path configured for the table is incorrect or the table has an incorrect format.

Error correction

Check the configuration and PLC error table.


Error description 320-001B

Error message

PLC error table erroneous
(%1)

Cause of error

An invalid error marker was given in the PLC error table.It could be that a symbolic name is written incorrectly.

Error correction

Correct the PLC error table.


Error description 320-001C

Error message

Control cannot read operating times

Cause of error

The control cannot read one or more operating time values that are saved in a file. The file was presumably destroyed.

Error correction

If the error message appears repeatedly, inform your service agency.


Error description 320-001D

Error message

System error in the PLC

Cause of error

Internal software error:
The persistent storage of operating times in a file has failed, presumably because of an error in the file system.

Error correction

Inform your service agency.


Error description 320-0023

Error message

Invalid configuration for fast inputs
Number %1 - Operand %2

Cause of error

The configuration of the fast inputs is incorrect.

Error correction

Correct the configuration under consideration of the following constraints:
- PLC programs that use the TNC marker can only use the markers M4590-4593
- The data type D (DWORD) is required to record all edges
- Symbolic operands must be defined in the PLC program


Error description 320-0024

Error message

Configuration datum %1/%2 missing

Cause of error

The given configuration datum was not found.

Error correction

Add the given configuration datum or inform your machine tool builder.


Error description 320-0025

Error message

The PLC program has been stopped

Cause of error

Due to a change of the configuration data, the PLC was stopped and will be restarted.

Error correction

No correction necessary.


Error description 320-0026

Error message

PLC: Division by 0/ Modulo error

Cause of error

Run-time error in the PLC program:
- Division by 0 was caused.
- A modulo calculation was incorrectly executed.

Error correction

Edit the PLC program.
Change the PLC compiler setting DIVERROR/MODERROR.


Error description 320-0027

Error message

PLC: Overflow when multiplying

Cause of error

Run-time error in PLC program:
- Overflow during multiplication

Error correction

Edit the PLC program.
Change the PLC compiler setting MULERROR.


Error description 320-0028

Error message

Invalid configuration for PLC arithmetic error
operand %1

Cause of error

The configuration for treatment of PLC arithmetic errors is illegal.

Error correction

Correct the configuration under consideration of the following constraints:
- Examine the MULERROR, DIVERROR, and MODERROR entries in the configuration file for the PLC compiler (see entry under CfgPlcPath)
- PLC programs that use the TNC marker interface can use only the markers M4200 to M4202
- Symbolic operands must be defined in the PLC program


Error description 320-0029

Error message

System error in the PLC

Cause of error

A PLC server function that has not yet been implemented was called.

Error correction

Inform your service agency


Error description 320-002A

Error message

System error in the PLC

Cause of error

The PLC server cannot find the sender of a message.

Error correction

Inform your service agency


Error description 320-002B

Error message

System error in the PLC

Cause of error

The PLC server cannot reach the sender of a message.

Error correction

Inform your service agency


Error description 320-002C

Error message

System error in the PLC

Cause of error

A software error has occurred in the PLC.

Error correction

Inform your service agency


Error description 320-002D

Error message

Cannot read the PLC MAIN file
(%1)

Cause of error

The PLC cannot read its program file.

Error correction

Check the configuration and PLC program file.


Error description 320-002E

Error message

Cannot read the PLC compiler file
(%1)

Cause of error

The PLC cannot read a given compiler file.

Error correction

Check the PLC compiler configuration file (.cfg).Check the PLC compiler error text file (.err).


Error description 320-002F

Error message

Operand field %1 in datum %2 too large

Cause of error

The given symbolic name refers to a field of PLC operands. The field size is too large for the given configuration data item.

Error correction

Correct the given configuration item, or contact your machine tool builder.


Error description 320-0030

Error message

Operand field %1 in datum %2 too small

Cause of error

The given symbolic name refers to a field of PLC operands. The field size is too small for the given configuration data item.

Error correction

Correct the given configuration item, or contact your machine tool builder.


Error description 320-0031

Error message

Invalid text source

Cause of error

A text source configured for dialog and error texts cannot be loaded.

Error correction

Configure another language or contact your machine tool builder.


Error description 320-0032

Error message

PL510 fault in cyclic operation

Cause of error

An EMC disturbance has occurred in the cyclical PL 510 mode. The periphery cannot be used.

Error correction

Inform your machine tool builder


Error description 320-0033

Error message

System error in the PLC

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 320-0034

Error message

Strobe was not realized

Cause of error

A strobe output was not realised after the block scan


Error description 320-0035

Error message

System-management-bus initialization failed

Cause of error

No support for system management bus, or version of operating system is too old.

Error correction

Inform your service agency.


Error description 320-0036

Error message

Error in PLC Python script

Cause of error

The given PLC Python script has an error.

Error correction

Inform your machine tool builder.


Error description 320-0037

Error message

Error in PLC program

Cause of error

PLC run-time error:
An error occurred when an API was called in the PLC program.

Error correction

Edit the PLC program.


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The programmed parameter is outside the valid range

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The programmed parameter is invalid/does not exist

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The programmed address is outside the valid value range

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Sum of address and block length outside valid value range

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The programmed address is not a word or double word address

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The programmed value can/must not be changed

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Programmed file is faulty

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Wrong NC operating mode is active

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- A position command or another job is already being executed

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- No tool changer defined

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- String cannot be converted or contains illegal characters in the string

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- No end of string detected, or string incomplete

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- No connection over interface or to a server

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- RS-232 interface busy or not assigned

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- RS-232 transmit buffer not empty

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- RS-232 receiving buffer empty

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- RS-232 baud rate not possible

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Transmission error of RS-232 interface

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- No current controller found

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The PLC module was not called as a submit or spawn job

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

An error occurred when a PLC module was called in the PLC program. The PLC module was called during program run without a strobe.

Error correction

- Check and correct the PLC program
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Overflow of key queue

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Overflow of PLC error message queue

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The PLC module was called from a submit or spawn job

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Too many elements in a constants field

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Illegal elements programmed in a constants field

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Oriented spindle stop already active

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Module function is already active

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The entered file name is invalid!

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The programmed field name does not exist

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Syntax error of the query statement

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- No fitting data record available for the inquiry

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The programmed axis has not yet been referenced

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The reset of a connected external device is faulty

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The editor is not active

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- A general error occurred during a data access

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The control's system memory is too small

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Error occurred during parsing

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Fast PLC input set when drives are to be switched on

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The drives cannot be switched on

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The inspection of the number type was interrupted during entry in the tool table

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The powerfail monitoring cannot be switched off

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The control is a system without functional safety (FS)

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Error occurred in the evaluation of the soft-key resource file

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The PLC module execution was canceled

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- There has been an Profibus error

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program

Error correction

- Check and correct the PLC program
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The programmed function is not supported by the PLC module

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The programmed function is supported only by a dual-processor control.

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The control hardware does not have a serial interface

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The programmed function is not supported by a dual-processor control

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- File could not be disabled

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Entered file not found

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The function (software option or FCL) has not not been released

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The function not available when there is more than one configured NC channel

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Could not start the programmed process (Python)

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- This hardware does not support the programmed analog output at X8/X9

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The PLC module could not be run

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The transferred symbol/designator does not exist

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Could not create the handle

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- The transferred handle is invalid

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- Wrong data direction for transmission

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0037

Error message

Error in PLC program

Cause of error

- An error occurred when an PLC module was called in the PLC program
- A control with functional safety (FS) does not support the function called

Error correction

- Check the PLC program and correct it
- Inform your service agency


Error description 320-0038

Error message

Operand %1 for configuration datum %2 illegal

Cause of error

The operand defined in the given configuration datum is not allowed at this location.
In most cases, configuration data can refer only to ordinary logical PLC markers (type M) or ordinary arithmetic PLC operands (types B,W,D).

Error correction

Correct the given configuration datum, and select another PLC program or inform your machine manufacturer


Error description 320-0039

Error message

Configuration datum %1

Cause of error

Correct the given configuration datum or inform your machine manufacturer

Error correction

Too many configuration data of the given type were defined.


Error description 320-003A

Error message

PLC: Error in magazine rules file

Cause of error

The selected magazine rules file is missing or contains errors.

Error correction

Restore or correct the magazine rules file.


Error description 320-003B

Error message

Default setting of IOC hardware is incomplete

Cause of error

The default setting for the use of the IOC hardware and the IOC configuration file is incomplete:
(see also the machine parameter iocProject under CfgPlcPeriphery)
- IOC file not found
- Hardware is configured in the IOC file, but the file is not available
- IOC hardware is available, but the IOC file is not configured

Error correction

- Match the configuration file and hardware.
- You can find more information in the diagnostics menu


Error description 320-003C

Error message

Profibus initialization incorrect

Cause of error

An error occurred during initialization of the Profibus hardware.

Error correction

- Inform your service agency
- You can find more diagnostic information in the diagnostics menu.


Error description 320-003D

Error message

Profibus error in cyclic operation

Cause of error

An error occurred during access to the Profibus hardware.

Error correction

- Inform your service agency
- You can find more diagnostic information in the diagnostics menu.


Error description 320-003E

Error message

Faulty initialization of IOC hardware

Cause of error

Errors occurred while initializing the IOC hardware and the IOC configuration file (see the attribute iocProject under CfgPlcPeriphery).

Error correction

- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Inform your service agency


Error description 320-003F

Error message

Faulty HSCI initialization

Cause of error

An error occurred while initializing the HSCI hardware.

Error correction

- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Inform your service agency
- Pay attention to any other, previously issued warnings


Error description 320-0040

Error message

Error from PL/MB in cyclic operation

Cause of error

A PL component (PLB), a machine operating panel (MB, TE), or a PL part of a compact inverter (UEC, UMC) reported an error.

Error correction

- Inform your service agency
- For more diagnostics information about the affected device and the cause, see the bus diagnosis under HSCI


Error description 320-0041

Error message

SPLC MAIN file cannot be read
(%1)

Cause of error

The PLC cannot read the program file for the SPLC program.

Error correction

Check configuration and SPLC program file.


Error description 320-0042

Error message

Inconsistent SPLC program

Cause of error

The API version in the selectable SPLC program is not compatible with the control software or the definition of the API version in the SPLC program is faulty.

Error correction

Update the file SplcApiMarker.DEF or correct the SPLC program. The file SplcApiMarker.def must be included in the SPLC program before all other definition files.


Error description 320-0043

Error message

Inconsistent SPLC program

Cause of error

The definition of the markers that are transferred between the PLC program and SPLC program is faulty.

Error correction

Correct the SPLC program


Error description 320-0044

Error message

SPLC program has changed

Cause of error

The SPLC program has been edited. A partial acceptance test must be conducted before the machine can be operated with this edited SPLC program.

Error correction

Intended change:
Delete the error message, then restart the control and run the required partial acceptance test.
Unintended change:
Undo the change of the SPLC program and recompile the SPLC program.


Error description 320-0045

Error message

SPLC program binary code has changed

Cause of error

The binary code of the SPLC program has been changed, although the source code has remained unchanged.
Possible causes:
- New SPLC compiler through software update
- Corrupted binary file of the SPLC program on MC or CC (without software update)

Error correction

Message appears after a software update:
Delete the error message, then restart the control and run the required partial acceptance test. Then take the new CRC sum into the corresponding safe machine parameters.
Message appears, although no software update has been conducted:
Inform your service agency


Error description 320-0046

Error message

%1

Cause of error

siehe Maschinenhandbuch

Error correction

siehe Maschinenhandbuch


Error description 320-0047

Error message

Configuration PLC compiler: Enter %1

Cause of error

A value inappropriate for the control model is defined for a constant in the configuration file for the PLC compiler.
The values of the constants OMG_COUNT, CHANNEL_COUNT, AXIS_COUNT and SPINDLE_COUNT must be entered correctly.

Error correction

- Check the configuration file of the PLC compiler and correct it if necessary


Error description 320-0048

Error message

PLC program source code required

Cause of error

Because of a reconfiguration, the PLC program is no longer suitable on the control.
The PLC program must be regenerated from the source code.

Error correction

- Undo the configuration change (ignore the repeated error message).
- Copy the source code of the PLC program to the control and compile it.


Error description 320-004A

Error message

AC powerfail

Cause of error

An error occurred during the AC Fail process.
The line voltage was intermittently interrupted.
Possible causes:
- Power failure
- Dropout in line power
- Defective protection of the line power supply
- Check the wiring of the line power supply

Error correction

- Check the line power circuit breakers
- Check the power supply wiring
- Check the quality of the line voltage (possible dropouts)
- Inform your service agency


Error description 320-004B

Error message

DC powerfail

Cause of error

An error occurred during the DC Fail process. The dc-link voltage is below the specified limit.

Error correction

- Check the dc-link voltage
- Check the DC-link charging contactor for interruptions
- Check the line power supply
- Check the line power circuit breakers
- Check the wiring of the line power
- Check the quality of the line voltage (possible dropouts)
- Inform your service agency


Error description 320-004C

Error message

Error: Process %1 could not be started

Cause of error

The hardware used does not have enough main memory.

Error correction

Inform your service agency.


Error description 320-004D

Error message

Error: Process %1 could not be started

Cause of error

The command line transferred to the process is too long.

Error correction

Ensure that the command line has fewer than 127 characters.


Error description 320-004E

Error message

Error: Process %1 could not be started

Cause of error

The name selected for the process is ambiguous.

Error correction

Select another unique name for the process.


Error description 320-004F

Error message

Error: Process %1 could not be started

Cause of error

Possible causes:
- The given path does not lead to a valid Python script.
- Fatal errors occurred during initialization of the Python script.
- The assigned memory was exhausted during initialization of the Python script.
- Other system resources were exhausted during initialization of the Python script.

Error correction

- Check the path of the Python script and correct it if necessary.
- Ensure that all required libraries are installed in the required versions.
- Increase the memory reserved for the script.


Error description 320-0050

Error message

Error: Process %1 could not be started

Cause of error

An excessively long name was entered for the Python process.

Error correction

- Edit the Python script. The name of the Python process must be shorter than 17 characters.


Error description 320-0051

Error message

Error: Process %1 could not be started

Cause of error

Possible causes:
- The path given for the Python script is too long.
- No file was found in the path given for the Python script.

Error correction

- Ensure that a Python script has been saved in the given path.
- Check the path information. The path must have fewer than 260 characters.


Error description 320-0052

Error message

Error: Process %1 could not be started

Cause of error

Possible causes:
- You have assigned too much memory to the Python script.
- You have assigned more memory to the script than is available in total for all Python processes.
- You have assigned a negative value to the Python script.
- You have not assigned any memory to the Python script.

Error correction

- Adapt the Python script so that it is assigned a correct memory size.


Error description 320-0053

Error message

Error: Process %1 could not be started

Cause of error

The maximum memory available for Python processes is in use.

Error correction

- Edit the Python scripts so that fewer processes are started at the same time.
- Assign less memory for the individual processes.


Error description 320-0054

Error message

Error: Process %1 could not be started

Cause of error

Could not start the Python process because it would exceed the maximum number of simultaneous Python processes.

Error correction

- Edit the Python scripts so that fewer processes are active at the same time.


Error description 320-0055

Error message

Error: Process %1 could not be started

Cause of error

The software option #46 (Python OEM Process) required for execution of Python processes is not enabled.

Error correction

- Order the software option from your service agency.


Error description 320-0056

Error message

Initialization of IOC hardware with warnings

Cause of error

Warning occurred during the initialization of IOC hardware and the IOC configuration file (see the parameter iocProject under CfgPlcPeriphery).

Error correction

You can find more information in the diagnostics menu.


Error description 320-0057

Error message

ProfiNET: Initialization faulty

Cause of error

An error occurred during initialization of the ProfiNET hardware.

Error correction

- Inform your service agency.
- You can find more information in the diagnostics menu.


Error description 320-0058

Error message

ProfiNET: Error in cyclic operation

Cause of error

An error occurred during access to the ProfiNET hardware.

Error correction

- Inform your service agency.
- You can find more information in the diagnostics menu.


Error description 320-0059

Error message

IOC configuration has invalid PLC operand addresses

Cause of error

The IOC configuration contains PLC operand addresses that exceed the permissible PLC memory area.
Possible causes:
- IOC configuration and PLC configuration file do not match
- Initial servicing or new installation
- Loading of a backup
The BUS diagnosis shows which operand range is affected.

Error correction

Confirm the error message and power interruption, and note the further error messages:
- Either the ranges for the affected operands must be enlarged in the PLC configuration file for the PLC compiler, or
- the control must be restarted in order to activate a new or changed configuration.
- Inform your service agency


Error description 320-005A

Error message

IOC configuration requires too much memory

Cause of error

- The IOC configuration requires for at least one bus system (e.g. HSCI) too much memory on the field bus hardware.
- The BUS diagnosis has more information.

Error correction

- Check the IOC configuration.
- Reduce the number of configured system components.
- Create a service file.
- Inform your service agency.


Error description 320-005B

Error message

Error from PL/MB in cyclic operation

Cause of error

A PL component (PLB), a machine operating panel (MB, TE), or a PL part of a compact inverter (UEC, UMC) reported a warning.

Error correction

For more diagnostics information about the affected device and the cause, see the bus diagnosis under HSCI


Error description 320-005C

Error message

Change of %1/%2
requires a compilation of the PLC program

Cause of error

The changed configuration datum goes into the definition of symbols for the PLC program. The PLC program must be recompiled so that the change becomes effective.

Error correction

Recompile the PLC program


Error description 320-005D

Error message

Internal inputs/outputs: Faulty initialization

Cause of error

An error occurred during initialization of the internal I/O hardware (PL/PL510/SPI).

Error correction

- Inform your service agency.
- You can find more information in the diagnostics menu


Error description 320-005E

Error message

Internal inputs/outputs: Error in cyclic operation

Cause of error

An error occurred upon access to the internal I/O hardware (SPI modules).

Error correction

- Inform your service agency.
- You can find more information in the diagnostics menu.


Error description 320-005F

Error message

Spindle not available

Cause of error

An NC function is trying to control a spindle that is not available at the moment:
- At present the spindle is functioning as an NC axis
- The spindle is occupied by another channel
- A spindle is to be switched to the NC axis while it is occupied by the NC

Error correction

Edit the NC program or contact your machine tool builder


Error description 320-0060

Error message

IOC configuration has invalid PLC operands

Cause of error

The IOC configuration includes PLC operands that have already been assigned.
The BUS diagnosis shows which operands are affected.
Possible causes:
- Use of operands that are occupied by an internal PL board.
- Use of operands that are occupied by a handwheel.

Error correction

Correct the operand addresses in the IOC file:
- If an internal PL board is active, then the operands I0-I32 and O0-O31 must not be used.
- If the default data of a handwheel are active, then the operands I160-I175 and O96-O111 must not be used.
- Inform your service agency.


Error description 320-0061

Error message

Invalid IOC configuration for PLC operand
Operand %1 not found

Cause of error

The operand designated in the IOC file was not defined in the PLC program.

Error correction

- Correct the PLC program or the IOC project.
- Inform your service agency.


Error description 320-0062

Error message

Invalid IOC configuration for PLC operand
Operand %1 not appropriate for terminal (%2)

Cause of error

The operand designated in the IOC file is not suitable for the terminal:
- The data size is incorrect.
- The terminal cannot be mapped to the operand type.
- Mixture of logical and arithmetical data types.

Error correction

- Correct the PLC program or the IOC project.
- Inform your service agency.


Error description 320-0063

Error message

Invalid configuration for PLC log files

Cause of error

The configuration under CfgPlcLogging is invalid.

Error correction

Inform your service agency


Error description 320-0064

Error message

Strobe %1 was canceled

Cause of error

Execution of the NC program was canceled in the output of an M, S, or T strobe to the PLC program.

Error correction

- Your system might be in an inconsistent condition. Check whether the status shown for the machine and for the active tool reflect the actual situation.
- Inform your service agency.


Error description 320-041A

Error message

PLC: excessive nesting

Cause of error

PLC runtime error:
- You attempted to nest more than 32 module calls within each other.
- You programmed a recursive module call that exceeds the limit of 32 levels.

Error correction

Edit PLC program.


Error description 320-041B

Error message

PLC: stack underflow

Cause of error

PLC runtime error: You attempted to retrieve data from the stack, although it had not been written there.

Error correction

Edit PLC program.


Error description 320-041C

Error message

PLC: stack overflow

Cause of error

PLC runtime error: You attempted to write more than 128 bytes of data to the stack. Word operands (B/W/D/K) each occupy 4 bytes, Logic operands (M/I/O/T/C) occupy 2 bytes.

Error correction

Edit PLC program.


Error description 320-041D

Error message

PLC: timeout

Cause of error

PLC runtime error:
- The processing of the cyclically executed program section takes too long. Check the subprogram structure for very calculation-intensive sections that you can start as SUBMIT jobs.
- The displayed processing time will be increased during data transfer and in handwheel mode. In case of doubt, select handwheel mode and simultaneously start the data transfer at max. baud rate. At the same time, check "MAXIMUM PROCESSING TIME" in the
PLC programming. Values should not exceed 150% (safety reserve in the event of unfavorable operating conditions!).

Error correction

Edit the PLC program.


Error description 320-041E

Error message

PLC: CASE out of range

Cause of error

PLC runtime error: The operand for the CASE statement contains a value that cannot be interpreted as an offset in the CM table (smaller than 0, or greater than or equal to the table length).

Error correction

- Have the PLC program checked
- Inform your service agency


Error description 320-041F

Error message

PLC: subprogram not defined

Cause of error

PLC runtime error: Subprogram not defined.

Error correction

Edit the PLC program.


Error description 320-0420

Error message

PLC: index range incorrect

Cause of error

PLC runtime error:
- The address for a writing access to data types B/W/D/M/I/O/T/C is, through the inclusion of the index register, in an invalid region for these operand types.
- The index register contains a value, due to accessing a constant field, which is not possible for this field (less than 0, or greater than or equal to field length).
- The address of a string leads through the inclusion of the index register to an invalid value.
- The number of a dialog (S#Dn[X]) or an error message (S#En[X]) leads through the inclusion of the index register to an invalid value (less than 0 or greater than 999).
- During the addressing of a component string.

Error correction

Edit the PLC program.


Error description 320-0421

Error message

PLC: error table missing

Cause of error

There is no PLC error table.
- A PLC error module 9085/9086 was called although no error table was compiled, or there were no entries in the table.
- A PLC error module 9085/9086 was called or an error marker was set, although the error table was edited or erased after compilation.

Error correction

- Compile the PLC error table.
- Check the entries in the PLC error table.


Error description 320-0422

Error message

PLC: error in module call

Cause of error

Fatal error during PLC module call (e.g. Module 9031: error converting MP).

Error correction

Edit the PLC program.


Error description 320-0423

Error message

PLC: Event file not found

Cause of error

In the system file plc.cfg the file defined with PLCEVENTS= was not found.

Error correction

Contact your service agency.


Error description 320-0424

Error message

PLC: Too many events

Cause of error

More than 15 events were defined for the current SPAWN process (cooperative multitasking).

Error correction

Contact your service agency.


Error description 320-0442

Error message

PLC: error table not .PET

Cause of error

The PLC error table selected in plc.cfg is not a PET file.

Error correction

Check the format of the PLC error table.


Error description 320-0443

Error message

PLC: error table not found

Cause of error

The PLC error table in the plc.cfg file was not found.

Error correction

Check the file name or the path name.


Error description 320-0444

Error message

PLC: err. table format incorrect

Cause of error

PLC error table: The error table selected in the plc.cfg file does not have an up-to-date binary format (e.g. after a software exchange).

Error correction

Delete the PLC error table and download a new PLC error table through the data interface.


Error description 320-0445

Error message

PET table: Too many lines

Cause of error

There are too many error messages defined in the PET table.

Error correction

Only a limited number of lines in a PET table can be evaluated. All subsequent lines are ignored.


Error description 320-07D0

Error message

PLC: Checksum error

Cause of error


Error description 320-07D1

Error message

PLC: M4005/M4006/M4006 incorrect

Cause of error

PLC runtime error: More than one of the markers M4005 (M03), M4006, (M04), M4007 (M05) is set.

Error correction

Edit the PLC program.


Error description 320-07D2

Error message

PLC: more than one strobe active

Cause of error

PLC runtime error: More than one of the functions "PLC positioning," "datum shift," or "spindle orientation" has been activated.

Error correction

Edit the PLC program.


Error description 320-07D3

Error message

PLC: undefined run-time error

Cause of error

Undefined run-time error

Error correction

Inform your service agency.


Error description 320-07D4

Error message

Supply voltage missing at X44

Cause of error

No supply voltage is applied at connector X44 of the control (= Relay external DC voltage missing).
Possible causes:
- PLC fuses defective
- 24V power supply unit in the electrical cabinet defective
- Faulting wiring of 24 V supply
- Lines interrupted

Error correction

- Check the PLC fuses
- Check the 24 V power supply unit in the electrical cabinet
- Check the wiring of the 24 V supply
- Check the lines for interruption


Error description 320-07D5

Error message

Incorrect wiring of EMERGENCY STOP

Cause of error

- The wiring of the emergency stop circuit is faulty.

Error correction

- Inform your service agency
- Check the wiring


Error description 320-07D6

Error message

STOP through PLC

Cause of error

The system was stopped by the PLC program

Error correction

Note any further messages. If necessary, inform your machine tool builder.
The control must be shut down and restarted.


Error description 320-07D7

Error message

M0-999 and B0-127 deleted

Cause of error

You called the function for deleting the non-volatile data. The system has been stopped.

Error correction

Restart the control


Error description 320-07D8

Error message

Exchange buffer battery

Cause of error

The voltage of the buffer battery has dropped below the minimum permissible value.

Error correction

Refer to your machine manual or contact your machine tool builder.


Error description 320-07D9

Error message

Temperature too high (CPU%1 := %2°C)

Cause of error

Temperature sensor detects an excessively high temperature within the main computer's housing.
- Insufficient heat dissipation for the MC main computer
- Contaminated filter pads
- Defective climate control unit in the electrical cabinet or operating panel (where MC is installed)
- Defective fan
- Defective temperature sensor
- Unfavorable mounting of components

Error correction

- Clean the filter pads
- Check the climate control unit and repair it if necessary
- Replace the fan
- Inform your service agency


Error description 320-07DA

Error message

Temperature of MC main computer too high := %1°C

Cause of error

Temperature sensor detects an excessively high temperature within the main computer's housing.
- Insufficient heat dissipation for the MC main computer
- Contaminated filter pads
- Defective climate control unit in the electrical cabinet or operating panel (where MC is installed)
- Defective fan
- Defective temperature sensor
- Unfavorable mounting of components

Error correction

- Clean the filter pads
- Check the climate control unit and repair it if necessary
- Replace the fan
- Inform your service agency


Error description 320-07DB

Error message

MC housing fan defective

Cause of error

Rotational speed of the housing fan is too low.

Error correction

- Exchange the fan
- inform your service agency


Error description 320-07DC

Error message

Supply voltage missing at device

Cause of error

The supply voltages on a device in the HSCI line are outside of the specified range.
The HSCI bus diagnosis indicates which HSCI component triggered the error. Possible devices:
- MC main computer
- PL inputs/outputs
- MB machine operating panel
- Other CC in the HSCI line
Possible causes:
- Insufficient power supply to the devices
- Short circuit in the power supply
- Short circuit in PL inputs and outputs

Error correction

- Check the voltage supply to the devices
- Note further information in the control's diagnostic functions (bus diagnostics or TNCdiag)
- Check the wiring for possible short circuits (e.g., PLC inputs or outputs)
- Exchange the hardware
- Inform your service agency


Error description 320-0BB8

Error message

%1

Cause of error


Error description 320-0FA1

Error message

M

Cause of error


Error description 320-0FA2

Error message

S

Cause of error


Error description 320-0FA3

Error message

T0

Cause of error


Error description 320-0FA4

Error message

TOOL CALL

Cause of error


Error description 320-0FA5

Error message

TOOL DEF

Cause of error


Error description 320-0FA6

Error message

Strobe

Cause of error


Error description 320-0FA7

Error message

Acknowledgment

Cause of error


Error description 320-0FA8

Error message

Parameter

Cause of error


Error description 320-0FA9

Error message

Rotational speed

Cause of error


Error description 320-0FAA

Error message

Mode

Cause of error


Error description 320-0FAB

Error message

Gear range

Cause of error


Error description 320-0FAC

Error message

Index

Cause of error


Error description 320-0FAD

Error message

Magazine

Cause of error


Error description 320-0FAE

Error message

Pocket

Cause of error


Error description 320-0FAF

Error message

Channel

Cause of error


Error description 320-0FB0

Error message

Status

Cause of error


Error description 320-0FB1

Error message

Manual

Cause of error


Error description 320-0FB2

Error message

Incremental

Cause of error


Error description 320-0FB3

Error message

Referencing

Cause of error


Error description 320-0FB4

Error message

Probing

Cause of error


Error description 320-0FB5

Error message

Negative direction

Cause of error


Error description 320-0FB6

Error message

Position

Cause of error


Error description 320-0FB7

Error message

Feed rate

Cause of error


Error description 320-0FB8

Error message

W/o limit switches

Cause of error


Error description 320-0FB9

Error message

Without NC stop

Cause of error


Error description 320-0FBB

Error message

Supply voltage missing for HSCI device

Cause of error

It was detected that the +24 V supply voltage was missing on an HSCI bus device. The -PF.BOARD is pending in the S status.

Error correction

- Open the bus diagnosis and check the status messages of the devices connected to the HSCI bus system.
- Provide all devices connected to the HSCI bus system with the correct +24 V NC and +24 V PLC voltage.
- Restart the control.


Error description 320-0FBC

Error message

The TNC will be shut down and machine functions will be performed

Cause of error

The PLC program is delaying shutdown of the control

Error correction

Run the machine functions requested by the PLC program.


Error description 320-0FBE

Error message

Tool is inconsistent


Error description 320-0FBF

Error message

More than one error class was defined for a PET error

Cause of error

- More than one error class was defined for an error in an error table (.PET).

Error correction

- Define only one error class for the relevant error.
- You will find more informationen (table name, error number) in the error list through the "Internal info" soft key.
- Inform your service agency.


Error description 320-0FC0

Error message

Fast PLC input has incorrect parameters

Cause of error

A fast PLC input is not in the IOC file, or the parameters are incorrect.

Error correction

- Check the IO configuration.
- Inform your service agency


Error description 320-0FC2

Error message

JHIOSim installation incomplete

Cause of error

Windows: JHIOSim DLL not available
Virtual Box: Installation incomplete
Virtual Box: Common folder /mnt/sf/IOsim does not exist

Error correction

Check the installation of virtual box and Windows


Error description 320-0FC3

Error message

Start of an NC program not permitted at this time

Cause of error

Starting the NC program is not permitted at this time, since axes are currently executing positioning tasks.

Error correction

Try to start the NC program at a later time


Error description 320-0FC4

Error message

System overload – message buffer is full

Cause of error

Very many small jobs were sent in a short time to the PLC run-time system. As a result, the associated messages could no longer be delivered in the system.
These jobs result from calling PLC modules or calling the Python function library for OEM applications.
The capacity for buffering the messages in the system has been exhausted; the PLC program has been stopped.

Error correction

Change the PLC program or the OEM application
Distribute the calls from PLC modules or functions of the JH function library in Python OEM applications more evenly over time.


Error description 320-0FC6

Error message

Temperature of the MC main computer too high: %1°C (warning)

Cause of error

Temperature sensor detects an excessively high temperature within the main computer's housing.
- Insufficient heat dissipation for the MC main computer
- Contaminated filter pads
- Defective climate control unit in the electrical cabinet or operating panel (where MC is installed)
- Defective fan
- Defective temperature sensor
- Unfavorable mounting of components

Error correction

- Clean the filter pads
- Check the climate control unit and repair it if necessary
- Replace the fan
- Inform your service agency


Error description 320-0FC7

Error message

Temperature of the MC main computer too low: %1°C (warning)

Cause of error

Temperature sensor detects an excessively low temperature within the main computer's housing.
- Defective climate control unit in the electrical cabinet or operating panel (where MC is installed)
- Defective temperature sensor
- Unfavorable mounting of components

Error correction

- Check the temperature conditions in the electrical cabinet
- Check the climate control unit, and repair it if necessary
- Inform your service agency


Error description 320-0FC8

Error message

Temperature of the MC main computer too low: %1°C

Cause of error

Temperature sensor detects an excessively low temperature within the main computer's housing.
- Defective climate control unit in the electrical cabinet or operating panel (where MC is installed)
- Defective temperature sensor
- Unfavorable mounting of components

Error correction

- Check the temperature conditions in the electrical cabinet
- Check the climate control unit, and repair it if necessary
- Inform your service agency


Error description 320-0FC9

Error message

Calling an external tool not permitted at this time

Cause of error

An external tool can be called only if it is inserted in the spindle as part of the call. However, at this time the called tool is supposed to remain in its position.

Error correction

Assign the tool a place in the pocket table.


Error description 322-0002

Error message

Incorrect tool location at start of block scan ( %1 )

Cause of error

Mid-program startup started with incorrect tool.

Error correction

Change to the correct tool and start again.


Error description 322-0003

Error message

Configuration datum %1 - %2
contains errors

Cause of error

The file entered in the configuration data for the description of a tool-change sequence contains errors, and was not loaded onto the control for operation.

Error correction

Inform your machine tool builder.


Error description 322-0004

Error message

Tool call unclear

Cause of error

Two tools are to be inserted or exchanged at the same time.

Error correction

Correct the NC program.


Error description 322-0005

Error message

File not found

Cause of error

The file entered in the configuration data for describing a tool-change sequence does not exist.

Error correction

Inform your machine tool builder.


Error description 322-0006

Error message

Pocket table faulty

Cause of error

No primary key (TOOL_P.P, magazine number and pocket number) is defined for the pocket table TOOL_P.

Error correction

Inform your machine tool builder.


Error description 322-0007

Error message

Pocket table faulty

Cause of error

The wrong column (not TOOL_P.P, magazine number and pocket number) was defined as primary key for the pocket table TOOL_P.

Error correction

Inform your machine tool builder.


Error description 322-0008

Error message

Pocket table faulty

Cause of error

An invalid value was read in column P of the pocket table.

Error correction

Inform your machine tool builder.


Error description 322-0009

Error message

Pocket table faulty

Cause of error

An invalid value was read in column ST of the pocket table.

Error correction

Inform your machine tool builder.


Error description 322-000A

Error message

Pocket table faulty

Cause of error

An invalid value was read in column F of the pocket table.

Error correction

Inform your machine tool builder.


Error description 322-000B

Error message

Pocket table faulty

Cause of error

An invalid value was read in column PTYP of the pocket table.

Error correction

Inform your machine tool builder.


Error description 322-000C

Error message

Pocket table faulty

Cause of error

A tool was found more than once in the pocket table.

Error correction

Correct the pocket table. Delete the tool from the pockets that it is not in, or mark these pockets as reserved.


Error description 322-000D

Error message

Pocket table might be inconsistent

Cause of error

The internal data of the control on the loaded tool do not correspond with the content of the pocket table.
This can happen after the pocket table is edited or overwritten, or after a tool change was canceled.
The contents of the pocket table might no longer correspond to the tool configuration in the tool memory.

Error correction

Check the contents of the pocket table and correct them if required.


Error description 322-000E

Error message

Pocket table faulty

Cause of error

A required column (P, Tor RSV) is not defined for the pocket table TOOL_P.

Error correction

Inform your machine tool builder.


Error description 322-000F

Error message

File not found

Cause of error

The file with the pocket table was not found in the path configured.

Error correction

Restore the file to the original path, or create a new file with the original path, or contact your machine tool builder.


Error description 322-0010

Error message

System error in the PLC

Cause of error

Internal software error

Error correction

Inform your service agency


Error description 322-0011

Error message

Access to pocket table denied

Cause of error

The tool call cannot proceed because write-access to the pocket table was denied.
The PLC program or editing of the pocket table can be the cause of such a lock.

Error correction

Conclude editing of the pocket table, or contact your machine tool builder.


Error description 322-0012

Error message

Pocket table faulty

Cause of error

The configuration data for a column in the pocket table are missing or faulty.

Error correction

Inform your machine tool builder


Error description 322-0013

Error message

File access not possible

Cause of error

The file with the pocket table is missing, or access to this file was denied.

Error correction

Restore the file, or check the access rights to the file. Rescind any active write-protection.


Error description 322-0014

Error message

Pocket table faulty

Cause of error

The file with the pocket table is incomplete, or contains lines of differing lengths, syntactical errors or unknown columns.

Error correction

Correct the file, or restore the file, or contact your machine tool builder.


Error description 322-0015

Error message

Pocket table faulty

Cause of error

An invalid value was read in column T of the pocket table.

Error correction

Correct the file, or restore the file, or contact your machine tool builder.


Error description 322-0016

Error message

System error in the PLC

Cause of error

Internal software error

Error correction

Inform your service agency


Error description 322-0017

Error message

Access to pocket table denied

Cause of error

Access to the pocket table is locked by another application.
The control could therefore no longer update the pocket table after tool change.
The contents of the pocket table might no longer correspond to the tool configuration in the tool memory.

Error correction

Check the contents of the pocket table and correct them if required.
Conclude editing of the pocket table, or contact your machine tool builder.


Error description 322-0018

Error message

System error in the PLC

Cause of error

Internal software error

Error correction

Inform your service agency


Error description 322-0019

Error message

Pocket table faulty

Cause of error

An invalid value was read in column RSV of the pocket table.

Error correction

Correct the file, or restore the file, or contact your machine tool builder.


Error description 322-001A

Error message

Tool change without configured spindle required

Cause of error

No spindle was configured for channel %1 or (only channel 0). It was not possible to implicitly assign a spindle.

Error correction

Edit the NC program or contact your machine tool builder


Error description 322-001B

Error message

PLC datum %1 cannot be changed

Cause of error

An attempt was made to change the PLC datum with the given designation.
The datum does not exist, or cannot be changed, or the new value is not permissible.

Error correction

Check whether the datum with the given designation exists and is free for changes.
Check whether the new value is permissible for this datum.
Edit your NC program so that a correct designation and a permissible value are used.


Error description 322-001C

Error message

System error in the PLC

Cause of error

Internal software error

Error correction

Inform your service agency


Error description 322-001D

Error message

Pocket table faulty

Cause of error

An invalid value was read in column L of the pocket table.

Error correction

Inform your machine tool builder


Error description 322-001E

Error message

Pocket in tool magazine is locked

Cause of error

The tool call cannot be executed because the pocket in the tool magazine is locked.
Such a lock can be caused by editing the pocket table or by the PLC program.

Error correction

Correct the pocket datum or inform your machine manufacturer.


Error description 330-0002

Error message

Safe Torque Off (-STO.B.x) is active

Cause of error

- Error in program run
- Safety function Safe Torque Off (STO) is active

Error correction

- Inform your service agency.


Error description 330-0003

Error message

External EMERGENCY STOP

Cause of error

- The PLC input for the control-is-ready signal is inactive
- The EMERGENCY STOP circuit was interrupted manually or by the control.

Error correction

- Enable the EMERGENCY STOP button, switch on the control voltage, and acknowledge the error message.
- Check the EMERGENCY-STOP circuit. (EMERGENCY STOP button, axis limit switches, wiring, etc.)


Error description 330-0004

Error message

Switch off external dc voltage

Cause of error

The machine control voltage is still switched on.

Error correction

Switch off the machine control voltage.


Error description 330-0005

Error message

Normally closed relay open?

Cause of error

In the relay chain the normally closed contact of one or more relays is open.

Error correction

- Check the relay for proper function.
- If necessary, contact your service agency.


Error description 330-0006

Error message

Switch on external dc voltage

Cause of error

The machine control voltage is switched off.

Error correction

Switch on the machine control voltage.


Error description 330-0008

Error message

Inverter not ready

Cause of error

- Power-on of the drive not possible, because an inverter is not ready (RDY signal).
- On interface PCBs for Siemens inverters, the second axis is not enabled
- No switch signals to the inverter contacts or relays
- Compact inverter, inverter supply unit or power module is defective
- Interruption at inverter bus cable (supply bus, unit bus, PWM bus)
- Defective PWM interface on the control

Error correction

- Remove interruption in the electrical cabinet
- Replace the defective compact inverter, supply unit or power module
- Replace the defective cable
- Inform your service agency


Error description 330-0012

Error message

MC machine key depressed

Cause of error

Contact of a machine key does not open.

Error correction

Release the key if pressed, otherwise inform your service agency.


Error description 330-0013

Error message

Relay: n.c. contact closed?

Cause of error

In the relay chain, the normally closed contact of all relays is closed.

Error correction

Check the relays for proper function. If required, inform your service agency.


Error description 330-0014

Error message

CC%2 inverter for spindle RDY=0

Cause of error

The power module of the spindle could not be switched to ready condition.
- Safety relay not on (e.g. connector X71 of the UE/UV/UVR, X73 of the HEIDENHAIN expansion board for Simodrive)
- Defective power module
- PWM bus cable interrupted

Error correction

Check the wiring and inform your service agency.


Error description 330-0015

Error message

CC%2 inverter for axis RDY=0

Cause of error

The power module of an axis could not be switched to ready condition.
- Safety relay not on (e.g. connector X72 of the UV, X73 of the HEIDENHAIN expansion board for Simodrive)
- Defective power module
- PWM bus cable interrupted

Error correction

Check the wiring and inform your service agency.


Error description 330-0016

Error message

CC%2 inverter for spindle RDY=1

Cause of error

The spindle power supply is ready for operation although it ought to be switched off.

Error correction

Inform your service agency.


Error description 330-0017

Error message

CC%2 inverter for axis RDY=1

Cause of error

The power module of an axis is ready for operation although it should actually be switched off.

Error correction

Inform your service agency.


Error description 330-001A

Error message

Input (ES.B) not equal to 0

Cause of error

24 V at input ES.B. During the dynamic test, the voltage is expected to be 0 V.

Error correction

Inform your service agency.


Error description 330-001B

Error message

Test of cutout channels inactive

Cause of error

The MC (Main Computer Unit) failed to test the cutoff channels.

Error correction

Inform your service agency.


Error description 330-001F

Error message

CC%2 FS checksum error

Cause of error

- Checksum error due to faulty data
- Internal software error

Error correction

Inform your service agency.


Error description 330-0020

Error message

Command buffer overflow

Cause of error

The CC could not run so many commands from the MC.

Error correction

Inform your service agency.


Error description 330-0021

Error message

Commands do not agree

Cause of error

The command confirmed from the CC as an echo is not the command sent from the MC.

Error correction

Inform your service agency.


Error description 330-0022

Error message

CC%2 command not acknowledged

Cause of error

Command was not acknowledged by the Computer Control Unit (CC) within 200 ms.

Error correction

Inform your service agency.


Error description 330-0023

Error message

FS function not performed

Cause of error

One or more FS functions within a cycle were not performed.

Error correction

Inform your service agency.


Error description 330-0024

Error message

MC handwheel permissive key pressed

Cause of error

The permissive button of the handwheel was pressed. An incorrect handwheel was selected by CfgHandwheel–>type.

Error correction

- Check the permissive button
- Set the configuration datum properly;
- Inform your service agency.


Error description 330-0025

Error message

Faulty data from CC%2

Cause of error

Faulty software

Error correction

Inform your service agency.


Error description 330-0026

Error message

System clock MC not = CC%2

Cause of error

- Hardware error (crystal generator)
- Internal software error

Error correction

- Inform your service agency
- Exchange the drive control board or processor board
- Check the software version


Error description 330-0027

Error message

MC pos. deviation too large %2

Cause of error

The calculated position deviation between the speed encoder and the position encoder is greater than the value from the parameter CfgAxisSafety->positionDiffRef or CfgAxisSafety->positionDiffRun.
- Excessive difference between the positions calculated from the position encoder pulses and the speed encoder pulses
- During initial operation: Incorrect standardization of speed encoder pulses (e.g. incorrect screw pitch entered)
- Excessive backlash
- Defective coupling, gear, etc.
- Belt torn

Error correction

- Switch the control off and on again
- Check CfgAxisSafety->positionDiffRef, CfgAxisSafety->positionDiffRun
- During initial operation: Check the standardization of speed encoder pulses (enter the correct screw pitch)
- Check the backlash
- Repair the defective coupling, gear, etc.
- Replace the belt
- Inform your service agency


Error description 330-0028

Error message

No pos. values from the CC%2

Cause of error

For a certain time the CC has not sent any position values to the MC.

Error correction

- Switch the control off and back on again
- Inform your service agency


Error description 330-0029

Error message

CC%2 no pos. values from the MC

Cause of error

- The MC must not send any position values to the CC.
- Internal software error

Error correction

- Switch the control off and on again
- Inform your service agency


Error description 330-002A

Error message

MC/CC%2 checked axes unequal

Cause of error

- Contradictory status of checked position values in the MC and CC.
- Internal software error

Error correction

- Switch the control off and on again
- Inform your service agency


Error description 330-002B

Error message

CC%2 wrong include-file version

Cause of error

- The version number of one of the called Include files are different in the MC and CC
- Internal software error

Error correction

- Check the software version
- Inform your service agency


Error description 330-002D

Error message

Switch on spindle

Cause of error

The spindle start key was pressed but not the permissive key while the protective door A/S was open.

Error correction

Press the spindle start key and the permissive key


Error description 330-002E

Error message

SMP or checksum erroneous

Cause of error

- Safety-related machine parameter (SMP) was changed.
- Checksum over safety-related machine parameter was changed.

Error correction

- Check the safety-related machine parameter and the checksum.
- Change must be conducted only by the machine manufacturer using a manufacturer's password.
- If there are changes, it may be necessary to conduct acceptance tests on the machine.
- Inform your service agency


Error description 330-002F

Error message

SMP or checksum calculation erroneous

Cause of error

- Safety-related machine parameter (SMP) was changed.
- Checksum over safety-related machine parameter was changed.
- Machine parameter file could not be opened or does not exist.

Error correction

- Check the safety-related machine parameter and the checksum.
- Change must be conducted only by the machine manufacturer using a manufacturer's password.
- If there are changes, it may be necessary to conduct acceptance tests on the machine.
- Inform your service agency


Error description 330-0030

Error message

Safe axes must have sinusoidal inputs

Cause of error

- Safety orientation (SG) error


Error description 330-0031

Error message

Axis status cannot be determined

Cause of error

- Safety orientation (SG) error


Error description 330-0033

Error message

Not in the REF operating mode

Cause of error

- The axes can be tested only in the Reference Run REF operating mode.

Error correction

- Press CE to acknowledge the error message and switch to the REF mode.
- Then home the axes.
- Inform your service agency


Error description 330-0034

Error message

Invalid axis

Cause of error

- The axis to be tested is not a safe axis.
- The axis to be tested is a spindle.
- The given axis number is invalid.

Error correction

- Check the configuration of the axis and, if necessary, correct it (spindles cannot be referenced).
- Inform your service agency.


Error description 330-0035

Error message

Axis has already been checked

Cause of error

- Axis to be tested has already been checked.
- The given axis number is invalid.

Error correction

- Internal software error.
- Inform your service agency


Error description 330-0036

Error message

Axis is not referenced

Cause of error

- The axis to be tested has not yet been homed.

Error correction

- Internal software error.
- Inform your service agency


Error description 330-0037

Error message

Axis in motion

Cause of error

- The axis to be tested is not yet stationary.

Error correction

- Press CE to acknowledge the error message and bring the axis to a standstill.
- Then test the axis.
- Inform your service agency


Error description 330-0038

Error message

Axis not at test position

Cause of error

- The axis to be tested is not located at the test position (safe machine parameter positionMatch in CfgAxisSafety).
- The axis to be tested is not located at the test position (safe machine parameter positionDiffRef in CfgAxisSafety).
- Axis traverse direction is not correctly configured (machine parameter MP_signCorrActualVal, MP_signCorrNominalVal or entry in the DIR column of the motor table).

Error correction

- Press CE to acknowledge the error message and move the axis to the test position.
- Then test the axis.
- If the message appears although the axis is at the correct test position, check the configuration of the axis traverse direction and correct it if necessary.
- Inform your service agency


Error description 330-0039

Error message

Missing permission

Cause of error

- When testing the axis (message: "Confirm with permissive key") control receives no permission through a permissive key.
- Permissive key(s) defective.
- Test of the axes cannot be concluded without permission.

Error correction

- Check the hardware of the permissive keys.
- Inform your service agency


Error description 330-003A

Error message

No authorization for testing

Cause of error

- The axis(or axes) cannot be tested in the safety-related operating mode SOM_1.

Error correction

- Select another safety-related operating mode (e.g. SOM_2, SOM_3).
- To acknowledge any pending error message, use the CE key.
- Then test the axis.
- Inform your service agency if the error message recurs.


Error description 330-003C

Error message

MC S input signals %2 not equal

Cause of error

Safety-oriented input of SPLC-MC is not equal to input of SPLC-CC.
e.g. FB_NCC.x, KSW.x, ES.x

Error correction

Inform your service agency.


Error description 330-003D

Error message

CC%2 safe inputs %1 not equal

Cause of error

- A safety-related input of the CC is longer than
400 ms unequal to MC
- Different levels at the safety module input:
4 = Acknowledgement of switch-off
8 = Safe reduced velocity of axes/spindle
10 = Safe reduced velocity of auxiliary axes
11 = Operating mode 3(detachable-key switch 1, Pos3)
(safe controlled stop of axes/spindle)
18 = Operating mode 2 (detachable-key switch 1,Pos2)
19 = Operating mode 4 (detachable-key switch 2)
- Wiring error X65, X66, (X67)
– Safety module defective

Error correction

– Check the wiring X65, X66, (X67)
– Exchange the safety module
- Generate the service files and notify the Service Department


Error description 330-003E

Error message

MC limit switch %2 +

Cause of error

- Violation of the absolute positive limit position value (in the positive traverse direction) of the safety function SLP.
- The calculated path of the tool exceeds the defined traversing range (software limit switch) of the machine.
- The software limit switch (absolute position limit value) was reached in a manual operating mode.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.
- Move the tool in the opposite direction.
- Inform your service agency.


Error description 330-003F

Error message

CC limit switch %2 +

Cause of error

The calculated tool path exceeds the machine's positive traverse limits. The current machine setting was presumably not used and the workpiece is therefore in the wrong position in the working space.
The positive software limit switch is defined with the configuration datum CfgPositionLimits->swLimitSwitchPos.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.


Error description 330-0040

Error message

MC limit switch %2 -

Cause of error

- Violation of the absolute negative limit position value (in the negative traverse direction) of the safety function SLP.
- The calculated path of the tool exceeds the defined traversing range (software limit switch) of the machine.
- The software limit switch (absolute position limit value) was reached in a manual operating mode.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.
- Move the tool in the opposite direction.
- Inform your service agency.


Error description 330-0041

Error message

CC limit switch %2 -

Cause of error

The calculated tool path exceeds the machine's negative traverse limits. The current machine setting was presumably not used and the workpiece is therefore in the wrong position in the working space.
The negative software limit switch is defined with the configuration datum CfgPositionLimits->swLimitSwitchNeg.

Error correction

- Check the programmed coordinates. If required, edit the program.
- Check the reference point. If required, set a new reference point.


Error description 330-0042

Error message

MC standstill monitoring %2

Cause of error

- The position error in an active safe operating stop (SOS) is greater than the value specified in the configuration parameter CfgAxisSafety->positionRangeVmin.
- If during an emergency stop the axes and spindle are decelerated, and the axes come to a stop earlier than the spindle, then the axes are standstill-monitored for the value from CfgAxisSafety->positionRangeVmin until the spindle comes to a stop.
- If the protective door is closed in the automatic mode (SOM 1), axes whose drives are switched off (e g. clamped axes) are standstill-monitored for the value from CfgAxisSafety->positionRangeVmin.
- After the permissive button is released, the tool magazine axis continues to move for more than 3 seconds.
- During the braking test, the axis exceeds the maximum permissible path in CfgAxisSafety->positionRangeVmin. It must be assumed that a holding brake for the axis is defective!
- After triggering of an SS2 stop reaction and expiration of the SS2 stopping time, a position error greater than the value in the configuration parameter CfgAxisSafety->positionRangeVmin was detected.

Error correction

- If the error occurs during the brake test, the axis remains in the servo loop. The axis has to be moved to a safe position before you switch the machine off. It must be assumed that a holding brake is defective.
- Inform your service agency.


Error description 330-0044

Error message

MC feed rate greater SLS %2

Cause of error

The feed rate exceeds the permissible limit value for the active safety-related operating mode (SOM).

Error correction

Inform your service agency.


Error description 330-0045

Error message

CC feed rate greater SLS %2

Cause of error

The feed rate exceeds the permissible limit value for the active safety-related operating mode (SOM).

Error correction

Inform your service agency.


Error description 330-0046

Error message

MC S input %2 not equal 0

Cause of error

The safety-oriented inputs for detachable-key switches, door contacts and emergency stop were not set to 0 during the cyclic test.

Error correction

Inform your service agency!


Error description 330-0047

Error message

CC%1 S input %2 not equal 0

Cause of error

The safety-oriented inputs for detachable-key switches, door contacts and emergency stop were not set to 0 during the cyclic test.

Error correction

Inform your service agency!


Error description 330-0048

Error message

MC NC temperature out of tol.

Cause of error

The temperature inside the control is outside the permissible tolerance range.
- Clogged filter pads in the electrical cabinet
- Defective climate control unit in the electrical cabinet
- Defective fan in the control housing
- Defective control

Error correction

- Clean the filter pads
- Repair the air conditioner
- Exchange the fan in the control housing / if necessary, exchange the complete control
Improve the ventilation in the electrical cabinet.


Error description 330-0049

Error message

CC%2 NC temperature out of tol.

Cause of error

The temperature inside the control is outside the permissible tolerance range.
- Clogged filter pads in the electrical cabinet
- Defective climate control unit in the electrical cabinet
- Defective fan in the control housing
- Defective control

Error correction

- Clean the filter pads
- Repair the air conditioner
- Exchange the fan in the control housing / if necessary, exchange the complete control
Improve the ventilation in the electrical cabinet.


Error description 330-004A

Error message

MC +5V out of tolerance

Cause of error

- The internal +5-V power supply of the MC is outside the permissible tolerance range.

Error correction

- Exchange defective hardware (MC)
- Inform your service agency


Error description 330-004B

Error message

CC%2 +5V out of tolerance

Cause of error

The 5V power supply of the control is outside the permissible tolerance range.

Error correction

Inform your service agency


Error description 330-004C

Error message

Op. state of MC not equal CC

Cause of error

The automatic SLS, SOS, STO operating states of the MC and CC are compared cyclically. If the values remain unequal for longer than 500 ms, a Safe Stop 1 (SS1) is released.

Error correction

- Press CE to acknowledge the error message
- Switch the machine off and on
- Inform your service agency.
- Check the software version


Error description 330-004D

Error message

CC%2 operating state not equal MC

Cause of error

- The automatic SLS, SOS, STO operating states of the MC and CC are compared cyclically. If the values remain unequal for longer than 500 ms, a Safe Stop 1 (SS1) is released.

Error correction

- Press CE to acknowledge the error message
- Switch the machine off and on
- Inform your service agency.
- Check the software version


Error description 330-004E

Error message

MC amplitude too high %2

Cause of error

The amplitude of the encoder signal is too high or the signal for contamination is active.
- Incorrect adjustment between head and encoder, air gap too small (exposed encoders)
- Excessive supply voltage

Error correction

- Check the amplitude of the encoder signal
- Inform your service agency


Error description 330-004F

Error message

CC amplitude too high %2

Cause of error

- The amplitude of the encoder signal is too high or the signal for contamination is active.
- Incorrect adjustment between head and encoder, air gap too small (exposed encoders)
- Excessive supply voltage

Error correction

- Check the amplitude of the encoder signal
- Inform your service agency


Error description 330-0050

Error message

MC amplitude too low %2

Cause of error

The amplitude of the encoder signal is too small or the signal for contamination is active.
- Encoder contaminated
- Encoder defective
- Penetration of humidity
- Scanning head misaligned (distance, parallelism, etc.)
- Encoder cabling defective
- Encoder input defective on the control
- Vibration
- Interfering signals

Error correction

- Inform your service agency


Error description 330-0051

Error message

CC amplitude too low %2

Cause of error

The amplitude of the encoder signal is too small or the signal for contamination is active.
- Encoder contaminated
- Encoder defective
- Penetration of humidity
- Scanning head misaligned (distance, parallelism, etc.)
- Encoder cabling defective
- Encoder input defective on the control
- Vibration
- Interfering signals

Error correction

- Inform your service agency


Error description 330-0052

Error message

MC frequency too high %2

Cause of error

The maximum input frequency was exceeded at an encoder input.
- Fault on signal of the speed encoder
- Vibrations on the machine

Error correction

- Check the speed encoder connection (ground connection)
- Check the speed encoder
- Check the encoder signal input frequency.
- Eliminate the vibrations
- Inform your service agency


Error description 330-0053

Error message

CC frequency too high %2

Cause of error

- The maximum input frequency was exceeded at an encoder input.
- Noise on motor encoder signal
- Vibrations on the machine

Error correction

- Inform your service agency
- Check the motor encoder connection (ground connection)
- Check the motor encoder
- Check the encoder signal input frequency
- Remove the vibrations


Error description 330-0054

Error message

MC speed greater than SLS %2

Cause of error

The rotational speed exceeds the permissible limit value for the active safety-related operating mode (SOM_2, SOM_3, SOM_4 or SLI_S).

Error correction

Inform your service agency.


Error description 330-0055

Error message

CC speed greater than SLS %2

Cause of error

The feed rate exceeds the permissible limit value for the active safety-related operating mode (SOM).

Error correction

Inform your service agency.


Error description 330-0056

Error message

MC: Machine permissive button depressed

Cause of error

The permissive button of the tool changer was pressed.

Error correction

- Check the permissive buttons.
- Contact your service agency.


Error description 330-0057

Error message

CC%2 SH1=0

Cause of error

Internal software error

Error correction

Inform your service agency


Error description 330-0058

Error message

CC%2 SH1=1

Cause of error

- Hardware error
- Internal software error

Error correction

Inform your service agency


Error description 330-0059

Error message

No hardware for functional safety

Cause of error

Hardware components not compatible with safety software.

Error correction

Inform your service agency.


Error description 330-005A

Error message

MC no memory available

Cause of error

Internal software error

Error correction

Inform your service agency


Error description 330-005B

Error message

MC safety doors are open

Cause of error

Guard doors are open
The guard doors have to be closed in order to conduct the safety self-test or the brake test of an axis.
Further possible causes:
- Faulty wiring of guard doors
- Guard door contact is defective
- SPLC interface signal PP_AxGrpStateReq unequal to S_STATE_AUTO [10]

Error correction

- Close the guard doors in order to conduct the safety self-test or the brake test
Further possible measures:
- Check the wiring of the guard door contacts
- Check the guard door contact.
- Check the SPLC program.
- Inform your service agency


Error description 330-005C

Error message

Axis %2 started w/o test by MC

Cause of error

The axis was not yet tested.

Error correction

Test the axis.


Error description 330-005E

Error message

Internal software error

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 330-005F

Error message

FS hardware used without FS software!

Cause of error

The safety hardware cannot be installed without safety software!

Error correction

Inform your service agency.


Error description 330-0060

Error message

FS error in configuration

Cause of error

- The machine parameter or config object is erroneous, incomplete, or the like (datum was read as additional info).
- Axis group from config object CfgAxisSafety is not configured.
- Safe spindle not in the axis group for spindles
- Maximum velocity for SOM 2 is missing or incorrect
- Safe feed axis not in the axis group for spindles
- The encoder input (position or motor) was configured incorrectly or not at all
- PWM output was configured incorrectly
- Safe axis not controlled through CC (analog, simulation, PLC spindle, etc.)
- Safe axis configured for “referencing on the fly"; check machine parameter MP_refType (400401)
- Differing line counts for motor encoder in various parameter sets of one axis
- Several axis groups assigned with identical ID
- Invalid index number assigned for axis group (negative, too large)

Error correction

- Correct the machine configuration
- Inform your service agency


Error description 330-0064

Error message

MC brake test not completed

Cause of error

The brake test was started, but no end was received within 10 seconds from the CC.

Error correction

- Internal software error
- Inform your service agency


Error description 330-0065

Error message

MC command %1 not acknowledged

Cause of error

Command was not acknowledged by the Main Computing Unit (MC) within 400 ms.

Error correction

Inform your service agency.


Error description 330-0066

Error message

MC PWM output is not present

Cause of error

Internal software error

Error correction

Inform your service agency


Error description 330-0067

Error message

CC%2 timeout version comparison

Cause of error

The CC does not send a version number (safe stop 0) within 2 s.

Error correction

Inform your service agency.


Error description 330-0068

Error message

MC wrong quantity FS-CC

Cause of error

Internal software error

Error correction

- Inform your service agency
- Exchange the software


Error description 330-0069

Error message

MC S checksum error

Cause of error

- Checksum error due to faulty data
- Internal software error

Error correction

Inform your service agency.


Error description 330-006A

Error message

CC%2 timeout SMP check sum

Cause of error

The CC does not find an SMP checksum (safe stop 0) within 2 s.
- Internal software error

Error correction

Inform your service agency.


Error description 330-006B

Error message

MC SOM 2 only one axis allowed

Cause of error

Two or more axes are to be moved simultaneously in the SOM 2 operating mode.

Error correction

Only one axis may be moved at a time in SOM 2.


Error description 330-006C

Error message

+24 V MC short on brake line

Cause of error

There is a short circuit with 24 V on the brake line A of the MC.

Error correction

- Check brake channel A
- Inform your service agency


Error description 330-006D

Error message

MC 0 V short on brake line %2

Cause of error

There is a short circuit with 0 V on the brake line A of the MC.

Error correction

- Check brake channel A
- Inform your service agency


Error description 330-006E

Error message

MC SOM 4 Press the permissive key

Cause of error

In the SOM 4 mode of operation, the permissive key was not pressed within the time defined in MP529.

Error correction

Press the permissive key.


Error description 330-006F

Error message

MC SOM 4 not released

Cause of error

The operating mode BA4 is addressed through the keylock switch and is still not enabled over the configuration datum "permitSom4".

Error correction

- Inform your service agency
- Enable the operating mode through the configuration datum "permitSom4"


Error description 330-0070

Error message

MC SOM 4 not possible

Cause of error

1. Key switch is not on SOM 1.

Error correction

1. Turn the key switch to SOM 1.


Error description 330-0071

Error message

MC operating mode not possible

Cause of error

Wiring error at the SG inputs BA2.x, BA3.x and BA4.x.

Error correction

- Inform your service agency.
- Check the wiring.


Error description 330-0073

Error message

CC%2 current measurement timeout

Cause of error

Current measurement of the controller unit in the cut-out test could not be performed because the standby signal RDY of a power stage (inverter) is missing.

Error correction

- Check the switch setting of “AXIS/SPINDLE (X110)” on the inverter.
- Inform your service agency


Error description 330-0074

Error message

MC: Incorrect safe axis group

Cause of error

- The axis-group definition is not allowed in the safe machine parameter axisGroup in CfgAxisSafety.

Error correction

- Correct the machine parameter axisGroup in CfgAxisSafety.
- Changes in this safe machine parameter may be performed solely by the machine tool builder.
- Inform your service agency.


Error description 330-0075

Error message

MC braking test not activated

Cause of error

- Move the axis to a safe position before power-off
- Brake test was not commanded by the MC

Error correction

- Software error
- Inform your service agency


Error description 330-0076

Error message

CC: Guard doors are open

Cause of error

- One or more guide doors are open
The guard doors have to be closed in order to conduct the safety self-test or the brake test of an axis.
Further possible causes:
- Faulty wiring of guard doors
- Guard door contact is defective

Error correction

- Close the guard doors in order to conduct the safety self-test or the brake test
Further possible measures:
- Check the wiring of the guard door contacts
- Check the guard door contact
- Check the SPLC program
- Inform your service agency


Error description 330-0077

Error message

Checksum error A

Cause of error

The CRC sum of the EPROMs IC-P1 and IC-P2 is incorrect.

Error correction

- Switch the control off and on again (reboot)
- Inform your service agency.


Error description 330-0078

Error message

MC movement monitoring %2

Cause of error

- Defective hardware
- Spindle cannot be controlled

Error correction

- Adjust the spindle
- Exchange the hardware
- Inform your service agency


Error description 330-0079

Error message

MC error in braking process %2

Cause of error

The axes cannot be servo-controlled. dv/dt monitoring has responded.

Error correction

- Check machine parameter CfgAxParSafety/timeToleranceDvDt
- Adjust the axes
- Exchange the hardware
- Inform your service agency


Error description 330-007A

Error message

CC: Machine key depressed

Cause of error

One or more machine keys of an operating station are active on the CC side.
Machine keys are keys, e.g. on the machine operating panel or the handwheel, that can release a movement of the machine (permissive keys, axis-direction keys, chip conveyors, etc.)

Error correction

- Release the key(s) or check the wiring
- Inform your service agency


Error description 330-007B

Error message

MC: Mach. permiss. button depressed

Cause of error

Machine-key permissive key is depressed on the MC side.

Error correction

- Release the key or check the wiring
- Inform your service agency


Error description 330-007C

Error message

CC panel permissive button pressed

Cause of error

Machine-key permissive key is depressed on the CC side.

Error correction

- Release the key or check the wiring
- Inform your service agency


Error description 330-007D

Error message

CC: Machine permissive button pressed

Cause of error

Tool changer permissive key is active on CC side.

Error correction

- Release the key or check the wiring
- Inform your service agency


Error description 330-007E

Error message

MC inverter RDY=0 %2

Cause of error

Although SH1B.x=1, RDY.x=0

Error correction

- Hardware error
- Inform your service agency


Error description 330-007F

Error message

MC inverter RDY=1 %2

Cause of error

Although SH1B.x=0, RDY.x=1

Error correction

- Hardware error
- Inform your service agency


Error description 330-0080

Error message

MC 1st violation of limit switch %2+

Cause of error

The safety limit switch was tripped for the first time.

Error correction

- Press "machine on" to cancel the error message and move to the limit switch range.


Error description 330-0081

Error message

MC 1st violation of limit switch %2-

Cause of error

The safety limit switch was tripped for the first time.

Error correction

- Press "machine on" to cancel the error message and move to the limit switch range.


Error description 330-0082

Error message

MC nominal-to-actual position error too large %2

Cause of error

The following error of a moving axis is greater than the value specified in the safe machine parameter positionDiffNom.

Error correction

- Reduce the contouring feed rate, increase the rotational speed.
- Remove any possible sources of vibration.
- Inform your service agency if the error occurs frequently.


Error description 330-0083

Error message

MC S software error %1

Cause of error

- Software error

Error correction

- Inform your service agency


Error description 330-0084

Error message

MC start test of the cut-out channels not possible

Cause of error

The start test of the cutout channels was commanded through the PLC, although the machine-on input is inactive.

Error correction

- Error in PLC program
- Inform your service agency


Error description 330-0085

Error message

CC: Handwheel permissive button depressed

Cause of error

The permissive button of the handwheel on the CC side was pressed. An incorrect handwheel was selected by CfgHandwheel->type.

Error correction

- Check the permissive button
- Set the configuration datum properly
- Inform your service agency


Error description 330-0086

Error message

Emergency stop from SPLC

Cause of error

- Stop reaction for emergency stop (SS1) released by the SPLC program

Error correction

- Inform your service agency


Error description 330-0087

Error message

Fatal error from SPLC

Cause of error

- Stop reaction for fatal error (SS1) released by the SPLC program

Error correction

- Inform your service agency


Error description 330-0088

Error message

MC: Permissive button depressed

Cause of error

Permissive button of machine operating panel or handwheel is depressed.

Error correction

- Release permissive button
- Check inputs


Error description 330-0089

Error message

CC permissive button pressed

Cause of error

Permissive button of machine operating panel or handwheel is depressed.

Error correction

- Release permissive button
- Check inputs


Error description 330-008A

Error message

CC%2 inverter for axis RDY=0 (safety relay)

Cause of error

RDY of the inverter remains 0, although 1 is expected after a beginning a test. Possible causes:
- Safety relay for axes (K1) has a short circuit to 0 V
- Wiring of the enabling relays (X72) or the axis release module is faulty
- Wiring of the STO.A.G or MC.RDY signal is faulty
- Inverter is not configured for axes

Error correction

- Check the hardware
- Check the wiring
- Inform your service agency


Error description 330-008B

Error message

CC%2 inverter for axes RDY=1 (safety relay)

Cause of error

RDY of the inverter remains 1, although 0 is expected after a beginning a test. Possible causes:
- Safety relay for axes (K1) has a short circuit to +24 V.
- Wiring of the enabling relays (X72) or the axis release module is faulty
- Wiring of the STO.A.G or MC.RDY signal is faulty
- Inverter is not configured for axes

Error correction

- Check the hardware
- Check the wiring
- Inform your service agency


Error description 330-008C

Error message

MC timeout during braking (SS1) %2

Cause of error

- The maximum permissible time for braking at the current limit (SS1 reaction) was exceeded.

Error correction

- Check the parameter values:
timeLimitStop1: Default time for stopping the axes/spindle at the emergency braking ramp for SS1 reaction
- Inform your service agency.


Error description 330-008D

Error message

MC traverse range exceeded at SS2 %2

Cause of error

When braking at a contour (SS2), a spindle or axis exceeded the maximum permissible path.
The maximum permissible path for axes is the entry in the safety-related machine parameter distLimitStop2.
A maximum of 2 revolutions are permissible for spindles during an SS2 reaction in SOM_2, and 5 revolutions are permissible in SOM_3, SOM_4.

Error correction

- Check the machine parameters for the braking process during an SS2 reaction.
- Check the entry in distLimitStop2
- Inform your service agency.


Error description 330-008E

Error message

MC change from SOM_2/SOM_3 to SOM_4 not possible

Cause of error

- Safety-related mode of operation SOM_1 not selected
- E.g. keylock switch 1 not in SOM_1 position

Error correction

- Select safety-related mode of operation SOM_1
- E.g. keylock switch 1 in SOM_1 position


Error description 330-008F

Error message

MC change from SOM_4 to SOM_2/SOM_3 not possible

Cause of error

- Safety-related mode of operation SOM_1 not selected
- E.g. keylock switch 1 not in SOM_1 position

Error correction

- Select safety-related mode of operation SOM_1
- E.g. keylock switch 1 in SOM_1 position


Error description 330-0090

Error message

MC SPLC requests invalid stop reaction

Cause of error

- SPLC demands an invalid stop reaction (SS0, SS1, SS1F or SS2) for an axis/spindle group
- Error in SPLC program

Error correction

- Check the SPLC program
- Inform your service agency


Error description 330-0091

Error message

MC SPLC requests invalid safety function

Cause of error

- SPLC demands an invalid safety function (SLI, SLS, STO, SOS or AUTO) for an axis/spindle group
- Error in SPLC program

Error correction

- Check the SPLC program
- Inform your service agency


Error description 330-0092

Error message

MC brake cannot be deactivated %2

Cause of error

- Drive was switched on although the STO (Safe Torque Off) safety function for the axis or spindle is still active.

Error correction

- Internal software error
- Inform your service agency


Error description 330-0093

Error message

MC System clock MC is not equal to SKERN MC

Cause of error

- MC does not increase the internal watchdog counter value
- There is an MC hardware defect or internal software error

Error correction

- Restart the control
- Inform your service agency


Error description 330-0094

Error message

MC System clock MC is not equal to SPLC MC

Cause of error

- MC does not get any messages from the SPLC MC
- There is an SPLC MC hardware defect or internal software error

Error correction

- Restart the control
- Inform your service agency


Error description 330-0095

Error message

MC System clock MC is not equal to SPLC CC

Cause of error

- MC does not get any messages from the SPLC CC
- There is an SPLC CC hardware defect or internal software error

Error correction

- Restart the control
- Inform your service agency


Error description 330-0096

Error message

MC error during cross comparison: %1

Cause of error

- A cross comparison between safety-related data of the MC and the CC reports errors
- Data of the programming interface SPlcApiFromSaftey (NN_xxx) are different on the MC and CC
- Data of the programming interface SPlcApiToSaftey (PP_xxx) are different on the MC and CC
- Hardware defective- Internal software error

Error correction

- Inform your service agency


Error description 330-0097

Error message

MC Safe output is not equal: %1

Cause of error

Cross comparison of a back-readable output reports an error. Possible causes:
- Power supply of the outputs
- Wiring of the outputs
- Hardware defective (PL module)
- Internal software error

Error correction

- Check the power supply of both channels or all outputs
- Check the wiring
- Exchange the defective PL module
- Inform your service agency


Error description 330-0098

Error message

MC +3.3 V out of tolerance

Cause of error

- The internal +3.3-V power supply of the MC is outside the permissible tolerance range.

Error correction

- Exchange defective hardware (MC)
- Inform your service agency


Error description 330-0099

Error message

MC +3.3 V PIC out of tolerance

Cause of error

- The internal +3.3 V PIC power supply of the MC is outside the permissible tolerance range.

Error correction

- Exchange defective hardware (MC)
- Inform your service agency


Error description 330-009A

Error message

MC +12 V out of tolerance

Cause of error

- The internal +12-V power supply of the MC is outside the permissible tolerance range.

Error correction

- Exchange defective hardware (MC)
- Inform your service agency


Error description 330-009B

Error message

MC speed of fan 1 too slow

Cause of error

- Internal fan 1 of the MC is below the permissible tolerance range (too slow).

Error correction

- Exchange defective hardware (MC)
- Inform your service agency


Error description 330-009C

Error message

MC Speed of fan 2 too slow

Cause of error

- Internal fan 2 of the MC is below the permissible tolerance range (too slow).

Error correction

- Exchange defective hardware (MC)
- Inform your service agency


Error description 330-009D

Error message

MC fan not recognized

Cause of error

- Hardware (MC) defective

Error correction

- Exchange defective hardware (MC)
- Inform your service agency


Error description 330-009E

Error message

MC error in actual-value measurement %2 %1

Cause of error

The encoder reports an internal error in the actual value acquisition

Error correction

Inform your service agency


Error description 330-00A0

Error message

MC axis %2 in servo control

Cause of error

- The SPLC program requests the STO safety function, although the axis is still in servo control
- Internal software error

Error correction

Inform your service agency


Error description 330-00A1

Error message

MC spindle %2 in servo control

Cause of error

- The SPLC program requests the STO safety function, although the spindle is still in servo control
- Internal software error

Error correction

Inform your service agency


Error description 330-00A2

Error message

MC excessive deviation of actual from nominal speed %2

Cause of error

- The safety function "comparison of actual to nominal speed values" reports an error
- The maximum permissible deviation between the actual and nominal speed value (speedDiffNom) exceeded the permissible time in the safety related machine parameter timeToleranceSpeed

Error correction

- Check the entries in the safety-related machine parameters speedDiffNom and timeToleranceSpeed in CfgAxisSafety
- Inform your service agency


Error description 330-00A3

Error message

MC: Erroneous data from SPLC %1

Cause of error

- Data transfer error
- CRC checksum error

Error correction

- Inform your service agency.


Error description 330-00A4

Error message

MC S status reaction is active: %1

Cause of error

- An error bit was set in the S status by an internal hardware or software error:
-STO.B.CC.WD: Watchdog WD.B.CC of a CC controller unit has timed out
-SMOP.WD: Watchdog WD.A.SMOP or WD.B.SMOP of an MB machine operating panel has timed out
-SPL.WD: Watchdog WD.A.SPL or WD.B.SPL of a PLB has timed out
-PF.BOARD: The internal voltage monitoring of the HSCI components has detected a faulty operating voltage
-REQ.SS2: The internal temperature or fan monitoring of the HSCI components has detected a fault

Error correction

- Inform your service agency.


Error description 330-00A5

Error message

MC -SMC.A.WD=0

Cause of error

Internal software error

Error correction

Inform your service agency


Error description 330-00A6

Error message

SKERN-MC: autotest function active

Cause of error

- Unsafe test software loaded for acceptance tests
- Caution: Safety functions have been partly deactivated!

Error correction

- Inform your service agency.


Error description 330-00A7

Error message

MC timeout during braking (SS2) %2

Cause of error

- The maximum permissible time for a controlled stop (SS2 – braking on the contour) was exceeded

Error correction

- Check the parameter values:
timeLimitStop2: Default time for bringing axes to a controlled standstill for SS2 reaction
- Inform your service agency


Error description 330-00A8

Error message

Checksum of safe machine parameters are invalid

Cause of error

No checksum has been saved or a checksum is invalid for at least one of the following configurations:
- Safe configuration data
- Hardware configuration
- Configuration of the encoders

Error correction

- Check the entries of the safe machine parameters and correct them if necessary
- If the values of the machine parameters have been changed, they are to be loaded by entering the manufacturer's password.
Then a corresponding acceptance test must be run.
- Inform your service agency.


Error description 330-00A9

Error message

Checksum of safe machine parameters have been changed

Cause of error

- The internally saved checksum of the safe machine parameters does not match the new calculated checksum.
- One or more safe machine parameters were changed.

Error correction

- Check the entries of the safe machine parameters
- If the values of the machine parameters have been changed, they are to be loaded by entering the manufacturer's password.
Then a corresponding acceptance test must be run.
- Inform your service agency.


Error description 330-00AA

Error message

Checksum was changed through the hardware configuration

Cause of error

- The internally saved checksum of the HSCI system hardware configuration does not match the new calculated checksum.
- HSCI components were exchanged, removed, or new ones inserted

Error correction

- Check the hardware configuration and correct it if required.
- If the configuration has been changed, they are to be loaded by entering the manufacturer's password.
Then a corresponding acceptance test must be run.
- Inform your service agency.


Error description 330-00AB

Error message

Checksum was changed through the encoder configuration

Cause of error

- The internally saved checksum of the encoders' configuration does not match the new calculated checksum.
- Encoders were exchanged, removed, or new ones inserted

Error correction

- Check the encoder configuration and correct it if required.
- If the configuration has been changed, they are to be loaded by entering the manufacturer's password.
Then a corresponding acceptance test must be run.
- Inform your service agency.


Error description 330-00AC

Error message

Checksum of safe machine parameters have been changed

Cause of error

Entries in safe machine parameters have been changed.

Error correction

- Check the entries of the safe machine parameters
- Switch the control off and on again
- If the values of the machine parameters have been changed, they are to be loaded by entering the manufacturer's password.
Then a corresponding acceptance test must be run.
- Inform your service agency.


Error description 330-00AD

Error message

Impermissible deviation of safe machine parameters

Cause of error

Safe machine parameters deviate between the individual parameter blocks of a
safe axis. This is not allowed.
The values have to match in all parameter blocks of an axis:
- Encoder input
- PWM output
- Encoder resolution per path
- Counting direction
- Line count

Error correction

- Check the entries of the safe machine parameters and correct them if necessary
- Switch the control off and on again
- If the values of the machine parameters have been changed, they are to be loaded by entering the manufacturer's password.
Then a corresponding acceptance test must be run.
- Inform your service agency.


Error description 330-00AE

Error message

Invalid entry in safe machine parameter

Cause of error

The configuration datum CfgAxisSafety contains invalid values in one of the following safe machine parameters:
- positionMatch
Entered position or value is invalid
- positionDiffRef
Entered deviation or value is invalid
- speedLimitSom2
Entered velocity or value is invalid
- axisGroup
Invalid axis group, too many spindles, too many axes or axis configured as spindle.

Error correction

- Check the entries of the safe machine parameters and correct them if necessary
- Switch the control off and on again
- If the values of the machine parameters have been changed, they are to be loaded by entering the manufacturer's password.
Then a corresponding acceptance test must be run.
- Inform your service agency.


Error description 330-00AF

Error message

Invalid entry in safe machine parameter

Cause of error

The configuration datum CfgAxGroupSafety contains an invalid value in a safe machine parameter.
- The number of the axis group in the safe machine parameter “id”invalid.
- The axis group is not of the “SPINDLE” type, but in the safe machine parameter “brakeAfter” there is a dependency on at least one other axis group.
- The axis group is not of the “SPINDLE” type, but the value “STO” is set in the safe machine parameter “idleState”.

Error correction

- Check the entries of the safe machine parameter and correct if necessary
- Switch the control off and on again
- If the values of the machine parameters have been changed, they are to be loaded by entering the manufacturer’s password.
Then a corresponding acceptance test must be run.
- Inform your service agency


Error description 330-00B0

Error message

Invalid entry in safe machine parameter

Cause of error

The safe machine parameter cfgSafety contains invalid values.

Error correction

- Check the entries of the safe machine parameter and correct them if necessary
- Switch the control off and on again
- If the values of the machine parameters have been changed, they are to be loaded by entering the manufacturer's password.
Then a corresponding acceptance test must be run.
- Inform your service agency.


Error description 330-00B1

Error message

Invalid entry in safe machine parameter

Cause of error

The configuration of the safe machine parameters is invalid. The following causes are possible:
- Invalid encoder input was configured or none and all (speed or position encoder)
- Invalid PWM output was configured or none at all
- Invalid assignment of axes/spindles to controller main boards
- Invalid assignment of PWM output and encoder input (speed or position encoder) to the controller main board
- Configuration between PWM output and encoder input (speed or position encoder) is invalid

Error correction

- Check the configuration in the safe machine parameters and correct them if necessary
- Switch the control off and on again
- If the values of the machine parameters have been changed, they are to be loaded by entering the manufacturer's password.
Then a corresponding acceptance test must be run.
- Inform your service agency.


Error description 330-00B2

Error message

Deviations in safe machine parameter

Cause of error

Safe machine parameters deviate between the individual parameter blocks of a
safe axis. This is not allowed.
The values have to match in all parameter blocks of an axis:
- Encoder input
- PWM output
- Encoder resolution per path
- Counting direction
- Line count

Error correction

- Check the entries of the safe machine parameters and correct them if necessary
- Switch the control off and on again
- If the values of the machine parameters have been changed, they are to be loaded by entering the manufacturer's password.
Then a corresponding acceptance test must be run.
- Inform your service agency.


Error description 330-00B3

Error message

MC self test %1 not started

Cause of error

The self-test for safety detected an error. A certain signal must be set for test purposes. This signal was not released by the indicated HSCI component.
The error message contains the following information:
MC self test STEST_<signal>, STESTDEV_<HSCI component>, <HSCI address>
- The signal to be set is indicated under STEST_.
- The HSCI component that did not set the signal is indicated under STESTDEV_.
- The given number in the error message matches the HSCI address of the HSCI component concerned.
Possible causes:
- HSCI component is defective.
- Wiring is faulty.

Error correction

- Exchange the HSCI component.
- Check the wiring
- Inform your service agency


Error description 330-00B4

Error message

MC self test %1 not detected

Cause of error

The self-test for safety detected an error. A certain signal was set and was not recognized by the indicated HSCI component.
The error message contains the following information:
MC self test STEST_<signal>, STESTDEV_<HSCI component>, <HSCI address>
- The set signal is indicated under STEST_.
- The HSCI component that did not recognize the set signal is indicated under STESTDEV_.
- The given number in the error message matches the HSCI address of the HSCI component concerned.
Possible causes:
- HSCI component is defective.
- Wiring is faulty.

Error correction

- Exchange the HSCI component.
- Check the wiring
- Inform your service agency.


Error description 330-00B5

Error message

MC Incorrect command from the MC

Cause of error

- Internal software error

Error correction

- Inform your service agency


Error description 330-00B6

Error message

MC Invalid SPLC operating mode

Cause of error

- Error in SPLC program
- SPLC requests an invalid operating mode
The valid modes are SOM_1, SOM_2, SOM_3, SOM_4
- Internal software error

Error correction

- Check the SPLC program
- Inform your service agency


Error description 330-00B7

Error message

MC brake control is defective %2

Cause of error

- Brake output of the inverter is defective
- PL output for controlling the brake is defective
- Incorrect wiring of the braking control (e.g. short circuit to 0 V, short circuit to 24 V)

Error correction

- Check the wiring of the brake control
- Check the wiring for short circuits to 0 V or 24 V
- Check the supply voltage of the outputs to the brake control (PL module, inverter)
- Inform your service agency.


Error description 330-00B8

Error message

MC brake control is defective

Cause of error

- Brake output of the inverter is defective
- PL output for controlling the brake is defective
- Incorrect wiring of the braking control (e.g. short circuit to 0 V, short circuit to 24 V)

Error correction

- Check the wiring of the brake control
- Check the wiring for short circuits to 0 V or 24 V
- Check the supply voltage of the outputs to the brake control (PL module, inverter)
- Inform your service agency.


Error description 330-00B9

Error message

MC error in the cutout channel STO.A.x (-STO.A.P.x=0) %2

Cause of error

The cutout channel test detected a fault:
The axis-specific pulse deletion for the power stage over the A channel is defective.
Switch-off signal: STO.A.P.x
Switch-off signal: STO.A.x
The acknowledgment signal for this cutout channel has the wrong condition, i.e. when
- JH inverter: Power stage reports "readiness" (RDY.x=1),
although "No readiness“ (RDY.x=0) is expected.
- DRIVE-CLiQ inverter: Associated diagnostic signal is "1",
although "0" is expected.

Error correction

- Check the wiring (PWM cable)
- Hardware error (power module, controller unit)
- Inform your service agency.


Error description 330-00BA

Error message

MC error in the cut-out channel STO.A.x (-STO.A.P.x=1) %2

Cause of error

The cutout channel test detected a fault:
The axis-specific pulse release for the power stage over the A channel is defective.
Switch-off signal: STO.A.P.x
Switch-off signal: STO.A.x
The acknowledgment signal for this cutout channel has the wrong condition, i.e. when
- JH inverter: Power stage reports "no readiness" (RDY.x=0), although "readiness“ (RDY.x=1) is expected.
- DRIVE-CLiQ inverter: Associated diagnostic signal is "0", although "1" is expected.

Error correction

- Check the wiring (PWM cable)
- Hardware error (power module, controller unit)
- Inform your service agency.


Error description 330-00BB

Error message

CC%2 error in cut-out channel STO.A.x (-STO.A.MC.WD=0) ax-grp A

Cause of error

The cutout channel test detected a fault:
The CC-specific pulse deletion for the corresponding power modules of the NC axis group (A) over the A channel is defective.
Switch-off signal: STO.A.MC.WD
Switch-off signal: STO.A.x
At least one of the acknowledgment signals for this cutout channel has the wrong condition, i.e. when
- JH inverter: At least one power module reports "readiness" (RDY.x=1), although for all power modules of the axis group A of the CC, "No readiness“ (RDY.x=0) is expected.
- DRIVE-CLiQ inverter: At least on of the associated diagnostic signal is "1", although "0" is expected.

Error correction

- Check the wiring (PWM cable)
- Hardware error (power module, controller unit)
- Inform your service agency.


Error description 330-00BC

Error message

CC%2 error in cut-out channel STO.A.x (-STO.A.MC.WD=0) ax-grp. S

Cause of error

The cutout channel test detected a fault:
The CC-specific pulse deletion for the corresponding power modules of the spindle axis group (S) over the A channel is defective.
Switch-off signal: STO.A.MC.WD
Switch-off signal: STO.A.x
At least one of the acknowledgment signals for this cutout channel has the wrong condition, i.e. when
- JH inverter: At least one power module reports "readiness" (RDY.x=1), although for all power modules of the axis group S of the CC, "No readiness“ (RDY.x=0) is expected.
- DRIVE-CLiQ inverter: At least on of the associated diagnostic signal is "1", although "0" is expected.

Error correction

- Check the wiring (PWM cable)
- Hardware error (power module, controller unit)
- Inform your service agency.


Error description 330-00BD

Error message

CC%2 error in cut-out channel STO.A.x (-STO.B.P.x) axis group A

Cause of error

The cutout channel test detected a fault:
The CC-specific pulse release for the corresponding power modules of the NC axis group (A) over the A channel is defective. The ready signal RDY for one axis group is missing.
The cutout channel STO.A.x was switched to inactive for the test of the cutout channel STO.B.x for all power modules.
At least one of the acknowledgment signals for this cutout channel has the wrong condition, i.e. when
- At least one power module reports “No readiness” (RDY.x=0), although “Readiness“ (RDY.x=1) is expected for all power modules of the axis group of the CC.

Error correction

- Check the wiring (e.g. pulse release X72 of the supply module,
X73 Heidenhain interface PCB, PWM cable is defective)
- Exchange defective hardware (power module)
- Inform your service agency


Error description 330-00BE

Error message

CC%2 error in cut-out channel STO.A.x, RDY signal missing

Cause of error

The cutout channel test detected a fault:
The CC-specific pulse release for the corresponding power modules of the spindle (S) over the A channel is defective. The ready signal RDY for one axis group is missing.
The cutout channel STO.A.x was switched to inactive for the test of the cutout channel STO.B.x for all power modules of the axis group S.
At least one of the acknowledgment signals for this cutout channel has the wrong condition, i.e. when
- At least one power module reports “No readiness” (RDY.x=0), although “Readiness“ (RDY.x=1) is expected for all power modules of the axis group of the CC.

Error correction

- Check the wiring (e.g. pulse release X71 of the supply module,
X73 Heidenhain interface PCB, PWM cable is defective)
- Exchange defective hardware (power module)
- Inform your service agency


Error description 330-00C0

Error message

Self-test required

Cause of error

- Maximum permissible time interval for the self-test has been exceeded
- For further operation of the machine with open guard doors, the self-test must be conducted

Error correction

- Start the self-test
- If the guard doors are closed, the error message can be acknowledged and machine operation continued
- With open guard doors, or before the guard doors are opened, the self-test must be conducted in order to continue operating the machine
- Inform your service agency


Error description 330-00C1

Error message

MC drives cannot be switched on: NN_GenSafe = 0

Cause of error

- SPLC interface signal NN_GenSafe = 0. It is therefore impossible to switch on the drives.
- SPLC program does not set the interface signal.

Error correction

- Check the SPLC program.
- Inform your service agency.


Error description 330-00C2

Error message

Error during activation of an FS configuration

Cause of error

The activation of another FS configuration was canceled because the CRC checksums of the FS data records differ.

Error correction

- Reset the "accepted" status of the most recently changed FS data records
- Manually undo your most recently made changes
- Copy a valid backup onto the machine
- Inform your service agency


Error description 330-00C3

Error message

FS configuration error: machine IDs do not match

Cause of error

The activation of another FS configuration was canceled because the entered machine IDs of the FS configurations differ.

Error correction

– Check the machine IDs of the FS configurations
- Inform your service agency


Error description 330-00C4

Error message

Maximum number of FS data records has been reached

Cause of error

The activation of another FS configuration was canceled because the maximum permissible number of different FS data records was exceeded.

Error correction

- Delete any unneeded FS data records
- Inform your service agency


Error description 330-00C5

Error message

Maximum number of FS configurations has been reached

Cause of error

The activation of another FS configuration was canceled because the maximum permissible number of different FS configurations was exceeded.

Error correction

- Delete any unneeded FS configurations
- Inform your service agency


Error description 330-00C6

Error message

MC manual operation. Only one axis allowed.

Cause of error

— Two or more axes are being moved in the "Electronic Handwheel" operating mode.
- Simultaneous movement of multiple axes is not allowed.

Error correction

- Move only one axis in the Handwheel operating mode.
- Check the entry in the appropriate safe machine parameter and correct it if necessary.
- Inform your service agency.


Error description 330-00C7

Error message

A fatal reconfiguration error was triggered

Cause of error

- The reconfiguration process for functional safety (FS) has failed.

Error correction

- The status "accepted" will be reset for all configurations and data records for functional safety.
- The comparison data records will be deleted.
- Install a complete backup of the machine.
- Inform your service agency.


Error description 330-00C8

Error message

Acceptance not allowed during configuration process

Cause of error

- Acceptance testing of data records configurations was conducted during an FS configuration process. This is not allowed.

Error correction

- Conduct the acceptance testing when the configuration process is completed.
- Inform your service agency.


Error description 330-00C9

Error message

Error during activation of an FS configuration

Cause of error

One of the following safe machine parameters was changed after the self-test began:
- Time to next self-test
- Time monitoring for brake test
These machine parameters can be changed only before starting the safety self-test.

Error correction

- Undo the change in the affected machine parameters.
- Restart the control.
- Inform your service agency.


Error description 330-00CA

Error message

Axis-group-specific guard door is open (MC) %1

Cause of error

- Guard door of the axis group is opened
The guard door has to be closed in order to conduct the safety self-test or the brake test of a respective axis group
Further possible causes:
- Faulty wiring of guard doors
- Guard door contact is defective
- SPLC interface signal PP_AxGrpStateReq unequal to S_STATE_AUTO [10]

Error correction

- Close the axis-group-specific guard doors in order to conduct the safety self-test or the brake test
Further possible measures:
- Check the wiring of the guard door contacts
- Check the guard door contact
- Check the SPLC program
- Inform your service agency


Error description 330-00CB

Error message

Axis-group-specific guard door is open (CC) %1

Cause of error

- The guard door is open
The guard door(s) has to be closed in order to conduct the safety self-test or the brake test of an axis
Further possible causes:
- Faulting wiring of the guard door
- Guard door contact is defective

Error correction

- Close the guard door(s) in order to conduct the safety self-test or the brake test
Further possible measures:
- Check the wiring of the guard door contacts
- Check the guard door contact
- Check the SPLC program
- Inform your service agency


Error description 330-00CC

Error message

The time until the next brake test is invalid for one axis %1

Cause of error

- A time greater than 0 is configured for a non-safe axis

Error correction

- For an axis that is not monitored by functional safety (FS) , only 0 is allowed as the time value.


Error description 330-00DE

Error message

Commissioning function for FS is active

Cause of error

Commissioning support for functional safety (FS) functions are active:
- The NC software does not limit velocity
- Unexpected movements or dangerous situations might occur

Error correction

- The machine must be operated only by trained personnel.
- Operate the machine only with great caution
- This function must be activated only for commissioning purposes
- Deactivate this function before shipping the machine


Error description 330-00E7

Error message

FS data record cannot be accepted

Cause of error

- There are at least two FS data records with identical ID in different parameter sets and at least one safe parameter SMP has a different value in both parameter set.

Error correction

- Compare and adjust the values of the safe parameters SMP of the same data record between the parameter sets.
- To avoid such errors, HEIDENHAIN recommends using the “KeySynonym” function.
- Inform your service agency.


Error description 330-00E8

Error message

Self-test required

Cause of error

- Maximum permissible interval time for the self-test has been exceeded
- The self-test must be conducted for further operation of the machine with open guard doors

Error correction

- Start the self-test
- When the guard doors are open, or before opening the guard doors, the self-test must be started in order to continue operating the machine


Error description 330-00EA

Error message

Activation of the automatic change mode not possible

Cause of error

An FS reconfiguration has not yet concluded.

Error correction

Wait until the FS reconfiguration process is completed and then retry.


Error description 330-00EC

Error message

MC: S status reaction is active: %1

Cause of error

An error bit was set in the S status by an internal hardware or software error:
-SCC.B.WD: Watchdog WD.B.CC of a CC controller unit has timed out
-SMOP.WD: Watchdog WD.A.SMOP or WD.B.SMOP of an MB or TE machine operating panel has timed out
-SPL.WD: Watchdog WD.A.SPL or WD.B.SPL of a PLB has timed out
-PF.BOARD: The internal voltage monitoring of an HSCI component has detected a faulty supply voltage
-REQ.SS2: The internal temperature or fan monitoring of an HSCI component has detected a fault

Error correction

- Generate the service file
- Inform your service agency


Error description 330-00ED

Error message

MC error, device-specific evaluation CC %2 / %3, error %1

Cause of error

The CC controller unit reports a device-specific error.

Error correction

Inform your service agency


Error description 330-00EE

Error message

SKERN-MC: single-event-upset error (SEU) was determined

Cause of error

- Internal software error
- Possible sporadic error due to EMC irradiation

Error correction

- Restart the control
- Check the shielding or shield connection of the devices
- Shield or remove possible EMC interferences
- Inform your service agency


Error description 330-00EF

Error message

SMC error in the configuration data %1

Cause of error

The configuration parameters do not match the expected values.

Error correction

Check the machine parameters and correct as needed


Error description 330-00F0

Error message

Checking of axes of various axis groups

Cause of error

You attempted to check axes of different axis groups simultaneously.

Error correction

- Check the configuration: axes that are coupled in a rigid gantry combination must belong to the same axis group
- Uncouple a dynamic gantry combination if you want to check it
- If necessary, inform your machine manufacturer


Error description 330-00F1

Error message

Reconfiguration while checking the axes

Cause of error

Safe machine parameters were reconfigured while the axes were being checked. Checking was therefore aborted.

Error correction

- Re-check the axes
- If the problem persists, inform your machine manufacturer


Error description 330-00F2

Error message

Checking of an externally monitored axis

Cause of error

You attempted to check an externally monitored axis. The control can check only internally monitored axes.

Error correction

- Check the parameter CfgAxParSafety/encoderForSafety
- Inform your service agency


Error description 330-00F3

Error message

Permissive button missing while checking

Cause of error

While checking an axis, you failed to press the permissive button within the time prescribed by the control.

Error correction

Re-check the axis.


Error description 330-00F4

Error message

Checking during a fatal error

Cause of error

You attempted to check an axis while the functional safety was in a fatal error state.

Error correction

- Restart the control
- If necessary, inform your service agency


Error description 330-00F5

Error message

Axis not at test position

Cause of error

- The axis to be checked is not located at the test position (safe machine parameter positionMatch in CfgAxisSafety)
- Axis is too far from the test position (safe machine parameter positionDiffRef in CfgAxisSafety)

Error correction

- Press CE to acknowledge the error message and move the axis to the test position
- Then check the axis
If the message appears although the axis is at the correct test position:
- For gantry combinations, an axis other than the one being checked might not be in the correct position. If necessary, uncouple the gantry combination for checking.
- Check the configuration of the axis traverse direction and correct it if necessary (machine parameter signCorrActualVal, signCorrNominalVal, or entry in the DIR column of the motor table)
- Inform your machine manufacturer


Error description 330-00F6

Error message

FS configuration with a parameter whose value cannot be accepted

Cause of error

Acceptance of CfgSafety/CfgAxParSafety > speedPosComptype with the value noComp is not allowed.

Error correction

- Reset the acceptance status
- Reset the parameter value


Error description 330-00F7

Error message

Axis in motion

Cause of error

Possible causes:
- The axis to be checked is still in motion
- Another axis that belongs to the same axis group as the axis to be checked is still in motion

Error correction

- Press CE to acknowledge the error message and bring the axis to a standstill
- Then check the axis
- Inform your service agency


Error description 330-00F8

Error message

Internal software error

Cause of error

You checked an axis while another axis was still being checked

Error correction

- Conclude checking of the first axis before checking another axis
- Inform your service agency


Error description 330-00F9

Error message

Checking of axes of different axis groups

Cause of error

You checked two or more axes at the same time even though they belong to different axis groups

Error correction

- Make sure that all internally monitored axes of a gantry combination belong to the same axis group
- Inform your machine manufacturer
- Inform your service agency


Error description 330-00FA

Error message

CC error while testing axes

Cause of error

An error occurred in the CC controller unit while testing the axes.

Error correction

Note the additional error message of the CC controller unit


Error description 330-00FB

Error message

Internal software error SMC

Cause of error

An internal software error occurred in the functional safety aspect.

Error correction

Inform your service agency


Error description 400-071F

Error message

Key non-functional

Cause of error

In this context the key has no function.


Error description 400-0720

Error message

Selected block not addressed

Cause of error

After an interruption in the program run, the control cannot resume program run from the present cursor location.

Error correction

Select the desired location for resuming the program with "GOTO" + block number, or with the mid-program startup function.


Error description 400-073E

Error message

Parameter not found %1

Cause of error

A value could not be read from the configuration data.

Error correction

Check the configuration data.


Error description 400-075F

Error message

Error while reading the model data from %1

Cause of error

Error while reading the model data.

Error correction

Delete the faulty file and make a new one.


Error description 400-0760

Error message

Error while writing the model data to %1

Cause of error

Error while writing the model data.

Error correction

Check the memory capacity. Error in file system.


Error description 400-0761

Error message

Directory '%1' could not be created.

Cause of error

Directory could not be created.

Error correction

Check the memory capacity. Error in file system.


Error description 400-0768

Error message

Selection of %1 not allowed

Cause of error

The tool table tool.t is meant only for program run.

Error correction

Select another tool table.


Error description 400-0773

Error message

Unable to write parameter

Cause of error

A configuration file might be write protected.


Error description 400-0774

Error message

Error in preset table

Cause of error

The preset table is faulty. Possible causes:
- The preset table is write-protected or it does not exist.
- Line 0 does not exist.
- The is no line with ACTNO = 1.

Error correction

- Please make the preset table or cancel the write protection
- Enter the line 0 in the preset table
- Set ACTNO in one line to zero


Error description 400-0775

Error message

Incomplete graphic model

Cause of error


Error description 400-0777

Error message

Error while transferring command to PLC server

Cause of error

Internal software error.

Error correction

Inform your service agency.


Error description 400-077F

Error message

File is being saved and cannot yet be opened

Cause of error

The file is now being saved in the editor.

Error correction

- After the saving process is complete, reselect the file.
- The condition is indicated by the “Please wait” icon.


Error description 401-0001

Error message

Message %1 cannot be transmitted

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 401-0002

Error message

The application could not be initialized

Cause of error

Logon with the confiration server is not possible. Configuration of the programmable axes is contradictory.

Error correction

Check the configuration data and edit.


Error description 401-0003

Error message

Bad option %1 specified

Cause of error

Internal software error

Error correction

Inform your service agency.


Error description 401-0004

Error message

The file %1 already contains a binary coded NC program

Cause of error


Error description 401-0005

Error message

The file %1 does not contain an NC program

Cause of error


Error description 401-0006

Error message

The file %1 already contains an encrypted NC program

Cause of error


Error description 401-0007

Error message

The file %1 contains data in an unknown format

Cause of error


Error description 401-0008

Error message

The file %2 will be overwritten by file %1

Cause of error


Error description 401-0009

Error message

Specified drive %2 of the file %1 cannot be substituted

Cause of error

An NC program is to be installed on a drive other that 0:, R: or V:.

Error correction

Check and edit the configuration data for cycles and NC macros.


Error description 401-000A

Error message

%2 file was converted ( %1 )

Cause of error


Error description 401-000B

Error message

File %1 could not be converted to file %2

Cause of error

Error during conversion of an NC program. The file could not be saved.

Error correction

Check the path name and write protection of the target file.


Error description 401-000C

Error message

File %2 was encrypted

Cause of error


Error description 401-000D

Error message

Installation of cycles complete

Cause of error


Error description 401-000E

Error message

Error:

Cause of error


Error description 401-000F

Error message

%2 file was converted

Cause of error


Error description 401-0010

Error message

%1 file contains data in an illegible format

Cause of error

At an earlier time the program was converted to an unreadable format. No backup copy was made from which another conversion would be possible.

Error correction

Recopy the file with the source text of the program to the control and start the conversion again.


Error description 401-0011

Error message

The file %1 contains syntactically incorrect NC block
%2.

Cause of error

The program uses an unknown cycle or axis, or contains other syntax errors.

Error correction

Copy the file with the corrected program source text to the control again and restart the conversion.


Error description 402-0001

Error message

FK programming: Contradictory input

Cause of error

You programmed contradictory data within a contour element or in different contour elements.

Error correction

Check the entered data and modify it.


Error description 402-0002

Error message

FK programming: Undefined starting position

Cause of error

You did not define an unambiguous tool position before beginning an FK sequence.

Error correction

Before beginning an FK sequence, program a positioning block with both coordinates of the working plane.


Error description 402-0003

Error message

FK programming: No FPOL defined

Cause of error

You programmed polar coordinates within an FK sequence without first defining the pole.

Error correction

Use the FPOL function to program a pole.


Error description 402-0004

Error message

FK programming: FSELECT not allowed.

Cause of error

An FK sequence contains an FSELECT block although the contour is already clearly defined.

Error correction

Edit the NC program: delete the corresponding FSELECT block.


Error description 402-0005

Error message

FK programming: Contour too complex

Cause of error

The number of unresolvable FK blocks or the number of selectable alternative contours exceeds the permissible maximum value of 32 each.

Error correction

Use FSELECT to resolve the FK sequence earlier, or enter additional data.


Error description 402-0006

Error message

FK programming: Internal software error

Cause of error

The control software could not calculate the programmed contour, although it satisfies all formal requirements tested.

Error correction

Try to program the desired contour in another way. If necessary, inform the service agency for you control.


Error description 402-0007

Error message

FK programming: Illegal coordinate

Cause of error

You programmed an illegal axis within an FK sequence.

Error correction

Program only coordinates in the working plane that you defined using FPOL (default: XY plane).


Error description 402-0008

Error message

FK programming: Incomplete input

Cause of error

You did not program all required data within an FK sequence. The following are illegal:
only one coordinate in the FPOL block,
only one coordinate of a auxiliary point (PD, P1, P2 or P3),
PD auxiliary point without the distance DP or vice versa,
FC/FCT circular arc without definition of a rotational direction (DR),
the distance of a contour to a parallel line (DP) without the parallel line (PAR) or vice versa.

Error correction

Add the missing data to the NC program.


Error description 402-0009

Error message

FK programming: Illegal positioning block

Cause of error

Within an unresolved FK sequence you programmed an illegal positioning block other than FK blocks, RND/CHF, APPR/DEP, and L blocks with motion components exclusively perpendicular to the FK plane.

Error correction

First resolve the FK sequence completely or delete illegal positioning blocks. Geometry functions that are defined over the gray contouring keys and have coordinates in the working plane are illegal (exception: RND, CHF, APPR/DEP).


Error description 402-000A

Error message

FK programming: Illegal operation

Cause of error

The following are illegal in open FK sequences: PGM END (program end), CYCL DEF 7-11 and 26 (coordinate transformations), TOOL CALL (tool change), and PGM CALL (program calls)

Error correction

First resolve the FK sequence or program the objectionable operation at another location in the program.


Error description 402-000B

Error message

FK programming: Illegal block reference

Cause of error

From an FK sequence, a block number is used to make reference to the end point or the end tangent of a block that either
- does not exist
- is too far away (> 64 blocks below or > 32 blocks above)
- is not a positioning block
- belongs to a category of positioning blocks which cannot be used for references (transitions, CC, FPOL, blocks containing only axis values or machine coordinates)

Error correction

Enter a reference to another block, or do without the reference


Error description 402-000C

Error message

FK programming: Incomplete input

Cause of error

The FK sequence is not complete at its program end. You will have to program additional data or NC blocks.

Error correction

* Add FK blocks as the end or edit them.
* Add the missing data or NC blocks within the program.
Note:
- In each block, program the data that do not change. (Non-programmed data are treated as unknown.)
- If the first block of an FK contour is an FCT or FLT block, you must program at least two NC blocks with the gray path function keys to fully define the direction of contour approach.
An FK contour must not be programmed immediately after an LBL command


Error description 600-0009

Error message

Casting machining was interrupted due to an
internal error. Machining is not possible.
%1

Cause of error

Data overflow or insufficient memory.

Error correction

Check the program. If necessary, correct the finished part.


Error description 600-000A

Error message

Blank defined smaller than finished part.
%1

Cause of error

Error in the part definition.

Error correction

Redefine the table.


Error description 600-000B

Error message

Drill tip longer than bore!
No rough drilling takes place.
%1

Cause of error

Perhaps the inside contour resulted unintentionally from contour generation of the finished part.

Error correction

Check the program. If necessary, correct the finished part.


Error description 600-000C

Error message

No free memory capacity.
%1

Cause of error

The data module is too small or the contours are too large.

Error correction

If possible, simplify the part.


Error description 600-000F

Error message

Internal error - more information in the system warning
%1

Cause of error


Error description 600-0011

Error message

There is nothing to machine or nothing
can be machined under these preconditions.
%1

Cause of error

Error in the data.

Error correction

Redefine the program.


Error description 600-0012

Error message

No automatic function available for this function.
Do the machining manually.
%1

Cause of error

Incorrect main machining mode.

Error correction

Redefine the main machining mode.


Error description 600-0013

Error message

Since "Clamping" was not used, an external
chuck with 15 mm clamping length is assumed.
%1

Cause of error

The part is not clamped.

Error correction

Interrupt TURN PLUS and clamp the part.


Error description 600-0015

Error message

Since no cutting limit was defined, it will be set to the
end of the workpiece
%1

Cause of error

The cutting limit assignment will be exited without data.

Error correction

Clamp or enter the values for the cutting limit.


Error description 600-0031

Error message

Tool %2 was programmed without cutting speed.
A default value is set.
%1

Cause of error

The database is incomplete.

Error correction

Expand the cutting database.


Error description 600-0032

Error message

Tool %2 was programmed without main feed!
A default value is set.
%1

Cause of error

The database is incomplete.

Error correction

The cutting database must be expanded.


Error description 600-0033

Error message

You are attempting to load cutting data
for an unidentifiable tool number. This is not possible.
%1

Cause of error

Since the tool was already loaded via DCS, the cause can only be a software or hardware error.

Error correction

Load the part again and restart AWG.


Error description 600-0034

Error message

No cutting data available for this tool.
(Tool number, Material, Cutting material %2)
%1

Cause of error

The database has no data beyond the current combination of cutting material.

Error correction

Expand the cutting database, then restart the AWG.


Error description 600-0041

Error message

Defined secondary machining mode is invalid!
%1

Cause of error

Software error or incorrect data in the machining sequence.

Error correction

Check the entered machining sequence.


Error description 600-0049

Error message

Generated working block contains incorrect
record types or technology record is missing.
%1

Cause of error

No technology record was made.

Error correction

Check whether a tool was selected.


Error description 600-0051

Error message

Due to a tool geometry cutting limitation
an area to be finished cannot be machined.
%1

Cause of error

The tool diameter is too large.

Error correction

Select or define another tool.


Error description 600-0081

Error message

For automatic calculation of the tool change
position, tool selection must be set to turret!
%1

Cause of error

The parameter for tool selection is set incorrectly.

Error correction

In the parameter editor, set the tool selection to turret.


Error description 600-0083

Error message

No valid slide number was found, machining
is taking place with slide number 1!
%1

Cause of error

Header is invalid.

Error correction

The slide number must be entered in the header.


Error description 600-00A9

Error message

No data on machining site;
no automatic tool selection possible!
%1

Cause of error

The data were not entered correctly.

Error correction

Reenter the data.


Error description 600-00AA

Error message

No data on machining direction;
no automatic tool selection possible!
%1

Cause of error

The data were not entered correctly.

Error correction

Reenter the data.


Error description 600-00AB

Error message

No data on machining mode;
no automatic tool selection possible!
%1

Cause of error

The data were not entered correctly.

Error correction

Reenter the data.


Error description 600-00B1

Error message

Since no drill with sufficient effective length
is available, no through-drilling is possible.
%1

Cause of error

No suitable tool available.

Error correction

If possible, add to the data bank.


Error description 600-00B2

Error message

Since no suitable internal roughing tool was
found, only a partial section can be machined.
%1

Cause of error

No suitable tool available.

Error correction

If possible, add to the data bank.


Error description 600-00B3

Error message

Since no internal finishing tool was found,
only a partial section can be machined.
%1

Cause of error

No suitable tool available.

Error correction

If possible, add to the data bank.


Error description 600-00B4

Error message

No suitable tools available
(Ideal-/Alternative-/Emergency tool: %2)! %3
%1

Cause of error

The database is too small.

Error correction

Enter more tools, or increase the possible tolerance values.


Error description 600-00B5

Error message

Unknown tool type defined!
No automatic tool selection possible.
%1

Cause of error

Tool type input error.

Error correction

Reenter the tool type.


Error description 600-00CC

Error message

The 1st hole limit diameter must not be smaller
than the 2nd hole limit diameter.
%1

Cause of error

UBD2 > UBD1

Error correction

Exchange the diameter values.


Error description 600-00F9

Error message

Due to technological cutting limitations,
specific machining areas must be omitted.
%1

Cause of error

Cutting limitations of the chuck.

Error correction

Clamp the part differently.


Error description 600-0101

Error message

No tool selection possible with available
data on machining mode, site and direction!
%1

Cause of error

The data were not entered correctly.

Error correction

Reenter the data.


Error description 600-0149

Error message

Elements with unknown machining data
were found in the finished part contour.
%1

Cause of error

Error in the analysis.

Error correction

Reload the contour and restart the AWG.


Error description 600-0181

Error message

Starting or overtravel length of thread too long!
Collision with workpiece or chuck jaws!
%1

Cause of error

Starting length or overtravel length is defined too large.

Error correction

Correct the starting or overtravel length.


Error description 600-0189

Error message

Secondary machining direction of tool invalid;
end face elements are not finished faced.
%1

Cause of error

Auxiliary cutting edge undefined or incorrectly defined.

Error correction

Define the auxiliary cutting edge correctly.


Error description 600-01C3

Error message

No attributes defined for thread.
%1

Cause of error

No thread attributed defined.

Error correction

Define thread attributes.


Error description 600-01C4

Error message

Contour contains thread whose edge elements
are not finish machined.
%1

Cause of error

Unmachined contour areas.

Error correction

Machine manually or after a second clamping.


Error description 600-01C9

Error message

More than 6 threads were defined
within a machining site.
%1

Cause of error

More that six threads were defined for one machining location.

Error correction

Define a maximum of six threads per machining location.


Error description 600-0211

Error message

Finished part does not line entirely within the workpiece
blank. Defined part can't be machined in this condition.
%1

Cause of error

The parts were entered incorrectly.

Error correction

Delete one part and define it again.


Error description 600-0212

Error message

Contour sense of rotation undeterminable!
%1

Cause of error

The parts were entered incorrectly.

Error correction

Delete the part and define them again.


Error description 600-0213

Error message

Blank contour contains irreparable errors!
Machining is not possible.
%1

Cause of error

The part was entered incorrectly.

Error correction

Delete the part and define it again.


Error description 600-0214

Error message

Finished part contour contains irreparable errors!
Machining is not possible.
%1

Cause of error

The part was entered incorrectly.

Error correction

Delete the part and define it again.


Error description 600-0215

Error message

No program header defined!
Definition required prior to machining.
%1

Cause of error

The program header was not generated or it has an old structure.

Error correction

Generate a program head.


Error description 600-0229

Error message

Corner is unsuitable for the separation point.
Cond.: inner corner angle > 180 deg. - inward copy angle
%1

Cause of error

The AWG cannot follow the machining strategy resulting from the chosen separation point.

Error correction

Either machine the part with the interactive working plane generation (IWG) or change the separation point.


Error description 600-022A

Error message

Contour element for machining through the separation
is within clamping range. Separation point is deleted.
%1

Cause of error

The separation point lies within the clamping range.

Error correction

Either clamp differently or change the separation point.


Error description 600-0239

Error message

Either all secondary machining modes
must be defined or none.
%1

Cause of error


Error description 600-0261

Error message

Pocket/island milling is not yet possible.
Alternatively the contour is milled.
%1

Cause of error

You defined a contour without attributes. You did not define whether it is machined internally or externally, therefore pocket milling is assumed.

Error correction

Assign contour attributes.


Error description 600-0262

Error message

The cutter radius cannot be determined from the
contour. A default cutter is used (%2).
%1

Cause of error

The contour now has circular inside corners. The cutter diameter cannot be determined.


Error description 600-0263

Error message

Contour sense of rotation undetermined. The cutter radius
cannot be determined ==> standard cutter (%2 dia.)
%1

Cause of error

The contour is open. Open contours can only be engraved.


Error description 600-0264

Error message

Machining side is not clear. The contour side
is selected depending on the depth.
%1

Cause of error

There were no contour attributes assigned.

Error correction

Assign contour attributes.


Error description 600-0265

Error message

Pockets can only be machined internally.
%1

Cause of error

You assigned either the "contour" or "external" attribute to the pocket.

Error correction

Assign the "internal" attribute.


Error description 600-0266

Error message

Islands can only be machined externally.
%1

Cause of error

You assigned either the "contour" or "internal" attribute to the island.

Error correction

Assign the "external" attribute.


Error description 600-0267

Error message

Tool with the defined %2 diameter was not
found. Select tool with a smaller diameter %3.
%1

Cause of error

The corresponding tool is not in the turret or in the file, or the tool with the given diameter is not well suited for the task.

Error correction

Make the tools available or change the parameter.


Error description 600-02D9

Error message

No tool found. Use a left-hand tool to machine the
front side and a right-hand tool to machine the rear.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02DA

Error message

No tool found in the file with which machining
is to be carried out.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters.


Error description 600-02DB

Error message

No tool found in the file which can be used to carry
out the machining process.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02DC

Error message

No tool found with a permissible secondary machining
direction needed for machining.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02DD

Error message

No tool found. Contour cannot be machined using the
adjustment and tool tip angle specified
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02DE

Error message

No tool found. The tool cutting width (without radius)
is too large for the recess.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02DF

Error message

No tool found. The plunging depth of the tool is
insufficient.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02E0

Error message

No tool found whose direction of rotation fits the
machining side of the contour and the milling direction.
%1

Cause of error

A tool is being sought whose a direction of rotation that has not yet been defined.

Error correction

In the machining attributes, change up-cut to climb, or vice versa.


Error description 600-02E1

Error message

No tool found. Machining is only possible with
stationary tools.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02E2

Error message

No tool found. Machining is only possible with
driven tools.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02E3

Error message

No tool found. Please check the milling machine
cutting teeth.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02E4

Error message

No tool found. The effective length is insufficient
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02E5

Error message

No tool found. Please check the milling diameter.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02E6

Error message

No tool found. Please check the milling angle.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02E7

Error message

Multi-cut tools are not supported and are therefore
rejected.
%1

Cause of error

The automatic tool selection does not work for multi-cut tools.


Error description 600-02E8

Error message

No tool found that also fits in the tool mount location.
%1

Cause of error

The mount types of tool and tool carrier do not match.

Error correction

If the mount type is incorrect, adjust the mount type of the tool to the mount type of the tool-carrier mount positions.


Error description 600-02E9

Error message

No tool found. The effective length is insufficient
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02EA

Error message

No tool found. Please check drill diameter.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02EB

Error message

No tool found. Please check tool tip angle.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02EC

Error message

No tool found. Please check tappet diameter.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02ED

Error message

No tool found. Please check tappet length.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02EE

Error message

No tool found. Check countersinking angle.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02EF

Error message

No tool found. Please check thread pitch.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02F0

Error message

No tool found. Please check centering angle.
%1

Cause of error

Optimization deletes all tools because they seem unsuitable for the AWG.

Error correction

Check the parameters stored under tool geometry with those of the tool.


Error description 600-02F1

Error message

No tool found. Data on cutting materials are
missing.
%1

Cause of error

There are no cutting materials entered on the tool data.

Error correction

Enter the cutting materials in the tool data.


Error description 600-0301

Error message

Selection parameters for tool selection
mode not set!
%1

Cause of error

Parameter error.

Error correction

In the parameter editor, set the parameter for type of tool selection.


Error description 600-0302

Error message

No tool and turret data defined for
entered slide number.
%1

Cause of error

Parameter error.

Error correction

In the parameter editor, set the parameter for type of tool selection.


Error description 600-0304

Error message

Machining only possible using the turret!
%1

Cause of error

The automatic magazine position assignment is not supported by the AWG.

Error correction

In the parameter editor, set the parameter for type of tool selection.


Error description 600-0305

Error message

Invalid slide/spindle assignment in program header!
%1

Cause of error

Incorrect parameter description in the program header.

Error correction

Change the program header.


Error description 600-0306

Error message

Invalid slide number specification in program header!
%1

Cause of error

Incorrect parameter description in the program header.

Error correction

Change the program header.


Error description 600-0307

Error message

Mount type of tool %2 does not fit any
mount type in turret.
%1

Cause of error

During automatic tool selection from a file, the control compares the tool mount types listed for the turret with the tool mount types entered in the NC program. The types must match.

Error correction

Ensure that the tool holder types match.


Error description 600-0309

Error message

Selected tool not in turret.
%1

Cause of error

The turret was incorrectly assigned, or the tool selection parameter is incorrectly set.

Error correction

Set the tool selection to "NEW" turret and start INI_REVBELEGUNG.


Error description 600-030A

Error message

Turret is full!
%1

Cause of error

The tool turret is full.

Error correction

Check the turret assignment and remove superfluous tools.


Error description 600-030B

Error message

Selection parameter for tool selection
mode not set!
%1

Cause of error

Parameter error.

Error correction

In the parameter editor, set the parameter for type of tool selection.


Error description 600-030C

Error message

Tool %2 is not suitable for mount location %3.
%1

Cause of error

Due to its mount type and preferred mount in the tool carrier description, the tool does not fit into its ideal, alternative, or emergency location. It is therefore simply placed in a vacant location.

Error correction

Edit the tool mount locations in the tool carrier description.


Error description 600-030D

Error message

There are no longer any free tool mount locations or
tool does not fit in carrier due to the mount type.
%1

Cause of error

The tool carrier is full, or the tool or the vacant locations in the carrier do not share the same mount types.

Error correction

If the mount type is incorrect, adjust the mount type of the tool to the mount type of the tool-carrier mount positions.


Error description 600-030E

Error message

No tool was found that also fits in the tool mount
location.
%1

Cause of error

The mount types of tool and tool carrier do not match.

Error correction

If the mount type is incorrect, adjust the mount type of the tool to the mount type of the tool-carrier mount positions.


Error description 600-030F

Error message

Tool %2 has no cam or location number.
%1

Cause of error

A cam number or code number is missing in the database.

Error correction

Enter a code or cam number in the tool data.


Error description 600-0379

Error message

Tool not contained in data base.
(Tool number %2)!
%1

Cause of error

The tool was inserted directly into the turret.

Error correction

Save the tool data in the database.


Error description 600-0399

Error message

Shaft is not prepared; no reverse machining possible
in this clamping mode.
%1

Cause of error

The shaft has a constant diameter.

Error correction

Delete the part and define it again.


Error description 603-0027

Error message

Contour area cannot be executed with active tool.

Cause of error

There is probably a blank form definition error. This means that the limiting contour lies in the vicinity of the starting element outside the workpiece blank.

Error correction

Check the workpiece blank definition in the part program and correct it if necessary.


Error description 603-0161

Error message

Extension of limiting contour at traversing angle
not possible due to formation of a contour loop.
%1

Cause of error

You selected an traversing angle at which the limiting contour intersects itself when extended in the traversing angle.

Error correction

Select a traversing angle that rules out a contour loop, or select a different machining range.


Error description 603-0162

Error message

Extension of limiting contour at travel angle
not possible due to formation of a contour loop.
%1

Cause of error

You selected an departure angle at which the limiting contour intersects itself when extended in the travel angle.

Error correction

Select a travel angle that rules out a contour loop, or select a different machining range.


Error description 603-0164

Error message

Error in finished part or blank definition.
Starting element of BEA area outside blank.
%1

Cause of error

There is probably a blank form definition error. This means that the limiting contour lies in the vicinity of the starting element outside the workpiece blank.

Error correction

Check the workpiece blank definition in the part program and correct it if necessary.


Error description 603-0165

Error message

Error in finished part or blank definition.
An end element of BEA area outside blank.
%1

Cause of error

This is probably a blank form definition error, which means that the limiting contour lies in the vicinity of the end element outside the workpiece blank.

Error correction

Check the workpiece blank definition in the part program and correct it if necessary.


Error description 603-0182

Error message

Residual material due to cutting
edge geometry!
%1

Cause of error

You selected a poorly suited tool.

Error correction

Select a tool whose geometry enables it to machine grooves in the contour.


Error description 603-01A2

Error message

The complete machining area is a
recessing contour and was erased.
%1

Cause of error

The cycle was not intended to machine recessing contours. Because it identified the entire limiting contour as recessing contour, it was deleted.

Error correction

Either select the cycle "with recessing," or select another machining area.


Error description 603-01A3

Error message

Too many recessing areas! Cycle not executable
due to a lack of memory. Reduce machining area.
%1

Cause of error

The recessing areas are saved internally in a contour list. Since there was not enough memory to save all recessing areas, the cycle had to interrupt.

Error correction

Try to run the cycle with a smaller machining area.


Error description 603-01E0

Error message

Invalid position of workpiece blank corner (X1,Z1)
%1

Cause of error

The workpiece blank corner was defined such that the workpiece does not fully include the ICP contour.

Error correction

Correct the coordinates (X1,Z1)


Error description 603-01E2

Error message

Residual material in recess due to cutting
edge width of recessing tool.
%1

Cause of error

Due to its cutting-edge geometry, the tool cannot reach every point in the selected machining area.

Error correction

Select another tool, or change the machining area.


Error description 603-0242

Error message

Nothing to machine for cycle in selected
contour area.
%1

Cause of error

It could be that the oversize is greater than the maximum distance between limiting contour and workpiece blank contour.

Error correction

Select a smaller oversize or another machining area.


Error description 603-0243

Error message

Nothing to machine for cycle in selected
contour area.
%1

Cause of error

You selected oversizes that are greater than the max. distance between limiting contour and workpiece blank contour, or you programmed machining in an area that has already been machined.

Error correction

Select a smaller oversize or another machining range.


Error description 603-0244

Error message

Longitudinal cutting limitation incompatible
with current tool position. Position the tool.
%1

Cause of error

You defined a longitudinal cutting limitation and the tool is positioned so that the cutting limitation shields the limiting contour from the tool.

Error correction

The tool must be positioned on the same side of the cutting limitation as the limiting contour to be machined. Reposition the tool accordingly.


Error description 603-0245

Error message

Transverse cutting limitation incompatible
with current tool position. Position the tool.
%1

Cause of error

You defined a transverse cutting limitation and the tool is positioned so that the cutting limitation shields the limiting contour from the tool.

Error correction

The tool must be positioned on the same side of the cutting limitation as the limiting contour to be machined. Reposition the tool accordingly.


Error description 603-0247

Error message

Equidistant allowance contour cannot be calculated.
Cycle cannot be executed.
%1

Cause of error

The equidistant replied with an error message and the equidistant was not executed.

Error correction

Inform your service agency.


Error description 603-0261

Error message

Machining with the selected tool is impossible!
Select another tool!
%1

Cause of error

The auxiliary machining direction, which results from the cutting edge geometry, is not entered in WZ_NORM. The use of the tool is therefore not permissible.

Error correction

Select another tool.


Error description 603-0281

Error message

Tool position unknown!
Position tool.
%1

Cause of error

You defined a longitudinal cutting limit. There are no valid position coordinates defined for the tool.

Error correction

Position the tool.


Error description 603-0282

Error message

Tool position unknown!
Position tool.
%1

Cause of error

A cutting limit plan was defined. There are no valid position coordinates defined for the tool.

Error correction

Position the tool.


Error description 603-0283

Error message

Tool positioned exactly on longitudinal cutting
limitation. Machining area cannot be determined.
%1

Cause of error

The control cannot recognize which side of the limit along the limiting contour to machine, because the tool is located exactly on the limiting axis.

Error correction

Position the tool longitudinally on the side of the cutting limitation to be machined.


Error description 603-0284

Error message

Tool positioned exactly on transverse cutting
limitation. Machining area cannot be determined.
%1

Cause of error

The control cannot recognize which side of the limit along the limiting contour to machine, because the tool is located exactly on the limiting axis.

Error correction

Position the tool transversely on the side of the cutting limitation to be machined.


Error description 603-02A1

Error message

Rough-machining cycle called with
invalid tool!
%1

Cause of error

Error correction

Select another tool.


Error description 603-02A2

Error message

Recessing cycle called with
invalid tool!
%1

Cause of error

Error correction

Select another tool.


Error description 603-02A3

Error message

Finish-machining cycle called with
invalid tool!
%1

Cause of error

Error correction

Select another tool.


Error description 603-02A4

Error message

Contour area cannot be machined with current tool
either with main (+Z) or secondary cutting edge (+X).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02A5

Error message

Contour area cannot be machined with current tool
either with main (+Z) or secondary cutting edge (-Z).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02A6

Error message

Contour cannot be machined with current tool
either with main (+Z) or secondary cutting edge (-X).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02A7

Error message

Contour area cannot be machined with current tool
either with main (+X) or secondary cutting edge (+Z).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02A8

Error message

Contour area cannot be machined with current tool
either with main (+X) or secondary cutting edge (-Z).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02A9

Error message

Contour area cannot be machined with current tool
either with main (+X) or secondary cutting edge (-X).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02AA

Error message

Contour area cannot be machined with current tool
either with main (-Z) or secondary cutting edge (+Z).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02AB

Error message

Contour area cannot be machined with current tool
either with main (-Z) or secondary cutting edge (X).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02AC

Error message

Contour area cannot be machined with current tool
either with main (-Z) or secondary cutting edge (-X).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02AD

Error message

Contour area cannot be machined with current tool
either with main (-X) or secondary cutting edge (+Z).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02AE

Error message

Contour area cannot be machined with current tool
either with main (-X) or secondary cutting edge (+X).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02AF

Error message

Contour area cannot be machined with current tool
either with main (-X) or secondary cutting edge (-Z).
%1

Cause of error

Error correction

Select another contour area or another tool.


Error description 603-02B0

Error message

Machining direction incompatible with contour direction.
Longitudinal or transverse cycle cannot be executed.
%1

Cause of error

A longitudinal or transverse cycle was called with a tool whose machining direction does not match the limiting contour direction.

Error correction

Select another tool or change the machining direction.


Error description 603-02B1

Error message

Recess cannot be machined with selected
tool. Check RECESS and TOOL SELECTION.
%1

Cause of error

Either you attempted to machine a recess with the width 0, or you attempted to machine a radial recess with an axial tool, or vice versa.

Error correction

Check the recess and the selected tool.


Error description 603-02C1

Error message

Approach to limiting contour at this traversing
angle invalid due to cutting edge geometry!
%1

Cause of error

With the programmed tool, the approach to the limiting contour is not permissible at this angle because otherwise the side rake would gouge the workpiece.

Error correction

Select another traversing angle or another tool.


Error description 603-02C2

Error message

Travel from limiting contour at this travel
angle invalid due to cutting edge geometry.
%1

Cause of error

With the programmed tool, the departure from the limiting contour is not permissible at this angle because otherwise the side rake would gouge the workpiece.

Error correction

Select another travel angle or another tool.


Error description 603-02C3

Error message

Transverse cutting limitation incompatible
with current tool position. Position the tool.
%1

Cause of error

The present tool position and the selected longitudinal cutting limitation make it impossible to machine the limiting contour in the roughing cycle.

Error correction

Position the tool so that it is on the other side of the cutting limitation axis, or select another transverse cutting limitation.


Error description 603-02C4

Error message

Longitudinal cutting limitation incompatible
with current tool position. Position the tool.
%1

Cause of error

The present tool position and the selected longitudinal cutting limitation make it impossible to machine the limiting contour in the roughing cycle.

Error correction

Position the tool so that it is on the other side of the cutting limitation axis, or select another longitudinal cutting limitation.


Error description 603-02E1

Error message

Longitudinal cutting limitation incompatible
with current tool position. Position the tool.
%1

Cause of error

The present tool position and the selected longitudinal cutting limitation make it impossible to machine the limiting contour in the recessing cycle.

Error correction

Position the tool so that it is on the other side of the cutting limitation axis, or select another longitudinal cutting limitation.


Error description 603-02E2

Error message

Transverse cutting limitation incompatible
with current tool position. Position the tool.
%1

Cause of error

The present tool position and the selected longitudinal cutting limitation make it impossible to machine the limiting contour in the recessing cycle.

Error correction

Position the tool so that it is on the other side of the cutting limitation axis, or select another transverse cutting limitation.


Error description 603-0301

Error message

Insufficient memory for individual contour areas.
Cycle cannot be executed. Reduce machining area.
%1

Cause of error

The limiting contour switches so often with the workpiece contour that the individual limiting contour areas cannot be saved in the contour list.

Error correction

Reduce the machining area and try again.


Error description 603-0321

Error message

Incorrect tool for machining.
Select WO 2 or WO 8.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select on of the proposed tools.


Error description 603-0322

Error message

Incorrect tool for machining.
Select WO 4 or WO 6.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0323

Error message

Incorrect tool for machining.
Select WO 5 or WO 7.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0324

Error message

Incorrect tool for machining.
Select WO 1 or WO 3
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools..


Error description 603-0325

Error message

Incorrect tool for machining.
Select WO 1 or WO 2
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0326

Error message

Incorrect tool for machining.
Select WO 2 or WO 3
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0327

Error message

Incorrect tool for machining.
Select WO 3 or WO 4
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0328

Error message

Incorrect tool for machining.
Select WO 4 or WO 5
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0329

Error message

Incorrect tool for machining.
Select WO 5 or WO 6
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-032A

Error message

Incorrect tool for machining.
Select WO 6 or WO 7
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-032B

Error message

Incorrect tool for machining.
Select WO 7 or WO 8
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-032C

Error message

Incorrect tool for machining.
Select WO 8 or WO 1
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-032D

Error message

Incorrect tool for machining.
Select WO 2, WO 3, WO 5 or WO 6
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools. CAUTION: The selection of the tool determines whether the contour is machined from the left or right!


Error description 603-032E

Error message

Incorrect tool for machining.
Select WO 1, WO 2, WO 6 or WO 7
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools. {0>ACHTUNG:<}0{>CAUTION:<0} The selection of the tool determines whether the contour is machined from the left or from the right!


Error description 603-032F

Error message

Incorrect tool for machining.
Select WO 1, WO 8, WO 3 or WO 4
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools. ACHTUNG: The selection of the tool determines whether the contour is machined from the left or right!


Error description 603-0330

Error message

Incorrect tool for machining.
Select WO 4, WO 5, WO 7 or WO 8
%1

Cause of error

An unsuitable tool was chosen for the intended operation.

Error correction

Select one of the proposed tools CAUTION: The selection of the tool decides whether cutting is on the left or right of the contour!


Error description 603-0331

Error message

Incorrect tool for machining.
Select WO 1, WO 3, WO 5 or WO 7
%1

Cause of error

An unsuitable tool was chosen for the intended operation.

Error correction

Select one of the proposed tools
CAUTION:
The selection of the tool decides whether cutting is on the left or right of the contour!


Error description 603-0332

Error message

Incorrect tool for machining.
Select WO 2, WO 4, WO 6 or WO 8
%1

Cause of error

An unsuitable tool was chosen for the intended operation.

Error correction

Select one of the proposed tools
CAUTION:
The selection of the tool decides whether cutting is on the left or right of the contour!


Error description 603-0333

Error message

The machining contour exceeds the center of turning
Modify the corresponding coordinates!
%1

Cause of error

The machining contour corners were programmed past the turning center

Error correction

Enter the coordinates so they all lie on one side of the center of rotation


Error description 603-0334

Error message

No surface for machining
Cycle has nothing to process!
%1

Cause of error

The cycle cannot calculate a machining surface because the contour only consists of one paraxial segment.

Error correction

Edit the entered coordinates


Error description 603-0335

Error message

Tool position not permissible!
Position in front of, or over the machining area!
%1

Cause of error

The cycle cannot move the tool from its given position to the starting point of machining without danger of collision.

Error correction

Position the tool in front of or over the machining area


Error description 603-0336

Error message

RAM data memory is full!
Contact Service!
%1

Cause of error

Insufficient memory for contour calculation

Error correction

This problem can only be fixed by service personnel.


Error description 603-0337

Error message

Incorrect tool for turning.
Select a lathe tool.
%1

Cause of error

An unsuitable tool was chosen for the intended operation.

Error correction

Select one of the proposed tools
CAUTION:
The selection of the tool decides whether cutting is on the left or right of the contour!


Error description 603-0338

Error message

Incorrect tool for cutting off.
Select a recess. tool.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.
CAUTION:
The selection of the tool determines whether the contour is machined from the left or right!


Error description 603-0339

Error message

Incorrect tool for machining.
Select WO 1, WO 3 or WO 2.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools..


Error description 603-033A

Error message

Incorrect tool for machining.
Select WO 1, WO 3 or WO 4.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-033B

Error message

Incorrect tool for machining.
Select WO 2, WO 8 or WO 1.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select on of the proposed tools.


Error description 603-033C

Error message

Incorrect tool for machining.
Select WO 2, WO 8 or WO 7.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select on of the proposed tools.


Error description 603-033D

Error message

Incorrect tool for machining.
Select WO 4, WO 6 or WO 3.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select on of the proposed tools.


Error description 603-033E

Error message

Incorrect tool for machining.
Select WO 4, WO 6 or WO 5.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select on of the proposed tools.


Error description 603-033F

Error message

Incorrect tool for machining.
Select WO 5, WO 7 or WO 6.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0340

Error message

Incorrect tool for machining.
Select WO 5, WO 7 or WO8.
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0341

Error message

Incorrect tool for machining.
Select WO 1, WO 2, WO 3, WO 4 or WO 5
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0342

Error message

Incorrect tool for machining.
Select WO 3, WO 4 or WO 5
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0343

Error message

Incorrect tool for machining.
Select WO 3, WO 4, WO 5, WO 6 or WO 7
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0344

Error message

Incorrect tool for machining.
Select WO 5, WO 6 or WO 7
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0345

Error message

Incorrect tool for machining.
Select WO 5, WO 6, WO 7, WO 8 or WO 1
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0346

Error message

Incorrect tool for machining.
Select WO 7, WO 8 or WO 1
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0347

Error message

Incorrect tool for machining.
Select WO 7, WO 8, WO 1, WO 2 or WO 3
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0348

Error message

Incorrect tool for machining.
Select WO 1, WO 2 or WO 3
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0355

Error message

Incorrect tool for machining.
Select WO 5, WO 6, WO 7, WO 8 or WO 1
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0356

Error message

Incorrect tool for machining.
Select WO 7, WO 8 or WO 1
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0357

Error message

Incorrect tool for machining.
Select WO 7, WO 8, WO 1, WO 2 or WO 3
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0358

Error message

Incorrect tool for machining.
Select WO 1, WO 2 or WO 3
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0359

Error message

Incorrect tool for machining.
Select WO 1, WO 2, WO 3, WO 4 or WO 5
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-035A

Error message

Incorrect tool for machining.
Select WO 3, WO 4 or WO 5
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-035B

Error message

Incorrect tool for machining.
Select WO 3, WO 4, WO 5, WO 6 or WO 7
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-035C

Error message

Incorrect tool for machining.
Select WO 5, WO 6 or WO 7
%1

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-035D

Error message

The main cutting direction does not fit the contour.

Cause of error

An unsuitable tool was selected for the next operation.

Error correction

Select one of the proposed tools.


Error description 603-0360

Error message

Invalid tool orientation for transverse machining (roughing)

Cause of error

In the facing cycle (transverse machining), tool orientations 2 and 6 are not possible for roughing


Error description 603-0361

Error message

Invalid tool orient. for longitudinal machining (roughing)

Cause of error

In longitudinal machining, tool orientations 4 and 8 are not possible for roughing


Error description 603-0366

Error message

The cycle cannot completely create the
programmed contour; residual material will remain.
%1

Cause of error

As a result of, for example, the cutting edge geometry and/or the inclination angle between the tool and workpiece, the cycle cannot reach all parts of the programmed contour.

Error correction

Check the current machining situation and assess whether
- the contour to be machined
- the selected tool
- the selected angle
- the programmed cycle
are appropriate for the programmed operation and make any necessary corrections.
Check whether a subsequent (finishing) cycle can remove the residual material without overloading the tool, and also correct any of the abovementioned parameters if necessary.
If the remaining residual material is acceptable for your machining situation then you can ignore this message.


Error description 605-024E

Error message

Programmed cutting depth too small
%1

Cause of error

The programmed value is too small.

Error correction

Check the NC program


Error description 605-0278

Error message

Feed axis is already braked in the thread
%1

Cause of error

The run-out length P in the thread cycle G31 is less than the cutting width SB of the tool being used.

Error correction

Enter a run-out length P at least as large as the cutting width SB of the tool, or select a tool with a smaller cutting width SB.


Error description 605-0279

Error message

Feed axis is still accelerated in the thread
%1

Cause of error

The run-in distance of the feed axis is too small. The tool cannot achieve the speed necessary in order to cut the thread correctly.

Error correction

Increase the run-in length B


Error description 605-027A

Error message

Determined run-in length is too short
%1

Cause of error

The space automatically determined from the recess or undercut is too short for the run-in length.

Error correction

Program a run-in length, or increase the recess or undercut


Error description 605-027B

Error message

Determined run-out length is too short
%1

Cause of error

The space automatically determined from the recess or undercut is too short for the run-out length.

Error correction

Program a run-out length, or increase the recess or undercut


Error description 605-032C

Error message

"TOOL_P" configured without tool magazine

Cause of error

The path to a pocket table was given in the machine configuration although no tool magazine is configured.
Access by the PLC run-time system to the pocket table is enabled through the symbolic name "TOOL_P" only for tool magazines.

Error correction

Adapt the machine configuration:
- Delete the "TOOL_P" path for the pocket table if no tool magazines are configured.


Error description 605-032D

Error message

Tool magazine configured without path for "TOOL_P"

Cause of error

Tool magazines were configured without the TOOL_P path for the pocket table.

Error correction

Adapt the machine configuration:
- Enter the symbolic name "TOOL_P" for the pocket table in CfgTablePath
- Enter the path to the pocket table under "TOOL_P"


Error description 605-0342

Error message

Active tool pocket unknown

Cause of error

The tool change was canceled.

Error correction

- Correct any pending error messages and repeat
- Inform your service agency


Error description 605-0344

Error message

Protective zone monitoring not allowed in axis system with B axis

Cause of error

The protection zone monitor in the axis system does monitor any position changes of the tool by rotary axes (e.g. the B axis).

Error correction

- Activation of the expanded protection zone monitor is required (MP_enhancedProtZone = 2: Machine base system)
- In addition, for machines with rear-face machining, adjustments in the kinematics is required
- Contact the machine tool builder
- Inform your service agency


Error description 605-0358

Error message

Starting block of channel <%2> cannot be reached because
other channels are already waiting at the sync. point
%1

Cause of error

The starting blocks were set on the individual channels in such a manner that,
because of sync. points, they cannot be reached.

Error correction

Cancel the mid-program startup, and set the starting block before the sync. point.


Error description 605-0359

Error message

Program run blocked due to a serious error
(e.g., configuration data or table)
%1

Cause of error

The configuration data or tables are not complete.
Reliable program execution cannot be performed.
See the LogFile.log for more information.

Error correction

Correct the configuration data and complete the tables.


Error description 605-035A

Error message

No workpiece blank defined for turning cycle

Cause of error

The workpiece blank must be defined in order for the turning cycle to calculate the paths. This workpiece blank definition does not match the workpiece blank defined with BLK FORM.

Error correction

Use FUNCTION TURNDATA BLANK to define a workpiece blank for the turning cycle.


Error description 606-0062

Error message

Calculation of the approach path not possible
%1

Cause of error

All calculated approaching paths damage the workpiece.

Error correction

Select another tool position


Error description 606-02E2

Error message

Area to be machined was not provided
%1

Cause of error

The area to be machine has not been provided.

Error correction

- Check the NC program
- Contact your service agency if the error occurs during program generation with TURN PLUS


Error description 606-02E3

Error message

A negative safety clearance is not allowed
%1

Cause of error

Global machining parameters are incorrect or safety clearance is set to an invalid value

Error correction

Revise the global machining parameters or set the safety clearance before the cycle call


Error description 606-0343

Error message

No valid cutting depth was defined; cycle is working
with 2/3 of the tool’s max. cutting depth
%1

Cause of error

The value of the G function’s P parameter is less than or equal to 0.

Error correction

Reset the P parameter of the NC block


Error description 606-0345

Error message

Internal memory of calculating the cuts is full
%1

Cause of error

The cycle needs too much memory space to save all cut lines. Example: 50 mm oversize with 0.003 mm cutting depth.

Error correction

Enter a larger cutting depth


Error description 606-0385

Error message

Too many stepping angles for simultaneous turning cycle

Cause of error

Calculation of the simultaneous turning cycle takes too long because the resolution of the angle range is too high.
The resolution was reduced automatically.


Error description 606-0386

Error message

Not a valid machining contour for simultaneous turning cycle

Cause of error

- The cycle has received an invalid contour.
- Internal software error.

Error correction

Check the contour: workpiece blank, tool holder, and machining contour must be closed. All elements must be greater than zero.
- Inform your service agency.


Error description 606-0387

Error message

Contour elements not properly marked (simultaneous turning)

Cause of error

The contour elements of the center point contour are not correctly marked for the simultaneous turning cycle.

Error correction

The following conditions must be fulfilled:
- An open space of the contour must be marked as "CYC".
- The starting element of the space must be the first element of the contour.


Error description 606-0388

Error message

Internal error in the simultaneous turning cycle

Cause of error

Due to an internal error, the simultaneous turning cycle could not be executed.

Error correction

- See "INTERNAL INFO" for more information.
- Generate the service files and inform your service agency.


Error description 606-0389

Error message

The contour cannot be completely machined

Cause of error

With the selected parameters, the simultaneous turning cycle cannot completely finished the programmed contour without collision.

Error correction

Inasmuch as is technically meaningful, adapt the range of the inclination angle in the cycle and, if required, select another tool for machining.


Error description 606-038B

Error message

Simultaneous turning: Tool is too far "behind" input contour

Cause of error

Correct approach and departure behavior is not possible if the tool along the Z axis is behind the workpiece blank or the machining contour.

Error correction

Position the tool farther away from the chuck (along Z+) in order to enable correct approach and departure behavior.


Error description 606-038C

Error message

The tilting motion results in a collision with the tool

Cause of error

The cycle could not rotate the tool from the initial inclination to the start inclination calculated by the cycle, or from the end inclination back to the initial inclination.

Error correction

Position the tool outside the collision range, farther away from the workpiece.


Error description 606-038D

Error message

Simultaneous turning: Tool tip radius must not be null

Cause of error

The simultaneous turning cycle requires a tool with a cutter radius greater than zero.

Error correction

Select another tool for the operation


Error description 606-038E

Error message

Tool position not defined

Cause of error

For open contours, the tool position must be programmed for the simultaneous turning cycle.

Error correction

Enter whether the tool should move to the right or left of the contour.


Error description 606-038F

Error message

No valid tool contour for simultaneous turning cycle

Cause of error

- The cycle has received an invalid contour.
- Internal software error.

Error correction

Check the contour: workpiece blank, tool holder, and machining contour must be closed. All elements must be greater than zero.
- Inform your service agency.


Error description 606-0391

Error message

Collision-free approach/departure could not be calculated

Cause of error

No collision-free approach/departure paths could be calculated for the given turning contour and position of the tool.

Error correction

It may be that the contour does not allow collision-free approach/departure paths. Check the contour, and correct the position of the tool if necessary.


Error description 606-0392

Error message

Desired inclination angles can't be reached without collision

Cause of error

The cycle could not be run because the programmed inclination angles could cause collisions.

Error correction

Change the NC program - adjust the inclination angle accordingly


Error description 606-0393

Error message

Cannot reach desired angle of incidence at beginning of contour
%1

Cause of error

The cycle could not be run because the programmed inclination angles could cause collisions.

Error correction

Change the NC program - adjust the inclination angle accordingly


Error description 606-0394

Error message

Clearance angle + cutting edge angle must be less than 180
%1

Cause of error

Clearance angle + cutting edge must not be more than 180°.

Error correction

- Decrease the clearance angle or
- Select a different tool


Error description 606-0396

Error message

Cycle changes angle of incidence at starting point
%1

Cause of error

An inclination angle was defined at the beginning of machining, together with the option "do not approach".

Error correction

- Select a different type of approach or
- Approach the desired inclination angle manually


Error description 606-0397

Error message

Aux. contour of tool head faulty,
collision monitoring not possible
%1

Cause of error

The description of the tool head does not include a closed envelope.

Error correction

Adapt or correct the description of the tool head.


Error description 606-0398

Error message

Wear comp. violates holder oversize
%1

Cause of error

The wear compensations of the tool are greater than the selected holder oversize

Error correction

Check the wear compensations and the holder oversize; you might need to choose a different tool


Error description 606-0399

Error message

Maximum infeed exceeded

Cause of error

The desired infeed must be chosen so that it is less than the maximum infeed.

Error correction

Reduce the desired infeed or increase the maximum infeed.


Error description 606-039A

Error message

Initial tool angle not in permitted inclination range

Cause of error

The pre-positioned tool angle violates the minimum or maximum inclination angle.

Error correction

Either pre-position the tool angle within the permitted angle range or expand the angle range correspondingly


Error description 606-039B

Error message

%2 Residual material will remain
%1

Cause of error

The target contour cannot be completely machined; residual material will remain.
This can be due to various reasons, such as the tool cannot reach the respective area due to geometrical reasons, the prescribed inclination angle range makes it impossible to reach the residual material, etc.

Error correction

Residual material must be considered for the subsequent machining operations.


Error description 606-039C

Error message

The cycle cannot machine the indicated target contour

Cause of error

The cycle cannot use the defined input parameters and the selected tool to machine the target contour.

Error correction

Adapt the corresponding input parameters or adapt the target contour or select an appropriate tool.


Error description 606-039D

Error message

Maximum infeed of tool exceeded

Cause of error

The desired infeed exceeds 2/3 of the cutting edge length of the tool. Cutting lines will be adapted if necessary.

Error correction

Reduce the desired infeed or select an appropriate tool


Error description 606-039F

Error message

The infeed does not match the length of the cutting edge

Cause of error

Possible causes:
- The current infeed is greater than the maximum cutting depth
- The maximum cutting depth is greater than 2/3 of the current length of the cutting edge

Error correction

Reduce the (maximum) infeed or use an appropriate tool


Error description 606-03A0

Error message

The safety clearance is too small
%1

Cause of error

The cycle requires a greater safety clearance in order to work without collision.

Error correction

Program a greater safety clearance.


Error description 60C-000B

Error message

No valid cutting speed programmed

Cause of error

The cycle cannot be run with the entered values.

Error correction

- Correct the values
- Restart the program


Error description 60C-000C

Error message

Invalid tool rotation direction

Cause of error

The cycle cannot be run with the entered values.

Error correction

- Correct the values
- Restart the program


Error description 60C-000D

Error message

Data not fully defined (2%)

Cause of error

The cycle cannot be run with the entered values.

Error correction

- Correct the values
- Restart the program


Error description 60C-000E

Error message

Information is missing for 2%

Cause of error

The cycle cannot be run with the entered values.

Error correction

- Correct the values
- Restart the program


Error description 60C-000F

Error message

The target point must be after the starting point

Cause of error

The cycle cannot be run with the entered values.

Error correction

- Correct the values
- Restart the program


Error description 60C-0010

Error message

Value in %2 does not agree with value in %3

Cause of error

The cycle cannot be run with the entered values.

Error correction

- Correct the values
- Restart the program


Error description 60C-0011

Error message

Tool diameter is too large

Cause of error

The cycle cannot be run with the entered values.

Error correction

- Correct the values
- Restart the program


Error description 60C-0012

Error message

Tool type %2 doesn't match the machining operation

Cause of error

The cycle cannot be run with the entered values.

Error correction

- Correct the values
- Restart the program


Error description 60C-0013

Error message

Tool %2 doesn't match the machining operation

Cause of error

The cycle cannot be run with the entered values.

Error correction

- Correct the values
- Restart the program


Error description 60C-0014

Error message

No head diameter and no module indicated

Cause of error

The cycle cannot be run with the entered values.

Error correction

- Correct the values
- Restart the program


Error description 60C-0015

Error message

Tooth number of tool doesn't match gear wheel
Actual: %2 Nominal: %3

Cause of error

The cycle cannot be run with the entered values.

Error correction

- Correct the values
- Restart the program


Error description 60C-0016

Error message

Cannot calculate infeed depths

Cause of error

Automatic calculation of the infeed depths and feed rates is not possible.

Error correction

Vary the number of cuts or set the value to 0 (automatic calculation of the number of cuts)


Error description 60F-0033

Error message

Finished part no longer located within
current workpiece.
%1

Cause of error

An area of the finished part, e.g. an end point, lies outside of the defined workpiece blank.
This note has no effect on the program run.


Error description 612-0001

Error message

System warning: %1

Cause of error

System warning. A recoverable internal error has occurred. The process will NOT be canceled.


Error description 612-0002

Error message

System error: %1

Cause of error

A fatal error has occurred. The process will be canceled.


Error description 620-004D

Error message

Tool ID %1 not found

Cause of error

A tool not included in the tool table has been entered in the turret or magazine assignment.

Error correction

Remove the tool from the turret/magazine assignment, or add the tool to the tool table.


Error description 620-00C9

Error message

Tool not found (%1)

Cause of error

A tool not included in the tool table has been entered in the turret or magazine assignment.

Error correction

Remove the tool from the turret/magazine assignment, or add the tool to the tool table.


Error description 621-003F

Error message

Helix diameter is greater than twice the cutter diameter
%1

Cause of error

With the selected cutter diameter, material remains standing in the middle of the plunging helix.

Error correction

Program a smaller “Diameter of helix”


Error description 621-0040

Error message

Pilot holes were calculated for a different contour
%1

Cause of error

For the calculation of the pilot hole positions, a different contour was programmed than the one in the current milling cycle.

Error correction

Change the position marker of the pilot holes or exchange the contour to be machined


Error description 621-0041

Error message

Pilot holes were calculated for a different trochoid width
%1

Cause of error

For the calculation of the pilot hole positions, a different
trochoid width was programmed than the one in the current milling cycle.

Error correction

Correct the trochoid width.


Error description 621-0042

Error message

Pilot holes were calculated with a different oversize
%1

Cause of error

For the calculation of the pilot hole positions, a different
oversize was programmed than the one in the current milling cycle.

Error correction

Correct the oversize


Error description 621-0043

Error message

No corners for trochoidal milling present
%1

Cause of error

For slots and circular pockets, there are no corners to be milled trochoidally.

Error correction

Program the machining operation as “Complete” or “W/o corner machining”


Error description 621-0044

Error message

Pilot holes on the other side of the contour
%1

Cause of error

For the calculation of the pilot hole positions, a different
tool position was programmed than the one in the current milling cycle.

Error correction

Correct the tool position


Error description 621-0045

Error message

Tool diameter is too large
%1

Cause of error

The tool diameter must be smaller than the plunging length or the diameter of the helix.

Error correction

Use a suitable tool


Error description 621-0047

Error message

Cutter diameter must be less than the trochoid width
%1

Cause of error

With the current cutter diameter and the programmed trochoid width, no trochoidal paths can be calculated.

Error correction

Select a cutter with smaller diameter, or program a larger trochoid width


Error description 621-0048

Error message

Radius for return greater than half the trochoid width
%1

Cause of error

With the programmed radius, the path for return lies outside of the trochoidal path.

Error correction

Program a smaller radius for return or a larger trochoid width


Error description 621-0049

Error message

Trochoid width smaller than plunging helix radius
%1

Cause of error

The plunging paths lie partially outside of the trochoidal path.

Error correction

Program a smaller plunging helix or larger trochoid width


Error description 621-004A

Error message

Pilot holes not present
%1

Cause of error

No position markers were programmed under the specified position marker.

Error correction

Correct the position marker


Error description 621-004B

Error message

Depth of the pilot hole less than the milling depth
%1

Cause of error

The drilling depth must not be less than the milling depth.

Error correction

Correct the drilling or milling depth


Error description 621-004C

Error message

No trochoid width programmed
%1

Cause of error

Without a specified trochoid width, the cycle cannot calculate any paths.

Error correction

Program the trochoid width


Error description 621-004D

Error message

Programmed oversize too large
%1

Cause of error

The oversize is so large that inside machining
of the contour is no longer possible.

Error correction

Correct the oversize


Error description 621-004E

Error message

Programmed trochoid width too large
%1

Cause of error

The trochoid width must be less than the slot width or
rectangle width when the oversize values are taken into account.

Error correction

Correct the trochoid width.


Error description 659-004B

Error message

Internal software error / 3D graphics switched off

Cause of error

Internal software error in the 3D graphics. Other operating modes of the control are not affected by this.

Error correction

Restart the control


Error description 663-04EA

Error message

Error when loading a dialog: %1

Cause of error

The dialog box could not be opened because of a faulty or missing dialog description by the machine manufacturer.

Error correction

Inform your service agency
Inform your machine tool builder


Error description 900-0BB8

Error message

File '%1' not found

Cause of error

The given file path does not refer to a graphic file.

Error correction

Select another graphic file.


Error description 900-0BB9

Error message

Failed to send internal message

Cause of error

Error in the internal system communication.

Error correction

Inform your service agency.


Error description 900-0BBA

Error message

Unable to open configuration server queue

Cause of error

Error in the internal system communication.

Error correction

Inform your service agency.


Error description 900-0BBB

Error message

Unable to read configuration data '%1'

Cause of error

Error in the internal system communication.

Error correction

Inform your service agency.


Error description 900-0BBC

Error message

Configuration data '%1' could not be written

Cause of error

Error in the internal system communication.

Error correction

Inform your service agency.


Error description 900-0BBD

Error message

Internal error!

Cause of error

Internal GRED software error.

Error correction

Inform your service agency.


Error description 900-0BBE

Error message

Internal error: %1

Cause of error

Internal GRED software error.

Error correction

Inform your service agency.


Error description 900-0BBF

Error message

Invalid data in graphic file: %1

Cause of error

The existing data cannot be read as graphic data.

Error correction

- Correct/remove and save the corresponding data, or
- Delete the graphic file and make a new one


Error description 900-0BC0

Error message

No graphic file: %1

Cause of error

The specified file cannot be read as a graphic file.

Error correction

Select another graphic file.


Error description 900-0BC1

Error message

Missing object '%1'

Cause of error

Missing object in the selected graphic file.

Error correction

- Add the corresponding object and save, or
- Delete the graphic file and make a new one


Error description 900-0BC2

Error message

Object '%1' is incomplete

Cause of error

Missing object elements in the selected graphic file.

Error correction

- Correct the corresponding object and save, or
- Delete the graphic file and make a new one


Error description 900-0BC3

Error message

Object '%1' already exists

Cause of error

Displayed object already exists in the selected graphic file.

Error correction

- Remove the redundant object and save, or
- Delete the graphic file and make a new one


Error description 900-0BC4

Error message

Working plan '%1' is incomplete

Cause of error

Steps are still missing in the displayed working plan.

Error correction

- Add the missing work steps and save, or
- Remove all entries in the working plan


Error description 900-0BC5

Error message

Geometry object list is incomplete

Cause of error

More geometry objects are needed to fully describe the workpiece form.

Error correction

- Add the missing geometry objects and save, or
- Delete the graphic file and make a new one


Error description 900-0BC6

Error message

Redundant object '%1' present

Cause of error

A redundant object is in the selected graphic file and will no longer be used.

Error correction

Remove the redundant object manually and save:
- Remove the object in the graphic file and save the file, or
- Resave the loaded graphic file


Error description 900-0BC7

Error message

Environment variable '%1' not defined

Cause of error

Internal GRED NC program template error.

Error correction

Inform your service agency.


Error description 900-0BC8

Error message

Control structure variable '%1' not defined

Cause of error

Internal GRED NC program template error.

Error correction

Inform your service agency.


Error description 900-0BC9

Error message

Maximum nesting depth of control structures has been reached

Cause of error

Internal GRED NC program template error.

Error correction

Inform your service agency.


Error description 900-0BCA

Error message

Faulty composition of control structure

Cause of error

Internal GRED NC program template error.

Error correction

Inform your service agency.


Error description 900-0BCB

Error message

Unknown control structure '%1'

Cause of error

Internal GRED NC program template error.

Error correction

Inform your service agency.


Error description 900-0BCC

Error message

Invalid value '%1' in object '%2'

Cause of error

There is an incorrect attribute value in the current object.

Error correction

Use a text editor to check and correct the attribute value in the object and to save it again to the corresponding graphic file.


Error description 900-0BCD

Error message

Tool data incomplete: '%1'

Cause of error

Required data on the tool are missing.

Error correction

Add the required tool data to the workpiece table and save it.


Error description 900-0BCE

Error message

Error when opening the tool table '%1'

Cause of error

The corresponding tool table cannot be opened:
- Tool table is not missing in the given file path
- Tool table has an invalid format
- Tool table is inconsistent

Error correction

Inform your service agency.


Error description 900-0BCF

Error message

New parameters of input form '%1' inserted

Cause of error

Some required parameters are missing in the form.

Error correction

The system has already made the correction. Please check the result!


Error description 900-0BD0

Error message

Old parameters of input form '%1' removed

Cause of error

There are too many parameters in the current form.

Error correction

The system has already made the correction. Please check the result!


Error description 900-0BD1

Error message

Variable name '%1' already exists

Cause of error

Internal GRED NC program template error.

Error correction

Inform your service agency.


Error description 900-0BD2

Error message

Graphic file '%1' cannot be opened

Cause of error

An error occurred when the graphic file was opened.

Error correction

Ensure that the graphic file exists, that the given path is correct, and that the file is in a readable format.


Error description 900-0BD3

Error message

Graphic file '%1' is too large

Cause of error

The graphic file does not fit into the space provided.

Error correction

Ensure that the graphic file fulfills the required dimensions.


Error description 900-0BD4

Error message

Error when writing the tool data '%1'

Cause of error

The tool cannot be saved to the table.

Error correction

Check the corresponding tool data.


Error description 900-0BD5

Error message

Object '%1' is faulty

Cause of error

Incorrect object elements in the selected graphic file.

Error correction

Correct the corresponding object and save.


Error description 900-0BD6

Error message

Parameter '%1' not defined

Cause of error

The given parameter is not fully defined in the configuration.

Error correction

Complete the definition of the configuration and save.


Error description 900-0BD7

Error message

Environment variable '%1' not initialized

Cause of error

Internal GRED NC program template error.

Error correction

Inform your service agency.


Error description 900-0BD8

Error message

Error when reading the tool data '%1'

Cause of error

Required data on the tool are missing.

Error correction

Add the corresponding tool data.


Error description 900-0BD9

Error message

Configuration data are incomplete

Cause of error

The given references/information regarding configuration data are incomplete.

Error correction

Complete the configuration data.


Error description 900-0BDA

Error message

Parameter '%1' not allowed in this formula!

Cause of error

The input form lists an illegal parameter that cannot be evaluated.

Error correction

Remove the corresponding form parameter and replace it with another.


Error description 900-0BDB

Error message

Configuration object '%1' is faulty

Cause of error

Configuration object has incorrect or incomplete data.

Error correction

Correct the configuration object and save.


Error description 903-0001

Error message

Starting position of noncircular contour not in workpiece system

Cause of error

- Axis-value programming is active

Error correction

- Edit the program


Error description 903-0002

Error message

Polar starting position is programmed incrementally

Cause of error

The radius or angle of the polar-programmed starting position is programmed incrementally

Error correction

Edit the program or the cycle


Error description 903-0003

Error message

Starting position is programmed incrementally

Cause of error

Polar programmed starting position is programmed incrementally

Error correction

Edit the program or the cycle


Error description 903-0004

Error message

Relative programming of the reciprocation starting position is
not allowed

Cause of error

Starting position of the reciprocation is programmed in relative values

Error correction

Program the starting position with absolute values


Error description 903-0005

Error message

Absolute programming of the relief vector is not allowed

Cause of error

- Relief vector was programmed absolutely instead of incrementally

Error correction

- Program the relief vector incrementally


Error description 903-0006

Error message

Relative programming of the infeed starting position is
not allowed!

Cause of error

Starting position of the infeed is programmed in relative values

Error correction

Program the starting position with absolute values


Error description 903-0007

Error message

Programmed axis is not a grinding axis

Cause of error

Wrong axis selected for grinding

Error correction

Program a grinding axis


Error description 903-0008

Error message

Programmed value is not interpreted as a coordinate

Cause of error

Presumably a system error

Error correction

Inform your service agency


Error description 903-0009

Error message

Incremental programming of the starting position is not allowed

Cause of error

Starting position is programmed incrementally

Error correction

Program the starting position with absolute values


Error description 903-000A

Error message

Reciprocation over zero length is not allowed

Cause of error

Error correction

- Edit the program


Error description 905-2711

Error message

Pre-position [Ls]

Cause of error


Error description 905-2712

Error message

Thread type (0=ext. / 1=int.)

Cause of error


Error description 905-2713

Error message

Thread pitch

Cause of error


Error description 905-2714

Error message

Thread depth

Cause of error


Error description 905-2715

Error message

Amount of infeed

Cause of error


Error description 905-2716

Error message

Remaining cut division (0 = Yes)

Cause of error


Error description 905-2717

Error message

Number of dry runs

Cause of error


Error description 905-2718

Error message

Run-out length at end of thread

Cause of error


Error description 905-2719

Error message

Starting angle

Cause of error


Error description 905-271A

Error message

Rotational speed (rpm)

Cause of error


Error description 905-271B

Error message

Peripheral speed (m/min)

Cause of error


Error description 905-271C

Error message

Workpiece rotation speed (1/min)

Cause of error


Error description 905-271D

Error message

Taper angle (>0 = ascending)

Cause of error


Error description 905-271F

Error message

Stndrd thread (0=none, 1=ISO,..)

Cause of error


Error description 905-2720

Error message

Nominal diameter

Cause of error


Error description 905-2721

Error message

Thread 0=righthand,1=lefthand

Cause of error


Error description 905-2722

Error message

Return

Cause of error


Error description 905-2723

Error message

Run-in length

Cause of error


Error description 905-2724

Error message

Run-in speed

Cause of error


Error description 905-2725

Error message

Length of cut in depth

Cause of error


Error description 905-2726

Error message

Traversing speed

Cause of error


Error description 905-2727

Error message

Run-out length

Cause of error


Error description 905-2728

Error message

Speed on run-out

Cause of error


Error description 905-2729

Error message

Target position X

Cause of error


Error description 905-272A

Error message

Target position Z

Cause of error


Error description 905-272B

Error message

Reciprocation feed rate [F]

Cause of error


Error description 905-272C

Error message

Infeed rate [D]

Cause of error


Error description 905-272D

Error message

Number of spark-out strokes [H]

Cause of error


Error description 905-2737

Error message

Tool number (T0 - T9)

Cause of error


Error description 905-2738

Error message

Error number

Cause of error


Error description 905-2739

Error message

Error consequence

Cause of error


Error description 905-273A

Error message

Error level

Cause of error


Error description 905-273B

Error message

Wheel location

Cause of error


Error description 905-273C

Error message

Dresser location

Cause of error


Error description 905-273D

Error message

Wheel edge

Cause of error


Error description 905-273E

Error message

Place – Bit

Cause of error


Error description 905-273F

Error message

Type of machining

Cause of error


Error description 905-2740

Error message

Command number

Cause of error


Error description 905-2741

Error message

Dresser number

Cause of error


Error description 905-2742

Error message

Value 1

Cause of error


Error description 905-2743

Error message

Value 2

Cause of error


Error description 905-2744

Error message

Value 3

Cause of error


Error description 905-2745

Error message

Calibration

Cause of error


Error description 905-2746

Error message

Encoder

Cause of error


Error description 905-2747

Error message

Linear measurement

Cause of error


Error description 905-2748

Error message

Diameter

Cause of error


Error description 905-2749

Error message

Delete Z

Cause of error


Error description 905-274A

Error message

Delete X

Cause of error


Error description 905-274B

Error message

Define the wheel shape

Cause of error


Error description 905-274C

Error message

Teach in width

Cause of error


Error description 905-274D

Error message

Define the tool

Cause of error


Error description 905-274E

Error message

Continue

Cause of error


Error description 905-274F

Error message

Question mark

Cause of error


Error description 905-2750

Error message

Teach in Z

Cause of error


Error description 905-2751

Error message

Teach in X

Cause of error


Error description 905-2752

Error message

Delete the dresser

Cause of error


Error description 905-2753

Error message

Spindle dresser

Cause of error


Error description 905-2754

Error message

Dress plate

Cause of error


Error description 905-2755

Error message

Diamond dresser

Cause of error


Error description 905-2756

Error message

Dresser alignment

Cause of error


Error description 905-2757

Error message

Teach in dresser position

Cause of error


Error description 905-2758

Error message

New dresser

Cause of error


Error description 905-2759

Error message

V

Cause of error


Error description 905-275A

Error message

Transmission ratio

Cause of error


Error description 905-275B

Error message

Initialize

Cause of error


Error description 905-275C

Error message

Calculate

Cause of error


Error description 905-275D

Error message

Reload the data

Cause of error


Error description 905-275E

Error message

Settings

Cause of error


Error description 905-275F

Error message

Outer side

Cause of error


Error description 905-2760

Error message

Inner side

Cause of error


Error description 905-2761

Error message

Search criteria

Cause of error


Error description 905-2762

Error message

Confirm the data

Cause of error


Error description 905-2763

Error message

Next

Cause of error


Error description 905-2764

Error message

Previous

Cause of error


Error description 905-2765

Error message

Next identical

Cause of error


Error description 905-2766

Error message

Previous identical

Cause of error


Error description 905-2767

Error message

Tool information

Cause of error


Error description 905-2768

Error message

Internal grinding

Cause of error


Error description 905-2769

Error message

External grinding

Cause of error


Error description 905-276A

Error message

General wheel data

Cause of error


Error description 905-276B

Error message

Face plate

Cause of error


Error description 905-276C

Error message

Angular wheel

Cause of error


Error description 905-276D

Error message

Straight wheel

Cause of error


Error description 905-276E

Error message

End ?

Cause of error


Error description 905-276F

Error message

Starting position X

Cause of error


Error description 905-2770

Error message

Starting position Z

Cause of error


Error description 905-2771

Error message

End position X

Cause of error


Error description 905-2772

Error message

End position Z

Cause of error


Error description 905-2773

Error message

X value for swing position 1

Cause of error


Error description 905-2774

Error message

Z value for swing position 1

Cause of error


Error description 905-2775

Error message

X value for swing position 2

Cause of error


Error description 905-2776

Error message

Z value for swing position 2

Cause of error


Error description 905-2777

Error message

Reciprocation feed rate [F1]

Cause of error


Error description 905-2778

Error message

Reciprocation feed rate [F2]

Cause of error


Error description 905-2779

Error message

Infeed rate [F]

Cause of error


Error description 905-277A

Error message

Amount of infeed [D]

Cause of error


Error description 905-277B

Error message

Search path of the probe

Cause of error


Error description 905-277C

Error message

Offset [L]

Cause of error


Error description 905-277D

Error message

Dwell time [H]

Cause of error


Error description 905-277E

Error message

Dwell time [H] at swing pos. 1

Cause of error


Error description 905-277F

Error message

Dwell time [H2] at swing pos. 2

Cause of error


Error description 905-2780

Error message

Number of spark-out strokes [N]

Cause of error


Error description 905-2781

Error message

Selection of override switch [O]

Cause of error


Error description 905-2782

Error message

Retraction amount [A]

Cause of error


Error description 905-2783

Error message

Absolute (=0) or relative (=1)

Cause of error


Error description 905-2784

Error message

Referenced to axis 1=yes, 0=no

Cause of error


Error description 905-2785

Error message

Infeed in pos. 1, 2 or both

Cause of error


Error description 905-2786

Error message

Faulty behavior with undersize

Cause of error


Error description 905-2787

Error message

Faulty behavior with oversize

Cause of error


Error description 905-2788

Error message

Shift of end position [K]

Cause of error


Error description 905-2789

Error message

Sensor already active at start

Cause of error


Error description 905-278A

Error message

Sensor has not responded

Cause of error


Error description 905-278B

Error message

Probe already active at start

Cause of error


Error description 905-278C

Error message

Probe has not responded

Cause of error


Error description 905-278D

Error message

Type of status information 0-4

Cause of error


Error description 905-278E

Error message

Type of movement 0-2

Cause of error


Error description 905-278F

Error message

Mode of execution 0-1

Cause of error


Error description 905-2790

Error message

Type of movement 0-8

Cause of error


Error description 905-2791

Error message

Type of movement 0-3

Cause of error


Error description 905-2792

Error message

Type of event

Cause of error


Error description 905-2793

Error message

Type of reaction

Cause of error


Error description 905-2794

Error message

Signal for OK

Cause of error


Error description 905-2795

Error message

Reaction in event test 1

Cause of error


Error description 905-2796

Error message

Reaction in event test 2

Cause of error


Error description 905-2797

Error message

Reaction in event test 3

Cause of error


Error description 905-2798

Error message

Dressing amount [D]

Cause of error


Error description 905-2799

Error message

Dressing feed rate [F]

Cause of error


Error description 905-279A

Error message

Number of repetitions [E]

Cause of error


Error description 905-279B

Error message

Number of idle strokes [H]

Cause of error


Error description 905-279C

Error message

Angle of infeed [Q]

Cause of error


Error description 905-279D

Error message

Dressing after number of pcs.

Cause of error


Error description 905-279E

Error message

Diamond number for outer side

Cause of error


Error description 905-279F

Error message

Diamond number for inner side

Cause of error


Error description 905-27A0

Error message

Type of dressing

Cause of error


Error description 905-27A1

Error message

Dressing strategy

Cause of error


Error description 905-27A2

Error message

Removal at diameter

Cause of error


Error description 905-27A3

Error message

Removal at outer edge

Cause of error


Error description 905-27A4

Error message

Removal at inner edge

Cause of error


Error description 905-27A5

Error message

Valve number

Cause of error


Error description 905-27A6

Error message

Operation code

Cause of error


Error description 905-27A7

Error message

Type of offset 0=X,1=Z,2=X/Z

Cause of error


Error description 905-27A8

Error message

Retraction type (0=X,1=Z,2=X/Z)

Cause of error


Error description 905-27A9

Error message

Infeed direction: X component

Cause of error


Error description 905-27AA

Error message

Infeed direction: Z component

Cause of error


Error description 905-27AB

Error message

Retractn amnt intermed. dressing

Cause of error


Error description 905-27AC

Error message

Retraction: X component

Cause of error


Error description 905-27AD

Error message

Retraction: Z component

Cause of error


Error description 905-27AE

Error message

Retractn. in X (incl. direction)

Cause of error


Error description 905-27AF

Error message

Retractn. in Z (incl. direction)

Cause of error


Error description 905-27B0

Error message

Retraction speed (0=FMAX)

Cause of error


Error description 905-27B1

Error message

Sensor active

Cause of error


Error description 905-27B2

Error message

Dimensional control active

Cause of error


Error description 905-27B3

Error message

Dimensional control valve

Cause of error


Error description 905-27B4

Error message

Initiate interm. dressing drctly

Cause of error


Error description 905-27B5

Error message

Start the reciprocation

Cause of error


Error description 905-27B6

Error message

Start preset for X

Cause of error


Error description 905-27B7

Error message

Activation of C axis

Cause of error


Error description 905-27B8

Error message

Start preset for Y

Cause of error


Error description 905-27B9

Error message

End position

Cause of error


Error description 905-27BA

Error message

Start preset for Z

Cause of error


Error description 905-27BB

Error message

Feed rate for positioning in C

Cause of error


Error description 905-27BC

Error message

Start preset for R (radius)

Cause of error


Error description 905-27BD

Error message

Start preset for H (angle)

Cause of error


Error description 905-27BE

Error message

Start preset for B

Cause of error


Error description 905-27BF

Error message

Start preset for C

Cause of error


Error description 905-27C0

Error message

Start preset for C

Cause of error


Error description 905-27C1

Error message

Tool compensation

Cause of error


Error description 905-27C2

Error message

Number of revolutions

Cause of error


Error description 905-27C3

Error message

Restart noncylindrical movemnt.

Cause of error


Error description 905-27C4

Error message

Stop of noncylindrical movemnt.

Cause of error


Error description 905-27C5

Error message

Do not approach with meas. sys.

Cause of error


Error description 905-27C6

Error message

Diameter Q400

Cause of error


Error description 905-27C7

Error message

Width Q401

Cause of error


Error description 905-27C8

Error message

Overhang Q402

Cause of error


Error description 905-27C9

Error message

Depth Q403

Cause of error


Error description 905-27CA

Error message

Angle Q404

Cause of error


Error description 905-27CB

Error message

Angle Q405

Cause of error


Error description 905-27CC

Error message

Radius Q406

Cause of error


Error description 905-27CD

Error message

Radius Q407

Cause of error


Error description 905-27CE

Error message

Radius Q408

Cause of error


Error description 905-27CF

Error message

Minimum diameter

Cause of error


Error description 905-27D0

Error message

Minimum width

Cause of error


Error description 905-27D1

Error message

Wheel type

Cause of error


Error description 905-27D2

Error message

Type of machining

Cause of error


Error description 905-27D3

Error message

Tool number

Cause of error


Error description 905-27D4

Error message

Angle Q414

Cause of error


Error description 905-27D5

Error message

Cutting speed

Cause of error


Error description 905-27D6

Error message

Location number

Cause of error


Error description 905-27D7

Error message

Maximum diameter

Cause of error


Error description 905-27D8

Error message

Minimum diameter

Cause of error


Error description 905-27D9

Error message

Maximum width

Cause of error


Error description 905-27DA

Error message

Minimum width

Cause of error


Error description 905-27DB

Error message

Chamfer width Q421

Cause of error


Error description 905-27DC

Error message

Chamfer angle Q422

Cause of error


Error description 905-27DD

Error message

Corner radius Q423

Cause of error


Error description 905-27DE

Error message

Side length Q424

Cause of error


Error description 905-27DF

Error message

Angle of relief Q425

Cause of error


Error description 905-27E0

Error message

Depth of relief Q426

Cause of error


Error description 905-27E1

Error message

Length of recess Q427

Cause of error


Error description 905-27E2

Error message

Angle of departure Q428

Cause of error


Error description 905-27E3

Error message

Total depth Q429

Cause of error


Error description 905-27E4

Error message

Safety clearance X

Cause of error


Error description 905-27E5

Error message

Safety clearance Z

Cause of error


Error description 905-27E6

Error message

Safety clearance Z

Cause of error


Error description 905-27E7

Error message

X edge Q433

Cause of error


Error description 905-27E8

Error message

Minimum (V)

Cause of error


Error description 905-27E9

Error message

Maximum (V)

Cause of error


Error description 905-27EA

Error message

Motor pulley

Cause of error


Error description 905-27EB

Error message

Wheel pulley

Cause of error


Error description 905-27EC

Error message

Radius Q438

Cause of error


Error description 905-27ED

Error message

Length Q439

Cause of error


Error description 905-27EE

Error message

Length Q440

Cause of error


Error description 905-27EF

Error message

Location number Q441

Cause of error


Error description 905-27F0

Error message

Logic location Q442

Cause of error


Error description 905-27F1

Error message

Alignment Q443

Cause of error


Error description 905-27F2

Error message

Type of dresser Q444

Cause of error


Error description 905-27F3

Error message

Actual position X Q445

Cause of error


Error description 905-27F4

Error message

Actual position Z Q446

Cause of error


Error description 905-27F5

Error message

Rotational speed Q447

Cause of error


Error description 905-27F6

Error message

Width Q448

Cause of error


Error description 905-27F7

Error message

Compensation Q449

Cause of error


Error description 905-27F8

Error message

Nominal position X Q450

Cause of error


Error description 905-27F9

Error message

Nominal position Z Q451

Cause of error


Error description 905-27FA

Error message

Tool type (select by soft key)

Cause of error


Error description 905-27FB

Error message

Radius Q453

Cause of error


Error description 905-27FC

Error message

Length Q454

Cause of error


Error description 905-27FD

Error message

Length Q455

Cause of error


Error description 905-27FE

Error message

Diameter X Q456

Cause of error


Error description 905-27FF

Error message

Length Z Q457

Cause of error


Error description 905-2800

Error message

Actual position X Q458

Cause of error


Error description 905-2801

Error message

Actual position Z Q459

Cause of error


Error description 905-2802

Error message

Select the edge Q460

Cause of error


Error description 905-2803

Error message

Select the wheel shape Q461

Cause of error


Error description 905-2804

Error message

Position X Q462

Cause of error


Error description 905-2805

Error message

Position Z Q463

Cause of error


Error description 905-2806

Error message

Number (1...4) of position Q464

Cause of error


Error description 905-2807

Error message

Number of safety positions Q465

Cause of error


Error description 905-2808

Error message

Datum shift X Q466

Cause of error


Error description 905-2809

Error message

Datum shift Z Q467

Cause of error


Error description 905-280A

Error message

Select the preset Q468

Cause of error


Error description 905-280B

Error message

Delete entry or status

Cause of error


Error description 905-280C

Error message

Measured value in axis system

Cause of error


Error description 905-280D

Error message

Axis

Cause of error


Error description 905-280E

Error message

Axis number

Cause of error


Error description 905-280F

Error message

Parameter block

Cause of error


Error description 905-2810

Error message

Probe input X12 or X13

Cause of error


Error description 905-2811

Error message

Name of noncylindrical program

Cause of error


Error description 905-2812

Error message

Name of wheel

Cause of error


Error description 905-2813

Error message

Tolerance value 1?

Cause of error


Error description 905-2814

Error message

Tolerance value 2?

Cause of error


Error description 905-2815

Error message

Feed rate limit?

Cause of error


Error description 905-2816

Error message

Ls

Cause of error


Error description 905-2817

Error message

I

Cause of error


Error description 905-2818

Error message

P

Cause of error


Error description 905-2819

Error message

T

Cause of error


Error description 905-281A

Error message

D

Cause of error


Error description 905-281B

Error message

B

Cause of error


Error description 905-281C

Error message

H

Cause of error


Error description 905-281D

Error message

K

Cause of error


Error description 905-281E

Error message

C

Cause of error


Error description 905-281F

Error message

S

Cause of error


Error description 905-2820

Error message

V

Cause of error


Error description 905-2821

Error message

S

Cause of error


Error description 905-2822

Error message

W

Cause of error


Error description 905-2823

Error message

L

Cause of error


Error description 905-2824

Error message

Q

Cause of error


Error description 905-2825

Error message

X

Cause of error


Error description 905-2826

Error message

R

Cause of error


Error description 905-2827

Error message

A

Cause of error


Error description 905-2828

Error message

E

Cause of error


Error description 905-2829

Error message

Ve

Cause of error


Error description 905-282A

Error message

M

Cause of error


Error description 905-282B

Error message

Vm

Cause of error


Error description 905-282C

Error message

K

Cause of error


Error description 905-282D

Error message

Vk

Cause of error


Error description 905-282E

Error message

X

Cause of error


Error description 905-282F

Error message

Z

Cause of error


Error description 905-2830

Error message

F

Cause of error


Error description 905-2831

Error message

D

Cause of error


Error description 905-2832

Error message

H

Cause of error


Error description 905-2833

Error message

Tool number

Cause of error


Error description 905-2834

Error message

Error number

Cause of error


Error description 905-2835

Error message

Error consequence

Cause of error


Error description 905-2836

Error message

Error level

Cause of error


Error description 905-2837

Error message

W_PL

Cause of error


Error description 905-2838

Error message

D_PL

Cause of error


Error description 905-2839

Error message

E

Cause of error


Error description 905-283A

Error message

B

Cause of error


Error description 905-283B

Error message

E

Cause of error


Error description 905-283C

Error message

NR

Cause of error


Error description 905-283D

Error message

D_Nr

Cause of error


Error description 905-283E

Error message

D1

Cause of error


Error description 905-283F

Error message

D2

Cause of error


Error description 905-2840

Error message

D3

Cause of error


Error description 905-2841

Error message

K

Cause of error


Error description 905-2842

Error message

Q

Cause of error


Error description 905-2843

Error message

L

Cause of error


Error description 905-2844

Error message

D

Cause of error


Error description 905-2845

Error message

Delete Z

Cause of error


Error description 905-2846

Error message

Delete X

Cause of error


Error description 905-2848

Error message

Teach in width

Cause of error


Error description 905-2849

Error message

Define the tool

Cause of error


Error description 905-284A

Error message

Continue

Cause of error


Error description 905-284F

Error message

Spindle dresser

Cause of error


Error description 905-2850

Error message

Dress plate

Cause of error


Error description 905-2851

Error message

Diamond dresser

Cause of error


Error description 905-2852

Error message

Alignment

Cause of error


Error description 905-2853

Error message

Teach in dresser pos

Cause of error


Error description 905-2854

Error message

New dresser

Cause of error


Error description 905-2856

Error message

Ratio

Cause of error


Error description 905-2859

Error message

Reload the data

Cause of error


Error description 905-285D

Error message

Search criteria

Cause of error


Error description 905-285E

Error message

Confirm the data

Cause of error


Error description 905-2861

Error message

Next identical

Cause of error


Error description 905-2862

Error message

Previous identical

Cause of error


Error description 905-2863

Error message

Tool information

Cause of error


Error description 905-2864

Error message

Internal grinding

Cause of error


Error description 905-2865

Error message

External grinding

Cause of error


Error description 905-2866

Error message

General wheel data

Cause of error


Error description 905-2867

Error message

Face plate

Cause of error


Error description 905-2868

Error message

Angular wheel

Cause of error


Error description 905-2869

Error message

Straight wheel

Cause of error


Error description 905-286A

Error message

End

Cause of error


Error description 905-286B

Error message

X

Cause of error


Error description 905-286C

Error message

Z

Cause of error


Error description 905-286D

Error message

X

Cause of error


Error description 905-286E

Error message

Z

Cause of error


Error description 905-286F

Error message

X

Cause of error


Error description 905-2870

Error message

Z

Cause of error


Error description 905-2871

Error message

X

Cause of error


Error description 905-2872

Error message

Z

Cause of error


Error description 905-2873

Error message

F1

Cause of error


Error description 905-2874

Error message

F2

Cause of error


Error description 905-2875

Error message

F

Cause of error


Error description 905-2876

Error message

D

Cause of error


Error description 905-2877

Error message

Search path

Cause of error


Error description 905-2879

Error message

H

Cause of error


Error description 905-287A

Error message

H1

Cause of error


Error description 905-287B

Error message

H2

Cause of error


Error description 905-287C

Error message

N

Cause of error


Error description 905-287D

Error message

O

Cause of error


Error description 905-287E

Error message

A

Cause of error


Error description 905-287F

Error message

I

Cause of error


Error description 905-2880

Error message

M91

Cause of error


Error description 905-2881

Error message

E

Cause of error


Error description 905-2882

Error message

ER1

Cause of error


Error description 905-2883

Error message

ER2

Cause of error


Error description 905-2884

Error message

K

Cause of error


Error description 905-2885

Error message

ER3

Cause of error


Error description 905-2886

Error message

ER4

Cause of error


Error description 905-2887

Error message

ER5

Cause of error


Error description 905-2888

Error message

ER6

Cause of error


Error description 905-2889

Error message

E

Cause of error


Error description 905-288A

Error message

E

Cause of error


Error description 905-288B

Error message

S

Cause of error


Error description 905-288C

Error message

E

Cause of error


Error description 905-288D

Error message

K

Cause of error


Error description 905-288E

Error message

E

Cause of error


Error description 905-288F

Error message

R

Cause of error


Error description 905-2890

Error message

S

Cause of error


Error description 905-2891

Error message

R1

Cause of error


Error description 905-2892

Error message

R2

Cause of error


Error description 905-2893

Error message

R3

Cause of error


Error description 905-2894

Error message

D

Cause of error


Error description 905-2895

Error message

F

Cause of error


Error description 905-2896

Error message

E

Cause of error


Error description 905-2897

Error message

H

Cause of error


Error description 905-2898

Error message

Q

Cause of error


Error description 905-2899

Error message

N

Cause of error


Error description 905-289A

Error message

Diamond no. outside

Cause of error


Error description 905-289B

Error message

Diamond no. inside

Cause of error


Error description 905-289C

Error message

Type of dressing

Cause of error


Error description 905-289D

Error message

Dressing strategy

Cause of error


Error description 905-289E

Error message

D

Cause of error


Error description 905-289F

Error message

O

Cause of error


Error description 905-28A0

Error message

I

Cause of error


Error description 905-28A1

Error message

V

Cause of error


Error description 905-28A2

Error message

C

Cause of error


Error description 905-28A3

Error message

RL

Cause of error


Error description 905-28A4

Error message

RA

Cause of error


Error description 905-28A5

Error message

dX

Cause of error


Error description 905-28A6

Error message

dZ

Cause of error


Error description 905-28A7

Error message

AZ

Cause of error


Error description 905-28A8

Error message

dXA

Cause of error


Error description 905-28A9

Error message

dZA

Cause of error


Error description 905-28AA

Error message

AX

Cause of error


Error description 905-28AB

Error message

AZ

Cause of error


Error description 905-28AC

Error message

FA

Cause of error


Error description 905-28AD

Error message

SA

Cause of error


Error description 905-28AE

Error message

MA

Cause of error


Error description 905-28AF

Error message

MV

Cause of error


Error description 905-28B0

Error message

D_OK

Cause of error


Error description 905-28B1

Error message

P

Cause of error


Error description 905-28B2

Error message

X

Cause of error


Error description 905-28B3

Error message

E

Cause of error


Error description 905-28B4

Error message

Y

Cause of error


Error description 905-28B5

Error message

C

Cause of error


Error description 905-28B6

Error message

Z

Cause of error


Error description 905-28B7

Error message

F

Cause of error


Error description 905-28B8

Error message

R

Cause of error


Error description 905-28B9

Error message

H

Cause of error


Error description 905-28BA

Error message

B

Cause of error


Error description 905-28BB

Error message

C

Cause of error


Error description 905-28BC

Error message

C

Cause of error


Error description 905-28BD

Error message

COR

Cause of error


Error description 905-28BE

Error message

COUNT

Cause of error


Error description 905-28BF

Error message

RESET

Cause of error


Error description 905-28C0

Error message

STOPP

Cause of error


Error description 905-28C1

Error message

U

Cause of error


Error description 905-28C2

Error message

Diameter

Cause of error


Error description 905-28C3

Error message

Width of wheel

Cause of error


Error description 905-28C4

Error message

Overhang

Cause of error


Error description 905-28C5

Error message

Depth of wheel

Cause of error


Error description 905-28C6

Error message

Wheel tilt angle

Cause of error


Error description 905-28C7

Error message

Corner angle

Cause of error


Error description 905-28C8

Error message

Corner radius RV

Cause of error


Error description 905-28C9

Error message

Corner radius RV1

Cause of error


Error description 905-28CA

Error message

Corner radius RV2

Cause of error


Error description 905-28CB

Error message

Minimum diameter

Cause of error


Error description 905-28CC

Error message

Minimum width

Cause of error


Error description 905-28CD

Error message

Straight,angul.,flat

Cause of error


Error description 905-28CE

Error message

External / Internal

Cause of error


Error description 905-28D0

Error message

Offset B axis

Cause of error


Error description 905-28D1

Error message

Cutting speed

Cause of error


Error description 905-28D2

Error message

Location no. (0..99)

Cause of error


Error description 905-28D3

Error message

Upper limit diameter

Cause of error


Error description 905-28D4

Error message

Lower limit diameter

Cause of error


Error description 905-28D5

Error message

Upper limit width

Cause of error


Error description 905-28D6

Error message

Lower limit width

Cause of error


Error description 905-28D7

Error message

Width

Cause of error


Error description 905-28D8

Error message

Angle

Cause of error


Error description 905-28D9

Error message

Radius

Cause of error


Error description 905-28DA

Error message

Side length

Cause of error


Error description 905-28DB

Error message

Angle

Cause of error


Error description 905-28DC

Error message

Depth

Cause of error


Error description 905-28DD

Error message

Length

Cause of error


Error description 905-28DE

Error message

Radius

Cause of error


Error description 905-28DF

Error message

Depth

Cause of error


Error description 905-28E0

Error message

Diameter

Cause of error


Error description 905-28E1

Error message

Outer side

Cause of error


Error description 905-28E2

Error message

Inner side

Cause of error


Error description 905-28E3

Error message

Edge selection

Cause of error


Error description 905-28E4

Error message

Cutting speed

Cause of error


Error description 905-28E5

Error message

Cutting speed

Cause of error


Error description 905-28E6

Error message

Diameter

Cause of error


Error description 905-28E7

Error message

Diameter

Cause of error


Error description 905-28E8

Error message

Diamond radius

Cause of error


Error description 905-28E9

Error message

Length L1

Cause of error


Error description 905-28EA

Error message

Length L2

Cause of error


Error description 905-28EB

Error message

Dresser location

Cause of error


Error description 905-28EC

Error message

Dresser location

Cause of error


Error description 905-28ED

Error message

Alignment

Cause of error


Error description 905-28EE

Error message

Type of dresser

Cause of error


Error description 905-28EF

Error message

Dresser position

Cause of error


Error description 905-28F0

Error message

Dresser position

Cause of error


Error description 905-28F1

Error message

Dressing spindle

Cause of error


Error description 905-28F2

Error message

Width of dress plate

Cause of error


Error description 905-28F3

Error message

Type of compensation

Cause of error


Error description 905-28F4

Error message

Dresser position

Cause of error


Error description 905-28F5

Error message

Dresser position

Cause of error


Error description 905-28F6

Error message

Tool type

Cause of error


Error description 905-28F7

Error message

Probe-tip radius

Cause of error


Error description 905-28F8

Error message

Length L1

Cause of error


Error description 905-28F9

Error message

Length L2

Cause of error


Error description 905-28FA

Error message

Calibration

Cause of error


Error description 905-28FF

Error message

Wheel shape

Cause of error


Error description 905-2903

Error message

Safety position.

Cause of error


Error description 905-2905

Error message

Datum shift

Cause of error


Error description 905-2906

Error message

Calibration

Cause of error


Error description 905-2907

Error message

E

Cause of error


Error description 905-2908

Error message

Axis system

Cause of error


Error description 905-2909

Error message

Radius

Cause of error


Error description 905-290A

Error message

A

Cause of error


Error description 905-290B

Error message

Axis

Cause of error


Error description 905-290C

Error message

P

Cause of error


Error description 905-290D

Error message

Probe input

Cause of error


Error description 905-290E

Error message

PGM_NAME

Cause of error


Error description 905-290F

Error message

Wheel name

Cause of error


Error description 905-2910

Error message

TOLERANCE 1

Cause of error


Error description 905-2911

Error message

TOLERANCE 2

Cause of error


Error description 905-2912

Error message

Feed rate limit

Cause of error


Error description 905-2913

Error message

Wheel data

Cause of error


Error description 905-2914

Error message

Wheel data

Cause of error


Error description 905-2915

Error message

Wheel data

Cause of error


Error description 905-2916

Error message

Wheel data

Cause of error


Error description 905-2917

Error message

Outside

Cause of error


Error description 905-2918

Error message

Inside

Cause of error


Error description 905-2919

Error message

Settings

Cause of error


Error description 905-291A

Error message

Cutting speed

Cause of error


Error description 905-291B

Error message

Cutting speed

Cause of error


Error description 905-291C

Error message

Ratio

Cause of error


Error description 905-291D

Error message

Insertion location 0

Cause of error


Error description 905-291E

Error message

Insertion location 1

Cause of error


Error description 905-291F

Error message

Insertion location 2

Cause of error


Error description 905-2920

Error message

Insertion location 3

Cause of error


Error description 905-2921

Error message

Insertion location 4

Cause of error


Error description 905-2922

Error message

Insertion location 5

Cause of error


Error description 905-2923

Error message

Insertion location 6

Cause of error


Error description 905-2924

Error message

Insertion location 7

Cause of error


Error description 905-2925

Error message

Insertion location 8

Cause of error


Error description 905-2926

Error message

Insertion location 9

Cause of error


Error description 905-2927

Error message

Wheel data

Cause of error


Error description 905-2928

Error message

Cutter data

Cause of error


Error description 905-2929

Error message

Dresser data

Cause of error


Error description 905-292A

Error message

Probe data

Cause of error


Error description 905-292B

Error message

Drill data

Cause of error


Error description 905-292C

Error message

Search criteria

Cause of error


Error description 905-292D

Error message

Probe

Cause of error


Error description 905-292E

Error message

New dresser

Cause of error


Error description 905-292F

Error message

Define dresser

Cause of error


Error description 905-2930

Error message

Define dresser

Cause of error


Error description 905-2931

Error message

Define dresser

Cause of error


Error description 905-2932

Error message

Define alignment

Cause of error


Error description 905-2933

Error message

Dresser position

Cause of error


Error description 905-2934

Error message

Dresser position

Cause of error


Error description 905-2935

Error message

Calibration: Select

Cause of error


Error description 905-2936

Error message

Teach in positions

Cause of error


Error description 905-2937

Error message

Teach in width

Cause of error


Error description 905-2938

Error message

Wheel form

Cause of error


Error description 905-2939

Error message

Wrkpc. datum shift

Cause of error


Error description 905-293A

Error message

Wheel datum shift

Cause of error


Error description 905-293B

Error message

Safety position

Cause of error


Error description 905-293C

Error message

No. of safety pos.

Cause of error


Error description 905-293D

Error message

T command

Cause of error


Error description 905-293E

Error message

Q command

Cause of error


Error description 905-2940

Error message

Thread grinding

Cause of error


Error description 905-2941

Error message

Thread plunging

Cause of error


Error description 905-2942

Error message

Thread oscillation

Cause of error


Error description 905-2943

Error message

C axis

Cause of error


Error description 905-2944

Error message

Start of grinding

Cause of error


Error description 905-2945

Error message

End of grinding

Cause of error


Error description 905-2946

Error message

Reciprocation config

Cause of error


Error description 905-2947

Error message

Recipr.para. config.

Cause of error


Error description 905-2948

Error message

Start pos. infeed

Cause of error


Error description 905-2949

Error message

Asynchronous infeed

Cause of error


Error description 905-294A

Error message

Synchronous infeed

Cause of error


Error description 905-294B

Error message

General infeed

Cause of error


Error description 905-294C

Error message

Infeed meas.sys.asyn

Cause of error


Error description 905-294D

Error message

Infeed meas.sys.sync

Cause of error


Error description 905-294E

Error message

Probe infeed

Cause of error


Error description 905-294F

Error message

Infeed gap control

Cause of error


Error description 905-2950

Error message

Infeed probe

Cause of error


Error description 905-2951

Error message

General dressing

Cause of error


Error description 905-2952

Error message

Intermed. dressing

Cause of error


Error description 905-2953

Error message

Load contour program

Cause of error


Error description 905-2954

Error message

Start of contour pgm

Cause of error


Error description 905-2955

Error message

End of contour pgm

Cause of error


Error description 905-2956

Error message

Start of contour pgm

Cause of error


Error description 905-2957

Error message

Contour program stop

Cause of error


Error description 905-2958

Error message

Asynchr. infeed def.

Cause of error


Error description 905-2959

Error message

Synchr. infeed def.

Cause of error


Error description 905-295A

Error message

General infeed def.

Cause of error


Error description 905-295B

Error message

Override assignment

Cause of error


Error description 905-295C

Error message

Start of grinding

Cause of error


Error description 905-295D

Error message

Grinding stop

Cause of error


Error description 905-295E

Error message

Grinding status

Cause of error


Error description 905-295F

Error message

Wait f. grinding end

Cause of error


Error description 905-2960

Error message

Activate event

Cause of error


Error description 905-2961

Error message

Deactivate event

Cause of error


Error description 905-2962

Error message

Check event

Cause of error


Error description 905-2963

Error message

Wheel data

Cause of error


Error description 905-2964

Error message

Wheel head

Cause of error


Error description 905-2965

Error message

Dresser data

Cause of error


Error description 905-2966

Error message

Calibration

Cause of error


Error description 905-2967

Error message

Safety position

Cause of error


Error description 905-2968

Error message

Wrkpc. datum shift

Cause of error


Error description 905-2969

Error message

Wheel datum shift

Cause of error


Error description 905-296A

Error message

T command

Cause of error


Error description 905-296B

Error message

Q command

Cause of error


Error description 905-296C

Error message

Wheel status

Cause of error


Error description 905-296D

Error message

Delete the dresser

Cause of error


Error description 905-296E

Error message

Select param. block

Cause of error


Error description 905-296F

Error message

Start dressing

Cause of error


Error description 905-2970

Error message

Reverse dressing

Cause of error


Error description 905-2971

Error message

Compensate wheel

Cause of error


Error description 905-2972

Error message

Reference system

Cause of error


Error description 905-2973

Error message

PLC command

Cause of error