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Information Contained in this 
Manual

This addendum covers the operating and setup feature additions and improvements implemented in IK 5000 Software v3.0.x - 
v3.4.x. For OEM setup feature additions refer to the IK 5000 QUADRA-CHEK OEM Addendum (ID 1041353-2x), available by 
request from HEIDENHAIN.

Minimum System Requirements

Backward Compatibility

The IK 5000 QUADRA-CHEK v3.4.x software version is compatible with several previous versions down to version 2.93.0. It 
can be used to update any prior version starting at version 2.93.0 and up. To update a previous version refer to “Software 
Updates” below.

Software Updates

End users should only update the IK 5000 software after consultation with the machine manufacturer. Observe the system 
requirements as described in “Minimum System Requirements” above. For software updating procedures, refer to " Updating 
the IK 5000 Software on page 100”.

Fonts Used in these Instructions

Items of special interest or concepts that are emphasized to the user are shown in bold type.

Software controls and Windows are shown in letter gothic bold type.

Component w/o 3D Profiling w/ 3D Profiling

PC 2.66 GHz dual-core Pentium 2.8 GHz quad-core Pentium

Operating System (OS) Windows Vista 32-bit

Windows 7 32-bit, Windows 7 64-bit

Windows 8 32-bit, Windows 8 64-bit

Windows 10 32-bit, Windows 10 64-bit

RAM 1GB 2GB

Available Hard Disk 500MB 1GB

PCI 1 PCI slot and 1 to 3 additional empty slots (depending on the version)

Video Display Unit 1024 x 768 resolution

Windows users rights for 
installation and setup

Administrator
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n 1.1   Operation

About IK 5000 window information

The About window provides information about the system. 

About window information includes:

 IK 5000 version number

Configured options

 Temporary license time remaining

 IK 5000 ID and serial number (displayed with PCIe boards only)

Axis board revision

DSP software version

 Software copyright

Website address

To open the About window:

 Click Help>About IK 5000...
The About window is displayed.

Click Help>About IK 
5000...

The About window is displayed.
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nAdjusting for Change of Part Size

The location of features in a part under measure can change due to 
change in size of the part. A program can adjust to measure the 
features at the new locations by using the Prompt user for part scaling 
function. This function prompts the user for a scaling factor that 
repositions all features in a program. The new feature position is 
calculated using the recorded feature position multiplied by the scaling 
factor. The scaling factor is prompted for each time the program is run.

The Prompt user for part scaling function is located in the General tab 
of the Program Properties dialog.

To prompt a user for part scaling:

 Start recording a program
 Double click Program Properties in the Program template window
 Click the General tab
 Check the check box next to Prompt user for part scaling and 

then click OK
The operator will now be prompted to enter a scaling factor when the 
program is run.

The size of the features under measure in the program are 
not altered by the part scaling function, hence the system 
will probe the features at the recorded size but new scaled 
position.

Selecting Prompt User for Part Scaling
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n Part Scaling Example

This example shows measurement results before and after part 
scaling has been applied.

 Start recording a program
 Measure a feature and note the position of the feature

 Stop recording the program
 Activate Prompt user for part scaling as described on page 11.
 Run the recorded program. A prompt will appear requiring the user 

to enter a part scaling factor for each axis.

 Re-measure the feature and complete program execution

Note that the program feature CIRCLE 2 will now be probed at a 
position scaled by a factor of 0.500 (X=4.00000), 0.500 (Y=2.50000), 
0.500 (Z=0.00000)

Feature measurement results

Enter Part Scaling prompt
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nAuto Probe a Plane

Plane measurement accuracy is increased by probing more than the 
three required points. IK 5000 systems with CNC and touch probe 
options can automatically probe multiple points by using the 
Auto Probe Plane feature in the Measure Plane Dialog.

To auto probe a plane:

 Click the Auto Probe... button in the Measure Plane dialog.The 
Auto Probe Plane dialog appears.

 Select the Grid or DISC tab
 Probe the required positions and enter the required parameters
 Click OK

Grid Pattern Auto Probe

Grid dialog Grid pattern

1

3

4

5

2

Parameter Description

1 Corner position 1 The first corner position in the grid

2 Corner position 2 The second corner position in the 
grid

3 Corner position 3 The third corner position in the grid

4 # Points on longer side The number of points on the longest 
side of the grid

5 # Points on shorter 
side

The number of points on the 
shortest side of the grid

Normal position A position above the plane for the 
probe to retract to after probing a 
point
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n Disc Pattern Auto Probe

Disc dialog Disc pattern

1

3

4

5

2

Parameter Description

1 Center position The center position of the disc pattern

2 Number of rings The number of rings in the pattern

3 # Points per ring The number of points probed per ring

4 Inner radius The radius of the inner ring of the pattern

5 Outer radius The radius of the outer ring of the pattern

Normal position A position above the plane for the probe 
to retract to after probing a point
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nProgramming Changes

While recording a program that is intended to include a looping 
function (such as a loop, grid, polar grid, or random placement), it is 
important to record the entire program with the looping function 
before completing the program and running or editing it. This ensures 
proper handling of any datum steps in the loop, if any, and proper 
insertion of offset recall tags.

When a feature is under measure during program playback, that 
feature is now removed from the feature list. Previously, the recorded 
feature was maintained in the feature list during measurement and 
replaced by the newly measured feature once the measurement was 
completed. 

Grids, polar grids, and random placements are described in 
Programming Wizards on page 16.

Tags are not displayed in the program.
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n Programming Wizards

Use programming wizards to create the following program steps:

Grids

 Polar grids

Random placements

Grids

Use the Create a Grid wizard to measure arrays or a series of like 
features within a single part. For example, create a grid to measure an 
array of evenly spaced holes on a pc board. The IK 5000 requires the 
user to input the X and Y offset distance, the X and Y distance from 
one feature to the next.

Before creating a grid begin a new part program with a datum.

To create a grid:

 Position the first array feature as shown

All features in a grid must be evenly spaced.
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n Click the center mouse button to fire the probe tool

 Click OK in the dialog box
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n  Highlight the first array feature in the Program template as shown

 Right-click in the Program template and select Programming Wizards, 
then select Create a Grid
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n Enter the number of features and type in the desired X and Y offsets 
as shown

 Click OK in the dialog box

The grid is created and the program is ready to run

 Click New Run to run the program

Items are the number of features in each axis direction. 
Offsets are the distance to the next feature relative from 
previous feature.
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n Polar Grids

A polar grid measures a part with like features that are in a rotational 
array. For example, create a polar grid to measure a bolt hole pattern. 
The programming wizard that creates a polar grid requires the user to 
input the number of features and the angle between the features.

Before creating a polar grid, create a new part program. Use the center 
of the polar grid features as the zero point of the part.

To create a polar grid:

 Position the first feature in the polar array in the center of the field 
of view as shown

All features in a polar grid must be evenly spaced.

Make certain the program is recording before completing 
the following steps.
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n Select Measure>Circle

 Click Enter Point in the Measure Circle dialog
 Click OK
 Select the measured Circle in the Program template
 Select Tools>Programming>Programming Wizards>Create a Polar 
Grid

 Enter the number of times to loop in the Times to Repeat field
 Enter the loop increment angle in the Angle Increment field
 Click OK

The polar grid is created and the program is ready to run.
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n Random placement

Use the Random Placement wizard for multiple parts on a stage 
without a fixture.

Before creating a random placement, create a new part program with 
reference steps.

Reference Steps

To insert reference steps in a part program:

 Click the Record/Edit button on the Program toolbar

 Position the desired reference feature as shown

All parts must have the same orientation on the stage and 
be square to the axes of the machine.

The reference feature is a repeatable point to help the 
IK 5000 locate the randomly placed parts.



IK 5000 QUADRA-CHEK 23

1
.1

 O
p

e
ra

ti
o

n Click the center mouse button to fire the probe tool

 Click OK in the dialog

The IK 5000 will use this feature to locate the randomly place parts.

Create a the rest of the part program measuring all the features of the 
part.

Save the reference frame in the part program immediately 
after creating the datum.
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n Random Placement

To create a random placement:

 Highlight the desired features, and the reference point as shown

 Right-click in the Program template and select Programming Wizards, 
then select Random Placement

Make certain the program is recording before completing 
the following steps.
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nThe IK 5000 inserts the required steps for the random placement.

To run a parts program with a random placement:

 Click the New Run button on the Program toolbar
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n  Measure the reference point for the first part

Repeat these steps until all parts are entered.

 Click OK in the dialog box

Click the Remove Last button to remove the last point 
enter. Reenter the point for that part.

Click the Use Last Run button to use the same offsets as 
the previous run.
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nAdding a Program Variable to a Template 

Header or Footer

A program variable can be added to a report template header or footer. 
When a variable is added to the template it will be included in the 
header or footer when the report is displayed and printed.

To add a variable to a report template:

 Open or record a program that includes a variable
 Right click inside the Program window and select 
Template Properties...

 Check the Show report header or Show report footer checkbox

 Right-click inside the header or footer area and select 
Add Program User Variable...

 Select the desired variable from the User Variable drop-down list 
and click OK

Select Template Properties... Check Show report header or Show report footer

Select Add Program User Variable... Select the desired variable
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n  Move the variable to the desired position in the header or footer

The program variable will be added to the header or footer when the 
report is printed.

Move the variable to the desired position
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nCopy and Paste Special

Before performing a copy and paste special, record a new part 
program with a datum.

To copy and paste special:

 Position the first array feature as shown

 Click the center mouse button to fire the probe tool
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n  Click OK in the dialog box

 Highlight the first array feature in the Program template as shown

 Right-click in the Program template and select Copy
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n Right-click in the Program template and select Paste Special

 Enter the number of Items and type the desired X and Y offsets as 
shown

Items are the number of features in each axis direction. 
Offsets are the distance to the next feature relative from 
previous feature.
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n  Click OK in the dialog box

The IK 5000 creates a grid on the part view and assigns a numbered 
feature name to each feature in the grid.
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nThe copied and pasted parts appears in the Part View window as 
shown.

The program is ready to run.
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n Palletizing Multiple Parts

A pallet is a rectangular arrangement of identical parts organized into 
a consistent matrix of columns and rows. The X and Y offsets between 
parts in the matrix must be the same for all parts.

Once a part program is created and tested for a single part, it can be 
run on each of the identical parts contained in a pallet. The IK 5000 will 
begin measuring parts at the lower-left corner of the pallet, and will 
proceed from left to right and from bottom to top.

To specify the palletizing mode:

 Double click Program Properties in the Program template. The 
Program Properties dialog is displayed.

 Select the Palletize tab. The pallet setup parameters will be 
displayed.

Pallet of 12 identical parts

Double click Program Properties in the 
Program template

Select the Palletize tab



IK 5000 QUADRA-CHEK 35

1
.1

 O
p

e
ra

ti
o

n Enter the Number of Columns and Number of Rows into the fields 
provided

 Enter the X Offset and Y Offset between parts into the fields 
provided

 When it is known that some pallets will not be full, the program can 
prompt the operator at the beginning of each run to specify the 
location of parts contained by the current pallet. Check the Prompt 
user for position of loaded pallet elements check box to 
prompt the operator.

 Click OK

New run of data

New data can be entered into the runs database for every pallet 
instead of appending the data to the previous pallet's data. 

To enter new data into the runs database:

 Check New run of data in the Program Properties window

 Click OK to save the changes and exit the Program Properties 
window

Enter pallet parameters and click OK

Check New run of data
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n Begin pallet

A Begin pallet step is inserted into the program when the palletize 
function is used.

Prompt user for position

When Prompt user for position of loaded pallet elements is 
enabled,  the system will prompt you to enable or disable elements 
that are available on the pallet when the program is played back.

Begin pallet step

Enable or disable elements on the pallet
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nProfile Import Points

Probed points from features can be imported into a profile 
measurement when recording a program. This eliminates the need to 
re-probe points for contours that make up features already measured 
in the same program.

To import points into a Profile measurement:

 Start recording a program
 Measure features into the program by probing them

 Start a Profile measurement
 Select the features whose data cloud will be imported into the 

measurement as probed points

All features whose points are used in the import process 
need to exist during program playback or the import 
function will fail.
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n  Click Import Pts

Points are imported into the Profile measurement.

 Click OK
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nMeasuring maximum inscribed and minimum 

superscribed tangent circles

The IK 5000 can measure maximum inscribed and minimum 
superscribed tangent circles. The circles can be measured by 
constructing a circle from a set of circles that are in a bolt-hole pattern.

To measure a maximum inscribed or minimum superscribed tangent 
circle:

 Measure a set of circles that are in a bolt-hole pattern

Measure a set of circles
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n  Construct a circle from the measured circles

 Right-click on the Results window
 Select Maximum Inscribed Tangent Circle or Minimum Superscribed 
Tangent Circle

Construct a circle

 Select Maximum Inscribed Tangent Circle or Minimum Superscribed Tangent Circle
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nA Maximum Inscribed Tangent Circle or Minimum Superscribed 
Tangent Circle will be measured.

Maximum Inscribed Tangent Circle

Minimum Superscribed Tangent Circle
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n Measuring Rectangles

Precisely five probed points are required to measure a rectangle. The 
five points must be located in an exact pattern, and can be probed in 
either clockwise or counterclockwise order.

The correct pattern of points probed around the rectangle are:

 Two points evenly distributed along one long side

One point on the closest end

One point on the approximate center of the second long side

 The last point on the remaining end

Measurement results are shown in the Features template, Part View 
window and Results window. The Results window shows:

 The feature identification number

 The number of points used in the measurement

 The length and width of the rectangle

 The angular orientation of the rectangle

 The coordinate location of the center of the rectangle

Only the rectangle shape and orientation are shown in the Feature 
stamp of the Results window.

Clockwise probing order

Counterclockwise probing order

1 2

3

4

5

2 1

5

4

3

Probing a different pattern of points, or probing out of 
either clockwise or counterclockwise order will result in 
erroneous rectangle measurements.
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nProfile3D Measurements

Profile3D measurements compare probed part surfaces to nominal 
part profiles from drawing or part data files. Probed surfaces and 
nominal profile surfaces are compared in the Measure Profile3D 
window.

The nominal part profile can be imported into the Measure Profile3D 
window from a drawing file in .IGS or .STP formats.

As surfaces are probed, their points are displayed in the Measure 
Profile3D window. When the desired surface measurements are 
complete, a fit operation is performed. During the fit operation, the 
system positions the probed data over the nominal profile and adjusts 
the X, Y, Z and rotational orientation of the probed points to achieve 
the best fit. Data points are shown as dots and form errors are shown 
as whiskers.

Tolerances can be applied to Profile3D measurements as bilateral 
limits or as unilateral pass/fail boundaries. Bilateral tolerances can be 
distributed equally or unequally on opposite sides of a surface.

The form errors, the number of data points and tolerance pass/fail 
results can be displayed in the Measure Profile3D window at the 
conclusion of the Fit operation. Upon completion of the Profile3D 
measurement, the Profile3D feature is listed in the Features template.

The form error of each surface point is listed in the Points Detail 
template and can be visually inspected using the Profile3D Feature 
Stamp.

Probed points shown in Measure 
Profile3D window

Fit operation performed and form 
error whiskers shown

Points Detail template Profile3D feature stamp
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n Profile3D Measurement Screen Functions

Functions for conducting Profile3D measurements are located across 
the bottom of the Measure Profile3D window. These functions are 
discussed in detail later in the Profile3D measurement instructions.

The Measure Profile3D window functions are shown below:

Measure Profile3D window

Functions Function descriptions

OK Complete the Profile3D measurement

Enter Pt Probe part surfaces

Remove Last Remove the last probed points

Cancel Cancel the Profile3D measurement

Fit Fit probed data to the nominal Profile3D

Reset Reset the fit operation

Export Export the adjusted Profile3D model

Tolerance Assign surface tolerances

Allow X, Y, Z Allow (or prohibit) data shifts during Profile3D fit analyses

Allow AX, AY, AZ Allow (or prohibit) data rotation during Profile3D fit analyses

Pass Only Enable (or disable) Pass Only option
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nProfile3D Window Menu

Functions for evaluating and displaying Profile3D measurement 
results are contained in the Measure Profile3D window menu. 
Right-click anywhere in the Measure Profile3D window to display the 
Measure Profile3D menu.

The Measure Profile3D window menu functions are shown below:

Measure Profile3D window menu

Functions Function descriptions

Zoom All Zoom to fit model in window

Zoom Window Click and drag to select an area to zoom in on

Zoom In Zoom in to show more detail

Zoom Out Zoom out to show less detail

Rotate Rotate the model around the datum

Pan Move the model in the measure window

Maximize Expand the measure window to the full size of the IK 5000 application window

Preset views Set the viewpoint of the model to a predefined view

Solidify Toggle between a wireframe and solid model

Transparency Adjust the percentage of transparency for surfaces of a solid model

Error Mag Magnify the display of form error whiskers

Alignment Adjust the model to match the orientation of the part to the shape
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n The Profile3D Measurement Process

Typical steps required to complete a Profile3D measurement are 
shown below. Details regarding the use of measurement windows, 
menus and toolbar tools are included in the instructions.

Profile3D measurement process steps are shown below:

Profile3D measurement process

1 2 3 84 5 6 7

A B C

Requirement Step System activity

A Measure 1 Start Profile3D measurement

A Measure 2 Import part profile

A Measure 3 Enable data shifts for fit

A Measure 4 Assign tolerances

A Measure 5 Probe part surfaces

A Measure 6 Perform Profile3D fit analysis. Go to step 5 and probe more points 
if needed.

B Review and adjust results 7 Adjust display magnification of error whiskers. Go to step 5 and 
probe more points if needed.

C Complete measurement 8 Add Profile3D feature to the Feature template
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nStart Profile3D Measurement

To begin a Profile3D measurement:

 Click Measure>Profile3D

or

 Click the Profile3D icon button on the Measure toolbar

The Import Profile dialog will be displayed. A nominal part profile can 
be imported from a drawing file. Drawing files can be in the .IGS or 
.STP format.

Import Part Profile

 Select the desired .IGS or .STP file and then Click Open

Start a Profile3D measurement from the Measure 
menu

Start a Profile3D measurement from the Measure toolbar

Select file
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n The nominal Profile3D will be shown in the Measure Profile3D 
window.

Nominal Profile3D shown in Measure Profile3D window
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nEnable or Prohibit Data Shifts for Profile3D Fit

The Profile3D fit algorithm shifts the probed data points in the 
cartesian or polar coordinate system to achieve the best fit between 
the probed points and the nominal part profile.

Maximum degrees of freedom are given to the fit algorithm by 
checking the Allow X, Allow Y, Allow Z, Allow AX, Allow AY and 
Allow AZ check boxes across the bottom of the window. Clearing a 
check box prohibits data movement in the indicated orientation.

To give maximum degrees of freedom to the Profile3D fit algorithm:

 Check the Allow X, Allow Y, Allow Z, Allow AX, Allow AY and 
Allow AZ check boxes across the bottom of the Measure Profile3D 
window

 Clear a check box to prohibit movement of data in the indicated 
orientation

Check all check boxes for maximum degrees of freedom

Allowing the maximum degrees of freedom for the 
Profile3D fit algorithm is recommended for most 
applications.
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n Assign Tolerances

Bilateral or unilateral tolerances can be assigned to Profile3D 
measurements. Bilateral tolerances can be equal or unequal.

To begin applying tolerances:

 Click the Tolerance button to display the Profile Tolerance Edit 
dialog

Begin applying tolerances
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nEqual Bilateral Tolerances

Bilateral tolerance values will be centered on the surface of the 
nominal profile. For example, an equal bilateral tolerance of 0.005 will 
be applied as ±0.0025.

To apply an equal bilateral tolerance:

 Check the Bilateral check box, enter the desired tolerance value 
into the Tolerance field for equal bilateral tolerances and then click 
OK

Unequal Tolerances

Unequal or unilateral tolerance values are specified by the user for In-
material and Out-material tolerances.

To apply an unequal tolerance:

 Uncheck the Bilateral check box, enter the desired 
In material Tol and Out material Tol tolerance values in the 
fields provided and then click OK

Apply equal bilateral tolerances

Apply unequal tolerances
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n Probe Part Surfaces

As part surfaces are probed and points are collected, they appear in 
green in the Measure Profile3D window.

To enter a probed point manually:

 Click Enter Pt in the Measure Profile3D window

To remove the last point(s) collected:

 Click Remove Last

To cancel the Profile3D measurement:

 Click Cancel

When Auto Enter is enabled points will be entered 
automatically as they are probed.

Enter points from the Measure Profile3D window

If a point was probed in a non-perpendicular direction to 
the surface during program recording, the system will 
probe that point orthogonal to the surface during program 
playback as long as the fit analysis was done and 
completed.
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nPerform Profile3D Fit Analysis

When all the required points have been probed, the points can be fit 
to the nominal part model.

When the fit operation is complete, the green probed points will be 
shifted to match the part model as closely as possible and form error 
whiskers will indicate differences between the probed locations and 
the nominal part surfaces. 

To perform a fit analysis:

 Click Fit

Points shown before fit calculation Form error whiskers shown after fit operation

To decrease the fit analysis time, well distributed points all 
around the part under measure are recommended. In 
addition, part alignment and datum can be performed 
before commencing the Profile3D measurement or using 
the Six Point alignment function in the Profile3D 
measurement.
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n Profile3D Automatic Fit Analysis

The fit analysis can be set to be performed automatically once the 
measurement is completed by clicking the OK button.

To select the Profile3D automatic fit analysis option:

 Select Tools>Options...
 Select the Measure tab
 Select the Automatically fit Profile3D when measurement 
complete checkbox

 Click OK

Select Tools>Options
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nProfile3D Pass Only Option

The Pass Only option on the Profile3D Measure window specifies that 
the fitting algorithm terminates the fitting process when it finds a fit 
that is within all specified surface tolerances. If the Pass Only option 
is checked, and a tolerance has been specified for every surface on 
which points have been probed, then the fitting algorithm will 
terminate as soon as it finds a fit in which all probed points pass their 
tolerance. If no such fit can be found then the fitting algorithm will 
continue the process of fitting until it either finds the best fit it can or 
none is found.

The Pass Only option is used to improve performance in cases where 
time is a more important factor than accuracy. This is to be used when 
a tolerance pass/fail is all that is required and not the exact amount of 
the error. The amount of performance improvement varies depending 
on how loose the tolerance is, and how close the part is to its nominal 
form. The fitting of a part that fails its tolerance will not have any 
performance improvement by using the Pass Only option.

To select the Pass Only option:

 Select Measure>Profile3D
 Select the Pass Only checkbox
 Click OK

Select the Pass Only checkbox
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n Six Point Alignment

A six point alignment allows the operator to align the model with the 
orientation of the part on the stage.

To perform a six point alignment:

 Right click in the Measure Profile3D window
 Select Alignment>Six Point. A prompt appears with directions for 

marking points on the model.
 Select OK in the prompt

 Mark three points on the model surface to define a primary plane
 Mark two points on the model on a surface that is close to 

perpendicular to the first surface to define a secondary line

 Mark one point on the model on a surface that is close to 
perpendicular to both the first and second surfaces to define a zero 
point

When six points are selected the first point is highlighted on the model

 Probe the first point on the part. The next point is highlighted on the 
model.

 Repeat probing the remaining five points
 Select Fit in the Measure Profile3D window. The six point 

alignment is completed and the initial fit is done.

Six points selected and first point highlighted
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nResetting the Fit Analysis

The results of a fit analysis can be reset and the point data refined in 
preparation for revised fit operations. The user can review the 
positions of data points, remove data points or change the degrees of 
freedom for the fit analysis.

To reset the fit analysis back to the original probed point locations:

 Click Reset

Points shown after resetting the fit analysis
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n Adjust the Display Magnification of Error Whiskers

During the fit analysis, probed points that do not fall precisely on the 
nominal profile generate form errors. When tolerances are specified, 
the errors are divided into two groups, those that pass (Passed) and 
those that fail (Failed) tolerance criteria.

The passed and failed form errors can be displayed as whiskers that 
extend from the nominal surface. The length of each whisker is 
proportional to its magnitude of error.

Typically, the magnitude of most form errors is so small in proportion 
to the part displayed that without magnification they would not be 
visible. The Measure Profile3D window menu and toolbar include 
fixed, automatic and user-definable levels of magnification for 
displaying error whiskers.

Fixed magnifications: display magnifications are selected directly by 
the user.

Automatic magnification (AX): the system optimizes the display of 
error whiskers based on the maximum form error value.

User-defined magnification (UX): A data field will be displayed for 
specifying the level of magnification.

To adjust the display magnification of form error whiskers:

 Right-click the Measure Profile3D window to display the Measure 
Profile3D window menu

 Click Error Mag to display a menu of magnification alternatives
 Click the desired magnification selection

Select error magnification from Measure Profile3D 
window menu
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nAdd Profile3D Feature to the Feature Template

When the final fit analysis is finished, the Profile3D measurement can 
be completed and the Profile3D feature can be added to the Feature 
template.

To complete the Profile3D measurement:

 Click OK in the Measure Profile3D window

Complete the Profile3D measurement
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n To view the Profile3D measurement results:

 Click on the Feature Stamp Icon in the results window

Measurements results are also available in the PointDetails 
template.

Profile3D feature stamp

PointDetails template

If the PointDetails template is not open it can be viewed 
by clicking Windows>Open Template... and selecting 
PointDetails.5ft.
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nAuto Focus (option)

The Auto Focus teach function has been removed from the IK 5000 
software. The focus search distance is now entered directly into the 
search distance field. The previous Auto Focus algorithm used the 
teach function to teach the optimum search distance and Z axis 
velocity, depending on the connected camera's frame rate. This could 
cause an intermittent Auto Focus failure when used on a significantly 
different surface from the surface used during the teach process. The 
algorithm now automatically adjusts the Z axis velocity depending on 
the camera frame rate and the user specified search distance. 

High resolution cameras may produce less than optimal results which 
can be improved by decreasing the search distance. Decreasing 
search distance also speeds up the focal point acquisition time but 
requires initial position to be closer to the targeted focal point. On 
some cameras turning on the despeckle filter prior to performing auto 
focus will improve results, despeckle filter can then be turned off after 
focus.

To turn on the despeckle filter:

 Right click on the Video window and select Filter...
 Check the Despeckle checkbox
 Click OK

Right click the Video 
window and select Filter...

Check the Despeckle box and click OK
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n To set Auto Focus options:

 Click Tools>Options

 Verify the Supervisor Password is entered and the Keep privileges 
until program is exited option is checked

 Click Probe>Probe Library
 Click on the target camera

 Click on the target magnification
 Click the Auto Focus tab
 Enter the desired search distance in the Search Distance field
 Click OK to save the changes and exit the Probe Library

Verify the Password is entered and Keep 
privileges until program is exited is 
checked

Click Probe>Probe Library Click on the target camera

Click on the target magnification Click the Auto Focus tab Enter the desired search distance and 
click OK
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nAuto focus will search and make as many passes as necessary until a 
optimum focus point is found. The Max two passes feature limits the 
number of auto focus passes to two. Selecting this feature can speed 
up the auto focus process but may result in less reliable repeatability 
of the auto focus height.

To enable Max two passes:

 Select the Max two passes check box

Select the Max two passes check box
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n Autofocus Final Check

An option to perform a final autofocus check is available from the 
Auto Focus tab in the Probe Library.

Enabling a final check helps to avoid missing an optimum focus point 
when autofocusing with a search distance smaller than 1 mm and a 
magnification greater than 20 x. An optimum focus point can be 
missed due to skipping of the focus frames during the focus search, 
machine drive mechanics, changes in lighting, or the objective lens 
being used.

A final check compares the difference in contrast values of frames in 
the range of 5 µm above to 5 µm below the initial focus point. If there 
is a point with a larger contrast value found the system will focus on 
the point of greater contrast.

To enable the autofocus final check:

 Select Probe>Probe Library...

 Select the target camera and target magnification
 Select the Autofocus tab
 Check the check box next to Enable final check

Click Probe>Probe Library... Check the check box next to Enable final check
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nManual VED Height Point Measurement

The VED height probe can be used to measure height points in a VED 
configured system. This is done automatically in a motorized stage 
system. In a manual system this function must be performed manually 
using the VED height probe.

To perform VED height point measurement manually:

 Click Measure>Point...
The Measure Point window opens.

 Select the VED Height probe

 Press Enter Pt in the Measure Point window

Click Measure>Point... Select the VED Height probe

Press ENTER PT



66 1 Operation

1
.1

 O
p

e
ra

ti
o

n  Follow the prompt on the screen to slowly move up and down in the 
focus zone

Once the system finds focus, it will fire the probe and take a point 
measurement which will be posted in the Measure Point window.

Follow the prompt Slowly move up and down in the focus zone

The system will fire the probe and take a point measurement
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n Press OK in the Measure Point window. The Point height 
measurement is complete.

Press OK in the Measure Point window The Point height measurement is complete
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n Optimet Laser Lens Selection

The Optimet laser is a laser measuring probe supported by IK 5000. 
Multiple laser lenses are available for probing different types of 
surfaces and materials. Each lens has an ID.

The Lens settings in the IK 5000 software must match the physical 
lens that is attached to the probe. These settings allow the IK 5000 to 
adjust the laser beam properties to match the physical lens. When 
attaching a physical lens to the probe, verify that the settings match 
the physical lens.

To verify the Optimet laser lens:

 Click Probe>Probe Library...

 Select the Optimet probe

 Select the ID for the physical lens attached to the probe from the 
Index drop-down list

 Verify that the Focal Distance setting matches the focal distance of 
the physical lens

 Click OK.

Click Probe>Probe Library...

Verify that the Focal Distance setting matches the focal distance label on the physical lens
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nKeyence Laser Settings

The Keyence LK-G5000 Series laser is a laser measuring probe 
supported by IK 5000. The Keyence laser can be used to measure 
features that require a laser probe for acquiring a feature data cloud.

How the Keyence laser acquires data points can be controlled by 
changing settings in the IK 5000 software.

To edit Keyence laser settings:

 Click Tools>Keyence Settings...

Click Tools>Keyence Settings...
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n  Edit any settings that require changes

 Click OK 

The changes are saved and the Keyence Settings window closes.

Edit any settings that require changes

Refer to the documentation provided with the 
Keyence LK-G5000 for additional information regarding 
the Frequency, Median filter, Measurement mode and 
Mounting method settings.
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nExploding the Data Cloud

Explode Data Cloud is used to extract point features from the data 
cloud used in a probed feature. 

To extract point features from the data cloud:

 Verify the system is in No Program or Editing state of programming

 Probe a feature
 Select the target feature

 Click Tools>Explode Data Cloud.

The Features List is populated with point features created from the 
data cloud of the selected feature. 

Verify the system is in 
No Program or Editing 
state

Probe a feature Select the target feature

Click Tools>Explode Data Cloud Point features are created from the data cloud
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n Rotating and Positioning of VED Tools using Part 

Reference Frame

If a part datum has been performed, the system will rotate and 
position the VED tools, including the Video Charts, to the part 
reference frame.

ISO Tolerance

The ISO tolerance enables the use of data stored in ISO 286-2 
Standard tables.

The ISO tolerance can be added to the following features:

 Point

Circle

Arc

 Sphere

 Line

 Slot

 Torus

Rectangle

The ISO tolerance is applied to a feature similar to other tolerances, for 
instance by right-clicking on a feature in the Features list template.

Right-click on a feature in the Feature list
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nOnce the ISO tolerance is selected the ISO Tolerance Entry dialog 
box appears. The ISO Tolerance Entry dialog box is used to select 
which ISO tolerance table entry will be used to tolerance each 
applicable feature parameter.

Available parameter selections are:

 ISO table

 ISO Index

The ISO index entry can be used to select which column, 1 through 
18, to use for the selected ISO tolerance table. For questions about 
the ISO tolerance table selection please refer to the ISO 286-2 
standard.

ISO tolerance entry table
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n The nominal value for the feature parameter along with the selected 
ISO tolerance table and index entries are used to determine the low 
and high limits to be used when tolerancing the feature. These limits 
are calculated through a look-up into the ISO tolerance table. If no ISO 
tolerance table entry or ISO tolerance index entry is specified then the 
tolerance is considered empty and the tolerance will pass. Also, if the 
nominal value for the feature parameter is outside of the range of 
nominal values found within the selected tolerance table, then the 
tolerance will also pass.

Similar to all tolerances, the ISO tolerance can be added to features 
within a program.

The ISO tolerance results can also be viewed in reports when using 
the AllTol template. 

ISO tolerance results

ISO tolerance added to a feature in a program
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n

AllTol template
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n Continuous Probe Firing

Probes can be dry-fired continuously to show data points that would 
be acquired under the current light, focus, part alignment and other 
current measurement conditions if the probe were actually fired. The 
data points are shown in blue until the probe is fired to acquire points, 
then the acquired points are shown momentarily in red.

To enable Continuous Fire:

 Right-click the Live Video window to display the Window menu
 Select Other>Continuous Fire
or

 Click the Continuous Fire button on the VED toolbar

Continuous Fire enabled

Continuous probe firing is useful for setup and 
troubleshooting activities, but requires substantial system 
resources and should be avoided during routine use to 
maintain high throughput.

Enable Continuous Fire from menu

Enable Continuous Fire from VED toolbar
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nProgramming Continuous Probe Firing

Continuous probe firing is programmable. A Continuous Fire mode 
step is recorded in the Initial settings program step when a new 
program is recorded. Continuous probe firing is turned off in the Initial 
settings step by default.

Initial settings step

To turn Continuous Fire on in the Initial settings:

 Click the + sign next to Initial settings... to expand the Initial 
settings step in the program window

 Double-click Turn off continuous fire mode...

The text changes to Turn on continuous fire mode.... Continuous 
Fire mode will now be turned on when the program is run.

After a program is run the state of Continuous Fire returns 
to the same state that was in place before the program 
was executed.

Enable Continuous Fire from Initial settings... step
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n Program Step

When the state of Continuous Fire is changed from the Live Video 
window or the VED toolbar, a separate Continuous Fire step is 
recorded in the program. The state of this step can be changed.

To turn Continuous Fire off in an existing program step:

 Double-click on Turn on continuous fire mode...
Turn off continuous fire mode... is displayed in the Program 
window and the program will now turn Continuous Fire off at this step 
in the program.

To turn Continuous Fire on in an existing program step:

 Double-click on a Turn off continuous fire mode... step

Turn on continuous fire mode... is displayed in the Program window 
and the program will now turn Continuous Fire on at this step in the 
program.

Change the state of a Continuous Fire program step
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nMeasure Shortcuts

Keyboard shortcuts for starting Ellipse, Torus, Profile, and Profile3D 
measurements are now available. The shortcuts are listed in the 
Measure menu.

In addition to the new measure shortcuts, the Rectangle menu item 
has been moved to a more appropriate location in the Measure menu.

Ellipse Shortcut

To start an Ellipse measurement:

 Press Ctrl+E on the keyboard

Torus Shortcut

To start a Torus measurement:

 Press Ctrl+T on the keyboard

Profile Shortcut

To start a Profile measurement:

 Press Ctrl+F2 on the keyboard

Profile3D Shortcut

To start a Profile3D measurement:

 Press Ctrl+F12 on the keyboard

Measure menu
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n  Axial Runout Tolerance Check  for Plane Feature

Axial runout tolerance can be applied to a Plane feature that is 
perpendicular to a reference axis, e.g. plane to cylinder.

To apply axial runout tolerance:

 Measure a cylinder to be used as a reference in the tolerance
 Measure the plane to apply the axial runout tolerance to
 Select the Plane feature in the Features template
 Select Tools>Tolerance>Axial Runout
 Enter tolerance parameters
 Click ok

Tolerance results are displayed.

Select 
Tools>Tolerance>Axial Runout

Enter tolerance parameters and 
click OK

Tolerance results are displayed
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nPerforming a runout tolerance on a circle using a 

cylinder as a reference

Performing a runout tolerance on a circle requires a reference feature 
such as another circle or cylinder. 

To use a cylinder as a reference feature:

 Measure a cylinder to be used as the reference feature for the 
runout tolerance and then measure the circle to be toleranced.

Measure a cylinder to be used as the reference feature and then measure the circle
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n  Right-click on the Results window
 Select Tolerance>Runout…

 Enter the Tol. Zone
 Select the cylinder to use as the reference feature from the 
Reference Feature drop-down list

 Enter a name into the Named Tolerances field if desired
 Click OK in the Runout Tolerance Entry window to accept the values 

entered

Right-click and select Tolerance>Runout…

Enter Runout Tolerance Entry information and click OK 
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n Click OK  in the Runout Tolerance Results window to save changes 
and close the window

Or

 Click Edit... to go back to the entry window

Click OK or Edit...
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n Symmetry Tolerance

A symmetry tolerance can be applied to Line and Plane features that 
are symmetrical to a reference feature.

Symmetry Tolerance Applied to a Line

To apply the symmetry tolerance to a line:

 Measure four lines, two lines on opposite sides that are considered 
to be master edges and two lines from edges that are to be 
symmetrically toleranced. Lines 1 and 2 are measured from master 
edges while lines 3 and 4 are measured from the edges to be 
symmetrically toleranced.

 Construct a reference line from lines 1 and 2
 Construct the line to be tolerance for symmetry from lines 3 and 4
 Select the resultant line from the construction using lines 3 and 4
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n Apply symmetry tolerance with the constructed line from lines 1 and 
2 as the reference feature

The actual tolerance is calculated by doubling the 
maximum distance between the endpoints of the 
constructed tolerance line from the endpoints of the 
constructed reference line.



86 1 Operation

1
.1

 O
p

e
ra

ti
o

n Symmetry Tolerance Applied to a Plane

To apply the symmetry tolerance to a plane:

 Measure four planes, two planes on opposite sides that are 
considered to be master surfaces and two planes from surfaces that 
are to be symmetrically toleranced (see drawing above). Planes 1 
and 2 are measured from master surfaces while planes 3 and 4 are 
measured from the surfaces to be symmetrically toleranced.

 Construct a reference plane from planes 1 and 2
 Construct the plane to be toleranced for symmetry from

planes 3 and 4
 Select the resultant plane from the construction using

planes 3 and 4
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n Apply symmetry tolerance with the constructed plane from planes 
1 and 2 as the reference feature

The actual tolerance is calculated by doubling the 
maximum distance between the endpoints of the 
constructed tolerance plane from the endpoints of the 
constructed reference plane.
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n Plane Probing Technique

A plane can be measured by probing three seed points for the data 
cloud. The IK 5000 fitting algorithm uses these three points as the first 
three corners of the plane.

It is important to probe the three seed points on the corner surfaces 
of the actual plane if the Add Probe Points function is used to add 
more points to the data cloud of the plane measurement.
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nIn some cases it may be necessary to probe the seed points in a 
different order and location. For example, probing the seed points 
where the first two are located at the immediate corners facing the 
operator while the third point is probed on the middle point of the 
opposite edge.

The resulting plane cannot be used with the Add Probe Points 
function because it will fail due to some points being located outside 
the actual surface. The system will miss target points as they will be 
located outside the actual plane and cannot be reached.
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n Exporting 3D CAD Model Features in STEP File 

Format

IK 5000 supports exporting features to the STEP file format.

To export features to the STEP file format:

 Open a reporting template (e.g. Feature List template, Reports 
template, etc)

 Measure a feature or features to export

 Select the features to be exported

Open a reporting template

Select the features to be exported
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n Click File>Export...

 Select STEP (3D) from the Save as type drop-down list

Click File>Export... Select STEP (3D)
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n  Enter a name in the File name field
 Click Save

The features will be saved to file in STEP file format.

Enter a File name and click Save



IK 5000 QUADRA-CHEK 93

1
.1

 O
p

e
ra

ti
o

nOpen Database Connectivity (ODBC) Data 

Export

The IK 5000 can export data to applications, like Microsoft Excel, using 
Open Database Connectivity (ODBC).

To send data to a target application:

 Create a database in the target application (in the case of Excel, 
create a file)

 Configure the database as a data source using the operating 
system's ODBC Data Source administration

Microsoft Windows 7 database configuration example

 Open the Windows Control Panel from the Start menu
 Select Administrative Tools
 Select the Data Sources shortcut

The ODBC Data Source Administrator window opens.

Refer to the PC’s operating system instructions for how to 
configure an ODBC data source. An example is provided 
below.

ODBC Data Source Administrator
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If the Excel Files Data Source does not exist, click the Add button and 
add it from the installed ODBC drivers.

  Click Configure

The ODBC Microsoft Excel Setup window opens.

 Enter the Data Source Name and Description into the text fields
 Click the Select Workbook button and select the workbook to be 

used for the database
 Click OK to save the data source configuration

The Data Source is configured and the name is updated in the ODBC 
Data Source Administrator.

 Close the ODBC Data Source Administrator window

 Close the Excel file if it is open

ODBC Microsoft Excel Setup window

ODBC Data Source Administrator
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 Select Tools>Options... from the IK 5000 menu bar
The Options window opens.

 Select the General tab
 Select the Prompt for ODBC Export checkbox

Select Tools>Options... Select the General tab and the Prompt for ODBC Export checkbox
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 Select features or records from the available data templates

 Select File>Export...

A prompt will request confirmation to export data to an ODBC data 
source.

 Click Yes

Select features or records

Select File>Export... Click Yes
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 Enter the DSN (Data Source Name), User Name and Password for the 
data source

 Enter the Table Name that the data will be exported to
 Click OK

Enter the Database Connection Information and click OK

The target database file must be closed before performing 
an ODBC data export from the IK 5000.

If using DDE OUTPUT, the target database file has to be 
open before performing a DDE output from the IK 5000.
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Updating the IK 5000 Software

The update should be performed according to the following 
procedure:

Make a backup of the IK 5000 system settings

Uninstall the installed IK 5000 software

 Install the new IK 5000 software version

Restore the IK 5000 system settings

Backup System Settings

 Make a backup of the IK 5000 system settings (via 
menu: Help>Backup Settings...)

Uninstall Old Software Version

 Uninstall the installed IK 5000 software with the tools provided by 
the operating system (control panel)

Install New Software Version

 Install the new software version 3.0.x

Restore System Settings

 Restore the IK 5000 system settings (via 
menu: Help>Restore Settings...)

If an option that requires a license key is enabled the current license 
key remains valid. A new license key is not required.
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IK 5000 technical support may be obtained by contacting 
HEIDENHAIN or the Original Equipment Manufacturer (OEM).

To access support contact information:

 Click Help>Support

A customer support information PDF file will open.

Click Help>Support Customer support information is displayed
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IK 5000 files and folders locations are distributed throughout Windows 
operating system folder locations in accordance with the operating 
system's files and folders location guidelines.

The files and folders are distributed as follows:

 IK 5000 files are located in the HEIDENHAIN\IK 5000 folder which is 
in the Program Files OS folder

 IK 5000 application is located in HEIDENHAIN folder in the Start 
menu

Configuration files are stored in IK 5000 folder in Program Data OS 
folder

User settings files are saved to the IK 5000 folder in Local User OS 
folder

User document files are saved to the IK 5000 folder in the Documents 
OS folder

Some file types that were supported in previous versions 
are no longer used. File type .met is no longer supported. 
Files of this type have been removed from the system.
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The Use machine reference option in the Program Properties dialog 
has been renamed to Use current reference frame. When an 
existing program is loaded into IK 5000 SW v3.0.0 or higher, the 
Use current reference frame option will take on the opposite state 
of the Use machine reference option.

The reference frame that is in place when a program is first recorded 
is now stored within the program. If Use current reference frame is 
unchecked, the program will use this stored reference frame as its 
initial reference frame when the program is executed.

If Use current reference frame is checked, the program will use the 
current part reference frame when the program is executed.

To change the current part reference frame:

 Select a different part reference frame from the status bar

Program Properties window
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part reference frame has been created before the program is first 
recorded Use current reference frame will be automatically 
checked.

Programs written prior to SW v2.96.0 do not include the reference 
frame that was in place when the program was first recorded. If 
Use current reference frame is unchecked the program will use the 
machine reference frame as the initial reference frame when the 
program is executed.

If Use machine reference was previously used the same behavior can 
be obtained with Use current reference frame.

To obtain the same behavior:

 Select the machine reference frame prior to recording the program
 Uncheck Use current reference frame in the Program Properties 

dialog prior to executing the program

or

 Check Use current reference frame
 Select the machine reference frame prior to executing the program
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The IK 5000 supports the configuration of camera and image quality 
parameters through DirectShow interfaces. The configurable 
parameters are limited to those provided by the camera driver support 
for DirectShow. The IK 5000 cannot modify a parameter that the 
camera driver does not allow to be modified.

Example configurable parameters are gamma, brightness, contrast 
and color saturation. Brightness and contrast settings are saved when 
the IK 5000 is shut down and restored on the next start up.

To access digital camera parameters:

 Right-click in the Video window
 Select Video Properties

A video properties window will open displaying the available camera 
parameters that can be edited.

Right click in the Video window and select Video 
Properties

Example video properties window
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Use the VED screen in video edge detection systems to specify video 
probe measurements parameters.

To display the VED screen:

 Click Tools>Options...>VED

Digital video probe and measurement parameters will be displayed for 
your system.

New options:

 Camera: Select the camera to use for VED (previously unnamed)

 Image format: Select the image color format

VED screen example
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The digital camera selected as the spotter camera and the format for 
the spotter camera can be set from the VED setup tab.

Spotter camera options
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UYVY

RGB24

RGB32

To access Spotter camera options:

 Select Tools>Options...
 Select the VED tab
 Select a digital camera from the Spotter drop down menu
 Select an image format from the Image Format drop down menu
 Click OK
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(Optional)

A CNC system can be operated in either Closed Loop or Open Loop 
joystick control mode. This can cause a system to move with different 
velocities when a user switches from one mode to the other. To make 
the velocity comparable, a user can apply a scaling factor to the 
joystick parameters when in open loop control mode. The Scale factor 
ranges from 0.01 to 1.00. This is a unit-less value. The default value is 
0.5.

Verify the system is set to Open Loop joystick control mode:

 Click Tools>CNC...
 Enter the Password
 Click the General tab
 Select the Set joystick control to Open Loop mode checkbox if 

not already selected

 Click OK

Set joystick control to Open Loop mode
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 Click TOOLS>CNC...
 Enter the Password
 Click the Joystick tab
 Enter the desired scaling factor into the Scale factor field

 Click Apply
 Click OK

Enter the desired scaling factor



IK 5000 QUADRA-CHEK 111

2
.1

 S
e

tu
pShutdown

The Shutdown function applies to CNC enabled systems only. During 
system shutdown the probe returns to a position defined in machine 
coordinates regardless of probe type. The position may be specified 
using X, Y and Z coordinates or by choosing the current probe location.

To specify the probe position at shutdown:

 Select Tools>CNC...

 Enter the Supervisor password into the Password field
 Select the Shutdown tab
 Select the Enabled checkbox
 Enter the X, Y and Z coordinates or click Use Current Location
 Click OK

Shutdown settings window
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Y and Z axis debounce count values for the digital positioner use their 
own axis value. Previously they used the X axis value.

To specify debounce count values:

 Select Tools>CNC...

 Enter the Supervisor password into the Password field
 Select the Digital Positioner tab
 Enter values into the Debounce (cnts) fields
 Click OK

Digital Positioner settings window
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A software fence is used to limit axial movement in a CNC system.

The IK 5000 has three software fence options:

Machine Fence

User Fence 1

User Fence 2

A machine fence is a software fence established to prevent collisions 
at the end of an axis.

A user fence is a software fence established to limit axial travel, 
usually in relationship to part geometry.

A software fence may be established in two ways:

Manually

Using the Teach function

If a user fence and a machine fence are active at the same 
time the more restrictive fence defines the limits on an 
axis
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To manually create a software fence:

 Select Tools>CNC...

 Select the Supervisor tab

 Enter the Supervisor Password
 Press the Enter key on the keyboard

Select Tools>CNC... Select the Supervisor tab, enter the Supervisor Password and press Enter on the keyboard
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 Enter maximum coordinates in the Max field for each desired axis
 Enter minimum coordinates in the Min field for each desired axis

 Select the Enable checkbox next to an axis to enable the software 
fence for that axis. If the Enable checkbox for an axis is not checked, 
the software fence is not applied to that axis.

 Click Apply to apply the changes
or

 Click OK to apply the changes and exit the CNC window

Select the Software Fence tab, enter coordinates and enable axes
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To create a software fence using the Teach function:

 Select Tools>CNC...

 Select the Supervisor tab

 Enter the Supervisor Password
 Press the Enter key on the keyboard

Select Tools>CNC... Select the Supervisor tab, enter the Supervisor Password and press Enter on the 
keyboard
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 Click the Teach button

Select the Software Fence tab and click the Teach button
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 Click a radio button to select the desired software fence to teach

 Click Next

 Check the box next to the axis or axes to teach

Any single axis or combination of axes may be selected.

 Click Next

 Move each axis to the desired limit of travel for the selected axes. 
In general, position the axes at the point that is to mark the 
beginning of positive travel.

 Click Next

 Move each axis in the safe direction

 Click Next

Click a radio button to select the desired 
software fence to teach and click Next

Check the box next to the axis or axes 
to teach and click Next

Move each axis to the desired limit of travel and click Next Move each axis in the safe direction and click Next
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direction. This should be the furthest distance away for each axis to 
travel from the point taught in the previous two steps.

 Click Finish

The system fills in the minimum and maximum values.

 Select the Enable checkbox next to an axis to enable the software 
fence for that axis. If the Enable checkbox for an axis is not checked, 
the software fence is not applied to that axis.

Move each axis to the desired limit of travel in the opposite 
direction and click Finish

The system fills in the minimum and maximum values.

Enable axes



120 2 Setup

2
.1

 S
e

tu
p  Click Apply to apply the changes

or

 Click OK to apply the changes and exit the CNC window

Joystick Button Assignment

Joystick buttons can be assigned to toggle the user fence state or to 
activate a user fence.

To assign a user fence option to a button:

 Click Tools>Options...
 Select the Supervisor tab
 Enter the supervisor Password

If a user fence and the machine fence are active at the 
same time the more restrictive fence defines the limits on 
an axis

Option Description

Toggle User Fence Toggles the user fence state between 
Fence Off, User Fence 1 and 
User Fence 2 when the assigned button 
is pressed.

Activate User Fence 1 Activates User Fence 1 settings when 
the assigned button is pressed.

Activate User Fence 2 Activates User Fence 2 settings when 
the assigned button is pressed.

Click Tools>Options... Select the Supervisor tab and enter the supervisor Password
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 Select Toggle User Fence, Activate User Fence 1 or 
Activate User Fence 2 from the drop-down list of the desired 
button

 Click OK to apply the changes and exit the Options window

Select the Buttons tab

Select Toggle User Fence
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The user fence state can be displayed and toggled in the status bar.

To show or hide the user fence status bar item:

 Click Tools>Customize...

 Select the Supervisor tab

 Enter the supervisor Password

Click Tools>Customize... Select the Supervisor tab and enter the supervisor Password
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 Scroll to the User fence option and select it
 Click Show to display the User fence status or Hide to remove the 

User fence status item from the status bar

 Click Apply to apply the changes
or

 Click OK to apply the changes and exit the CNC window

The status bar will be updated.

Select the Statusbar tab, select User fence and click Show or Hide
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The user fence can be toggled between Fence Off, User Fence 1 and 
User Fence 2 when displayed in the status bar.

To toggle the user fence state:

 Click the user fence state in the status bar

The state will toggle to the next user fence option.

Click the user fence state in the status bar to toggle the status.



IK 5000 QUADRA-CHEK 125

2
.1

 S
e

tu
pTouch Probe Requalification and Starting Point

Touch probe auto requalification can be set to Use circular moves and 
to begin the requalification measurements at the top of the sphere and 
not along the diameter.

To select 'Auto Requal' parameters:

 Select Tools>CNC...

 Enter the Supervisor password into the Password field
 Select the Auto Requal tab
 Select the Begin measurement at top of sphere and Use circular 
moves checkboxes

 Click OK

Deselecting this option allows the automatic 
requalification to be executed by linear movements, 
minimizing stage vibrations for systems with large 
measuring stages.

Auto Requal settings window



126 2 Setup

2
.1

 S
e

tu
p Reset Template Text Colors

It is possible to set the text color of a template to the same color as 
the background. When this happens the text is not readable.

The Reset Template Text Colors option makes it simple to revert the 
text colors for all open templates back to the default color. The default 
text color for all templates is black.

To reset template text colors:

 Select Help>Diagnostics>Reset Template Text Colors. A prompt 
appears requesting verification to reset the text colors.

 Click Yes

Select Help>Diagnostics>Reset Template Text Colors

Click Yes



IK 5000 QUADRA-CHEK 127

2
.1

 S
e

tu
pDefault Fixtures Files Location

A default location for Fixtures files can be selected. The IK 5000 uses 
this location to save and load reference frames.

The default location is the Fixtures subfolder of the IK 5000 folder 
located in the user's system documents folder.

To change the Fixtures file location:

 Select Tools>Options...
 Select the Files tab
 Browse or enter a new Fixtures file location

Browse or enter a new Fixtures file location
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completed

Measurements can be disabled when machine zero homing is not 
completed.

To disable measurements when homing is not complete:

 Click Tools>Options…

Click Tools>Options…
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 Check Disable measurements if homing is not completed

 Click OK to save changes and exit the Options window

Click Tools>Options… and check Disable measurements if homing is not completed
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IK 5000 Open Loop joystick control provides the ability to toggle 
between two joystick speeds when Speed Toggle is assigned to a 
joystick button. External amplifier Open Loop joystick control provides 
the ability to toggle between three speeds. The ability to toggle 
between three speeds provides increased control over the velocity of 
movements.

When Set joystick to Open Loop mode and Use external amplifier 
for Open Loop control are enabled, Open Loop functionality is 
controlled by the HEIDENHAIN amplifier connected to the IK 5000 
system. Use external amplifier for Open Loop control is disabled 
by default.

To enable external amplifier Open Loop control:

 Select Tools>CNC...
 Select the General tab
 Select the Set joystick to Open Loop mode and Use external 
amplifier for Open Loop control checkboxes

 Click OK

CNC window General settings tab
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A pop-up warning can be enabled that warns you when the system is 
about to make a CNC movement.

To enable the CNC movement warning:

 Click Tools>CNC… 

 Select the General tab
 Check Warn user on CNC movement

Click Tools>CNC…
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A pop-up warning will now appear when the CNC is going to make a 
movement.

Check Warn user on CNC movement

CNC movement pop-up warning
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program.

To restrict the warning to the first movement:

 Check In programs only

The warning will now only appear on the first movement of a program.

 Click OK button to save the changes and exit the Options window

Check In programs only

Pop-up warning on first CNC movement
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Speed Toggle must be assigned to a joystick button in order use 
joystick speed control. The HEIDENHAIN QUADRA-STEP setup 
software is used to assign joystick button functions in the 
HEIDENHAIN amplifier. QUADRA-STEP setup software and the 
QUADRA-STEP setup guide can be downloaded from 
www.heidenhain.de. 

The IK 5000 and external amplifier both sense joystick button presses. 
When Speed Toggle is assigned to a joystick button in the external 
amplifier, the same button must be set to No Assignment in the 
IK 5000 Options settings.

To set a IK 5000 joystick button assignment:

 Click Tools>Options
 Select the Buttons tab
 Click the drop-down arrow for the joystick button Speed Toggle was 

assigned to in the external amplifier
 Select No Assignment
 Click OK 

Options window Buttons tab
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The IK 5000 uses RS-232 for data transfer and to communicate with 
custom devices. Serial communication ports (COM ports) are 
configured to enable this communication.

Several COM ports can be available in a computer system and can be 
used for data transfer and communication. The ports are typically 
numbered COM 1, COM 2, etc...

The IK 5000 can use any COM port to communicate with an attached 
serial device and the port to use with each device can be configured.

In some cases it is necessary to assign a specific serial port to be used 
for a certain device. In these cases the COM port is set to a specific 
number and cannot be changed.

The COM port can be changed for the following functions and devices:

 Sending feature data

 Sending general RS-232 strings
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To configure the COM port for sending feature data:

 Select Tools>Options...
 Select the General tab
 Enter the desired COM port in the COM# field

COM 1 is the default setting.

 Click OK

Other serial port parameters are set to 9600 baud, 8 data bits, 1 stop 
bits and 0 parity.

Select Tools>Options... Enter the COM #
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To configure the settings for sending general RS-232 strings:

 Select Tools>Options...
 Select the Supervisor tab
 Enter “RS232” in the Password field

The RS232 Setup window appears.

 Enter the desired COM port in the Port number field

COM 1 is the default setting.

 Click OK

Select Tools>Options... Select the Supervisor tab and enter “RS232” in the Password field

Enter the COM port in the Port number field
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The IK 5000 can communicate with certain RS-232 capable devices. 
Sending and receiving data between the IK 5000 and an RS-232 
compatible device requires the baud, data bits, stop bits, and parity 
communications parameters match on both the IK 5000 and the 
device. The IK 5000 COM port must be set to the port where the 
device is connected.

The RS-232 cable type used to connect the IK 5000 to the device may 
vary depending on the device's serial port design. Some devices use 
a straight-through cable (no cross-overs) while others require a cable 
with cross-overs. Connecting computer-as-a-device requires a cable 
with cross-overs. The Serial Port setting on the computer set as the 
sending/receiving device must be set to match the settings on the 
IK 5000 serial port in the Windows OS Control Panel.

Printer Selection

The IK 5000 uses the Windows operating system default printer. If the 
Windows default printer is changed after the IK 5000 has been run, the 
IK 5000 printer settings need to be updated.

To update the printer settings:

 Click File>Page Setup...
The Page Setup window opens.

 Make any desired changes in the Page Setup window
 Click OK

The changes are updated and the Page Setup window closes

Click File>Page Setup... Make any desired changes in the Page Setup window
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The IK 5000 software version can be displayed in a report header.

To display the software version:

 Click Tools>Options…

 Select the General tab
 Check Show Software Version in Reports

Click Tools>Options…

Select the General tab and check Show Software Version in Reports
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Ver: <v> will be displayed when the report template header is 
opened. 

Ver: <v> will be displayed in the report template header.
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Report headers can display the current system linear units. This option 
can be activated by enabling Show report header for new report 
templates. For existing templates, the option must be activated 
manually.

To enable Show report header manually in a report template:

 Click Windows>Open Template…
 Select a report template from the list and click the Open button

Click Windows>Open 
Template…

Select a report template from the list and click the Open button
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 Select Show report header in the Sections group and click OK

The report template now shows the header with Unit: <unit> 
displayed.

Right-click on the report 
template and select 
Template Properties

Select Show report header in the Sections group

The report template now shows the header with Unit: <unit> displayed.
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Configuring a system with an indexible contact probe head is done by 
turning on the Indexible Probe Head option and enabling the Probe 
Selector.

To configure the indexible system:

 Click Tools>Options…
 Select the Probes tab and enable the installed Indexible probe type

 Click OK

Click Tools>Options… Select the Probes tab and enable the installed Indexible probe type
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angles.

To enable the probe selector window:

 Click Probe>Contact Probes>Probe Selector
 Stretch the probe selector window in order to access all of the 

controls if neccessary

Click Probe>Contact Probes>Probe Selector Stretch the probe selector window in order to access all of the 
controls if neccessary

Adding probe groups and their probe tips is done in the 
probe library. Refer to the operating instructions for adding 
probe groups and tips. 
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Position for CNC Systems with an Indexible 

Probe

The following example assumes that valid data has been entered into 
the Tools>CNC… Auto-Requal tab and that groups and tips have been 
added in the Probe Library.

To teach an angle position for an indexible position:

 Select a group from the group drop-down list
 Select a probe tip from the probe tip drop-down list

 Set the tip to the straight-down position (A0.00-B0.00, this is the 
reference position) by clicking on that position on the cobweb of the 
Probe Selector window (example A0.00-B0.00) or by repeatedly 
clicking on the A+- and B+- buttons
The system will automatically switch to this probe indexible position 
if the indexible probe head is motorized. Otherwise the system will 
prompt you to manually switch to this probe indexible position. 

Select a group Select a probe tip
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sphere
 Once done probing the qualification sphere, click the OK button to 

complete the teach process

Once qualified, the position indicator will turn green.

If the Stack length for the selected group is equal to zero, the system 
will calculate it and automatically add it. If you manually add a value 
that is greater than zero, the system will use that value.

Click the position on the cobweb (example A0.00-B0.00) or 
repeatedly click on the A+- and B+- buttons

Click the OK button to complete the teach process
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cobweb of the Probe Selector window (example A45.00-B45.00), 
or by repeatedly clicking on the A+- and B+- buttons
If the indexible probe head is motorized, the system will 
automatically switch to this probe indexible position (Otherwise, the 
system will prompt you to manually switch to this probe indexible 
position).

 Teach this position by probing the qualification sphere that was used 
to qualify the reference position
You can probe it manually or automatically. Automatic probing is 
done by clicking the Auto… button in the qualification window. 

 Once done probing the qualification sphere manually, click the OK 
button to complete the teach process
If done automatically, the system will complete the teach process 
automatically.

Click the position on the cobweb (example A45.00-B45.00) or 
repeatedly click on the A+- and B+- buttons

Click the OK button to complete the teach process
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 The group Stack length can be reset by going to the 
Probe Library and entering a value of zero for that group. 
The next time the reference position for the reference 
tip of that group is qualified manually, a new Stack 
length will be calculated and automatically added.

 The system will not automatically change a group's 
Stack length if you manually enter a value that is greater 
than zero.

 The qualification sphere position for automatically 
probing can be set to a new location by moving the 
qualification sphere to the new location and then 
manually re-teaching the reference position of the 
reference tip of the reference group.

 The reference position can be re-qualified using 
automatic qualification sphere probing if the group Stack 
length is non-zero.

Non-reference group’s Stack length will be calculated 
and added in automatically once a group has been cross-
calibrated with the reference group.
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Position for a Non-CNC System With an 

Indexible Probe

To teach an angle position for an indexible position:

 Select a group from the group drop-down list
 Select a probe tip from the probe tip drop-down list

 Set the tip to the straight-down position (A0.00-B0.00, this is the 
reference position) by clicking on that position on the cobweb of the 
Probe Selector window (example A0.00-B0.00), or by repeatedly 
clicking on the A+- and B+- buttons.
The system will prompt you to manually switch to this probe 
indexible position.

 Teach this indexible position by probing a qualification sphere

Select a group Select a tip
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complete the teach process

Once qualified, the position indicator will turn green.

Click the position on the cobweb (example A0.00-B0.00) or 
repeatedly click on the A+- and B+- buttons

Click the OK button to complete the teach process
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cobweb of the Probe Selector window (example A45.00-B45.00), 
or by repeatedly clicking on the A+- and B+- buttons
The system will prompt you to manually switch to this probe 
indexible position.

 Teach this indexible position by probing the qualification sphere that 
was used to qualify the reference position

 Once done probing the qualification sphere, click the OK button to 
complete the teach process

Once qualified, the position indicator will turn green.

Click the position on the cobweb (example A45.00-B45.00) or 
repeatedly click on the A+- and B+- buttons

Click the OK button to complete the teach process
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Programming

A circle fit algorithm can be set during auto programming to be used 
when a program is played back.

To set the fit algorithm:

 Select the features to be auto programmed from the feature list
 Click Tools >Programming>Auto Program… 

Select the features to be auto programmed from the feature 
list

Click Tools >Programming>Auto Program… 
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subgroup

 Click OK

Notice that the circles are measured using the selected fit type after 
playing back the program.

Select the desired fit type under the Circles group, Fit Type subgroup
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A laser pointer can be connected to the IK 5000 to be used as an input.

To configure the laser pointer:

 Click Tools>Options…

 Select the Supervisor tab and enter "Options" in the password field

Click Tools>Options…

Select the Supervisor tab and enter "Options" in the password field
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 Enable the LaserPointer option

 Click OK

The CNC option or the CcLight option must be selected for 
the LaserPointer option to be selectable.

Enable the LaserPointer option
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a toolbar.

To add the enable/disable LaserPointer button to a toolbar:

 Click Tools>Customize...
 Select the Supervisor tab and enter the supervisor password in the 
Password field

Click Tools>Customize... Select the Supervisor tab and enter the supervisor password in the Password field



IK 5000 QUADRA-CHEK 157

2
.1

 S
e

tu
p Select the Toolbars tab

 Select a toolbar in the Toolbars column
 Select LaserPointer in the All Possible Buttons column
 Click <- Copy to copy the button to the selected toolbar

 Click OK

Click <- Copy to copy the button to the selected toolbar
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already displayed

Notice the button in the Off state and On state when the button is 
toggled.

LaserPointer 
Off

LaserPointer 
On

The Laser Pointer uses the first lamp enable line output; 
connector N, pin 3, Lamp en 1.

The first lamp enable line is not available for use with light 
control while the LaserPointer option is active.

Refer to the installation instructions for the lamp enable 
connector pin assignments.
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A program can be recorded with a step to wait for an external input 
line. The input line can be high (1) or low (0).

To record this step into a program:

 Click Tools>Options...

 Enter the supervisor password in the Password field

The CNC software option is required in order to use the 
Wait For Input Line feature.

Click Tools>Options...

Enter the supervisor password in the Password field



160 2 Setup

2
.1

 S
e

tu
p  Select the Buttons tab

 Assign an external button input by selecting Use In Program from 
the drop-down menu and checking the level based checkbox

Button Connector Pin Assignment

Button 1 B1) I2) 15 Button 1
TTL in

Button 2 B1) I2) 6 Button 2
TTL in

Button 3 B1) I2) 24 Button 3
TTL in

Narrow 
footswitch 
button

A1) H2) 30 Foot switch 1

Wide 
footswitch 
button

A1) H2) 15 Footswitch 2

1) IK 5000 QUADRA-CHEK Installation Instructions (ID 1035034-9x)
2) IK 5000 QUADRA-CHEK Installation Instructions (ID 1108935-9x)

Select the Buttons tab, select Use In Program, and check  level based
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window and select CNC Mode Steps>Wait For Input Line

A new program step Wait for input line <button> at a state is 
added to the program.

Right-click in the program template window and 
select CNC Mode Steps>Wait For Input Line

When playing back the program, the program will wait 
until the state of <button> changes when the program 
step Wait for input line <button> at a state is 
encountered. A CNC option is required for this program 
step to be available.

A new program step Wait for input line <button> at a state is added to the program.
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A program variable can be set to be used in multiple programs. It can 
be set to be edited every time the program is run, only the first time 
the program is run, or only once. 

To set program variable options: 

 Record a program
 Right-click in the Program template and select Special Steps>Set 
Variable… to add a program variable  
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 Select the Result Type and Constant Type
 Check the Remember this variable across Runs and Parts (make 
it permanent) or Prompt on first run or both options to set the 
desired option for the variable

Select the options for the variable
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Groups/Cameras, and Tips/Magnifications

The IK 5000 can cross-calibrate between probe families (in a multi-
sensor system), different groups/cameras in a probe family, and 
various probe tips/magnifications within a group/camera.

Any probe family (in a multi-sensor system), group/camera (in a probe 
family), or probe tip/magnification (in a group/camera) can be assigned 
to be the reference.

A multi-sensor system with Video Edge Detection (VED) and Contact 
Probe family of probes is an example. The system may be configured 
with one camera (Camera_1) for VED with two magnifications (Mag_1 
and Mag_2), and two groups (Group_1 and Group_2) for Contact Probe 
with two probe tips each (Tip1_G1, Tip2_G1, Tip1_G2, Tip2_G2). Each 
level is automatically assigned a reference. This can be changed by 
going to the probe library and selecting a different item to be the 
reference.

Example: Change the Reference of a Probe Tip from Tip1_g1 to 
Tip2_g1

To change the reference of a probe tip:

 Click Probe>Probe Library…

 Select Contact Probe on the left side and double-click on Group_1 to 
show probe tips Tip1_G1 and Tip2_G1

Click Probe>Probe Library… Select Contact Probe on the left side and double-click on Group_1 to show probe 
tips Tip1_G1 and Tip2_G1
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reference probe for all probes within this group

 Click Proceed in the Change a Reference Family/Probe window

 Click OK in the Probe Library window to save the changes and exit 
the window

Select the Size/Ofs tab and check This is the reference probe for all probes 
within this group

Click Proceed
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To cross-calibrate between probe families:

 Click Probe>Probe Library…
The Probe Library window opens.

 Select Probes on the left  and then select ContactProbes on the right 
 Check Reference (other probe families are calibrated relative 
to this one)

At every level of the probe hierarchy, there must be a 
reference item. There must be a reference family, 
reference group/camera, and reference probe tip/
magnification.

Click Probe>Probe Library… Select Probes, then ContactProbes  and check Reference (other probe families 
are calibrated relative to this one)
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 Select Probes on the left side and then select Ved on the right side
 Select the Offset tab and Click Teach

 Follow the prompts until the cross-calibration is completed.
If the cross-calibration is successful, the system will insert values 
(most likely non-zero values) in the XYZ offset group box.

 Click OK in the Probe Library window to save the changes and exit 

Click Proceed

Select Probes, then Ved, Select the Offset tab and click Teach...
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Creating the Master User Profile

A supervisor can create an IK 5000 master user profile that can be 
loaded for different Windows OS users. When this master user profile 
is loaded, it gives the IK 5000 a uniform look as designed when the 
profile was saved.

The profile is saved to the IK 5000 folder located in the ProgramData 
system folder. 

To create the master user profile:

 Click Tools>Options...

 Select the Supervisor tab and enter the supervisor password in the 
Password field

 Check Keep privileges until program is exited
 Click OK to save the changes and exit the Options window

Click Tools>Options…

Select the Supervisor tab, enter the supervisor password, check Keep privileges until 
program is exited, and click OK



IK 5000 QUADRA-CHEK 169

2
.1

 S
e

tu
p Click Help>Master User Profile...>Save

A pop-up message is displayed indicating that a Master User Profile 
was saved.

 Click OK to close the message window

Loading the Master User Profile

To load the Master User Profile:

 Click Help>Master User Profile...>Load
A pop-up message is displayed indicating that loading the Master User 
Profile will shutdown the program.

 Click Yes

A pop-up message is displayed indicating that the Master User Profile 
was loaded successfully and the program will shutdown for the 
changes to take effect.

 Click OK

Click Help>Master User Profile...>Save Click OK

Click Yes

Click OK
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The Master User Profile can be loaded on startup for situations when 
a supervisor wants the user to always have the same profile at startup.

To enable Load master user profile at startup:

 Click Tools>Options...

 Select the Supervisor tab and enter the supervisor password in the 
Password field

Click Tools>Options…

Select the Supervisor tab and enter the supervisor password
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 Check Load master user profile at startup

 Click OK to save the changes and exit the Options window

 Select the Locks tab and check Load master user profile at startup



172 2 Setup

2
.1

 S
e

tu
p Setting Focus Offset

Focus Offset lets you move the focal point from the one found when 
performing autofocus.

For example, you may want to do this when a camera has an inbuilt 
delay in the posting of image frames. The target focal point will be off 
because of the delay. The distance that the focal point is off can be 
corrected by applying a focus offset.

An offset can be set for each magnification of each camera in the 
system.

To set a Focus Offset value:

 Determine the offset value that needs to be applied to the acquired 
focus point for a magnification

 Click Probe>Probe Library… 
 Select Ved, the desired camera, and the desired magnification

Click Probe>Probe Library… Select Ved, the desired camera, and the desired magnification
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Focus Offset field

 Click OK in the Probe Library window to save the changes and exit

Select the Auto Focus tab and enter the offset value
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Compensation) file

NLEC information is stored in a file in the system configuration folder. 

To load an NLEC file: 

 Replace the NLEC.txt file in the system configuration folder with the 
new NLEC file. The new file must be named NLEC.txt.

 Click Tools>Options…

An NLEC file must be created by an IK 5000 system or 
structured in the same format as an IK 5000 NLEC file.

Click Tools>Options…
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 Verify that the NLEC Enabled check-box is checked
 Click Load...

 Click Yes in the prompt to confirm loading

 Browse to the system configuration folder and select the new 
NLEC.txt file

 Click OK to save the changes and exit the Options window

Click Load...

Click Yes



176 2 Setup

2
.1

 S
e

tu
p 2D Profile Maximum Form Error

When a 2D profile feature has been measured, applying a tolerance 
can result in a failure if outlier data points are present.

The Maximum Form Error function can be used to filter outlier data 
points from tolerance test consideration.

To use Maximum Form Error and filter outlier data points:

 Start measuring a 2D profile feature

While in the Measure Profile screen: 

 Click Fit...

Click Fit...
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data points to be included in the tolerance pass/fail test in the 
Maximum Form Error field
Any data point that is greater in absolute value than the maximum 
form error value will be filtered from the overall set of points used in 
the fit of the profile.

 Enable/disable applicable fit options Allow X, Allow Y, Allow Z, and 
Allow A.

 Click OK in the Fit Settings window to save the changes, exit the 
dialog, and perform a fit calculation. Notice the results data on the 
upper left corner (if display data is enabled).

 Complete the 2D profile measurement

Enter the Maximum Form Error and click OK

Complete the measurement
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VED tools can be edited to change the size, number of scans, scan 
direction and edge type.

For tools with two sides—inner and outer or left and right—the size of 
each side can be changed independently using the Inner and Outer 
size change parameters.

For probes like the circle tool, the Inner size change applies to the 
inner circle and the Outer size change applies to the outer circle.

For probes like the buffer tool, the Inner size change affects the start 
of scan side and the Outer size change affects the end of scan side. 

Example: Recording a program with features measured using the 
circle VED tool

To edit VED tools in a program:

 Start recording a program using the VED circle tool

 Highlight the Select probe "Circle"… step in the program

The Inner size change cannot be applied if the change is 
going to make the inner side larger than the outer side.

The Outer size change cannot be applied if the change is 
going to make the outer side smaller than the inner side.

Highlight the Select probe "Circle"…
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Selected Steps…
 Enter the size percentage for the selected edge tool in the Inner and 
Outer fields

 Make any other neccessary changes to the parameters in the Edit 
Probe Steps window

 Click Apply to save the changes and then click Close to exit.
Note the changes on the tool—before and after.

Right-click on the program template and select Editing 
Steps>Edit Selected Steps…

Enter the Inner and Outer size percentage

Note the changes on the tool—before. Note the changes on the tool—after.
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Stake Marks

The Continuous Fire VED function uses stake marks to show where 
an edge has been found. The size of the stake marks can be set from 
1–30 pixels.

To change the stake mark size:

 Click Tools>Options…
 Select the Supervisor tab and enter the supervisor password in the 
Password field

 Select the VED tab
 Enter the desired pixel size in the Continuous fire stake marks 
size field. The value needs to be set from 1–30 pixels

Click Tools>Options… Select the Supervisor tab and enter the password

Select the VED tab and enter the Continuous fire stake marks size
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Note the changes on the tool—before and after

Enabling User Access to Settings

Most IK 5000 configuration settings are set by the OEM or a 
supervisor. A supervisor can allow the User to access User settable 
settings if the option is available for that parameter. The VedProbes in 
the Probe Library are an example of a User settable parameter.

To enable User settable settings:

 Check the User settable checkbox

Note the changes on the tool—before. Note the changes on the tool—after.

Check the User settable checkbox
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